You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Thursday, November 19th 2009, 2:37am

aktueller patch für eHD und vdr 1.7.9 + 1.7.10

da es jetzt einen fix für die replay probleme gibt (neuer hdplayer) steht dem umstieg nichts mehr im weg?

edit: derzeit wird bei ts-aufnahmen das bild nicht aktualisiert wenn man auf eine schnittmarke springt

edit2:
http://www.linuxtv.org/pipermail/vdr/200…ber/021654.html
"There is still a bug in VDR-1.7.9's I-frame detector which is
used to generate the index file. The index position is off by one
TS packet so that the first TS packet of the I-frame is missing
when VDR sends the still picture data to vdr-xine. Hence, the
image cannot be decoded, so you won't see a change on screen.

The bug is going to be fixed -- see [vdr] FF/RW problems with xine."

edit3: an dem problem mit den schnittmarken hat sich auch mit der 1.7.10 nichts geändert

der patch für einen vanilla vdr passt auf für die 1.7.10, beim patch für die ext-version muss man erst mal sehen ob der von der 1.7.9 passt und ob es eine version für 1.7.10 geben wird

im wesentlichen gilt das was im README.ehd für die 1.7.0 steht nur das ein patch mehr für xinemediaplayer nötig ist

da es keinen extension patch von zulu für die 1.7.9 gibt habe ich den von hier ohne den lirc speedup patch benutzt
http://www.vdrportal.de/board/thread.php…3611#post843611

es ist je ein patch für einen vanilla vdr und einer mit ext72, die für die plugins sind für beide szenarien


PS: die svn versionsnummer der patches stimmt nicht, das ist die version in der der quellcode des hdplayers geändert wurde, richtig wäre 13957 aber bei 13962 gab es eine änderung am dvdswitch plugin was eine kleine anpassung der anleitung nötig macht (-> README.ehd thread)
IG88 has attached the following files:

This post has been edited 9 times, last edit by "IG88" (Nov 22nd 2009, 6:06pm)


Posts: 6,250

Location: Main-Spessart

  • Send private message

2

Sunday, November 22nd 2009, 7:45pm

RE: aktueller patch für eHD und vdr 1.7.9 + 1.7.10

Quoted

Original von IG88
edit3: an dem problem mit den schnittmarken hat sich auch mit der 1.7.10 nichts geändert


Schon in der Mailinglist gemeldet?
VDR4Arch --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | Digital Devices Cine S2 V6 | ZOTAC GT630 (Rev. 2) Zone Edition

3

Sunday, November 22nd 2009, 8:15pm

RE: aktueller patch für eHD und vdr 1.7.9 + 1.7.10

nein
die lassen da nicht jeden rein?
habe nach dem abmelden meiner alten mailadresse zwei mal versucht drauf zu kommen ohne das was passierte, seitdem benüge ich mich mit dem mailarchiv

real_schorsch liest hier vermutlich eher mit als auf der ml, momentan scheint er der einzige zu sein der noch was macht, maniac (von dem der patch für die ehd stammt) ist auf vdpau gewechselt und sonst scheint keiner ahnung oder lust zu haben den sachen nachzugehen

Posts: 6,250

Location: Main-Spessart

  • Send private message

4

Sunday, November 22nd 2009, 9:53pm

Ich hab zwar die Mailinglistvon kls gemein, aber ok.

ich verstehe nicht, warum alle vdpau wollen. Ein Bekannter von mir hatte nur Probleme. Außerdem verbraucht die eHD nur ~10 Watt. Als ich das gelesen habe war es für mich klar

Soweit ich weis ist kls auch mehr in Richtung eHD interessiert
VDR4Arch --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | Digital Devices Cine S2 V6 | ZOTAC GT630 (Rev. 2) Zone Edition

5

Sunday, November 22nd 2009, 11:47pm

> Ich hab zwar die Mailinglistvon kls gemein, aber ok.

???, also ich rede hiervon http://www.linuxtv.org/pipermail/vdr/

und bezüglich des fehlers bei den ts recordings und den schnittmarken warten wir mal ab was die vdpau'ler sagen

> Soweit ich weis ist kls auch mehr in Richtung eHD interessiert

er hat auch eine aber vermutlich nicht in betirieb da es ihm zu nervig ist mit der ganzen installierer- und updaterei

helau

Sage

Posts: 5,213

Location: Northern Black Forest

  • Send private message

6

Monday, November 23rd 2009, 8:34am

Hi,

Die Patches gehen aber nicht gegen das aktuelle reel svn, oder uebersehe ich da was ?
Da gibts naemlich bereit ein /dev/fb_reel device ...
Gen2VDR / alcd / admin / yacoto - Features & Bugs - HW: Zotac Geforce 9300 MoBo / Cine-S2 im Activy Gehaeuse
und her mit den Logs :)
VDR-Portal Forenregelergänzung: Wer es wagt Anfragen eines Moderators zu ignorieren kann an den virtuellen Pranger gestellt werden.

7

Monday, November 23rd 2009, 12:10pm

> Die Patches gehen aber nicht gegen das aktuelle reel svn

bei mir schon (im rahmen dessen was in dem README.ehd steht), zumindest stand vom sonntag

> Da gibts naemlich bereit ein /dev/fb_reel device ...

wo genau tauchen probleme auf?

This post has been edited 1 times, last edit by "IG88" (Nov 23rd 2009, 12:11pm)


free-x

Intermediate

Posts: 391

Location: OWL

Occupation: Systemingenieur

  • Send private message

8

Monday, November 23rd 2009, 1:07pm

Hab heute umfassend upgedatet.
VDR-1.7.10 + vdr179-_rmm_svn13951_patch.diff.gz
Reelbox (rev 14016)+ reelbox-svn13951-setup-patch.diff.gz
Xinemediaplayer( rev 14016) + xinemediaplayer-svn13951-patch.diff.gz
Xine-Lib 1.1.11.1 neupaketiert mit patches von Reel.
Neueste hdplayer.
System Ubuntu 8.04 LTS. DVB Treiber aus S2-Liplianin
Mainboard Intel D945GCLF2
CPU Intel(R) Atom(TM) CPU 330 @ 1.60GHz
DVB Adapter: TeVii S650 USB
Funzt prächtig. Das einzige: crash beim Menu->Setup->Plugins->Reelbox->Picture
HD + SD kanäle 1a
AVI geht
Matroska 720p geht

Grossen DANK an IG88 für die aktuelle Patches
T90: 28.2E-19.2E-S13E-S9E-S4.8E-S4W
VDR#1: Ubuntu 8.04+VDR-1.7.15+S2API+eHD TeVii S650
VDR#2: Ubuntu 8.04+ArVDR 0.7 SS1 Rev.1.3
VDR#3: Ubuntu 10.04+VDR-1.7.18+S2API+VDPAU(GeForce 8400 GS)+xine-0.9.4 TT S2-3200
RuVDRWiki

helau

Sage

Posts: 5,213

Location: Northern Black Forest

  • Send private message

9

Monday, November 23rd 2009, 1:09pm

Quoted

> Da gibts naemlich bereit ein /dev/fb_reel device ...

wo genau tauchen probleme auf?


Im framebuffer patch wird /dev/fb0 auf /dev/fb1 geaendert.
Im SourceFile steht aber nicht fb0 sondern fb_reel
Gen2VDR / alcd / admin / yacoto - Features & Bugs - HW: Zotac Geforce 9300 MoBo / Cine-S2 im Activy Gehaeuse
und her mit den Logs :)
VDR-Portal Forenregelergänzung: Wer es wagt Anfragen eines Moderators zu ignorieren kann an den virtuellen Pranger gestellt werden.

Posts: 6,250

Location: Main-Spessart

  • Send private message

10

Monday, November 23rd 2009, 2:47pm

Quoted

Original von IG88
???, also ich rede hiervon http://www.linuxtv.org/pipermail/vdr/


Also ich benutze gmane dafür, soweit ich weis kann ich auch schreiben
VDR4Arch --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | Digital Devices Cine S2 V6 | ZOTAC GT630 (Rev. 2) Zone Edition

11

Monday, November 23rd 2009, 10:11pm

@helau

habe nochmal mit einem repo browser im testing und stable nachgesehen, in der HdFbTrueColorOsd.c steht /dev/fb0

> Im SourceFile steht aber nicht fb0 sondern fb_reel

stammt das vieleicht aus einem sourcepacket satt aus dem svn?

@free-x
> Funzt prächtig. Das einzige: crash beim Menu->Setup->Plugins->Reelbox->Picture

geht bei mir
was steht im log bzw. wenn du gdb benutzt

> HD + SD kanäle 1a

naja das schneiden von ts-aufnahmen ist eigentlich nicht möglich da man nicht sehen kann was man trifft und beim replay start von der schnittmarke springt vdr einige sekunden vorwärts ohne das man was sieht, nur wenn man beim replay auf den zeitindex sieht und die marke entsprechend setzt könnte man was schneiden (dann aber eher ungenau)

Stalker

Intermediate

Posts: 382

Location: Ulm

  • Send private message

12

Tuesday, November 24th 2009, 10:13am

Quoted

Originally posted by free-x
Funzt prächtig. Das einzige: crash beim Menu->Setup->Plugins->Reelbox->Picture

Das hatte ich auch einmal, Ursache war, dass die FB-Devices nicht zusammenpassten. Prüfe, welches FB-Device von der eHD angelegt wird, wenn sie bootet, und passe das Plugin gegebenfalls an. Außerdem muss es rw für VDR sein.

Posts: 6,250

Location: Main-Spessart

  • Send private message

13

Tuesday, November 24th 2009, 2:27pm

wie sieht es eigentlich aus, wenn man den kleinen Patch, den kls zur 1.7.10 nachgereicht hat draufpatcht.

Geht dann das Schneiden?
VDR4Arch --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | Digital Devices Cine S2 V6 | ZOTAC GT630 (Rev. 2) Zone Edition

14

Tuesday, November 24th 2009, 3:31pm

nein, der patch behebt nur das wenn ein neues index file einer bestehenden aufnahme erstellt wird (weil man das falsch erstellt der älteren vdr version gelöscht hat) der index auch für mehr als eine ts datei erstellt wird
hat also eigentlich nichts damit zu tun - habe aber trotzdem zur sicherheit nach dem patch nochmal eine neue aufnahme erzeugt und es getestet

This post has been edited 1 times, last edit by "IG88" (Nov 24th 2009, 3:32pm)


Posts: 6,250

Location: Main-Spessart

  • Send private message

15

Tuesday, November 24th 2009, 4:04pm

Bei mir hat sicher gerade beim Kompilieren des Kernelmoduls ein komischer Fehler aufgetreten.

Wenn ich "make x86" eingebe bleibt er deswegen hängen.

Quoted

aus der Datei hdshm.c
link ../../src/driver/hdshm.c


Wenn ich jetzt die Datei gegen die ../../driver/hdshm.c tausche klappt es perfekt.

Diese "Link"-Sache ist aber in ziemlich vielen Datein.
VDR4Arch --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | Digital Devices Cine S2 V6 | ZOTAC GT630 (Rev. 2) Zone Edition

16

Tuesday, November 24th 2009, 5:22pm

Was wird denn jetzt aus den Problem mit dem nicht funktionierenden Schneiden? Besteht da eine Chance, dass das noch gelöst wird?

Mal ne andere Frage: Warum baut Reel eigenglich den ganzen DVD-Kram via Patch in den VDR rein? IMHO wäre das aber in einem Plugin besser aufgehoben...

17

Tuesday, November 24th 2009, 5:54pm

> Was wird denn jetzt aus den Problem mit dem nicht funktionierenden Schneiden?
> Besteht da eine Chance, dass das noch gelöst wird?

hängt davon ab ob es an vdr oder dem reelbox plugin liegt
geht das auf vdpau systemen mit der 1.7.10? - vermutlich so das es am plugin liegen wird

- jemand von hier mit c++ kenntnissen nimmt sich der sache an
- wir warten und hoffen das real_schorsch sich der sache annimmt, das kann aber dauern da er diese sachen in seiner freizeit mach und auch mit dem netceiver zu gange ist (s2api, vdr plugin)

> Mal ne andere Frage: Warum baut Reel eigenglich den ganzen DVD-Kram via Patch
> in den VDR rein? IMHO wäre das aber in einem Plugin besser aufgehoben...

das dvd replay läuft über das xinemediaplayer plugin (zu xine) und da die ihren eigenen vdr stricken haben die eben auch eigene vorsstellungen wo etwas besser aufgehoben ist (oder schneller umzusetzen ist)
letztlich ist es so wie es jetzt ist ausreichen kompatibel zum aktuellen vdr, das man ein paar dateien in den vdr 1.7.x kopieren muss und nur das makefile anzupassen ist (mehr ist es punkto dvd imho nicht) finde ich nicht so schlimm, da wüßte ich dringenderes

btw. wäre die ausgabe für die (alten) ff-karten nicht besser in einem ausgabe plugin ausgehoben (wie bei dxr3 oder ...)? manchmal hat es auch einfach historische gründe und ein umbau lohnt nicht (die AVG hat ja auch einen vorläufer) - viel neuer code (fehler sind immer drin) und keine neue funktion

This post has been edited 1 times, last edit by "IG88" (Nov 24th 2009, 6:14pm)


Posts: 6,250

Location: Main-Spessart

  • Send private message

18

Saturday, November 28th 2009, 6:49pm

Hey, kann mir hier mal jemand helfen.

Hoffe das es so schneller geht, weil ihr ja dann eine Mail bekommt.
VDR4Arch --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | Digital Devices Cine S2 V6 | ZOTAC GT630 (Rev. 2) Zone Edition

Posts: 6,250

Location: Main-Spessart

  • Send private message

19

Monday, November 30th 2009, 2:14pm

Wie sieht denn bei euch das SDTV-Bild aus?

Ich bekomme bei Bewegungen immer ein Krieseln rein.

Zum Beispiel auf N24, sieht die untere Laufleiste "unmöglich" aus.


Gibts da zufällig irgendwelche Tricks?
VDR4Arch --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | Digital Devices Cine S2 V6 | ZOTAC GT630 (Rev. 2) Zone Edition

20

Monday, November 30th 2009, 4:29pm

> Gibts da zufällig irgendwelche Tricks?

umschalten

ich habe es häufiger das bei interlaced (576i) die reihenfolge der bilder vertauscht ist (vor allem nach dem start des systems), da ich die einstellung mediaresolution nutze, ein receiver mit hdmi dazwischen häng, der tv auch schuld sein könnte und sonst niemand das bemängelt (vor allem nicht auf der AVG) habe ich das bisher nicht weiter verfolgt

This post has been edited 2 times, last edit by "IG88" (Nov 30th 2009, 6:10pm)


Immortal Romance Spielautomat