You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Sunday, November 16th 2003, 10:39pm

linvdr 0.4...super! ...aber...

Hab gerade die 0.4 installiert.
Das setup hat sich *lob* erheblich verbessert. (extrem DAU-freundlich!)
Auch so sind die ausgewählten plugins mal wieder genau das was ich so brauche.

Leider funktioniert die Fernbedienung nicht so richtig...
Ich nutze den Empfänger meiner NEXUS 2.1 und die Universal FB von TCM.
Beides lief in kombination mit LINVDR 0.3 nach einigem einstellen tadellos.

Nun stehe ich vor dem Problem daß alle befehle der FB anscheinend mehrmals aufgerufen werden, als ob ich Remote Plugin UND "use internal IR=yes" gleichzeitig eingestellt hätte.

*Dem ist aber nicht so.*

Remote Plugin ist deaktiviert und "use internal IR = YES" ist in die sysconfig eingeschrieben.

Sobald ich mich an der konsole einlogge, scheint alles normal zu funktionieren.
Nur dann erscheinen bei jedem Tastendruck an der Fernbedienung alle möglichen Zeichen auf der Konsole.
Das is nich so toll

Bin leider nicht der hellste in sachen Linux, hab aber Grundkenntnisse.
Hat jemand ´ne Idee???

P.S. **Foren und Suche habe ich bereits durchsucht! Ich finde nichts auf dieses Problem zutreffendes!**
Alles ist wie immer...nur schlimmer...*mist* :-(


SMT 7020+120Gig-Hdd 2.5", DVD-Brenner an USB2 ----- NATÜRLICH mit GEN2VDR2!!! Echt der hammer!
In Arbeit: Sempron "Sparta" 64 LE1100+MSI K9MM-V+320Seagate HDD SATA, 512MB DDR-2, Case SuperFlower SF101BK

This post has been edited 1 times, last edit by "arneproft" (Nov 16th 2003, 11:07pm)


WilQu

Beginner

Posts: 3

Location: Pinneberg

Occupation: Angestellter

  • Send private message

2

Monday, November 17th 2003, 6:15pm

RE: linvdr 0.4...super! ...aber...

Habe leider auch dieses Problem und die Suchfunktion bringt leider nur Einträge für die alte Version. (Hat dort dann auch geklappt).

Was muss ich tun um die Nexus FB in der LinVdr 0.4 richtig zum laufen zu bringen?

Mit freundlichem Gruß
Wilfried

Posts: 4,478

Location: nahe Eschwege/Göttingen

Occupation: Linux-Redakteur

  • Send private message

3

Monday, November 17th 2003, 6:34pm

RE: linvdr 0.4...super! ...aber...

Servus Arne,

Quoted

**Foren und Suche habe ich bereits durchsucht! Ich finde nichts auf dieses Problem zutreffendes!**

Das glaube ich dir, das Problem ist nämlich in der Version 0.4 neu, es gibt erst einen anderen Thread dazu -- noch ungelöst.

Quoted

Sobald ich mich an der konsole einlogge, scheint alles normal zu funktionieren.
Nur dann erscheinen bei jedem Tastendruck an der Fernbedienung alle möglichen Zeichen auf der Konsole.

Das bringt mich auf eine Idee: Nach dem Start schaltet die Maschine ja automatisch auf Konsole 10, schalte doch -- noch bevor du die erste Taste auf der Fernbedienung drückst -- einfach auf die Konsole 1 (wo der grüne Fortschrittsbalken zu sehen ist), aber logg dich nicht ein.

Funktioniert dann die Fernbedienung einwandfrei? (Zeichen auf der ersten Konsole getrost ignorieren)

Wenn ja, haben wir in 10 Minuten einen Workaround!

Übrigens, weder Tom noch ich haben eine Nexus-FB in Betrieb, deshalb müssen wir so etwas komplett blind einbauen.

Viele Grüße, Mirko

WilQu

Beginner

Posts: 3

Location: Pinneberg

Occupation: Angestellter

  • Send private message

4

Monday, November 17th 2003, 6:50pm

RE: linvdr 0.4...super! ...aber...

Hallo,
ja nach Umschalten auf die Konsole 1 ist die Nexus FB ok.

Mit freundlichem Gruß
Wilfried

Posts: 4,478

Location: nahe Eschwege/Göttingen

Occupation: Linux-Redakteur

  • Send private message

5

Monday, November 17th 2003, 7:38pm

RE: linvdr 0.4...super! ...aber...

Quoted

ja nach Umschalten auf die Konsole 1 ist die Nexus FB ok.

Danke! Dann weiß ich, wo der Hase im Pfeffer liegt: Aus irgend einem Grund werden die Tasten vom Input-Plugin auf die aktuelle Konsole geschrieben, wo sie VDR brav als Tastaturkommandos einliest... und schon ist alles doppelt.

Und hier der Workaround: Öffnet die Datei /etc/init.d/runvdr und blättert etwa bis zum unteren Drittel. Dort findet ihr folgenden Block (oberhalb von "down)"):

Source code

1
2
3
sleep 5 && nice -n 19 vdradmind.pl &
umask 0002
$BINDIR/vdr -L $PLUGINDIR $PLUGINS -v /video0 -c $CONFDIR -w 900 -E /ramdisk/epg.data -s /usr/bin/poweroff.pl < /dev/tty$VDRTTY


Dort müsst ihr das Ende der letzte Zeile bis einschließlich des Kleinerzeichens löschen, so dass folgende Zeile übrig bleibt:

Source code

1
$BINDIR/vdr -L $PLUGINDIR $PLUGINS -v /video0 -c $CONFDIR -w 900 -E /ramdisk/epg.data -s /usr/bin/poweroff.pl


Nach Speichern der Datei und Neustart von LinVDR sollte der Spuk mit der Nexus-Fernbedienung ein Ende haben.

Viele Grüße, Mirko

WilQu

Beginner

Posts: 3

Location: Pinneberg

Occupation: Angestellter

  • Send private message

6

Monday, November 17th 2003, 7:48pm

RE: linvdr 0.4...super! ...aber...

Hallo Mirko,

Änderungen habe ich wie von Dir beschrieben gemacht. Jetzt funktioniert die Nexus FB.

Recht herzlichen Dank für die schnelle Hilfe.

Mit freundlichem Gruß
Wilfried

7

Monday, November 17th 2003, 9:42pm

Hallo,

die FB funktioniert zwar, aber auf die Konsole wird immer noch geschrieben.

Bye, Joe
VDR WakeUP Modul und AudioServer (Pyroplay)

UFO

Sage

Posts: 5,408

Location: Großherzogthum Baden

  • Send private message

8

Tuesday, November 18th 2003, 12:54am

Hi,

Quoted

Danke! Dann weiß ich, wo der Hase im Pfeffer liegt: Aus irgend einem Grund werden die Tasten vom Input-Plugin auf die aktuelle Konsole geschrieben, wo sie VDR brav als Tastaturkommandos einliest... und schon ist alles doppelt.


Die eigentliche Ursache ist der keybdev-Treiber im Kernel. Dieser Treiber holt sich alle Tasteneingaben, gleichgültig, ob sie von der FB oder der Tastatur kommen.
Das Problem tritt immer dann auf, wenn im Kernel "Input-core-support -> Keyboard-Support" aktiviert ist.

Diesen Treiber sollte man daher rauswerfen. Man braucht ihn jedoch, wenn man eine *USB*-Tastatur hat.
In diesem Fall hilft leider nur ein Kernel-Patch (kann ich bei Bedarf zur Verfügung stellen).

Gruß,
Oliver
VDR Remote Control Plugin (Version 0.7.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

Posts: 4,478

Location: nahe Eschwege/Göttingen

Occupation: Linux-Redakteur

  • Send private message

9

Tuesday, November 18th 2003, 1:20am

Servus Oliver,

Quoted


Die eigentliche Ursache ist der keybdev-Treiber im Kernel. Dieser Treiber holt sich alle Tasteneingaben, gleichgültig, ob sie von der FB oder der Tastatur kommen.
Das Problem tritt immer dann auf, wenn im Kernel "Input-core-support -> Keyboard-Support" aktiviert ist.

... dann hätten wir auch geklärt, warum das bei der 0.4 auftritt: Da ist nämlich USB-Keyboard-Support hinzu gekommen.

Quoted

Diesen Treiber sollte man daher rauswerfen. Man braucht ihn jedoch, wenn man eine *USB*-Tastatur hat.

Wir würden gern USB-Tastaturen weiterhin unterstützen.

Quoted

In diesem Fall hilft leider nur ein Kernel-Patch (kann ich bei Bedarf zur Verfügung stellen)


Schick ihn doch bitte mal an linvdr@linvdr.org, dann schauen wir mal, ob wir den noch schnell rein bekommen.

Viele Grüße, Mirko

UFO

Sage

Posts: 5,408

Location: Großherzogthum Baden

  • Send private message

10

Tuesday, November 18th 2003, 1:31am

Hi Mirko,

habe den Patch mal hierhin hochgeladen.
Ist evtl. auch für einige Leute nützlich, die ihren Kernel selbst kompilieren.

Einfach in /usr/src/linux/drivers/input/ ausführen.

Gruß,
Oliver
VDR Remote Control Plugin (Version 0.7.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

This post has been edited 1 times, last edit by "UFO" (Nov 18th 2003, 1:32am)


mottobug

Professional

Posts: 860

Location: Hessen / Kassel

Occupation: Codesklave

  • Send private message

11

Wednesday, November 19th 2003, 8:40am

Quoted

Original von UFO
Hi Mirko,

habe den Patch mal hierhin hochgeladen.
Ist evtl. auch für einige Leute nützlich, die ihren Kernel selbst kompilieren.


Da keybdev als Modul geladen wird, sollte es reichen nur die Datei keybdev.o neu einzuspielen. Ein gepatchtes Modul habe ich unter:

http://linvdr.org/download/linvdr/beta/0.4/keybdev.tar.gz

abgelegt. Bitte in / entpacken und die runvdr wieder auf den Originalzustand zurückversetzen.

Alternativ könnte es auch reichen wenn die beiden Einträge:

hid
keybdev

in der Datei /etc/modules auskommentiert werden. Das bitte auch austesten und feedback geben. Natürlich nur mit der Original runvdr und wenn kein USB Keyboard verwendet wird.

Tom.

12

Wednesday, November 19th 2003, 10:39am

Hallo Tom,

hatte das gleiche Problem, das die FB aufs Terminal geschrieben hatte. Hab Dein Update keybdev.o eingespielt . Jetzt funktioniert.
Danke !

Gruss

Hape

Chris HB

Beginner

Posts: 20

Location: Bremen

  • Send private message

13

Wednesday, November 19th 2003, 9:23pm

Hi Tom,
auch ich habe die keybdev.o eingespielt und seitdem keine Tasterdoppler ( "1" bleibt "1"). Allerdings werden die Tasten nach wie vor aufs Terminal geschrieben (muss ich wohl mit Leben, -> andere Konsole wählen.
Das Askommentieren in /etc/modules kann ich nicht nachvollziehen - kann so ein File nicht finden -> Suse 9.0 vdr 1.2.6

Tschüss Christian
Im Aufbau: SUSE 9.0, VDR 1.2.6, ASRock K7VM4, AMD Athlon 2700+, 1 GB RAM, Samsung SV1604N(160,0 GB), NEC 1300-A

14

Wednesday, November 19th 2003, 9:26pm

:wow Wundert mich aber das die für Debian (linvdr) kompilierte Version auch mit Deiner SuSi läuft....

Sachen gibbet


Michael

UFO

Sage

Posts: 5,408

Location: Großherzogthum Baden

  • Send private message

15

Thursday, November 20th 2003, 2:34am

Hi,

Quoted

Wundert mich aber das die für Debian (linvdr) kompilierte Version auch mit Deiner SuSi läuft....

Funktionioniert ja auch nicht. Vermutlich wird das gepatchte Modul nicht einmal gefunden, denn sonst wäre

Quoted

Allerdings werden die Tasten nach wie vor aufs Terminal geschrieben.

gar nicht mehr möglich. Genau dieses Problem wird doch durch den Patch beseitigt! :wand

CU
Oliver
VDR Remote Control Plugin (Version 0.7.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

This post has been edited 2 times, last edit by "UFO" (Nov 20th 2003, 2:46am)


16

Saturday, November 22nd 2003, 9:27am

RE: linvdr 0.4...super! ...aber...

@COOPER
@ALL

Danke für die schnellen Antworten ,hat alles bestens geklappt. :] :] :]
Ich kann erst jetzt alles durchlesen, da ich in der Woche auf Montage bin.
Alles ist wie immer...nur schlimmer...*mist* :-(


SMT 7020+120Gig-Hdd 2.5", DVD-Brenner an USB2 ----- NATÜRLICH mit GEN2VDR2!!! Echt der hammer!
In Arbeit: Sempron "Sparta" 64 LE1100+MSI K9MM-V+320Seagate HDD SATA, 512MB DDR-2, Case SuperFlower SF101BK

This post has been edited 1 times, last edit by "arneproft" (Nov 22nd 2003, 9:28am)


17

Tuesday, November 25th 2003, 10:43pm

RE: linvdr 0.4...super! ...aber...

Hallo,

nach dem ich die Datei keybdev.o ausgetaucht habe und noch in /etc/modules
hid
keybdev

auskommandiert habe, habr ich immer noch das gleiche Problem, daß die Taste doppelt ausgewertet wird (neustart habe ich gemacht).

Ich habe eine Nexus-s Rev.2.2


Gruß
matrix79

Thyor

Professional

Posts: 627

Location: NRW / Münsterland

  • Send private message

18

Saturday, November 29th 2003, 6:10pm

Probleme mit Nexus-FB bei LinVDR 0.4

Hallo,

beide beschriebenen Effekte (Doppeltes Signal und Signalausgabe auf Konsole) sind gestern bei einer neuen LinVDR-Installation mit Nexus-Fernbedienung Nexus-IR-Empfänger aufgetreten.

Mit dem Patch von Mottobug konnten wir die Ausgabe auf die Konsole beheben.
(Nebenbei: Das Laden der Datei per wget führte zu einem ungültigen Zip-Archiv! Einzelfall?)

Der Doppel-Empfang ging erst nach der Deaktivierung des Remote-Plugins unter Beibehaltung der Setup-Option 'IR-Empfänger benutzen' und reboot weg.
(Diesen Vorschlag gab es wohl schon zur 0.3er Version! Da hatte er mich aber noch nicht interessiert ;)
MfG
Thomas

yaVDR 0.5: MSI K9AG Neo2-Digital, Athlon X2 BE-2400, RAM: 4GB; HDMI: ZOTAC GT610; HDD: 3TB; DVB-S2: 2x TBS-6981 Doppel-Tuner; FB: Pollin X10
Streaming-Clients: S100 mit 2,5"-HDD unter Zendeb 0.3 von Egalus

UFO

Sage

Posts: 5,408

Location: Großherzogthum Baden

  • Send private message

19

Saturday, November 29th 2003, 7:26pm

RE: Probleme mit Nexus-FB bei LinVDR 0.4

Quoted

Original von Thyor
Der Doppel-Empfang ging erst nach der Deaktivierung des Remote-Plugins unter Beibehaltung der Setup-Option 'IR-Empfänger benutzen' und reboot weg.
(Diesen Vorschlag gab es wohl schon zur 0.3er Version! Da hatte er mich aber noch nicht interessiert ;)


Tja, da wurde wohl das Remote-Plugin zweimal geladen...

@Maintainers:
Vielleicht könnte man die Setup-Routine dahingehend optimieren, daß so etwas verhindert wird? Denn das scheint ein relativ beliebter Anfängerfehler zu sein.

CU
Oliver
VDR Remote Control Plugin (Version 0.7.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

geeg07

Professional

Posts: 596

Location: Austria

  • Send private message

20

Sunday, November 30th 2003, 1:00am

Hallo Tom!

Quoted


Alternativ könnte es auch reichen wenn die beiden Einträge:

hid
keybdev

in der Datei /etc/modules auskommentiert werden. Das bitte auch austesten und feedback geben. Natürlich nur mit der Original runvdr und wenn kein USB Keyboard verwendet wird.

Auch ich hatte Probleme mit der FB einer Nexus2.1. Habe folgendes jeweils mit Neustart durchgespielt

1. editieren runvdr -> Besserung aber immer noch Probleme
2. runvdr rücksetzen und keybdev.o in / kopieren -> wie 1.

Dann habe ich hid und keybdev auskommentiert. Nach dem Neustart funktionierte die Karte nicht mehr. Kein Bild/Ton aber EPG-Anzeige OK.
Beim shutdown wurden Fehlemeldungen bezüglich Zugriff auf COM... angezeigt. (Bin leider noch nicht sonderlich sattelfest und konnte daher eine evt. vorhandene Datei die diese Fehlermeldung enthält nicht auf die Schnelle ausfindig machen, sorry für die unzureichende Meldung)

Nun habe ich mit folgender Konstilation getestet

hid
#keybdef

Damit funktioniert alles (Tasten werden nur 1x verwendet, keine Ausgabe auf aktiver Console), /keybdev.o habe ich wieder entfernt.

lg, Gerry
VDR1: AMD Duron-1300, 512mb RAM, Nexus-S rev2.1, Airstar 2, Debian Lenny, kernel: 2.6.28-etobi.3, VDR 1.6.0-17 experimental/extensions von Tobi
VDR2: Athlon XP-M-2600+, 512mb RAM, TT Prem 1.3 DVB-S, Skystar2, Airstar 2, Debian Lenny, kernel: 2.6.28-etobi.3, VDR 1.6.0-17 experimental/extensions von Tobi
Extern: Activy300, Gen2VDR V2

This post has been edited 3 times, last edit by "geeg07" (Nov 30th 2003, 11:33am)


Immortal Romance Spielautomat