You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

UweHeinritz

Intermediate

  • "UweHeinritz" started this thread

Posts: 390

Location: Lengefeld

Occupation: Programmierer

  • Send private message

1

Monday, October 24th 2005, 7:40pm

Hilfe bei externremux

Hallo,

wollte gern mal versuchen mit dem VDR live zu konvertieren und das dann über's Netz zu streamen. Leider klappt das nicht.

Ich habe das hier in der /root/externremux.sh stehen:

Source code

1
2
3
rm -f /tmp/out.avi
/usr/bin/mkfifo /tmp/out.avi
cat /tmp/out.avi & /usr/bin/mencoder -ovc lavc -oac mp3lame -lavcopts vcodec=mpeg1video:vbitrate=1200:vhq:keyint=250 -o /tmp/out.avi -- - &>/tmp/out.log


Die wird scheinbar auch aufgerufen, da ich ein out.log erhalte und auch ein out.avi. Das avi ist aber immer leer und im MC wird es schwarz dargestellt.

In der Out.log steht folgendes:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
MEncoder 1.0pre7-3.3.5 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices  (Family: 8, Stepping: 0)
Detected cache-line size is 64 bytes
MMX2 supported but disabled
SSE2 supported but disabled
3DNow supported but disabled
3DNowExt supported but disabled
CPUflags: Type: 8 MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX SSE

File not found: 'frameno.avi'
Failed to open frameno.avi
Reading from stdin...
success: format: 0  data: 0x0 - 0x0
Cannot seek backward in linear streams!
Seek failed
Win32 LoadLibrary failed to load: avisynth.dll, /usr/lib/win32/avisynth.dll, /usr/local/lib/win32/avisynth.dll
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
Cannot seek backward in linear streams!
Seek failed
TS file format detected.
DEMUX OPEN, AUDIO_ID: -1, VIDEO_ID: -1, SUBTITLE_ID: -1,
Cannot seek backward in linear streams!
Seek failed
PROBING UP TO 2000000, PROG: 0
TS_PARSE: COULDN'T SYNC
VIDEO MPEG2(pid=511)AUDIO MPA(pid=512) NO SUBS (yet)!  PROGRAM N. 0
Opened TS demuxer, audio: 50(pid 512), video: 10000002(pid 511)...POS=28200
MPEG: FATAL: EOF while searching for sequence header.
Video: Cannot read properties.

Exiting...
Mache ich was falsch, fehlt noch was auf dem VDR?

Wäre schön wenn mir jemand dabei helfen könnte.

Tschau, Uwe.
Gigabyte GA-Z77-D3H; I3-3220; 4GB 1600MHz DDR3; Technotrend S2-4100 + Technotrend Budget + Nova-HD-S2;
passive geForce GT620 1GB; WD RED 2TB; LG DVD-DL Brenner; Debian Jessie mit VDR 2.2.0 + SoftHDDevice + KODI

This post has been edited 1 times, last edit by "UweHeinritz" (Oct 24th 2005, 7:41pm)


UweHeinritz

Intermediate

  • "UweHeinritz" started this thread

Posts: 390

Location: Lengefeld

Occupation: Programmierer

  • Send private message

2

Monday, October 24th 2005, 7:57pm

Hat sich erledigt,
es fehlte nur ein Enter nach dem "&" :rolleyes:

Tschau, Uwe.

PS: Fall das ein Mod liest kann er den Beitrag auch löschen
Gigabyte GA-Z77-D3H; I3-3220; 4GB 1600MHz DDR3; Technotrend S2-4100 + Technotrend Budget + Nova-HD-S2;
passive geForce GT620 1GB; WD RED 2TB; LG DVD-DL Brenner; Debian Jessie mit VDR 2.2.0 + SoftHDDevice + KODI

Immortal Romance Spielautomat