You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Wednesday, February 23rd 2005, 10:35pm

Update: DVB-Treiber & Repository

Hallo,

nach längerer Abstinenz habe ich endlich Zeit gehabt, aktuellere DVB-Treiber für ctvdr3 (Kernel 2.4.27) in ein Paket zu verwandeln. In einigen Threads wird über diese Treiber schon gesprochen - ich hatte sie einigen zum Probieren vorab gegeben - jetzt sind sie auch "offiziell" zu haben.

Näheres steht hier: http://www.heise.de/ct/ftp/projekte/vdr3…tml#dvbtreiber2

Die Kurzform:
- Firmware-Load für Premium-Karten via Hotplug (Firmware im Archiv ist C-Version)
- VHF-Fix für TechniSat AirStar2
- schnellere Umschaltzeichen bei Transponderwechsel bei alten Nova-Ts

Die Treiber liegen auch im testing-Ast der VDR-Repositories auf heise online. Wer die als Quelle eingetragen hat, kann mit apt-get installieren - von o.g. Seite ist aber auch ein manueller Download möglich (Installation dann mit dpkg -i). Die Treiber haben ein abweichenden Namen, um sie von offiziellen Debian-Treibern zu unterscheiden, werden also nicht automatisch bei einem apt-get upgrade gezogen.

Außerdem ist der testing-Zweig des Repository für ctvdr3 jetzt wieder auf einem halbwegs aktuellen Stand.

Peter

2

Wednesday, February 23rd 2005, 11:02pm

ah welcome back ;D

3

Friday, February 25th 2005, 4:59pm

RE: Update: DVB-Treiber & Repository

Hallo Peter,

toll dass es diese Treiber jetzt als Paket gibt. Seit ich Donnerstag früh den neuen Treiber und die d-Firmware aufgespielt habe, hatte ich keinen VDSB mehr. Ich hoffe das bleibt auch so :-))

Ciao
Holger
Debian Squeeze mit vdr 1.7.18 e-tobi/multipatch, Kernel 2.6.32-5-amd64, AMD Phenom-CPU, 4 GB RAM, Technotrend S2-6400, Digital Devices Cine S2 V6, 2 TByte HDD für Videodaten.

Franzose

Professional

Posts: 1,024

Location: Eching

Occupation: Globetrotter

  • Send private message

4

Friday, February 25th 2005, 10:54pm

SUPER!!!

Das ist genau das, wonach ich so verzweifelt gesucht habe....:tup

Danke! :applaus

MeinVDR

Silverstone Grandia GD04, schwarz, Gigabyte GA-H110M-HD3, Intel Celeron G3900T, Zotac GeForce GT 630, DD Octopus mini PCIe Bridge mit Dual DVB-S2 & DD MAX A8, yaVDR 0.61 :D

This post has been edited 1 times, last edit by "Franzose" (Feb 25th 2005, 11:14pm)


Aman

Intermediate

Posts: 422

Location: Peine

  • Send private message

5

Saturday, February 26th 2005, 7:31am

Hallo Peter,

Danke für die neuen Treiber :-)
Bin gerade dabei meinen 2ten vdr aufzubauen,
nach Installation von 3.07 (ging übrigens nur über jigdo's
CD-Update, auch ohne mplayer/mp3 gab's bei der Online-Installation Probleme) ...

Jedenfalls danach die neuen Treiber via apt-get aus dem Testing
installiert und die Avermedia 771 DVB-T lief ohne Probleme an :-)

Sobald ich die Treiber auf der andere Kiste installiet habe geb ich
Rückmeldung, wie die TT DVB-T/WinTV Nova-T (alte Rev.) läuft,
da werkeln zZ noch die 1.0.1'er ...


Gruß
Aman
USER: EX-Aman
seit kurzem produktiv: VDR SZ: Geh.: MS-Tech LC-02 / Asus M3N78-EM / DVB-S: 2xCTX929 / IR-Einschalter / nvidia-vdpau / USB-Boot... easyVDR 1.0
zZ noch produktiv VDR-WZ: Low-Budget -- Asus A7V133/1700+/Nova-S/GeForce 5500/4:3 Röhre - XBMC + easyVDR 0.8 ohne vdpau
zZ Testsystem: Digitainer-Gehäuse / Asus M3N78-EM / DVB-S: 2xNova-S / Medion X10 / nvidia-vdpau / USB-Boot... easyVDR 1.0
Bastelstatus: O2 Joggler - YaVDR
... Dockstar für Aufnahmen ...

pet547

Trainee

Posts: 98

Location: Köln

  • Send private message

6

Saturday, February 26th 2005, 8:34am

@psct

auch von mir vielen Dank für die neuen Treiber. Die Kombination DVB-C und DVB-T Karte (Nova-T, alte Rev.) funktioniert einwandfrei. Endlich sehe ich auch die DVB-T oberen UHF-Kanäle 65 und 66 (hier in Köln) und das mit schneller Umschaltzeit.

-
VDR Hardware: ASRock B75 Pro3-M, Intel Celeron G1610, CPU-Lüfter Scythe Shuriken Rev. B, 4GB Kingston Ram, 2x PCI Terratec Cinergy 1200 DVB-C, passive Zotac GeForce GT630, 1x Samsung F4 HD204UI * 2 TB, 10"-TFT-Display, Atric Rev.5
Eingabegerät: LIRC-Home-brew, Toshiba TV-Universal Remote
Software: yavdr64 0.5.0

This post has been edited 1 times, last edit by "pet547" (Feb 26th 2005, 8:44am)


7

Saturday, February 26th 2005, 2:04pm

Updates für die CD

Besten Dank auch von mir für Updates. :)

Wird es in absehbarer Zeit auch eine aktualisierte CD/jigdo-Datei für die netzwerklose Installation geben?

Franzose

Professional

Posts: 1,024

Location: Eching

Occupation: Globetrotter

  • Send private message

8

Sunday, February 27th 2005, 12:30am

Mal eine kurze Frage, da ich ein paar Probleme mit dem neuen Treiber festgestellt habe:

Meine Aufnahmen haben in erhöhtem Maße Blockartefaktbildung. Das betrifft nicht nur DVB-T, sondern auch DVB-C, wo ich bisher keinerlei Fehler feststellen konnte.

Da diese Fehler wirklich des Öfteren auftreten, frage ich mich, was wurde da verändert um das zu bewirken?

MeinVDR

Silverstone Grandia GD04, schwarz, Gigabyte GA-H110M-HD3, Intel Celeron G3900T, Zotac GeForce GT 630, DD Octopus mini PCIe Bridge mit Dual DVB-S2 & DD MAX A8, yaVDR 0.61 :D

kwacker

Intermediate

Posts: 304

Location: Herne

  • Send private message

9

Monday, February 28th 2005, 9:43pm

RE: Update: DVB-Treiber & Repository

Hallo,
hat hier jemand mit dem Treiber-Update eine Twinhan PCI VisionPlus DVB-T am laufen?

Leider immer noch vollkommen schlechter Signal-Pegel meist ca. um 30% und einige Sender hier in NRW sind nicht empfangbar z.b VIVA und TerraNova.

Das ist mittlerweile eigentlich noch das einzigste Manko, was mich am VDR stört:-)

Tschau, Karsten.
Mein VDR: LianLi-Gehäuse, AMD X2 64 5200+ auf Biostar TA690G, 768MB Ram, 250 GB HD, TT S3200, ne Airstar2 DVB-T und nen Touchpanel:-), Ubuntu Karmic , VDR 1.7.12 Extensionpatch mit x-vdr gebaut.

weidnerd

Trainee

Posts: 127

Location: Hahnbach/Oberpfalz

  • Send private message

10

Sunday, March 13th 2005, 1:39pm

261d wird nicht geladen

Servus!

Ich probiere jetzt schon Ewigkeiten rum, aber ich schaffe es nicht.
So sollte es funktieren:
- dvb-ttpci-01.fw-261d in /usr/lib/hotplug/firmware
- link von dvb-ttpci-01.fw auf diese Datei zeigen lassen.
- dvb-Module neu laden
dmseg zeigt aber unnachgibig 261c an.
/etc/init.d/horplug restart u.a. gibt dvb-ttpci und dvb-ttpci-budget-ci zurück
dvb-ttpci ist knapp 60kB groß, d.h. gemäß anderen Beiträgen, dass die Firmware wohl nicht einkompiliert ist.

Was mach ich falsch?

Daniel
Zalman HD160XT Plus - ASUS M4N78 Pro AM3 ATX, AMD Athlon II X2 215, 2GB RAM - Grafik: ASUS GT610-SL-2GD3-L - Digital Devices Cine S2 V6 DVB adapter (4*DVB-S2) - yaVDR 0.5

11

Sunday, March 13th 2005, 2:04pm

Quoted

dvb-ttpci-01.fw-261d in /usr/lib/hotplug/firmware
- link von dvb-ttpci-01.fw auf diese Datei zeigen lassen.


sollte nicht von dvb...261d ein link auf dvb-ttpci-01.fw zeigen ?
warum eigentlich link löscht doch die alte firmware nimm die neue und benenn
die um in dvb-ttpci-01.fw dann sollte doch in jedem fall die neue geladen werden.

marpiet

Professional

Posts: 610

Location: Oberpfalz

  • Send private message

12

Sunday, March 13th 2005, 5:25pm

RE: 261d wird nicht geladen

hi,

bei mir hats so geklappt:

mit:
/etc/init.d/vdr stop
/etc/init.d/vdrdevel stop
modprobe -r dvb
dpkg –i linuxtv-dvb-ct-modules-2.4.27-ctvdr-1_1.1.1+cvs-041202-3_i386.deb

installieren.

dann firmware ins verzeichnis /usr/lib/hotplug/firmware und neu
verlinken:

Im Hotplug-Verzeichnis /usr/lib/hotplug/firmware sollte eigentlich ein
Link dvb-ttpci-01.fw -> dvb-ttpci-01.fw.linuxtv-dvb-ct-modules zu
sehen sein. Den änderst du mit:
ln -sf dvb-ttpci-01.fw-261d dvb-ttpci-01.fw

gruß

marpiet



HDVDR: yavdr-0.6.0-stable: Intel G2120,Intel DH 77EB mit CIR, Co-Haus CIR, 64 GB SSD, 3 TB WD Red, Cine S2 V6.5 + Duoflex S2 an Centauri Multiswitch,
Zotac Nvidia GT 630
:prost2


13

Sunday, March 13th 2005, 7:17pm

RE: 261d wird nicht geladen

Einen schönen guten Abend!

Wo ist eigentlich der Unterschied zwischen den o.g. Treiber und den IVTV Treibern? Ist mir irgendwie noch ein Rätsel!

LG Squaregarden
Silverstone LC11 / Asus P4P800-VM / Celeron 2,53 / 512 MB / 2x250 1x160 GB / PVR350 rev. 991 / Technotrend 2.1 PE DVB-C / IR-Modul / Medion MD41169 / c't VDR: 1.4.3-1ctvdr3
Das Nebensächliche macht riesige Fortschritte. Wir entfernen uns immer weiter vom Wesentlichen.

Alien

Trainee

Posts: 101

Location: Berlin

  • Send private message

14

Sunday, March 13th 2005, 7:31pm

Hi,

sorry, aber hier geht es doch wohl um DVB Treiber. IVTV ist doch wohl meines Wissens für die Analog-Karten von Hauppauge gedacht. Und das ist doch ein erheblicher Unterschied. Äpfel und Birnen sozusagen.

Ciao,

Alien.
Hardware: FSC D1337, 1.6Ghz P4 Northwood, 512MB PC2100, 120GB Samsung SP1203, DVR-105, 2x Nova-T (alt), Eigenbau LIRC, Audigy 5.1fun

Software: ct'vdr4 kernel 2.4.31, TOBI-vdr-1.3.41 sarge/exp, dvb-1.0.1, softdevice+div. plugins

Gehäuse: Chieftec BE-01B-SL-B (Desktop)

15

Sunday, March 13th 2005, 7:54pm

Quoted

Original von Alien
Äpfel und Birnen sozusagen.


Hi Alien,

genau das war mir ja nicht klar! Also vielen Dank!

Hatte mal den Tip bekommen, daß man für das Installationsskript für den Mplayer von Tobi die neusten DVB Treiber installieren sollte.
Scheint sich dann vielleicht generell mit meiner PVR350 nicht zu verstehen, weil ich da halt ivtv treiber benutze...

Ich werde mich dann jetzt meinem Obstsalat widmen!

LG Squaregarden
Silverstone LC11 / Asus P4P800-VM / Celeron 2,53 / 512 MB / 2x250 1x160 GB / PVR350 rev. 991 / Technotrend 2.1 PE DVB-C / IR-Modul / Medion MD41169 / c't VDR: 1.4.3-1ctvdr3
Das Nebensächliche macht riesige Fortschritte. Wir entfernen uns immer weiter vom Wesentlichen.

weidnerd

Trainee

Posts: 127

Location: Hahnbach/Oberpfalz

  • Send private message

16

Monday, March 14th 2005, 3:17pm

RE: 261d wird nicht geladen

Genau so habe ich es doch gemacht!

Quoted

Original von marpiet
hi,

bei mir hats so geklappt:

mit:
/etc/init.d/vdr stop
/etc/init.d/vdrdevel stop
modprobe -r dvb
dpkg –i linuxtv-dvb-ct-modules-2.4.27-ctvdr-1_1.1.1+cvs-041202-3_i386.deb

installieren.

dann firmware ins verzeichnis /usr/lib/hotplug/firmware und neu
verlinken:

Im Hotplug-Verzeichnis /usr/lib/hotplug/firmware sollte eigentlich ein
Link dvb-ttpci-01.fw -> dvb-ttpci-01.fw.linuxtv-dvb-ct-modules zu
sehen sein. Den änderst du mit:
ln -sf dvb-ttpci-01.fw-261d dvb-ttpci-01.fw

gruß

marpiet
Aber es wird nicht die richtige FW geladen!
Kann es sein, dass hotplug irgendwie falsch konfiguriert ist? Wie wären da die richtigen Einstellungen? Was macht die Blacklist?
Gruß
Daniel
Zalman HD160XT Plus - ASUS M4N78 Pro AM3 ATX, AMD Athlon II X2 215, 2GB RAM - Grafik: ASUS GT610-SL-2GD3-L - Digital Devices Cine S2 V6 DVB adapter (4*DVB-S2) - yaVDR 0.5

ajo

Beginner

Posts: 26

Location: Elsass

  • Send private message

17

Wednesday, March 16th 2005, 8:11pm

Hallo,

ich habe zwei FF-Karten. Es wird aber bei der Treiberinstallation nur eine Karte erkannt.

lspci ergibt:
0000:00:08.0 ffff: Philips Semiconductors SAA7146 (rev ff)
0000:00:0b.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)

im vdr wird aber nur eine Karte eingebunden.


Gruß Axel
c´t-vdr 7IX4E mit Duron 800, 512 MB Ram, 250GB Hd, 2 x TT 1.5 )
2CV for ever

PeterD

Master

Posts: 1,769

Location: Hessen

Occupation: Elektronikingenieur

  • Send private message

18

Wednesday, March 16th 2005, 8:54pm

@ajo

Ich hab ähnliche probleme mit FF+budget.
Ich hab schon mal letzten Sonntag experimentiert.
Es scheint an der reihenfolge zu liegen wie die modules.conf die treiber läd.
Wenn ich nicht modprobe benutze sondern die für die budget nötigen treiber händisch (insmod) lade und dann erst den rest für die FF mit modprobe nachlade gehen beide karten.

Versuch doch mal die treiber zu entladen und dann schritt für schritt per insmod wieder zu laden, o du unterschiede feststellst.

Da fällt mir noch die trivialvariante bei dir ein: hast du identische FF oder unterschiedliche revisionen. Vielleicht sinds dann nur unterschiedliche tuner.

gruss Peter
Mein anderer VDR ist (auch) ein EPIA
1)VIA M10000-Nehemiah, 160+120G Samsung; NEC 1300A; YY A106; LCD20x4 ...
2) ctvdr+e-tobi ; C3M266+1,2GHz-Nehmiah; 160G Samsung + 4x500G Seagate SATA; NEC3500; TT-Case; DVB-S 1.3+4MB + Nova ; gLCD 240x128 ...

. . .TB rulez. . .

ajo

Beginner

Posts: 26

Location: Elsass

  • Send private message

19

Thursday, March 17th 2005, 7:17am

Hallo Peterd,

das war anscheinend ein IRQ-Problem. Karte in einen anderen Slot und sie wurde erkannt.

Gruß Axel
c´t-vdr 7IX4E mit Duron 800, 512 MB Ram, 250GB Hd, 2 x TT 1.5 )
2CV for ever

Frissi

Trainee

Posts: 102

Location: nähe Frankfurt

  • Send private message

20

Friday, March 18th 2005, 8:07pm

Hilfe, treiber werden nach Update nicht mehr geladen!

Ich hab gestern versucht das Update zu machen.
Vorgegangen bin ich wie folgt beschrieben:

Quoted

Original von marpiet
mit:
/etc/init.d/vdr stop
/etc/init.d/vdrdevel stop
modprobe -r dvb
dpkg –i linuxtv-dvb-ct-modules-2.4.27-ctvdr-1_1.1.1+cvs-041202-3_i386.deb

installieren.

dann firmware ins verzeichnis /usr/lib/hotplug/firmware und neu
verlinken:

Im Hotplug-Verzeichnis /usr/lib/hotplug/firmware sollte eigentlich ein
Link dvb-ttpci-01.fw -> dvb-ttpci-01.fw.linuxtv-dvb-ct-modules zu
sehen sein. Den änderst du mit:
ln -sf dvb-ttpci-01.fw-261d dvb-ttpci-01.fw


Danach, weil die neuen Treiber nicht geladen wurden, habe ich diese wieder mit dpkg -r entfernt.

Über apt-get wollte ich zurück auf die alten Treiber, aber es kommen die gleichen Fehlermeldungen wie nach dem Update:


dmesg _______________________________________________________________________

Mar 18 19:51:58 vdr kernel: i2c-core.o: i2c core module version 2.6.1 (20010830)
Mar 18 19:51:58 vdr kernel: i2c-algo-bit.o: i2c bit algorithm module
Mar 18 19:51:58 vdr kernel: bttv: driver version 0.9.15 loaded
Mar 18 19:51:58 vdr kernel: bttv: using 8 buffers with 2080k (520 pages) each for capture
Mar 18 19:51:58 vdr kernel: Linux video capture interface: v1.00
Mar 18 19:51:58 vdr kernel: i2c-core.o: i2c core module version 2.6.1 (20010830)
Mar 18 19:51:58 vdr kernel: i2c-algo-bit.o: i2c bit algorithm module
Mar 18 19:51:58 vdr kernel: bttv: driver version 0.9.15 loaded
Mar 18 19:51:58 vdr kernel: bttv: using 8 buffers with 2080k (520 pages) each for capture
Mar 18 19:51:58 vdr kernel: Linux video capture interface: v1.00
Mar 18 19:51:58 vdr kernel: i2c-core.o: i2c core module version 2.6.1 (20010830)
Mar 18 19:51:58 vdr kernel: i2c-algo-bit.o: i2c bit algorithm module
Mar 18 19:51:58 vdr kernel: bttv: driver version 0.9.15 loaded
Mar 18 19:51:58 vdr kernel: bttv: using 8 buffers with 2080k (520 pages) each for capture
Mar 18 19:51:58 vdr kernel: Linux video capture interface: v1.00
Mar 18 19:51:58 vdr kernel: i2c-core.o: i2c core module version 2.6.1 (20010830)
Mar 18 19:51:58 vdr kernel: i2c-algo-bit.o: i2c bit algorithm module
Mar 18 19:51:58 vdr kernel: bttv: driver version 0.9.15 loaded
Mar 18 19:51:58 vdr kernel: bttv: using 8 buffers with 2080k (520 pages) each for capture
Mar 18 19:51:58 vdr kernel: Linux video capture interface: v1.00
Mar 18 19:51:58 vdr kernel: i2c-core.o: i2c core module version 2.6.1 (20010830)
Mar 18 19:51:58 vdr kernel: i2c-algo-bit.o: i2c bit algorithm module
Mar 18 19:51:58 vdr kernel: bttv: driver version 0.9.15 loaded
Mar 18 19:51:58 vdr kernel: bttv: using 8 buffers with 2080k (520 pages) each for capture
Mar 18 19:51:58 vdr kernel: Linux video capture interface: v1.00
Mar 18 19:51:58 vdr kernel: i2c-core.o: i2c core module version 2.6.1 (20010830)
Mar 18 19:51:58 vdr kernel: i2c-algo-bit.o: i2c bit algorithm module
Mar 18 19:51:58 vdr kernel: bttv: driver version 0.9.15 loaded
Mar 18 19:51:58 vdr kernel: bttv: using 8 buffers with 2080k (520 pages) each for capture
Mar 18 19:51:58 vdr insmod: /lib/modules/2.4.27-ctvdr-1/kernel/drivers/media/video/bttv.o: init_module: No such device
Mar 18 19:51:58 vdr insmod: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. You may find more information in syslog or the output from dmesg
Mar 18 19:51:58 vdr insmod: /lib/modules/2.4.27-ctvdr-1/kernel/drivers/media/video/bttv.o: init_module: No such device
Mar 18 19:51:58 vdr insmod: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. You may find more information in syslog or the output from dmesg
Mar 18 19:51:58 vdr insmod: /lib/modules/2.4.27-ctvdr-1/kernel/drivers/media/video/bttv.o: init_module: No such device
Mar 18 19:51:58 vdr insmod: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. You may find more information in syslog or the output from dmesg
Mar 18 19:51:58 vdr insmod: /lib/modules/2.4.27-ctvdr-1/kernel/drivers/media/video/bttv.o: init_module: No such device
Mar 18 19:51:58 vdr insmod: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. You may find more information in syslog or the output from dmesg
Mar 18 19:51:58 vdr insmod: /lib/modules/2.4.27-ctvdr-1/kernel/drivers/media/video/bttv.o: init_module: No such device
Mar 18 19:51:58 vdr insmod: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. You may find more information in syslog or the output from dmesg
Mar 18 19:51:58 vdr insmod: /lib/modules/2.4.27-ctvdr-1/kernel/drivers/media/video/bttv.o: init_module: No such device
Mar 18 19:51:58 vdr insmod: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. You may find more information in syslog or the output from dmesg
Mar 18 19:51:58 vdr insmod: /lib/modules/2.4.27-ctvdr-1/kernel/drivers/media/video/bttv.o: insmod dvb-bt8xx failed
Mar 18 19:51:58 vdr vdr[1706]: no DVB device found
________________________________________________________________________________

Woran könnte das liegen?
Die IRQ´s würde ich ausschliessen, an der Konfiguration hat sich sonst ja ni geändert!
Gruß
Frissi
--------------------------------------------------------------------------------------------------
[SIZE=7]
HD VDR Client: yavdr 0.3a - ASRock ION 330HT, TT-3600, SDCMegtron LCD
[/SIZE]
[SIZE=7]VDR Server: ct'VDR (vdr 1.6.x) - ASUS Pundit ID3, Celeron 2.0 GHz; 256 MB RAM; 2TB WD20EVDS; TT FF Rev. 1.5; TT Budget Rev 1.1[/SIZE]

Immortal Romance Spielautomat