You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Monday, November 22nd 2004, 11:31am

Soundblaster Live & ct vdr 3

Hallo!

Ich versuche gerade meine Soundblaster Live! 5.1 mit der c't VDR 3 zum laufen zu bekommen. dabei habe folgendes Problem:


Laut lspci habe ich ein eum10k1:
0000:00:00.0 Host bridge: Intel Corp. 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
0000:00:01.0 PCI bridge: Intel Corp. 82865G/PE/P PCI to AGP Controller (rev 02)
0000:00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #1 (rev 02)
0000:00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #2 (rev 02)
0000:00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #3 (rev 02)
0000:00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #4 (rev 02)
0000:00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev c2)
0000:00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Bridge (rev 02)
0000:00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) Ultra ATA 100 Storage Controller (rev 02)
0000:00:1f.3 SMBus: Intel Corp. 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
0000:01:00.0 VGA compatible controller: nVidia Corporation NV35 [GeForce FX 5900XT] (rev a1)
0000:02:03.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 46)
0000:02:0a.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
0000:02:0c.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 0a)
0000:02:0c.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 0a)
0000:02:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8029(AS)

Mittels "apt-get install alsa" habe ich alsa installiert.

Bei "modprobe emu10k1" habe keine Fehlermeldung und der Ton kommt über die beiden Lautsprecher.

Bei "insmod emu10k1" hagelt es jedoch Fehlermeldungen das benötigte Module nich gefunden werden konten.

alsaconf, alsamixer, alsactl, amixer finden keine Soundkarte.

Was mache ich falsch?

Gruß

Norbert

Mein vdr

SilverStone Milo ML03 schwarz, ASRock H67M-GE/HT, Zotac GT 630 Rev.2, Intel Pentium G630T, DD Cine S2 V6.2, yavdr 0.6, Onkyo 508, LG55LA6608, Unicable

seti

Trainee

Posts: 119

Location: Karlsruhe

Occupation: studi

  • Send private message

2

Monday, November 22nd 2004, 11:54am

insmod erfüllt nicht automatisch die dependencies von deinem Modul, wohingegen modprobe ein higer-level Skript ist was insmod aufruft und darauf achtet dass alle benötigten Module auch geladen sind und das wenn nötig nachholt. Du hast also nix falsch gemacht! Wenn modprobe zu dem gewünschten resultat führt ist ja alles i.O.
Ausgaben der Treiber kannst du übrigens durch aufrufen von "dmesg" sehen!

Gruß,

seti
AsRock K7VM2, Duron 600, 512MB SDRam, TT DVB-S 1.3, WLAN 54Mbit, Compact Flash 256MB mit CF2IDE Adapter
Reichelt LCD 128x64, DVD-Rom, Wakü und TBE Ext. Board!:D
Gehäuse in Arbeit...(Ende in Sicht!)

3

Monday, November 22nd 2004, 3:35pm

Hallo seti,

beibt nur noch das Problem das alsaconf, alsamixer, alsactl, amixer keine Soundkarte finden.

Gruß

Norbert

Mein vdr

SilverStone Milo ML03 schwarz, ASRock H67M-GE/HT, Zotac GT 630 Rev.2, Intel Pentium G630T, DD Cine S2 V6.2, yavdr 0.6, Onkyo 508, LG55LA6608, Unicable

HOSTess

Professional

Posts: 704

Location: Autokennzeichen L

  • Send private message

4

Monday, November 22nd 2004, 3:52pm

Ich vermute mal...

... Du hast (noch) nicht "modconf" zum Einrichten benutzt ?
sondern nur apt-get alsa. Da weiß alsa noch nicht, welches Modul drunter zu steuern ist.

Im modconf unter Multimedia? ->emu10k1->soundblaster Deine Karte aktivieren
(Inwiefern jetzt noch Teile oder der ganze Rechner neu gestartet werden müssen....)

-----------------------------------------------------------------------------------------------
ansonsten evtl
dpkg reconfigure alsa (oder so ähnlich, bin away from linuxmachine und weiß
gerade nicht, wo ein evtl. Optionsstrich hinkommt).


Mike

5

Monday, November 22nd 2004, 4:24pm

Hallo!

So geht es:

mount /dev/cdrom
apt-get install alsa-base
apt-get install alsa-modules-2.4.27-ctvdr-1

/etc/modules erweitern
#Soundblaster Live!
snd-emu10k1
snd-pcm-oss

alsamixer
alsaconf
alsactl store

Jetzt brauch ich den Fernseher nicht mehr :-)

Gruß

Norbert

Mein vdr

SilverStone Milo ML03 schwarz, ASRock H67M-GE/HT, Zotac GT 630 Rev.2, Intel Pentium G630T, DD Cine S2 V6.2, yavdr 0.6, Onkyo 508, LG55LA6608, Unicable

maxkr

Professional

Posts: 690

Location: Putzbrunn bei München

  • Send private message

6

Wednesday, January 19th 2005, 10:49pm

[c't-VDR3]: ALSA+Bitstreamout > kein DD

Hi,

endlich habe ich den Umstieg auf c't-VDR 3.06 (nach Vollsicherung der Boot-Partition mit Knoppix/Partimage gewagt).

Soweit funktioniert nun eigentlich alles nur der DolbyDigital-Ton will mit Bitstreamout nicht so recht mit meiner SB Live, die optisch mit dem Reciver verbunden ist:
Nur ein Knacksen bzw. Rauschen ist zu hören. Der Receiver schaltet nicht mehr auf DolbyDigital um sondern bleibt auf PCM z.B. auf ZDF. "PCM-Sender" wie ARD funktionieren einwandfrei...

Allerdings vermute ich eher, dass es an den Mixer-Einstellungen liegt:

Vor c't-VDR 3.06 habe ich mit folgenden Mixereinstellungen (vollständig siehe: http://www.vdrportal.de/board/thread.php?threadid=413&sid=) gearbeitet:

PCM:

Source code

1
2
3
4
amixer -q -c 0 sset 'Surround Digital' 50%,50% capture
amixer -q -c 0 sset 'IEC958 Optical Raw' 0%,0% mute
amixer -q -c 0 sset 'IEC958 TTL' 100%,100%
amixer -q -c 0 sset 'Capture' 80%,80% unmute,captureamixer -q -c 0 


AC3:

Source code

1
2
3
amixer -q -c 0 sset 'Surround Digital' 0%,0% capture
amixer -q -c 0 sset 'IEC958 Optical Raw' 0%,0% unmute
amixer -q -c 0 sset 'Capture' 0%,0% unmute,capture


Außerdem lässt sich 'IEC958 Optical Raw' mit dem alsamixer nicht mehr einstellen, was vorher glaube ich ging - also vielleicht doch noch mal die Sicherung einspielen?
In der aktuellen Mixer-Version scheint es auch 'Surround Digital' nicht mehr zu geben. Evt. auch eine Ursache...

Vielleicht habt ihr einen Tipp für mich wie der Mixer konfiguriert werden muss um wieder in den Genuss von Dolby Digital zu kommen...

Viele Grüße,
Max

VDRClient [MLD] auf RaspberryPi mit LIRC+IR-Einschalter (mit Arduino Pro Mini)
Amazon FTV 2 [Kodi 15.x] als VDR-Streaming-Client
Headless VDR [Ubuntu 14.04LTS mit VDR 2.2.0] mit Digital Devices Octopus mit 2x DVB-S2 DuoFlex-Karten

maxkr

Professional

Posts: 690

Location: Putzbrunn bei München

  • Send private message

7

Thursday, January 20th 2005, 9:45am

RE: [c't-VDR3]: ALSA+Bitstreamout > kein DD

Hi,

über einen Thread hier im VDRPortal bin ich auf die Seite http://alsa.opensrc.org/index.php?page=emu10k1 aufmerksam geworden.

Daraufhin habe die /etc/modutils/alsa-base um folgende Zeile erweitert:

Source code

1
options snd-emu10k1 extin="0x3fff" extout="0x1fff"


da meine Karte eigentlich alle Ein-/ und Ausgänge besitzen müsste...

...nur leider ohne Erfolg: 'Surround Digital' fehlt nach wie vor!


Viele Grüße,
Max

VDRClient [MLD] auf RaspberryPi mit LIRC+IR-Einschalter (mit Arduino Pro Mini)
Amazon FTV 2 [Kodi 15.x] als VDR-Streaming-Client
Headless VDR [Ubuntu 14.04LTS mit VDR 2.2.0] mit Digital Devices Octopus mit 2x DVB-S2 DuoFlex-Karten

maxkr

Professional

Posts: 690

Location: Putzbrunn bei München

  • Send private message

8

Thursday, January 20th 2005, 9:49pm

RE: [c't-VDR3]: ALSA+Bitstreamout > kein DD

Hi,

jetzt habe ich ein Fallback auf die c't-VDR 2 gemacht und muss jetzt aber zu meinem erstaunen feststellen, dass es auch hier kein 'Surround Digital' (mehr) gibt.

Nur hier funktioniert DD einwandfrei. Allerdings scheinen bei DD die Mixereinstellungen per alsamixer völlig egal zu sein: Ich habe immer Ton - allerdings lässt sich hierüber 'IEC958 Optical Raw' nicht deaktivieren...

Werde jetzt mal die Settings aus amixer überprüfen...


[Nachtrag] Ergebnis:

amixer controls:
bei PCM:

Source code

1
2
3
4
5
Simple mixer control 'IEC958 Optical Raw',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Front Left: Playback [off]
  Front Right: Playback [off]


bzw. bei AC3:

Source code

1
2
3
4
5
Simple mixer control 'IEC958 Optical Raw',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Front Left: Playback [on]
  Front Right: Playback [on]


amixer contents:
bei PCM:

Source code

1
2
3
4
5
6
7
8
9
10
11
numid=35,iface=MIXER,name='IEC958 Optical Raw Playback Switch'
  ; type=BOOLEAN,access=rw---,values=2
  : values=off,off

numid=177,iface=MIXER,name='IEC958 Playback Default'
  ; type=IEC958,access=rw---,values=1
  : values=?

numid=181,iface=MIXER,name='SB Live Analog/Digital Output Jack'
  ; type=BOOLEAN,access=rw---,values=1
  : values=on


bzw. bei AC3:

Source code

1
2
3
4
5
6
7
8
9
10
11
numid=35,iface=MIXER,name='IEC958 Optical Raw Playback Switch'
  ; type=BOOLEAN,access=rw--l,values=2
  : values=on,on

numid=177,iface=MIXER,name='IEC958 Playback Default'
  ; type=IEC958,access=rw--l,values=1
  : values=?

numid=181,iface=MIXER,name='SB Live Analog/Digital Output Jack'
  ; type=BOOLEAN,access=rw--l,values=1
  : values=on


Viele Grüße,
Max

VDRClient [MLD] auf RaspberryPi mit LIRC+IR-Einschalter (mit Arduino Pro Mini)
Amazon FTV 2 [Kodi 15.x] als VDR-Streaming-Client
Headless VDR [Ubuntu 14.04LTS mit VDR 2.2.0] mit Digital Devices Octopus mit 2x DVB-S2 DuoFlex-Karten

This post has been edited 1 times, last edit by "maxkr" (Jan 20th 2005, 10:16pm)


rfehr

Intermediate

Posts: 283

Location: NRW

  • Send private message

9

Tuesday, January 25th 2005, 9:21pm

Funktioniert wunder bar
1x OctopusNet mit 2x DVB-S2 u. 2x DVB-C
1x intel E7 als Server mit 4 DVB Karten(Sat/Kabel) MLD 4.0.1-64bit
1x Zotac ITX-A Atom 330 als Client MLD 5.0.0-64bit
1x Raspberry als Client MLD 5.0.0
3x VIP1710 als Client
1x Cubietruck, das neue Spielzeug MLD 5.0.0
1x BananaPi MLD 5.0.0
1x WetekPlay MLD 5.0.0

maxkr

Professional

Posts: 690

Location: Putzbrunn bei München

  • Send private message

10

Thursday, February 10th 2005, 2:41pm

Hi rfehr,

bei dir geht es also?! Mit Bitstreamout?!

Ich kann nicht mal die Settings verstellen. Bekomme nur eine Fehlermeldung! Sezte seit geraumer Zeit deshalb wieder die 2er Version ein...

Viele Grüße,
Max

VDRClient [MLD] auf RaspberryPi mit LIRC+IR-Einschalter (mit Arduino Pro Mini)
Amazon FTV 2 [Kodi 15.x] als VDR-Streaming-Client
Headless VDR [Ubuntu 14.04LTS mit VDR 2.2.0] mit Digital Devices Octopus mit 2x DVB-S2 DuoFlex-Karten

Immortal Romance Spielautomat