You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

61

Tuesday, December 7th 2010, 1:34pm

Quoted

Original von Steve135

Quoted

Original von Uwe
Ich habe das schon verstanden. Aber warum muss ich den parameter angeben, um mit femon zugriff auf beide Tuner zu haben? Macht doch kein Sinn!

Weil meines Wissens nach die bisherigen Femon-Versionen nicht (korrekt) mit multiplen-Frontends umgehen konnten/können. Möglicherweise ist mein Wissen diesbezüglich aber auch schon überholt... Ich lasse mich da gern eines Besseren belehren.


Das sollte klappen. Habe hier eine hauppauge dvb-t 500 dual tuner karte, damit kann ich in femon mit den tasten links und rechts beide tuner auswählen.
Bei der Cine S2 klappt dies aber nicht. Hier gibt nur das 1. Device messwerte aus ... Schaltet man auf das 2. Device wird nix angezeigt ... Ich meine es ist ein Fehler im Treiber!?

mein VDR Stuff... :)

Thermaltake DH101: M2N68 Plus - 1 x HD-FF-6400 - 1 x L4MV6.2
angeschlossen über (SCR Inverto Black Unicable Multiswitch UST111-CUO10-8PP an Selfsat DQ)
yavdr-0.5 - vdr-2.2.0 - Plugins: dvbhddevice - targavfd - skinnopacity - osdteletext - xmltv2vdr
Neu: RaspberryPi2 mit rpihddevice Plugin (git) + sat2ip (an GSSBox) sowie USB-S2 DVB Empfänger (DVB-SKY)

62

Tuesday, December 7th 2010, 9:08pm

Quoted

Original von Uwe

Quoted

Original von Steve135

Quoted

Original von Uwe
Ich habe das schon verstanden. Aber warum muss ich den parameter angeben, um mit femon zugriff auf beide Tuner zu haben? Macht doch kein Sinn!

Weil meines Wissens nach die bisherigen Femon-Versionen nicht (korrekt) mit multiplen-Frontends umgehen konnten/können. Möglicherweise ist mein Wissen diesbezüglich aber auch schon überholt... Ich lasse mich da gern eines Besseren belehren.


Das sollte klappen. Habe hier eine hauppauge dvb-t 500 dual tuner karte, damit kann ich in femon mit den tasten links und rechts beide tuner auswählen.
Bei der Cine S2 klappt dies aber nicht. Hier gibt nur das 1. Device messwerte aus ... Schaltet man auf das 2. Device wird nix angezeigt ... Ich meine es ist ein Fehler im Treiber!?


Moin Uwe,

was hast du denn für eine Femon-Version am Laufen?

Welcher Skin vom Femon-Plugin ist eingestellt?

Link

Mal auf den Link klicken und ein bisschen auf der Seite lesen, voar allem das hier:

...
Notes:

- The plugin supports only those DVB cards with _one_ frontend, because I
haven't yet figured howto do it without patching the VDR core.
...

Gruß
Wolfgang
Hardware: -
Software: -

63

Wednesday, December 8th 2010, 9:10pm

Hi,

ich hab ja mit der Cine S2 ebenfalls das CI Problem und UFO war so nett mir hier einen Patch für die dvb-apps zur Verfügung zu stellen, der beim CA Testen hilft.

Der Patch leitet den gesamten Datenstrom des getunten Transponder ungefiltert weiter. D.h. wenn ich ORF1 HD tune hab ich einen TS mit ORF1 HD, ORF2 HD und Servus TV HD (alles vom gleichen Tuner natürlich). Die ORFs bleiben zwar dunkel bei mir, da das CI nicht tut, aber der verschlüsselte stream wird vollständig mitgeschrieben.

Interessante Feststellung: Der Servus TV HD ist dann immer stark beschädigt, extrem viele Artefakte. Zeichne ich Servus TV HD "normal" - also nur die PIDs aus dessem PMT auf -> keine (mir) sichtbaren Fehler (ffmpeg nörgelt aber).

Will sagen: Ich kann das Problem auch mit einem Tuner reproduzieren. Meine Vermutung ist, das es nichts mit dem 2 Tuner Betrieb zu tun hat sondern mit der Größe des Gesamtdatenstroms der da über den Bus gejagt wird.

Wäre nett wenn einer der anderen betroffen Cine S2 Besitzer das mal auf seinem System verifizieren könnte!

LG

Steve135

Professional

  • "Steve135" started this thread

Posts: 642

Location: Thüringen

  • Send private message

64

Thursday, December 9th 2010, 8:26am

Quoted

Original von digibert
Will sagen: Ich kann das Problem auch mit einem Tuner reproduzieren. Meine Vermutung ist, das es nichts mit dem 2 Tuner Betrieb zu tun hat sondern mit der Größe des Gesamtdatenstroms der da über den Bus gejagt wird.

Moin,
so unmöglich scheint das nicht! Auch ich habe die Erfahrung gemacht, dass ich bei zwei oder mehr zeitgleichen Aufnahmen auf einem Transponder manchmal 'Aussetzer' bei einer der Aufnahmen hatte und das, obwohl ich den zweiten Tuner der Karte derzeit nicht nutze. Ich dachte aber bisher, dass es vielleicht an einem Darstellungsproblem der eHD liegen würde. Die dabei im Datenstrom erzeugten Probleme/Fehler sind aber auf jeden Fall nicht so groß, dass daraus vom VDR ein VDSB-Error erzeugt wird, der mit dem Emergency Exit endet... Während des parallelen Betrieb mit beiden Tunern erfolgt schon bei zwei zeitgleichen Aufnahmen auf unterschiedlichen Transpondern nach einiger Zeit ein VDSB-Error.

Gruss Steve135

Steve135

Professional

  • "Steve135" started this thread

Posts: 642

Location: Thüringen

  • Send private message

65

Saturday, December 11th 2010, 3:48pm

So, habe jetzt mal so meine syslog-files durchsucht und meine bisherige Freude über die nun auf einen Tuner 'kastrierte', funktionierende Cine-S2 ist schnell verflogen. Laut den Log-Files lässt sich nachvollziehen, dass die VDSB-Errors auch bei der Benutzung nur eines Tuners auftreten. Es passiert also auch, sobald mehr als eine Aufnahme auf dem selben Transponder ausgeführt wird. So etwas hatte ja schon digibert vermutet. Erstaunlicherweise passiert das aber nicht immer. Da ich jetzt erstmal den Kanal voll habe mit dem 'Funktions-Lotto', fliegt die Karte bei nächster Gelegenheit raus!!! Ich habe mir jetzt erst mal eine TBS-6981 bestellt. Hoffentlich habe ich damit jetzt nicht wieder "in's Braune" gegriffen. Aber wbreu und F_L haben ja bereits gepostet, dass sie bei ihnen problemlos funktioniert. Wenn in einer fernen Zeit UFO doch noch einen Bugfix finden sollte, kann ich es mit dem Teil ja vielleicht nochmal versuchen... Bis dahin wird sie wohl erst mal im Karton enden.

Gruss Steve135

UFO

Sage

Posts: 5,408

Location: Großherzogthum Baden

  • Send private message

66

Sunday, December 12th 2010, 8:13pm

Hi,

ich denke, der Fehler ist behoben. :alki

Bitte folgenden Patch testen: http://linuxtv.org/hg/~endriss/ngene-tes…ev/9a42d7ae0693
bzw. einfach ngene-test2 neu auschecken...

CU
Oliver
VDR Remote Control Plugin (Version 0.7.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

This post has been edited 1 times, last edit by "UFO" (Dec 13th 2010, 3:44am)


Steve135

Professional

  • "Steve135" started this thread

Posts: 642

Location: Thüringen

  • Send private message

67

Monday, December 13th 2010, 8:29am

Quoted

Original von UFO
Hi,

ich denke, der Fehler ist behoben. :alki

Bitte folgenden Patch testen: http://linuxtv.org/hg/~endriss/ngene-tes…ev/9a42d7ae0693
bzw. einfach ngene-test2 neu auschecken...

CU
Oliver


Danke UFO!!! Was ein einfaches 'if' alles so ausmachen kann. :]
Sollte ich mir jetzt etwa doch noch die 120,-€ für die neue TBS-6981 sparen können!? Werde es heute Abend gleich mal ausprobieren! Erklärt/Löst der Fix auch die Probleme, wenn die VDSB-Errors auch schon auf nur einem Tuner kommen?

Danke, Gruss Steve135

68

Monday, December 13th 2010, 10:58am

gelöscht: nicht relevant

Meine VDRs

VDR Server: Ubuntu Lucid Lynx mit 6TB im RAID und quadtuner DVB-S2
VDR Client1: Raspbian @ Raspberry Pi 2
VDR Client2: Ubuntu @ Laptop
VDR Client3: MDL @ Raspberry Pi
VDR Client4: zen2vdr @ SMT-7020s (wird zZ nicht benutzt)
VDR Client5: Android @ HP Touchpad mit VDR Manager App

This post has been edited 1 times, last edit by "decembersoul" (Dec 13th 2010, 11:06am)


69

Monday, December 13th 2010, 1:47pm

Hi Oliver

Quoted

Original von UFO
ich denke, der Fehler ist behoben. :alki


Super, vielen Dank, für Deine Arbeit an den Treibern!

Ich habe den Treiber gestern Abend noch installiert und dann über Nacht für ca. 10 Stunden HD von zwei verschiedenen Transpondern aufgezeichnet und hatte dabei nicht einen VDSB.

Lässt sich eigentlich - nach dem Verständnis, das Du jetzt über den Fehler entwickelt hast - erklären, warum das Fehlverhalten bei manchen zu VDSB, bei mindestens Dir zu beschädigten Aufnahmen und bei anderen vermeindlich zu überhaupt keinen Fehlern geführt hat?

Vielen Dank nochmals,
Alex

Meine VDRs

seca: Server, Intel DH87RL + i5-4570S, 32GB RAM, 1x 2TB WD black, 2x 4TB WD red, 2x CineS2 Rev. 5.5
core: Client/Entwicklung, Intel DH87RL + i5-4570, 32GB RAM, Samsung SSD 830 Series 240GB, Asus GT610-SL-2GD3-L Silent
liro: Client, Asus P8H77-M, Intel i3-2120T, 4GB RAM, Asus GT610-SL-2GD3-L, Lian Li C37B Silent, IOWarrior24
bero: Client, Asus EeeBox PC EB1012U, IOWarrior24
Alle: Kernel 3.x.y, Gentoo Linux
Server: vdr-2.2.0 vanilla, streamdev, epgsearch, epg2vdr, scraper2vdr, live
Clients: vdr-2.2.0-extp, streamdev, epgsearch, epg2vdr, scraper2vdr, softhddevice, skindesigner, extrecmenu, remotetimers, mailbox, fritzbox

This post has been edited 1 times, last edit by "Alex" (Dec 13th 2010, 1:49pm)


70

Monday, December 13th 2010, 7:06pm

Quoted

Original von UFO
ich denke, der Fehler ist behoben. :alki


Hi Oliver,

ich hab auch den neuen Treiber installiert. Ich hab mal zum testen 15min ARD HD, ZDF HD und Servus TV HD gleichzeitig aufgenommen. Sieht gut aus! War vorher nicht möglich.

LG

franky93128

Intermediate

Posts: 244

Location: Regensburg

Occupation: Dipl.Ing.

  • Send private message

71

Tuesday, December 14th 2010, 12:35am

Quoted

Original von UFO
Hi,

ich denke, der Fehler ist behoben. :alki

Bitte folgenden Patch testen: http://linuxtv.org/hg/~endriss/ngene-tes…ev/9a42d7ae0693
bzw. einfach ngene-test2 neu auschecken...

CU
Oliver


Hallo Oliver,

ich hab auf drei VDRs mit unterschiedlicher DVB-HW (CineS2 V5.4, V5.5 und DuoFlexS2) den Treiber auf den aktuellen Stand upgedatet.

Parallele HD-Aufnahmen (ServusTV und ZDF) sind jetzt auf allen drei VDRs OK.
Hab auch parallele Aufnahmen über mehr als 2 Stunden laufen lassen.
Alles OK. Keine Auffälligkeiten (wie VDSB) im log.

Super, dass Du das Problem lösen konntest. :)

Gruß
Klaus
Einige HD-VDRs mit VDPAU-GPU und Gen2VDR V4 Release
3x Asus AT3IONT-I Deluxe, 3xCineS2V5.5 davon eine mit DuoFlexS2
2x ZotacION-G-E, 1xDuoFlexS2 miniPCIe; 1xMystique SaTix Dual
1x Zotac-ION-T, TeVii 480
1x Zotac D2550 Wifi Supreme, CineS2 V6.2
2x Shuttle XS35GTV2 (ION2), 1x Streamin-Client und 1x mit Sundtek S2 Stick
3x AMD AM1 mit Athlon 5350 oder 5150, CineS2 bzw. Streamdev-Clinet

Steve135

Professional

  • "Steve135" started this thread

Posts: 642

Location: Thüringen

  • Send private message

72

Tuesday, December 14th 2010, 8:52am

:moin

auch von mir nochmal vielen Dank!!! :tup :tup :tup

Alle meine bisherigen Tests verliefen positiv. Habe gestern Abend mal verschiedene parallele Aufnahmen durchgeführt und es gab keine Fehler/VDSB. Werde es mal im Auge behalten, aber bisher sieht es sehr, sehr gut aus!

Gruss Steve135

P.S: Dann geht die neue TBS-6981 wohl jetzt zurück. ...und ich hatte das Paket noch nicht mal aufgemacht... :]

UFO

Sage

Posts: 5,408

Location: Großherzogthum Baden

  • Send private message

73

Tuesday, December 14th 2010, 1:39pm

Quoted

Original von Alex
Lässt sich eigentlich - nach dem Verständnis, das Du jetzt über den Fehler entwickelt hast - erklären, warum das Fehlverhalten bei manchen zu VDSB, bei mindestens Dir zu beschädigten Aufnahmen und bei anderen vermeindlich zu überhaupt keinen Fehlern geführt hat?

Der stv0900 ist ein ziemlich komplexer Chip, in dem die Daten beider Kanäle verarbeitet werden müssen.
Was da genau passiert, könnte wohl nur ein Ingenieur von ST erklären.

Bei mir trat der Fehler zyklisch beim gleichzeitigen Empfang zweier verschiedener DVB-S2 Transponder auf, d.h. nach einer gewissen Zeit fehlerfreien Empfangs tritt ein Fehlerburst auf, dann wieder fehlerfreier Empfang usw.

Wahrscheinlich hängt die Ausgeprägtheit des Fehlers von der Signalqualität ab. (Ich habe ein gutes Signal.)
Daneben spielt auch die Spannungsversorgung eine Rolle.

Alle möglichen Störkomponenten überlagern sich und führen dann eben zu einem mehr oder weniger ausgeprägten Fehlerbild.

Gefunden habe ich die Lösung nur dadurch, daß ich die Registereinstellungen so lange an die des Windows-Treibers angeglichen habe, bis der Fehler weg war. Leider hat sich als Ursache eine Registereinstellung herausgestellt, die ich als unkritisch eingestuft hatte und daher auch erst ganz am Schluß getestet habe...

CU
Oliver
VDR Remote Control Plugin (Version 0.7.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

74

Tuesday, December 14th 2010, 3:18pm

Herzlichen Glückwunsch,hast es echt drauf. :grinzs :respekt
Hardware
TBS-6981(rennt perfekt)
ASUS AT3IONT-I Mini-ITX
DDR3 4GB Kingston ValueRAM
Samsung EcoGreen F2 1TB
LG DH16NS schwarz Bulk
Pollin X10

Software
yaVDR 0.4pre1 alle Updates

75

Tuesday, December 14th 2010, 3:21pm

Könnte mir jemand eventuell die "richtigen" Treiber und firmware bereitstellen?

Habe nämlich auch eine Cine S2 Karte (2 Tuner). Danke!
OS: Debian GNU/Linux wheezy 3.2.0-4-amd64
SW: 2.0.3-1~etobi1 (vor upgrade vdr 1.7.21-1~ctvdr1)
MB: POV/330 mit nVidia Corporation ION VGA
DVB: Digital Devices Cine S2 - Duale DVB-S2 HDTV

Posts: 8,599

Location: Schwabenländle

Occupation: Bootmanager

  • Send private message

76

Tuesday, December 14th 2010, 6:37pm

Quoted

Original von Duff11
Könnte mir jemand eventuell die "richtigen" Treiber und firmware bereitstellen?

Habe nämlich auch eine Cine S2 Karte (2 Tuner). Danke!


Hier: http://linuxtv.org/hg/~endriss/ngene-test2

Herunterladen mit:

Source code

1
hg clone  http://linuxtv.org/hg/~endriss/ngene-test2


fw18 wird automatisch mit heruntergeladen. ;)

77

Tuesday, December 14th 2010, 7:48pm

Danke. Muss ich danach dann wieder ein ./configure, make und make install ausführen?
OS: Debian GNU/Linux wheezy 3.2.0-4-amd64
SW: 2.0.3-1~etobi1 (vor upgrade vdr 1.7.21-1~ctvdr1)
MB: POV/330 mit nVidia Corporation ION VGA
DVB: Digital Devices Cine S2 - Duale DVB-S2 HDTV

Steve135

Professional

  • "Steve135" started this thread

Posts: 642

Location: Thüringen

  • Send private message

78

Wednesday, December 15th 2010, 8:23am

Quoted

Original von Duff11
Danke. Muss ich danach dann wieder ein ./configure, make und make install ausführen?


:moin

...das hatte ich Dir hier doch schon mal beschrieben! :lehrer1

http://www.vdr-portal.de/board/thread.ph…1432#post961432

Musst hald nochmal etwas kreativ die Quelle für das HG-Clone anpassen (und sofern sie nicht automatisch geladen, wird die fw_18 von der richtigen Adresse runterladen)...

Gruss Steve135

79

Wednesday, December 15th 2010, 8:34am

Danke, habe es hinbekommen.

Was bedeutet eigentlich die option mit one_adapter=0?
Das ich mehrere habe, sprich in meinem Fall zwei?

-- Modul-Options erzeugen
echo "options ngene one_adapter=0" > /etc/modprobe.d/dvb.conf
OS: Debian GNU/Linux wheezy 3.2.0-4-amd64
SW: 2.0.3-1~etobi1 (vor upgrade vdr 1.7.21-1~ctvdr1)
MB: POV/330 mit nVidia Corporation ION VGA
DVB: Digital Devices Cine S2 - Duale DVB-S2 HDTV

Steve135

Professional

  • "Steve135" started this thread

Posts: 642

Location: Thüringen

  • Send private message

80

Wednesday, December 15th 2010, 9:05am

one_adapter=0 bedeutet, das für jeden Tuner der DVB-S-Karte ein eigenes Frontend angelegt wird. Das ist oft hilfreich, wenn die Plugins (z:Bsp. femon) nicht korrekt mit dem (neuen) Doppeltuner-Frontend umgehen können. Es bringt m.W. auf jeden Fall nach keinen Nachteil, diese 'Compatibility-Option' zu benutzen!

Gruss Steve135

Immortal Romance Spielautomat