You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

961

Thursday, June 11th 2009, 1:42pm

Hallo carel,

danke für den Tipp. Damit habe ich zwar keine *Play PES Buffer overflow errors* mehr aber laufen tuts trotzdem nicht.



Hab jetzt auch noch das lokale Frontend von xineliboutput getestet, aber das bleibt auch sofort hängen:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
Jun 11 13:27:21 hdvdr vdr: [805] cVideoRepacker: switching to MPEG1/2 mode
Jun 11 13:27:21 hdvdr vdr: [805] cVideoRepacker: operating in MPEG1/2 mode
Jun 11 13:27:21 hdvdr vdr: [805] [xine..put] Detected video size 720x576
Jun 11 13:27:22 hdvdr vdr: [788] channel 1 (Das Erste) event Don 11.06.2009 13:00-14:00 (VPS: 11.06 13:00) 'ARD-Mittagsmagazin' status 4
Jun 11 13:27:24 hdvdr vdr: [805] clearing device because of consecutive poll timeouts
Jun 11 13:27:25 hdvdr vdr: [806] buffer usage: 70% (tid=805)
Jun 11 13:27:25 hdvdr vdr: [806] buffer usage: 80% (tid=805)
Jun 11 13:27:25 hdvdr vdr: [806] buffer usage: 90% (tid=805)
Jun 11 13:27:26 hdvdr vdr: [806] buffer usage: 100% (tid=805)
Jun 11 13:27:26 hdvdr vdr: [806] ERROR: 1 ring buffer overflow (177 bytes dropped)
Jun 11 13:27:32 hdvdr vdr: [806] ERROR: 27767 ring buffer overflows (5220196 bytes dropped)
Jun 11 13:27:38 hdvdr vdr: [806] ERROR: 27767 ring buffer overflows (5220196 bytes dropped)
Jun 11 13:27:40 hdvdr vdr: [800] EPGSearch: timer conflict check started
Jun 11 13:27:40 hdvdr vdr: [800] EPGSearch: timer conflict check finished
Jun 11 13:27:41 hdvdr vdr: [799] EPGSearch: search timer update started
Jun 11 13:27:41 hdvdr vdr: [799] EPGSearch: search timer update finished
Jun 11 13:27:44 hdvdr vdr: [806] ERROR: 26444 ring buffer overflows (4971472 bytes dropped)
Jun 11 13:27:50 hdvdr vdr: [806] ERROR: 29679 ring buffer overflows (5579652 bytes dropped)
Jun 11 13:27:56 hdvdr vdr: [806] ERROR: 31851 ring buffer overflows (5987988 bytes dropped)
....


Schon merkwürdig, ich habe seit Mitte Februar fast jede verfügbare Revision von xine-vdpau getestet. Solche massiven Probleme hatte ich noch nie..........

Gruß, tomas

carel

Intermediate

Posts: 436

Location: Niederlande

Occupation: Satelliet und ICT

  • Send private message

962

Thursday, June 11th 2009, 2:08pm

Strange

Wann du vdr-sxfe auf einer console startest (zuerst "export DISPLAY=:0.0" typen) gibt's dan etwas hilfreichere meldungen ?

Ich hab z.b:

Source code

1
vdr-sxfe --video=vdpau --fullscreen  --audio=alsa --nokbd --post tvtime:method=use_vo_driver xvdr+rtp://127.0.0.1


Carel
Intel E7400, Ubuntu Server x86_64 12.04, Nvidia GF9400, nvidia 295.40, vdr-1.7.27+ext patch, xine-lib-git + df patches, xineliboutput-git :portal1

963

Thursday, June 11th 2009, 2:16pm

Servus,

ich habe gestern meine beiden VDR's mit der r264 versorgt.

Vorgehen wie immer:

- xine-vdpau komplett neu geholt

- den alten xine-plugin-Ordner gelöscht

- xine-vdpau und xineliboutput neugebaut und installt

Ergebnis löppt, sogar bisher ohne jeglichen Hänger!!!

Soweit ich das sehe ist da jetzt Anpassungsbedarf am Patch von durchflieger, da da die neuen Deinterlacer-Stufen mit v6-Patch nicht greifen (zumindest sagt das log das => verworfene Frames erhöhen sich extrem, ohne Patch laufen die neuen Stufen!?)

Nach wievor läuft bob am Besten auf dem AMD-System.

@tomas, bau noch mal neu und schau ob im xine-Plugins-Ordner alles das heutige Datum hat.

Gruß
Wolfgang
Hardware: -
Software: -

carel

Intermediate

Posts: 436

Location: Niederlande

Occupation: Satelliet und ICT

  • Send private message

964

Thursday, June 11th 2009, 2:26pm

@Wolfgang

Hast du ein idee warum es überhaupt PES overflow fehler gibt (auch mit vdr-1.7.7 und xineliboutput-cvs) ?

Ich hab als de-interlacer temporal-spatial und nen GF9400, ist das wohl zu langsam zusammen? GPU ist 74 grad.

Ich möchte gerne method "pipe" benutzen weil damit das Music plugin läuft...

Danke,

carel
Intel E7400, Ubuntu Server x86_64 12.04, Nvidia GF9400, nvidia 295.40, vdr-1.7.27+ext patch, xine-lib-git + df patches, xineliboutput-git :portal1

965

Thursday, June 11th 2009, 2:34pm

Quoted

Original von carel
@Wolfgang

Hast du ein idee warum es überhaupt PES overflow fehler gibt (auch mit vdr-1.7.7 und xineliboutput-cvs) ?

Ich hab als de-interlacer temporal-spatial und nen GF9400, ist das wohl zu langsam zusammen? GPU ist 74 grad.

Ich möchte gerne method "pipe" benutzen weil damit das Music plugin läuft...

Danke,

carel


Hi carel,

naja die 9400er ist zu langsam für temporal_spatial, teste doch mal bob als deinterlacer. Siehe hier, ab Seite 4:

http://www.nvnews.net/vbulletin/showthre…t=133465&page=1

Ne 9500er sollte damit gut zurechtkommen.

Music-Plugin läuft sauber, allerdings nutze ich nur das lokale Frontend => siehe Wiki.

vdr-1.7.7 und xineliboutput-cvs, habe ich noch nicht getestet, da hier etliche Plugins die gerne habe nicht laufen.

Gruß
Wolfgang
Hardware: -
Software: -

carel

Intermediate

Posts: 436

Location: Niederlande

Occupation: Satelliet und ICT

  • Send private message

966

Thursday, June 11th 2009, 2:50pm

Und ich mal denken das 9400 reicht..., vielen dank für der link, das macht alles klar...

Ich hab bevor auch lokales frontend (--local=sxfe) benutzt aber damit hab ich dass, mit eingeschaltenes Livebuffer, manchmal mein OSD einfriert.

Aber ich versuch's asap mit Bob !

Grusse,

carel
Intel E7400, Ubuntu Server x86_64 12.04, Nvidia GF9400, nvidia 295.40, vdr-1.7.27+ext patch, xine-lib-git + df patches, xineliboutput-git :portal1

NemoN

Professional

Posts: 637

Location: Hamburg (Neu Wulmstorf)

Occupation: QA Engineer

  • Send private message

967

Thursday, June 11th 2009, 2:55pm

@carel:

Quoted


Hast du ein idee warum es überhaupt PES overflow fehler gibt (auch mit vdr-1.7.7 und xineliboutput-cvs) ?


bei mir ist es genau umgekehrt:
- vdr-1.7.7 mit xineliboutput-cvs läuft
- vdr-1.7.7 mit xineliboutput-1.0.4 + vdpau patches gibt nur PES overflow fehler = unbenutzbar
NAS: Synology D213+
Server: Debian, 2.5" 320GB, 3.5" 2TB, GuruPlug Plus, 10 Watt idle
Client 1: HD/VDPAU (VDR 2.0.x / 1.5TB / Antec Fusion Remote / yaUsbIr / M3N78-EM + GT220 (inkl. HDMI Audio) / AMD X2 250 / 2GB RAM / HVR-4000 / NOVA-HD-S2) (CineS2 wartet auf Einbau)
Client 2: M740AV (VDR 1.4.7)

carel

Intermediate

Posts: 436

Location: Niederlande

Occupation: Satelliet und ICT

  • Send private message

968

Thursday, June 11th 2009, 3:38pm

Quoted

vdr-1.7.7 mit xineliboutput-cvs läuft


Das muss ich bestätigen, das war eigene wochen her bei mir getestet aber mit dem letzte cvs version von xineliboutput läuft es sauber (und schnell !)

Aber mit vdr-1.7.0 in zusammenhang mit "pipe/tcp" und vdpau gibts bei mir manchmal die PES buffer fehler...

Gruss !

Carel
Intel E7400, Ubuntu Server x86_64 12.04, Nvidia GF9400, nvidia 295.40, vdr-1.7.27+ext patch, xine-lib-git + df patches, xineliboutput-git :portal1

gda

Im Forum Zuhause

Posts: 13,389

Location: HH

  • Send private message

969

Thursday, June 11th 2009, 4:47pm

Patch r265 ist raus. Sagt mal versteht ihr den Code von r264 auch so, dass man jetzt ein Video im OSD abspielen kann? Also quasi OSDPIP in Vollendung?

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 12.04.2, Plex Media Server
Samsung UE55H6470

Marcus

Trainee

Posts: 131

Location: Umkirch

Occupation: SysAdmin u. Programmierer

  • Send private message

970

Thursday, June 11th 2009, 5:07pm

Quoted

Original von tomas

Quoted

Original von Marcus
bin gerade am compilieren, mal sehen was es für Verbesserungen mit sich bringt


Hallo,

und wie läuft das bei dir?



Hallo Thomas,

bei mir genau das gleiche wie bei Dir, ich hatte aber auch TCP: fifo buffer full Meldungen ohne Ende.
Habe daraufhin die CVS Version von Xineliboutput Plugin versucht allerdings ebenso ohne Erfolg.
Bin aktuell wieder auf die r262 zurück, werde es nachher allerdings mit der r265 nochmals probieren.

Gruß,
Marcus

Mein VDR

H: Gigabyte E7AUM-D2SH, Intel Celeron 440, 2GB, Zotac GT630 ZONE Edition, WD7500BPKT, CineS2 v6.5, 7" TFT, Powermate, Hewlett's 130mm, HDMI an Onkyo TX-NR616
S: yaVDR 0.5 testing / softhddevice / graphtftng

971

Thursday, June 11th 2009, 5:41pm

Hallo,

vielen Dank für eure Hilfe, jetzt weiß ich zumindest, dass es bei den meisten hier keine Probleme mit der neuen Revision gibt.

Was ich da jetzt im Einzelnen verbockt habe, werde dann schon noch rauskitzeln;)

@wbreu: ich mache das in der Regel genauso, wie du es beschrieben hast. Ich werde das heute abend nochmal versuchen.

Gruß, tomas

972

Thursday, June 11th 2009, 6:58pm

Source code

1
2
3
4
Jun 11 13:27:25 hdvdr vdr: [806] buffer usage: 70% (tid=805)
Jun 11 13:27:25 hdvdr vdr: [806] buffer usage: 80% (tid=805)
Jun 11 13:27:25 hdvdr vdr: [806] buffer usage: 90% (tid=805)
Jun 11 13:27:26 hdvdr vdr: [806] buffer usage: 100% (tid=805)


Mit diesem Zeug kämpfe ich schon seit Wochen, leider ohne Erfolg. Bei mir ist das sowas von egal welche Versionen ich benutzte. Buffer wird spätestens nach 5 Minuten voll, das gleiche passiert aber auch mit vdr-xine u. vdr 1.7.7.

Ich habe eine PCI von Sparkle 8400 ( G98 ).

So habe ich noch ausprobiert:

Source code

1
vdr-sxfe --video=vdpau --fullscreen  --audio=alsa --nokbd --post tvtime:method=use_vo_driver xvdr+rtp://127.0.0.1
werde aber demnächst ausprobieren.
YaVDR-0.5 Stable - DVB-C - Nvidia GT520

973

Thursday, June 11th 2009, 7:41pm

Sodele,

nachdem ich gewissenhaft meine Leichen im Keller entsorgt und das Ganze nochmal neu gebaut hatte, brachte das auch keine Besserung.

Aber man sollte sich ja auch mal die Changelogs ansehen!

r263:

Quoted

...make XLock/UnlockDisplay compilation conditionnal


in der /src/video_out/video_out_vdpau.c

Source code

1
/*#define LOCKDISPLAY*/ /*define this if you have a buggy libX11/libX11xcb*/


die Kommentarzeichen entfernt, neu gebaut und schon läuft die Sache auch bei mir wieder :)

zumindest mit vdr-xine, xineliboutput kommt auch noch dran.

Jetzt frage ich mich nur, was an meinem libX11 buggy ist.

@neptunvasja: hier traten diese Probleme erst mit r263 auf, vorher lief das astrein.

Mann und jetzt gibts ja schon r266.

Gruß, tomas

974

Friday, June 12th 2009, 11:17am

Quoted

Original von gda
Patch r265 ist raus. Sagt mal versteht ihr den Code von r264 auch so, dass man jetzt ein Video im OSD abspielen kann? Also quasi OSDPIP in Vollendung?

Gerald


Hi Gerald,

jepp so ist es mit osdpip-0.10 und dem Patch aus dem Wiki lässt sich jetzt damit ein schönes OSD-PIP in den VDR mit xineliboutput einbinden.

Mit dem Patch geht auch die Wiedergabe von Aufnahmen im PIP.
Allerdings habe ich den Code ein bisschen angepasst um das Ausgabefenster auf 640x480 Pixel zu bekommen. Sieht ein bisschen doof aus bei einer 1920x1080er Auflösung das kleine PIP im oberen rechten Bereich.

Gruß
Wolfgang
Hardware: -
Software: -

975

Friday, June 12th 2009, 11:33am

Servus,

übrigens sind mit der r267 von gestern abend die neuen Deinterlacer-Stufen komplett umgesetzt.

D.h. man kann jetzt z.b mit dem 8200/8300er Chipsatz auch half_temporal als Deinterlcer nutzen. Dabei ist die GPU mit 500/1500 auf Auslieferungszustand.
Der bob-Deinterlacer geht damit auch schneller beim Umschalten.

Das Umschaltverhalten/Einpendeln auf den neuen Stream bei half_temporal ist nach 8 Frames auf Astra HD beendet.

Gruß
Wolfgang
Hardware: -
Software: -

976

Friday, June 12th 2009, 12:13pm

Quoted

Original von wbreu

Quoted

Original von gda
Patch r265 ist raus. Sagt mal versteht ihr den Code von r264 auch so, dass man jetzt ein Video im OSD abspielen kann? Also quasi OSDPIP in Vollendung?

Gerald


Hi Gerald,

jepp so ist es mit osdpip-0.10 und dem Patch aus dem Wiki lässt sich jetzt damit ein schönes OSD-PIP in den VDR mit xineliboutput einbinden.

Mit dem Patch geht auch die Wiedergabe von Aufnahmen im PIP.
Allerdings habe ich den Code ein bisschen angepasst um das Ausgabefenster auf 640x480 Pixel zu bekommen. Sieht ein bisschen doof aus bei einer 1920x1080er Auflösung das kleine PIP im oberen rechten Bereich.

Gruß
Wolfgang


welcher patch ist hier gemeint? :-)
VDR Server: 1,8 core2 Duo, 3x TT-S3200, Gentoo, VDR 1.7.22
VDR Client 1: Zotac ION, Gentoo, streamdev, VDR 1.7.22
VDR Client 2: Nvidia 9500GT, Gentoo aktuell yavdr (zum Testen), streamdev, VDR 1.7.22
VDR Client 3: Nvidia GT220 passiv, Gentoo, streamdev, VDR 1.7.28

977

Friday, June 12th 2009, 12:31pm

Quoted

Original von mentox

Quoted

Original von wbreu

Quoted

Original von gda
Patch r265 ist raus. Sagt mal versteht ihr den Code von r264 auch so, dass man jetzt ein Video im OSD abspielen kann? Also quasi OSDPIP in Vollendung?

Gerald


Hi Gerald,

jepp so ist es mit osdpip-0.10 und dem Patch aus dem Wiki lässt sich jetzt damit ein schönes OSD-PIP in den VDR mit xineliboutput einbinden.

Mit dem Patch geht auch die Wiedergabe von Aufnahmen im PIP.
Allerdings habe ich den Code ein bisschen angepasst um das Ausgabefenster auf 640x480 Pixel zu bekommen. Sieht ein bisschen doof aus bei einer 1920x1080er Auflösung das kleine PIP im oberen rechten Bereich.

Gruß
Wolfgang


welcher patch ist hier gemeint? :-)


servus mentox,

das müßte "vdr-osdpip-0.0.10.diff" aus dem wiki sein (das wieder ins vdr-portal verlinkt ist :o) --> Link

@Wolfgang:

Quoted

Original von wbreu
[..]Allerdings habe ich den Code ein bisschen angepasst um das Ausgabefenster auf 640x480 Pixel zu bekommen.[..]


hast du dazu im file "osd.c" des osdpip-plugs änderungen an "m_Width" und "m_Height" für die größere auflösung unternommen und die auflösung deines display mit rein genommen (von 720x576 auf 1920x1080) oder sind da noch andere sourcefiles betroffen? :schiel

gruß, ciax
Lascala LC17 - tribute to viking ;o) + atric IR / AMD X2 BE-2400 / DVB-S2 TT3200 + DigitalDevices CineS2 (defekt) / yavdr stable / output: graphTFT-fe via 6.4" TFT & DVB-S/S2 via FullHD / NVidia GT220 passiv

978

Friday, June 12th 2009, 1:22pm

Hi ciax,

soweit ich das noch im Kopf habe, jepp so ist es.

Zudem ist noch ein File betroffen, musst mal schauen, sind ja nicht viele.

Da gibt es einen Code-Block mit den möglichen Auflösungen die im OSD dann einstellbar sind.

Da aufpassen, die "11" nimmt er nicht. Ich habe eine geringere Auflösung ersetzt mit 640x480.

Das PIP erscheint rechts oben in der Ecke mit 640x480 mit jeweiligen Abstand zu rechts und oben, gesamt hat der Screen 1920x1080.

Gruß
Wolfgang
Hardware: -
Software: -

979

Friday, June 12th 2009, 1:28pm

Quoted

Original von wbreu
Hi ciax,

soweit ich das noch im Kopf habe, jepp so ist es.

Zudem ist noch ein File betroffen, musst mal schauen, sind ja nicht viele.

Da gibt es einen Code-Block mit den möglichen Auflösungen die im OSD dann einstellbar sind.

Da aufpassen, die "11" nimmt er nicht. Ich habe eine geringere Auflösung ersetzt mit 640x480.

Das PIP erscheint rechts oben in der Ecke mit 640x480 mit jeweiligen Abstand zu rechts und oben, gesamt hat der Screen 1920x1080.

Gruß
Wolfgang


danke Wolfgang! genau das mit der 11-ten option im "switch"/case habe ich fälschlicherweise gemacht ... konnte es noch nicht ausprobieren, da not@home.

gruß, ciax
Lascala LC17 - tribute to viking ;o) + atric IR / AMD X2 BE-2400 / DVB-S2 TT3200 + DigitalDevices CineS2 (defekt) / yavdr stable / output: graphTFT-fe via 6.4" TFT & DVB-S/S2 via FullHD / NVidia GT220 passiv

carel

Intermediate

Posts: 436

Location: Niederlande

Occupation: Satelliet und ICT

  • Send private message

980

Friday, June 12th 2009, 2:11pm

Quoted

Da gibt es einen Code-Block mit den möglichen Auflösungen die im OSD dann einstellbar sind.


Damit würde ich auch gerne spielen...

Und mittlerweile ist 270 schon da !

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
------------------------------------------------------------------------
r270 | julian | 2009-06-12 14:39:42 +0200 (vr, 12 jun 2009) | 1 line

fixed a typo in the default_8x8_intra scaling matrix
------------------------------------------------------------------------
r269 | julian | 2009-06-12 13:30:39 +0200 (vr, 12 jun 2009) | 1 line

- fix default scaling lists, to use zigzag encoding
------------------------------------------------------------------------
r268 | julian | 2009-06-12 13:00:43 +0200 (vr, 12 jun 2009) | 1 line

fix color shifting, due to missing second_chroma_qp_index_offset default
------------------------------------------------------------------------
r267 | hftom | 2009-06-12 01:05:16 +0200 (vr, 12 jun 2009) | 1 line

query features and enable accordingly + cleanup



Carel
Intel E7400, Ubuntu Server x86_64 12.04, Nvidia GF9400, nvidia 295.40, vdr-1.7.27+ext patch, xine-lib-git + df patches, xineliboutput-git :portal1

This post has been edited 1 times, last edit by "carel" (Jun 12th 2009, 2:46pm)