You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

e9hack

Professional

Posts: 1,641

Location: BW in der Nähe von Esslingen

  • Send private message

341

Tuesday, February 3rd 2009, 1:33am

Quoted

Original von UFO
Test mit Full-TS FF-Karte. Nach einiger Zeit ein "cat /sys/module/dvb_core/parameters/ts_cnt" liefert:

Source code

1
10503,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,1,10502,0,20710,295,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0


Ich finde die Verteilung nicht ungewöhnlich. Die "kleinen" Puffer stammen daher, daß im Tasklet bei einem Wrap des Puffers die Demuxer-Funktion zweimal aufgerufen wird.


Dann muß es aber noch einen gewaltigen Unterschied zwischen Budget und Full-TS geben:

Source code

1
46693,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,4298,0,8532,65,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
Warum es 64kByte Packete anstelle von 16k gibt, ist auch nicht klar. Wenn die Spec vom SAA7146 BYTE- und DWORD-Counter durcheinander bringt, wären die 64 kByte Blöcke plausibel.

Gruß
e9hack

UFO

Sage

  • "UFO" started this thread

Posts: 5,132

Location: Großherzogthum Baden

  • Send private message

342

Tuesday, February 3rd 2009, 2:02am

Quoted

Original von e9hack

Quoted

Original von UFO
Test mit Full-TS FF-Karte. Nach einiger Zeit ein "cat /sys/module/dvb_core/parameters/ts_cnt" liefert:

Source code

1
10503,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,1,10502,0,20710,295,1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0


Ich finde die Verteilung nicht ungewöhnlich. Die "kleinen" Puffer stammen daher, daß im Tasklet bei einem Wrap des Puffers die Demuxer-Funktion zweimal aufgerufen wird.


Dann muß es aber noch einen gewaltigen Unterschied zwischen Budget und Full-TS geben:

Source code

1
46693,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,4298,0,8532,65,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0


Deine Hardware hat einen Hang zu kurzen Paketen. :D

Dies hier liefert meine Activy Budget:

Source code

1
2
cat /sys/module/dvb_core/parameters/ts_cnt
730,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,730,0,0,0,0,0,5843,6,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0

Also alles im grünen Bereich.

Quoted


Warum es 64kByte Packete anstelle von 16k gibt, ist auch nicht klar. Wenn die Spec vom SAA7146 BYTE- und DWORD-Counter durcheinander bringt, wären die 64 kByte Blöcke plausibel.

Imho ist das Datenblatt falsch. PCI ist ein 32-Bit-Bus, daher dürften es DWords, nicht Bytes sein.

CU
Oliver
VDR Remote Control Plugin (Version 0.5.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

This post has been edited 1 times, last edit by "UFO" (Feb 3rd 2009, 2:04am)


e9hack

Professional

Posts: 1,641

Location: BW in der Nähe von Esslingen

  • Send private message

343

Tuesday, February 3rd 2009, 10:09pm

Quoted

Original von UFO

Deine Hardware hat einen Hang zu kurzen Paketen. :D


Neben der Budget werkelt ja noch eine FF ohne Full-TS. Die will ja auch ein paar TS-Packete gefiltert haben. Die Interrupts von der Budget kommen nur alle 64k.

Gruß
e9hack

UFO

Sage

  • "UFO" started this thread

Posts: 5,132

Location: Großherzogthum Baden

  • Send private message

344

Tuesday, February 3rd 2009, 10:31pm

Quoted

Original von e9hack

Quoted

Original von UFO

Deine Hardware hat einen Hang zu kurzen Paketen. :D


Neben der Budget werkelt ja noch eine FF ohne Full-TS. Die will ja auch ein paar TS-Packete gefiltert haben. Die Interrupts von der Budget kommen nur alle 64k.


Ach so. Mit FF ohne Mod + Budget ist dieses Ergebnis natürlich zu erwarten. ;)

CU
Oliver
VDR Remote Control Plugin (Version 0.5.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

345

Saturday, February 14th 2009, 10:14pm

FULLTS MOD für REV.B

Hallo,

@UFO
danke für Deine tolle Arbeit und die Anleitung...

Habe mich mal daran gewagt und meine Rev.B Karte auf FullTS zu modden...

An alle die es interessiert:

Es läuft 100%ig...

Also kann auch die Rev.B in die Liste mit aufgenommen werden... :)

Für alle die es auch machen wollen - die 1.3er Anleitung funktioniert wegen der Ähnlichkeit 100%ig.

Das einzige "Problem" sind die Lötstellen auf der AV7110 Seite... man kann aber die Platinendurchführungen als Lötpads verwenden.

Danke..

Weiter so...

Gruß

Amigaman
amigaman has attached the following image:
  • FullTS_REV.B_small_3.jpg
amIGa ruleZ dA biG wiDE woRld

This post has been edited 2 times, last edit by "amigaman" (Feb 15th 2009, 2:14am)


jowi24

Professional

Posts: 679

Location: Bruchsal

  • Send private message

346

Sunday, February 15th 2009, 12:53pm

Quoted

Original von UFO
Um ganz sicher zu sein, könntest Du im fehlerhaften Treiber einmal genau diesen Patch herausnehmen:
Changeset http://linuxtv.org/hg/v4l-dvb/raw-rev/aa3e5cc1d833 (einfach mit "patch -p1 -R" rückgängig machen)


Auch das habe ich nun verifiziert. Das genannten Changeset ist definitiv die Ursache für meine Probleme mit LIRC/Full-TS gewesen und nun aus meiner Treiberkopie verbannt.

UFO

Sage

  • "UFO" started this thread

Posts: 5,132

Location: Großherzogthum Baden

  • Send private message

347

Sunday, February 15th 2009, 1:44pm

RE: FULLTS MOD für REV.B

Quoted

Original von amigaman
Hallo,

@UFO
danke für Deine tolle Arbeit und die Anleitung...

Habe mich mal daran gewagt und meine Rev.B Karte auf FullTS zu modden...

An alle die es interessiert:

Es läuft 100%ig...

Also kann auch die Rev.B in die Liste mit aufgenommen werden... :)

Done.

Quoted


Für alle die es auch machen wollen - die 1.3er Anleitung funktioniert wegen der Ähnlichkeit 100%ig.

Das einzige "Problem" sind die Lötstellen auf der AV7110 Seite... man kann aber die Platinendurchführungen als Lötpads verwenden.

Ok. Bei der Rev. B gibt es die Widerstands-Arrays ja nicht...

CU
Oliver
VDR Remote Control Plugin (Version 0.5.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

348

Tuesday, February 17th 2009, 8:25pm

Full Ts

So, habe jetzt full ts aufgelötet und neuen Treiber installiert:
http://linuxtv.org/hg/~endriss/v4l-dvb
Kernel ist 2.6.26.r4
Das Menü funktioniert jetzt viel besser und schneller.

Allerdings bekomme ich manchmal Klötzchen im Bild.
Frage mich gerade woran das liegen könnte.
Hab auch errors im Log. Siehe Attachement.
Heiliger has attached the following file:
  • error-log.txt (28.41 kB - 92 times downloaded - latest: Nov 21st 2014, 5:16am)

UFO

Sage

  • "UFO" started this thread

Posts: 5,132

Location: Großherzogthum Baden

  • Send private message

349

Tuesday, February 17th 2009, 10:28pm

RE: Full Ts

Quoted

Original von Heiliger
So, habe jetzt full ts aufgelötet und neuen Treiber installiert:
http://linuxtv.org/hg/~endriss/v4l-dvb
Kernel ist 2.6.26.r4
Das Menü funktioniert jetzt viel besser und schneller.

Allerdings bekomme ich manchmal Klötzchen im Bild.
Frage mich gerade woran das liegen könnte.
Hab auch errors im Log. Siehe Attachement.


Zur Fehlersuche bei Full-TS-Mod siehe
http://vdrportal.de/board/thread.php?threadid=79958

CU
Oliver
VDR Remote Control Plugin (Version 0.5.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

350

Wednesday, February 18th 2009, 8:53am

RE: Full Ts

Ok danke,

das hatte ich schon gelesen.
Meine Fehler sehen im Log sehen etwas anders aus.
Hab alles Drähte durchgepiepst... bisher nichts gefunden.

Ich werde die Plattine heute nochmal komplett durchmessen. Vielleicht finde ich etwas.
Die Drähte hab ich unter den Tuner gelegt. Gebündelt sind die nicht.

Unklar ist mir das mit der Spannungsversorung für die beiden ICs.
Hab eine Rev. 1.5 Karte und hab die jetzt an 3.3 V gelegt. Welche Betriebsspannung haben denn die Chips auf dem Board? Laufen die alle mit 3.3V? Ich glaube die haben eher 5 V, oder?

- Heiliger -




Quoted

Originally posted by UFO

Quoted

Original von Heiliger
So, habe jetzt full ts aufgelötet und neuen Treiber installiert:
http://linuxtv.org/hg/~endriss/v4l-dvb
Kernel ist 2.6.26.r4
Das Menü funktioniert jetzt viel besser und schneller.

Allerdings bekomme ich manchmal Klötzchen im Bild.
Frage mich gerade woran das liegen könnte.
Hab auch errors im Log. Siehe Attachement.


Zur Fehlersuche bei Full-TS-Mod siehe
http://vdrportal.de/board/thread.php?threadid=79958

CU
Oliver

UFO

Sage

  • "UFO" started this thread

Posts: 5,132

Location: Großherzogthum Baden

  • Send private message

351

Wednesday, February 18th 2009, 1:00pm

RE: Full Ts

Quoted

Original von Heiliger
Unklar ist mir das mit der Spannungsversorung für die beiden ICs.
Hab eine Rev. 1.5 Karte und hab die jetzt an 3.3 V gelegt. Welche Betriebsspannung haben denn die Chips auf dem Board? Laufen die alle mit 3.3V? Ich glaube die haben eher 5 V, oder?

Die Karte verwendet 3,3V. Ich hoffe ja, daß Du 3,3V-Chips verbaut hast...

CU
Oliver
VDR Remote Control Plugin (Version 0.5.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

352

Wednesday, February 18th 2009, 7:55pm

Die ICs die ich verwende sind ein 74HC74D und ein 74HC4040D. Angeschlossen an 3,3V.

Ich habe jetzt alle Leitungen nochmal durchgemessen (Pin zu Pin).
Alle habe 0.3 Ohm Widerstand und sind hochohmig zum Nachbarn, zu GND, und zu 3,3V.

Also alles so wie es sein soll. Die ICs sind an den unbenutzten Eingängen an 3.3V angeschlossen.

Tja, ich bin ratlos. Ein Lötfehler oder Schaltungsfehler lässt sich nicht ausmachen.

(Wollte gerade noch die Bilder anhängen, aber mit 50 kB komme ich beim besten Willen nicht hin).

-Heiliger-

353

Wednesday, February 18th 2009, 8:11pm

Quoted

Original von Heiliger
.....Wollte gerade noch die Bilder anhängen, aber mit 50 kB komme ich beim besten Willen nicht hin....


Poste Deine Bilder doch einfach hier: http://www.imageshack.us/

:!: Hier nicht klicken!!



dreipo.cc

"Ubuntu" -- An african Word, meaning: "Gentoo is too hard for me".

my VDR


Gen2VDR V4.3PO

VDR: vdr-2.1.6
Mainboard: ASUS Z97-PRO (Wi-Fi ac)
CPU: i7-4770K
RAM: 16G
System HDD: OCZ-VERTEX4 SSD, 120 GB
Video HDD: WD Caviar Green, 3 TB
BD-ROM: Samsung SH-B123L
Gehäuse: Thermaltake DH202 Touch (VM90051N2Z)
DVB: DD Cine S2 V6.5 & DuofleX C/T
IR/FB: yaUSBIR v3 ; Harmony 885

354

Thursday, February 19th 2009, 1:29am

@Heiliger

GND an PIN 11 des 74HC4040D hast Du dran, ja? hatte nämlich auch so ein ähnliches Problem und nach mehrfachem Messen und suchen ist mir das auch erst aufgefallen... :-(

Gruß

Amigaman
amIGa ruleZ dA biG wiDE woRld

355

Sunday, February 22nd 2009, 3:07pm

Das mit den Bildern dauert noch einen Moment.
Hatte gerade erstmal noch eine andere Baustelle - der Stecker meiner Ethernet Karte im VDr war ausgebrochen und da der VDR gleichzeitig Server für die Home Verzeichnisse ist, muss ich das erstmal fixen - sonst geht hier gar nix mehr.

356

Tuesday, February 24th 2009, 7:46pm

Hier sind meine Bilder,

die Karte funktioniert jetzt anscheinend. Ohne weitere Modifikationen.
Schien ein Treiber Problem gewesen zu sein. Bei System Überlast kommt wohl die Karté oder der Treiber total durcheinander.
Jedenfalls 1 oder 2 Aufnahmen gehen jetzt. Menü ist auch flüssig.
Mal weiter beobachten.
Soweit bin ich aber zufrieden -> super Mod!!!

- Heiliger -



This post has been edited 1 times, last edit by "Heiliger" (Feb 24th 2009, 7:51pm)


UFO

Sage

  • "UFO" started this thread

Posts: 5,132

Location: Großherzogthum Baden

  • Send private message

357

Tuesday, February 24th 2009, 10:14pm

Quoted

Original von Heiliger
Hier sind meine Bilder,

die Karte funktioniert jetzt anscheinend. Ohne weitere Modifikationen.
Schien ein Treiber Problem gewesen zu sein. Bei System Überlast kommt wohl die Karté oder der Treiber total durcheinander.
Jedenfalls 1 oder 2 Aufnahmen gehen jetzt. Menü ist auch flüssig.
Mal weiter beobachten.
Soweit bin ich aber zufrieden -> super Mod!!!


Hm - ich würde die Platine auf keinen Fall auf den AV7110 kleben, denn
- da drin ist HF-mäßig ziemlich viel los und
- die Platine behindert die Wärmeableitung.

CU
Oliver
VDR Remote Control Plugin (Version 0.5.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

Marcus 2208

Intermediate

Posts: 444

Location: Hessen, Germany

  • Send private message

358

Tuesday, February 24th 2009, 10:15pm

Quoted

Schien ein Treiber Problem gewesen zu sein


Oder ein Wackelkontakt. Nimms mir nicht übel, aber gute Lötstellen sehen anders aus. Besonders im oberen Bild die rechte Lötstelle, sieht aus wie ein Klumpen kaltes Lötzinn. Ein heisser Tip ist Löthonig. Gibts u.A. bei Conrad. Damit fliesst das Lötzinn deutlich besser. Die Reste kann man entweder drauflassen (dann sieht man aber evtl Lötbrücken nicht), oder einfach mit Spiritus und nem Pinsel entfernt werden.

Wie gesagt, nimms mir nicht übel, aber die Ausfallwarscheinlichkeit ist doch sehr hoch.

Grüße
Marcus
VDR1: MLD 3.0.1
Gigabyte 7VT600P-RZ (VIA KT600/VT8237); AMD Geode NX 1500@6W mit 1024 MB DDR 133MHz;
TT FF DVB-C rev. 2.1

VDR2: MLD 2.0.0
Shuttle XPC SS40G (SiS740/961/315); AMD Geode NX 1500@6W mit 1024 MB DDR 133MHz;
TT FF DVB-C rev. 2.1 (4MB, Full-TS); 1x Technisat CableStar 2 TV

359

Tuesday, February 24th 2009, 11:43pm

ich hab mir mal bei reichelt nen flussmittelstift und eine dose platinenreiniger gekauft. war ne super investition, kann ich nur empfehlen.
Meine Homepage mit VDR-Projekten: http://ca.rstenpresser.de/~cpresser/

Dr. Seltsam

Im Forum Zuhause

Posts: 9,986

Location: 3. Planet des Sonnensystems

Occupation: Organisator

  • Send private message

360

Tuesday, February 24th 2009, 11:58pm

mal ne Frage zwischendurch: was nehmt Ihr eigentlich, um beim Kupferlackdraht die Enden abzuisolieren? eine spezielle Lackabziehpinzette? oder reicht es, die Drahtenden mit dem Lötkolben zu verzinnen (wobei der Lack verdampft)?
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD