Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

41

Montag, 20. Dezember 2004, 18:27

Hallo,
hat irgendjemand einen DWL-122 WLAN USB-Stick(prism2-Chipset) mit der 0.7 laufen?
Woher bekomme ich die passenden Kernelmodule prism2_usb, p80211 (ich habe kein dev-system) bzw. die dazu passenden linux-wlan-ng Utils? In der aktuellen packages ist
kein install-Kandidat zu finden und das vorhandene prism54.ko erkennt den Stick leider
nicht :( Unterstützen die überhaupt schon prism2-Karten?

Gruß,
Lutz
Linvdr0.7 auf Siemens D1171, P3-700, 200GB WD, TT-1.6ff

42

Dienstag, 21. Dezember 2004, 18:20

Hat sich erledigt,
Treiber gebastelt (woody in qemu sei Dank) und
installiert -> DWL-122 funktioniert ;)

Lutz
Linvdr0.7 auf Siemens D1171, P3-700, 200GB WD, TT-1.6ff

Southpark

unregistriert

43

Dienstag, 21. Dezember 2004, 22:06

Hallo,

könntest Du evtl. den gebastelten Treiber hier uppen?
Hab auch so ein Teil.

Danke und Gruß Southpark

44

Mittwoch, 22. Dezember 2004, 09:43

Zitat

Original von Southpark
könntest Du evtl. den gebastelten Treiber hier uppen?


Moin,

du kannst ihn hier finden. Im Archiv gibt's ein /etc/init.d/wlan_up.sh, das muss angepasst werden
und dann aus der /etc/init.d/boot.local heraus aufgerufen werden. Zusätzlich
sind evtl. noch ein paar Kleinigkeiten in /etc/init.d/rcStart zu ändern (NIC-Config, SSH-Start etc).

Gruß,
Lutz
Linvdr0.7 auf Siemens D1171, P3-700, 200GB WD, TT-1.6ff

45

Montag, 27. Dezember 2004, 12:18

Hallo Lutz,

leider bekomme ich das modul unter Linvdr0.7 nicht geladen.

'Modul prism2_usb not found'
ich hab alles in die entsprechenden Verzeichnisse entpackt.

hab schon alles mögliche probiert, mit vollem Pfad, in verschiedene Vezeichnisse kopiert, aber nix.

unter Linvdr0.6 hatte ich den MA111 schon mal am laufen, aber mit dem modul (ist ja auch für kernel 2.4..) läuft es auch nicht.

wo liegt mein Fehler?

Danke schon mal
:) HP

VDR1: VDR 1.2.5 , SuSe8.2, Shuttle SB61G2, nvram-wakeup, Celeron2000, 256MB, Siemens DVB-S 1.3, AV-Board von STB
VDR2: easyVDR 0.5rc1, ASUS Pundit 2600, Celeron 2400, 256MB, TT DVB-S 1.5, AV-Board von STB

46

Montag, 27. Dezember 2004, 14:07

Zitat

Original von *HP*
leider bekomme ich das modul unter Linvdr0.7 nicht geladen.

'Modul prism2_usb not found'
ich hab alles in die entsprechenden Verzeichnisse entpackt.


Verschiebe das "linux-wlan-ng" Verzeichnis mal nach /lib/modules/2.6.9/kernel
und rufe dann "depmod -a" auf. Eigentlich sollte es dann klappen...
(Mein Fehler, falscher Pfad im tar-file)

Gruß,
Lutz
Linvdr0.7 auf Siemens D1171, P3-700, 200GB WD, TT-1.6ff

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Lutz« (27. Dezember 2004, 14:18)


47

Montag, 27. Dezember 2004, 18:30

Zitat


Verschiebe das "linux-wlan-ng" Verzeichnis mal nach /lib/modules/2.6.9/kernel
und rufe dann "depmod -a" auf. Eigentlich sollte es dann klappen...
(Mein Fehler, falscher Pfad im tar-file)

Zitat



Super, danke für den Tip, jetzt klappt es!!

Gruß
:) HP

VDR1: VDR 1.2.5 , SuSe8.2, Shuttle SB61G2, nvram-wakeup, Celeron2000, 256MB, Siemens DVB-S 1.3, AV-Board von STB
VDR2: easyVDR 0.5rc1, ASUS Pundit 2600, Celeron 2400, 256MB, TT DVB-S 1.5, AV-Board von STB

48

Sonntag, 2. Januar 2005, 19:24

Hallo Gemeinde,
ich habe jetzt auch den ma111 zum Laufen gebracht (vielen Dank an Lutz!!!)
Von meiner LinVDR 0.7 Kiste komme ich auch problemlos ins Netz. Ich habe jetzt aber das Problem, das ich meinen VDR von einem weiteren PC im Netz nicht 'pingen' kann (http und ssh geht natürlich auch nicht). Auf dem VDR läuft soweit ich es sehen kann auch keine Firewall (iptables / ipchains) o.ä.. Die ebenfalls vorhandene 2 Ethernetkarte lief ohne Probleme (ist jetzt aber down) .
Habe ich eine Einstellung übersehen ? Oder gibt es eine Zugriffskontrolle o.ä.

Danke
Ede

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »vdrede« (3. Januar 2005, 09:46)


49

Freitag, 15. April 2005, 14:50

Habe es auch mal mit meinem DWL-122 und Linvdr-0.7 probiert.

Die Module lade ich mit "modprobe prism2_usb", laut logread und dmesg werden sie auch angezogen, diese sollten doch nach meinem Verständniss das WLAN0 interface bereitstellen, oder ?
Bei mir wird es nämlich nicht angezeigt. Hat jemand 'ne Idee ?
Powered by Point of View ION330 und Mystique SaTiX-S2 Dual
Geguckt wird auf einem 52PFL5605H/12 per HDMI mit Atmolight Quattro
Audio optisch per Yamaha RX-V459 auf einem Teufel Concept P
Non-TV content über XBMC und boblight
Remote Harmony 525 durch Atric-IR
Remote und Streaming mit Motorola XOOM und AndroVDR sowie Daroon Player
Streaming auf ZBOX ID-81 und Desktop per streamdev
All based on selfbuild OpenenELEC master

Nebenbei noch ein par andere VDRs

50

Freitag, 15. April 2005, 16:07

Moin,

wurde das Modul p80211 (lsmod) auch geladen?
Zeigt dir ein "ifconfig -a" auch kein wlan0 an?

Gruß,
Lutz
Linvdr0.7 auf Siemens D1171, P3-700, 200GB WD, TT-1.6ff

51

Freitag, 15. April 2005, 18:05

Zitat

Original von Lutz
Moin,

wurde das Modul p80211 (lsmod) auch geladen?
Zeigt dir ein "ifconfig -a" auch kein wlan0 an?

Gruß,
Lutz



Jo ! Hier jetzt noch mal mehr Info's :

linvdr:~# modprobe -v prism2_usb
insmod /lib/modules/2.6.9/kernel/p80211.ko
insmod /lib/modules/2.6.9/kernel/prism2_usb.ko

dmesg:

prism2usb_init: prism2_usb.o: 0.2.1-pre23 Loaded
prism2usb_init: dev_info is: prism2_usb
usbcore: registered new driver prism2_usb


logread:

Apr 15 17:02:52 linvdr user.notice kernel: prism2usb_init: prism2_usb.o: 0.2.1-pre23 Loaded
Apr 15 17:02:52 linvdr user.notice kernel: prism2usb_init: dev_info is: prism2_usb
Apr 15 17:02:52 linvdr user.info kernel: usbcore: registered new driver prism2_usb

linvdr:~# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:40:05:65:88:41
inet addr:192.168.0.3 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:430 errors:0 dropped:0 overruns:0 frame:0
TX packets:298 errors:0 dropped:0 overruns:0 carrier:0
collisions:9 txqueuelen:1000
RX bytes:40386 (39.4 KiB) TX bytes:82686 (80.7 KiB)
Interrupt:12 Base address:0xe400

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:323 errors:0 dropped:0 overruns:0 frame:0
TX packets:323 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1698601 (1.6 MiB) TX bytes:1698601 (1.6 MiB)

eht0 ist die, zusätzlich noch eingebaute, Netzwerkkarte.
Powered by Point of View ION330 und Mystique SaTiX-S2 Dual
Geguckt wird auf einem 52PFL5605H/12 per HDMI mit Atmolight Quattro
Audio optisch per Yamaha RX-V459 auf einem Teufel Concept P
Non-TV content über XBMC und boblight
Remote Harmony 525 durch Atric-IR
Remote und Streaming mit Motorola XOOM und AndroVDR sowie Daroon Player
Streaming auf ZBOX ID-81 und Desktop per streamdev
All based on selfbuild OpenenELEC master

Nebenbei noch ein par andere VDRs

52

Freitag, 15. April 2005, 19:51

hast Du mal die Schritte aus der boot.local (in /etc/init.d) probiert ? (halt angepasst auf Deine Module...)

Quellcode

1
2
3
4
5
6
7
8
9
10
11
# Actiontech USB Wlan (prism2)
#execute modprobe prism2_usb
#execute modprobe p80211netdev
#execute wlanctl wlan0 lnxreq_ifstate ifstate=enable
#execute wlanctl wlan0 lnxreq_autojoin ssid="<network Name>" authtype=sharedkey
#execute wlanctl wlan0 lnxreq_hostwep decrypt=true encrypt=true
#execute wlanctl wlan0 dot11req_mibset mibattribute=dot11WEPDefaultKey0=<wepkey>
#execute wlanctl wlan0 dot11req_mibset mibattribute=dot11PrivacyInvoked=true
#execute ifconfig wlan0 up
#execute udhcpc -i wlan0 -b -H `hostname`
##ifconfig wlan0 192.168.1.20 up

ich hatte obiges aber auch schon mit dem DWL-122 probiert (mit Kernel 2.6.9), letztendlich aber auch erfolglos (zumal m.W noch kein WPA unterstützt wird...)

Grüße, Klaus
gepanschtes LinVDR MT Edition - 23.01.2005 (Basis war linvdr 0.7)
das Ganze auf FSC D1219 , PIII 933

53

Montag, 18. April 2005, 18:56

Zitat

Original von KlausK
[...] ich hatte obiges aber auch schon mit dem DWL-122 probiert (mit Kernel 2.6.9), letztendlich aber auch erfolglos (zumal m.W noch kein WPA unterstützt wird...)

Moin,

ein DWL122 läuft hier mit 2.6.9 nahezu problemlos.

Gruß,
Lutz
Linvdr0.7 auf Siemens D1171, P3-700, 200GB WD, TT-1.6ff

54

Montag, 18. April 2005, 20:00

@Lutz:

ich möchte aber nicht mehr auf WPA verzichten. Da war es einfacher, den Router etwas näher an den VDR zu bringen, und die restlichen Rechner per WLan dranzuhängen.

Grüße, Klaus
gepanschtes LinVDR MT Edition - 23.01.2005 (Basis war linvdr 0.7)
das Ganze auf FSC D1219 , PIII 933

55

Dienstag, 19. April 2005, 22:33

Kleines Update von mir:

Funktioniert jetzt wunderbar auf zwei VDR's. Hatte im Bios was falsch eingestellt.
Powered by Point of View ION330 und Mystique SaTiX-S2 Dual
Geguckt wird auf einem 52PFL5605H/12 per HDMI mit Atmolight Quattro
Audio optisch per Yamaha RX-V459 auf einem Teufel Concept P
Non-TV content über XBMC und boblight
Remote Harmony 525 durch Atric-IR
Remote und Streaming mit Motorola XOOM und AndroVDR sowie Daroon Player
Streaming auf ZBOX ID-81 und Desktop per streamdev
All based on selfbuild OpenenELEC master

Nebenbei noch ein par andere VDRs

Immortal Romance Spielautomat