You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

steini

Professional

Posts: 847

Location: NRW

  • Send private message

41

Saturday, April 24th 2004, 2:23pm

Linvdr0.6 aufm Multitainer-geht doch

Sooo, jetzt mal ne "kurze" Zusammenfassung für alle die Linvdr 0.6 auf nem Multitainer laufen lassen möchten:
1. Alle relevanten Konfigurationsdateien und ggf. Videodateien sichern!!
2. Linvdr 0.6 installieren, ich bevorzuge die Neuinstallation, man kann auch updaten.
3. Netzwerk: in /etc/sysconfig "NETWORK_DRIVER_LAN="8139cp" " gegen "NETWORK_DRIVER_LAN="8139too"" austauschen
4. Shutdown: Wie robert.b schon geschrieben hat: In /etc/rcStart "execute insmod apm" in "execute modprobe apm" ändern. Dann erstellt man besser ein eigenes shutdownskript, da die poweroff.pl nur gut funktioniert wenn ACPI unterstützt wird. Das eigene Skript muss dann natürlich in der runvdr mit -s aufgerufen werden.
5. Serielle Schnittstelle: In /etc/modules das modul 8250 ergänzen (Danke nochmal an meinrad), setserial nachinstallieren und dann noch wie oben beschrieben in /etc/init.d/rcStart "/usr/bin/setserial /dev/ttyS0 uart none" nach Laden der Kernelmodule einfügen. Mlcd-Plugin installieren (Danke an DarkAngel) und aktivieren
6. Reboot tut gut und dann lüppt's. ;)
So. Das war's schon, hoff ich.....oder hab ich was vergessen?

Vielen, viiiiieeeelen Dank an alle, die hier mitgebastelt haben. :]
Gruß
steini

PS: @meinrad:[off topic]kann man irgendwie einstellen, dass der Kanalname auf dem Display einer Karte zugeordnet wird, da bei mir beim automatischen EPG-Scan immer der aktuelle Kanal der 2. Karte angezeigt wird? [/off topic]

PPS:@mibö jetzt kannste auch dein Mediadetection-Plugin ohne basteln nutzen ;D
1.: Multitainer, P3 Celeron 1,1GHz, 320MB, Samsung 300GB, TT 1.3 (4MB), TT-Budget, IR Selbstbau, µC-Wakeup-Selbstbau, RGB & SPDif über Platine von STB
mod. Linvdr 0.7 (auf 512 Mb CF), AC3-Firmware 2623
2.: Met@box 500, 64 MB, mod. Linvdr0.7 (auf 128 Mb CF), 20GB Seagate, TT 1.5

42

Saturday, April 24th 2004, 3:54pm

@steini:
Es sollte eigentlich immer der aktuelle Kanal der primaeren Karte angezeigt werden. Ich kann es aber mangels zweiter Karte nicht ueberpruefen. Welche VDR Version hast Du?

Gruss
Meinrad

steini

Professional

Posts: 847

Location: NRW

  • Send private message

43

Saturday, April 24th 2004, 5:20pm

@meinrad,
zur Zeit 1.2.6. Also wenn im Hintergrund von der 2. Karte der EPG-Scan läuft zeigt mir das Display den Kanalnamen der 2. Karte.....komisch. Auch wenn eine Aufnahme startet, zeigt das Display erst die Info der zweiten Karte. Wenn ich dann mal umschalte stimmt der Name wieder, solange die Aufnahme läuft. Dann kommt ja wieder bald der EPG-Scan. Vielleicht ist das ja nur bei mir so. Kann ich mir aber fast nicht vorstellen.
Gruß
steini
1.: Multitainer, P3 Celeron 1,1GHz, 320MB, Samsung 300GB, TT 1.3 (4MB), TT-Budget, IR Selbstbau, µC-Wakeup-Selbstbau, RGB & SPDif über Platine von STB
mod. Linvdr 0.7 (auf 512 Mb CF), AC3-Firmware 2623
2.: Met@box 500, 64 MB, mod. Linvdr0.7 (auf 128 Mb CF), 20GB Seagate, TT 1.5

44

Saturday, April 24th 2004, 7:34pm

Hallo steini,

ich glaube ich habs gefunden. War wohl ein Semikolon zuviel. Versuch mal die neue Version.

Gruss
Meinrad
meinrad has attached the following file:

steini

Professional

Posts: 847

Location: NRW

  • Send private message

45

Saturday, April 24th 2004, 7:44pm

Hi meinrad,
das ging ja superschnellllll. Werd ich testen und berichten
Danke
steini
1.: Multitainer, P3 Celeron 1,1GHz, 320MB, Samsung 300GB, TT 1.3 (4MB), TT-Budget, IR Selbstbau, µC-Wakeup-Selbstbau, RGB & SPDif über Platine von STB
mod. Linvdr 0.7 (auf 512 Mb CF), AC3-Firmware 2623
2.: Met@box 500, 64 MB, mod. Linvdr0.7 (auf 128 Mb CF), 20GB Seagate, TT 1.5

DarkAngel

Professional

Posts: 898

Location: Dresden

  • Send private message

46

Saturday, April 24th 2004, 7:47pm

Kompilierst Du es selber?

Gruß,

Marcus

DarkAngel

Professional

Posts: 898

Location: Dresden

  • Send private message

47

Saturday, April 24th 2004, 8:01pm

mlcd-0.0.3a für LinVDR 0.6

Hier das aktualisierte Package.

Gruß,

Marcus
DarkAngel has attached the following file:

steini

Professional

Posts: 847

Location: NRW

  • Send private message

48

Saturday, April 24th 2004, 8:42pm

@meinrad,
läuft bisher perfekt :]. Das war's wohl. Was ein Zeichen ausmachen kann..... :rolleyes:
vielen Dank

@DarkAngel
ich hab's zwar selbst kopiliert, aber trotzdem Danke

Gruß
steini

PS: wundert mich, dass das noch keinem aufgefallen ist
1.: Multitainer, P3 Celeron 1,1GHz, 320MB, Samsung 300GB, TT 1.3 (4MB), TT-Budget, IR Selbstbau, µC-Wakeup-Selbstbau, RGB & SPDif über Platine von STB
mod. Linvdr 0.7 (auf 512 Mb CF), AC3-Firmware 2623
2.: Met@box 500, 64 MB, mod. Linvdr0.7 (auf 128 Mb CF), 20GB Seagate, TT 1.5

steini

Professional

Posts: 847

Location: NRW

  • Send private message

49

Sunday, April 25th 2004, 10:43pm

Hi Leute,
ich hab jetzt mein System auf Linvdr0.6 umgestellt. Allerdings mit den neuen DVB-Treibern (gibt's hier) und der Addon-Version von MarkTwain (gibt's hier. Läuft bisher problemlos. :]

@meinrad
Das Plugin läuft absolut fehlerfrei. Also alles klar :]. Hab nur folgendes vergessen zu erwähnen: Seit Version 0.0.3 muß ich im Makefile folgendes ändern:

Source code

1
CXXFLAGS = -O2 -Wall -Woverloaded-virtual
gegen

Source code

1
CXXFLAGS = -O2 -Wall -Woverloaded-virtual -D_GNU_SOURCE
tauschen bzw. -D_GNU_SOURCE ergänzen, da sonst beim kompilieren ein Fehler bzgl. "Deklaration lround" auftritt. Weiß aber nicht woran das liegt. Nur so als Hinweis, falls das bei anderen auch passiert.
Gruß
steini
1.: Multitainer, P3 Celeron 1,1GHz, 320MB, Samsung 300GB, TT 1.3 (4MB), TT-Budget, IR Selbstbau, µC-Wakeup-Selbstbau, RGB & SPDif über Platine von STB
mod. Linvdr 0.7 (auf 512 Mb CF), AC3-Firmware 2623
2.: Met@box 500, 64 MB, mod. Linvdr0.7 (auf 128 Mb CF), 20GB Seagate, TT 1.5

50

Monday, April 26th 2004, 10:02pm

Hallo zusammen,

bin gerade wieder hier und dann "muss" ich das hier lesen :) Wirklich klasse!!!
Ich werde dann morgen mal auf die 0.6er Version umsteigen. Zuvor aber noch eine Frage, kann ich die Konfiguratinsdateien (Lirc, Command, na eben alles, was ich so angepasst habe) unter 0.6 auch wieder verwenden?? Änderungen in der runvdr z.B. muss ich doch sicherlich in der 0.6 erneut machen, oder? Wie kann ich denn LinVDR komplett sichern?? Na, ich werd' da sicherlich im Forum was zu finden. Wie gesagt, werd' mich morgen Abend mal dransetzen ... Vielleicht bekomme ich dann auch noch meinen Wlan USB-Adapter zum Laufen ;)

You guys are great!

steini

Professional

Posts: 847

Location: NRW

  • Send private message

51

Monday, April 26th 2004, 11:43pm

Hallo mibö,
also ich war jetzt so "mutig" und hab ein update gemacht. Hat auch geklappt :]
Allerdings hab ich sicherheitshalber vorher alle Plugins deaktiviert, weil's da wohl mal Probleme gab. Die runvdr wird "überklatscht" und die Konfigurationsdateien werden so gelasssen wie sie sind. Voher aber besser trotzdem sichern!! ;D. Ich hab mir die runvdr auch nicht so genau angeschaut und lieber die neue genommen und die notwendigen Änderungen von Hand gemacht. Wenn du dann die Anpassungen wie oben beschrieben machst, läuft's :)
Gruß
steini

PS: Ach so, deine lirc.conf und die remote.conf kannst du natürlich wieder nehmen
1.: Multitainer, P3 Celeron 1,1GHz, 320MB, Samsung 300GB, TT 1.3 (4MB), TT-Budget, IR Selbstbau, µC-Wakeup-Selbstbau, RGB & SPDif über Platine von STB
mod. Linvdr 0.7 (auf 512 Mb CF), AC3-Firmware 2623
2.: Met@box 500, 64 MB, mod. Linvdr0.7 (auf 128 Mb CF), 20GB Seagate, TT 1.5

This post has been edited 1 times, last edit by "steini" (Apr 26th 2004, 11:45pm)


52

Tuesday, April 27th 2004, 8:35am

steini,

was passiert denn bei einem Uopdate mit den Plugins der alten Version. Die geistern dann doch sicherlich noch im System herum, oder!? Das fänd ich nicht so toll.

Ich werde wohl den Weg der Neuinstallation gehen.

steini

Professional

Posts: 847

Location: NRW

  • Send private message

53

Tuesday, April 27th 2004, 8:44am

Hi,
kannste machen (Die Festplatte wird dabei aber neu formatiert!!). Aber die Plugins "geistern" bei nem Update nich mehr rum ;D. Die werden überschrieben. Sind alle im Ordner "/usr/lib/vdr/plugins". Kannste ja nachschauen ;)
Gruß
steini
1.: Multitainer, P3 Celeron 1,1GHz, 320MB, Samsung 300GB, TT 1.3 (4MB), TT-Budget, IR Selbstbau, µC-Wakeup-Selbstbau, RGB & SPDif über Platine von STB
mod. Linvdr 0.7 (auf 512 Mb CF), AC3-Firmware 2623
2.: Met@box 500, 64 MB, mod. Linvdr0.7 (auf 128 Mb CF), 20GB Seagate, TT 1.5

54

Tuesday, April 27th 2004, 10:46pm

Juhuuuu

Ein kräftiges JUHUUUUU in die Runde :)

Habe vorhin die 0.6er installiert (nach steinis Liste) und was soll ich sagen alles wunderbar. Na ja, jetzt sind die Umschaltzeiten leider nicht mehr so toll (hab auch die neuen DVB-Treiber installiert) aber damit kann ich vorerst leben. Wichtig ist, dass das Ausschalten und das MT-LCD funktionieren und das klappt wunnerbaah!

Nochmals vielen Dank euch allen !!!!!!!!!!!!!!!!!

Immortal Romance Spielautomat