You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Tuesday, October 2nd 2007, 10:06pm

c't VDR: Bild ruckelt, kein Ton, etc.

Hallo Allerseits,

ich habe einige Probleme mit der VDR-Installation/Konfiguration.

Aktueller Stand:
Ich habe den c't-VDR 6 aus dem Heft 11/07 als Dual-Boot neben meinem WinXP installiert. Nach dem Installieren startete der VDR mit einer Textkonsole => Kein Bild, kein Ton.
Nach weiterem Studium des zugehörigen Artikels, stellte ich fest, dass ich noch X11 und xinelib installieren muss, damit ich ein Bild bekomme. Das habe ich getan. Mit der Zeile xinit -e vdr-sxfe -f xvdr:tcp://localhost startet jetzt auch X11 mit einem Bild "No Signal". Nach dem Editieren von channels.conf habe ich jetzt auch ein Bild ausgewählter Sender.

Aktuelle Probleme:
A) Ich habe zwar ein Bild - das ruckelt jedoch extrem und hat oft Fehler (bunte Klötzchen).
B) Ich habe keinen Ton.
C) Verschlüsselte Sender klappen noch nicht.
D) Nach startx bekomme ich nur ein xterm ohne Windowmanager geschweige denn, dass Programme wie Firefox o.ä. installiert sind.

Ziel:
Ich möchte mit dem VDR Filme digital (verlustfrei) aufnehmen und sie zur weiteren Bearbeitung (Werbung raus, etc.) unter WInXP bereitstellen. Dazu möchte ich sie unter VDR auf dem PC-Monitor flüssig mit Ton sehen können. Langfristig soll sich dazu der Rechner selbsttätig ein- und ausschalten.

Meine Hardware:
Mainboard: ASUS P5NE-SLI
CPU: Core 2 Quad 6600
RAM: 2GB
Festplatte: 2xSamsung 500GB
Grafikkarte: MSI nVIDIA GeForce 7600GT 256MB
DVB-Karte: Technotrend TT-premium C2300

So, ich hoffe das sind genug Informationen, sodass mir einer oder mehrere der hier lesenden Experten weiterhelfen kann.

Kurz noch zu meiner Person: Ich bin Informatiker und kann mit der Kommandozeile umgehen. Wenn mir also jemand sagt, wo und was ich konfigurieren soll, bekomme ich das vermutlich hin. ;-)

Dann legt mal Los.

Grüße,
Licitarius

wirbel

Im Forum Zuhause

Posts: 9,929

Location: Berlin

  • Send private message

2

Tuesday, October 2nd 2007, 10:21pm

RE: c't VDR: Bild ruckelt, kein Ton, etc.

Du hast ne FF Karte, also installier einfach KDE und nutze kvdr. Den Ton kannst dann direkt am Audio Ausgang der DVB Karte abgreifen oder den zur Soundkarte durchschleifen.




Die Lösung XP zum Anschauen zu verwenden ist Geschmackssache, eigentlich eignet sich ein dedizierter PC besser auf dem nur vdr läuft und ein herkömmlicher TV an deiner FF Karte hängt viel besser. Aber natürlich kannst du auch Streaming oder Samba für den Zugriff verwenden - es wäre aber schade um die bessere Bedienbarkei des vdr ;)

3

Friday, October 5th 2007, 10:12pm

Hallo wirbel,

jetzt habe ich auf eine weitere Partition Kubuntu installiert. Dann habe ich über die Paketverwaltung kvdr installiert.

Das Programm lässt sich auch aufrufen. Allerdings erscheint dann kein Fenster, geschweige denn eine Fehlermeldung.

Was fehlt denn jetzt schon wieder?

Gruß,
Licitarius

PS: Ich will die Filme nicht unter WinXP ansehen, sondern sie dort schneiden und auf DVD brennen. Angesehen werden bei mir Filme mittels DVD-Player im Wohnzimmer auf dem Fernseher und nicht am lärmenden PC. ;-)

wirbel

Im Forum Zuhause

Posts: 9,929

Location: Berlin

  • Send private message

4

Friday, October 5th 2007, 10:28pm

?

Was erscheint denn dann? Irgendne Fehlermeldung muss ja kommen.

Versuch mal in ner Konsole (xterm)

kvdr -x




PS: Für das Brennen gibts das burn Plugin, was seine Sache eigentlich recht gut tut. Und dann kannst du genau das mit deiner frisch gebrannten dvd tun: ab in den Player. Und noad hilft beim Markieren nerviger Werbung vor dem Schnitt schneller als du es könntest.

5

Friday, October 5th 2007, 11:37pm

Hallo wirbel,

da kam eine Message-Box mit ein paar Hinweisen, dass ich einen Symlink erzeugen solle, etc. Die Anweisungen habe ich teilweise befolgt. Leider ohner Erfolg.

Jetzt habe ich einfach mal kvdr.real gestartet. Da bekomme ich eine Menge Fehlermeldungen. Offensichtlich fehlen mir ein paar Treiber für meine Karte. Ich dachte dafür sorgt der Packagemanager schon.
Ok: Also konkrete Frage: Wie installiere ich Treiber für meine TT-premium C2300?

Die erscheinenden Fehlermeldungen habe ich unten eingefügt. Vielleicht kannst du etwas damit anfangen.

Gruß,
Licitarius

PS: Wenn's denn läuft werde ich mir die Plugins mal ansehen. Vielleicht steige ich ja doch komplett um. Dazu müssen aber die Grundfunktionen erst einmal reibungslos vorhanden sein.

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
X Error: BadDevice, invalid or uninitialized input device 166
  Major opcode:  144
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 166
  Major opcode:  144
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
kbuildsycoca running...
Reusing existing ksycoca
kio (KService*): WARNING: The desktop entry file /usr/share/applications/DefaultPlugins.desktop has Type=Link instead of "Application" or "Service"
kio (KService*): WARNING: Invalid Service : /usr/share/applications/DefaultPlugins.desktop
kio (KSycoca): ERROR: No database available!
X Error: BadDevice, invalid or uninitialized input device 166
  Major opcode:  144
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 166
  Major opcode:  144
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 166
  Major opcode:  144
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 166
  Major opcode:  144
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
khelpcenter: WARNING: Main template file name is empty.

wirbel

Im Forum Zuhause

Posts: 9,929

Location: Berlin

  • Send private message

6

Friday, October 5th 2007, 11:44pm

Was für ne Message Box und welche Symlinks anlegen? :schiel


Du hast doch ein Bild mit xinelib gehabt, also laufen deine Treiber doch.

7

Saturday, October 6th 2007, 11:49pm

Hallo wirbel,

erst einmal danke, dass du dich immer noch bemühst, mir zu helfen.

Nachdem du schriebst, dass kvdr wohl die bessere Lösung für mich wäre, habe ich mir meine CD/DVD-Sammlung angesehen und mir eine Linux-Distribution herausgesucht, die KDE enthält. Die habe ich dann auf einer neuen Partition installiert und mittels Paketverwaltung kvdr nachinstalliert.
Diese Installation hat mit der c't-VDR-Installation nichts gemeinsam, außer dass sie auf dem selben Rechner installiert sind.
Wenn ich mir die Meldungen des kvdr so ansehe, muss ich wohl vorher noch den vdr konfigurieren und dafür brauche ich wohl die richtigen Treiber.

Ich sehe im Moment zwei Varianten:

A) Ich bringe Ubuntu 7.04 einen konfigurierten VDR bei.
B) Ich bringe dem c't-VDR 6 KDE und kvdr bei.

Welchen Ansatz würdest du verfolgen?

Gruß,
Licitarius

wirbel

Im Forum Zuhause

Posts: 9,929

Location: Berlin

  • Send private message

8

Sunday, October 7th 2007, 10:57am

ct ist ja ein debian und sollte damit auf dessen Paketverwaltung zurückgreifen können.

9

Sunday, October 7th 2007, 6:48pm

Hallo wirbel,

du bist also eher für B).

Welche Pakete muss ich denn da nachinstallieren

Gruß,
Licitarius

wirbel

Im Forum Zuhause

Posts: 9,929

Location: Berlin

  • Send private message

10

Sunday, October 7th 2007, 6:52pm

Gute Frage, da fragst du am besten einen 'Debianer' da müßte ich selbst erst mühsam recherchieren.

pidel

Professional

Posts: 836

Location: Weltstadt Wümme

  • Send private message

11

Sunday, October 7th 2007, 7:11pm

Eigentlich sollte apt die Abhängigkeiten auflösen, wenn du ein
apt-get install kvdr
losschickst. Da kde etc. als dependencies dazu gehören müsste er alles benötigte automatisch auswählen.

[edit]
Failed to open device -> Da stimmt wohl was mit den Rechten nicht. kvdr evtl. mal per sudo aufrufen?
[/edit]

mfg
pidel
Mediaportal (AVT), 533er Celeron, 250GB HD, 128MB RAM, DVBs Rev. 1.3, easyVdr 0.5 04
Meine Projekte: vdr_remote
Registered vdr user #1306
Typisiert und Organspender

This post has been edited 1 times, last edit by "pidel" (Oct 7th 2007, 7:13pm)


12

Monday, October 8th 2007, 8:26pm

Hallo,

ich habe es geschafft und kvdr unter ubuntu am Laufen. Er zeigt auch ein flüssiges Bild. Leider habe ich immer noch folgende zwei Probleme:

A) Der Ton ist extrem leise. Selbst wenn ich alle Regler bei der Lautstärkeregelung voll aufziehe, höre ich den Ton nur sehr leise.

B) Im Bild sind immer wieder Artefakte und Fehler zu sehen.

Das mit B) wäre ja nicht so schlimm, wenn die Aufnahme ok wäre. Leider nimmt der VDR genau das auf, was er anzeigt.

Hat noch jemand eine Idee?

Gruß,
Licitarius

PS: sudo kvdr bringt nur noch mehr Fehlermeldungen. Im Moment bin ich bei folgenden angelangt. Was immer er auch für ein Device öffnen möchte.

Source code

1
2
3
4
5
6
7
8
9
10
X Error: BadDevice, invalid or uninitialized input device 167
  Major opcode:  144
  Minor opcode:  3
  Resource id:  0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 167
  Major opcode:  144
  Minor opcode:  3
  Resource id:  0x0
Failed to open device