You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Baloe

Beginner

  • "Baloe" started this thread

Posts: 6

Location: Holland

  • Send private message

1

Tuesday, October 7th 2003, 4:05pm

vdr xine-plugin mit nova problemen

Hallo,

Zuerst entschuldige mich für meinem Deutsch...

Hab mal gesucht im Forum nach Probleme mit dem xine-plugin und VDR. Aber meine Probleem nicht können Löschen... Vielleicht kan jemand mir helfen...

Hab alles kompiliert (vdr 1.2.1 und 1.2.5, xine plugin 0.0.1 und 0.0.2. 0.0.2 gab ein Fehler beim Kompilieren, aber mit dem Makefile aus 0.0.1 war es OK. CVS version von xine-lib un xine-ui (Gestern))

Hab auch dem 4 fifo devices gemacht in /video/xine (device0-3.vdr), alles gepatched, gesymlinkd etc. etc. Ich benutzte den letzte (nicht CVS) DVB treiber, es sagt im /var/log/messages beim laden:

Oct 7 16:06:15 piii733 kernel: kernel: Linux video capture interface: v1.00
Oct 7 16:06:15 piii733 kernel: DVB: registering new adapter (TT-Budget/WinTV-NOVA-CI PCI).
Oct 7 16:06:15 piii733 kernel: PCI: Found IRQ 3 for device 00:10.0
Oct 7 16:06:16 piii733 kernel: stv0299.c: setup for tuner SU1278/SH
Oct 7 16:06:16 piii733 kernel: DVB: registering frontend 0:0 (STV0299/TSA5059/SL1935 based)...
Oct 7 16:06:17 piii733 kernel: mt312_read: ret == -121
Oct 7 16:06:17 piii733 kernel: TT-Budget/WinTV-NOVA-CI PCI adapter 0 has MAC addr = 00:a2:5c:02:32:d1
Oct 7 16:06:17 piii733 kernel:
Oct 7 16:06:17 piii733 kernel: Technisat SkyStar2 driver loading

(Den letzte Stelle is etwas fremd weil den Nova kein SkyStar2 ist, aber ok!)

Beim starten von VDR (ich bin dus noch gar nicht bei xine angekommen) is das folgende im /var/log/messages

..
Oct 7 15:51:02 piii733 vdr[10383]: VDR version 1.2.1 started
Oct 7 15:51:02 piii733 vdr[10383]: loading plugin: ./PLUGINS/lib/libvdr-xine.so.1.2.1
Oct 7 15:51:02 piii733 vdr[10383]: loading /video/setup.conf
Oct 7 15:51:02 piii733 vdr[10383]: ERROR: unknown config parameter: ZapTimeout = 3
Oct 7 15:51:02 piii733 vdr[10383]: loading /video/sources.conf
Oct 7 15:51:02 piii733 vdr[10383]: loading /video/diseqc.conf
Oct 7 15:51:02 piii733 vdr[10383]: loading /video/channels.conf
Oct 7 15:51:02 piii733 vdr[10383]: loading /video/svdrphosts.conf
Oct 7 15:51:02 piii733 vdr[10383]: loading /video/ca.conf
Oct 7 15:51:02 piii733 vdr[10383]: loading /video/remote.conf
Oct 7 15:51:02 piii733 vdr[10383]: loading /video/keymacros.conf
Oct 7 15:51:02 piii733 vdr[10383]: found 1 video device
Oct 7 15:51:02 piii733 vdr[10383]: initializing plugin: xine (0.0.2): Plugin for "software only" playback using xine.
Oct 7 15:51:02 piii733 vdr[10383]: setting primary device to 1
Oct 7 15:51:02 piii733 vdr[10383]: device 1 has no MPEG decoder
Oct 7 15:51:02 piii733 vdr[10383]: trying device number 2 instead
Oct 7 15:51:02 piii733 vdr[10383]: setting primary device to 2
Oct 7 15:51:02 piii733 vdr[10383]: SVDRP listening on port 2001
Oct 7 15:51:02 piii733 vdr[10383]: starting plugin: xine
Oct 7 15:51:03 piii733 vdr[10383]: switching to channel 2
Oct 7 15:51:03 piii733 vdr[10398]: ERROR (transfer.c,108): No such file or directory
..

Ich begreiffe nicht warum er von device wechselt und den Primary device ändert (Das macht er nicht wann ich runvdr startte ohne xine plugin), und ich begreiffe den Error nicht in der letzte Stelle. Es kann sein das dan nicht device /video/xine/device0.vdr doch eigentlich /video/xine/device1.vdr benutzt wird. Aber das ist noch nicht im plugin eingebracht.

Hat jemand auch dieses Probleem? Weisst jemand ein Losüng?

Ich hab eine Konfiguration mit nur eine hauppauge nova dvb-s.

Danke im voraus,

CU Baloe

p.s. Wann ich runvdr MIT xine plugin startte, kann ich mit mplayer FTA channels ansehen (mplayer - < /dev/dvb/adapater0/vdr0) Das sieht aus das den plugin funtzt

This post has been edited 3 times, last edit by "Baloe" (Oct 7th 2003, 4:45pm)


2

Tuesday, October 7th 2003, 6:03pm

RE: vdr xine-plugin mit nova problemen

Hi,

ok die lösung für dich (alles richtig gemacht!) ist in der datei
.../vdr/Make.config den Eintrag "VIDEODIR=/video" hinzuzufügen

also im vdr ordner die datei (neu erstellen wenn sie nicht dar ist)
Make.config editieren und jetzt das xine plugin neu kompilieren.

das plugin erfährt über diese deffinition wo das video folder ist.
alternativ kannst du auch den /video/xine ordner nach /xine kopieren,
das sollte ohne neu kompilieren gehen, sagt der autor dazu.

Gruß MeMeD

p.s. in english, no prob, just pm me
--
viel spass am geraet
---
AMD1100/512 # 200GB-VDR # 220GB-DIVX #
1.3 Siemens # 2.1 Haupauge(primary) # RH 7.3

Baloe

Beginner

  • "Baloe" started this thread

Posts: 6

Location: Holland

  • Send private message

3

Tuesday, October 7th 2003, 7:16pm

RE: vdr xine-plugin mit nova problemen

@memed,

Thanks, this made at least the 0.0.2 version compile OK :-)

Have to fiddle around a little (i'm short of time now) to get it working properly I guess.

I'l let know of propgressions.

CU Baloe

Baloe

Beginner

  • "Baloe" started this thread

Posts: 6

Location: Holland

  • Send private message

4

Friday, October 17th 2003, 4:50pm

RE: vdr xine-plugin mit nova problemen

@memed,

Do you perhaps have another tip for me? I cannot get rid of the "ERROR (transfer.c,108): no such device or address". I can see that the xine plugin is compiled with VIDEODIR=/video. I tried to copy /device/xine to /xine also.

It just does not work...

thanks...

CU Baloe

Baloe

Beginner

  • "Baloe" started this thread

Posts: 6

Location: Holland

  • Send private message

5

Friday, October 17th 2003, 5:14pm

RE: vdr xine-plugin mit nova problemen

@memed,

An update. I have video :) Using vdr-1.2.1 and the xine-plugin 0.0.2. The weird thing is that the error remains... So something else must be the source...

weird...

CU Baloe

This post has been edited 1 times, last edit by "Baloe" (Oct 17th 2003, 5:14pm)