Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Freitag, 4. März 2005, 15:23

Umstieg auf Suse 9.2 und schon gleich die ersten Probleme...

Hallo

Ich hatte jahrelang meine VDR-Box unter Suse 7.3 laufen, und das lief eigentlich auch...jedenfalls das meiste. Die Probleme haben sich teilweise gehäuft und ich wollte jetzt mal auf eine aktuellere Version umsteigen.
Hab mir dann mal Suse 9.2 per FTP-Installation installiert.

Ich muss zu meiner Verteidigung sagen, ich hab mich jetzt schon sehr lange nicht mehr mit VDR beschäftigt, es lief einfach und gut war ;) Bin also nicht mehr so ganz auf dem neusten Stand in der Entwicklung

Ich hab mir also Linux installiert, und noch nach Hubertus Anleitung (der scheint ja auch nicht mehr so ganz tolle zu sein, oder? Kennt da jemand eine Alternative?) noch die fehlenden Pakete bei einer Minimalinstallation nachinstalliert...

Gut, jetzt will ich DVB-Treiber installieren, jedenfalls so, wie ich das noch weiß.

Quellcode

1
tar -xjvf linux-dvb.2003-11-08.tar.bz2 -C /usr/local/src

sind die vielleicht zu alt?
Entpackt hat er ja auch

gut, dann will ich mit "make" kompilieren, sagt er mir aber sofort schon:

Quellcode

1
2
3
4
5
6
7
cat: CVS/Root: Datei oder Verzeichnis nicht gefunden
(cd driver; make)
make[1]: Entering directory `/usr/local/src/linux-dvb.2003-11-08/driver'
Makefile:102: /lib/modules/2.6.8-24.10-default/build/Rules.make: Datei oder Verzeichnis nicht gefunden
make[1]: *** Keine Regel, um »/lib/modules/2.6.8-24.10-default/build/Rules.make« zu erstellen.  Schluss.
make[1]: Leaving directory `/usr/local/src/linux-dvb.2003-11-08/driver'
make: *** [dvb] Fehler 2


Jetzt steh ich vor dem Schlauch...Hab da nicht viel Ahnung von, und weiß garnicht weiter.

LIRC konnte ich auch nicht kompilieren

Quellcode

1
tar -xjvf lirc-0.7.0.tar.bz2 -C /usr/local/src


Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
video:/usr/local/src/lirc-0.7.0 # make
make  all-recursive
make[1]: Entering directory `/usr/local/src/lirc-0.7.0'
Making all in drivers
make[2]: Entering directory `/usr/local/src/lirc-0.7.0/drivers'
Making all in lirc_dev
make[3]: Entering directory `/usr/local/src/lirc-0.7.0/drivers/lirc_dev'
mv Makefile Makefile.automake
cp ../Makefile.kernel Makefile
make -C /usr/src/linux/ SUBDIRS=/usr/local/src/lirc-0.7.0/drivers/lirc_dev modules \
        KBUILD_VERBOSE=1
make[4]: Entering directory `/usr/src/linux-2.6.8-24.10'
Makefile:465: .config: Datei oder Verzeichnis nicht gefunden
mkdir -p /usr/local/src/lirc-0.7.0/drivers/lirc_dev/.tmp_versions

WARNING: Symbol version dump /usr/src/linux-2.6.8-24.10/Module.symvers is  missing, modules will have CONFIG_MODVERSIONS disabled.

make -f scripts/Makefile.build obj=/usr/local/src/lirc-0.7.0/drivers/lirc_dev
  gcc -Wp,-MD,/usr/local/src/lirc-0.7.0/drivers/lirc_dev/.lirc_dev.o.d -nostdinc -iwithprefix include -D__KERNEL__ -Iinclude  -Wall -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -O2 -fomit-frame-pointer  -pipe -msoft-float -mpreferred-stack-boundary=2 -funit-at-a-time -fno-unit-at-a-time  -Iinclude/asm-i386/mach-default -DIRCTL_DEV_MAJOR=61 -DEXPORT_SYMTAB -DHAVE_CONFIG_H -I. -I. -I../.. -I /usr/local/src/lirc-0.7.0/drivers/lirc_dev/../.. -I /usr/src/linux//include/  -DMODULE -DKBUILD_BASENAME=lirc_dev -DKBUILD_MODNAME=lirc_dev -c -o /usr/local/src/lirc-0.7.0/drivers/lirc_dev/lirc_dev.o /usr/local/src/lirc-0.7.0/drivers/lirc_dev/lirc_dev.c
/bin/sh: scripts/basic/fixdep: Datei oder Verzeichnis nicht gefunden
make[5]: *** [/usr/local/src/lirc-0.7.0/drivers/lirc_dev/lirc_dev.o] Fehler 1
make[4]: *** [_module_/usr/local/src/lirc-0.7.0/drivers/lirc_dev] Fehler 2
make[4]: Leaving directory `/usr/src/linux-2.6.8-24.10'
make[3]: *** [lirc_dev.o] Fehler 2
make[3]: Leaving directory `/usr/local/src/lirc-0.7.0/drivers/lirc_dev'
make[2]: *** [all-recursive] Fehler 1
make[2]: Leaving directory `/usr/local/src/lirc-0.7.0/drivers'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/usr/local/src/lirc-0.7.0'
make: *** [all] Fehler 2


Tjoa, das wars dann auch

Sorry, falls das hier schonmal gestellt wurde, oder falsche Forum oder so...Aber wäre echt nett, wenn mir jemand helfen würde...Und wenns auch nur irgendeine Schritt-für-Schritt Anleitung ist :(
Hab davon keine Ahnung :(

Danke schonmal
PIII 500, 128 MB RAM, Voodoo Banshee
Nexus-s, Nova-s, SB Live 1024, 40x4 LCD, 80 GB Festpaltte

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Hellstorm« (4. März 2005, 15:24)


RalfW

Fortgeschrittener

Beiträge: 496

Wohnort: Mechernich

  • Nachricht senden

2

Freitag, 4. März 2005, 15:36

Hallo Hellstorm,

Du hast Nova-s Nexus-s. Habe ich auch und mit dem Installationsscript installiert. Mit dem DVB Treibern gibt es Probleme da Suse nicht standartconform ist, weshalb man die originalen Treiber der DVD nehmen sollte. Bei mir hat sich dann die Nova immer nach ca. 5 Min ohne Felermehdungen verabschiedet. Aufnahmen gigen fast alle in die Hose. Und einen Kernel neu zu kompilieren unter Suse ist heit eine Sache für sich. Ich würde Dir empfelen, wenn Du schon Suse 9.2 installiert hast, nimm einfach das Installationsscript und lass es mal druchlaufen. Am besten das PIP Plugin mit installieren, und erst einmal testen ob es bei Dir geht. (bei mir friert dann das Bild nach ca. 5 Minuten ein.)
(Anderes Board, Prozessor usw. ) Muss ja nicht zwangsleufig deshalb bei jedem nicht funktionieren.

Gruss
RalfW
******************************

Gen2Vdr 2.0
ASUS K8N-E Deluxe, AMD Semperon 3000, 762 MB RAM
Nova-S + Nova SE2 + DigiStar DVB-S
Toschiba DVD-LW,
IDE 160 GB, 200 GB, S-ATA 500 GB
Wakeup Board 2.0,
Genius SW-HF5.1 5000 Beech Wood Boxenset

3

Freitag, 4. März 2005, 15:37

RE: Umstieg auf Suse 9.2 und schon gleich die ersten Probleme...

Hallo,
bin mir nicht sicher, ob ich Dir helfen kann, aber geb einfach mal meinen Senf dazu. Besser als nix, oder? ;D


Zitat

Ich hab mir also Linux installiert, und noch nach Hubertus Anleitung (der scheint ja auch nicht mehr so ganz tolle zu sein, oder?


Mhm. Ich hab meinen VDR unter Suse 9.0 nach seiner Anleitug installiert und dass hat wunderbar funktioniert.


Zitat

Kennt da jemand eine Alternative?)

Guck mal Hier


Zitat

2003-11-08.tar.bz2

Genau den hab ich auch. Könnt mich nicht beschweren. Kann das sein dass Suse 9.2 schon automatsch DVB Treiber dabei hat und diese installiert hat und die beiden sich nicht mögen? ?(

Zitat

LIRC konnte ich auch nicht kompilieren

Das hat bei mir zuerst auch nicht funktioniert. Dann hab ich ein etwas ... Monöver gemacht. Hab lirc von Suse installiert und dann konnt ich auch das Lirc selbst kompilieren. (Nicht schimpfen...) ;)


Mfg Josef
registered VDR-User: #1013

Hardware: Asus A7V133 / 640 MB Ram / Athlon TB 1000 / SanDisk Ultra II 1GB / Samsung 120 GB + 160 GB/ Nec 1300 / TT 1.5 + Extension Board / TT Budget / GLCD 240x64

Software: LinVDR 0.7 - vdr-1.4.3-2 - Kernel-2.6.18 auf CF-Card ... 384 MB LiveBuffer auf Ramdisk

I30R6

Profi

Beiträge: 1 627

Wohnort: Dortmund

Beruf: Elektroniker

  • Nachricht senden

5

Freitag, 4. März 2005, 15:48

So ich fasse mich kurz :

Die Anleitung von Hubertus gilt nur bis Suse 9.0.

was danach folgt geht man danach :

http://www.hardcoreaudio.de/vdrhowto.htm#_Toc80339185

ansonsten wie immer bitte die :suche

nutzen ...


I30R6










VDR











Hardware : GA-EP35-DS3L, C2Q Q6700 , 3GB DDR2 , Palit GT240, 250GB System & 500GB Video,
Mystique-CaBix C2,TT Budget C-1501,Airstar 2, Fernbedienung X10
Software : gen2vdr, Kernel 3.8.10, vdr 2.0.1
PlugIns : audiorecorder,femon,admin,yacoto..
Ausgabe: softhddevice

6

Freitag, 4. März 2005, 15:58

Ah, ok, danke an alle! Werd mich da mal durch die Seiten lesen.

wegen der Suche: hab ich jetzt garnicht dran gedacht, ich hab zwar auf den ersten Seiten geschaut, aber nicht gesucht, tut mir leid :(

Aber danke!
PIII 500, 128 MB RAM, Voodoo Banshee
Nexus-s, Nova-s, SB Live 1024, 40x4 LCD, 80 GB Festpaltte

7

Freitag, 11. März 2005, 18:03

Also ich hab mir jetzt mal Suse 9.0 draufgepackt, und eigentlich geht jetzt das meiste (von dem was ich installiert hab)
Nur bei LIRC hab ich immer noch Probleme...

Also wenn ich kompilieren will, kommt folgendes:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
video:/usr/local/src/lirc-0.7.0 # make
make  all-recursive
make[1]: Entering directory `/usr/local/src/lirc-0.7.0'
Making all in drivers
make[2]: Entering directory `/usr/local/src/lirc-0.7.0/drivers'
Making all in lirc_dev
make[3]: Entering directory `/usr/local/src/lirc-0.7.0/drivers/lirc_dev'
mv Makefile Makefile.automake
cp ../Makefile.kernel Makefile
make -C /usr/src/linux/ SUBDIRS=/usr/local/src/lirc-0.7.0/drivers/lirc_dev modules \
        KBUILD_VERBOSE=1
make[4]: Entering directory `/usr/src/linux-2.4.21-144'

The present kernel configuration has modules disabled.
Type 'make config' and enable loadable module support.
Then build a kernel with module support enabled.

make[4]: *** [modules] Fehler 1
make[4]: Leaving directory `/usr/src/linux-2.4.21-144'
make[3]: *** [lirc_dev.o] Fehler 2
make[3]: Leaving directory `/usr/local/src/lirc-0.7.0/drivers/lirc_dev'
make[2]: *** [all-recursive] Fehler 1
make[2]: Leaving directory `/usr/local/src/lirc-0.7.0/drivers'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/usr/local/src/lirc-0.7.0'
make: *** [all] Fehler 2


Hm, bin jetzt auch etwas ratlos :ugly: Wie kann ich das denn umstellen? Neu kompilieren will ich ja nicht :(
Auch wie das JosefGierl beschrieben hat, geht das nicht wirklich :(

Irgendwelche Ideen?

Und mit lcdproc geht das auch nicht so ganz. Der LCDd-Treiber läuft, wenn ich das Plugin in der runvdr drinhabe, läuft es auch kurz, also VDR startet und im Display steht auch was, aber dann steht in der Konsole immer "restarting VDR".

In /var/log/messages:

Quellcode

1
2
3
Mar 11 18:03:49 video vdr[1016]: starting plugin: lcdproc
Mar 11 18:03:50 video vdr[1024]: LCD output thread started (pid=1024), display size: 4x40
Mar 11 18:03:50 video vdr[1016]: connection to LCDd at localhost:13666 established.


Dann kommen ganz normale Meldungen und irgendwann dann:

Quellcode

1
Mar 11 18:03:53 video su: pam_unix2: session finished for user vdr, service su



Ich hab jetzt VDR 1.3.22 und die DVB-Treiber vom 26.12.2004 installiert. lcdproc 0.45, lirc 0.7.0, lcdproc-plugin 0.0.9
PIII 500, 128 MB RAM, Voodoo Banshee
Nexus-s, Nova-s, SB Live 1024, 40x4 LCD, 80 GB Festpaltte

I30R6

Profi

Beiträge: 1 627

Wohnort: Dortmund

Beruf: Elektroniker

  • Nachricht senden

8

Freitag, 11. März 2005, 18:17

Ich glaub da bleibt dir nix anderes übrig als den Kernel mit Module Support neu zu kompilieren.



I30R6










VDR











Hardware : GA-EP35-DS3L, C2Q Q6700 , 3GB DDR2 , Palit GT240, 250GB System & 500GB Video,
Mystique-CaBix C2,TT Budget C-1501,Airstar 2, Fernbedienung X10
Software : gen2vdr, Kernel 3.8.10, vdr 2.0.1
PlugIns : audiorecorder,femon,admin,yacoto..
Ausgabe: softhddevice

Immortal Romance Spielautomat