Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

beko

Fortgeschrittener

  • »beko« ist der Autor dieses Themas

Beiträge: 178

Wohnort: Göttingen

  • Nachricht senden

1

Donnerstag, 17. Mai 2012, 21:15

[GELÖST] yaVDR "Richtiges" Mounten neue Aufnahmepartition - Hilfe!

Hallo!

Ich habe Probleme mit dem Mounten meiner neu erstellten Partition für Aufnahmen und benötige eure HIlfe.

Wie ich vorgegangen bin:

Ausgangssituation:
Installation yaVDR auf die gesamte Festplatte (sda1, sda2, sda5)

1. Über Gparted-LiveCD Patition sda1 verkleinert und eine neue Partition sda3 erstellt
2. Neuen Ordner angelegt: /srv/vdr/video.01
2. In der /etc/fstab folgende Zeile eingetragen: UUID=f2d2ec90-5d91-4a57-b432-0aa4bf81714e /srv/vdr/video.01 ext4 defaults 0 2
3. Schreibberechtigung setzen: sudo chown -R vdr:vdr /srv/vdr/video.01 und sudo chown vdr:vdr /srv/vdr/video.01

Was nicht klappt (VDR startet dann nicht):
Default Aufnahmeverzeichnis setzen:
/etc/default/vdr VIDEO_DIR="/srv/vdr/video.01"

Lasse ich den Eintrag für Default-Aufnahmeverzeichnis weg, startet der VDR.
Meine Vorgehensweise ergibt folgendes Ergebnis:

- In vdr.01 ist das Verzeichnis der Aufnahme und nur die TS-Datei
- In vdr.00 ist ebenfalls das Verzeichnis der Aufnahme aber mit index und info Datei und ein symbolischer Link der TS-Datei auf Video.01

- Über das Netzwerk kann nicht mehr auf die Aufnahme zugegriffen werden (Zugriff verweigert)

- Das von meinem NAS über die Webobefläche gemountete Video-Verzeichnis wird nicht mehr unter Recordings angezeigt, jeoch noch über die Konsole in video.00
[EDIT] Habe in der Weboberfläche das Verzeichnis neu eingetragen und wird jetzt wie gewohnt angezeigt.

Wo ist mein Fehler, bzw. wie wäre die korrekte, bzw. einfachste Vorgehensweise?
Ich habe schon viel zu dem Thema gelesen und vermutlich einiges durcheinandergebracht.

Ich möchte nur erreichen, dass yaVDR und Aufnahmen in getrennten Partition sind.

Gruß
beko

VDR 1: SilverStone Milo ML03 | ASRock H61M/U3S3 | Celeron G530 | 4GB RAM | Digital Devices cineS2 | ASUS GeForce GT 520 | CIR Empfänger Asrock Smart Remote | FB Harmony 300i, yaVDR 0.5 > Wohnzimmer
VDR 2: Duron 800, ECS K7S5A | 256 MB RAM | 160 GB HD | 1 x Nexus 2.1 | 1x Skystar2 | FB Medion MD 82467, EasyVDR 0.8 > Schwiegermutter
VDR 3: Samsung SMT7020, Zen2VDR > Tochter

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »beko« (18. Mai 2012, 18:15)


2

Donnerstag, 17. Mai 2012, 21:50

Die Datenpartition nach /srv mounten.

Dabei darauf achten das die yaVDR Standartverzeichnisse *) mit korrekten Rechten auf der Datenpartition sind.

cu

*) http://www.yavdr.org/documentation/0.4/de/ch02s01.html

Mein VDR

Mein VDR
Digitainer2xBouget DVB-SDebian Squeeze (Kernel 2.6.35.3 von kernel.org)Softdevice Ausgabepluginvdr 1.6.0-3 (Extensions Patch 72) und viele Plugins von SourceMedion X10 FernbedienungSDC-Megtron Display (240x128x1) mit GraphLCD-PluginFreevo 1.9.0
Vodcatcher Helper in ein freundliches DEB verpackt, Tester Willkommen: http://dl.dropbox.com/s/705bh6ydgisfrqu/index.htmlFingerprint: 8A104A00D5031773A9F72A19BAEE135EA7860149

beko

Fortgeschrittener

  • »beko« ist der Autor dieses Themas

Beiträge: 178

Wohnort: Göttingen

  • Nachricht senden

3

Donnerstag, 17. Mai 2012, 22:06

Die Datenpartition nach /srv mounten.

Dabei darauf achten das die yaVDR Standartverzeichnisse *) mit korrekten Rechten auf der Datenpartition sind.

cu

*) http://www.yavdr.org/documentation/0.4/de/ch02s01.html


Also wenn ich in der fstab den Eintrag

von
UUID=f2d2ec90-5d91-4a57-b432-0aa4bf81714e /srv/vdr/video.01 ext4 defaults 0 2
in
in UUID=f2d2ec90-5d91-4a57-b432-0aa4bf81714e /srv ext4 defaults 0 2

ändere, startet der VDR nicht mehr (schwarzes Bild mit Mauszeiger). An den Rechten habe ich, außer oben beschriebenen, nichts weiter geändert.

Gruß
beko

VDR 1: SilverStone Milo ML03 | ASRock H61M/U3S3 | Celeron G530 | 4GB RAM | Digital Devices cineS2 | ASUS GeForce GT 520 | CIR Empfänger Asrock Smart Remote | FB Harmony 300i, yaVDR 0.5 > Wohnzimmer
VDR 2: Duron 800, ECS K7S5A | 256 MB RAM | 160 GB HD | 1 x Nexus 2.1 | 1x Skystar2 | FB Medion MD 82467, EasyVDR 0.8 > Schwiegermutter
VDR 3: Samsung SMT7020, Zen2VDR > Tochter

4

Donnerstag, 17. Mai 2012, 22:45

Installation yaVDR auf die gesamte Festplatte (sda1, sda2, sda5)

Ich glaube Dir nicht. Warum drei Partitionen? Root und Swap, was noch? ?(

Erzähle mal: mit LVM oder ohne?

Poste, was:

Quellcode

1
sudo fdisk -l

sagt.

Albert

Signatur

HD-VDR | yaVDR 0.5.0 | Cooltek AH-01 | Intel DH67BL | i3-2100 + Kozuti | 4GB | Zotac GT630 | 60GB SSD + 1TB 2,5" | L4M-Twin S2 6.2 | Harmony ONE+ CIR | Samsung UE40C6200
SD-VDR | yaVDR 0.3.2 | MSI Hermes 845GV | P4 2,53 | 2GB | 250GB | TT Premium S-2300 RGB + TT-budget | SCR/Unicable | ausgeborgt
HD-W10 | DVBViewer Pro | Bluechip MT tuned | Core i7 | 16GB | GTX 960 | 240GB SSD + 2TB | TT S2-3200 | X10

beko

Fortgeschrittener

  • »beko« ist der Autor dieses Themas

Beiträge: 178

Wohnort: Göttingen

  • Nachricht senden

5

Donnerstag, 17. Mai 2012, 22:56

Kein LVM

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
Platte /dev/sda: 1000.2 GByte, 1000204886016 Byte
255 Köpfe, 63 Sektoren/Spur, 121601 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000a3a93

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sda1   *           1        6055    48629760   83  Linux
/dev/sda2          121084      121602     4156417    5  Erweiterte
/dev/sda3            6055      121084   923973632   83  Linux
/dev/sda5          121084      121602     4156416   82  Linux Swap / Solaris

VDR 1: SilverStone Milo ML03 | ASRock H61M/U3S3 | Celeron G530 | 4GB RAM | Digital Devices cineS2 | ASUS GeForce GT 520 | CIR Empfänger Asrock Smart Remote | FB Harmony 300i, yaVDR 0.5 > Wohnzimmer
VDR 2: Duron 800, ECS K7S5A | 256 MB RAM | 160 GB HD | 1 x Nexus 2.1 | 1x Skystar2 | FB Medion MD 82467, EasyVDR 0.8 > Schwiegermutter
VDR 3: Samsung SMT7020, Zen2VDR > Tochter

6

Donnerstag, 17. Mai 2012, 22:57

An den Rechten habe ich, außer oben beschriebenen, nichts weiter geändert.


Zeigt mal zusätzlich (zu dem was DaKilla fragte) "ls -l /srv" wenn deine Datenpartition nach /srv gemountet ist.

cu

Mein VDR

Mein VDR
Digitainer2xBouget DVB-SDebian Squeeze (Kernel 2.6.35.3 von kernel.org)Softdevice Ausgabepluginvdr 1.6.0-3 (Extensions Patch 72) und viele Plugins von SourceMedion X10 FernbedienungSDC-Megtron Display (240x128x1) mit GraphLCD-PluginFreevo 1.9.0
Vodcatcher Helper in ein freundliches DEB verpackt, Tester Willkommen: http://dl.dropbox.com/s/705bh6ydgisfrqu/index.htmlFingerprint: 8A104A00D5031773A9F72A19BAEE135EA7860149

NullP

Fortgeschrittener

Beiträge: 499

Wohnort: Hinterm Mond

Beruf: Zitronenfalter

  • Nachricht senden

7

Donnerstag, 17. Mai 2012, 22:59

Ich möchte nur erreichen, dass yaVDR und Aufnahmen in getrennten Partition sind.
das passt aber nicht damit zusammen:
UUID=f2d2ec90-5d91-4a57-b432-0aa4bf81714e /srv/vdr/video.01 ext4 defaults 0 2
Das bedeutet doch normalerweise, dass vdr die Aufnahmen auf video.00 und video.01 verteilen soll, so wie du es weiter oben selbst beschrieben hast.
Auf die Gefahr hin, Prügel vom yavdr-Team zu beziehen:
Ich hab es genauso mit video.00 (statt 01) gemacht und es klappt einwandfrei.

VDR-Hardware


DVB-T: Siemens M740AV, vdr-firmware von open7x0.org
DVB-S: Samsung SMT-7020 mit zenslack
DBV-S2: Eigenbau (Zotac IonItx-G, 2*DigitalDevices Duoflex an Octopus miniPCIe, yavdr-0.5, root auf Samsung SSD, video.00 auf Samsung 2,5"-640GB)

Wer alkoholfreies Bier trinkt, wählt auch kompetenzfreie Politiker [frei nach Volker Pispers]

8

Donnerstag, 17. Mai 2012, 23:05

WAS IST DAS? ID 5 -> DOS!

3. Schreibberechtigung setzen: sudo chown -R vdr:vdr /srv/vdr/video.01 und sudo chown vdr:vdr /srv/vdr/video.01

Na denn, safety first :D

Quellcode

1
UUID=f2d2ec90-5d91-4a57-b432-0aa4bf81714e /srv/vdr/video.01 ext4 defaults 0 2

Quellcode

1
2
3
4
5
sudo -s
stop vdr
chmod -R 777 /srv/vdr/video.*
chown -R vdr:vdr /srv/vdr/video.*
start vdr

Albert

Signatur

HD-VDR | yaVDR 0.5.0 | Cooltek AH-01 | Intel DH67BL | i3-2100 + Kozuti | 4GB | Zotac GT630 | 60GB SSD + 1TB 2,5" | L4M-Twin S2 6.2 | Harmony ONE+ CIR | Samsung UE40C6200
SD-VDR | yaVDR 0.3.2 | MSI Hermes 845GV | P4 2,53 | 2GB | 250GB | TT Premium S-2300 RGB + TT-budget | SCR/Unicable | ausgeborgt
HD-W10 | DVBViewer Pro | Bluechip MT tuned | Core i7 | 16GB | GTX 960 | 240GB SSD + 2TB | TT S2-3200 | X10

beko

Fortgeschrittener

  • »beko« ist der Autor dieses Themas

Beiträge: 178

Wohnort: Göttingen

  • Nachricht senden

9

Donnerstag, 17. Mai 2012, 23:41

WAS IST DAS? ID 5 -> DOS!

Keine Ahnung wie das passiert ist. Hat das irgendwelche Auswirkungen? Kann ich das korrigieren?

Zitat von »beko«
Schreibberechtigung setzen: sudo chown -R vdr:vdr /srv/vdr/video.01 und sudo chown vdr:vdr /srv/vdr/video.01

Na denn, safety first :D

War das falsch?

UUID=f2d2ec90-5d91-4a57-b432-0aa4bf81714e /srv/vdr/video.01 ext4 defaults 0 2

So steht es in meiner fstab. Ist das richtig, oder soll es wie NulIP vorgeschlagen hat in srv/vdr/video.00 geändert werden?

sudo -s
stop vdr
chmod -R 777 /srv/vdr/video.*
chown -R vdr:vdr /srv/vdr/video.*
start vdr

... dann sollte es auch mit dem Netzwerkzugiff klappen?

Ich kann im Moment nichts testen, da Frauchen den VDR "blockiert"
Sorry für die Nachfragen, bin nicht so fit in Linux.

Gruß
beko

VDR 1: SilverStone Milo ML03 | ASRock H61M/U3S3 | Celeron G530 | 4GB RAM | Digital Devices cineS2 | ASUS GeForce GT 520 | CIR Empfänger Asrock Smart Remote | FB Harmony 300i, yaVDR 0.5 > Wohnzimmer
VDR 2: Duron 800, ECS K7S5A | 256 MB RAM | 160 GB HD | 1 x Nexus 2.1 | 1x Skystar2 | FB Medion MD 82467, EasyVDR 0.8 > Schwiegermutter
VDR 3: Samsung SMT7020, Zen2VDR > Tochter

NullP

Fortgeschrittener

Beiträge: 499

Wohnort: Hinterm Mond

Beruf: Zitronenfalter

  • Nachricht senden

10

Freitag, 18. Mai 2012, 00:03

So steht es in meiner fstab. Ist das richtig, oder soll es wie NulIP vorgeschlagen hat in srv/vdr/video.00 geändert werden?
Der offizielle Weg gemäß yavdr-Doku wurde ja weiter oben schon genannt, nämlich weder noch.
Vielleicht sollten wir nicht zu viele Sachen durcheinander ausprobieren.
Lies dir besser nochmal die vorigen Beiträge durch und poste die Ergebnisse.

VDR-Hardware


DVB-T: Siemens M740AV, vdr-firmware von open7x0.org
DVB-S: Samsung SMT-7020 mit zenslack
DBV-S2: Eigenbau (Zotac IonItx-G, 2*DigitalDevices Duoflex an Octopus miniPCIe, yavdr-0.5, root auf Samsung SSD, video.00 auf Samsung 2,5"-640GB)

Wer alkoholfreies Bier trinkt, wählt auch kompetenzfreie Politiker [frei nach Volker Pispers]

11

Freitag, 18. Mai 2012, 00:04

Keine Ahnung wie das passiert ist. Hat das irgendwelche Auswirkungen? Kann ich das korrigieren?

Ich auch nicht, egal.

So steht es in meiner fstab. Ist das richtig, oder soll es wie NulIP vorgeschlagen hat in srv/vdr/video.00 geändert werden?

Ja, richtig. Ne IP haste und video.00 AUCH! Es ist wie bei Highlander, es kann nur einen geben! :D

... dann sollte es auch mit dem Netzwerkzugiff klappen?

Auch.

Ich kann im Moment nichts testen, da Frauchen den VDR "blockiert"

Wir haben MÄNNERTAG! :mua

Sorry für die Nachfragen, bin nicht so fit in Linux.

Wer ist das schon? :arme

Albert

Signatur

HD-VDR | yaVDR 0.5.0 | Cooltek AH-01 | Intel DH67BL | i3-2100 + Kozuti | 4GB | Zotac GT630 | 60GB SSD + 1TB 2,5" | L4M-Twin S2 6.2 | Harmony ONE+ CIR | Samsung UE40C6200
SD-VDR | yaVDR 0.3.2 | MSI Hermes 845GV | P4 2,53 | 2GB | 250GB | TT Premium S-2300 RGB + TT-budget | SCR/Unicable | ausgeborgt
HD-W10 | DVBViewer Pro | Bluechip MT tuned | Core i7 | 16GB | GTX 960 | 240GB SSD + 2TB | TT S2-3200 | X10

beko

Fortgeschrittener

  • »beko« ist der Autor dieses Themas

Beiträge: 178

Wohnort: Göttingen

  • Nachricht senden

12

Freitag, 18. Mai 2012, 09:34


Zeigt mal zusätzlich (zu dem was DaKilla fragte) "ls -l /srv" wenn deine Datenpartition nach /srv gemountet ist.


Quellcode

1
2
3
4
5
6
7
bk@yaVDR:~$ sudo ls -l /srv
insgesamt 32
drwxrwxrwx 2 vdr vdr 16384 2012-05-16 20:37 lost+found
drwxrwxrwx 3 vdr vdr  4096 2012-05-17 19:48 Reimanns_auf_Reisen:_Die_abenteuerliche_Campingtour_mit_Konny_und_Co_durch_Florida
drwxrwxrwx 3 vdr vdr  4096 2012-05-16 23:23 Saw_IV
drwxrwxrwx 3 vdr vdr  4096 2012-05-17 20:36 Sherlock_-_Ein_Skandal_in_Belgravia
drwxrwxrwx 3 vdr vdr  4096 2012-05-17 21:55 vdr


Jetzt fehlen natürlich die Verzeichnisse:

/srv/picture
/srv/audio
/srv/video

Meine NAS-Freigabe ist jedoch vorhanden und wird angezeigt:
/srv/vdr/video.00/192.168.1.200.000

Im yaVDR ist auch nur dieser Ordner vorhanden!

Gruß
beko

VDR 1: SilverStone Milo ML03 | ASRock H61M/U3S3 | Celeron G530 | 4GB RAM | Digital Devices cineS2 | ASUS GeForce GT 520 | CIR Empfänger Asrock Smart Remote | FB Harmony 300i, yaVDR 0.5 > Wohnzimmer
VDR 2: Duron 800, ECS K7S5A | 256 MB RAM | 160 GB HD | 1 x Nexus 2.1 | 1x Skystar2 | FB Medion MD 82467, EasyVDR 0.8 > Schwiegermutter
VDR 3: Samsung SMT7020, Zen2VDR > Tochter

beko

Fortgeschrittener

  • »beko« ist der Autor dieses Themas

Beiträge: 178

Wohnort: Göttingen

  • Nachricht senden

13

Freitag, 18. Mai 2012, 10:36

So steht es in meiner fstab. Ist das richtig, oder soll es wie NulIP vorgeschlagen hat in srv/vdr/video.00 geändert werden?
Der offizielle Weg gemäß yavdr-Doku wurde ja weiter oben schon genannt, nämlich weder noch.
Vielleicht sollten wir nicht zu viele Sachen durcheinander ausprobieren.
Lies dir besser nochmal die vorigen Beiträge durch und poste die Ergebnisse.


Nach den vielen Experimenten funktioniert die Varante über die fstab den Mountpoint nach srv/vdr/video.00 zu legen wie gewünscht. Ich musste jedoch zuvor das "ursprüngliche" srv/vdr/video.00 bereinigen.

Ich würde das Thema als (GELÖST] ansehen, falls mir nicht jemand noch einen besseren Weg aufzeigt.

Vielen Dank an die Helfer!

Gruß
beko

VDR 1: SilverStone Milo ML03 | ASRock H61M/U3S3 | Celeron G530 | 4GB RAM | Digital Devices cineS2 | ASUS GeForce GT 520 | CIR Empfänger Asrock Smart Remote | FB Harmony 300i, yaVDR 0.5 > Wohnzimmer
VDR 2: Duron 800, ECS K7S5A | 256 MB RAM | 160 GB HD | 1 x Nexus 2.1 | 1x Skystar2 | FB Medion MD 82467, EasyVDR 0.8 > Schwiegermutter
VDR 3: Samsung SMT7020, Zen2VDR > Tochter

14

Freitag, 18. Mai 2012, 13:09

Nach den vielen Experimenten funktioniert die Varante über die fstab den Mountpoint nach srv/vdr/video.00 zu legen wie gewünscht.

Ist vielleicht die beste Lösung. Die knappe 40 MB für VDR auf sda1 hätte dir wenig genutzt und das was Du ursprünglich vor hattest, das hätte so nie funktioniert.

Wenn Du viel Zeit hast, die Partitionierung haben wir schon mal hier diskutiert. Wenn die Partition sda3 nach /srv strukturkonform eingebunden ist , dann hast Du eine Chance auf Datensicherung.

[EDIT] Nur zu Beruhigung. Die sda2 ist wegen der logischen Swap-Partition angelegt worden, ist also alles iO. Entschuldige, mein Fehler. :dösen

Albert

Signatur

HD-VDR | yaVDR 0.5.0 | Cooltek AH-01 | Intel DH67BL | i3-2100 + Kozuti | 4GB | Zotac GT630 | 60GB SSD + 1TB 2,5" | L4M-Twin S2 6.2 | Harmony ONE+ CIR | Samsung UE40C6200
SD-VDR | yaVDR 0.3.2 | MSI Hermes 845GV | P4 2,53 | 2GB | 250GB | TT Premium S-2300 RGB + TT-budget | SCR/Unicable | ausgeborgt
HD-W10 | DVBViewer Pro | Bluechip MT tuned | Core i7 | 16GB | GTX 960 | 240GB SSD + 2TB | TT S2-3200 | X10

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »DaKilla« (18. Mai 2012, 13:22)


beko

Fortgeschrittener

  • »beko« ist der Autor dieses Themas

Beiträge: 178

Wohnort: Göttingen

  • Nachricht senden

15

Freitag, 18. Mai 2012, 18:14


Wenn Du viel Zeit hast, die Partitionierung haben wir schon mal hier diskutiert. Wenn die Partition sda3 nach /srv strukturkonform eingebunden ist , dann hast Du eine Chance auf Datensicherung.


Danke für den Tipp!

Die vorgeschlagene Partitionierung werde ich bei der nächsten Installation (yaVDR 0.5) mit berücksichtigen.

Gruß
beko

VDR 1: SilverStone Milo ML03 | ASRock H61M/U3S3 | Celeron G530 | 4GB RAM | Digital Devices cineS2 | ASUS GeForce GT 520 | CIR Empfänger Asrock Smart Remote | FB Harmony 300i, yaVDR 0.5 > Wohnzimmer
VDR 2: Duron 800, ECS K7S5A | 256 MB RAM | 160 GB HD | 1 x Nexus 2.1 | 1x Skystar2 | FB Medion MD 82467, EasyVDR 0.8 > Schwiegermutter
VDR 3: Samsung SMT7020, Zen2VDR > Tochter

Immortal Romance Spielautomat