You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Thursday, April 26th 2012, 7:40am

[gelöst] vdr-mplayer beendet nicht nach filmende

amd64 System
TV-Karte : Hauppauge Nexus-S 2.1
media-plugins/vdr-mplayer-0.10.2
media-video/vdr-1.6.0_p2-r7

Also wenn ich einen aufgenommenen Film über den vdr-mplayer starte ist es so dass der mplayer bis zum Schluss des Films durchläuft, und dann dort einfach mit einem Schwarzen Bild verweilt und nicht wie ich es gewohnt bin beendet und ein Fernsehprogramm weiter läuft. Dass Problem dass sich dabei für mich ergibt ist, ich schlafe beim Fernsehen gerne ein, was kein Problem ist da ich mir den shutdown timer stelle, der aber dadurch dass der vdr-mplayer nach dem Film nicht beendet wird und anscheinend während dem abspielen nicht aktiv ist, nicht zum Einsatz kommt. Heute ist die Kiste deswegen schon wieder die ganz Nacht durchgelaufen.

Eine Lösung wäre entweder dass der Timer trotz aktivem vdr-mplayer aktiv bleibt oder lieber wäre es mir wenn es eine möglichkeit gäbe dass der vdr-mplayer sich sobald er am ende des Films ist, im ungünstigsten Fall mit gewallt beendet.

This post has been edited 6 times, last edit by "nkwd4876" (May 24th 2012, 11:12am)


2

Sunday, May 20th 2012, 8:03pm

hmm,
doofe sache,

als alternative wäre anstatt das

Paket mplay-sh
mplayer-sh
zu nutzen.

leider werden die mplay-sh sourcen anscheinend nicht mehr gewartet
Letzter Eintrag in dem post hier im portal ist irgendwann von ~2009
( url dazu steht im ebuild )

3

Wednesday, May 23rd 2012, 1:09am

Danke für deinen Beitrag hd.brummy. Habe deinen Rat angenommen und auch mit der vdr-mplayer.sh getestet leider mit selbem ergebnis.

Mir ist da wohl ein Fehler unterlaufen, das Problem dass der VDR nach Filmende nicht beendet, besteht auch weiterhin aber nur bei DIVX kodierten Filmen. Bei XVID kodierten Filmen beendet der VDR sauber.
Was mir noch aufgefallen ist, ist dass der Mplayer am ende eines DIVX Films bis auf 100% CPU Last geht.

Da ich ein Problem im Codec vermute wollte ich mal nachfragen ob es vielleicht eine Möglichkeit gibt die DIVX Filme zu Patchen um sie vom xvid codec abspielen zu lassen, natürlich nur falls der xvid codec fähig ist divx abzuspielen.
Für andere Problemlösungen wie z.B. schnelles verlustfreies umkodieren wäre ich natürlich auch dankbar.

4

Thursday, May 24th 2012, 11:14am

Source code

1
[ebuild   R   ~] media-video/mplayer-1.0_rc4_p20120405


Hab mir heute mal kurz Zeit genommen und mich nochmals mit dem Problem beschäftigt. Nun beendet mein Mplayer auch bei DIVX Filmen sauber, die Lösung war der oben genannte testing mplayer.


Vielen dank für eure Anteilnahme.

This post has been edited 1 times, last edit by "nkwd4876" (May 24th 2012, 11:31am)


5

Thursday, May 24th 2012, 5:28pm

Ja, altbekanntes Problem. Beim mplayer muss man streng genommen hin und wieder in Eigenregie ein SVN-Checkout machen. Releases gibt es, wenn überhaupt, deutlich zu selten.

6

Monday, June 4th 2012, 1:34pm

mit dem letzten smplayer laufen alle Formate einwandfrei..einfach probieren und geniessen

7

Thursday, June 7th 2012, 6:31pm

Mineiro:
Bei dir hilft glaub ich nur noch ein Gebet. Wenn überhaubt