You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

sinai

Professional

  • "sinai" started this thread

Posts: 977

Location: Erlangen

  • Send private message

1

Tuesday, January 24th 2012, 9:01pm

Gelöst: Login auf Server per ssh klappt nicht

Ich möchte hier fragen

Ich habe einen Webserver, auf den ich mich in alle Userverzeichnisse per ssh und key-only einloggen kann. Das klappte bisher problemlos Nun habe ich einen neuen User angelegt, in dessen /home einen funktionierenden authorized_key kopiert, dessen Rechte an den neuen User angepasst, dem neuen User in /etc/ssh/sshd_config den Zugang erlaubt und direkt nach dem Einloggen, bin ich wieder draußen. User web3 klappt (sieben Skunden später ein exit von mir), User web10 nicht.

Hier das Logfile.

Ideen?

Source code

1
2
Jan 23 11:00:52 ip geändert sshd[30623]: Accepted publickey for web3 from 87.161.112.254 port 43699 ssh2
Jan 23 11:00:59 ip geändert sshd[30625]: Received disconnect from 87.161.112.254: 11: disconnected by user


Login klappt - Logout ebenfalls

Source code

1
2
Jan 23 11:01:01 ip geändert sshd[30682]: Accepted publickey for web10 from 87.161.112.254 port 43700 ssh2
Jan 23 11:01:01 ip geändert sshd[30684]: Received disconnect from 87.161.112.254: 11: disconnected by user


Bei User web10 werde ich sofort ausgeloggt, obwohl der Key akzeptiert wird.

Danke für hilfreiche Hinweise - ich verstehe es nicht.

Andy

Meine VDRs

VDR 1: Intel D945GCLF2 Little Falls - Intel Atom 1,6 Ghz - 1 GB - 750 GB S-ATA - FF-Karte - easyVDR 1.0.4
VDR 2: IBM Netvista P4 - 1,8 GHZ - 256 MB - 160 GB P-ATA - Budget-DVB-S-Karte - VDPAU NVidia 8400 GS - easyVDR 1.0.4
VDR 3: Asus M3N78-VM AMD 4850e 1 GB - 250 GB P-ATA - TT S2-6400 Twin-HD und easyVDR 1.0.4

This post has been edited 1 times, last edit by "sinai" (Jan 24th 2012, 9:41pm)


2

Tuesday, January 24th 2012, 9:32pm

Das Log ist leider nicht sehr aussagekräftig, aber mal ein Schuss ins Blaue. Hat der User web3 eine gültige Shell in der /etc/passwd gesetzt?

sinai

Professional

  • "sinai" started this thread

Posts: 977

Location: Erlangen

  • Send private message

3

Tuesday, January 24th 2012, 9:40pm

Ich Depp! Web3 ja, aber web10 nicht. Geändert und schon klappts

Danke - der Schuß war klasse - daran hatte ich nicht mehr gedacht.

Andy

Meine VDRs

VDR 1: Intel D945GCLF2 Little Falls - Intel Atom 1,6 Ghz - 1 GB - 750 GB S-ATA - FF-Karte - easyVDR 1.0.4
VDR 2: IBM Netvista P4 - 1,8 GHZ - 256 MB - 160 GB P-ATA - Budget-DVB-S-Karte - VDPAU NVidia 8400 GS - easyVDR 1.0.4
VDR 3: Asus M3N78-VM AMD 4850e 1 GB - 250 GB P-ATA - TT S2-6400 Twin-HD und easyVDR 1.0.4

4

Tuesday, January 24th 2012, 9:43pm

:) ist aus Erfahrung mittlerweile das erste was ich kontrolliere wenn jemand sagt Authentifizierung klappt, aber dann direkt wieder disconnect.

sinai

Professional

  • "sinai" started this thread

Posts: 977

Location: Erlangen

  • Send private message

5

Tuesday, January 24th 2012, 9:47pm

Ich hoffe, ich denke beim nächsten User wieder dran - so wie bei den neun vorigen.

Ist ja schon fast peinlich...

Andy

Meine VDRs

VDR 1: Intel D945GCLF2 Little Falls - Intel Atom 1,6 Ghz - 1 GB - 750 GB S-ATA - FF-Karte - easyVDR 1.0.4
VDR 2: IBM Netvista P4 - 1,8 GHZ - 256 MB - 160 GB P-ATA - Budget-DVB-S-Karte - VDPAU NVidia 8400 GS - easyVDR 1.0.4
VDR 3: Asus M3N78-VM AMD 4850e 1 GB - 250 GB P-ATA - TT S2-6400 Twin-HD und easyVDR 1.0.4

Posts: 3,600

Occupation: Admin;Support

  • Send private message

6

Thursday, January 26th 2012, 5:29pm

passt zumindest zum Thema, ich musste letztens putty aus meinen Toolsordner ersetzten,
da die Version zu alt war und sich nicht mit dem neuen Router mittels ssh verbinden wollte.
Die aktuelle Version (die auch schon alt ist) funktionierte einwandfrei.
Software: gen2vdr V3 ( Beta8 ) / gen2vdr V2
Hardware: Intel 5200EE - 5N7A-VM - Scythe Shuriken - BeQuiet(Netzteil) - X10-USB Remote
SMT 7020S & P3@900 - Testsystem mit FF und X10-USB Remote
Links für Neueinsteiger

"Jetzt, wo ich weiß wie es geht, versteh ich auch die Gebrauchsanleitung"

Similar threads