You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Tuesday, September 13th 2011, 12:16am

Kann man dem Kernel bei der Kartenerkennung helfen ?

Hallo zusammen,

Mein VDR hat drei DVB Karten, davon wird immer die erste beim Systemstart nicht zuverlässig vom Kernel erkannt.

Zuerst dachte ich an ein Hardware-Problem, z.B. schlechter Sitz der Karte im PCI-Slot o.ä.
Als ich dann entschied, auf die erste Karte zu verzichten, verschob sich das Problem auf die "neue erste", also bis dahin zweite Karte.
D.h. bei 3 eingebauten Karten hab ich mal 2, mal 3 verfügbar, bei 2 eingebauten Karten mal 1, mal 2 ...
Ein Hardware-Problem scheidet da wohl eher aus.
Nur noch eine Karte drin zu lassen, hab ich nicht ausprobiert.

Laut lspci sind immer alle eingebauten Karten auch da, aber laut
fgrep DVB /var/log/messages
fehlt ab und zu eine und der VDR zeigt dann auch Timer-Konflikte an.

Könnte das ein Timing-Problem bei der Harware-Erkennung sein ?
Sieht das eher nach Kernel oder nach udev aus ?
Lässt sich da evtl. was per Kernel-Parameter entzerren ?

Mein System ist ein Ubntu 10.04 (LTS) Server mit Kernel 2.6.32-33 und alles aus den Paketquellen installiert.

Hat jemand sonst noch eine Idee was ich prüfen kann ?

Danke und Gruß,
Markus
Danke und Gruß,
Markus

fnu

Moderator

Posts: 8,417

Location: Böblingen

  • Send private message

2

Tuesday, September 13th 2011, 12:30am

@12-monkeys

Also wenn Du Rat suchst solltest Du schon auch mit ein paar Details ums Eck kommen, wie z.B. welche DVB Karten das sind, Mainboard etc.

So in der Glaskugel gelesen, könnte das schon ein "Timingproblem" sein, hatte auch schon ein Kartentyp der da Probleme macht, weil Ubuntu ab 10.04 schon sehr flott startet und die Karte die FW oft beim Startup nicht schnell genug geladen bekam.

Regards
fnu
Gib HD+/CI+ keine Chance! >> HowTo: APT Pinning <<

>>click<< for my VDR stuff

[¹] Modu CD21, MeanWell (80W)/LC-Power (75W), Futaba MDM166A, Intel DH77EB, G1610, 4GB DDR3, Intel 313 SSD 24GB, WD20EFRX 2TB, Zotac GT630 ('GK208'), SHDD, L4M Twin S2 (V5.6)/FlexS2 (4x DVB-S2), rt Unicable®, CIR, Ubuntu LTS 12.04.4, VDR 2.1.6 (x64, 44W)
[²] Modu CD21, MeanWell (80W)/PicoPSU (90W), Futaba MDM166A, ASRock Q1900M, 2GB DDR3, Intel 320 SSD 40GB, WD10JFCX, Palit GT630 ('GK208'), SHDD, Octopus Net SAT>IP, rt Unicable®, mceusb, Ubuntu LTS 14.04, VDR 2.1.6 (x64, 22W)
[³] Cooler Master Elite 360, Xilence SPS-XP250.SFX (250W), Intel DH77KC, Xeon E3-1245v2, 8GB DDR3, Intel 313 SSD 24GB (Sys & HostCache), HP SA P400 256MB BBWC, 4x WD7500BPKX@Backplane, VMWare ESXi 5.5 (6 VM)(x64, 38W)

3

Tuesday, September 13th 2011, 2:08am

Hallöchen,
Ich dachte, auf diese Details kommts nicht so sehr an, weil das Problem sich ja verschiebt, wenn ich die Hardware ändere.

Also:
Karte 1 ist eine KNC-One
Karte 2 und 3 sind Terratec Cinergy's in unterscheidlichen Revisions
Alles DVB-C (ich wohne in Baden-Württemberg, da gibts keine Grundverschlüsselung auf Kabel)
Der Tuner-Chip ist bei allen Karten ein Philips SAA7146 (rev 01)

Mainboard ist ein ASUS M3A-H/HDMI mit einem Athlon 64 X2 2350 EE (Brisbane-Kern, recht flott und mit 45 W recht stromsparend)

Was ich halt total seltsam finde ist die Tatsache, dass lspci immer alle eingebauten Karten auflistet, aber eben nicht alle vom Kernel auch eingebunden werden.

Danke und Gruß,
Markus
Danke und Gruß,
Markus

This post has been edited 1 times, last edit by "12-monkeys" (Sep 13th 2011, 2:15am)


fnu

Moderator

Posts: 8,417

Location: Böblingen

  • Send private message

4

Tuesday, September 13th 2011, 2:12pm

Was ich halt total seltsam finde ist die Tatsache, dass lspci immer alle eingebauten Karten auflistet, aber eben nicht alle vom Kernel auch eingebunden werden.

Ja, das kenne ich von der "Nova HD" auch, diese wurde zwar PCI-mäßig gelistet, aber regelmäßig nicht als DVB Device vom Kernel erkannt. Das Problem war, das die Karte ab und an ihre FW nicht schnell genug von Platte geladen hat, bei der HW Erkennung dann nicht bereit war und eben auch nicht nutzbar wurde ...

Hast Du schon mal nur einen von beiden Kartentypen probiert?

Regards
fnu
Gib HD+/CI+ keine Chance! >> HowTo: APT Pinning <<

>>click<< for my VDR stuff

[¹] Modu CD21, MeanWell (80W)/LC-Power (75W), Futaba MDM166A, Intel DH77EB, G1610, 4GB DDR3, Intel 313 SSD 24GB, WD20EFRX 2TB, Zotac GT630 ('GK208'), SHDD, L4M Twin S2 (V5.6)/FlexS2 (4x DVB-S2), rt Unicable®, CIR, Ubuntu LTS 12.04.4, VDR 2.1.6 (x64, 44W)
[²] Modu CD21, MeanWell (80W)/PicoPSU (90W), Futaba MDM166A, ASRock Q1900M, 2GB DDR3, Intel 320 SSD 40GB, WD10JFCX, Palit GT630 ('GK208'), SHDD, Octopus Net SAT>IP, rt Unicable®, mceusb, Ubuntu LTS 14.04, VDR 2.1.6 (x64, 22W)
[³] Cooler Master Elite 360, Xilence SPS-XP250.SFX (250W), Intel DH77KC, Xeon E3-1245v2, 8GB DDR3, Intel 313 SSD 24GB (Sys & HostCache), HP SA P400 256MB BBWC, 4x WD7500BPKX@Backplane, VMWare ESXi 5.5 (6 VM)(x64, 38W)

This post has been edited 1 times, last edit by "fnu" (Sep 13th 2011, 2:19pm)


5

Tuesday, September 13th 2011, 2:50pm

Hilft es vielleicht die Treiber und FW in die initial ramdisk zu packen - oder ist es nicht eine bestimmte karte sondern immer im wechsel ?
VDR User: 87 - LaScala LC14B - LG/Phillipps 6,4" VGA Display | Asrock H61/U3S3 | G630T | 1x 16GB Mobi Mtron 3035 1x WD 750GB 2,5" |1x L4m DVB-S2 Version 5.4

6

Tuesday, September 13th 2011, 4:26pm

@fnu
Mir wäre jetzt nicht bekannt, dass diese Karten einen FW upload brauchen, aber sicher bin ich mir da nicht.

Wenn ich die Karte 1 rausziehe, verbleiben 2 (fast) gleiche Karten.

Zusatzinfo: Das sind alles Budget-Karten, keine einzige ist Full-Featured. Der Rechner ist locker schnell genug für xineliboutput.

@steffen_b
Es ist immer die erste:
Mein Board hat 3 PCI slots.
  • Sind alle drei belegt, trifft es immer PCI1.
  • Ist PCI1 frei, trifft es immer PCI2.
  • Slot 1 und 2 frei (also nur noch eine Karte) hab ich noch nicht probiert.
    Ebensowenig 1 und 3 belegt, 2 frei.
    Und auch nicht 1 und 2 belegt, 3 frei.



Momentan steckt die KNC-One in PCI1 und jeweils eine Terratec in PCI2 und 3.
D.h. es ist unabhängig vom Kartentyp.
Danke und Gruß,
Markus

This post has been edited 1 times, last edit by "12-monkeys" (Sep 13th 2011, 9:03pm)