You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Tuesday, September 6th 2011, 8:24pm

kryptische Verzeichnisnamen in samba share

Hallo,

Ich möchte gerne für jemanden regelmäßig Serienfolgen aufzeichnen und ihm das Aufnahmeverzeichnis in Samba freigeben dass er sich die Aufnahmen auf seinen Windows 7 Laptop ziehen kann. Leider erscheinen die Verzeichnisnamen in der Freigabe zum Teil kryptisch. Bevor ich lange erkläre und man es doch nicht versteht hänge ich einfach einen Screenshot an:



Das betrift ein paar wenige Verzeichnisnamen direkt unter video.0 und sämtliche Verzeichnisnamen auf der nächst tieferen Baumebene. Ab der wiederum nächsten Ebene scheint wieder alles in Ordnung zu sein.
Was ist denn da los?

Hier ist die smb.conf, ganz unspektakulär:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2010-07-05
[global]
	workgroup = NET
	passdb backend = smbpasswd
	include = /etc/samba/dhcp.conf
	security = user
	wins support = No
	netbios name = VDR
	encrypt passwords = Yes

[vdr-root]
    	comment = vdr-media
    	inherit acls = Yes
    	path = /vdr
    	read only = Yes
    	create mask = 0660
    	directory mask = 0770
    	valid users = G-SezZ-PC,G-SezZ-Notebook,gsezz
    	follow symlinks = yes


Ich bin für jeden Tipp dankbar
Grüßle G-SezZ
vdr (1.7.15/1.7.15) streamdev-server (0.5.1) skincurses (0.1.9) infosatepg (0.0.11) extrecmenu (1.2) epgsearch (0.9.25.beta17) femon (1.7.8) text2skin (1.3.1) streamdev-client (0.5.1) xineliboutput (1.0.90-cvs) live (0.2.0) noad (0.7.2)
Suse (11.3) linux (2.6.34.8-0.2)

Treito

Professional

Posts: 1,439

Location: Bremen

  • Send private message

2

Tuesday, September 6th 2011, 8:29pm

Das liegt an "Sonderzeichen" wie ":" im Verzeichnisnamen. Ggf. kannst Du VDR mit --vfat oder so ähnlich starten -> Boardsuche.
Asus AT3N7A-I (Dualcore Intel Atom 330), Nvidia GeForce 9400 (onBoard), Pinnacle PCTV 452e, Mystique Satix S2 Sky USB Rev.2, AverTV Green Volar HD, X-Tensions DVB-T-380U, 2GB RAM, Xubuntu 12.04 mit yaVDR stable-Paketen, gepatchter Kernel 3.6.7, yaVDR 0.4, linux-media-dkms bzw. media-match 3.3, USB-IR-Einschalter (igorplug-kompatibel)
Gehäuse: Maxdata Favorit 5000i, Antennen: Strong SRT Ant 15 Eco, Selfsat HD30D4

3

Tuesday, September 6th 2011, 8:32pm

Vermutlich sind da von Windows nicht unterstützte Zeichen im Ordnernamen - Hast du bei deinem VDR VFAT=1 gesetzt?
http://www.vdr-wiki.de/wiki/index.php/VD…on#Installation

Welche Distribution/Paketquellen nutzt du? Oder kompilierst du alles selbst?
yaVDR-Doku

Meine VDRs

VDR 1: Point of View Ion-330-1 (Intel Atom 330@1,6 GHz). 2GB, 4TB HDD, KNC One DVB-C, Sundtek MediaTV Pro (DVB-C), Atric IR-Einschalter Rev.5, yaVDR 0.5 testing
VDR 2: Acer Revo 3610, 4GB Ram, 1x HDD 320 GB, Pinnacle PCTV SAT 452e, Medion X10, YaVDR 0.5
VDR 3: Intel DH67BL, Celeron 540, 4 GB Ram, POV Geforce 210 512 MB, 500 GB, DD Duo-flex CT, Arch LInux, VDR 2.1.6, CIR-Empfänger
Client 1: Raspberry Pi Model B, Arch Linux ARM, VDR 2.1.6
vdr-epg-daemon + MariaDB auf Cubietruck mit 32 GB SSD, Arch Linux ARM, optional Sundtek MediaTV Pro III + VDR 2.1.6
Ceterum censeo enchiridia esse lectitanda.

BJ1

Master

Posts: 2,113

Location: Sachsen

  • Send private message

4

Tuesday, September 6th 2011, 8:35pm

Hau' doch mal in die smb.conf (üblicherweise /etc/samba/smb.conf) unter [global] den Eintrag:

Source code

1
2
unix charset = UTF-8
unix extensions = no


rein.

BJ1

meine Hardware

Produktiv/Testsystem/Datengrab (AZi): XBMCBuntu auf 14.04 LTS, TVHeadend | Asrock H61, Intel Celeron, Asus GT610 | 2 GB 1066 RAM | 2,5" 100GB (System + Aufnahme), 3xWD EARX 2 TB SATA II + 1x Samsung 2 TB SATA II, mhddfs | Triple DVB-C (Digital Devices Cine CT + Satelco Easywatch DVB-C) | Atric IR Rev.5 | Silverstone LC10
Produktiv (WoZi): XBMCBuntu auf 14.04 LTS, TVHeadend | MSI C847MS-E33, Zotac GT630 | 1GB 1333 RAM | 8 GB CF-Card System + WD 1TB Daten | DD DVB-C/T Dualtuner | Atric IR Rev.5 + Logitech Harmony 300

5

Tuesday, September 6th 2011, 8:37pm

Ah, Doppelpunkte, Danke.
Das ganze Zeichensatz Wirrwarr zwischen VDR, Linux bzw Dateisystem und Windows hat mich in den letzten Tagen schon Nerven gekostet. Ich dachte ich hätte es nun im Griff, dass Windows Doppelpunkte in Dateinamen überhaupt nicht unterstützt hatte ich gar nicht bedacht.
Dann werde ich die mal entfernen.

edit: übrigens die shcnellste Hilfe ever, vielen Dank :)
vdr (1.7.15/1.7.15) streamdev-server (0.5.1) skincurses (0.1.9) infosatepg (0.0.11) extrecmenu (1.2) epgsearch (0.9.25.beta17) femon (1.7.8) text2skin (1.3.1) streamdev-client (0.5.1) xineliboutput (1.0.90-cvs) live (0.2.0) noad (0.7.2)
Suse (11.3) linux (2.6.34.8-0.2)

Piet

Intermediate

Posts: 170

Location: Bad Segeberg

  • Send private message

6

Tuesday, September 6th 2011, 8:39pm

Den interessanten Effekt gibt's auch, wenn Ordner unter Linux auf "." enden, da stolpert der Windows Client drüber, und sucht verzweifelt den Extender :]

Ciao

Piet

Similar threads