You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Tuesday, July 5th 2011, 8:52am

[0.4 pre1] lirc ion 330 ht

i have a prerelease of yavdr 0.4 and ion 330 ht (other developer have this htpc) but lirc don't work natively with the remote.

asrock don't have released packages for ubuntu natty 11.04 i suppose that in this distro was recognized out of the box.

there is a packages in repository for this remote?

thank you.

This post has been edited 1 times, last edit by "hepi" (Jul 6th 2011, 11:57am)


gda

Im Forum Zuhause

Posts: 13,073

Location: HH

  • Send private message

2

Tuesday, July 5th 2011, 9:37am

i have a prerelease of yavdr 0.4 and ion 330 ht (other developer have this htpc) but lirc don't work natively with the remote.


You are right. I think I had it running, but forgot to check it in :(. I use the asrock only seldom these days so I didn't notice.
Will look into this issue next days. It should be enough to load the kernel module nuvoton-cir, preferable only there where it is need (this is not so easy because you can't detect the IR module) and to write an udev rule for eventlircd.
So there are only some scripts missing. The main files are already on your machine.

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 12.04.2, Plex Media Server
Zbox HD-ID40, OpenELEC 4.0.2, PLEXBMC

3

Tuesday, July 5th 2011, 9:54am

can you say me where is the script for recognize the nuvoton-cir remote?


this is my dmesg



[ 22.110092] lirc_dev: IR Remote Control driver registered, major 250
[ 22.120440] rc rc0: lirc_dev: driver ir-lirc-codec (nuvoton-cir) registered at minor = 0

seems to be recognized but dont'work

gda

Im Forum Zuhause

Posts: 13,073

Location: HH

  • Send private message

4

Tuesday, July 5th 2011, 10:24am

seems to be recognized but dont'work

As I told you, an udev script for eventlircd has to be written, currently it doesn't exist.

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 12.04.2, Plex Media Server
Zbox HD-ID40, OpenELEC 4.0.2, PLEXBMC

gda

Im Forum Zuhause

Posts: 13,073

Location: HH

  • Send private message

5

Tuesday, July 5th 2011, 10:56am

If you can't wait till I have set up my asrock to do the work. You can try it yourself.

Try this script:

Source code

1
2
3
for i in /sys/class/input/event*; do
  udevadm info --attribute-walk --path=$i|grep "ATTRS{name}"
done

If you can identify a line that seems to be the Name of the nuvoton-cir then edit the file /lib/udev/rules.d/98-eventlircd-names.rules.
Above the line

Source code

1
LABEL="end"

add the following

Source code

1
2
ATTRS{name}=="<name>", \
  ENV{eventlircd_enable}="true"

Replace <name> with the name you have found with the script.
Good chance that it will work already after a reboot. Maybe some keys are not correct, then we need to create a mapping file.

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 12.04.2, Plex Media Server
Zbox HD-ID40, OpenELEC 4.0.2, PLEXBMC

This post has been edited 1 times, last edit by "gda" (Jul 5th 2011, 11:08am)


CouchPotato

Intermediate

Posts: 313

Location: Rheinland

  • Send private message

6

Thursday, July 7th 2011, 9:25pm

@gda
Hallo Gerald, ich habe ja die gleiche Hardware aus gutem Grund. :)
Du wirst in diesem Fred doch mitteilen, wenn Du den Asrock ready für 0.4pre hast, oder?

Ich würde gerne so schnell wie möglich umsteigen, habe aber keinen Bock auf nicht funktionierende FB.
Dann könnte ich vielleicht endlich wieder mit 3 USB-Devices arbeiten, was schon lange nicht mehr funktioniert...

MfG von der Couch
Potato
VDR: ASRock ION 330-HT, yaVDR 0.4, linux-media-dkms TT-connect S2-3650 CI (DVB-S2 an USB, CI ungetestet), TeVii S660 (DVB-S2 an USB), Cinergy S2 USB HD (DVB-S2 an USB), HDMI mit Ton an 42"-LCD, MCE-Fernbedienung auch zum Einschalten (beim ASRock ION 330HT mitgeliefert)
VDR im Ruhestand: Xeatre 6100 pro mit easyVDR 0.6.0 mit VDR 1.4.7 (FF, Budget)
sonstige PVR: uralte Erfahrungen mit Topfield PVR 4000 und früher Grundig SeleXX (verschrottet)

gda

Im Forum Zuhause

Posts: 13,073

Location: HH

  • Send private message

7

Thursday, July 7th 2011, 9:52pm

@gda
Hallo Gerald, ich habe ja die gleiche Hardware aus gutem Grund. :)
Du wirst in diesem Fred doch mitteilen, wenn Du den Asrock ready für 0.4pre hast, oder?


Ich hatte da eigentlich auf return von italoc gehofft, weil ich im Moment eine Zbox als test system habe. Der AsRock ist aktuell nicht angeschlossen.
Also mach du doch erst mal was ich italoc empfohlen habe.

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 12.04.2, Plex Media Server
Zbox HD-ID40, OpenELEC 4.0.2, PLEXBMC

CouchPotato

Intermediate

Posts: 313

Location: Rheinland

  • Send private message

8

Thursday, July 7th 2011, 10:00pm

... Der AsRock ist aktuell nicht angeschlossen.
Also mach du doch erst mal was ich italoc empfohlen habe.
Gerald


Ich hatte insgeheim befürchtet, dass Du das sagst.
Wenn das hier tagelang nicht läuft, krieg ich hämische Kommentare von der Familie...
Und leider hab ich keine separate interne Festplatte für den Asrock zum Testen.

Da fällt mir aber was ein: Kann man eigentlich problemlos auf eine externe USB-HDD installieren, wenn man die internen abklemmt?
Dann würde ich es wagen.
VDR: ASRock ION 330-HT, yaVDR 0.4, linux-media-dkms TT-connect S2-3650 CI (DVB-S2 an USB, CI ungetestet), TeVii S660 (DVB-S2 an USB), Cinergy S2 USB HD (DVB-S2 an USB), HDMI mit Ton an 42"-LCD, MCE-Fernbedienung auch zum Einschalten (beim ASRock ION 330HT mitgeliefert)
VDR im Ruhestand: Xeatre 6100 pro mit easyVDR 0.6.0 mit VDR 1.4.7 (FF, Budget)
sonstige PVR: uralte Erfahrungen mit Topfield PVR 4000 und früher Grundig SeleXX (verschrottet)

gda

Im Forum Zuhause

Posts: 13,073

Location: HH

  • Send private message

9

Thursday, July 7th 2011, 10:07pm

Da fällt mir aber was ein: Kann man eigentlich problemlos auf eine externe USB-HDD installieren, wenn man die internen abklemmt?

Klar

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 12.04.2, Plex Media Server
Zbox HD-ID40, OpenELEC 4.0.2, PLEXBMC

CouchPotato

Intermediate

Posts: 313

Location: Rheinland

  • Send private message

10

Thursday, July 7th 2011, 10:09pm


Klar
Gerald

Einfach so abklemmen, anklemmen, BIOS checken und los?
Oder reicht sogar disablen der internen HDDs und ich muss die Kiste nicht mal öffnen?

Sach ja, dann mach ich das sofort. :)
VDR: ASRock ION 330-HT, yaVDR 0.4, linux-media-dkms TT-connect S2-3650 CI (DVB-S2 an USB, CI ungetestet), TeVii S660 (DVB-S2 an USB), Cinergy S2 USB HD (DVB-S2 an USB), HDMI mit Ton an 42"-LCD, MCE-Fernbedienung auch zum Einschalten (beim ASRock ION 330HT mitgeliefert)
VDR im Ruhestand: Xeatre 6100 pro mit easyVDR 0.6.0 mit VDR 1.4.7 (FF, Budget)
sonstige PVR: uralte Erfahrungen mit Topfield PVR 4000 und früher Grundig SeleXX (verschrottet)

gda

Im Forum Zuhause

Posts: 13,073

Location: HH

  • Send private message

11

Thursday, July 7th 2011, 10:11pm

Einfach so abklemmen, anklemmen, BIOS checken und los?

Ich denke nicht, dass du im Bios was machen musst.

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 12.04.2, Plex Media Server
Zbox HD-ID40, OpenELEC 4.0.2, PLEXBMC

12

Friday, July 8th 2011, 9:59am

i'm waiting for test the solution because i can't format my yavdr0.3 (is in production in my home) i'm trying with external HDD but i have strange problem during boot with grub

i hope to find some time for test this week end.

CouchPotato

Intermediate

Posts: 313

Location: Rheinland

  • Send private message

13

Friday, July 8th 2011, 4:06pm

Als Ausgabe kommt:

Source code

1
2
3
4
5
6
7
8
root@rocki:/srv/vdr/video.00# ./nuvo
info: unrecognized option '--path/sys/class/input/event0'
info: unrecognized option '--path/sys/class/input/event1'
info: unrecognized option '--path/sys/class/input/event2'
info: unrecognized option '--path/sys/class/input/event3'
info: unrecognized option '--path/sys/class/input/event4'
info: unrecognized option '--path/sys/class/input/event5'
info: unrecognized option '--path/sys/class/input/event6'

Ich habe das Script genauso abgetippt und in einer ausführbaren Datei gespeichert.
Dann kommt das oben dabei raus.

Beim Starten der Maschine kommt übrigens ein Bildschirm wie im Foto. Das bleibt einige Zeit stehen (gefühlt 1-2 min),
dann wird weiter gebootet und 3sat erscheint als IPTV. :)
Ausgabe übrigens alles nur über HDMI, kein Monitor angeschlossen.

MfG von der Couch
Potato
(Ralph)

Kernel-Log: http://pastebin.com/WSZ8UqrL
CouchPotato has attached the following image:
  • IMG_1311.png
VDR: ASRock ION 330-HT, yaVDR 0.4, linux-media-dkms TT-connect S2-3650 CI (DVB-S2 an USB, CI ungetestet), TeVii S660 (DVB-S2 an USB), Cinergy S2 USB HD (DVB-S2 an USB), HDMI mit Ton an 42"-LCD, MCE-Fernbedienung auch zum Einschalten (beim ASRock ION 330HT mitgeliefert)
VDR im Ruhestand: Xeatre 6100 pro mit easyVDR 0.6.0 mit VDR 1.4.7 (FF, Budget)
sonstige PVR: uralte Erfahrungen mit Topfield PVR 4000 und früher Grundig SeleXX (verschrottet)

gda

Im Forum Zuhause

Posts: 13,073

Location: HH

  • Send private message

14

Friday, July 8th 2011, 4:20pm

Dann hast du dich vertippt. Ich würde auch nicht abtippen, sondern mit ssh (putty) draufgehen und cut&paste machen. Ich habe das eben gerade nochmal ausprobiert und es geht problemlos:

Source code

1
2
3
4
5
6
7
# for i in /sys/class/input/event*; do                                                                     
>   udevadm info --attribute-walk --path=$i|grep "ATTRS{name}"                                                          
> done                                                                                                                  
    ATTRS{name}=="Power Button (FF)"                                                                                    
    ATTRS{name}=="Sleep Button (CM)"                                                                                    
    ATTRS{name}=="Macintosh mouse button emulation"                                                                     
    ATTRS{name}=="PC Speaker"


Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 12.04.2, Plex Media Server
Zbox HD-ID40, OpenELEC 4.0.2, PLEXBMC

CouchPotato

Intermediate

Posts: 313

Location: Rheinland

  • Send private message

15

Friday, July 8th 2011, 4:34pm

Und nun?

Source code

1
2
3
4
5
6
7
8
9
10
root@rocki:~# for i in /sys/class/input/event*; do
> udevadm info --attribute-walk --path=$i|grep "ATTRS{name}"
> done
    ATTRS{name}=="Power Button"
    ATTRS{name}=="Power Button"
    ATTRS{name}=="HID 04f3:0103"
    ATTRS{name}=="HID 04f3:0103"
    ATTRS{name}=="IR-receiver inside an USB DVB receiver"
    ATTRS{name}=="IR-receiver inside an USB DVB receiver"
    ATTRS{name}=="IR-receiver inside an USB DVB receiver"
VDR: ASRock ION 330-HT, yaVDR 0.4, linux-media-dkms TT-connect S2-3650 CI (DVB-S2 an USB, CI ungetestet), TeVii S660 (DVB-S2 an USB), Cinergy S2 USB HD (DVB-S2 an USB), HDMI mit Ton an 42"-LCD, MCE-Fernbedienung auch zum Einschalten (beim ASRock ION 330HT mitgeliefert)
VDR im Ruhestand: Xeatre 6100 pro mit easyVDR 0.6.0 mit VDR 1.4.7 (FF, Budget)
sonstige PVR: uralte Erfahrungen mit Topfield PVR 4000 und früher Grundig SeleXX (verschrottet)

CouchPotato

Intermediate

Posts: 313

Location: Rheinland

  • Send private message

16

Friday, July 8th 2011, 4:50pm

Ok, ich rate mal:

Source code

1
2
ATTRS{name}=="HID 04f3:0103", \
ENV{eventlircd_enable}="true"

einfügen.

Reboot, FB läuft nicht. :(
VDR: ASRock ION 330-HT, yaVDR 0.4, linux-media-dkms TT-connect S2-3650 CI (DVB-S2 an USB, CI ungetestet), TeVii S660 (DVB-S2 an USB), Cinergy S2 USB HD (DVB-S2 an USB), HDMI mit Ton an 42"-LCD, MCE-Fernbedienung auch zum Einschalten (beim ASRock ION 330HT mitgeliefert)
VDR im Ruhestand: Xeatre 6100 pro mit easyVDR 0.6.0 mit VDR 1.4.7 (FF, Budget)
sonstige PVR: uralte Erfahrungen mit Topfield PVR 4000 und früher Grundig SeleXX (verschrottet)

gda

Im Forum Zuhause

Posts: 13,073

Location: HH

  • Send private message

17

Friday, July 8th 2011, 5:01pm

Tja, das muss ich mir dann bei Gelegenheit mal ansehen.

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 12.04.2, Plex Media Server
Zbox HD-ID40, OpenELEC 4.0.2, PLEXBMC

CouchPotato

Intermediate

Posts: 313

Location: Rheinland

  • Send private message

18

Friday, July 8th 2011, 5:04pm

Schön, dass Du Dir das anschauen willst. :)

Schon eine Idee hierzu (siehe oben)?
"Beim Starten der Maschine kommt übrigens ein Bildschirm wie im Foto. Das bleibt einige Zeit stehen (gefühlt 1-2 min),
dann wird weiter gebootet und 3sat erscheint als IPTV.
Ausgabe übrigens alles nur über HDMI, kein Monitor angeschlossen."
VDR: ASRock ION 330-HT, yaVDR 0.4, linux-media-dkms TT-connect S2-3650 CI (DVB-S2 an USB, CI ungetestet), TeVii S660 (DVB-S2 an USB), Cinergy S2 USB HD (DVB-S2 an USB), HDMI mit Ton an 42"-LCD, MCE-Fernbedienung auch zum Einschalten (beim ASRock ION 330HT mitgeliefert)
VDR im Ruhestand: Xeatre 6100 pro mit easyVDR 0.6.0 mit VDR 1.4.7 (FF, Budget)
sonstige PVR: uralte Erfahrungen mit Topfield PVR 4000 und früher Grundig SeleXX (verschrottet)

gda

Im Forum Zuhause

Posts: 13,073

Location: HH

  • Send private message

19

Friday, July 8th 2011, 5:07pm

Schön, dass Du Dir das anschauen willst. :)

Schon eine Idee hierzu (siehe oben)?
"Beim Starten der Maschine kommt übrigens ein Bildschirm wie im Foto. Das bleibt einige Zeit stehen (gefühlt 1-2 min),
dann wird weiter gebootet und 3sat erscheint als IPTV.
Ausgabe übrigens alles nur über HDMI, kein Monitor angeschlossen."

Das interessiert mich jetzt nicht so sonderlich, weil ich denke, dass das mit der Anbindung der Platte per USB zusammenhängen könnte.

Gerald

HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 12.04.2, Plex Media Server
Zbox HD-ID40, OpenELEC 4.0.2, PLEXBMC

20

Friday, July 8th 2011, 6:05pm

Na nun sach schon, dass er den Thread highjacked und einfach mal die ... halten soll ;)

Similar threads

Used tags

0.4pre1, yaVDR