You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

41

Friday, August 31st 2007, 11:24pm

Wenn kein Bootloader installiert ist, ist es kein Wunder das daß Ding nicht bootet. ;)
Die Installationsfiles funktionieren, den lilo aufruf habe ich leicht abgeändert verwendet, weil ich berfürchtet habe das ohne angabe des Laufwerk lilo mir evtl. den Bootloader auf meiner Workstation HDD installiert und nicht auf der VDR-Platte.

Source code

1
lilo -b /dev/sde -r mnt/


Wobei /dev/sde die für den SMT-7020S vorgesehen Festplatte an meinem IDE/USB Adapter ist und mnt/ das lokale Verzeichnis unter dem bei mir das Rootverzeichnis von /dev/sde3 gemountet war. Wenn bei dir die lilo.conf fehlt hast du evtl. nicht alle Pakete installiert. Bei mir ist zumindest ein lilo.conf nach der Installation vorhanden gewesen.

Update: Die lilo.conf ist in dem Archiv zenslack-1.0-rc35-kernel-0.tar.gz enthalten.

Ins BIOS kommste mit der ENTF oder F2 Taste im Bootscreen, ich hämmere immer auf beiden rum und kann dir daher nicht genau sagen welche von beiden es genau war. ;)

This post has been edited 2 times, last edit by "Ioannis" (Aug 31st 2007, 11:28pm)


42

Friday, August 31st 2007, 11:45pm

HI

Quoted

Wobei /dev/sde die für den SMT-7020S vorgesehen Festplatte an meinem IDE/USB Adapter ist

also hat lilo dem Eintrag das er von sde starten soll und somit startet er nicht mehr von hda1 was die plate aber in der samsung ist

mfg det
Jeder sollte sein Leben so leben können wie er/sie es möchte, frei und
unabhängig, in der Not anderen zur Seite stehend, nie vergessen was man
ist, eben einfach nur Mensch sein mit allen Schwächen und Stärken
Lieber stehend sterben als ewig gebückt leben

43

Friday, August 31st 2007, 11:54pm

Also bei mir hats funktioniert. Lilo ist auf der /dev/sde Platte gelandet, der Grub auf meiner Workstation hats überlebt und die Platte funktioniert 1a im Samsung, dort taucht die Platte als /dev/hda auf.

44

Saturday, September 1st 2007, 12:42am

:) Bei mir auch.

Vielen Dank!

Source code

1
2
3
4
5
cyrus:/tmp# /mnt/sbin/lilo -b /dev/sdb -r /mnt
Ignoring entry 'boot'
Warning: COMPACT may conflict with LBA32 on some systems
Warning: /dev/sdb is not on the first disk
Added Linux *

Nur wenn "Added Linux" da steht, wird auch tatsächlich was geschrieben.
Außerdem hatte ich tatsächlich nicht alle Pakete installiert. :doof

Jetzt funktioniert alles bestens! :gap

Beim ersten Rumspielen ist mir aufgefallen:
- Das Bild ist (nach alledem, was man hier gehört hat) erstaunlich gut. Sehe eigentlich keinen Unterschied zu meinem normalen VDR mit FF 1.3. Und das, obwohl die Ausgabe nur CVBS ist. Wie schalte ich denn nun auf RGB um?
- Im Standby läuft die Festplatte weiter. Kann man die da auch abschalten?
- Ins BIOS kommt man mit F2, ist aber gar nicht nötig, wenn man korrekt(!) nach der Anleitung vorgeht. ;)
- Sogar MMS inklusive Internetradio ist auf der Distribution. Genial!

freut sich der
Chickie
YAVDR 0.5 auf AsRock H61M/U3S3, Hauppauge WinTV Nova-HD-S2, Nova SD, Gainward G210, Celeron G530, 2GB, 2TB EcoGreen, Atric im Digitainer mit Thermaltake-Netzteil und Logitech Harmony.

This post has been edited 1 times, last edit by "Chickie" (Sep 1st 2007, 1:30am)


45

Saturday, September 1st 2007, 11:25am

guter Tipp dem lilo das device mitzugeben, damit ahts bei mir auch auf Anhieb funktioniert.

Source code

1
lilo -b /dev/sdb -r /hdb3


sagt mal, auf welcher IP ist das Image vorkonfiguriert damit ich erstmal von remote auf die Box komme.

Und wie kann ich bei Slackware IP und Rechnername ändern?

Grüße Christian
CKone: yavdr 0.5/2.0.6 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 11.6" Selbstbau TFT, Harmony 700, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
CKtwo: yavdr 0.5/2.0.6 auf ASUS M4A78LT-M LE, Athlon II X2 240, 2x 2GB Corsair DDR3, ASUS ENGT430 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 700, atric rev5
PowerEdge: Ubuntu Server 12.04.5 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x DD CINE-S2, Samsung 840 EVO 120GB, 3x WD Red WD30EFRX 3TB in SW Raid5

46

Saturday, September 1st 2007, 11:36am

Vorkonfiguriert ist das Teil auf DHCP, in /etc/zenslack/zen-config kannst Du die IP konfigurieren.

Gruß,
Bienchen :)

Client 1: yaVDR 0.4, ION, streamdev + sundtek SkyTV Ultimate
Client 2: yaVDR 0.4, ION, streamdev-only-Client
Server: yaVDR 0.4, i5 2500, headless, dd Cine S2 v6, 4x

[[ Ein dickes Danke an die Macher von yaVDR, die uns ein leicht aufzusetzendes, toll funktionierendes Media-Home ermöglichen! ]]


47

Saturday, September 1st 2007, 12:02pm

ok ich hab ihn, dhcp geht definitiv besser wenn beim Booten das Lan schon steckt :)

gibt es nen ssh user der per default funkt? Wie gesagt, hatte mich darauf verlassen das Teil auch ohne Keyboard in gang zu setzen...

Danke, Christian

[Edit]bin drin mit zen/zen[/Edit]
CKone: yavdr 0.5/2.0.6 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 11.6" Selbstbau TFT, Harmony 700, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
CKtwo: yavdr 0.5/2.0.6 auf ASUS M4A78LT-M LE, Athlon II X2 240, 2x 2GB Corsair DDR3, ASUS ENGT430 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 700, atric rev5
PowerEdge: Ubuntu Server 12.04.5 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x DD CINE-S2, Samsung 840 EVO 120GB, 3x WD Red WD30EFRX 3TB in SW Raid5

This post has been edited 1 times, last edit by "CKone" (Sep 1st 2007, 12:09pm)


MHi

Trainee

Posts: 84

Location: Magdeburg

Occupation: Student

  • Send private message

48

Saturday, September 1st 2007, 12:16pm

neue Version vom smtled-plugin

Ich hab das Plugin nochmal ein wenig erweitert...

Aenderung Seit 0.0.1:
- Die Fehlerled(ROT) leuchtet jetzt wenn der VDR aufnimmt.
MHi has attached the following file:
VDR1: Pentium III 500MHz, TTbudget+FF2.1, 448 MB RAM, Slackware 10.2 mit Kernel 2.6.15 und VDR 1.4.7 als diskless recording&streaming server
VDR2: Scenic XS PIII 733MHz, Hauppauge DVB-S 1.3+Skystar2, 512 MB RAM, Slackware 10.2 mit Kernel 2.6.15 und VDR 1.4.7, diskless
VDR3: Samsung SMT-7020s, Slackware 10.2 mit Kernel 2.6.15 und VDR 1.4.7, diskless

49

Saturday, September 1st 2007, 12:21pm

Quoted

Original von CKone
ok ich hab ihn, dhcp geht definitiv besser wenn beim Booten das Lan schon steckt :)

gibt es nen ssh user der per default funkt? Wie gesagt, hatte mich darauf verlassen das Teil auch ohne Keyboard in gang zu setzen...

Danke, Christian

[Edit]bin drin mit zen/zen[/Edit]


Wie wäre es, wenn du dir einfach mal den Thread im zenslack forum dazu durchliest? Sämtliche Fragen die du hier stellst sind da beantwortet.
Server: Athlon II X2 250 - Asus M3N-H HDMI - 2x1GB RAM - 3TB HDDs -
1 x Digital Devices Cine S2 V6 DVB-S2 (SD Sender im Highband funktionieren mit der Karte nach wie vor unter Linux nicht, unter Windows schon)
3 x Nova Budget (die ich eigentlich durch die Cine S2 mit Erweiterungsmodul ersetzen wollte, leider aber für die SD Sender immer noch brauche)
mit yavdr 0.4.0

50

Saturday, September 1st 2007, 12:21pm

root/smt geht auch

Gruß,
Bienchen :)

Client 1: yaVDR 0.4, ION, streamdev + sundtek SkyTV Ultimate
Client 2: yaVDR 0.4, ION, streamdev-only-Client
Server: yaVDR 0.4, i5 2500, headless, dd Cine S2 v6, 4x

[[ Ein dickes Danke an die Macher von yaVDR, die uns ein leicht aufzusetzendes, toll funktionierendes Media-Home ermöglichen! ]]


51

Saturday, September 1st 2007, 12:25pm

Quoted

Original von Egalus
...
Wie wäre es, wenn du dir einfach mal den Thread im zenslack forum dazu durchliest? Sämtliche Fragen die du hier stellst sind da beantwortet.


leider steht da nur was von samba und vdradmin Usern - die Stelle mit dem dhcp per default hätte ich auch gern gesehen...

[Edit]Sorry, das root sich von remote einloggen darf davon war ich natürlich nicht ausgegangen - ist m.E. eher unüblich...[/Edit]

Christian
CKone: yavdr 0.5/2.0.6 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 11.6" Selbstbau TFT, Harmony 700, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
CKtwo: yavdr 0.5/2.0.6 auf ASUS M4A78LT-M LE, Athlon II X2 240, 2x 2GB Corsair DDR3, ASUS ENGT430 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 700, atric rev5
PowerEdge: Ubuntu Server 12.04.5 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x DD CINE-S2, Samsung 840 EVO 120GB, 3x WD Red WD30EFRX 3TB in SW Raid5

This post has been edited 1 times, last edit by "CKone" (Sep 1st 2007, 12:31pm)


52

Saturday, September 1st 2007, 12:34pm

http://forum.zenega-user.de/index.php?sh…764&hl=netzwerk

Einmal suchen und 3 Threads durchgucken.
Server: Athlon II X2 250 - Asus M3N-H HDMI - 2x1GB RAM - 3TB HDDs -
1 x Digital Devices Cine S2 V6 DVB-S2 (SD Sender im Highband funktionieren mit der Karte nach wie vor unter Linux nicht, unter Windows schon)
3 x Nova Budget (die ich eigentlich durch die Cine S2 mit Erweiterungsmodul ersetzen wollte, leider aber für die SD Sender immer noch brauche)
mit yavdr 0.4.0

53

Saturday, September 1st 2007, 12:56pm

Geht bei irgend jemanden der Optische Digitalausgang oder ist das nicht angedacht?

54

Saturday, September 1st 2007, 7:47pm

Hi,

Ich hab mir vor ein paar Wochen einen VDR installiert (Bin also noch ein Anfänger in Sachen VDR) und wollt jetzt den SMT-7020S als Streaming Client dazu aufsetzen.

Erstmal einen großen Dank an alle Entwickler und User die dieses geniale Projekt am laufen halten :vdr1

Zurück zum Thema:
Da ich am SMT-7020S eigentlich nicht direkt aufnehmen will, wollt ich mir die Festplatte sparen und von USB Stick oder LAN booten. Das hätte folgende Vorteile:
+ muss keine neue Festplatte kaufen
+ keine Umbauten am Gerät notwendig
+ es gibt einfach keine Festplatte die neben dem Lüfter lärmen könnte

USB Stick booten hab ich schon mal probiert, bis jetzt leider erfolglos. Im Bios ist Removable Device als 1. Bootdevice eingestellt, aber keine Ahnung ob damit ein USB Stick gemeint ist und ob das überhaupt geht.
LAN Boot werd ich mir morgen mal anschauen.

Hat das schon jemand probiert (USB Stick oder LAN boot)?
Erfolgreich? und wenn ja, wie? ;)


by(e)
Orca

MHi

Trainee

Posts: 84

Location: Magdeburg

Occupation: Student

  • Send private message

55

Saturday, September 1st 2007, 10:37pm

Booten von USB geht garnicht und von LAN auch nur per etherboot auf dem dom, da gibt es zwar eine bios-option, diese funktioniert jedoch leider nicht.

Ich hab mir nen Eierlegende-wollmilchsau-dom-image gebastelt... xosl als 1. bootloader, ein dos (falls es mal ein bios update geben sollte). eine etherboot-partition und eine ext2 bootpartition. Eine SMT bootet damit aus dem LAN, die andere von einer USB-Festplatte (der Linux-Kernel muss dafuer je NFS-Root oder USB-Masstorage direkt, oder per initrd, unterstuetzen)
VDR1: Pentium III 500MHz, TTbudget+FF2.1, 448 MB RAM, Slackware 10.2 mit Kernel 2.6.15 und VDR 1.4.7 als diskless recording&streaming server
VDR2: Scenic XS PIII 733MHz, Hauppauge DVB-S 1.3+Skystar2, 512 MB RAM, Slackware 10.2 mit Kernel 2.6.15 und VDR 1.4.7, diskless
VDR3: Samsung SMT-7020s, Slackware 10.2 mit Kernel 2.6.15 und VDR 1.4.7, diskless

56

Sunday, September 2nd 2007, 10:57am

Bei mir ruckelt die Wiedergabe von via Samba gemounteten Aufnahmen.
Kann man da irgendwas dagegen machen?
Alle paar Sekunden stockt es kurz.

This post has been edited 1 times, last edit by "m0190" (Sep 2nd 2007, 10:58am)


Kleo

Intermediate

Posts: 435

Location: Berlin

Occupation: Student

  • Send private message

57

Sunday, September 2nd 2007, 5:28pm

bei mir ruckelt's auch... ;-)

@m0190

Die Beobachtung mit ruckelnden Aufnahmen via SAMBA habe ich auch gemacht.
Werde als nächstes mal NFS ausprobieren und berichten.

@all

Hat sich schon jemand mit dem Übersetzen eigener Plugins befasst?
Einige (z.B. remoteosd/remotetimers) lassen sich relativ problemlos übersetzen, andere wie text2skin erforden weitere libs
(z.B. libmagick++-dev). Hat da schon jemand Tipps?
Wahrscheinlich eher eine Frage für's Zenega-Forum.

Grüße, Kleo
VDR-Server: Avance B031 Tower, ASUS A8V DELUXE Rev. 2, Athlon 64 3200+, 3GB Corsair RAM, 2 x 500GB Samsung-501LJ, Nvidia GeForce 200MX, 2x Technisat Airstar 2 DVB-T, Ubuntu 9.04, Kernel: 2.6.28-11-server, gepatchter e-tobi-vdr-1.6.0 und Plugins: streamdev-server, live, xineliboutput

58

Sunday, September 2nd 2007, 5:32pm

RE: bei mir ruckelt's auch... ;-)

Quoted

Original von Kleo
@m0190

Die Beobachtung mit ruckelnden Aufnahmen via SAMBA habe ich auch gemacht.
Werde als nächstes mal NFS ausprobieren und berichten.

@all

Hat sich schon jemand mit dem Übersetzen eigener Plugins befasst?
Einige (z.B. remoteosd/remotetimers) lassen sich relativ problemlos übersetzen, andere wie text2skin erforden weitere libs
(z.B. libmagick++-dev). Hat da schon jemand Tipps?
Wahrscheinlich eher eine Frage für's Zenega-Forum.

Grüße, Kleo


Hm, gut, dann iiegts wohl nicht an mir mit den ruckelnden Aufnahmen.
Remotetimer hab ich auch getestet.
Ich hab VDR mal gepatched und mal nicht.


Ungepatched werden die Aufnahmen immer zuerst lokal angelegt.
Wenn ich patche, dann kann ich zB das Kanalmenü nicht mehr öffnen...

Fritzle

Intermediate

Posts: 263

Location: Freiburg

  • Send private message

59

Sunday, September 2nd 2007, 6:17pm

Hi,

habe seit Freitag auch eine Samsung SMT 7020s :-)

Gestern dann gleich eine 2,5 Zoll Platte gekauft und mal
die Soft nach dieser Anleitung installiert.

http://forum.zenega-user.de/index.php?showtopic=4590

Jetzt noch denn 2,5 Zoll nach 3,5 Zoll Adapter umbauen.

http://img364.imageshack.us/my.php?image=cimg9203aon5.jpg

Und dann mal die Platte in die Samsung einbauen.

Jetzt bin ich mir aber nicht sicher ob man den Elko-Mod
bei der Samsung auch braucht?

Tschüss

Fritzle
1: P3 1000MHz, 384MB RAM, 160GB HD, easyVDR 0.8.06 - 2 x Nova-s - MediaTomb (E19.2°E, 13.0°E)
2: Samsung SMT-7020S - MLD-2.0
3: MediaMVP - Vomp
4: Kathrein UFS-910 - BPNeutrino (28.2°E, 23.5°, E19.2°E, 16°E, 13.0°E, 9.0°E)
5: Philips Streamium Network Music Player NP2500
6: Asus O!Play HDP-R1
7: LCD Toshiba 32 R 3500 - 100Hz
8: Intel® Core™2 Duo Processor E6750, 2GB RAM, 1.2TB HD, Ubuntu 10.04LTS (Server)

Kleo

Intermediate

Posts: 435

Location: Berlin

Occupation: Student

  • Send private message

60

Sunday, September 2nd 2007, 7:18pm

RE: bei mir ruckelt's auch... ;-)

@m0190

Das mit remotetimers klingt nicht gut...
Ich dachte Patchen & Übersetzen wäre die größere Hürde.

Ich habe auch den VDR mit dem MainMenu-Hooks-Patch übersetzt und das Phänomen,
daß sich die ersetzten Menüpunkte nicht mehr öffnen lassen. Die eigentlichen Menüeinträge des remotetimer-plugins lassen sich öffnen, bleiben aber leer.
Dann steht im syslog, daß die Timereinträge nicht geparst werden können.
Das liegt bei mir allerdings daran, daß der Haupt-VDR mit DVB-t empfängt...die SMT soll aber später zu meinen Eltern und hat eine DVB-s-channels.conf.

Im Moment scheitere ich am Mounten der nfs-Freigabe meines Servers.
Das Mounten dauert extrem lange (mehrere Minuten) und dann werden die Aufnahmen im Aufnahmenmenü nicht angezeigt.
Ich mounte das Videoverzeichnis des Haupt-VDR in ein Unterverzeichnis unterhalb von /video (auf der SMT).

Irgendwie vermisse ich auch die vom ctvdr gewohnte Datei ".update",
um das Neueinlesen des Videoverzeichnisses zu initiieren. :-(


Grüße, Kleo
VDR-Server: Avance B031 Tower, ASUS A8V DELUXE Rev. 2, Athlon 64 3200+, 3GB Corsair RAM, 2 x 500GB Samsung-501LJ, Nvidia GeForce 200MX, 2x Technisat Airstar 2 DVB-T, Ubuntu 9.04, Kernel: 2.6.28-11-server, gepatchter e-tobi-vdr-1.6.0 und Plugins: streamdev-server, live, xineliboutput