You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

141

Wednesday, October 10th 2007, 9:57pm

Ok, bei einigen Sendern sehe ich diese Farbartefakte nun auch ... Das ändern der Werte für den Sharpness sowie Flicker Filter ändert daran leider auch nix.
Ohne Anwendung des tvout_setup Tool und 640x480 scheinen ja diese Artefakte nicht aufzutreten.
Liegt es also an den Settings im tvout_setup Tool? Kann man die "Settings" bei 640x480 aus dem Focus auslesen?

mein VDR Stuff... :)

Thermaltake DH101: M2N68 Plus - 1 x HD-FF-6400 - 1 x L4MV6.2
angeschlossen über (SCR Inverto Black Unicable Multiswitch UST111-CUO10-8PP an Selfsat DQ)
yavdr-0.5 - vdr-2.1.6 - Plugins: dvbhddevice - targavfd - skinnopacity - osdteletext - xmltv2vdr
Scaleo Evi: NVidia G210 - 1 x L4M V6.2 TwinS2
angeschlossen am Legacy Ausgang vom Inverto Black Unicable Multiswitch UST111-CUO10-8PP
yavdr-0.5 - vdr-2.1.6 - Plugins: softhddevice-git - dm140vfd - skinnopacity - osdteletext
RaspberryPi mit rpihddevice Plugin (NEU!) / cubieboard2 mit vdr-2.1.6 + softhddevice-git (vdpau) / OdroidU3 CE als "DesktopPC" .... :D

ITnetX

Trainee

Posts: 59

Location: Pfalz

Occupation: IT-Techniker

  • Send private message

142

Wednesday, October 10th 2007, 10:03pm

Ich hab mal en Bild hochgeladen .. das ihr vergleichen könnt ob ihr die selben Artefaktbildung habt ! Wenn bewegung im Spiel ist find ichs schlimmer!
ITnetX has attached the following image:
  • 10102007(003).jpg
Project GreenIT (Media Center made with MacMini)

143

Wednesday, October 10th 2007, 11:10pm

Quoted

Original von Maniac
So jetzt mit mehr Zeit ;)

Also Flicker Filter ist in den Focus Defaults an, den könnt ihr abstellen indem ihr im Source die Werte für an Stelle 0x24 und 0x26 auf 0x00 setzt. Da steht im Moment 0x0a und 0x10 drin.


Also irgendwie hab ich noch nicht verstanden wo ich das da im Source ändern können soll.

Soll ich das in dem Array static const unsigned char fs454_defaults[] = { ...

ändern?
Und wenn ja ...

hat sich soeben erledigt, irgendwie war ich wieder schief gewickelt und
0x00 war für mich 2 Byte gross, daher stand in dem vermeintlichen 0x24 und 0x26 immer 0x00 ;)


Leider hilft das Abschalten des Flickerfilters bei mir auch nix.
Allerdings kann man sehr schön sehen, dass der Effekt erst nach Aufruf von dem kleinen Tool passiert, also hab ich die Hoffnung, dass sich das noch hinbiegen lässt ;)
Server: Athlon II X2 250 - Asus M3N-H HDMI - 2x1GB RAM - 3TB HDDs -
1 x Digital Devices Cine S2 V6 DVB-S2 (SD Sender im Highband funktionieren mit der Karte nach wie vor unter Linux nicht, unter Windows schon)
3 x Nova Budget (die ich eigentlich durch die Cine S2 mit Erweiterungsmodul ersetzen wollte, leider aber für die SD Sender immer noch brauche)
mit yavdr 0.4.0

This post has been edited 1 times, last edit by "Egalus" (Oct 10th 2007, 11:17pm)


ITnetX

Trainee

Posts: 59

Location: Pfalz

Occupation: IT-Techniker

  • Send private message

144

Wednesday, October 10th 2007, 11:16pm

Aber das Abschalten hilft nichts! Wärs nicht einfach möglich alles raus zu hauen was in der focus2.c drinne steht und nicht zwingend nötig ist. ich geh ja davon aus das einer der gesetzten Register das Problem verursacht !
Project GreenIT (Media Center made with MacMini)

145

Wednesday, October 10th 2007, 11:30pm

Ich glaub ich hab es ;)

#define FS454_MISC 0x0E /*! Miscellaneous Bits Register*/

Wenn ich den Wert von 0x10 auf 0x30 (oder auch 0x60) änder (nein, ich hab 0 Ahnung was ich da tue!), dann sind die Artefakte weg (ist zumindest mein erster Eindruck).
Das ist der vorletzte 0x.. Wert in der 1. Zeile des Arrays, das sieht bei mir nun so aus:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
static const unsigned char fs454_defaults[] = {
                0x64, 0x00, 0x1a, 0x00, 0xd0, 0x02, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x10, 0x21, 0x30, 0x00,
                0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x60, 0x72, 0x7c, 0x00, 0x04, 0x04, 0x1f, 0x03,
                0x00, 0x00, 0x40, 0x00, 0x0a, 0x00, 0x00, 0x00, 0x0d, 0x01, 0x00, 0x00, 0x00, 0x00, 0x08, 0x11,
                0x00, 0x0f, 0x05, 0xfe, 0x0b, 0x80, 0x00, 0x00, 0x82, 0x00, 0x0c, 0x02, 0x00, 0x00, 0x01, 0x00,
                0x2a, 0x09, 0x8a, 0xcb, 0x00, 0x00, 0x8d, 0x08, 0x7c, 0x3c, 0x9a, 0x2f, 0x21, 0x01, 0x3f, 0x00,
                0x3e, 0x03, 0x1a, 0x2a, 0x1c, 0x3d, 0x14, 0x9c, 0x01, 0x00, 0xfe, 0x7e, 0x60, 0x05, 0xc8, 0x00,
                0x9c, 0x07, 0x9c, 0x00, 0x00, 0x00, 0x08, 0x04, 0x00, 0x1a, 0x55, 0x01, 0x1e, 0x07, 0x7e, 0x02,
                0x54, 0xb1, 0x04, 0x14, 0x69, 0x10, 0x00, 0xa3, 0xc8, 0x22, 0x02, 0x22, 0x3e, 0x03, 0x00, 0x20,
                0x07, 0x2f, 0x07, 0x18, 0x00, 0x00, 0x18, 0x00, 0x00, 0x13, 0x13, 0x9c, 0x03, 0x00, 0x00, 0x00,
                0x00, 0x00, 0x01, 0x0b, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0xe4, 0x00,
                0x00, 0x02, 0x4d, 0x00, 0x96, 0x00, 0x1d, 0x00, 0xa0, 0x00, 0xdb, 0x00, 0x7e, 0x00, 0x00, 0x00,
                0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0xf0, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
                0x00, 0x00, 0x00, 0x00
        };


Flickerfilter ist btw auch gerade aus bei mir.

0x20 sieht übrigens extrem genial aus ;)
Server: Athlon II X2 250 - Asus M3N-H HDMI - 2x1GB RAM - 3TB HDDs -
1 x Digital Devices Cine S2 V6 DVB-S2 (SD Sender im Highband funktionieren mit der Karte nach wie vor unter Linux nicht, unter Windows schon)
3 x Nova Budget (die ich eigentlich durch die Cine S2 mit Erweiterungsmodul ersetzen wollte, leider aber für die SD Sender immer noch brauche)
mit yavdr 0.4.0

This post has been edited 1 times, last edit by "Egalus" (Oct 10th 2007, 11:32pm)


donulfo

Professional

Posts: 701

Location: Calmbeach city / BW

Occupation: Student

  • Send private message

146

Wednesday, October 10th 2007, 11:34pm

Quoted

Original von Egalus
0x20 sieht übrigens extrem genial aus ;)

Und was hat der für ne Funktion?
VDR#1: TT FF 1.3 | Duron 2600+ | 512MB RAM | easyVDR0.62 | VDR1.4.7 | DolbyDigital 5.1 per ac3dec |ATRIC IR-Einschalter | GraphLCD | NVRAM-wakeup | WakeOnCall über FritzBox | PicoAV Board 1.1 | Atmolight mit Ikea Diodern.
VDR#2 (HDTV): yavdr 0.2 - Tevii S470 - Zotac ION ITX-F

147

Wednesday, October 10th 2007, 11:35pm

Hi,
wenn ich folgendes im OSD Setup von xinelibout ändere, dann belastet dies nun kaum noch die CPU und somit fängt hier auch das Video nicht an zu ruckeln: Unscaliertes OSD (keine Transparenz): ja

In der setup.conf:

Source code

1
xineliboutput.OSD.UnscaledAlways = 1 

mein VDR Stuff... :)

Thermaltake DH101: M2N68 Plus - 1 x HD-FF-6400 - 1 x L4MV6.2
angeschlossen über (SCR Inverto Black Unicable Multiswitch UST111-CUO10-8PP an Selfsat DQ)
yavdr-0.5 - vdr-2.1.6 - Plugins: dvbhddevice - targavfd - skinnopacity - osdteletext - xmltv2vdr
Scaleo Evi: NVidia G210 - 1 x L4M V6.2 TwinS2
angeschlossen am Legacy Ausgang vom Inverto Black Unicable Multiswitch UST111-CUO10-8PP
yavdr-0.5 - vdr-2.1.6 - Plugins: softhddevice-git - dm140vfd - skinnopacity - osdteletext
RaspberryPi mit rpihddevice Plugin (NEU!) / cubieboard2 mit vdr-2.1.6 + softhddevice-git (vdpau) / OdroidU3 CE als "DesktopPC" .... :D

This post has been edited 2 times, last edit by "Uwe" (Oct 10th 2007, 11:50pm)


ITnetX

Trainee

Posts: 59

Location: Pfalz

Occupation: IT-Techniker

  • Send private message

148

Wednesday, October 10th 2007, 11:40pm

@Egalus

Jupp funktioniert !!!
Project GreenIT (Media Center made with MacMini)

149

Wednesday, October 10th 2007, 11:41pm

Quoted

Original von donulfo

Quoted

Original von Egalus
0x20 sieht übrigens extrem genial aus ;)

Und was hat der für ne Funktion?


Ich meinte als Wert für das Register, bei dem 0x30 gut funktioniert.
0x20 macht so ne Art Falschfarbendarstellung aus dem Bild.
Server: Athlon II X2 250 - Asus M3N-H HDMI - 2x1GB RAM - 3TB HDDs -
1 x Digital Devices Cine S2 V6 DVB-S2 (SD Sender im Highband funktionieren mit der Karte nach wie vor unter Linux nicht, unter Windows schon)
3 x Nova Budget (die ich eigentlich durch die Cine S2 mit Erweiterungsmodul ersetzen wollte, leider aber für die SD Sender immer noch brauche)
mit yavdr 0.4.0

150

Wednesday, October 10th 2007, 11:42pm

Quoted

Original von ITnetX
@Egalus

Jupp funktioniert !!!


Na dann kann uns ja vielleicht noch jemand, der sich die Doku mal durchgelesen hat sagen was das genau verändert, gut möglich, dass 0x30 nicht die optimale Einstellung für das Register ist und wir das noch schöner kriegen ;)
Server: Athlon II X2 250 - Asus M3N-H HDMI - 2x1GB RAM - 3TB HDDs -
1 x Digital Devices Cine S2 V6 DVB-S2 (SD Sender im Highband funktionieren mit der Karte nach wie vor unter Linux nicht, unter Windows schon)
3 x Nova Budget (die ich eigentlich durch die Cine S2 mit Erweiterungsmodul ersetzen wollte, leider aber für die SD Sender immer noch brauche)
mit yavdr 0.4.0

donulfo

Professional

Posts: 701

Location: Calmbeach city / BW

Occupation: Student

  • Send private message

151

Wednesday, October 10th 2007, 11:45pm

UNd habt ihr nach genauerem Betrachten nun wirklich festgestellt, dass die Artefakte an den Übergängen weg sind ?also kene Bilder mehr a la 16 bit?
VDR#1: TT FF 1.3 | Duron 2600+ | 512MB RAM | easyVDR0.62 | VDR1.4.7 | DolbyDigital 5.1 per ac3dec |ATRIC IR-Einschalter | GraphLCD | NVRAM-wakeup | WakeOnCall über FritzBox | PicoAV Board 1.1 | Atmolight mit Ikea Diodern.
VDR#2 (HDTV): yavdr 0.2 - Tevii S470 - Zotac ION ITX-F

152

Wednesday, October 10th 2007, 11:48pm

Quoted

Original von Egalus
Ich glaub ich hab es ;)

#define FS454_MISC 0x0E /*! Miscellaneous Bits Register*/

Wenn ich den Wert von 0x10 auf 0x30 (oder auch 0x60) änder (nein, ich hab 0 Ahnung was ich da tue!), dann sind die Artefakte weg (ist zumindest mein erster Eindruck).
...


Super, hier sind die Farbartefakte nun auch weg! :D

Quoted

0x20 sieht übrigens extrem genial aus.

:) Erinnert mich an Fraktale *gg*

mein VDR Stuff... :)

Thermaltake DH101: M2N68 Plus - 1 x HD-FF-6400 - 1 x L4MV6.2
angeschlossen über (SCR Inverto Black Unicable Multiswitch UST111-CUO10-8PP an Selfsat DQ)
yavdr-0.5 - vdr-2.1.6 - Plugins: dvbhddevice - targavfd - skinnopacity - osdteletext - xmltv2vdr
Scaleo Evi: NVidia G210 - 1 x L4M V6.2 TwinS2
angeschlossen am Legacy Ausgang vom Inverto Black Unicable Multiswitch UST111-CUO10-8PP
yavdr-0.5 - vdr-2.1.6 - Plugins: softhddevice-git - dm140vfd - skinnopacity - osdteletext
RaspberryPi mit rpihddevice Plugin (NEU!) / cubieboard2 mit vdr-2.1.6 + softhddevice-git (vdpau) / OdroidU3 CE als "DesktopPC" .... :D

ITnetX

Trainee

Posts: 59

Location: Pfalz

Occupation: IT-Techniker

  • Send private message

153

Wednesday, October 10th 2007, 11:51pm

Mal ne vielleicht Simple Frage wie schaff ich das er mir ./tvout_setup immer läd wenn er X Gestartet hat .. ohne das ich das von Hand machen muss ?
Project GreenIT (Media Center made with MacMini)

donulfo

Professional

Posts: 701

Location: Calmbeach city / BW

Occupation: Student

  • Send private message

154

Wednesday, October 10th 2007, 11:52pm

Also hat das Bild nun FF Niveau ???

Gibt es bei der
xineliboutput.OSD.UnscaledAlways = 1

auch einen Nachteil?

Nur das er das OSD nicht mehr skaliert ?
VDR#1: TT FF 1.3 | Duron 2600+ | 512MB RAM | easyVDR0.62 | VDR1.4.7 | DolbyDigital 5.1 per ac3dec |ATRIC IR-Einschalter | GraphLCD | NVRAM-wakeup | WakeOnCall über FritzBox | PicoAV Board 1.1 | Atmolight mit Ikea Diodern.
VDR#2 (HDTV): yavdr 0.2 - Tevii S470 - Zotac ION ITX-F

155

Wednesday, October 10th 2007, 11:53pm

Quoted

Original von donulfo
Also hat das Bild nun FF Niveau ???

Gibt es bei der
xineliboutput.OSD.UnscaledAlways = 1

auch einen Nachteil?

Nur das er das OSD nicht mehr skaliert ?


Das Bild sieht mit 720x576 schon sehr gut aus! ;)
Nur, dass das OSD nicht mehr transparent ist, aber darauf kann ich gerne verzichten ;)

Bei ARD und ZDF liegt hier die CPU Usage bei ~60%, bei Tele5 so bei 45%

mein VDR Stuff... :)

Thermaltake DH101: M2N68 Plus - 1 x HD-FF-6400 - 1 x L4MV6.2
angeschlossen über (SCR Inverto Black Unicable Multiswitch UST111-CUO10-8PP an Selfsat DQ)
yavdr-0.5 - vdr-2.1.6 - Plugins: dvbhddevice - targavfd - skinnopacity - osdteletext - xmltv2vdr
Scaleo Evi: NVidia G210 - 1 x L4M V6.2 TwinS2
angeschlossen am Legacy Ausgang vom Inverto Black Unicable Multiswitch UST111-CUO10-8PP
yavdr-0.5 - vdr-2.1.6 - Plugins: softhddevice-git - dm140vfd - skinnopacity - osdteletext
RaspberryPi mit rpihddevice Plugin (NEU!) / cubieboard2 mit vdr-2.1.6 + softhddevice-git (vdpau) / OdroidU3 CE als "DesktopPC" .... :D

This post has been edited 2 times, last edit by "Uwe" (Oct 10th 2007, 11:59pm)


156

Wednesday, October 10th 2007, 11:56pm

Quoted

Original von ITnetX
Mal ne vielleicht Simple Frage wie schaff ich das er mir ./tvout_setup immer läd wenn er X Gestartet hat .. ohne das ich das von Hand machen muss ?


Packs in die xinitrc.
Allerdings weiss ich garnicht, ob das jedesmal sein muss bzw. ob x überhaupt laufen muss, denn wenn ich X abschiesse und danach wieder starte sind die Register ja auch weiterhin richtig gesetzt.

Edit:
Ich beantworte das mal selbst, es muss nicht nach dem starten von X ausgeführt werden. Ich habs jetzt in meine zendeb.local gepackt.


Schade dass die Preise so angezogen haben - aber zum Glück hab ich ja 2 Spielzeugkisten ;)
Server: Athlon II X2 250 - Asus M3N-H HDMI - 2x1GB RAM - 3TB HDDs -
1 x Digital Devices Cine S2 V6 DVB-S2 (SD Sender im Highband funktionieren mit der Karte nach wie vor unter Linux nicht, unter Windows schon)
3 x Nova Budget (die ich eigentlich durch die Cine S2 mit Erweiterungsmodul ersetzen wollte, leider aber für die SD Sender immer noch brauche)
mit yavdr 0.4.0

This post has been edited 2 times, last edit by "Egalus" (Oct 11th 2007, 12:02am)


donulfo

Professional

Posts: 701

Location: Calmbeach city / BW

Occupation: Student

  • Send private message

157

Wednesday, October 10th 2007, 11:59pm

Quoted

Original von Uwe
Das Bild sieht mit 720x576 schon sehr gut aus! ;)
Nur das es auch nicht mehr transparent ist, aber darauf kann ich gerne verzichten ;)

Also Transparent ist mir auch egal...
Ziemlich gut...ok, werde es auch gleich mal testen... Und was ist mit den Streifen bei schnellen Bewegungen? Was habt ihr drauf? Zenslack oder Debian...?

EDIT...habe gerade die Sigantur gesehen... debian etch also...
VDR#1: TT FF 1.3 | Duron 2600+ | 512MB RAM | easyVDR0.62 | VDR1.4.7 | DolbyDigital 5.1 per ac3dec |ATRIC IR-Einschalter | GraphLCD | NVRAM-wakeup | WakeOnCall über FritzBox | PicoAV Board 1.1 | Atmolight mit Ikea Diodern.
VDR#2 (HDTV): yavdr 0.2 - Tevii S470 - Zotac ION ITX-F

This post has been edited 2 times, last edit by "donulfo" (Oct 11th 2007, 12:01am)


158

Thursday, October 11th 2007, 12:01am

Quoted

Original von donulfo

Quoted

Original von Uwe
Das Bild sieht mit 720x576 schon sehr gut aus! ;)
Nur das es auch nicht mehr transparent ist, aber darauf kann ich gerne verzichten ;)

Also Transparent ist mir auch egal...
Ziemlich gut...ok, werde es auch gleich mal testen... Und was ist mit den Streifen bei schnellen Bewegungen? Was habt ihr drauf? Zenslack oder Debian...?


Streifen habe ich bisher keine gesehen, mal die Tage darauf achten! Ich benutze eine angepasste gen2vdr-1.2 Distri.

mein VDR Stuff... :)

Thermaltake DH101: M2N68 Plus - 1 x HD-FF-6400 - 1 x L4MV6.2
angeschlossen über (SCR Inverto Black Unicable Multiswitch UST111-CUO10-8PP an Selfsat DQ)
yavdr-0.5 - vdr-2.1.6 - Plugins: dvbhddevice - targavfd - skinnopacity - osdteletext - xmltv2vdr
Scaleo Evi: NVidia G210 - 1 x L4M V6.2 TwinS2
angeschlossen am Legacy Ausgang vom Inverto Black Unicable Multiswitch UST111-CUO10-8PP
yavdr-0.5 - vdr-2.1.6 - Plugins: softhddevice-git - dm140vfd - skinnopacity - osdteletext
RaspberryPi mit rpihddevice Plugin (NEU!) / cubieboard2 mit vdr-2.1.6 + softhddevice-git (vdpau) / OdroidU3 CE als "DesktopPC" .... :D

donulfo

Professional

Posts: 701

Location: Calmbeach city / BW

Occupation: Student

  • Send private message

159

Thursday, October 11th 2007, 12:02am

Ich habe auf einer BOX ein angepasstes Konni Image, und auf der anderen ein selbstzusammengebasteltes Zenslack...dann werde ich mich jetzt auch mal daran machen, die Artefakte zu beseitigen...
VDR#1: TT FF 1.3 | Duron 2600+ | 512MB RAM | easyVDR0.62 | VDR1.4.7 | DolbyDigital 5.1 per ac3dec |ATRIC IR-Einschalter | GraphLCD | NVRAM-wakeup | WakeOnCall über FritzBox | PicoAV Board 1.1 | Atmolight mit Ikea Diodern.
VDR#2 (HDTV): yavdr 0.2 - Tevii S470 - Zotac ION ITX-F

160

Thursday, October 11th 2007, 12:03am

Muss nur einmal gestartet werden, ob X dabei läuft oder nicht ist egal. Die betreffenden Register werden ja nicht von X geändert.

Edit: Laut Doku ist die Änderung von Egalus folgendes:

Universal Input Mux Control Clock Mode. Setting this bit to 1 inverts the edge on which input control is latched. See Table 5 on page 21 for mapping information

Was das jetzt wirklich macht versteh ich zwar auch nicht, aber wenns nen besseres Bild bringt solls mir egal sein ob ichs kapiere ;)

Edit 2: Ich hab mir grad nochmal den Dump der Bios Einstellungen angeguckt, dort steht das auf 0x00 könnte man ja auch nochmal testen.

This post has been edited 2 times, last edit by "Maniac" (Oct 11th 2007, 12:09am)