You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

jm24

Trainee

Posts: 166

Location: Ingolstadt

  • Send private message

381

Sunday, November 21st 2010, 3:06pm

Hallo Gero,

Nur kein Stress, bin mit dem momentanen Stand eigentlich sehr zufrieden.(habe endlich eine Übersicht über alle meine Aufnahmen und kann diese verwalten).

Was mich noch interessieren würde, kann man auch HD Filme in DVDs umwandeln?

Allerdings bekomme auch ich sobald ich einen neuen Job anlegen will oder auch nur editieren will einen Fehler (vermute mal das ist der gleich wie von
brabax22):

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
java.lang.NullPointerException
	at javax.swing.JComboBox.setModel(JComboBox.java:292)
	at de.schwarzrot.ui.service.DefaultFormComponentFactory.createComboBox(DefaultFormComponentFactory.java:229)
	at de.schwarzrot.jobedit.app.view.JobDetails.createEditor(JobDetails.java:312)
	at de.schwarzrot.jobedit.app.view.JobDetails.createView(JobDetails.java:164)
	at de.schwarzrot.ui.control.support.AbstractDetailsView.buildPanel(AbstractDetailsView.java:133)
	at de.schwarzrot.ui.control.support.AbstractDialogBase.createDialog(AbstractDialogBase.java:262)
	at de.schwarzrot.ui.control.support.AbstractDialogBase.showDialog(AbstractDialogBase.java:161)
	at de.schwarzrot.ui.control.support.AbstractDialogBase.showDialog(AbstractDialogBase.java:150)
	at de.schwarzrot.jobedit.app.JobManager.doDetail(JobManager.java:912)
	at de.schwarzrot.jobedit.app.JobManager.doCreateJob(JobManager.java:787)
	at de.schwarzrot.jobedit.app.JobManager$JobActionHandler$9.actionPerformed(JobManager.java:190)
	at de.schwarzrot.ui.action.ApplicationCommand.actionPerformed(ApplicationCommand.java:163)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1223)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1264)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:272)
	at java.awt.Component.processMouseEvent(Component.java:6267)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
	at java.awt.Component.processEvent(Component.java:6032)
	at java.awt.Container.processEvent(Container.java:2041)
	at java.awt.Component.dispatchEventImpl(Component.java:4630)
	at java.awt.Container.dispatchEventImpl(Container.java:2099)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4577)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
	at java.awt.Container.dispatchEventImpl(Container.java:2085)
	at java.awt.Window.dispatchEventImpl(Window.java:2478)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122


@Stephanchen
wie du etwas weiter oben lesen kannst geht die Installation momentan unter Win 7 nicht mehr.
Bei meinem Win 7 habe ich unter C:\Users\"Username"\AppData\Local\Temp ein file "install.err"

Gruß
Johannes
VDR-Wohnzimmer: OrigenAE S16T, BeQuiet L8 300, Intel G2020, Intel DH77EB, Zotac GT630 Zone Edition, Mystique SaTiX-S2 Dual, Samsung 840 Evo
VDR-Schlafzimmer: OrigenAE S10V, HEC P3D-300, Intel i3 530, MSI H55M-E33, Asus EN210 Silent 128-bit, Mystique SaTiX-S2 Dual V2, OCZ Vertex2

Software: Ubuntu 12.04.3 LTS, Kernel 3.8.0, Nvidia 313.30, softhddevice-git, vdr-2.0.4

This post has been edited 1 times, last edit by "jm24" (Nov 21st 2010, 3:11pm)


382

Sunday, November 21st 2010, 5:57pm

Quoted

Nur kein Stress, bin mit dem momentanen Stand eigentlich sehr zufrieden.

Hey, sowas lese ich gerne :) Danke Dir!

Quoted

Was mich noch interessieren würde, kann man auch HD Filme in DVDs umwandeln?

Yepp, ist eingebaut.
Da gab es doch mal diese Diskussion, bei der genau diese Fähigkeit gewünscht wurde.
Daraufhin habe ich die eingebaut und auch getestet - hat soweit getan.

Ich hatte auch noch den Schnitt für HD-Material in die Hintergrundverarbeitung eingebaut.
Der hat auch getan - wenn auch nicht ganz so, wie ich es gerne hätte. Um es optimal zu machen müsste ich den VDR patchen. Aber da kenne ich mich nicht aus und zum Einarbeiten fehlt mir die Zeit.

Quoted

java -jar VdrAssistant-0.1.230.jar -verbose

Hm - Du rufst den Installateur mit einer Option auf, die dieser garnicht kennt.

Probiers mal so:

Source code

1
java -jar VdrAssistant-0.1.230.jar log
Die Logausgaben sollten in der Konsole auftauchen.
Falls nicht, schau mal unter /tmp - da sollte es ein Verzeichnis .vainst### oder so geben.
Alternativ probier mal ein Verzeichnis ~/log anzulegen.

Quoted

Allerdings bekomme auch ich sobald ich einen neuen Job anlegen will oder auch nur editieren will einen Fehler (vermute mal das ist der gleich wie von
brabax22):

Nö, isses leider nich.
Wenn ich den Zeilen aus dem Log nachgehe, komme ich zu dem Schluss, dass das garnicht sein kann :schiel
Hast Du vielleicht irgendwie Dateien beim Installieren vermischt?
Da muss ich im Moment passen.
Auf welchen System probierst Du die GUI?
Müsste ich mal ne neue VM aufsetzen. Diese Woche wird's vermutlich nicht klappen - also habt bitte noch etwas Geduld.

Gruß Gero

jm24

Trainee

Posts: 166

Location: Ingolstadt

  • Send private message

383

Sunday, November 21st 2010, 7:49pm

Hast Recht gehabt, das ist wohl was bei der Installation schief gelaufen.
Hab nochmal neu installiert und schon gehts, kann Jobs erstellen und auch editieren!
Kannst den Fehler also wieder von deiner Liste streichen.

Komischerweise werden mir aber im Menü "zuzuordnende Aufnahme auswählen" nur SD Aufnahmen angezeigt. Egal ob ich MKV oder DVD wähle.
Oder muss ich da noch was beachten?

Die GUI läuft auf einem Debian Squeeze in Oracle VM.

Gruß
Johannes
VDR-Wohnzimmer: OrigenAE S16T, BeQuiet L8 300, Intel G2020, Intel DH77EB, Zotac GT630 Zone Edition, Mystique SaTiX-S2 Dual, Samsung 840 Evo
VDR-Schlafzimmer: OrigenAE S10V, HEC P3D-300, Intel i3 530, MSI H55M-E33, Asus EN210 Silent 128-bit, Mystique SaTiX-S2 Dual V2, OCZ Vertex2

Software: Ubuntu 12.04.3 LTS, Kernel 3.8.0, Nvidia 313.30, softhddevice-git, vdr-2.0.4

384

Monday, November 22nd 2010, 5:21am

Quoted

Kannst den Fehler also wieder von deiner Liste streichen.

auch nicht schlecht ;) Danke.

Quoted

Komischerweise werden mir aber im Menü "zuzuordnende Aufnahme auswählen" nur SD Aufnahmen angezeigt.

Yo, das Viehtscher ist noch nicht freigegeben.
Die Änderung ist zwar im repository, aber wie bereits geschrieben, zickt der Installer gerade rum, sodass ich erst noch größere Tests fahren muss.
Wenn Du die Änderung trotzdem testen magst, müsstest Du den svn-Stand ausfassen und selbst übersetzen. Wenn das Proggy mal installiert ist und läuft, braucht man ja "nur" die Jar-Dateien drüber bügeln. Die findest Du nach dem Build-Lauf im Verzeichnis "xdist".

Ack so ja: eine mkv-Umwandlung wird aus dem Aufnahme-Verwalter heraus gestartet.
Gewünschte Aufnahme markieren und über (Kontext-)menü heraus "Umwandlung zu mkv" aktivieren.
Die Variante bei der eine solche Umwandlung vom vdr aus angestoßen werden kann, ist in Arbeit (aber noch net fertig).

Quoted

... läuft auf einem Debian Squeeze in Oracle VM.

Perfekt - ist meine Hausmarke :)
... aber so als "Oracle VM" habe ich es jetzt zum erstem Mal bewusst gelesen.

Gruß Gero

jm24

Trainee

Posts: 166

Location: Ingolstadt

  • Send private message

385

Monday, November 22nd 2010, 4:37pm

Hallo,

Hab jetzt mal probiert die svn Version zu bauen:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
johannes@debian:/home/vdrassistant$ ant -f srbuild.xml dist
Buildfile: /home/vdrassistant/srbuild.xml

-init:

-queryrelease:

-checkLicense:

BUILD FAILED
/home/vdrassistant/srbuild.xml:152: Execute failed: java.io.IOException: Cannot run program "/home/vdrassistant/../common/bin/checkLicense.pl": java.io.IOException: error=2, No such file or directory
	at java.lang.ProcessBuilder.start(ProcessBuilder.java:460)
	at java.lang.Runtime.exec(Runtime.java:593)
	at org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.java:827)
	at org.apache.tools.ant.taskdefs.Execute.launch(Execute.java:445)
	at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:459)
	at org.apache.tools.ant.taskdefs.ExecTask.runExecute(ExecTask.java:635)
	at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:676)
	at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:502)
	at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
	at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
	at org.apache.tools.ant.Task.perform(Task.java:348)
	at org.apache.tools.ant.Target.execute(Target.java:390)
	at org.apache.tools.ant.Target.performTasks(Target.java:411)
	at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1360)
	at org.apache.tools.ant.Project.executeTarget(Project.java:1329)
	at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
	at org.apache.tools.ant.Project.executeTargets(Project.java:1212)
	at org.apache.tools.ant.Main.runBuild(Main.java:801)
	at org.apache.tools.ant.Main.startAnt(Main.java:218)
	at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
	at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)
Caused by: java.io.IOException: java.io.IOException: error=2, No such file or directory
	at java.lang.UNIXProcess.<init>(UNIXProcess.java:148)
	at java.lang.ProcessImpl.start(ProcessImpl.java:65)
	at java.lang.ProcessBuilder.start(ProcessBuilder.java:453)
	... 23 more

Total time: 1 second
johannes@debian:/home/vdrassistant$ 

Muss ich zum bauen noch was einrichten??
Finde keine checkLicense.pl

Gruß
Johannes
VDR-Wohnzimmer: OrigenAE S16T, BeQuiet L8 300, Intel G2020, Intel DH77EB, Zotac GT630 Zone Edition, Mystique SaTiX-S2 Dual, Samsung 840 Evo
VDR-Schlafzimmer: OrigenAE S10V, HEC P3D-300, Intel i3 530, MSI H55M-E33, Asus EN210 Silent 128-bit, Mystique SaTiX-S2 Dual V2, OCZ Vertex2

Software: Ubuntu 12.04.3 LTS, Kernel 3.8.0, Nvidia 313.30, softhddevice-git, vdr-2.0.4

386

Tuesday, November 23rd 2010, 5:05am

Quoted

Muss ich zum bauen noch was einrichten?

Auf der Webseite zu VdrAssistant gibt es ein Kapitel, das sich mit dem Bau der Quellen beschäftigt.
Hast Du das gelesen, bzw. die Schritte befolgt?

Gruß Gero

jm24

Trainee

Posts: 166

Location: Ingolstadt

  • Send private message

387

Tuesday, November 23rd 2010, 4:54pm

Servus,

Oh, das tut mir Leid!
Hab wiedermal nicht gelesen, sondern zuerst gejammert.

Nun hat auch das bauen geklappt, werde dann mal etwas rumprobieren.

Gruß
Johannes
VDR-Wohnzimmer: OrigenAE S16T, BeQuiet L8 300, Intel G2020, Intel DH77EB, Zotac GT630 Zone Edition, Mystique SaTiX-S2 Dual, Samsung 840 Evo
VDR-Schlafzimmer: OrigenAE S10V, HEC P3D-300, Intel i3 530, MSI H55M-E33, Asus EN210 Silent 128-bit, Mystique SaTiX-S2 Dual V2, OCZ Vertex2

Software: Ubuntu 12.04.3 LTS, Kernel 3.8.0, Nvidia 313.30, softhddevice-git, vdr-2.0.4

jm24

Trainee

Posts: 166

Location: Ingolstadt

  • Send private message

388

Sunday, November 28th 2010, 4:40pm

Hallo,


Hab mal probiert eine DVD aus einem HD Film zu erzeugen.
Muss man im Job Menü den eigentlich was beim max Requant Faktor
verstellen?

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
DVDProcess: started processing at: Tue Nov 23 16:30:16 CET 2010
PREPARE: directory >/videoarbeit/test5/VDRSYNC.0< created.
DVDProcess: pre-check step #4
DVDProcess: pre-check step #3
DVDProcess: pre-check step #2
DVDProcess: pre-check step #1
DVDProcess: pre-check step #0
DVDProcess: Step >DemuxStep< seems already been done. So start with the rest
DVDProcess: Step >RequantStep< passed input-check, so start processing ...
REQUANT: sum of video-files: 2.0078358866424003E9
REQUANT: sum of audio-files: 1.47938112E8
REQUANT: total: 6.004209666E9
REQUANT: totalSize seems to fit into target ...
REQUANT: execute(E): echo
DVDProcess: Step #1 >RequantStep< passed output check ...
DVDProcess: Step >MuxStep< passed input-check, so start processing ...
MUX: execute(S): cat
MUX: /bin/bash: null: Kommando nicht gefunden.
DVDProcess: Step >MuxStep< failed - abort processing at: Tue Nov 23 16:30:18 CET 2010


Hab als Ausgabe DVD-SL gewählt, was hat den dann das "REQUANT: totalSize seems to fit into target ..." zu bedeuten? Das müsste doch kleiner sein.
Welches Kommando wird den nicht gefunden, etwa "cat"?

Gruß
Johannes
VDR-Wohnzimmer: OrigenAE S16T, BeQuiet L8 300, Intel G2020, Intel DH77EB, Zotac GT630 Zone Edition, Mystique SaTiX-S2 Dual, Samsung 840 Evo
VDR-Schlafzimmer: OrigenAE S10V, HEC P3D-300, Intel i3 530, MSI H55M-E33, Asus EN210 Silent 128-bit, Mystique SaTiX-S2 Dual V2, OCZ Vertex2

Software: Ubuntu 12.04.3 LTS, Kernel 3.8.0, Nvidia 313.30, softhddevice-git, vdr-2.0.4

389

Monday, November 29th 2010, 8:28am

Moin moin,

Quoted

Muss man im Job Menü den eigentlich was beim max Requant Faktor
verstellen?

Hey, die Frage könnte von Radio Eriwan stammen ;)

Mit dem Requant-Faktor legst Du fest, um wieviel das Endprodukt gegenüber dem Quellmaterial komprimiert werden darf. Mit einem Faktor von 0 wird garnicht komprimiert.

Quoted

was hat den dann das "REQUANT: totalSize seems to fit into target ..." zu bedeuten? Das müsste doch kleiner sein.

Hm, wenn Du ne dopplseitige DVD ausgewählt hast, könnte das passen.

Quoted

MUX: /bin/bash: null: Kommando nicht gefunden.

Für die Verarbeitung von TS zu DVD muss ffmpeg mit x264-Unterstützung installiert sein.
Wenn Du dann noch ungeschnittenes TS-Material verarbeiten willst, muss auf dem Verarbeiter ein vdr mit Version > 1.7.10 installiert sein. Der muss nicht für Anzeige oder Aufnahme funktionieren, nur installiert sein.
Der neue Installateur wird die ganzen Möglichkeiten prüfen - wenn er denn mal fertsch wird :O

Vielleicht liegt es auch nur daran, dass die System-Konfiguration erweitert werden muss?
Schau Dir mal die Datei

Source code

1
/etc/.java/.systemPrefs/VDRAssistant/de/schwarzrot/app/config/SystemDefault
an.
Dort müsste es folgende Einträge geben (Groß-/klein-Schreibung bitte beachten!):

Source code

1
  <entry key="fFmpegPath" value="/usr/local/bin/ffmpeg"/>
Den Pfad zu ffmpeg musst Du natürlich an Dein System anpassen.

Wenn Du TS-Dateien schneiden willst, sollten noch folgende Einträge dazu kommen:

Source code

1
2
  <entry key="cutHDenabled" value="Y"/>
  <entry key="cutterPath" value="/usr/bin/vdrdevel"/>
Auch hier solltest Du den Pfad zum vdr anpassen.

Dann ist natürlich noch der Eintrag "recordingRoot" wichtig. Wenn der Eintrag nicht stimmt, klappt kein TS-Schnitt.

Hoffe das hilft Dir weiter.

Gruß Gero

jm24

Trainee

Posts: 166

Location: Ingolstadt

  • Send private message

390

Friday, December 3rd 2010, 10:48am

Servus,

So hab mal etwas getestet, das es vorher nicht ging lag am fehlenden ffmpeg eintrag.

Hab auch nochmal mit einer SD Aufnahme (Sat1) probiert, dabei ist mir aufgefallen, daß die DVD Erstellung manchmal klappt und dann beim gleichen Film auch wieder nicht.
In den Logs ist auffällig, das wenn die Erstellung erfolgreich war, eine Größe erkannt wird

Source code

1
DEMUX: sum-size of recording #0 => 214199656 Bytes

Beim nächsten Versuch wird dann beim gleichen Film keine Größe mehr erkannt:

Source code

1
DEMUX: sum-size of recording #0 => 0 Bytes

Hab die logs mit ultraedit verglichen, das war der einzige Unterschied den ich gesehen habe.

Die Umwandlung einer HD Aufnahme (Das Erste HD) läuft jetzt auch schon weiter, stop aber dann mit folgender Meldung:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
DVDProcess: Step >AuthorStep< failed processing with: 
java.lang.NullPointerException
	at de.schwarzrot.menu.authoring.domain.support.AbstractDescriptionMenue.generateDescriptionMenue(AbstractDescriptionMenue.java:96)
	at de.schwarzrot.menu.authoring.domain.support.AbstractDescriptionMenue.genMenue(AbstractDescriptionMenue.java:524)
	at de.schwarzrot.menu.authoring.domain.support.AbstractMenueBase.createMenue(AbstractMenueBase.java:102)
	at de.schwarzrot.menu.authoring.AuthorBase.authorMenue4Script(AuthorBase.java:125)
	at de.schwarzrot.jobs.processing.AuthorStep.workOut(AuthorStep.java:271)
	at de.schwarzrot.jobs.processing.support.AbstractProcessStep.process(AbstractProcessStep.java:105)
	at de.schwarzrot.jobs.processing.support.AbstractProcess.run(AbstractProcess.java:344)
	at de.schwarzrot.jobs.processing.app.JobProcessor.run(JobProcessor.java:208)
	at de.schwarzrot.app.support.ServiceLauncher.start(ServiceLauncher.java:102)
	at de.schwarzrot.jobs.processing.app.JobProcessor.main(JobProcessor.java:336)
DVDProcess: Step >AuthorStep< failed - abort processing at: Wed Dec 01 10:36:52 CET 2010


Was mir noch aufgefallen ist, im Menü "zuzuordnende Aufnahme auswählen" wenn man dort eine Aufnahme auswählen will, muss man die irgendwie besonders markieren???
Meistens wird die Aufnahme nur nach mehrmaligem klicken übernommen.

Hab die Logs mal beigefügt.

Gruß
Johannes
jm24 has attached the following files:
  • HD.txt (107.37 kB - 33 times downloaded - latest: Jun 3rd 2013, 2:15am)
  • SD-IO.txt (123.58 kB - 38 times downloaded - latest: May 16th 2013, 1:11pm)
  • SD_NIO.txt (18.44 kB - 38 times downloaded - latest: May 26th 2013, 2:53pm)
VDR-Wohnzimmer: OrigenAE S16T, BeQuiet L8 300, Intel G2020, Intel DH77EB, Zotac GT630 Zone Edition, Mystique SaTiX-S2 Dual, Samsung 840 Evo
VDR-Schlafzimmer: OrigenAE S10V, HEC P3D-300, Intel i3 530, MSI H55M-E33, Asus EN210 Silent 128-bit, Mystique SaTiX-S2 Dual V2, OCZ Vertex2

Software: Ubuntu 12.04.3 LTS, Kernel 3.8.0, Nvidia 313.30, softhddevice-git, vdr-2.0.4

391

Friday, December 3rd 2010, 1:06pm

Quoted

So hab mal etwas getestet

Danke Dir! - Schön dass Du Rückmeldung gibst!

Quoted

Hab auch nochmal mit einer SD Aufnahme (Sat1) probiert, dabei ist mir aufgefallen, daß die DVD Erstellung manchmal klappt und dann beim gleichen Film auch wieder nicht.

Hm, also das hatte ich noch nicht.
Vielleicht sollte wir Dein System mal genauer unter die Lupe nehmen.
Alles was nicht h264 ist, wird nach wie vor mit projectX verarbeitet - und der Prozess ist (zumindest bei mir) sehr stabil und ständig in Gebrauch.

Bei den Größen hatte ich schon einen Fehler im JDK, der plötzlich alle Vergleiche von Dezimalzahlen absurd werden ließ. Ich habe daraufhin meinen Code umgestellt und seither keine Probleme mehr erlebt.

Eine andere Ursache könnten auch die Spracheinstellungen sein, da ich viele Ausgaben auswerte.
Wenn sich an den Ausgaben dann was ändert, klappt die Mustererkennung natürlich nimmer.

Wie gesagt - dem sollten wir nachgehen.

Quoted

Die Umwandlung einer HD Aufnahme (Das Erste HD) läuft jetzt auch schon weiter, stop aber dann mit folgender Meldung

Die Stelle deutet daraufhin, dass mit der Auswahl der Tonspuren was nicht stimmt.
Ich tippe mal, dass Du bei der Job-Erstellung "ausgewählte Tonspuren" aktiviert hast, dann aber bei den Filmen keine Tonspuren für die Verwendung markiert hast, oder die Menüeinträge nicht ausgefüllt hast.

Könntest Du das bitte überprüfen?

Ich gebe bei der Joberstellung ja schon eine Warnmeldung aus, wenn keine Tonspuren markiert sind. Da die Verarbeitung im Hintergrund läuft, kann ich an der Stelle keine Meldungen mehr zum Frontend schicken.

Quoted

Was mir noch aufgefallen ist, im Menü "zuzuordnende Aufnahme auswählen" wenn man dort eine Aufnahme auswählen will, muss man die irgendwie besonders markieren???

markieren - Ja
besonders markieren - Nein

Man kann mehrere Aufnahmen mit Strg- oder Shift-Taste auswählen. Bei Druck auf OK sollten die markierten Aufnahmen übernommen werden.

Gruß Gero

jm24

Trainee

Posts: 166

Location: Ingolstadt

  • Send private message

392

Sunday, December 5th 2010, 4:31pm

So weiter gehts:

Wegen dem sum-size 0 bytes Fehler hab ich jetzt nochmal eine längere SD Aufnahme probiert, mit dem gleichen Ergebnis, geht leider auch nicht.

Desweiteren scheint das ganze unwillkürlich aufzutreten, bei einer Aufnahme klappt die erste Umwandlung und dann keine mehr.
Bei einer anderen Aufnahme wiederrum klappt auch schon die erste Umwandlung nicht.

Die Umwandlung der HD Aufnahmen klappt jetzt!!
Hab einfach nochmal bei allen Aufnahmen die Audio Details editiert, gespeichert. Anscheinend hatte ich wie du schon vermutet hattest eine Spur vergessen.

Das für mich momentan viel größere Problem ist dass ich es wirklich nicht schaffe eine Aufnahme im Menü "zuzuordnende Aufnahme auswählen" auszuwählen.
Wenn ich eine Aufnahme auswähle, dann ist diese mit dem blauen Cursor markiert. Klicke ich dann auf "Zuordnen" bleibt zu 99% das Fenster "zugeordnete Aufnahmen" leer.
Um die Wandlung der HD Aufnahmen zu testen hab ich teilweise minutenlang immer wieder die gleiche aufnahme ausgewählt bis diese dann zugeordnet wurde, bei mir klappt die Zuordnung anscheinend immer nur zufällig.


Folgende Fehlermeldung gibts wenn ich auf Job duplizieren klicke:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
java.lang.NullPointerException
	at java.lang.String.<init>(String.java:147)
	at de.schwarzrot.jobs.domain.JobInfo.<init>(JobInfo.java:116)
	at de.schwarzrot.jobs.domain.Job.<init>(Job.java:100)
	at de.schwarzrot.jobedit.app.JobManager.doCloneJob(JobManager.java:805)
	at de.schwarzrot.jobedit.app.JobManager$JobActionHandler$13.actionPerformed(JobManager.java:225)
	at de.schwarzrot.ui.action.ApplicationCommand.actionPerformed(ApplicationCommand.java:163)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1223)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1264)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:272)
	at java.awt.Component.processMouseEvent(Component.java:6267)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
	at java.awt.Component.processEvent(Component.java:6032)
	at java.awt.Container.processEvent(Container.java:2041)
	at java.awt.Component.dispatchEventImpl(Component.java:4630)
	at java.awt.Container.dispatchEventImpl(Container.java:2099)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4577)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
	at java.awt.Container.dispatchEventImpl(Container.java:2085)
	at java.awt.Window.dispatchEventImpl(Window.java:2478)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
(nicht daß ich das jetzt unbedingt brauche, hab halt einfach rumprobiert)

Gruß
Johannes
VDR-Wohnzimmer: OrigenAE S16T, BeQuiet L8 300, Intel G2020, Intel DH77EB, Zotac GT630 Zone Edition, Mystique SaTiX-S2 Dual, Samsung 840 Evo
VDR-Schlafzimmer: OrigenAE S10V, HEC P3D-300, Intel i3 530, MSI H55M-E33, Asus EN210 Silent 128-bit, Mystique SaTiX-S2 Dual V2, OCZ Vertex2

Software: Ubuntu 12.04.3 LTS, Kernel 3.8.0, Nvidia 313.30, softhddevice-git, vdr-2.0.4

This post has been edited 2 times, last edit by "jm24" (Dec 5th 2010, 4:39pm)


393

Sunday, December 5th 2010, 5:03pm

Hi Du,

Quoted

Desweiteren scheint das ganze unwillkürlich aufzutreten, ...

Sorry, aber den Eindruck habe ich bei den meisten Fehlern, die Du gerade so beschreibst.

Habe spaßeshalber mal Job duplizieren auf dem letzten Job angewandt - kein Problem.

Beschreibe mir doch bitte mal, wie Du Deine jetzige Version erstellt hast und welche jvm Du verwendest.
Wenn ich es richtig im Kopf habe, verwendest Du Debian squeeze?

Interessant wäre jetzt die jvm und vielleicht noch die ant-Version.
Ich vermute/hoffe, dass Du ansonsten die squeeze Pakete verwendest.
Mit welcher Installer-Version hast Du die Datenbank angelegt?

Wenn Du "which java" ausführst und Dir den Wert von JAVA_HOME anschaust - zeigen die beide zum gleichen JDK?

Also ich installiere mir jeweils das aktuelle JDK nach /opt und ändere nur den Link auf das Verzeichnis.
Somit ist mein JAVA_HOME immer gleich.
Pfad und JAVA_HOME setze ich via /etc/profile

Wie sieht es denn mit der verwendeten HW aus?
Wieviel Hauptspeicher hat die Mühle?

Irgendwas scheint bei Dir mächtig in Unordnung zu sein. Habe leider noch kein Gespür dafür, was es sein könnte. Also bitte meine Fragen nicht krumm nehmen.

Gruß Gero

jm24

Trainee

Posts: 166

Location: Ingolstadt

  • Send private message

394

Tuesday, December 7th 2010, 7:01pm

Hallo,

Also, da das Arbeitstier eh in letzter Zeit irgendwie unstabil lief und ich da mit meiner rumprobiererei und wahrscheinlich auch unwissenheit ziemlich viel verbogen hab,
hab ich nochmal alles platt gemacht und neu installiert.

Bevor ich dir jetzt wieder Rückmeldung geben kann, dauert es allerdings noch etwas.

Ein Frage bezüglich ffmpeg hätte ich noch, installierst du das Paket von debian oder baust du es selbst wegen der x264 Unterstützung?

Gruß
Johannes
VDR-Wohnzimmer: OrigenAE S16T, BeQuiet L8 300, Intel G2020, Intel DH77EB, Zotac GT630 Zone Edition, Mystique SaTiX-S2 Dual, Samsung 840 Evo
VDR-Schlafzimmer: OrigenAE S10V, HEC P3D-300, Intel i3 530, MSI H55M-E33, Asus EN210 Silent 128-bit, Mystique SaTiX-S2 Dual V2, OCZ Vertex2

Software: Ubuntu 12.04.3 LTS, Kernel 3.8.0, Nvidia 313.30, softhddevice-git, vdr-2.0.4

395

Wednesday, December 8th 2010, 4:36am

Quoted

Also, da das Arbeitstier eh in letzter Zeit irgendwie unstabil lief

Dann solltest Du Deine HW aber auch mal tschäcken ;)
Insbesondere memtest und smartctl einsetzen - manchmal liegt die Instabilität an ganz anderer Ecke, wie erwartet.

Quoted

Ein Frage bezüglich ffmpeg hätte ich noch, installierst du das Paket von debian oder baust du es selbst wegen der x264 Unterstützung?

Seinerzeit, als die Diskussion um Unterstützung von HD-Aufnahmen für DVD-Produktion lief, habe ich mir den ffmpeg selbst gebacken, weil der offizielle fehlerhaft war.
Inzwischen ist fast ein halbes Jahr vergangen, ich denke, dass sich da an offizieller Seite sehr wohl was geändert hat.
Letztlich bleibt einem aber nur übrig, es auszuprobieren.
... und ja, ich verwende noch den selbstgebackenen vom Juli.

Vielleicht noch nen Tip zum Ausprobieren / System verbiegen:
Ich habe mir unter /usr/local eine eigene Platte gemountet und von Paketen, die ich selbst backen will, packe ich die Quellen nach /usr/local/src und verwende nicht die Option --prefix
Auf diese Weise werden die Binärdateien nach /usr/local/bin installiert (und das liegt sowieso im Suchpfad - und zwar vor /usr/bin sodass gar kein Systemeingriff notwendig ist).
Wenn ich dann ein "sauberes" System testen will, klinke ich meine Platte von /usr/local aus und alles ist so, wie es von offizieller Seite geliefert wird.

Bei den Paketen, die Binär geliefert werden, habe ich mir angewöhnt, die nach /opt zu installieren.
Auch dort habe ich eine separate Platte eingebunden.
Wie gesagt, java verwende ich von Sun, installiere das nach /opt/java und passen den Link an.
Das sieht dann bei mir so aus:

Source code

1
2
3
4
5
6
7
8
9
10
lrwxrwxrwx  1 root root       11  5. Dez 17:14 jdk -> jdk1.6.0_22
drwxr-xr-x 10 root   root    4096 19. Nov 2008  jdk1.6.0_10
drwxr-xr-x 11 root   root    4096 16. Dez 2008  jdk1.6.0_11
drwxr-xr-x 10 root   root    4096 14. Mär 2009  jdk1.6.0_12
drwxr-xr-x 11 root   root    4096 28. Mär 2009  jdk1.6.0_13
drwxr-xr-x 10 root   root    4096  4. Jan 2010  jdk1.6.0_17
drwxr-xr-x 11 root   root    4096  1. Feb 2010  jdk1.6.0_18
drwxr-xr-x 11 root   root    4096 15. Apr 2010  jdk1.6.0_20
drwxr-xr-x 10 root   root    4096 25. Aug 07:55 jdk1.6.0_21
drwxr-xr-x 10 root   root    4096  5. Dez 17:13 jdk1.6.0_22
Meine /etc/profile habe ich folgendermaßen erweitert (am Ende zugefügt):

Source code

1
2
3
export ANT_HOME='/opt/java/apache-ant-1.8.0'
export JAVA_HOME='/opt/java/jdk'
export PATH="$JAVA_HOME/bin:$ANT_HOME/bin:$PATH"
Damit ist wieder sicher gestellt, dass alle Anwendungen, die Java verwenden, das gleiche JDK benutzen.

Vielleicht magst Du es so ja auch mal ausprobieren.

Gruß Gero

This post has been edited 1 times, last edit by "geronimo" (Dec 8th 2010, 4:40am)


jm24

Trainee

Posts: 166

Location: Ingolstadt

  • Send private message

396

Wednesday, December 8th 2010, 7:49pm

Servus,

Danke für die Super Tips!!
Genauso hab ich das jetzt gemacht, echt toll.

Nur leider startet jetzt der Installer nicht mehr.
Direkt nachdem ich das System neu aufgesetzt hatte ging es noch.
(hab auch schon neu runtergeladen, wenn ich den Nvidia vdpau Treiber als run Datei teste gehts auch)
Hab seitdem nur ffmpeg, x264 gebaut.

Anscheinend hab ich wiedermal was verbogen, weiß auch nicht wie ich das immer wieder schaffe.

Source code

1
johannes@debian-server:~/Downloads$ ./VdrAssistant-0.1.230.run

Jetzt blinkt nur noch der Cursor, normalerweise sollte ja "checking integrity of installer" kommen.

Tut mir echt leid, dass ich dich immer mit solchen Sachen nerve.

Gruß
Johannes
VDR-Wohnzimmer: OrigenAE S16T, BeQuiet L8 300, Intel G2020, Intel DH77EB, Zotac GT630 Zone Edition, Mystique SaTiX-S2 Dual, Samsung 840 Evo
VDR-Schlafzimmer: OrigenAE S10V, HEC P3D-300, Intel i3 530, MSI H55M-E33, Asus EN210 Silent 128-bit, Mystique SaTiX-S2 Dual V2, OCZ Vertex2

Software: Ubuntu 12.04.3 LTS, Kernel 3.8.0, Nvidia 313.30, softhddevice-git, vdr-2.0.4

This post has been edited 3 times, last edit by "jm24" (Dec 8th 2010, 8:04pm)


397

Thursday, December 9th 2010, 3:58am

Moin moin,

Jetzt verwirrst Du mich aber.
Ich hatte Dich so verstanden, dass Du Dir mein Proggy selbst übersetzt. Egal.

Quoted

Jetzt blinkt nur noch der Cursor, normalerweise sollte ja "checking integrity of installer" kommen.

Könnte es sein, dass Du nach dem Ändern von /etc/profile nicht neu gestartet hast?
Die Datei wird zu einem so frühen Stadium im Boot-Prozess verwendet, dass Du Änderungen in einem laufenden System nicht aktivieren kannst.

Hast Du in Deinem neu aufgesetzten System auch dialog und Co installiert und ausprobiert?
Wie sieht es mit den Schreibrechten im /tmp Verzeichnis aus?
Die sollten normalerweise nie geändert werden.

Ansonsten kann ich nur empfehlen, für so große Aktionen Dir eine Todo-Liste zu schreiben.
Einen Server neu aufzusetzen ist nicht gerade eine Kleinigkeit. Dann mal eben ffmpeg zu schnitzen ...
Bist Du sicher, dass das noch notwendig ist?
Na und wenn Du von einem vdpau-Treiber schreibst, dann klingt das für mich, als würdest Du auf einem VDR-System arbeiten.
Hm - also da komm ich mit meinen Vorstellungen von VDR, Arbeitstier o.ä. ganz schön ins Straucheln.
... und wenn Du dann noch VdrAssistant selber bauen willst, ist das alles andere als trivial.
Da hilft es ungemein, wenn man ne Checkliste hat, auf der man einzelne Punkte abhaken kann.
So kann man die einzelnen Punkte auch schon auf dem Papier prüfen, ehe man ein System verbiegt ;)

Gruß Gero

jm24

Trainee

Posts: 166

Location: Ingolstadt

  • Send private message

398

Thursday, December 9th 2010, 3:25pm

Oh, anscheinend habe ich dich wirklich etwas verwirrt:

- Wollte den Installer nur benutzen, um die Grundinstallation vorzunehmen, und dann die jar Dateien ersetzen. Da du ja mal erwähnt hattest, dass der aktuelle Installer noch nicht funktioniert.

- keine sorge, das wird und war kein VDR, hatte nur in meiner Verzweiflung, den Treiber benutzt um zu testen um überhaupt noch run Dateien funktionieren.
(momentan läuft dort nur ein Raid für Aufnahmen, und eben dann der Vdrassistant.)

- Das mit der Liste mache ich tatsächlich auch schon länger so, da ich mir das alles schon gar nicht mehr merken kann.

Hab jetzt dank dir auch rausgefunden warum der Installer nicht mehr ging!
/usr/local unmount --> siehe da Installer geht wieder
(da hätte ich wohl auch gleich dran denken müssen, hast es ja vorher extra erwähnt)
also waren wirklich meine selbstgebauten Pakete schuld.
Es geht auch wenn ich den /usr/local/bin Ordner lösche.

Jetzt muss ich nur noch herausfinden welches bin schuld ist.
Aber am besten ist es wahrscheinlich einfach die fertigen Pakete zu nehmen.

Gruß
Johannes
VDR-Wohnzimmer: OrigenAE S16T, BeQuiet L8 300, Intel G2020, Intel DH77EB, Zotac GT630 Zone Edition, Mystique SaTiX-S2 Dual, Samsung 840 Evo
VDR-Schlafzimmer: OrigenAE S10V, HEC P3D-300, Intel i3 530, MSI H55M-E33, Asus EN210 Silent 128-bit, Mystique SaTiX-S2 Dual V2, OCZ Vertex2

Software: Ubuntu 12.04.3 LTS, Kernel 3.8.0, Nvidia 313.30, softhddevice-git, vdr-2.0.4

This post has been edited 4 times, last edit by "jm24" (Dec 9th 2010, 5:02pm)


399

Friday, December 10th 2010, 6:02am

Moin moin,

Quoted

Wollte den Installer nur benutzen, um die Grundinstallation vorzunehmen, und dann die jar Dateien ersetzen. Da du ja mal erwähnt hattest, dass der aktuelle Installer noch nicht funktioniert.

Yepp - Du hast völlig recht! - Ich war zu flüchtig beim Lesen und Antworten :(

Quoted

hatte nur in meiner Verzweiflung, den Treiber benutzt um zu testen um überhaupt noch run Dateien funktionieren.

Hm - schlechter Test. Denn der bringt Dich keinen Schritt weiter.

Der Bash-Installer bei mir ist ein einfaches Shellscript, also bringt es mehr, dort am Anfang ein "-x" einzufügen. In der ersten Zeile eines Shellscriptes steht ja "#!/bin/bash" und das muss erweitert werden zu "#!/bin/bash -x"
... dann wird jede einzelne Zeile ausgegeben und man sieht sofort, wo es hängt.
Es könnte sein, dass dann im Installer die Prüfsummen geändert werden müssen, bin mir nicht sicher, ob die erste Zeile bereits in der Prüfung mit drin ist.
Also einfach mal ausprobieren.
Wenn der Fehler lokalisiert und ausgemerzt ist, solltest Du das "-x" wieder entfernen. Es ist sehr wahrscheinlich, dass mit dem Parameter die Installation nicht klappt.

Quoted

/usr/local unmount --> siehe da Installer geht wieder

Phuh - da hast Du Dir aber ein Ei gelegt.

Also wenn Du die HW (insbesondere den Hauptspeicher) geprüft hast, dann ist da was ganz grob im Argen. Das kenne ich weder von x264, noch von ffmpeg - ich weiß schon garnimmer, wann mir sowas zuletzt passiert ist.

Wenn es mit /usr/local tatsächlich was gibt, was den Installer blockiert - dann heißt das /usr/local platt machen und nomml anfangen.

Vielleicht probierst Du erstmal die Pakete von debian multimedia. Es könnte ja gut sein, dass Du garnimmer selber bauen musst. Der Systemstabilität würde das auf jeden Fall gut tun.

Nur mal so am Rande: ich finde, ein Rechner, auf dem ein Raid läuft ist nicht unbedingt der beste Spielplatz für eigene Experimente ;)

Gruß Gero

jm24

Trainee

Posts: 166

Location: Ingolstadt

  • Send private message

400

Friday, December 10th 2010, 5:16pm

Hallo,

Quoted

Nur mal so am Rande: ich finde, ein Rechner, auf dem ein Raid läuft ist nicht unbedingt der beste Spielplatz für eigene Experimente

Ja, da ich das gleiche System sowieso auch noch in der Virtualbox laufen habe sollte ich wohl besser dort testen und ausprobieren.

Im Virtuellen Debian hab ich jetzt auch den Fehler gesucht, und nachdem ich das "-x" eingefügt hatte auch gefunden, es hängt tatsächlich am selbst gebauten lxdvdrip
(das hatte ich zum testen mal gebaut, wollte ich anstatt requant benutzen)

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
johannes@debian-server:~/Downloads$ ./VdrAssistant-0.1.230.run
+ crc=3087979805
+ md5=bceb7487a9336d6316ae2b0114debf9a
++ which dvdauthor
+ dvdauthor=/usr/bin/dvdauthor
++ which spumux
+ spumux=/usr/bin/spumux
++ which java
+ java=/opt/java/jdk/bin/java
+ projectX=/usr/share/project-x/ProjectX.jar
+ lafDesktop=de.schwarzrot.ui.MDIDesktop
++ which genisoimage
+ genisoimage=/usr/bin/genisoimage
++ which convert
+ convert=/usr/bin/convert
++ which ppmtoy4m
+ ppmtoy4m=/usr/local/bin/ppmtoy4m
++ which mpeg2enc
+ mpeg2enc=/usr/local/bin/mpeg2enc
++ which mplex
+ mplex=/usr/local/bin/mplex
++ which tcrequant
+ requantizer=
++ which requant_lxdvdrip
+ /usr/local/bin/requant_lxdvdrip
Gruß
Johannes
VDR-Wohnzimmer: OrigenAE S16T, BeQuiet L8 300, Intel G2020, Intel DH77EB, Zotac GT630 Zone Edition, Mystique SaTiX-S2 Dual, Samsung 840 Evo
VDR-Schlafzimmer: OrigenAE S10V, HEC P3D-300, Intel i3 530, MSI H55M-E33, Asus EN210 Silent 128-bit, Mystique SaTiX-S2 Dual V2, OCZ Vertex2

Software: Ubuntu 12.04.3 LTS, Kernel 3.8.0, Nvidia 313.30, softhddevice-git, vdr-2.0.4

This post has been edited 1 times, last edit by "jm24" (Dec 10th 2010, 5:16pm)