You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

241

Saturday, August 28th 2010, 5:37am

Argh :angryfire :§$%

Musste gerade feststellen, dass der Würgaround für die Rechnererkennung unter Debian squeeze nimmer funzt. Frust!

Also werde ich das umstellen und das externe ping verwenden. Das scheint ja zu funktionieren.
Leider begebe ich mich dadurch in eine Abhängigkeit zu Sprachen - aber einen Tod muss man bekanntlich sterben.

Könnte bitte jemand von den Windows-7-Benutzern mir die Ausgaben von ping posten?
1. ping zu einem bekannten und erreichbaren Rechner
2. ping zu einem bekannten aber nicht laufenden/erreichbaren Rechner
3. ping zu einem unbekannten Rechner

Wenn's geht, als Bildschirmfoto, sodass ich auch sehen kann, wo Leerzeilen auftreten.

Wenn jemand ein englisches Windows hat, würde mich eine solche Ausgabe auch freuen!


//Update:
Das Chaos ist noch viel größer, als ich angenommen hatte :(
Musste feststellen, dass ich unter squeeze mit Eclipse nimmer debuggen kann. Die Recherche führte zu diesem Fehler, der aber von Debian an Sun/Oracle weiter gereicht wurde und jetzt kann man anfangen zu orakeln, wann sich an der Ecke was tut ... :O

Glücklicherweise gibt es einen Fix. Bitte unter ubuntu genauso probieren, wie unter Debian squeeze

Source code

1
sudo sed -i 's/net.ipv6.bindv6only\ =\ 1/net.ipv6.bindv6only\ =\ 0/' /etc/sysctl.d/bindv6only.conf && sudo invoke-rc.d procps restart
Danach funktioniert mein altes Testproggy wieder und ich hoffe, dass der Rest ebenso wieder funzt.

Gruß Gero

P.S.: habe gerade eine Installation durchgeführt, den Scanlauf ausgeführt und wie man sehen kann, können auch die Details angezeigt werden (alles auf Debian Squeeze).
geronimo has attached the following file:
  • va-recscan-03.png (147.91 kB - 466 times downloaded - latest: May 28th 2013, 1:45pm)
Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

This post has been edited 3 times, last edit by "geronimo" (Aug 28th 2010, 7:45am)


jm24

Intermediate

Posts: 172

Location: Ingolstadt

  • Send private message

242

Saturday, August 28th 2010, 8:44am

Servus,

Hab dir die Pings angehängt, die Reihenfolge ist so wie von dir beschrieben.

Mein Problem, dass die Details nicht angezeigt werden, bezieht sich natürlich wie sollte es auch anders sein, auf meinen Win 7 Desktop.
(Bin aber noch nicht dazu gekommen die neue Version zu testen, da ich gerade dabei bin den Desktop neu aufzusetzen, melde mich sobald ich was neues weiß)

Gruß
Johannes
jm24 has attached the following file:
  • ping.jpg (118.12 kB - 442 times downloaded - latest: May 28th 2013, 1:45pm)
VDR-Wohnzimmer: OrigenAE S16T, BeQuiet L8 300, Intel G2020, Intel DH77EB, Zotac GT630 Zone Edition, Mystique SaTiX-S2 Dual, Samsung 840 Evo
VDR-Schlafzimmer: OrigenAE S10V, HEC P3D-300, Intel i3 530, MSI H55M-E33, Asus EN210 Silent 128-bit, Mystique SaTiX-S2 Dual V2, OCZ Vertex2

Software: Ubuntu 12.04.4 LTS, Kernel 3.8.0-39, Nvidia 331.67, softhddevice-git, vdr-2.1.6

243

Saturday, August 28th 2010, 8:53am

Hey,

danke schön für den Schnappschuss.
Sieht aus, als hätte sich seit XP an der Ecke nix geändert - das ist ja jut.

Muss allerdings gestehen, nachdem es mit dem Fix wieder funktioniert, hat die Änderung keine große Prio mehr, zumal die Abhängigkeiten auf Änderungen noch größer sind, als jetzt. Du hattest es ja unter Win7 auch schon hinbekommen.
Könnte also sein, wenn nur IPv6 aktiv ist, dass dann kein Java mehr funzt - aber das ist kein Problem um das ich mich kümmern kann und will ;)
Da mache ich lieber mal an meinem Sicherungskonzept weiter ;)

Gruß Gero
Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

244

Monday, August 30th 2010, 1:21pm

Hi Gero,
ich habe nun auch probiert das Ganze bei mir zu installieren. :-)

Zuerst mal ein paar Infos zu meinen Randbedingungen:
Ich habe einen potenten Rechner unter Ubuntu 10.04, der als Arbeitstier (um in Deiner Sprache zu bleiben) dienen soll. Dann einen VDR (YaVDR) und mehrere Rechner, auf denen die VDRAssistant-Oberfläche installiert werden soll.

Ich habe mit dem Arbeitstier angefangen, und habe dort über den Menupunkt SRSrvJobProzessor unter anderem die Datenbank erfolgreich angelegt. Das war als mysql-DAU nicht ganz einfach, Deine Doku auf der Webseite ist für mich leider oft sehr verwirrend gewesen.
Hat aber nun doch geklappt und ich habe auch einiges notiert. Wenn das hier bei mir mal läuft hab ich hoffentlich mal die Zeit, das ins Wiki zu klopfen. ;)

Die Menupunkte SRSrvEPGProzessor und SRSrvRecordingManager habe ich noch nicht angefasst. Auch auf dem VDR habe ich noch nix installiert. Ich dachte, ich installier mal den JobProzessor und dann auf einem (Windows) Notebook die Oberfläche dazu. Und dann nach und nach die restlichen Funktionen.

Nun bekomme ich die Oberfläche aber nicht installiert, wenn ich das .jar-File starte, kommt kurz das VDRAssistant-Logo und auf der Kommandozeile ein Hinweis auf die Lizenz und eine Linie voll mit Punkten. Danach verschwindet das Logo wieder und das war's.

Was für Sachen muß ich denn mindestens installieren, dass das mit der Oberfläche funktioniert?

Gruß
Stefan
Mein VDR: link :D

245

Monday, August 30th 2010, 3:09pm

Hi,

willkommen im Club :)

Quoted

Das war als mysql-DAU nicht ganz einfach, Deine Doku auf der Webseite ist für mich leider oft sehr verwirrend gewesen.

Wenn Du mir und Deinen Nachfolgern helfen willst, wäre es hilfreich für mich zu erfahren, was denn verwirrend für Dich war.
Denn erst wenn ich das weiß, dann kann ich die Seiten überarbeiten und umformulieren.

Weißt Du, ich verwende das Proggy bald täglich, wenn ich zuhause bin und mit Datenbanken bin ich quasi auch per Du, also fällt es mir nicht leicht, mir vorzustellen mich welchen Schwierigkeiten ein Neueinsteiger zu kämpfen hat.
Also ich würde mich freuen, wenn Du nicht bis zur Erstellung (D)eines Wiki-Beitrages warten würdest, sondern mir gleich reinen Wein einschenken ;)

Quoted

Die Menupunkte SRSrvEPGProzessor und SRSrvRecordingManager habe ich noch nicht angefasst.

Ist jetzt kein Problem, aber wenn Du vorhast, die auch noch zu verwenden (und zumindest den SRSrvRecordingManager solltest Du wollen ;) - denn ohne den geht nicht viel), dann macht es wenig Sinn, die nicht gleich beim ersten Mal mit zu installieren. Der RecordingManager-Dienst hat auch die geringsten Abhängigkeiten ...

... aber egal - so wie Du es willst, so ist es richtig :)

Quoted

Nun bekomme ich die Oberfläche aber nicht installiert, wenn ich das .jar-File starte, kommt kurz das VDRAssistant-Logo und auf der Kommandozeile ein Hinweis auf die Lizenz und eine Linie voll mit Punkten. Danach verschwindet das Logo wieder und das war's.

Das war hier im Fred schon öfters angesprochen und ist auch in den FAQ auf der Webseite aufgeführt (falls es nicht schon klar ist: FAQ heißt auf Deutsch HGF).
Einfach nomml nachlesen.
Die Voraussetzungen sind auch für jeden Rechner bzw. Anwendungsteil beschrieben.

Nochmal - ich habe alles, was mir einfiel auf der Webseite beschrieben. Wenn dort was fehlt oder unklar ist, bitte melden. Bin gerne bereit, dort zu ändern, aber dazu muss ich wissen, wo's klemmt.

Gruß Gero
Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

246

Monday, August 30th 2010, 4:14pm

Hi,
nunja, was fehlt mir. Eigentlich alles. (und Deine Seite kenne ich nun schon fast auswendig) :-)
Du schreibst zum Beispiel, auf Deiner Installationsseite als Mindestvoraussetzung, dass eine bash und ein mysql-client installiert sein muß. Als User, der noch nie was mit mysql gemacht hat, habe ich halt mysql-client installiert. Bis ich Depp gemerkt habe, dass damit keine Datenbank angelegt werden kann waren schon 1-2 Std mit lesen vergangen.
Dann mysql-server installiert und schon ging's weiter.

In Deinen HGFs und zum großen Teil hier im Thread geht's ja um fehlenden Netzwerkzugriff. Ich kann aber zumindest mit den gängigen Tools wie ping und nslookup alle Rechner in allen Richtungen auflösen, das ist kein Problem. Heute Abend probier ich aber noch Dein iplookup-Testtool (das übrigens auf Deinen Seiten überhaupt nicht auftaucht).

Dann schreibst Du, bei den Voraussetzungen für den Installateur des Desktops, dass man ein sun-java braucht und weiteres steht unter dem Punkt Desktop. Ich finde keinen Punkt Desktop...
Sun-Java (bzw. nun Oracle-Java) ist auf dem neuesten Stand trotzdem beendet sich der Installateur sofort wieder wie oben beschrieben ohne irgendeine Angabe von einem Fehler.
- Braucht man da noch ein mysql-Paket, wie z. B. Connector/J???
- Gibt's da unter Windows irgendwo ein log, in dem mehr steht als ein paar Punkte???
- Heißt es, wenn sich der Installateur so sang- und klanglos wieder beendet, dass ich doch noch einen Fehler in der Namensauflöung meines Rechners habe?

Gruß
Stefan
Mein VDR: link :D

This post has been edited 2 times, last edit by "stmeyer" (Aug 30th 2010, 4:15pm)


247

Monday, August 30th 2010, 5:16pm

Hallo Stefan!

Ich bin leider in letzter Zeit ueberhaupt nicht mehr zum experimentieren gekommen, aber nur so ein Gedanke:

Hast du auch wirklich ein Sun-Java-JDK installiert oder doch nur die JRE?

Glaube mich an dieses Verhalten mit dem kurz erscheinenden Logo erinnern zu koennen.

Vielleicht aber auch nicht...;)

Gruss!
VDR: Athlon64 X2 5600+, Gigabyte GA-M68SM-S2L, 2 GB, Nova-HD-S2, SkyStar 2.6D, 60GB-SSD als Systemplatte, 2x 4TB WD Green, Antec Fusion Silver V2, yavdr 0.5

248

Monday, August 30th 2010, 5:34pm

Hallo Stefan,

danke für die Info! Das ist doch mal was, mit dem ich was anfangen kann :)

Quoted

Als User, der noch nie was mit mysql gemacht hat, habe ich halt mysql-client installiert. Bis ich Depp gemerkt habe, dass damit keine Datenbank angelegt werden

Ok, jetzt hast Du mich aber eiskalt erwischt.
Das habe ich auf meinen Seiten in der Tat nicht geschrieben.
Sorry, aber ich dachte, dass "client" im Namen ausdrücken würde, dass man sich damit nur irgendwo anmelden kann. Klar das das "irgendwo" natürlich vorhanden sein muss.
Ich dachte, das würde schon mit dem Bildle deutlich werden - aber ok - werde ich nacharbeiten.

Quoted

In Deinen HGFs und zum großen Teil hier im Thread geht's ja um fehlenden Netzwerkzugriff.

Das ist jetzt aber nicht richtig.
Zugegeben, dieser Thread hat inzwischen Mammut-Ausmaße angenommen, die kaum lesbar sind, aber der von Dir beschriebene Fehler ist z.B. im 4. Punkt der HGF und im ersten Post dieses Freds beschrieben.
In beiden Beschreibungen habe ich ausgeführt, was man machen muss, um weiter zu kommen.

Quoted

- Braucht man da noch ein mysql-Paket, wie z. B. Connector/J???

Nein! - außer den aufgeführten Abhängigkeiten wird nichts benötigt. Den Connector bringt der Installer mit.

Quoted

Heißt es, wenn sich der Installateur so sang- und klanglos wieder beendet, dass ich doch noch einen Fehler in der Namensauflöung meines Rechners habe?

Ok, will Dich nicht länger auf die Folter spannen - es reicht nicht, das Java von sun/oracle zu installieren, man muss es auch aktivieren ;)
Wie das geht, kannst Du nachlesen ...
Falls Du händisch Deinen Pfad verändert hast, dann muss das sun-jdk am Anfang des Pfades kommen und nicht am Ende.

@Hera
Wie sieht es bei Dir aus? Läuft es inzwischen bei Dir?

Gruß Gero
Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

249

Monday, August 30th 2010, 6:35pm

Hi Gero,

Quoted

Ok, jetzt hast Du mich aber eiskalt erwischt.
Das habe ich auf meinen Seiten in der Tat nicht geschrieben.
Sorry, aber ich dachte, dass "client" im Namen ausdrücken würde, dass man sich damit nur irgendwo anmelden kann. Klar das das "irgendwo" natürlich vorhanden sein muss.
Ich dachte, das würde schon mit dem Bildle deutlich werden - aber ok - werde ich nacharbeiten.

Auf Deiner steht halt beim Arbeitstier mysql-client, aber ich hätte ja auch mitdenken können, deswegen schrieb ich ja "Ich Depp..."

Quoted


Das ist jetzt aber nicht richtig.
Zugegeben, dieser Thread hat inzwischen Mammut-Ausmaße angenommen, die kaum lesbar sind, aber der von Dir beschriebene Fehler ist z.B. im 4. Punkt der HGF und im ersten Post dieses Freds beschrieben.
In beiden Beschreibungen habe ich ausgeführt, was man machen muss, um weiter zu kommen.

Das betrifft doch aber nur Linux. Die Oberfläche will ich hier auf einem Windows (XP) Notebook installieren. Und da ist mit Sicherheit nur oracle-java installiert...

Quoted


Falls Du händisch Deinen Pfad verändert hast, dann muss das sun-jdk am Anfang des Pfades kommen und nicht am Ende.

Was heißt das nun? Ich gehe auf dem Notebook folgendermassen vor: Ich starte eine Commandshell, wechsle in das Verzeichnis in dem VDRAssistant.jar liegt und mache das:

Source code

1
java -jar vdrassistant-0.1.226.jar

Ergebnis sind nur die Punkte und sonst nix weiter...

Installiert ist java-jre. Ein java -version ergibt:

Source code

1
2
3
java version "1.6.0_21"
Java<TM> SE Runtime Enviroment <build 1.6.0_21-b07>
Java HotSpot<TM> Client VM <build 17.0-b17, mixed mode, sharing>

Brauche ich, wie Hera vermutet, entgegen Deiner Meinung, doch das JDK?

Ein Test mit Deinem IPLookup-Tool sagt übrigens auf allen Rechnern in alle Richtungen host [...] is reachable...

Gruß
Stefan
Mein VDR: link :D

This post has been edited 2 times, last edit by "stmeyer" (Aug 30th 2010, 6:41pm)


250

Monday, August 30th 2010, 7:07pm

So, jetzt habe ich mir nochmal Deine Web-Seiten angeschaut. Ich bin wirklich ein Oberdepp!

Ich habe die links rechts oben auf Deinen Seiten nun erst entdeckt (und ich war schon zig mal drauf), also z.B. Unter Installation dann Voraussetzung/Arbeitstier/VDR/Desktop.

Da steht nun doch noch deutlich mehr, was mir bei der seitherigen Installation sehr geholfen hätte. Da steht dann auch das mit dem mysql-Server). Sorry!!!!

Bei meinem oben beschriebenen Problem mit dem Desktop-Installer hilft mir das aber auch nicht weiter...

Gruß
Stefan
Mein VDR: link :D

This post has been edited 1 times, last edit by "stmeyer" (Aug 30th 2010, 7:14pm)


251

Monday, August 30th 2010, 8:52pm

Hallo Gero!

Ich bin einfach noch nicht dazu gekommen weiter an dem Thema zu werkeln.
Momentan habe ich sehr viel mit meiner Firma "um die Ohren" und renoviere nebenbei noch ein Haus. Da bleibt nicht viel freie Zeit die ich dann mal wieder fuer mein Hobby nutzen kann.

Du hattest aber nach meinen prinzipiellen Plaenen gefragt: Ich moechte zunaechst die grafische Oberflaeche auf dem Arbeitstier einrichten. Das hatte ja soweit funktioniert das der lustige kleine gelbe Kerl aufs Laufband gesprungen ist. Danach hatte ich nicht mehr viel Zeit und Du hast inzwischen scheinbar einige Aenderungen/Korrekturen vorgenommen. Muss ich neu installieren?
Unter Win7 hatte ich ja staendig das Problem mit dem "NOT reachable" zum Arbeitstier. Zum vdr hatte das geklappt. Konnte mich hier auch noch nicht mit den Dateien hosts.allow und hosts.denz beschaeftigen.

Vielleicht komme ich am WE mal wieder zu einer ruhigen Stunde. Ich lese nach wie vor regelmaessig mit und kann es eigentlich kaum erwarten bis ich die Funktionalitaet hier von verschiedenen Rechnern aus nutzen kann. Das hat mir bisher echt gefehlt.

So gesehen bleibe ich an der Front, auch wenn ich gerade mit eingezogenem Kopf im Graben liege ;)

Gruss!
VDR: Athlon64 X2 5600+, Gigabyte GA-M68SM-S2L, 2 GB, Nova-HD-S2, SkyStar 2.6D, 60GB-SSD als Systemplatte, 2x 4TB WD Green, Antec Fusion Silver V2, yavdr 0.5

252

Tuesday, August 31st 2010, 5:30am

Moin moin,

Quoted

Das betrifft doch aber nur Linux. Die Oberfläche will ich hier auf einem Windows (XP) Notebook installieren. Und da ist mit Sicherheit nur oracle-java installiert...

Öhm - unter Windows habe ich den Effekt noch nicht erlebt.
Außer vielleicht: startest Du den Installer vielleicht als Benutzer mit eingeschränkten Rechten?
Zur Installation solltest Du schon lokaler Admin sein.

Was ich mir sonst noch vorstellen könnte, ist das Du ein Java von M$ drauf hast.

Quoted

Brauche ich, wie Hera vermutet, entgegen Deiner Meinung, doch das JDK?

Check erst mal die anderen beiden Punkte.
Wenn das nix bringt, dann installiere Dir bitte ein JDK - und berichte!

Quoted

Ein Test mit Deinem IPLookup-Tool sagt übrigens auf allen Rechnern in alle Richtungen host [...] is reachable...

Lach - ja, mit XP war die Welt noch in Ordnung ;)

Quoted

Ich habe die links rechts oben auf Deinen Seiten nun erst entdeckt (und ich war schon zig mal drauf), also z.B. Unter Installation dann Voraussetzung/Arbeitstier/VDR/Desktop.

Irgend einen Tip, wie man die deutlicher machen könnte?
Oder anders herum gefragt, wo würdest Du spontan nach Unterkapiteln suchen?

Quoted

So gesehen bleibe ich an der Front, auch wenn ich gerade mit eingezogenem Kopf im Graben liege

... alles klar :)
gibt auch mal wieder besseres Wetter ;)

Gruß Gero
Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

253

Tuesday, August 31st 2010, 9:12am

Hi,

Quoted

Irgend einen Tip, wie man die deutlicher machen könnte?
Oder anders herum gefragt, wo würdest Du spontan nach Unterkapiteln suchen?

Es würde auf jeden Fall auffallen, wenn die Menupunkte (links in der Leiste) die Unterpunkte haben, dort auch "aufklappen". Andererseits würde ich meine Blindheit nicht auf andere übertragen wollen, die haben das wohl gleich gesehen...

Quoted

Öhm - unter Windows habe ich den Effekt noch nicht erlebt.
Außer vielleicht: startest Du den Installer vielleicht als Benutzer mit eingeschränkten Rechten?
Zur Installation solltest Du schon lokaler Admin sein.

Ich starte das schon als Admin, mit dem User hatte ich ja auch die java-Software installiert.

Quoted

Was ich mir sonst noch vorstellen könnte, ist das Du ein Java von M$ drauf hast.

Wie schon geschrieben habe ich das JRE von der Oracle-Seite runtergeladen und installiert. Außerdem bekomme ich ja folgende Ausgabe, wenn ich die Java-Version abfrage:

Source code

1
2
3
java version "1.6.0_21"
Java<TM> SE Runtime Enviroment <build 1.6.0_21-b07>
Java HotSpot<TM> Client VM <build 17.0-b17, mixed mode, sharing>


Ich habe gestern Abend noch ein bißchen weiter gemacht. Mittlerweile ist auf dem VDR der vdrproxy installiert und auf dem Arbeitstier der ServiceEPGProzessor. :)

Dann habe ich auf dem Arbeitstier mal testweise versucht den Dsktop-Installer auszuführen, da passiert das Gleiche wie unter Windows (nur Punkte) aber da gibt's zusätzlich die Fehlermeldung, dass kein Sun JDK installiert ist.
Also hab ich unter windows das aktuelle jdk von Oracle runtergeladen und installiert. Leider keine Änderung...:(

Hast Du sonst noch eine Idee?

Gruß
Stefan
Mein VDR: link :D

254

Tuesday, August 31st 2010, 9:51am

Quoted

Hast Du sonst noch eine Idee?

Yo, da fällt mir schon noch was ein ;)

... aahlso:
  • die Systemvariable TMP ist nicht gesetzt
  • die Systemvariable TMP zeigt zu einem Verzeichnis, das nicht existiert
  • Du bist nicht in dem Verzeichnis, in dem der Installer liegt, sondern rufst die Jar-Datei über einen relativen Pfad auf
  • Du bist (wie ich) gewöhnt, die Pfad-Vervollständigung wie unter Linux mit Tab zu verwenden. Das führt unter Windoof dazu, dass er möglicherweise eine falsche Datei verwendet, denn er nimmt zum Vervollständigen die erste Datei die passt und weist nicht (wie Linux) auf mögliche alte Naive hin.
Ich habe es gerade unter XP mit dem aktuellen JRE probiert. Der Installer startet auf jeden Fall.
Gut, wenn die Punkte durchgelaufen sind, dauert der Start noch ne ganze Weile - die Ecke ist zäh. Allerings bleiben das Logo und der Mauszeiger in Wartestellung, d.h. man könnte drauf kommen, dass Win noch beschäftigt ist.

Ob JRE zum kompletten Installieren und Bedienen der Anwendung reicht - kann ich nicht sagen. Hab's noch nicht ausprobiert.

Du könntest beim Start den Parameter "log" mitgeben. Dann kommt zumindest ein kleiner Hinweis dazu, was gerade probiert wird. Also z.B. so:

Source code

1
java -jar VdrAssistant-0.1.226.jar log
Ist nicht viel, was an der Stelle ausgegeben wird, aber man kann sehen, ob z.B. der Rückwärtspfad stimmt, etc.

Gruß Gero

P.S. Wenn Du die gleichen Probleme unter Linux hast, wäre der erste Kandidat, dass das falsche Java aktiv ist. Ansonsten auch tmp überprüfen und sicherstellen, dass man im Verzeichnis steht, in dem der Installer liegt.
Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

This post has been edited 1 times, last edit by "geronimo" (Aug 31st 2010, 9:54am)


255

Tuesday, August 31st 2010, 10:28am

Hi,

Quoted

die Systemvariable TMP ist nicht gesetzt
die Systemvariable TMP zeigt zu einem Verzeichnis, das nicht existiert

Das kann ich erst heute Abend kontrollieren, da die Variable aber standardmässig auf jedem normal installierten Windows eingerichtet ist, wird das auf dem Notebook auch so sein. Klär ich aber.

Quoted

Du bist nicht in dem Verzeichnis, in dem der Installer liegt, sondern rufst die Jar-Datei über einen relativen Pfad auf
Du bist (wie ich) gewöhnt, die Pfad-Vervollständigung wie unter Linux mit Tab zu verwenden. Das führt unter Windoof dazu, dass er möglicherweise eine falsche Datei verwendet, denn er nimmt zum Vervollständigen die erste Datei die passt und weist nicht (wie Linux) auf mögliche alte Naive hin.

Ich bin sicher in dem Verzeichnis und ich rufe auch sicher die richtige Datei auf. Wenn ich was Falsches ausführen würde, würden ja auch die Punkte nicht kommen...

Das mit dem log mach ich natürlich auch. Bin gespannt.

Was macht denn der Desktop-Installer am Anfang? Sucht er das Netz ab, ob irgendwo ein SRServiceManager-Dienst läuft?

Gruß
Stefan
Mein VDR: link :D

256

Tuesday, August 31st 2010, 11:16am

Hier mal die Ausgabe auf meinem PC (ohne Verbindung zur VDR bzw. Arbeitstier).

Gruß Stefan
stmeyer has attached the following file:
  • cmd.jpg (68.66 kB - 264 times downloaded - latest: Mar 31st 2013, 11:07pm)
Mein VDR: link :D

257

Tuesday, August 31st 2010, 12:26pm

Hi,

langsam siehst Du mich radlos ...

Bin auf jeden Fall schon mächtig gespannt auf die Auflösung ;)

Quoted

Was macht denn der Desktop-Installer am Anfang? Sucht er das Netz ab, ob irgendwo ein SRServiceManager-Dienst läuft?

Nö, der Installer braucht doch keinen Hintergrund-Dienst - und selbst wenn, würde das erst viel später passieren.

Nein, der Startvorgang des Java-Installers ist ein Hack speziell für die Windows-Anwender. Der Installer, ist eigentlich ein Archiv mit vielen Jar-Dateien. Da man die aber nicht aus einem Archiv direkt verwenden kann, muss das Archiv erstmal ausgepackt werden.
Wenn ich dann aber die Bibliotheken verwende, sperrt Windows die, sodass ich sie nimmer löschen kann.
Dazu kommt, dass in einem laufenden Java-Programm das Arbeitsverzeichnis nicht gewechselt werden kann, also habe ich den Installer 2-geteilt. Der eine Teil (der die Punkte malt) entpackt das Archiv in ein temporäres Verzeichnis und startet dort drin den 2. Teil des Installers.
Der startet aber in einer neuen VM, weil ich das aktuelle Verzeichnis wechsle - deshalb kann das sehr zäh / langwierig werden.
Nach getaner Arbeit startet der Installer wieder das ursprüngliche Archiv in dem Verzeichnis, wo die Installation begonnen wurde und der - kwasi 3. Teil der Installation - löscht alles aus dem temporären Verzeichnis.

Vielleicht hilft Dir das ja bei der Fehlersuche.

... dass die Platte voll ist, kann nicht sein?

Gruß Gero
Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

258

Tuesday, August 31st 2010, 1:20pm

Hi,

Quoted

langsam siehst Du mich radlos ...

Das wird schon... :)

Ich habe gerade in dem temporären Verzeichnis Deine entpackten Files gefunden (Ordner va-install und darunter jede Menge weitere Ordner und Files). (Platte ist nicht voll...)

Ich bin nun zu va-install gewechselt und habe dort

Source code

1
java -jar Vdrassistant.jar

ausgeführt. Dabei kommt dann folgendes log zustande:

Kannst Du damit was anfangen, bzw. kann ich was anderes probieren???

Gruß
Stefan
stmeyer has attached the following file:
  • log.txt (8.37 kB - 32 times downloaded - latest: Jun 9th 2013, 7:28pm)
Mein VDR: link :D

259

Tuesday, August 31st 2010, 1:46pm

Hi,


Quoted

Ich bin nun zu va-install gewechselt und habe dort

Source code

1
java -jar Vdrassistant.jar 
ausgeführt.

fast richtig :)

VdrAssistant ist die fertige GUI-Anwendung. Die bringt gleich zu Anfang den mysql-Fehler, weil die Einstellungen ja noch nicht geschrieben wurden. Das macht der Installer.
Sonst könnte ich ja sagen, kopier die Dateien nach xy und gut ist - aber ganz so einfach ist es nicht :O
... das Kopieren der Dateien ist fast der unwichtigste Teil.

Der Installateur heißt "SRJInstaller.jar" - wenn Du den aus dem va-install-Verzeichnis aufrufst mit den Parametern wie oben gepostet, dann könnte es vielleicht klappen - wobei, das "develop" könntest Du wech lassen.

Zwecks Fehlersuche könntest Du den richtigen Installer (also VdrAssistant-0.1.226.jar) mal mit Parameter dump aufrufen und mir das Ergebnis zukommen lassen.

Gruß Gero
Ich bin verantwortlich für das, was ich schreibe, nicht für das, was Du verstehst!

260

Tuesday, August 31st 2010, 2:06pm

Hi,

Quoted

Der Installateur heißt "SRJInstaller.jar" - wenn Du den aus dem va-install-Verzeichnis aufrufst mit den Parametern wie oben gepostet, dann könnte es vielleicht klappen - wobei, das "develop" könntest Du wech lassen.

Was heißt "develop" weglassen?

Der Aufruf

Source code

1
 java -jar SRJInstaller.jar

ergibt ein sofortiges "invalid Call!"

Hier das log von dem Aufruf

Source code

1
java -jar VdrAssistant-0.1.226.jar dump


Ein paar Werte sind ausgeixxt (Host-, Servernamen)

Gruß
Stefan
stmeyer has attached the following file:
  • dump.txt (6.54 kB - 59 times downloaded - latest: Jun 8th 2013, 5:56am)
Mein VDR: link :D