Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

XThunder

Anfänger

Beiträge: 52

Wohnort: Langen (Hessen)

Beruf: Softwareentwickler

  • Nachricht senden

101

Mittwoch, 20. April 2011, 21:09

Hi!

Mmmh, ich wollte noch etwas warten, bis die 11.0 PVR ein bisschen stabiler wird. Der PVR-Teil ranzt bei mir regelmäßig ab, meiner Familie ist das nicht zuzumuten.

Ich raffe immer noch nicht, was bei dir abgeht. Funzt der Display denn überhaupt noch? Mit VDR zum Beispiel? Kannst du mal eine xmbc.log bzw. die Teile mit XPCDproc posten?

Gruß,
XThunder
Antec Fusion Remote Silver, Nvidia G210, XUbuntu 10.04, yavdr (stable-vdr), XBMC 10.0 Dharma+pvr+imonpatch

Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth. (Arthur Conan Doyle)

bolzerrr

Fortgeschrittener

Beiträge: 434

Wohnort: Frankfurt

Beruf: IT

  • Nachricht senden

102

Donnerstag, 21. April 2011, 15:41

das klingt vernünftig!

ja es läuft einwandfrei im vdr- auch im xbmc- aber nur die icons/ progressbars, nicht die zeilen. ein remove --purge und frisches install hat auch nicht geholfen. die gedenkminute ist übrigends auch wieder da.
DVB Server Triax TSS400 SAT>IP Server
VDR Server Synlogy Diskstation DS214play, debian chroot headless streaming Sever, VDR 2.1.7 mit vtuner/satip und vdr-plugin-satip
VDR Client AMD X2 250, 4GB DDR3, G210 Passiv, 64GB SSD, Antec Fusion Micro iMON, Samsung LE 40 A659, Teufel E300, Logitech Harmony, yaVDR0.5 streamdev-client, (satip & USB DVBSKY S960 fallback)
VDR Client Raspberry PI B+, raspian wheezy, VDR 2.1.6 mit RpiHDDevice, streamdev-client
V/A Clients Windows PC's, Tablet, Smartphones via Streamdev or SatIP (UPNP)

bolzerrr

Fortgeschrittener

Beiträge: 434

Wohnort: Frankfurt

Beruf: IT

  • Nachricht senden

103

Samstag, 23. April 2011, 14:21

so hab nochmals ALLES was mit lcdproc zu tun hat gelöscht, xbmc, lcdproc neu isntalliert aus deinem repo, das init script von wwoody angelegt, LCDd aus allen runlevels entfernt. LCDd.conf unverändert gelassen

ergebniss:
gedenkminute ist weg (JUHU!)
display aber wie vorher: kein text aber prograssbars

logauszug:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
14:11:20 T:3078989696 M:2761949184   DEBUG: XLCDproc::Initialize - LCDproc data: Columns 16 - Rows 2 - Cellheight 8 - Cellwidth 6.
14:11:20 T:3078989696 M:2761945088    INFO: XLCDproc::RecognizeAndSetDriver - Plain driver name is: success
                                            success
                                            success
                                            success
                                            success
                                            ��
14:11:20 T:3078989696 M:2761945088    INFO: XLCDproc::RecognizeAndSetDriver - Plain driver name is: SoundGraph iMON LCD driver v0.6 : 15c2:ffdc and 15c2:0038 
                                            listen xbmc
                                            �>�
14:11:20 T:3078989696 M:2761945088    INFO: XLCDproc::RecognizeAndSetDriver - Driver is: SoundGraph iMON LCD driver


ich werde das gefühl nicht los das es eine einstallung von xmc _irgendwo_ ist. was ich versucht habe:

1) alles neu
-advancedsettings.xml, LCD.xml, guisettings.xml gelöscht
-xbmc gestartet
-guisetting lcd aktiviert

2) jegliche advancedsettings die hier im thread rumfliegt

3) in der LCDd.conf den user auf vdr gestellt

alles ohne erfolg :/
DVB Server Triax TSS400 SAT>IP Server
VDR Server Synlogy Diskstation DS214play, debian chroot headless streaming Sever, VDR 2.1.7 mit vtuner/satip und vdr-plugin-satip
VDR Client AMD X2 250, 4GB DDR3, G210 Passiv, 64GB SSD, Antec Fusion Micro iMON, Samsung LE 40 A659, Teufel E300, Logitech Harmony, yaVDR0.5 streamdev-client, (satip & USB DVBSKY S960 fallback)
VDR Client Raspberry PI B+, raspian wheezy, VDR 2.1.6 mit RpiHDDevice, streamdev-client
V/A Clients Windows PC's, Tablet, Smartphones via Streamdev or SatIP (UPNP)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »bolzerrr« (23. April 2011, 14:33)


104

Montag, 25. April 2011, 09:12

Hi bolzerrr,
-advancedsettings.xml, LCD.xml, guisettings.xml gelöscht
Aber eine neue-/Standard-LCD.xml gibt es bei Dir? Denn sonst weiß XBMC ja nicht, welchen Text es in welcher Situation aufs LCD schicken soll.
Ich frage nur, um sicher zu gehen ;D.

Viele Grüße,
Chriss

Signatur

Server: VDR 2.0.2, Kubuntu 12.04, 3.2.0-48-generic-pae Kernel
HW: AMD X2 4850, 4GB RAM, TeVii-S480, Asus M3A-H/HDMI, SeaSonic S12II 330W, WD 1,5TB Caviar Green, iMon-LCD, xine
Dienste: Router, Samba, DHCP, DNS, Mail, (T)FTP, LAMP, Portage-Mirror, VDR-Server für
Client: P3 1200MHz, DXR3, diskless, VDR 1.7.33, Gentoo, 2.6.32.60 Kernel, VFD: mdm166a
http://lcr.vdr-developer.org/

bolzerrr

Fortgeschrittener

Beiträge: 434

Wohnort: Frankfurt

Beruf: IT

  • Nachricht senden

105

Montag, 25. April 2011, 15:32

Ja die wird von XBMC automatisch erstellt ;-)
Ich verstehs nicht- eigentlich sollte das alles funktionieren.. hast du in der LCDd.conf änderungen vorgenommen?
DVB Server Triax TSS400 SAT>IP Server
VDR Server Synlogy Diskstation DS214play, debian chroot headless streaming Sever, VDR 2.1.7 mit vtuner/satip und vdr-plugin-satip
VDR Client AMD X2 250, 4GB DDR3, G210 Passiv, 64GB SSD, Antec Fusion Micro iMON, Samsung LE 40 A659, Teufel E300, Logitech Harmony, yaVDR0.5 streamdev-client, (satip & USB DVBSKY S960 fallback)
VDR Client Raspberry PI B+, raspian wheezy, VDR 2.1.6 mit RpiHDDevice, streamdev-client
V/A Clients Windows PC's, Tablet, Smartphones via Streamdev or SatIP (UPNP)

106

Montag, 25. April 2011, 18:05

Hi bolzerrr,

glaube nicht, dass meine LCD.xml den Ausschlag geben wird, aber ums ausschließen zu können, versuch's einfach mal damit ...

Viele Grüße,
Chriss

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
<lcd>
<!--   <disableonplay>video, music</disableonplay> -->
   <disableonplay>video</disableonplay>
   <navigation>
  	<line>$INFO[System.CurrentWindow]</line>
  	<line>$INFO[System.CurrentControl]</line>
  	<line>$INFO[System.CurrentWindow]</line>
  	<line>$INFO[System.CurrentControl]</line>
   </navigation>
   <music>
  	<line>$INFO[LCD.PlayIcon] $INFO[MusicPlayer.Artist] - $INFO[MusicPlayer.Album] ($INFO[MusicPlayer.Year])</line>
  	<line>$INFO[LCD.ProgressBar]</line>
  	<line>_</line>
  	<line>$INFO[LCD.PlayIcon]</line>
  	<line>$INFO[Player.Time]/$INFO[Player.Duration] $INFO[MusicPlayer.Title] - $INFO[MusicPlayer.Artist]</line>
  	<line>$INFO[MusicPlayer.Artist]</line>
   </music>
   <video>
  	<line>$INFO[LCD.PlayIcon]$INFO[Player.Time]/$INFO[Player.Duration]</line>
  	<line>$INFO[VideoPlayer.Title]</line>
  	<line>$INFO[VideoPlayer.Title]</line>
  	<line>$INFO[VideoPlayer.Genre]</line>
   </video>
   <general>
  	<line>$INFO[System.Date]</line>
  	<line>$INFO[System.Time]</line>
  	<line>$INFO[System.Date]</line>
  	<line>$INFO[System.Time]</line>
   </general>
   <screensaver>
  	<line>$INFO[LCD.Time21]</line>
  	<line>$INFO[LCD.Time22]</line>
  	<line>$INFO[System.CurrentWindow]</line>
  	<line>$INFO[VideoPlayer.Title]</line>
   </screensaver>
   <xbelaunch>
  	<line></line>
  	<line>Playing</line>
  	<line>$INFO[System.LaunchXBE]</line>
   </xbelaunch>
</lcd>

Signatur

Server: VDR 2.0.2, Kubuntu 12.04, 3.2.0-48-generic-pae Kernel
HW: AMD X2 4850, 4GB RAM, TeVii-S480, Asus M3A-H/HDMI, SeaSonic S12II 330W, WD 1,5TB Caviar Green, iMon-LCD, xine
Dienste: Router, Samba, DHCP, DNS, Mail, (T)FTP, LAMP, Portage-Mirror, VDR-Server für
Client: P3 1200MHz, DXR3, diskless, VDR 1.7.33, Gentoo, 2.6.32.60 Kernel, VFD: mdm166a
http://lcr.vdr-developer.org/

bolzerrr

Fortgeschrittener

Beiträge: 434

Wohnort: Frankfurt

Beruf: IT

  • Nachricht senden

107

Mittwoch, 27. April 2011, 19:28

Soeben getestet- leider ohne Erfolg.
Die /etc/LCDd.conf könnte man nochmal versuchen. Das initscript von wwoody nutzt du auch oder?
DVB Server Triax TSS400 SAT>IP Server
VDR Server Synlogy Diskstation DS214play, debian chroot headless streaming Sever, VDR 2.1.7 mit vtuner/satip und vdr-plugin-satip
VDR Client AMD X2 250, 4GB DDR3, G210 Passiv, 64GB SSD, Antec Fusion Micro iMON, Samsung LE 40 A659, Teufel E300, Logitech Harmony, yaVDR0.5 streamdev-client, (satip & USB DVBSKY S960 fallback)
VDR Client Raspberry PI B+, raspian wheezy, VDR 2.1.6 mit RpiHDDevice, streamdev-client
V/A Clients Windows PC's, Tablet, Smartphones via Streamdev or SatIP (UPNP)

XThunder

Anfänger

Beiträge: 52

Wohnort: Langen (Hessen)

Beruf: Softwareentwickler

  • Nachricht senden

108

Donnerstag, 28. April 2011, 16:44

Mmmh, keine Ahnung, ob es was bringt, aber es gibt im lcdproc 0.5.4 einen Bug bzgl. dem Imon-Display. Diesen habe ich gemeldet, es gibt auch bereits einen Patch dafür und natürlich auch gleich einen neuen Build vom lcdproc in meinem PPA. Kannste ja mal ausprobieren?!?

Gruß,
XThunder
Antec Fusion Remote Silver, Nvidia G210, XUbuntu 10.04, yavdr (stable-vdr), XBMC 10.0 Dharma+pvr+imonpatch

Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth. (Arthur Conan Doyle)

109

Donnerstag, 28. April 2011, 19:37

Das initscript von wwoody nutzt du auch oder?
Nein, da bei mir alles mehr oder minder selbst gestrickt ist. Ich nutze auch nicht das vdr-imonlcd Plugin zur Ausgabe während des VDR-Betriebs, sondern lcdproc. Daher ist das "Von-VDR-zu-XBMC-Wechsel Script" auch ein wenig anders:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
#!/bin/sh

SVDRPSEND="/usr/bin/svdrpsend.pl"
XBMC="/usr/bin/xbmc"

/bin/killall xbmc.bin
/bin/killall xine

$SVDRPSEND REMO OFF
export DISPLAY=":0.0"

$SVDRPSEND plug lcdproc OFF
$XBMC
sleep 2
$SVDRPSEND plug lcdproc ON
$SVDRPSEND REMO ON


Hier nun die relevanten Zeilen aus der LCDd.conf:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
[server]
Driver=imonlcd
Bind=127.0.0.1
Port=13666
ReportToSyslog=yes
WaitTime=5
User=nobody
ServerScreen=no
DriverPath=/usr/lib/lcdproc/


[imonlcd]
 # select the device to use
Device=/dev/lcd0

# display dimensions
Size=96x16
OnExit=0
Contrast=625
Backlight=1
DiscMode=0


Viele Grüße,
Chriss

Signatur

Server: VDR 2.0.2, Kubuntu 12.04, 3.2.0-48-generic-pae Kernel
HW: AMD X2 4850, 4GB RAM, TeVii-S480, Asus M3A-H/HDMI, SeaSonic S12II 330W, WD 1,5TB Caviar Green, iMon-LCD, xine
Dienste: Router, Samba, DHCP, DNS, Mail, (T)FTP, LAMP, Portage-Mirror, VDR-Server für
Client: P3 1200MHz, DXR3, diskless, VDR 1.7.33, Gentoo, 2.6.32.60 Kernel, VFD: mdm166a
http://lcr.vdr-developer.org/

110

Sonntag, 1. Mai 2011, 18:17

Ich wollte soeben XBMC 10.1 mit dem Imon-Patch bauen - leider klappt der Patch erst gar nicht:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
[root@antecvdr /usr/local/src/installiert/xbmc-10.1-imonlcd]$ patch -p1 < xbmc-imon_lcd_10.1.diff
patching file language/German/strings.xml
Hunk #1 succeeded at 873 (offset -3 lines).
patching file xbmc/Application.cpp
Hunk #1 succeeded at 2673 (offset -15 lines).
patching file xbmc/Application.h
Hunk #1 succeeded at 292 (offset -9 lines).
Hunk #2 succeeded at 371 (offset -11 lines).
patching file xbmc/addons/Visualisation.cpp
Hunk #1 succeeded at 32 with fuzz 2 (offset 1 line).
Hunk #2 succeeded at 317 (offset 1 line).
patching file xbmc/linux/Makefile.in
Hunk #1 FAILED at 15.
1 out of 1 hunk FAILED -- saving rejects to file xbmc/linux/Makefile.in.rej
patching file xbmc/linux/XLCDProc_imon.cpp
patching file xbmc/linux/XLCDProc_imon.h
patching file xbmc/linux/XLCDProc_mdm166a.cpp
patching file xbmc/linux/XLCDProc_mdm166a.h
patching file xbmc/linux/XLCDproc.cpp
Hunk #1 FAILED at 25.
Hunk #8 FAILED at 377.
2 out of 9 hunks FAILED -- saving rejects to file xbmc/linux/XLCDproc.cpp.rej
patching file xbmc/linux/XLCDproc.h
patching file xbmc/settings/AdvancedSettings.cpp
Hunk #1 FAILED at 119.
Hunk #2 FAILED at 575.
2 out of 2 hunks FAILED -- saving rejects to file xbmc/settings/AdvancedSettings.cpp.rej
patching file xbmc/settings/AdvancedSettings.h
Hunk #1 FAILED at 145.
1 out of 1 hunk FAILED -- saving rejects to file xbmc/settings/AdvancedSettings.h.rej
patching file xbmc/utils/LCD.cpp
Hunk #1 FAILED at 22.
Hunk #2 succeeded at 33 (offset 1 line).
Hunk #3 succeeded at 74 (offset 1 line).
Hunk #4 succeeded at 365 (offset 3 lines).
Hunk #5 succeeded at 407 (offset 3 lines).
Hunk #6 succeeded at 503 (offset 3 lines).
Hunk #7 succeeded at 541 (offset 3 lines).
Hunk #8 succeeded at 551 (offset 3 lines).
1 out of 8 hunks FAILED -- saving rejects to file xbmc/utils/LCD.cpp.rej
patching file xbmc/utils/LCD.h
patching file xbmc/utils/StringUtils.cpp
Hunk #1 FAILED at 244.
1 out of 1 hunk FAILED -- saving rejects to file xbmc/utils/StringUtils.cpp.rej
[root@antecvdr /usr/local/src/installiert/xbmc-10.1-imonlcd]$


Ideen woran es liegen könnte?

Marcus
VDR 1.7.26 und Plugins selbst kompiliert:
1: AMD X2 4850e, Asus M3N78-VM, Acer FullHD-Monitor, DVB-S2 TT-3200, NV 310.19, Debian/wheezy
2: C2D E7500, Zotac GF9300-I-E, Antec Fusion V2, Sony LCD-TV, TBS DVB-S2 6981, NV 295.59, Debian/squeeze
VDR 2.0.1 aus yaVDR-Repository:
3: Atom N330, Zotac IonTX-F-E , SilverStone SUGO SG05, Megtron LCD 240x128, Samsung LCD-TV, DVB-S2 CINE S2 V5.5, Ubuntu 12.04

111

Freitag, 6. Mai 2011, 22:24

mdm166a Display settings

Hi,
ich hab mir einen HTPC zusammengebaut der unter yavdr läuft. Ich nur sagen, da steckt ordentlich arbeit und schweiß dahinter, bis alles läuft. Aber als Linuxneuling kann man ja nur lernen. :-;

Es läuft bei mir unter yavdr auch das mdm166a Display. Deshalb habe ich nach der Anleitung von wwoody user/146-wwoody/?das xthunder-repo eingebunden. Das aktuelle lcdproc aus dem xthunder-repo ist installiert. Ich glaube, dass es soweit in Ordnung ist, da die Anzeige beim Wechsel zu XBMC verschwindet und nicht mehr einfriert. Da aber die Programmpunkte bei XBMC nicht erscheinen, vermute ich dass ich noch eine falsche LCD.xml und advancedsettings.xml habe. Oder vielleicht liegt der Fehler ja noch wo anders?
Meine bitte daher, vielleicht kann hier noch jemand die advancedsettings.xml und die LCDxml für das mdm166a veröffentlichen.


Gruß

digit11
* Prozessor/CPU: AMD Athlon II X2 240 mit 2x 2,8GHz
* Grafikkarte: Gainward 8400 GS
* TV-Karten: 1 x Techno Trend Budget DVB-S2 1600
* Motherboard: MSI 785GM-E51
* Gehäuse: Digitainer 1 mit eingpassten Futaba MDM166A
* Atric Ver. 5

yavdr 0.3 --> Test: 0.4

bolzerrr

Fortgeschrittener

Beiträge: 434

Wohnort: Frankfurt

Beruf: IT

  • Nachricht senden

112

Montag, 9. Mai 2011, 08:14

Hi,
ich hab mir einen HTPC zusammengebaut der unter yavdr läuft. Ich nur sagen, da steckt ordentlich arbeit und schweiß dahinter, bis alles läuft. Aber als Linuxneuling kann man ja nur lernen. :-;

Es läuft bei mir unter yavdr auch das mdm166a Display. Deshalb habe ich nach der Anleitung von wwoody user/146-wwoody/?das xthunder-repo eingebunden. Das aktuelle lcdproc aus dem xthunder-repo ist installiert. Ich glaube, dass es soweit in Ordnung ist, da die Anzeige beim Wechsel zu XBMC verschwindet und nicht mehr einfriert. Da aber die Programmpunkte bei XBMC nicht erscheinen, vermute ich dass ich noch eine falsche LCD.xml und advancedsettings.xml habe. Oder vielleicht liegt der Fehler ja noch wo anders?
Meine bitte daher, vielleicht kann hier noch jemand die advancedsettings.xml und die LCDxml für das mdm166a veröffentlichen.


Gruß

digit11
Kommt mir bekannt vor :-)
Hab das gleiche verhalten, zumindest klingt es sehr ähnlich, kannst gern mal die letzten 2 Seiten hier lesen. Ich hab keine Lösung finden können, trotz toller Unterstützung. An dieser Stelle nochmals danke an XThunder und theonlycriss. :tup
Ich hab mich vorerst damit abgefunden das es nur Progressbars gibt. Gehen die bei dir? (Einfach mal Film starten)
DVB Server Triax TSS400 SAT>IP Server
VDR Server Synlogy Diskstation DS214play, debian chroot headless streaming Sever, VDR 2.1.7 mit vtuner/satip und vdr-plugin-satip
VDR Client AMD X2 250, 4GB DDR3, G210 Passiv, 64GB SSD, Antec Fusion Micro iMON, Samsung LE 40 A659, Teufel E300, Logitech Harmony, yaVDR0.5 streamdev-client, (satip & USB DVBSKY S960 fallback)
VDR Client Raspberry PI B+, raspian wheezy, VDR 2.1.6 mit RpiHDDevice, streamdev-client
V/A Clients Windows PC's, Tablet, Smartphones via Streamdev or SatIP (UPNP)

113

Montag, 9. Mai 2011, 11:09

Das steht bei mir in "/var/lib/vdr/.xbmc/userdata/advancedsettings.xml":

Quellcode

1
2
3
4
5
6
7
8
 <lcd>
    <scrolldelay>5</scrolldelay>
    <spectrumanalyzer>false</spectrumanalyzer>
    <progressbar1>none</progressbar1>
    <progressbar2>progress</progressbar2>
    <progressbar3>none</progressbar3>
    <progressbar4>menu</progressbar4>
 </lcd>

und die LCD.xml sieht so aus:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
<lcd>
   <navigation>
      <line>$INFO[System.CurrentWindow]</line>
      <line>$INFO[System.CurrentControl]</line>
   </navigation>
   <music>
      <line>$INFO[Player.Time]|$INFO[Player.Duration]</line>
      <line>$INFO[MusicPlayer.Artist] - $INFO[MusicPlayer.Title] - </line>
      <line>$INFO[LCD.ProgressBar]</line>
   </music>
   <video>
      <line>$INFO[Player.Time]|$INFO[Player.Duration]</line>
      <line>$INFO[VideoPlayer.Title]</line>
      <line>$INFO[LCD.ProgressBar]</line>
   </video>
   <general>
      <line>$INFO[System.Time]</line>
      <line>$INFO[System.Date]</line>
   </general>
   <screensaver>
      <line>$INFO[System.Time]</line>
      <line>$INFO[System.Date]</line>
   </screensaver>
   <xbelaunch>
      <line>Playing</line>
      <line>$INFO[System.LaunchXBE]</line>
   </xbelaunch>
</lcd>

Mehr ist da nicht ...

//edit
Hier noch die "/etc/LCDd.conf":

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
# LCDd.conf -- configuration file for the LCDproc server daemon LCDd

[server]
DriverPath=/usr/lib/lcdproc/
Driver=imonlcd
Bind=127.0.0.1
Port=13666
#ReportLevel=3
#ReportToSyslog=yes
User=vdr
#Foreground=no
Hello=""
GoodBye=""
WaitTime=5
ServerScreen=blank
Backlight=on
#Heartbeat=off
#TitleSpeed=10

[menu]

[imonlcd]
Protocol=1
OnExit=0
#Backlight=on
DiscMode=1

# EOF

und das Upstart Script für LCDd "/etc/init/lcdd.conf":

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
# /etc/init/lcdd.conf
description     "LCDd Daemon"

start on starting xbmc
stop on stopping xbmc

pre-start script
/usr/bin/svdrpsend plug imonlcd off
end script


post-stop script
/usr/bin/svdrpsend plug imonlcd on
end script


exec /usr/sbin/LCDd -s 1 -f -c /etc/LCDd.conf


Sehe Dir bitte noch die guisettings.xml und die Option "haslcd" an: Klick
Gruß, WWOODY
...
vdr1: yaVDR 0.3 - ZOTAC IONITX-F-E, 2GB RAM, Cine S2, Antec MicroFusion/iMON LCD, BD-ROM - Atric IR + Harmony 555 - 50" Samsung Plasma
vdr2: yaVDR 0.3 - POV ION-330-1, 2GB RAM, 1x TT S2-3600, Atric IR + Harmony 555 - 32" Toshiba LCD
vdr3: yaVDR 0.3 - FOXCONN nT-330i, 2GB RAM, 1x TT S2-3600, HAMA MCE - 26" LG LCD

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »wwoody« (9. Mai 2011, 11:20)


nst

Schüler

Beiträge: 132

Beruf: Bastler vorm Herrn

  • Nachricht senden

114

Mittwoch, 11. Mai 2011, 18:05

iMon-Patch für aktuellen (PVR) GIT-Tree

Hallo zusammen,

anbei eine für den aktuellen Opdenkamp PVR GIT-Tree von gestern (10.5.2011, commit 869de83dd15a0a729f5c) angepasste Version vom iMon-Patch. Unterscheided sich von http://trac.xbmc.org/attachment/ticket/8…Exthunder1.diff darin, dass in LCD.cpp zusätzlich der "namespace PVR" mit referenziert wird, sowie "CPVRManager::Get()" durch "g_PVRManager" ersetzt wurde.

Ausserdem wird in XLCDproc.cpp anstatt eines Leerzeichens ein "*" an den Zeilenstring angehängt, wenn die Zeile gescrollt werden muss - meiner Meinung nach etwas übersichtlicher und schicker auf dem Display :-)

Hoffe, es kann jemand gebrauchen :)

Viele Grüße,
Daniel
»nst« hat folgende Datei angehängt:
HW: Gigabyte GA-EG41MF-US2H, Intel Core2Duo E7500, 2GB DDR2-RAM, NVIDIA GT610/1GB PCIe in Antec Fusion Remote Black+SoundGraph iMON LCD ( 0038 )
SW: Kodi Jarvis+VDPAU+HD-Audio+LCDproc addon auf Ubuntu Trusty 14.04 (x86_64)
Server: Gentoo Linux x86 / Kernel 4.4 / DD CineCTv6+DuoFlex C/T/T2, Mystique CaBiX (KNC ONE OEM) / TVHeadend-GIT

bolzerrr

Fortgeschrittener

Beiträge: 434

Wohnort: Frankfurt

Beruf: IT

  • Nachricht senden

115

Mittwoch, 13. Juli 2011, 08:22

Hi,

wie ich im yaVDR Bugtracker lese wurde der Patch in 0.4 aufgenommen, hat das bereits jemand getestet? Ich werd mich heute abend mal ransetzen.. bin schon gespannt ;-)
DVB Server Triax TSS400 SAT>IP Server
VDR Server Synlogy Diskstation DS214play, debian chroot headless streaming Sever, VDR 2.1.7 mit vtuner/satip und vdr-plugin-satip
VDR Client AMD X2 250, 4GB DDR3, G210 Passiv, 64GB SSD, Antec Fusion Micro iMON, Samsung LE 40 A659, Teufel E300, Logitech Harmony, yaVDR0.5 streamdev-client, (satip & USB DVBSKY S960 fallback)
VDR Client Raspberry PI B+, raspian wheezy, VDR 2.1.6 mit RpiHDDevice, streamdev-client
V/A Clients Windows PC's, Tablet, Smartphones via Streamdev or SatIP (UPNP)

116

Sonntag, 17. Juli 2011, 21:36

Das steht bei mir in "/var/lib/vdr/.xbmc/userdata/advancedsettings.xml":

Quellcode

1
2
3
4
5
6
7
    5
    false
    none
    progress
    none
    menu
 

und die LCD.xml sieht so aus:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
      $INFO[System.CurrentWindow]
      $INFO[System.CurrentControl]
   
   
      $INFO[Player.Time]|$INFO[Player.Duration]
      $INFO[MusicPlayer.Artist] - $INFO[MusicPlayer.Title] - 
      $INFO[LCD.ProgressBar]
   
   
      $INFO[Player.Time]|$INFO[Player.Duration]
      $INFO[VideoPlayer.Title]
      $INFO[LCD.ProgressBar]
   
   
      $INFO[System.Time]
      $INFO[System.Date]
   
   
      $INFO[System.Time]
      $INFO[System.Date]
   
   
      Playing
      $INFO[System.LaunchXBE]

Mehr ist da nicht ...

//edit
Hier noch die "/etc/LCDd.conf":

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
# LCDd.conf -- configuration file for the LCDproc server daemon LCDd

[server]
DriverPath=/usr/lib/lcdproc/
Driver=imonlcd
Bind=127.0.0.1
Port=13666
#ReportLevel=3
#ReportToSyslog=yes
User=vdr
#Foreground=no
Hello=""
GoodBye=""
WaitTime=5
ServerScreen=blank
Backlight=on
#Heartbeat=off
#TitleSpeed=10

[menu]

[imonlcd]
Protocol=1
OnExit=0
#Backlight=on
DiscMode=1

# EOF

und das Upstart Script für LCDd "/etc/init/lcdd.conf":

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
# /etc/init/lcdd.conf
description     "LCDd Daemon"

start on starting xbmc
stop on stopping xbmc

pre-start script
/usr/bin/svdrpsend plug imonlcd off
end script


post-stop script
/usr/bin/svdrpsend plug imonlcd on
end script


exec /usr/sbin/LCDd -s 1 -f -c /etc/LCDd.conf


Sehe Dir bitte noch die guisettings.xml und die Option "haslcd" an: Klick

Hallo Wwoody,

dank Deiner Dateien ist es mir nun gelungen das lcdpoc im yavdr 0.4 zum laufen zu bringen. Ich hab nur in der Datei LCDd.conf den Treiber von
Driver=imonlcd auf Driver=mdm166a abgeändert, und alles läuft. :D

Eine Frage hätte ich noch: Wie wird das Upstart Script angelegt? Einfach die Datei lcdd.conf im Ordner /etc/init erstelllen? Die Zeile "/usr/bin/svdrpsend plug imonlcd off " müsste ich wahrscheinlich abändern? (targavfd oder mdm166a?)

Gruß

digit11
* Prozessor/CPU: AMD Athlon II X2 240 mit 2x 2,8GHz
* Grafikkarte: Gainward 8400 GS
* TV-Karten: 1 x Techno Trend Budget DVB-S2 1600
* Motherboard: MSI 785GM-E51
* Gehäuse: Digitainer 1 mit eingpassten Futaba MDM166A
* Atric Ver. 5

yavdr 0.3 --> Test: 0.4

bolzerrr

Fortgeschrittener

Beiträge: 434

Wohnort: Frankfurt

Beruf: IT

  • Nachricht senden

117

Montag, 18. Juli 2011, 17:51

habs jetzt auch getestet, klappte auf anhieb! :tup

nervig sind allerdings die meldungen im log:

Quellcode

1
 lcd_write: write 8 bytes to LCD

da führt kein Weg dran vorbei oder?
DVB Server Triax TSS400 SAT>IP Server
VDR Server Synlogy Diskstation DS214play, debian chroot headless streaming Sever, VDR 2.1.7 mit vtuner/satip und vdr-plugin-satip
VDR Client AMD X2 250, 4GB DDR3, G210 Passiv, 64GB SSD, Antec Fusion Micro iMON, Samsung LE 40 A659, Teufel E300, Logitech Harmony, yaVDR0.5 streamdev-client, (satip & USB DVBSKY S960 fallback)
VDR Client Raspberry PI B+, raspian wheezy, VDR 2.1.6 mit RpiHDDevice, streamdev-client
V/A Clients Windows PC's, Tablet, Smartphones via Streamdev or SatIP (UPNP)

owenzel

Fortgeschrittener

Beiträge: 241

Wohnort: Düsseldorf

  • Nachricht senden

118

Montag, 1. August 2011, 17:26

Eine Frage hätte ich noch: Wie wird das Upstart Script angelegt? Einfach die Datei lcdd.conf im Ordner /etc/init erstelllen? Die Zeile "/usr/bin/svdrpsend plug imonlcd off " müsste ich wahrscheinlich abändern? (targavfd oder mdm166a?)

Gruß

digit11

digit11, wie hast Du das o.g. Thema denn gelöst? Hast Du denn das Targavfd Plugin generell installiert?

Spoiler Spoiler

yaVDR 0.6, Softhddevice, ZOTAC H77-ITX, Intel Pentium G2130, 4GB, Sundtek, KINGSTON 30GB SSDNow mSATA & WD Scorpio Blue 1TB
IR-Empfänger/Sender/Einschalter yaUsbIR V3.... alles im Streacom F7C EVO Gehäuse

Testsystem: yaVDR 0.6, Softhddevice (VM unter KVM unRAID V6.1.9 Pro), Supermicro X9SCL-F, XEON E3-1240V2

119

Montag, 1. August 2011, 21:09

Eine Frage hätte ich noch: Wie wird das Upstart Script angelegt? Einfach die Datei lcdd.conf im Ordner /etc/init erstelllen? Die Zeile "/usr/bin/svdrpsend plug imonlcd off " müsste ich wahrscheinlich abändern? (targavfd oder mdm166a?)

Gruß

digit11

digit11, wie hast Du das o.g. Thema denn gelöst? Hast Du denn das Targavfd Plugin generell installiert?

Hallo owenzel,
das targavfd hab ich über die weboberfläche vom vdr installiert.

Dank intensiver Unterstützung durch "bolzerrr" habe ich das LCD unter VDR und XBMC zu laufen gebracht.

1. ich habe unter /etc/init/ mit nano die Datei lcdd.conf angelegt. Die Zeile "/usr/bin/svdrpsend plug imonlcd off geändert durch targavfd

2. Danach habe ich die Runlevel beendet durch den Befehl: update-rc.d -f LCDd remove

3. In der Datei guisettings.xml habei ich noch die Option <haslcd>false</haslcd> auf true gesetzt.

Nach einem Neustart hat nun alles bestens funktioniert.

Ein bischen stört mich noch, idass der Text im LCD unter XBMC immer in 2 Zeilen geschrieben wird. Vielleicht kann man das ja noch irgendwo ändern. Ist aber nicht so wichtig.

Was aber noch ganz cool wäre, wenn noch die Icons funktionieren würden.

Gruß

digit11
* Prozessor/CPU: AMD Athlon II X2 240 mit 2x 2,8GHz
* Grafikkarte: Gainward 8400 GS
* TV-Karten: 1 x Techno Trend Budget DVB-S2 1600
* Motherboard: MSI 785GM-E51
* Gehäuse: Digitainer 1 mit eingpassten Futaba MDM166A
* Atric Ver. 5

yavdr 0.3 --> Test: 0.4

owenzel

Fortgeschrittener

Beiträge: 241

Wohnort: Düsseldorf

  • Nachricht senden

120

Dienstag, 2. August 2011, 13:47

Super, das hat prima geklappt. Vielen Dank.

Spoiler Spoiler

yaVDR 0.6, Softhddevice, ZOTAC H77-ITX, Intel Pentium G2130, 4GB, Sundtek, KINGSTON 30GB SSDNow mSATA & WD Scorpio Blue 1TB
IR-Empfänger/Sender/Einschalter yaUsbIR V3.... alles im Streacom F7C EVO Gehäuse

Testsystem: yaVDR 0.6, Softhddevice (VM unter KVM unRAID V6.1.9 Pro), Supermicro X9SCL-F, XEON E3-1240V2

Immortal Romance Spielautomat