You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

aelo

Professional

Posts: 1,059

Location: Österreich/Vlbg

  • Send private message

441

Monday, November 29th 2010, 5:28pm

dito,

läuft auch hier gut :-)
mal sehen ob die bekannten Bugs durch das mergen gefixed wurden :-)

Atechsystem

Professional

Posts: 1,113

Location: NRW

Occupation: Informationstechniker

  • Send private message

442

Monday, November 29th 2010, 6:41pm

Hi,

dann teil doch mal bitte mit was die bekannten Bugs sind.... :)

Bei mir hat sich hauptsäclich das Deinterleacing verbessert. Außerdem hat bei mir das Bild bei Sd nach einiger Zeit angefangen zu Ruckeln. Konnte nicht feststellen woran es gelegen hat - mit der Dharma Variante ist es weg.

Gruß
Atech
HTPC:
Softtware: Archlinux mit VDR aus Archvdr repo (1.7.31 mit softhddevice) und xbmc 12.2 Frodo stable
Hardware: Coolermaster 260 mit Core I3 540, 4 GB Kingst. Ram, GA.H55M-D2H, PCIe 16X RiserCard, NVIDIA 430GT, TT3600USB, Satix S2 Sky V2 USB, Samsung SSD 640, WD Blue 1TB (WD10TP), IR Einschalter, imon Display, mce FB und 12 Kanal Atmolight (4 Led Streifen) über DFatmo und Boblight

aelo

Professional

Posts: 1,059

Location: Österreich/Vlbg

  • Send private message

443

Monday, November 29th 2010, 6:51pm

Bug #1: Nach langer Zeit fernsehen und zurückwechseln in das Menü sind die Sender verschwunden und die XBMC stürtzt eventuell ab.

Bug #2: Sporadische Abstürtze :unsch generell in XBMC da der letzte Merge schon länger her ist und damals der trunk-branch natürlich noch sehr buggy war.

Bug #3: Nach einer Zeit bringt das VNSI-Plugin immer wieder die Melung -> möchte in x Minuten herunterfahren, und auch wenn man dann eine Taste drückt erscheint die Meldung immer wieder.


Bug #1: noch nicht getestet
Bug #2: hör jetzt grade ein wenig Musik damit, davor ein paar Minuten fernsehn, sieht schon besser aus :)
Bug #3: hab den Shutdown komplett deaktiviert :) also noch nicht getestet


nice regards

sphere

Intermediate

Posts: 249

Location: Krefeld

Occupation: Fachinformatiker

  • Send private message

444

Tuesday, November 30th 2010, 9:13am

Hier mal meine Erfahrungen zu deinen "Bugs" ;-)

Quoted

Bug #1: Hatte ich noch nie mit pvr-testing2
Bug #2: Hatte ich auch ein paar mal, tendenziell nimmt die Absturzrate zu je "älter" das Profil ist. Wenn ich den Home-Ordner verschiebe oder lösche - sprich ein leeres Profil habe - stürzt xbmc erstmal gar nicht mehr ab.
Bug #3: Das ist aber wirklich Einstellungssache von VDR, wobei ich dir zustimmen könnte, dass VDR evtl. ziemlich oft der Meinung ist, dass keine Aktivität vorliegt.


Grüße
silence: Ubuntu 9.10 | Asus M3N78-VM | AMD 4450e | TT-budget S2-1600 DVB-S2 | 5 X 1TB Raid5 | vdr (1.7.10) | xbmc opdenkamp master | Optoma HD65 Beamer | Samsung LE37B530 LCD | Onkyo 605 AVR | Heco Victa 700/300/100/25A

BJ1

Master

Posts: 2,078

Location: Sachsen

  • Send private message

445

Tuesday, November 30th 2010, 9:30am

Bug #1: Habe ich auch. Ich denke, das hängt mit der Aktualisierung des EPG zusammen.
Bug #2: Relativ selten, kommt aber vor. Ich habe daher den Neustart von XBMC auf eine Taste der FB gelegt und per irexec den Neustart eingepflegt.
Bug #3: Streamdev anstelle von VNSI nehmen.

Bug #4: Senderspezifische Einstellungen (Deinterlacingmethode, Bildformat usw.) werden nicht in der MyTVx.db gespeichert.

BJ1

meine Hardware

Produktiv/Testsystem/Datengrab (AZi): XBMCBuntu auf 14.04 LTS, TVHeadend | Asrock H61, Intel Celeron, HDMI über Asus GT610 | 2 GB 1066 RAM | 2,5" 100GB (System + Aufnahme), 3xWD EARX 2 TB SATA II + 1x Samsung 2 TB SATA II, mhddfs | Triple DVB-C (Digital Devices Cine CT + Satelco Easywatch DVB-C) | Atric IR Rev.5 | Silverstone LC10
Produktiv (WoZi): XBMCBuntu auf 14.04 LTS, TVHeadend | MSI C847MS-E33 | 1GB 1333 RAM | 8 GB CF-Card System + WD 1TB Daten | DD DVB-C/T Dualtuner | Atric IR Rev.5 + Logitech Harmony 300

Atechsystem

Professional

Posts: 1,113

Location: NRW

Occupation: Informationstechniker

  • Send private message

446

Tuesday, November 30th 2010, 12:54pm

Dann will ich auch mal:

Bug #1: Hatte ich lange Zeit, bisher nicht mehr aufgetreten (war aber auch ohne merge weg)
Bug #2: Beim TV bisher nicht mehr passiert, tritt aber manchmal beim starten von Videos auf, je nach Format häufiger.
Bug #3: Das automatische Ausschalten des VDR's im VDR Menü abschalten.

Bug #4: ->Senderspezifische Einstellungen<- werden bei mir scheinbar schon gespeichert. Ich habe bei ServusTVHD mal auf bob-deinterleacer umgeschaltet und jetzt wird immer bob verwendet. Bei allem anderen der "ION Auto Modus". Habe das aber noch nicht weiter verfolgt.

Zu der Sache mit dem "alternden" Home Verzeichnis:

Ich denke das hängt mit der Datenbank zusammen. Früher hatte ich oft abstürtze wenn ich die TV Datenbank nicht regelmäßig gelöscht habe. Änderungen z.B. an der Senderliste werden nicht umbedingt immer korrekt übernommen.

Gruß
Atech
HTPC:
Softtware: Archlinux mit VDR aus Archvdr repo (1.7.31 mit softhddevice) und xbmc 12.2 Frodo stable
Hardware: Coolermaster 260 mit Core I3 540, 4 GB Kingst. Ram, GA.H55M-D2H, PCIe 16X RiserCard, NVIDIA 430GT, TT3600USB, Satix S2 Sky V2 USB, Samsung SSD 640, WD Blue 1TB (WD10TP), IR Einschalter, imon Display, mce FB und 12 Kanal Atmolight (4 Led Streifen) über DFatmo und Boblight

karlson

Intermediate

Posts: 503

Location: Hamburg

  • Send private message

447

Tuesday, November 30th 2010, 2:53pm

Moin,

Bug #1: Habe ich nicht, schaue aber wenig Fernsehen damit

Bug #2: Kan ich nicht sagen, ist alles recht stabil.

Bug #3: Das ist eine Einstellung des Plugins (Meldungen zulassen oder so)

Aber:

Bug #5: Sporadischen Ruckeln beim Abspielen, Abstürze beim Anschauen
während einer Aufnahme (aka Timeshift): behoben durch Abschalten
des 2 GB Splittens. Dateigrenzen machten da wohl Ärger.

Bug #6: Nach dem S3 ist das Aufnahmeverzechnis leer. Wohl eher ein Problem
mit NFS und Automounter, aber das alternative Streamen über das
Plugin geht nicht (kann Aufnahme nicht abspielen).

Also nahe dran, fehlt aber noch was. VNSI oder streamdev tut bei mir nichts
zur Sache, die Probleme sind ähnlich.

Headless Server im Keller, Software selbskompiliert aus dem yavdr Repo,
Client XBMC auf Karmic aus dem yavdr Repo (binary).

Gruß,
Karlson.

448

Thursday, December 2nd 2010, 4:42pm

Hello

I'd like to report a bug in VNSI server, dunno if it's the right place for it.

When I zap to some channel, i don't have sound. If I open the audio menu on this channel i can see around 10 audio tracks, instead of 2 or 4, depending if channel have ac3 or not.

As example, Canal+ from cable:

The stream has 4 audio tracks, 2 ac3 and 2 mp2 ( one each for fr and en ).
In xbmc menu, i can see 11 tracks. 2 first ones are fake chans, then track 3,4,5,6 have the sound, then 7,8,9,10,11 are fake.

Those fakes trakcs are not supposed to exist. I don't have this problem with Streamdev, or tvheadend ( and not on vdr side of course ) .

When tuning from xbmc-pvr to those channel it gives me this on the log:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
16:21:34 T:2936011632 M:1012051968   DEBUG: CDVDDemuxPVRClient::UpdateStreams(): update stream 0:0 with codec_id 94215
16:21:34 T:2936011632 M:1012051968   DEBUG: CDVDDemuxPVRClient::UpdateStreams(): update stream 1:1 with codec_id 86020
16:21:34 T:2936011632 M:1012051968   DEBUG: CDVDDemuxPVRClient::UpdateStreams(): update stream 2:2 with codec_id 86020
16:21:34 T:2936011632 M:1012051968   DEBUG: CDVDDemuxPVRClient::UpdateStreams(): update stream 3:3 with codec_id 86020
16:21:34 T:2936011632 M:1012051968   DEBUG: CDVDDemuxPVRClient::UpdateStreams(): update stream 4:4 with codec_id 86020
16:21:34 T:2936011632 M:1012051968   DEBUG: CDVDDemuxPVRClient::UpdateStreams(): update stream 5:5 with codec_id 86016
16:21:34 T:2936011632 M:1012051968   DEBUG: CDVDDemuxPVRClient::UpdateStreams(): update stream 6:6 with codec_id 86016
16:21:34 T:2936011632 M:1012051968   DEBUG: CDVDDemuxPVRClient::UpdateStreams(): update stream 7:7 with codec_id 86020
16:21:34 T:2936011632 M:1012051968   DEBUG: CDVDDemuxPVRClient::UpdateStreams(): update stream 8:8 with codec_id 2
16:21:34 T:2936011632 M:1012051968   DEBUG: CDVDDemuxPVRClient::UpdateStreams(): update stream 9:9 with codec_id 86020
16:21:34 T:2936011632 M:1012051968   DEBUG: CDVDDemuxPVRClient::UpdateStreams(): update stream 10:10 with codec_id 86020
16:21:34 T:2936011632 M:1012051968   DEBUG: CDVDDemuxPVRClient::UpdateStreams(): update stream 11:11 with codec_id 86020
16:21:34 T:2936011632 M:1012051968   DEBUG: CDVDDemuxPVRClient::UpdateStreams(): update stream 12:12 with codec_id 86020


That's a really annoying bug as default audio track always a fake one.
I thought first the bug came from a bad ttxtsub patch, then i tryed a vanilla vdr with only vnsi running, but it gives me the same problem.

Other problem , related i think, I don't see any teletext subtitles in the xbmc sub menu. I could see them with streamdev if i remember well.


Tested with vdr-1.7.15 and vdr-1.7.16

Is it an identified problem and does somebody has it too ?

Thanks.

This post has been edited 1 times, last edit by "alib" (Dec 2nd 2010, 4:45pm)


449

Friday, December 10th 2010, 1:23pm

Off Topic:

Mal ne ganz andere Frage zu dem vnsiserver-Plugin - die Sourcen sind im XBMC Repo, aber gibt's irgendwo ne Protokollbeschreibung oder muss ich mir das aus dem aus dem Server und Client Code heraussuchen?

(was ich ja schon befürchte) .. ich würde mich dann nämlich über die Feiertage evtl .nochmal an das Thema App setzen wollen damit.

Grüße,
J*
VDR: ASRock 4Core SATA2, Intel Core2Duo E4500, 1GB Ram, MSI GT210, 2 x Cinergy 1200 DVB-C, yaVDR 0.5a, iStreamdev

450

Saturday, December 25th 2010, 9:44am

Latest development versions.

After a few minutes of watching a particular channel (xbmc log):

Quoted

PVR: VDR VNSI Client/127.0.0.1:34890 - Client returns bad error (-3) after SignalQuality

aelo

Professional

Posts: 1,059

Location: Österreich/Vlbg

  • Send private message

451

Saturday, December 25th 2010, 11:03am

Did you install the femon-plugin?
And which version do you use? The last version of Alwin or the newer one of Lars Op Den Kamp?

best regards & merry christmas
aelo

452

Saturday, December 25th 2010, 3:55pm

femon-plugin?

Using yavdr 0.3a with upgrades and dist-upgrades.

added ppa: the-vdr-team/unstable-plugins and yavdr/unstable-vdr

Watching only IPTV through VNSI - XBMC.

I also tried building it myself (using disable-ca-updates patch) as stated here:
http://www.linuxtv.org/pipermail/vdr/201…ber/023561.html

vdr is 1.7.16-12yavdr7_i386

... I think I don't have the latest dev builds. Alwin? Kamp? Where are the ppa's? :)

Thanks.

This post has been edited 1 times, last edit by "raw" (Dec 25th 2010, 3:59pm)


aelo

Professional

Posts: 1,059

Location: Österreich/Vlbg

  • Send private message

453

Saturday, December 25th 2010, 5:31pm

Okay just check whether you use more than one repository of the yavdr-team at the same time!
Because if you do so -> the plugin for vnsi and the version of xbmc may not fit together.
And if you still suffer under the same problem, make an entry in the yavdr bug tracker: https://bugs.yavdr.com/projects/yavdr/issues

best regards
aelo

Kloana

Trainee

Posts: 88

Location: Österreich/Stmk

Occupation: Netzwerkplaner

  • Send private message

454

Wednesday, January 12th 2011, 7:49am

Hallo,

ich wollte mal fragen, ob jemand was von Alwin/PingPong gehört hat. Wie geht denn die Entwicklung am VNSI weiter? Weiß da jemand was? Obdenkamp hat ja pvr-testing mit Dharma gemerged und pflegt Patche ein, aber wir daran auch entwickelt?

mfg
Herby

455

Wednesday, January 12th 2011, 11:54am

Quoted


... Obdenkamp hat ja pvr-testing mit Dharma gemerged und pflegt Patche ein, aber wir daran auch entwickelt?


Ich denke das fragt man am Besten im xbmc-Forum. L. Op den Kamp ist dort auch aktiv (dushmaniac afaik) und als PVR-Entwickler geführt. Wenn ich die commits in seinem git-repository anschaue, entwickelt er zumindest den pvr-Teil weiter.
Asus M3N78EM, X2 5050e, MP-S2 Twin Tuner, GT220, Ubuntu Lucid x86_64,v4l-dvb ngene-test, VDR 1.7.14 (The VDR Team), XBMC pvr-testing2 (hepi)

aelo

Professional

Posts: 1,059

Location: Österreich/Vlbg

  • Send private message

456

Wednesday, January 12th 2011, 12:20pm

Ich hab Alwin mal eine Email zukommen lassen :-)

Kloana

Trainee

Posts: 88

Location: Österreich/Stmk

Occupation: Netzwerkplaner

  • Send private message

457

Tuesday, January 18th 2011, 8:38am

Hi,

hast du schon was von Alwin gehört?

mfg
Herby

aelo

Professional

Posts: 1,059

Location: Österreich/Vlbg

  • Send private message

458

Tuesday, January 18th 2011, 9:49am

nö, leider nicht

horchi

Professional

Posts: 1,613

Location: Friedberg Hessen

  • Send private message

459

Monday, January 24th 2011, 11:18am

Hi,

erst mal danke für das tolle Plugin!
Habe es nun auch seit ca. einer Woche in Betrieb, leider immer mal mit Rucklern, mal selten mal so das man nicht schauen kann. Bei den Rucklern kommt in VDR Log eine Meldung bezüglich kaputter PES Pakete:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
19507:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: dropping broken PES packet
19509:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: payload not PES ?
19510:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: payload not PES ?
19511:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: dropping broken PES packet
19513:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: payload not PES ?
19514:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: dropping broken PES packet
19516:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: payload not PES ?
19517:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: dropping broken PES packet
19519:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: payload not PES ?
19520:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: dropping broken PES packet
19522:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: payload not PES ?
19523:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: dropping broken PES packet
19525:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: payload not PES ?
19526:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: payload not PES ?
19527:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: dropping broken PES packet
19529:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: payload not PES ?
19530:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: dropping broken PES packet
19532:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: payload not PES ?
19533:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: dropping broken PES packet
19535:Jan 23 21:00:36 horchi vdr: [10410] VNSI-Error: payload not PES ?
Ich verwende die aktuelle Version des Plug aus dem svn:

Source code

1
2
root@horchi:/usr/src/VDR/PLUGINS/src/vnsi# svn update
Revision 35744.
Ich habe ein paar Posts dazu gefunden nur nicht ob es jemand lösen konnte, ggf habe ich durch die Länge des Thread was übersehen, dann Sorry.

Der VDR (1.7.16) läuft unter Ubuntu 10.10, XBMC auf einem Mac-Mini.

Danke und viele Grüße,
Jörg

/EDIT
XBMC für den MAC habe ich von hier (dort das aktuellste):
http://xbmc.picmania.org/index.php?dir=&sort=date&order=desc
Kann man erkennen ob die Version zu dem VNSI aus dem svn passt?

meine VDRs

Bastel VDR - Kubuntu Natty mit yaVDR 0.5 (testing) Paketen, Intel Core2 Quad (Q6600) 2.40GHz, 4GB Ram,
Wohnzimmer VDR - yaVDR 0.5 (testing) mit softhddevice, Cine S2, Athlon II X2 240e, 4GB Ram, 64GB SSD, INTEL IRC, 2TB NFS und einer Harmony 700

Entwicklungen:
ipod - graphtft - pin - seduatmo - epgd - epg2vdr - squeezebox

This post has been edited 1 times, last edit by "horchi" (Jan 24th 2011, 11:26am)


horchi

Professional

Posts: 1,613

Location: Friedberg Hessen

  • Send private message

460

Thursday, January 27th 2011, 9:18am

Hi,

bin etwas weiter gekommen. Die oben genannten Meldungen bezüglich der PES Pakete kommen fast immer und unabhängig von den Rucklern. Also auch dann wenn alles Prima läuft.
Bei den Rucklern sehe ich zusätzlich Buffer 100% Meldungen, sieht für mich so aus als würde der Client die Daten nicht schnell genug abnehmen.

Gehe damit davon aus das man die 'PES' Meldungen ignorieren kann. Kann das jemand bestätigen?

Aufgrund der Buffer Meldungen habe ich das Netzwerk geprüft. Bislang war es schon zwei Mal reproduzierbar das in dieser Situation auch ein FTP zw. den Hosts sehr sehr langsam war (500-1000kByte/s statt der erwarteten knall 12MByte/s). Abhilfe schaffte jeweils ein Reset des Netzwerk Switches :o). Wenn es sich nochmals reproduzieren lässt werde ich wohl den Switch erneuern.

Danke, Grüße
Jörg

meine VDRs

Bastel VDR - Kubuntu Natty mit yaVDR 0.5 (testing) Paketen, Intel Core2 Quad (Q6600) 2.40GHz, 4GB Ram,
Wohnzimmer VDR - yaVDR 0.5 (testing) mit softhddevice, Cine S2, Athlon II X2 240e, 4GB Ram, 64GB SSD, INTEL IRC, 2TB NFS und einer Harmony 700

Entwicklungen:
ipod - graphtft - pin - seduatmo - epgd - epg2vdr - squeezebox