You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

gandalf

Professional

Posts: 799

Location: noch Madrid

Occupation: Telco Consultant

  • Send private message

101

Monday, December 14th 2009, 9:06pm

FS= FernSehen
--------------------------------------------------------------------------
HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin

102

Monday, December 14th 2009, 9:31pm

Aha! :D

Hm, Fersehkanäle laufen bei mir problemlos. Kannst höchstens mal die Einstellungen in Application Support löschen.
- VDR: Thermaltake DH 102 mit 7" TouchTFT * Mystique SaTiX-S2 Dual * Debian Wheezy/vdr-2.1.5/graphtft/MainMenuHooks-Patch * Intel Petium G3220 * DH87RL * Zotac GT630 * 1 TB System HDD * 4 GB Corsair Vegance * Harmony 900 (39-44W)
- Server: Zotac H55-ITX WiFi, Core i3 540, 4GB RAM, 4x4TB 3.5" WD RED + 1x500GB 2.5", Cine S2, vdr-2.1.6
- vdr-theme-darkred: https://github.com/TheChief79/vdr-theme-darkred

103

Tuesday, December 15th 2009, 11:37am

Holla TheChief,

also ich muß ja echt mal ein Lob loswerden.
ich suche ja schon lange einen Client für mein Macbook, habe dann zuletzt VDR RemoteX
verwendet, aber das ist echt der Hammer.

XBMC kenn ich von meinem Linux schon lange und habe es dann auch auf meinem Mac
eingesetz, aber jetzt mit VDR unterstützung ist das echt klasse.

Mit den kleinen Fehlern kann ich zur Zeit gut leben, ARD ruckel bei mir, EPG 1 Stunde zu früh
ist mir auch egal und meine Aufnahmen hab ich eh über eine Samba freigabe.

Also erst schon mal vielen Dank für Deine klasse Arbeit.

Gruß

THomas

104

Tuesday, December 15th 2009, 12:53pm

Danke für die Blumen, da macht man das doch gern. :) Und wenns einigermaßen läuft, freut mich das noch mehr. Ich versuch nebenbei auch noch nach einer Lösung mit den Aufnahmen zu suchen. Aber erstens bis ich kein C/C++ Profi und zweitens hab ich noch nicht wirklich den Durchblick, was wie und wo wann im Quelltext zu suchen ist.

Grüsse
TheChief
- VDR: Thermaltake DH 102 mit 7" TouchTFT * Mystique SaTiX-S2 Dual * Debian Wheezy/vdr-2.1.5/graphtft/MainMenuHooks-Patch * Intel Petium G3220 * DH87RL * Zotac GT630 * 1 TB System HDD * 4 GB Corsair Vegance * Harmony 900 (39-44W)
- Server: Zotac H55-ITX WiFi, Core i3 540, 4GB RAM, 4x4TB 3.5" WD RED + 1x500GB 2.5", Cine S2, vdr-2.1.6
- vdr-theme-darkred: https://github.com/TheChief79/vdr-theme-darkred

gandalf

Professional

Posts: 799

Location: noch Madrid

Occupation: Telco Consultant

  • Send private message

105

Tuesday, December 15th 2009, 1:10pm

Don't get me wrong guys.

Ich bin echt dankbar dass wir mit TheChief jemanden gefunden haben der sich die Mühe macht jeweils die Pakete zu bauen und der auch noch die Ergebnisse allen zur Verfügung stellt :respekt

Ich dachte halt nur ich berichte was bei mir noch nicht läuft!

Gruss,
Gandalf
--------------------------------------------------------------------------
HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin

106

Tuesday, December 15th 2009, 1:38pm

Immernoch keinen Erfolg gandalf? Hast Du mal die Einstellungen in Library/Apllications Support/XBMC gelöscht und es nochmal versucht?

Wie gesagt, Fernsehen kann ich auf allen Kanälen relativ problemlos, nur mit einigen Aufnahmen hab ich meine Probleme, wobei ich immernoch nicht festmachen kann, welche nicht gehen.
- VDR: Thermaltake DH 102 mit 7" TouchTFT * Mystique SaTiX-S2 Dual * Debian Wheezy/vdr-2.1.5/graphtft/MainMenuHooks-Patch * Intel Petium G3220 * DH87RL * Zotac GT630 * 1 TB System HDD * 4 GB Corsair Vegance * Harmony 900 (39-44W)
- Server: Zotac H55-ITX WiFi, Core i3 540, 4GB RAM, 4x4TB 3.5" WD RED + 1x500GB 2.5", Cine S2, vdr-2.1.6
- vdr-theme-darkred: https://github.com/TheChief79/vdr-theme-darkred

gandalf

Professional

Posts: 799

Location: noch Madrid

Occupation: Telco Consultant

  • Send private message

107

Tuesday, December 15th 2009, 1:42pm

Bin gerade auf Arbeit. Kann erst heute Abend weiter testen.
Gruss,
Gandalf
--------------------------------------------------------------------------
HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin

108

Tuesday, December 15th 2009, 4:23pm

Dann kannst Du auch gleich die neue Version mit Confluence Skin testen. Diese habe ich eben auf meinen Server geladen.

Neueste Version: r25714

Grüsse
TheChief
- VDR: Thermaltake DH 102 mit 7" TouchTFT * Mystique SaTiX-S2 Dual * Debian Wheezy/vdr-2.1.5/graphtft/MainMenuHooks-Patch * Intel Petium G3220 * DH87RL * Zotac GT630 * 1 TB System HDD * 4 GB Corsair Vegance * Harmony 900 (39-44W)
- Server: Zotac H55-ITX WiFi, Core i3 540, 4GB RAM, 4x4TB 3.5" WD RED + 1x500GB 2.5", Cine S2, vdr-2.1.6
- vdr-theme-darkred: https://github.com/TheChief79/vdr-theme-darkred

109

Tuesday, December 15th 2009, 11:45pm

Quoted

Original von TheChief
Dann kannst Du auch gleich die neue Version mit Confluence Skin testen. Diese habe ich eben auf meinen Server geladen.

Neueste Version: r25714

Grüsse
TheChief


Confluence läuft nicht. Entweder XBMC stürzt nach Aufruf eines Programmes ab, oder aber ich höre nur den Ton eines Senders und kann dann auch nicht mehr auf XBMC zugreifen.
PM3 läuft unter 25714
Grüße, Christian

Netceiver/3 Dual S2 + Alphacrypt , Aufnahmen -> QNAP NAS 8TB
Eigenbauserver: Intel DH61DL Mainboard, G620 CPU, 2GB RAM, yavdr 0.4 auf 8GB USB-Stick, 365/24/7

Clienten: 2x Netclient // Diverse Apples -> XBMC + VLC

110

Wednesday, December 16th 2009, 8:09am

hi,

also Confluence in der Version r25714 läuft bei mir seit gestern auf Debian Testing sehr gut,
es gehen zwar noch nicht alle Funktionen im TV ( Vollbild-OSD usw. ) aber das was läuft hat zumindest bei mir noch keine Probleme verursacht.

VDR-1.7.10 Streamserver pre5 20091108 mit allen Xbmc Patches XBMC pvr-testing2 r25714 -i386
PC AMD64 kein Mac!

mfg
vobie
OpenElec auf raspberry pi / Cubieboard2
Fernbedienungen: Handy, Fhem

This post has been edited 1 times, last edit by "jobit" (Dec 16th 2009, 8:14am)


gandalf

Professional

Posts: 799

Location: noch Madrid

Occupation: Telco Consultant

  • Send private message

111

Wednesday, December 16th 2009, 8:54am

Quoted

Originally posted by jobit
hi,

also Confluence in der Version r25714 läuft bei mir seit gestern auf Debian Testing sehr gut,
[...]
Was war noch gleich das Thema dieses Threads, "XBMC auf Debian ...." ?

Gruss,
Gandalf
--------------------------------------------------------------------------
HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin

112

Wednesday, December 16th 2009, 8:59am

Quoted

Original von gandalf

Quoted

Originally posted by jobit
hi,

also Confluence in der Version r25714 läuft bei mir seit gestern auf Debian Testing sehr gut,
[...]
Was war noch gleich das Thema dieses Threads, "XBMC auf Debian ...." ?

Gruss,
Gandalf


ja ja, is ja gut,
wollte damit nur sagen das es nicht generell an Confluence oder xbmc ligen kann.

mfg
jobit
OpenElec auf raspberry pi / Cubieboard2
Fernbedienungen: Handy, Fhem

gandalf

Professional

Posts: 799

Location: noch Madrid

Occupation: Telco Consultant

  • Send private message

113

Wednesday, December 16th 2009, 9:12am

Ja,

Confluence läuft schon seid einiger Zeit ganz gut, habe es auch auf einem Debian Server am Laufen. Nur eben auf dem Mac scheint es da noch Probleme zu geben...

Nichts für ungut,
Gandalf
--------------------------------------------------------------------------
HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin

114

Wednesday, December 16th 2009, 9:56am

Anfangs wollte es bei mir auch nicht, aber nach dem ich mal wieder die Einstellungen gelöscht habe und es ein paar mal probiert habe, gings dann.

@gandalf
Hast Du mal Debug Logging aktiviert? Eventuell steht ja was im Log, warums bei Dir nicht geht?
- VDR: Thermaltake DH 102 mit 7" TouchTFT * Mystique SaTiX-S2 Dual * Debian Wheezy/vdr-2.1.5/graphtft/MainMenuHooks-Patch * Intel Petium G3220 * DH87RL * Zotac GT630 * 1 TB System HDD * 4 GB Corsair Vegance * Harmony 900 (39-44W)
- Server: Zotac H55-ITX WiFi, Core i3 540, 4GB RAM, 4x4TB 3.5" WD RED + 1x500GB 2.5", Cine S2, vdr-2.1.6
- vdr-theme-darkred: https://github.com/TheChief79/vdr-theme-darkred

gandalf

Professional

Posts: 799

Location: noch Madrid

Occupation: Telco Consultant

  • Send private message

115

Wednesday, December 16th 2009, 10:02am

So,

Ich habe jetzt mal, wie hier empfohlen, /Library/Application Support/XBMC ersatzlos gelöscht und dann die r25714 geladen.

Erstens
Confluence Skin läuft problemlos, keine Beeinträchtigungen die ich auf das Skin zurückführen könnte

Zweitens
Live TV geht auch, auch wenn ich hier wohl noch Probleme mit dem Streamen bekomme, vor allem bei HD Sendern, siehe:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
Dec 16 09:50:13 VDR1 vdrdevel: [3847] buffer stats: 107912 (5%) used
Dec 16 09:50:13 VDR1 vdrdevel: [3847] receiver on device 2 thread ended (pid=3055, tid=3847)
Dec 16 09:50:13 VDR1 vdrdevel: [3849] receiver on device 2 thread started (pid=3055, tid=3849)
Dec 16 09:50:13 VDR1 vdrdevel: [3850] TS buffer on device 2 thread started (pid=3055, tid=3850)
Dec 16 09:50:13 VDR1 vdrdevel: [3850] TS buffer on device 2 thread ended (pid=3055, tid=3850)
Dec 16 09:50:13 VDR1 vdrdevel: [3849] buffer stats: 57152 (2%) used
Dec 16 09:50:13 VDR1 vdrdevel: [3849] receiver on device 2 thread ended (pid=3055, tid=3849)
Dec 16 09:50:13 VDR1 vdrdevel: [3851] receiver on device 2 thread started (pid=3055, tid=3851)
Dec 16 09:50:13 VDR1 vdrdevel: [3852] TS buffer on device 2 thread started (pid=3055, tid=3852)
Dec 16 09:50:15 VDR1 vdrdevel: [3851] buffer usage: 70% (tid=3846)
Dec 16 09:50:16 VDR1 vdrdevel: [3851] buffer usage: 80% (tid=3846)
Dec 16 09:50:16 VDR1 vdrdevel: [3851] buffer usage: 90% (tid=3846)
Dec 16 09:50:16 VDR1 vdrdevel: [3851] ERROR: 1 ring buffer overflow (188 bytes dropped)
Dec 16 09:50:17 VDR1 vdrdevel: [3118] ERROR: 1 ring buffer overflow (188 bytes dropped)
Dec 16 09:50:19 VDR1 vdrdevel: [3846] streamdev-livestreaming thread ended (pid=3055, tid=3846)
Dec 16 09:50:19 VDR1 vdrdevel: [3845] streamdev-writer thread ended (pid=3055, tid=3845)
Dec 16 09:50:19 VDR1 vdrdevel: [3152] buffer stats: 3759812 (99%) used
Dec 16 09:50:19 VDR1 vdrdevel: [3852] TS buffer on device 2 thread ended (pid=3055, tid=3852)
Dec 16 09:50:19 VDR1 vdrdevel: [3851] buffer stats: 132164 (6%) used
Dec 16 09:50:19 VDR1 vdrdevel: [3851] receiver on device 2 thread ended (pid=3055, tid=3851)
Dec 16 09:50:23 VDR1 vdrdevel: [3055] switching to channel 3
Dec 16 09:50:23 VDR1 vdrdevel: [3853] receiver on device 2 thread started (pid=3055, tid=3853)
Dec 16 09:50:23 VDR1 vdrdevel: [3854] TS buffer on device 2 thread started (pid=3055, tid=3854)


Drittens
Abspielen von "Normalen" Videos funktioniert einwandfrei, wenn auch gefühlt die Wiedergabe nicht so flüssig wie mit dem Quicktime-X Player oder VLC ist.
Abspielen von TV Aufnahmen geht bei mir definitiv nicht. Ich bekomme hier nur:

Source code

1
2
Dec 16 09:45:38 VDR1 vdrdevel: [3152] Streamdev: Setting data connection to 192.168.0.33:55660
Dec 16 09:45:38 VDR1 vdrdevel: [3152] openFile called for index 1 string:/var/lib/video.00/Series/HOSPITAL_CENTRAL#3A_'AUNQUE_SEA_LO_ULTIMO_QUE_HAGA'/Die_15.12.2009-22#3A30/2009-12-15.22.28.17-0.rec/00001.ts


Alles in allem kann man XBMC wohl bald als Mediencenter auf dem Mac einsetzen!

Gruss,
Gandalf
--------------------------------------------------------------------------
HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin

gandalf

Professional

Posts: 799

Location: noch Madrid

Occupation: Telco Consultant

  • Send private message

116

Wednesday, December 16th 2009, 10:03am

Quoted

Originally posted by TheChief
Anfangs wollte es bei mir auch nicht, aber nach dem ich mal wieder die Einstellungen gelöscht habe und es ein paar mal probiert habe, gings dann.

@gandalf
Hast Du mal Debug Logging aktiviert? Eventuell steht ja was im Log, warums bei Dir nicht geht?


Mache ich gerne. Kannst du mir kurz sagen wo man das aktiviert?

Gruss,
Gandalf
--------------------------------------------------------------------------
HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin

117

Wednesday, December 16th 2009, 10:15am

Unter Einstellungen=>System=>Fehlersuche. Das log findest Du dann unter Programme=>Dienstprogramme=>Konsole. Auch interessant wäre dann das Log vom VDR, beispielweise wenn Du einen Fernsehsender öffnest.
- VDR: Thermaltake DH 102 mit 7" TouchTFT * Mystique SaTiX-S2 Dual * Debian Wheezy/vdr-2.1.5/graphtft/MainMenuHooks-Patch * Intel Petium G3220 * DH87RL * Zotac GT630 * 1 TB System HDD * 4 GB Corsair Vegance * Harmony 900 (39-44W)
- Server: Zotac H55-ITX WiFi, Core i3 540, 4GB RAM, 4x4TB 3.5" WD RED + 1x500GB 2.5", Cine S2, vdr-2.1.6
- vdr-theme-darkred: https://github.com/TheChief79/vdr-theme-darkred

gandalf

Professional

Posts: 799

Location: noch Madrid

Occupation: Telco Consultant

  • Send private message

118

Wednesday, December 16th 2009, 10:17am

OK,

Ich hänge mich dran. Das Log des vdr beim Anspielen einer FS-Aufnahme habe ich ja weiter oben schon mitgegeben...

Gandalf
--------------------------------------------------------------------------
HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin

119

Wednesday, December 16th 2009, 10:19am

Ach hab grad gesehen, daß es bei Dir jetzt einigermaßen läuft. Ja, mit manchen Aufnahmen gibts bei mir auch probleme, ich kann aber noch nicht zuordnen, bei welchen. Erst hatte ich die Vermutung, die "neuen" TS Aufnahmen gehen nicht. Gestern hab ich allerdings auf Sat einen Film aufgenommen, den ich abspielen kann. Eventuell liegts am Adioformat der Filem, aber ich weiß es nicht. Du scheinst jetzt jedenfalls auf dem Stand zu sein, wie ich :)

HD Fernsehen kann ich nicht testen, da ich keine Karte habe. Wird langsam Zeit. ;)
- VDR: Thermaltake DH 102 mit 7" TouchTFT * Mystique SaTiX-S2 Dual * Debian Wheezy/vdr-2.1.5/graphtft/MainMenuHooks-Patch * Intel Petium G3220 * DH87RL * Zotac GT630 * 1 TB System HDD * 4 GB Corsair Vegance * Harmony 900 (39-44W)
- Server: Zotac H55-ITX WiFi, Core i3 540, 4GB RAM, 4x4TB 3.5" WD RED + 1x500GB 2.5", Cine S2, vdr-2.1.6
- vdr-theme-darkred: https://github.com/TheChief79/vdr-theme-darkred

gandalf

Professional

Posts: 799

Location: noch Madrid

Occupation: Telco Consultant

  • Send private message

120

Wednesday, December 16th 2009, 10:28am

Hmmm,

Eben ging Live TV noch problemlos, jetzt kratzt XBMC gleich ganz ab wenn ich auf den ersten Kanal gehen will...

Log auf dem MBP:

Source code

1
2
3
4
5
6
7
8
Dec 16 10:19:19 macbookpro-tpohl XBMC[3526]: XBMC(3526,0xa07a9500) malloc: *** error for object 0x1f01ae5: pointer being freed was not allocated\n*** set a breakpoint in malloc_error_break to debug
Dec 16 10:19:19 macbookpro-tpohl XBMC[3526]: XBMC(3526,0xa07a9500) malloc: *** error for object 0xe: pointer being freed was not allocated\n*** set a breakpoint in malloc_error_break to debug
Dec 16 10:19:19 macbookpro-tpohl XBMC[3526]: XBMC(3526,0xa07a9500) malloc: *** error for object 0xe7: pointer being freed was not allocated\n*** set a breakpoint in malloc_error_break to debug
Dec 16 10:19:19 macbookpro-tpohl XBMC[3526]: XBMC(3526,0xa07a9500) malloc: *** error for object 0x1f01ae5: pointer being freed was not allocated\n*** set a breakpoint in malloc_error_break to debug
Dec 16 10:19:19 macbookpro-tpohl XBMC[3526]: *** process 3526 exceeded 500 log message per second limit  -  remaining messages this second discarded ***
Dec 16 10:19:30 macbookpro-tpohl ReportCrash[3543]: [CrashReport _extractBinaryImageInfoUsingSymbolicator] caught exception: *** -[NSCFDictionary setObject:forKey:]: attempt to insert nil value (key: Identifier) (0x7fff83dce426 0x7fff82eab0f3 0x7fff83dce267 0x7fff83dce1f4 0x7fff88143ac3 0x100004638 0x7fff831a3917 0x1000044e2 0x100006a35 0x100007321 0x10000945f 0x10000923c 0x7fff83999474 0x100008943 0x7fff8398cf8e 0x7fff8398ce41)
Dec 16 10:19:33 macbookpro-tpohl com.apple.launchd.peruser.501[216] ([0x0-0x128128].com.teamxbmc.xbmc[3526]): Job appears to have crashed: Bus error
Dec 16 10:19:35 macbookpro-tpohl ReportCrash[3543]: Saved crash report for XBMC[3526] version 9.11.alpha2 (SVN-25714M) to /Users/thorsten/Library/Logs/DiagnosticReports/XBMC_2009-12-16-101935_thorsten-pohls-macbook-pro.crash

Wobei die "pointer being freed was not allocated" Meldungen sich endlos hinziehen, habe hier nur die letzten mit reingeschnitten. Den crash report hänge ich an.

VDR Log:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
Dec 16 10:19:06 VDR1 vdrdevel: [3118] channel 3 (KiKa) event Mit 16.12.2009 10:18-10:25 'Kikaninchen' status 4
Dec 16 10:19:10 VDR1 vdrdevel: [3055] OSD size changed to 720x576 @ 1,42222
Dec 16 10:19:14 VDR1 vdrdevel: [3152] Streamdev: Setting data connection to 192.168.0.33:56296
Dec 16 10:19:14 VDR1 vdrdevel: [3918] streamdev-writer thread started (pid=3055, tid=3918)
Dec 16 10:19:14 VDR1 vdrdevel: [3919] streamdev-livestreaming thread started (pid=3055, tid=3919)
Dec 16 10:19:15 VDR1 vdrdevel: [3877] TS buffer on device 2 thread ended (pid=3055, tid=3877)
Dec 16 10:19:15 VDR1 vdrdevel: [3876] buffer stats: 94376 (4%) used
Dec 16 10:19:15 VDR1 vdrdevel: [3876] receiver on device 2 thread ended (pid=3055, tid=3876)
Dec 16 10:19:15 VDR1 vdrdevel: [3920] receiver on device 2 thread started (pid=3055, tid=3920)
Dec 16 10:19:15 VDR1 vdrdevel: [3921] TS buffer on device 2 thread started (pid=3055, tid=3921)
Dec 16 10:19:15 VDR1 vdrdevel: [3055] switching to channel 3
Dec 16 10:19:15 VDR1 vdrdevel: [3055] info: Kanal nicht verfügbar!
Dec 16 10:19:16 VDR1 vdrdevel: [3921] TS buffer on device 2 thread ended (pid=3055, tid=3921)
Dec 16 10:19:16 VDR1 vdrdevel: [3920] buffer stats: 100956 (4%) used
Dec 16 10:19:16 VDR1 vdrdevel: [3920] receiver on device 2 thread ended (pid=3055, tid=3920)
Dec 16 10:19:16 VDR1 vdrdevel: [3922] receiver on device 2 thread started (pid=3055, tid=3922)
Dec 16 10:19:16 VDR1 vdrdevel: [3923] TS buffer on device 2 thread started (pid=3055, tid=3923)
Dec 16 10:19:16 VDR1 vdrdevel: [3923] TS buffer on device 2 thread ended (pid=3055, tid=3923)
Dec 16 10:19:16 VDR1 vdrdevel: [3922] buffer stats: 7332 (0%) used
Dec 16 10:19:16 VDR1 vdrdevel: [3922] receiver on device 2 thread ended (pid=3055, tid=3922)
Dec 16 10:19:16 VDR1 vdrdevel: [3924] receiver on device 2 thread started (pid=3055, tid=3924)
Dec 16 10:19:16 VDR1 vdrdevel: [3925] TS buffer on device 2 thread started (pid=3055, tid=3925)
Dec 16 10:19:17 VDR1 vdrdevel: [3118] channel 1 (Das Erste) event Mit 16.12.2009 10:03-10:25 'Brisant' status 4
Dec 16 10:19:21 VDR1 vdrdevel: [3118] ERROR: 1 ring buffer overflow (188 bytes dropped)
Dec 16 10:19:22 VDR1 vdrdevel: [3924] buffer usage: 70% (tid=3919)
Dec 16 10:19:22 VDR1 vdrdevel: [3924] buffer usage: 80% (tid=3919)
Dec 16 10:19:22 VDR1 vdrdevel: [3924] buffer usage: 90% (tid=3919)
Dec 16 10:19:22 VDR1 vdrdevel: [3924] ERROR: 1 ring buffer overflow (188 bytes dropped)
Dec 16 10:19:26 VDR1 vdrdevel: [3055] switching to channel 3
Dec 16 10:19:26 VDR1 vdrdevel: [3055] info: Kanal nicht verfügbar!
Dec 16 10:19:27 VDR1 vdrdevel: [3118] ERROR: 33 ring buffer overflows (6204 bytes dropped)
Dec 16 10:19:28 VDR1 vdrdevel: [3924] ERROR: 36356 ring buffer overflows (6834928 bytes dropped)
Dec 16 10:19:33 VDR1 vdrdevel: [3118] ERROR: 34 ring buffer overflows (6392 bytes dropped)
Dec 16 10:19:33 VDR1 vdrdevel: [3152] client (VTP) 192.168.0.33:56277 has closed connection
Dec 16 10:19:33 VDR1 vdrdevel: [3152] streamdev: closing streamdev connection to 192.168.0.33:56277
Dec 16 10:19:33 VDR1 vdrdevel: [3918] ERROR: streamdev-server: couldn't send 574556 bytes: Datenübergabe unterbrochen (broken pipe)
Dec 16 10:19:33 VDR1 vdrdevel: [3918] streamdev-writer thread ended (pid=3055, tid=3918)
Dec 16 10:19:33 VDR1 vdrdevel: [3919] streamdev-livestreaming thread ended (pid=3055, tid=3919)
Dec 16 10:19:33 VDR1 vdrdevel: [3152] buffer stats: 3759812 (99%) used
Dec 16 10:19:33 VDR1 vdrdevel: [3925] TS buffer on device 2 thread ended (pid=3055, tid=3925)
Dec 16 10:19:33 VDR1 vdrdevel: [3924] buffer stats: 139120 (6%) used
Dec 16 10:19:33 VDR1 vdrdevel: [3924] receiver on device 2 thread ended (pid=3055, tid=3924)
Dec 16 10:19:37 VDR1 vdrdevel: [3055] switching to channel 3
Dec 16 10:19:37 VDR1 vdrdevel: [3926] receiver on device 2 thread started (pid=3055, tid=3926)
Dec 16 10:19:37 VDR1 vdrdevel: [3927] TS buffer on device 2 thread started (pid=3055, tid=3927)
gandalf has attached the following file:
--------------------------------------------------------------------------
HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin