You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

761

Thursday, June 24th 2004, 6:14pm

Quoted

Scheint ein Laufzeitproblem zu sein, jetzt frag mich aber nicht ob eine schneller ober langsamer Rechner besser ist, ich habe ein EPIA-M10000 (1GHz)

Hier läuft es mit einem 1.3GHz Celeron. Kann ich leider nicht runtertakten, sonst hätte ich das mal getestet. Vielleicht bekommen wir ja noch von anderen etwas Feedback.

Tom

762

Thursday, June 24th 2004, 6:23pm

Quoted

Original von TBE
@LarsAC (RC5-Tastaturencoder)



  • Benutze mal Testweise die Universal-lircd.conf und schau dir die Ausgaben von irw an (Seite 28 im Thread).
  • Der RC5-Encoder SAA3010 übernimmmt die Tastenentprellung, siehe Datenblatt. Das ist doch eine vom PIC vollkommen unabhängige Schaltung. Direkt wird der PIC nur über die beiden Tasten POWER und EJECT gesteuert, und die sind selbstverständlich in der Firmware entprellt.



Das sieht schon bedeutend besser aus! Hatte noch gar keine lirc.conf und wollte mit mode2 erstmal Konfigurationsprobleme ausschließen. War wohl der falsche Weg.

Zwei Taster tun nicht, aber das finde ich wohl hoffentlich noch.

Lars

763

Thursday, June 24th 2004, 6:24pm

Hi,

jetzt konnte ich das ganze auch reproduzieren, bei mir waren halt nur 4 LED gleichzeitig
notwendig ?(

Das ganze passiert aber nur wenn die Wiedergabe per "Blau" beendet wird,
bei "Exit" wo das Aufnahmemenu erscheint passiert es nicht :rolleyes:

Ich werde das ganze doch mal auf die asyncrone Version umbauen, und
schauen ob sich damit eine Besserung ergibt...

Andreas
System: VDR 2.0 unter Debian Wheezy
Aktive Projekte : Radiorecorder Web GUI | DVD-Switch Plugin | targa VFD Plugin | XXV - Xtreme eXtension for VDR

This post has been edited 1 times, last edit by "Hulk" (Jun 24th 2004, 7:11pm)


764

Thursday, June 24th 2004, 6:25pm

Quoted

Original von TBE

Quoted

Scheint ein Laufzeitproblem zu sein, jetzt frag mich aber nicht ob eine schneller ober langsamer Rechner besser ist, ich habe ein EPIA-M10000 (1GHz)

Hier läuft es mit einem 1.3GHz Celeron. Kann ich leider nicht runtertakten, sonst hätte ich das mal getestet. Vielleicht bekommen wir ja noch von anderen etwas Feedback.


NPTL-Problem ist aber ausgeschlossen?

Lars

765

Friday, June 25th 2004, 12:41am

Probleme beim ansprechen des Extension Boards

Hallo,

ich habe jetzt endlich Zeit gefunden das extension Board an meinen
VDR anzuschließen. Doch schon fangen die Probleme an ...
Beim Versuch die neue Firmware auf das Board zu spielen bleibt das Programm
beim suchen vom Boot-Loader hängen ... sprich es zeigt nur Punkte an.
Das habe ich jeweils auf beiden Seriellen Schnittstellen ausprobiert!
Wo kann der Fehler liegen?

- Kabel sind O.K.
- lircd ist gestoppt
- das Kernelmodul (licserial) ist entladen

Grüße

Schrobbl

Pit Carlo

Intermediate

Posts: 419

Location: Wien

  • Send private message

766

Friday, June 25th 2004, 1:11am

RE: Probleme beim ansprechen des Extension Boards

@ TBE
Habe jetzt den TV-Out so wie Du geschrieben hast angeschlossen und funktioniert super
Danke für Deine Hilfe

@ Alle
Gibt es schon die neueste Version vom extb-Plugin für den c´t Multipatch?
Wenn ja wo bitte!

Bei dem script extb.sh steht VDR_CMD="./runvdr" was muss ich da für die c´t Disti eintragen

Danke
Pit
Intel 1800Mhz c´t 6.1 VDR 1.6.0 Multipatch (Tobi) Plugin Timelinie Nordlicht-EPG Epgsearch Noad

This post has been edited 1 times, last edit by "Pit Carlo" (Jun 25th 2004, 1:22am)


767

Friday, June 25th 2004, 3:48pm

RE: Probleme beim ansprechen des Extension Boards

Quoted

Original von schrobbl
Hallo,

ich habe jetzt endlich Zeit gefunden das extension Board an meinen
VDR anzuschließen. Doch schon fangen die Probleme an ...
Beim Versuch die neue Firmware auf das Board zu spielen bleibt das Programm
beim suchen vom Boot-Loader hängen ... sprich es zeigt nur Punkte an.
Das habe ich jeweils auf beiden Seriellen Schnittstellen ausprobiert!
Wo kann der Fehler liegen?

- Kabel sind O.K.
- lircd ist gestoppt
- das Kernelmodul (licserial) ist entladen

Grüße

Schrobbl


Du drückst nach dem Starten des Downloads aber schon auf die Reset-Taste am Extension-Board, oder etwa nicht ? ;)

768

Friday, June 25th 2004, 4:00pm

Hi,

Quoted

Original von TBE
die Reihenfolge der Plugins hatte ich ja schon geändert, das hilft nicht. Ist aber nicht so tragisch, normalerweise schalten sich ja nicht zwei LEDs ab, wenn man eine VDR-Wiedergabe beendet. War ja nur zum Testen. Wieso tritt der Crash bei dir eigentlich nicht auf?


Eine neue Version des extb-Plugins liegt auf dem Server,

http://deltab.de/vdr/extb.html
http://deltab.de/vdr/vdr-extb-0.2.6.tgz

Das Senden der LIRC-Codes durch das Plugin ist jetzt vom Hauptthread
mit einen eigenem Thread und einem Kommadoqueue entkoppelt und
damit konnte ich diesen Crash beim Wiedergabestop nicht mehr reproduzieren,
kleiner netter Nebeneffekt ist, das der VDR rein subjektiv ein wenig schneller reagiert ;D
das der VDR nicht mehr auf das Plugin warten muss bis die LIRC Codes gesendet sind.

Andreas
System: VDR 2.0 unter Debian Wheezy
Aktive Projekte : Radiorecorder Web GUI | DVD-Switch Plugin | targa VFD Plugin | XXV - Xtreme eXtension for VDR

769

Friday, June 25th 2004, 4:11pm

Wo liegt denn nochmal die aktuelle Firmware?

Lars

770

Friday, June 25th 2004, 4:17pm

Hallo,

Quoted

Original von LarsAC
Wo liegt denn nochmal die aktuelle Firmware?


meiner Meinung nach, ist das diese hier :
http://home.t-online.de/home/tb_electron…xtb_1.04.hex.gz
(Serverdatum 17-Jun-2004 14:31 )

Andreas
System: VDR 2.0 unter Debian Wheezy
Aktive Projekte : Radiorecorder Web GUI | DVD-Switch Plugin | targa VFD Plugin | XXV - Xtreme eXtension for VDR

771

Saturday, June 26th 2004, 10:35am

gibts noch welche bzw. gibts irgendwann wieder diese Boards?

Hallo miteinander!

Habe auch vor hurzem angefange, mir einen VDR (auf C´T Basis) zusammenzubauen. Und da ich mit der Bildqualität noch nicht ganz zufrieden bin (habe das RGB Signal vom J2 Block einfach auf Scart geleitet - Signalstärke ist dadurch verm. zu groß) habe ich auch großes Interesse am Extension Bord. Deshalb meine Frage ob es noch zu bekommen ist bzw. ob es wieder eine neue Auflage gibt?

Schöne Grüße

Thomas

Mike87

Beginner

Posts: 44

Location: bei Kaiserslautern

Occupation: Student

  • Send private message

772

Saturday, June 26th 2004, 3:25pm

hallo
ich habe das ext.-board über umwege entdeckt. (post von lars im ac-forum)
es ist genau das, was ich suche. habe vor kurzem die c't distri. installiert und nurtze sie nun täglich.
gibt es noch eine möglichkeit eines zu bekommen oder wann wird es eine neue auflage geben?
SD-VDR: P IV 1,8Ghz, FF 1.5, extb. c'T-VDR in Rente
HD-VDR: Zotac ION ITX F, 2GB Ram, WD green 1TB, Mystique SaTiX-S2 V2 CI Dual, yaVDR 0.4 SuperTalent 32 GB SSD, openelec 2.0

Server: Supermicro X8DTL-3F, 2x Xeon L5630, 32GB Ram, ESXi 5.1 auf USB-Stick, OpenIndiana auf 320GB Datastore als Fileserver mit 6x 2TB, u.A. yaVDR 0.5 headless mit Cine S2 V6 Dual DVB-S2
Sony KDL-32V2000, Yamaha RX-V2700


VDR-User 1232 seit 07/2004

This post has been edited 1 times, last edit by "Mike87" (Jun 26th 2004, 3:25pm)


rafter

Trainee

Posts: 147

Location: Nähe Darmstadt

  • Send private message

773

Saturday, June 26th 2004, 6:13pm

Servus @ all

Ich bin auch auf das Extension Board aufmerksam geworden. Das wäre wirklich etwas, das ich noch gebrauchen könnte. Also schließe ich mich obigen Fragen an, ob noch Boards erhältlich sind.

cya
Sebastian
VDR-User #1494
VDR Wohnzimmer
PIII 933 MHz | FSC D1184 | 2x FF DVB-S | VDR 1.6.0 ctvdr | Kernel 2.6.16 | LIRC 0.8
Mein VDR
Core Duo 1,66 GHz | AOpen i945GMm-HL | TT3200 DVB-S2 | GF8400GS | VDR 1.7.14 | yavdr 0.2
NAS
Pentium Dual-Core E2140 | Intel DQ965GF | Opensolaris 11/2005 | 3 TB RAID 5

Mozart488

Trainee

Posts: 121

Location: München

Occupation: Musiker / Pianist

  • Send private message

774

Saturday, June 26th 2004, 6:55pm

Extension Board V2 abzugeben

Hallo,

ich hätte ein unbenutztes Extension Board V2 abzugeben.

Mein anfänglicher Enthusiasmus am VDR ist inzwischen verraucht. Deshalb brauche ich das Board nicht mehr.

Das Board ist so verpackt, wie es von TBE vor ca. 3 Wochen mit der Post kam.
Es wurde weder angeschlossen, noch in Betrieb genommen.
Es ist also neuwertig.

Wer Interesse hat möge sich bitte melden.

Schöne Grüße
Lukas.

Nur zur Info: Das Board ist verkauft.
VDR M:
Revo 3610 mit yavdr hoffentlich bald
Hardware: Compaq Deskpro EP, TT DVB-S 2300, 200 GB Samsung SP2014N
Software: LinVDR 0.7, Dr. Seltsam 2.6.17.8, tarandor+cody, vdr1.4.2-1

This post has been edited 1 times, last edit by "Mozart488" (Jun 28th 2004, 11:32pm)


775

Monday, June 28th 2004, 10:34pm

RE: Probleme beim ansprechen des Extension Boards

Hhhuuupss,

ich sag nur eins RTFM und dann muß man ja auch noch die richtige
"Reset-Taste" drücken!http://www.vdrportal.de/board/images/icons/icon6.gif
wütend

Grüße

Schrobbl

776

Monday, June 28th 2004, 10:48pm

1 Sekunde drücken der PWR-Taste zum anschalten

Hallo,

ist es möglich die Zeit zum drücken der PWE-Taste auf der Fernbedienung
zu verändern. Ich habe nämlich das Problem, das höchtens 3 Signale von
der FB gesendet werden (ist ein Umsetzter)!

Grüße
Schrobbl

777

Tuesday, June 29th 2004, 8:16pm

Hallo,

@Andreas:
Wie schon per PM: Das neue Plugin läuft jetzt einwandfrei! Vielen Dank!

@schrobbl:
Die Verzögerung ist nicht einstellbar. Könnte ich aber noch mit einbauen (entweder ins Setup oder beim Anlernen der PWR-Taste). Auswahl dann z.B. 'Keine Verzögerung' oder '1 Sekunde Verzögerung'. Besteht daran allgemeines Interesse?

Ich habe euch hier mal eine Version der aktuellen Firmware ohne Einschaltverzögerung bereitgestellt:
http://www.tb-electronic.de/vdr/tmp/extb_1.04a.hex.gz


An alle neuen Interessenten: Es sind leider alle Boards vergeben :( Eventuell wird noch eins verfügbar, da es noch einen Vorbesteller gibt, der sich einfach nicht mehr meldet. Am besten, ihr schickt eine e-mail (siehe Link im ersten Posting dieses Threads). Für eine Neuauflage müssten allerdings erst wieder einige Boards zusammenkommen.

Grüße,
Tom

This post has been edited 1 times, last edit by "TBE" (Oct 25th 2004, 12:16am)


Luzifer

Intermediate

Posts: 243

Location: NRW

  • Send private message

778

Tuesday, June 29th 2004, 8:30pm

extb-0.2.6

Hallo,

habe folgende Fehlermeldung:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
make[1]make[1]: Entering directory `/usr/local/src/vdr-1.3.11/PLUGINS/src/extb'
g++ -O2 -Wall -Woverloaded-virtual -c -DPLUGIN_NAME_I18N='"extb"' -D_GNU_SOURCE -I../../../include -I../../../../DVB/include extb.c
In file included from /usr/lib/gcc-lib/i386-linux/2.95.4/../../../../include/g++-3/vector:30,
                 from lirc.h:5,
                 from extboardio.h:27,
                 from extb_status.h:6,
                 from extb.c:13:
/usr/lib/gcc-lib/i386-linux/2.95.4/../../../../include/g++-3/stl_algobase.h:76: redefinition of `template <class _Tp> void swap(_Tp &, _Tp &)'
../../../include/vdr/tools.h:52: `template <class T> void swap(T &, T &)' previously declared here
/usr/lib/gcc-lib/i386-linux/2.95.4/../../../../include/g++-3/stl_algobase.h:76: redefinition of `void swap(_Tp &, _Tp &)'
../../../include/vdr/tools.h:52: `void swap(T &, T &)' previously defined here
make[1]: *** [extb.o] Error 1


Kann mir da jemand helfen?
Gruß
Lu

:]LinVDR 0.7 mit VDR 1.3.22, Kernel 2.6.10, Vdradmin-0.97, Burn-0.0.6, Text2Skin-1.0, MP3-0.9.11, MPlayer-0.9.11, (S)VCD-0.0.7, Yaepg-0.0.2, Sleeptimer-0.6, DVD-0.3.6-b02-cvs, Osdteletext-0.4.2, Osdpip-0.0.7.2, Director-0.2.1a, Graphlcd-0.1.2-pre4, Graphtft-0.0.8, Image-0.2.3, Femon-0.8.5, Extb-0.2.9:]

779

Tuesday, June 29th 2004, 8:39pm

RE: extb-0.2.6

@Luzifer

ändere mal in lirc.h
folgende Zeilen

#include <vdr/plugin.h>
#include <vector>

in

#include <vector>
#define __STL_CONFIG_H
#include <vdr/plugin.h>

immer diese Probleme mit den alten Compilern ;-)
Andreas
System: VDR 2.0 unter Debian Wheezy
Aktive Projekte : Radiorecorder Web GUI | DVD-Switch Plugin | targa VFD Plugin | XXV - Xtreme eXtension for VDR

Luzifer

Intermediate

Posts: 243

Location: NRW

  • Send private message

780

Tuesday, June 29th 2004, 8:52pm

RE: extb-0.2.6

Hallo,

@Hulk
mag leider noch immer nicht. Selbe Fehlermeldung wie oben.

Hast du evtl. noch einen anderen Vorschlag?!
Gruß
Lu

:]LinVDR 0.7 mit VDR 1.3.22, Kernel 2.6.10, Vdradmin-0.97, Burn-0.0.6, Text2Skin-1.0, MP3-0.9.11, MPlayer-0.9.11, (S)VCD-0.0.7, Yaepg-0.0.2, Sleeptimer-0.6, DVD-0.3.6-b02-cvs, Osdteletext-0.4.2, Osdpip-0.0.7.2, Director-0.2.1a, Graphlcd-0.1.2-pre4, Graphtft-0.0.8, Image-0.2.3, Femon-0.8.5, Extb-0.2.9:]