Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Sonntag, 6. Juni 2010, 12:25

[0.2] yaVDR als Client zu c'tVDR Server

Moin moin,

nachdem mein c'tVDR Server nun schon einige Tage gut vor sich hinläuft und auch aufnimmt was ich ihm über VDRadmin auftrage, hab ich mich heute daran begeben auf meinem Client (Acer Revo 3610) yaVDR zu installieren.
Installation klappte super, laufen tut das Teil bisher auch ohne Fehler, schön aussehen tuts auch, aber wie zum Teufel komm ich an LiveTV etc.?

Ich such mir hier schon einen Wolf und komm irgendwie nicht drauf was ich unternehmen muss um über den Client Live-TV zu empfangen und die Aufnahmen anzuschauen.

Hoffe mir kann da jemand fix nen Tip geben.
Gruß

Majjo

2

Sonntag, 6. Juni 2010, 12:28

RE: [0.2] yaVDR als Client zu c'tVDR Server

je nach wuensche

vdr per streamdev-server und -client zu ner empfangsmoeglichkeit verhelfen.

vdr deinstallieren (wozu dann noch yavdr :P) und per xineliboutput plugin zum server konekten.
koennte aber "probleme" geben wegen unterschiedlichen plugin und vdr-sxfe.

...
2003 - 2011 - R.I.P.

3

Sonntag, 6. Juni 2010, 12:36

RE: [0.2] yaVDR als Client zu c'tVDR Server

Zitat

Original von wilderigel
vdr per streamdev-server und -client zu ner empfangsmoeglichkeit verhelfen.

Wie stell ich das an?
Gruß

Majjo

4

Sonntag, 6. Juni 2010, 12:38

naja, streamdev-server am server und streamdev-client am client installiern?
dann server fuer vdr2vdr streaming configurieren und client fuer server einstellen.

fertig.

(nix yavdr spezifisches)
2003 - 2011 - R.I.P.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »wilderigel« (6. Juni 2010, 12:39)


5

Sonntag, 6. Juni 2010, 12:42

So in etwa hab ich mir das eigentlich gedacht, doch ich find kein Paket zu streamdev-client.
Nur das Serverpaket.

Ich glaub die Hitze macht mich matschig ;)
Gruß

Majjo

6

Sonntag, 6. Juni 2010, 12:43

vdr-plugin-streamdev-client (hab alllerdings kein yavdr)
2003 - 2011 - R.I.P.

7

Sonntag, 6. Juni 2010, 12:47

Ich idiot.
Genau das hab ich schon probiert. (Hab ich gedacht)
Hatte vorher was mit apt-get remove runter gemacht.
Bin dann nur einen Befehl zurück gegangen und hab den Namen angepasst.
Passierte natürlich nix, da er es ja nicht löschen konnte weils nicht drauf war.

Habs allerdings auch nicht mit dpkg -l *stream* finden können, das machte mich dann stutzig.

Danke dir und schönen Sonntag noch.
Gruß

Majjo

8

Sonntag, 6. Juni 2010, 15:35

Komme da leider grad nicht weiter.
PVR Klient VDRClient für Streamdev ist aktiviert.
IP des Servers eingestellt, Port eingestellt (mit beidem kann ich über VLC Player von meinem Windows PC aus TV schauen).
Beim Klick auf Live TV in XBMC kommt die Meldung

Zitat

Keine PVR Klienten verfügbar.
Bitte überprüfen Sie Ihre Einstellungen oder den Server

Wobei ich eben auch mal diese Meldung bekam

Zitat

Erweiterung konnte nicht genutzt werden keine Verbindung

Syslog des Servers sagt folgendes

Zitat

Jun 6 15:12:21 vdr vdr: [2522] Streamdev: Accepted new client (HTTP) 192.168.0.8:40348


Eine Idee?
Gruß

Majjo

9

Sonntag, 6. Juni 2010, 15:38

probier zuerst mal vdr-sxfe

wenn das tut noch vnsiserver fuer xbmc dazu und dann xbmc testen

is aber sehr verschlungen der datenweg dann.

ausserdem wiki tipps wegen umschalten beachten (auf der pluginseite)
2003 - 2011 - R.I.P.

10

Sonntag, 6. Juni 2010, 21:40

Nichts zu machen.
Ich bekomme einfach kein Bild.
Kanal nicht verfügbar wird mir beim 1. nur gesagt.
IP und Port hab ich alles eingestellt.
Also rein theoretisch sollte er alle Daten vom Server haben.

Noch ne andere Idee?
Ich steh da voll auf dem Schlauch.
Hab jetzt den halben Sonntag davor gesessen.
Gruß

Majjo

11

Sonntag, 6. Juni 2010, 21:45

zeig mel streamdev* eintraege von der setup.conf vom server und clienten.

wasn fuer ne vdr version am server?
2003 - 2011 - R.I.P.

12

Sonntag, 6. Juni 2010, 21:53

verwendest du auch die gleiche Streamdev Server & Client Version (auch Patches sind unter Umständen zu beachten)?

13

Sonntag, 6. Juni 2010, 22:49

Wenn es ein 1.6er c't VDR ist, musst Du das streamdev-Paket auf dem Server evtl. austauschen gegen ein selbstkompiliertes. Ich musste das machen, um XBMC damit verbinden zu können.

Wo genau Du die passenden Sourcen herbekommst, müsste Dir wohl ein yaVDR-Entwickler sagen. Meinen Source habe ich von http://streamdev.vdr-developer.org/ (unter XBMC)

Ich glaube, mein freeVDR verwendet pvr-testing und yaVDR pvr-testing2. Keine Ahnung, ob das ansatzweise kompatibel ist.

Gruß,
Bienchen :)

Client 1: yaVDR 0.4, ION, streamdev + sundtek SkyTV Ultimate
Client 2: yaVDR 0.4, ION, streamdev-only-Client
Server: yaVDR 0.4, i5 2500, headless, dd Cine S2 v6, 4x

[[ Ein dickes Danke an die Macher von yaVDR, die uns ein leicht aufzusetzendes, toll funktionierendes Media-Home ermöglichen! ]]


14

Montag, 7. Juni 2010, 07:17

Zitat

Original von wilderigel
zeig mel streamdev* eintraege von der setup.conf vom server und clienten.

wasn fuer ne vdr version am server?


Client

Zitat

streamdev-client.HideMenuEntry = 0
streamdev-client.MaxPriority = 99
streamdev-client.MinPriority = -1
streamdev-client.RemoteIp = 192.168.0.7
streamdev-client.RemotePort = 3000
streamdev-client.StartClient = 1
streamdev-client.StreamFilters = 1
streamdev-client.SyncEPG = 1
streamdev-server.AllowSuspend = 0
streamdev-server.HTTPBindIP = 0.0.0.0
streamdev-server.HTTPServerPort = 3000
streamdev-server.HTTPStreamType = 0
streamdev-server.IGMPBindIP = 0.0.0.0
streamdev-server.IGMPClientPort = 1234
streamdev-server.IGMPStreamType = 0
streamdev-server.MaxClients = 5
streamdev-server.ServerPort = 2004
streamdev-server.StartHTTPServer = 1
streamdev-server.StartIGMPServer = 0
streamdev-server.StartServer = 1
streamdev-server.SuspendMode = 1
streamdev-server.VTPBindIP = 0.0.0.0


Server
Nix!
Also Streamdev Einträge hab ich da nirgends gefunden, das läuft aber, ich kann es ja auch über VLC am WinPC empfangen.

VDR-Info

Zitat

**************************************
* c't VDR Ãýersicht *
**************************************
VDR : 1.6.0-17ctvdr1
Kernel: 2.6.28-etobi.3-686
ABI : vdr-abi-1.6.0-multipatch-2009-05-03
Patches:
--------------------------------------
opt-20_liemikuutio
opt-21_internal-cam-devices
opt-24_jumpplay
opt-27_ttxtsubs
opt-28_audioindexer
opt-29_syncearly-audioindexer
opt-30-x_analogtv
opt-31-x_reelchannelscan
opt-37-x_menuorg
opt-38_disableDoubleEpgEntrys


Client

Zitat

ii vdr-plugin-streamdev-client 0.5.0~pre20090706+cvs20100307.210 VDR Plugin to stream Live-TV to other VDR's - client part
ii vdr-plugin-streamdev-server 0.5.0~pre20090706+cvs20100307.210 VDR Plugin to stream Live-TV to other VDR's - server part


Server

Zitat

ii vdr-plugin-streamdev-client 0.5.0~pre20090706+cvs20091108.2341-3 VDR Plugin to stream Live-TV to other VDR's - client part
ii vdr-plugin-streamdev-server 0.5.0~pre20090706+cvs20091108.2341-3 VDR Plugin to stream Live-TV to other VDR's - server part
Gruß

Majjo

15

Montag, 7. Juni 2010, 20:38

So, ich hab jetzt mal ne leere Platte in den Server gegen die mit c't VDR getauscht und dort ebenfalls yaVDR drauf gemacht.

Alles soweit eingestellt, channels.conf hochgeladen, IPs zum Streamserver eingestellt.
Hab auf dem Server mit dem Frontend vdr-sxfe@vdr-plugin-xineliboutput nichtmal ein Bild bekommen.
Kanal nicht verfügbar.

Was muss ich denn machen um dort ein Bild zu bekommen?
Wie gesagt, Channels.conf ist drauf.

Will er vielleicht meine DVB Karten nicht?

Zitat

Jun 7 20:05:14 vdr vdr: [3817] ERROR: can't open DVB device 0/0
Jun 7 20:05:14 vdr vdr: [3817] ERROR: can't open DVB device 1/0


Hab 2 Technisat SkyStar 2 verbaut.

EDIT:
Das find ich anschliessend auch noch im syslog

Zitat

Jun 7 20:10:28 vdr vdr: [9009] frontend 0/0 provides DVB-S ("Conexant CX24123/CX24109")
Jun 7 20:10:28 vdr vdr: [9009] frontend 1/0 provides DVB-S ("Conexant CX24123/CX24109")
Jun 7 20:10:28 vdr vdr: [9009] found 2 DVB devices


Also hat er nun die DVB Karten?

Mist, mir raucht der Kopf :(
Gruß

Majjo

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Majjo« (7. Juni 2010, 20:41)


16

Sonntag, 13. Juni 2010, 09:56

Ob er die Karten mag, könnte man doch zunächst ohne streamdev testen, indem man lokal eine Aufnahme macht, oder?

Client 1: yaVDR 0.4, ION, streamdev + sundtek SkyTV Ultimate
Client 2: yaVDR 0.4, ION, streamdev-only-Client
Server: yaVDR 0.4, i5 2500, headless, dd Cine S2 v6, 4x

[[ Ein dickes Danke an die Macher von yaVDR, die uns ein leicht aufzusetzendes, toll funktionierendes Media-Home ermöglichen! ]]


Immortal Romance Spielautomat