You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Thyor

Professional

  • "Thyor" started this thread

Posts: 627

Location: NRW / Münsterland

  • Send private message

1

Sunday, March 14th 2010, 12:26pm

[gelöst] Pollin X10 Remote funktioniert (teilweise)

Hi,

eigentlich hatte ich ja den Igor-USB-Lirc ans laufen bekommen. Leider musste ich aber nach jedem Neustart den Igor-USB auf ein anderen USB-Port stecken, damit er dann wieder lief.
Daher habe ich schon vor einigen Wochen versucht auf die Pollin X10 Remote (die silberne mit dem schwarzen rechten Rand) zu wechseln. Leider klappte das bisher nicht. Nach einem apt-get upgrade funktioniert die Pollin jedoch völlig unerwartet. Nicht alle Tasten - aber Zahlen und Pfeiltasten.

Merkwürdig ist hierbei, dass ich in der Webkonfiguration noch die Igor-USB ausgwählt hatte und dass ich derzeit gerade auch keine /etc/lirc/lircd.conf hatte.
Wenn ich die ATI-USB im Webfrontend wähle, funktioniert es dann irritierender weise nicht mehr.
Ein lsmod zeigt (bei ausgewählter Igor-USB sowohl das Igor-Usb) als auch das Ati_Remote Modul.

Die Pollin scheint also immer einen anderen Kanal als Lirc reinzukommen. (IRW sag nichts, killall lircd bewirkt nichts)
Falls das zutreffen sollte?
Wo kann man die restlichen Tasten (z.B. OK) konfigurieren?
MfG
Thomas

yaVDR 0.5: MSI K9AG Neo2-Digital, Athlon X2 BE-2400, RAM: 4GB; HDMI: ZOTAC GT610; HDD: 3TB; DVB-S2: 2x TBS-6981 Doppel-Tuner; FB: Pollin X10
Streaming-Clients: S100 mit 2,5"-HDD unter Zendeb 0.3 von Egalus

This post has been edited 1 times, last edit by "Thyor" (Mar 21st 2010, 5:30pm)


2

Sunday, March 14th 2010, 5:16pm

RE: Pollin X10 Remote funktioniert (teilweise)

Hossa,
hatte das gleiche Problem mit einer MSi Karte. Nachdem ich in den logs geschaut habe /var/logs/syslog oder messages hab ich da die codes die nicht erkannt worden sind aufgeschrieben und den Treiber um diese erweitert. Das must du wohl auch machen.
MfG

Thyor

Professional

  • "Thyor" started this thread

Posts: 627

Location: NRW / Münsterland

  • Send private message

3

Sunday, March 14th 2010, 7:08pm

Hi,

das hört sich ja recht aussichtsreich an.

Wo kann man denn konkret die fehlenden Codes nachtragen?
MfG
Thomas

yaVDR 0.5: MSI K9AG Neo2-Digital, Athlon X2 BE-2400, RAM: 4GB; HDMI: ZOTAC GT610; HDD: 3TB; DVB-S2: 2x TBS-6981 Doppel-Tuner; FB: Pollin X10
Streaming-Clients: S100 mit 2,5"-HDD unter Zendeb 0.3 von Egalus

4

Sunday, March 14th 2010, 7:27pm

wichtig ist das log: /var/log/syslog
wenn die fernbedienung so halb geht einfach ein: tail -f /var/log/syslog eingeben. Dann alle Tasten der reihe nach druecken. Dann steht da sowas wie (Treibername) code XX nicht gefunden oder so aehnlich.
Danach suchst du in der Datei:
/usr/src/dvb-s2api-liplianin0~20101224.hg17010/linux/drivers/media/IR/ir-keymaps.c
nach dem treibernamen suchen. Und da dann die fehlenden Codes eintragen.
such mal nach meinem Nicknamen hier im Board da findest du dann eine Beschreibung wie ich bei der MSI Karte gemacht habe.
MfG

This post has been edited 1 times, last edit by "assie17" (Mar 14th 2010, 7:30pm)


Thyor

Professional

  • "Thyor" started this thread

Posts: 627

Location: NRW / Münsterland

  • Send private message

5

Sunday, March 14th 2010, 10:22pm

Hi assie17,

irgendwie finde ich mich immer noch nicht zurecht.
Die liblianin-Version ist wohl bei mir etwas älter. Der Rest passt.
In der ir-keymaps.c finde ich aber keinen Hinweis auf die Codes der ati_remote.

Im syslog folgt auf dem einmaligen Drücken den OK-Taste folgende Einträge:

Source code

1
2
3
4
5
6
7
8
/etc/var/syslog:
Mar 14 22:09:15 yavdr kernel: [  199.199742] ati_remote 2-2:1.0: Unknown input from channel 0x00: data 73,9e
Mar 14 22:09:15 yavdr kernel: [  199.247726] ati_remote 2-2:1.0: Unknown input from channel 0x00: data 73,9e
Mar 14 22:09:15 yavdr kernel: [  199.287700] ati_remote 2-2:1.0: Unknown input from channel 0x00: data 73,9e
Mar 14 22:09:15 yavdr kernel: [  199.327677] ati_remote 2-2:1.0: Unknown input from channel 0x00: data 73,9e
Mar 14 22:09:15 yavdr kernel: [  199.375653] ati_remote 2-2:1.0: Unknown input from channel 0x00: data 73,9e
Mar 14 22:09:15 yavdr kernel: [  199.415636] ati_remote 2-2:1.0: Unknown input from channel 0x00: data 73,9e
Mar 14 22:09:15 yavdr kernel: [  199.455614] ati_remote 2-2:1.0: Unknown input from channel 0x00: data 73,9e


In deiner Anleitung steht auch wieder was von lircd.conf. Ich habe ja derzeit keine - und es läuft ja (eingeschränkt).
MfG
Thomas

yaVDR 0.5: MSI K9AG Neo2-Digital, Athlon X2 BE-2400, RAM: 4GB; HDMI: ZOTAC GT610; HDD: 3TB; DVB-S2: 2x TBS-6981 Doppel-Tuner; FB: Pollin X10
Streaming-Clients: S100 mit 2,5"-HDD unter Zendeb 0.3 von Egalus

6

Monday, March 15th 2010, 12:08pm

Hossa,
also so wie es ausieht ist das ein kernel treiber problem. Leider habe ich nicht so eine Fernbedienung. Aber ich habe im VDR-Wiki folgendes gefunden:
http://www.vdr-wiki.de/wiki/index.php/Fe…_Kerneltreibern
und das hier:
http://www.vdrportal.de/board/thread.php?postid=882094
MfG

This post has been edited 1 times, last edit by "assie17" (Mar 15th 2010, 12:16pm)


Tiroler

Professional

Posts: 693

Location: Tirol (Österreich)

  • Send private message

7

Monday, March 15th 2010, 3:43pm

Hallo Thyor,

wenn du möchtest, kannst du mal meine Dateien probieren (im Anhang, .txt Endung entfernen und dann entpacken)
Hat mich auch einiges an Nerven gekostet :unsch
Tiroler has attached the following file:
Server: 19" Rack - yaVDR 0.5, 4x DVB-S2
Server (Reserve): 19" Rack Server - Ubuntu 10.04 + yaVDR Repo (COMPUCASE 4HE, GIGABYTE 770TA-UD3, SNT-BA3151-1 Backplane, Athlon II X2 245e, 4 GB, 2x WD Caviar Green 2TB, 3x TT-budget S2-1600)
Client "Wohnzimmer": Zotac ZBOX (MLD 3.0.3)
Client "Schlafzimmer": Zotac ZBOX (MLD 3.0.3)
Client "Kinderzimmer": Asus EeeBox EB1012P-B0550 (yaVDR 0.5 Streaming Client)
Client "Fitness": Atom PC (yaVDR 0.5 Streaming Client)
Client "Küche": Asus EeeBox B202 (Lubuntu+VLC)
Client "Büro" (Lubuntu)
Client "Terrasse": NSLU2 (Debian, MPD)


Thyor

Professional

  • "Thyor" started this thread

Posts: 627

Location: NRW / Münsterland

  • Send private message

8

Monday, March 15th 2010, 11:17pm

Hallo Tiroler,

vielen Dank! Deine Dateien funktionieren prima! Sogar XMBC läuft!

Ich musste nur per Web-Interface auch den ATI/NVIDIA/X10-Lirc Treiber einstellen, dann lief es!

Btw. funken eigentlich alle Pollin-X10 auf er gleichen Frequenz/Kanal/Kennung?
Könnte man mit einer zweiten Pollin-X10 ein anderen unabhängig steuern?
MfG
Thomas

yaVDR 0.5: MSI K9AG Neo2-Digital, Athlon X2 BE-2400, RAM: 4GB; HDMI: ZOTAC GT610; HDD: 3TB; DVB-S2: 2x TBS-6981 Doppel-Tuner; FB: Pollin X10
Streaming-Clients: S100 mit 2,5"-HDD unter Zendeb 0.3 von Egalus

Tiroler

Professional

Posts: 693

Location: Tirol (Österreich)

  • Send private message

9

Monday, March 15th 2010, 11:29pm

Freut mich zu hören!

Quoted

Ich musste nur per Web-Interface auch den ATI/NVIDIA/X10-Lirc Treiber einstellen, dann lief es!

Stimmt, das hatte ich vergessen zu erwähnen...

Die Pollin kann, glaube ich, 12 unterschiedliche Codes benutzen. Hier im Wiki findest du die Anleitung, wie du zwischen den Codes wechseln kannst... falls du mehrere Pollins in unmittelbarer Nähe für unterschiedliche Geräte nutzen möchtest, wäre das wohl sinnvoll... dazu ist es notwendig sich eine neue lircd.conf zu erstellen...
Server: 19" Rack - yaVDR 0.5, 4x DVB-S2
Server (Reserve): 19" Rack Server - Ubuntu 10.04 + yaVDR Repo (COMPUCASE 4HE, GIGABYTE 770TA-UD3, SNT-BA3151-1 Backplane, Athlon II X2 245e, 4 GB, 2x WD Caviar Green 2TB, 3x TT-budget S2-1600)
Client "Wohnzimmer": Zotac ZBOX (MLD 3.0.3)
Client "Schlafzimmer": Zotac ZBOX (MLD 3.0.3)
Client "Kinderzimmer": Asus EeeBox EB1012P-B0550 (yaVDR 0.5 Streaming Client)
Client "Fitness": Atom PC (yaVDR 0.5 Streaming Client)
Client "Küche": Asus EeeBox B202 (Lubuntu+VLC)
Client "Büro" (Lubuntu)
Client "Terrasse": NSLU2 (Debian, MPD)