You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Thursday, October 27th 2011, 11:33am

[yavdr 0.4]: System (ngene) Shutdown Issue [solved]

Hello all,
because this is my first post in the form I want to thank you all for your great work implementing, assembling and supporting the yavdr platform. After starting with yavdr (and Linux/Unix systems in commen) a few month ago with version 0.3a, I personally had a steep learning curve with the system - all with the help of this forum just by reading.

Because of some minor problems in my 0.3a System (mainly S3 nvidia and ngene issues because of older drivers) I thought it is the perfect time to restart (after a backup) with version 0.4 (see profile).

After a smooth setup without any issues and simply reconfiguration of the atric serial remote the base system really works fine. Actually only the system shutdown doesn't work out of the box - same behavior when started from VDR OSD and Webinterface:

LiveTV is going to Black Screen and after one or two Seconds the YaVdr Splash is shown. This remains forever and the system is not responsive anymore.
So my questions are:

- Is this (yaVDR - Bug #465: 0.4.0Pre1 - ngene Kernel Treiber verhindert auf ION Board das Herunterfahren - Bugstracker of yaVDR )bug still an issue and could it be the same?
- Should as proposed the 'v4l-dvb-dkms' package be activated?

It's clear that the log messages are missing here, these will follow when I have access again to the system in case that the 'visionaries' here in the forum doesn't have their glass spheres ready on hand.

Ralf
yavdr 0.4 | Zotac IonItx P 4GB RAM | OCZ Onyx 32GB Root + Swap SDA | Samsung EARX 2TB SDB
Atric V5 | Harmony 555 | Silverstone SG06 | CineS2 5.5

This post has been edited 2 times, last edit by "RaHe67" (Oct 28th 2011, 8:06am) with the following reason: gelöst


2

Thursday, October 27th 2011, 11:37am

Sorry, the signature was missing (hopefully it is here yet)

Ralf
yavdr 0.4 | Zotac IonItx P 4GB RAM | OCZ Onyx 32GB Root + Swap SDA | Samsung EARX 2TB SDB
Atric V5 | Harmony 555 | Silverstone SG06 | CineS2 5.5

3

Thursday, October 27th 2011, 5:48pm

1.) The package v4l-dvb-dkms should be installed automatically. If that's not the case we missed it in the detection. Please check if the package is installed or not. If not install it.
2.) as we dont want to enable it by default (as the driver developer doesnt want it and we can not judge the risk) you need to enable the shutdown workaround with
echo "options ngene shutdown_workaround=1" > /etc/modprobe.d/ngene.conf

Output of lspci -nn might be useful to add it for detection of the right dkms for any later version of yavdr.
VDR User: 87 - LaScala LC14B - LG/Phillipps 6,4" VGA Display | Asrock H61/U3S3 | G630T | 1x 16GB Mobi Mtron 3035 1x WD 750GB 2,5" |1x L4m DVB-S2 Version 5.4

4

Thursday, October 27th 2011, 10:44pm

Hi Steffen,

that worked shutdown is working again ... thank you
Output of lspci -nn might be useful to add it for detection of the right dkms for any later version of yavdr.
<code>
root@vdr:~# lspci -nn
00:00.0 Host bridge [0600]: nVidia Corporation MCP79 Host Bridge [10de:0a82] (rev b1)
00:00.1 RAM memory [0500]: nVidia Corporation MCP79 Memory Controller [10de:0a88] (rev b1)
00:03.0 ISA bridge [0601]: nVidia Corporation MCP79 LPC Bridge [10de:0aae] (rev b3)
00:03.1 RAM memory [0500]: nVidia Corporation MCP79 Memory Controller [10de:0aa4] (rev b1)
00:03.2 SMBus [0c05]: nVidia Corporation MCP79 SMBus [10de:0aa2] (rev b1)
00:03.3 RAM memory [0500]: nVidia Corporation MCP79 Memory Controller [10de:0a89] (rev b1)
00:03.5 Co-processor [0b40]: nVidia Corporation MCP79 Co-processor [10de:0aa3] (rev b1)
00:04.0 USB Controller [0c03]: nVidia Corporation MCP79 OHCI USB 1.1 Controller [10de:0aa5] (rev b1)
00:04.1 USB Controller [0c03]: nVidia Corporation MCP79 EHCI USB 2.0 Controller [10de:0aa6] (rev b1)
00:06.0 USB Controller [0c03]: nVidia Corporation MCP79 OHCI USB 1.1 Controller [10de:0aa7] (rev b1)
00:06.1 USB Controller [0c03]: nVidia Corporation MCP79 EHCI USB 2.0 Controller [10de:0aa9] (rev b1)
00:08.0 Audio device [0403]: nVidia Corporation MCP79 High Definition Audio [10de:0ac0] (rev b1)
00:09.0 PCI bridge [0604]: nVidia Corporation MCP79 PCI Bridge [10de:0aab] (rev b1)
00:0a.0 Ethernet controller [0200]: nVidia Corporation MCP79 Ethernet [10de:0ab0] (rev b1)
00:0b.0 IDE interface [0101]: nVidia Corporation MCP79 SATA Controller [10de:0ab4] (rev b1)
00:0c.0 PCI bridge [0604]: nVidia Corporation MCP79 PCI Express Bridge [10de:0ac4] (rev b1)
00:10.0 PCI bridge [0604]: nVidia Corporation MCP79 PCI Express Bridge [10de:0aa0] (rev b1)
00:15.0 PCI bridge [0604]: nVidia Corporation MCP79 PCI Express Bridge [10de:0ac6] (rev b1)
00:16.0 PCI bridge [0604]: nVidia Corporation MCP79 PCI Express Bridge [10de:0ac7] (rev b1)
00:17.0 PCI bridge [0604]: nVidia Corporation MCP79 PCI Express Bridge [10de:0ac7] (rev b1)
00:18.0 PCI bridge [0604]: nVidia Corporation MCP79 PCI Express Bridge [10de:0ac7] (rev b1)
02:00.0 Multimedia video controller [0400]: Micronas Semiconductor Holding AG Device [18c3:0720] (rev 01)
03:00.0 VGA compatible controller [0300]: nVidia Corporation C79 [ION] [10de:0874] (rev b1)
04:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
</code>

Ralf
yavdr 0.4 | Zotac IonItx P 4GB RAM | OCZ Onyx 32GB Root + Swap SDA | Samsung EARX 2TB SDB
Atric V5 | Harmony 555 | Silverstone SG06 | CineS2 5.5

5

Friday, October 28th 2011, 12:13pm

Thanks

This is the card:
02:00.0 Multimedia video controller [0400]: Micronas Semiconductor Holding AG Device [18c3:0720] (rev 01)

Which should be already detected:

Source code

1
2
3
4
# Digital Devices Ocptopus / LE Bridge / NGene Bridge
elif check_pci2 "dd01:0003" || check_pci2 "18c3:0720"; then
DRIVER="v4l-dvb-dkms"
fi


So i assume you only needed to create the config file to make it working. :)
VDR User: 87 - LaScala LC14B - LG/Phillipps 6,4" VGA Display | Asrock H61/U3S3 | G630T | 1x 16GB Mobi Mtron 3035 1x WD 750GB 2,5" |1x L4m DVB-S2 Version 5.4

6

Friday, October 28th 2011, 1:06pm

Steffen,

your are right. I simply wasn't aware of that the "shutdown_workaround" is still necessary with the newest drivers.
Have a nice weekend

Ralf
yavdr 0.4 | Zotac IonItx P 4GB RAM | OCZ Onyx 32GB Root + Swap SDA | Samsung EARX 2TB SDB
Atric V5 | Harmony 555 | Silverstone SG06 | CineS2 5.5

Used tags

0.4, cineS2, ion, ngene, yaVDR