You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Daniel26

Intermediate

  • "Daniel26" started this thread

Posts: 279

Location: Krumbach

Occupation: Administrator

  • Send private message

1

Sunday, November 13th 2011, 10:12pm

YaVDR 0.4: imon-pad Fernbedienung macht Probleme

Hallo,

unter YaVDR 0.4 macht die Fernbedinung Probleme.... bis heute Nachmittag musste ich ewig auf den Teasten bleiben oder 3x eine Taste drücken, bis sich etwas getan hat. Habe dann heute Abend mal ein apt-get update und ein apt-get upgrade gefahren....seitdem tut sich gar nichts mehr....reagiert auf keinen Tastendruck.

lsusb sagt: 15c2:0038 SoundGraph Inc. GD01 MX VFD Display/IR Receiver
Dürfte baugleich mit dem Antec Veris sein.

Ich würde gerne ausschließen, das die Hardware daran schuld ist.
Kann man die Ausgabe des Empfängers irgendwie dumpen um zu sehen, ob da überhaupt was ankommt? Lt. irw kommt da gar nichts an.

Gruß

Daniel
Gruß

Daniel
--------------------------------------------------------------------------
1. Client Sempron 140, M3N78-VM, 2GB DDR, 60GB SDD, Silverstone ML01-B-MXR, yaVDR 0.4 PRE1, Samsung LE42B530
2. Client Fujitsu Esprimo E5600, YaVDR 0.5 32" Phillips LCD
3. Eigenbau-PC, YaVDR 0.5 Headless-Server, CineS2 V6.5

This post has been edited 1 times, last edit by "steffen_b" (Nov 22nd 2011, 5:04pm)


2

Sunday, November 13th 2011, 10:18pm

Hallo, den Abschnitt in der Doku kennst du? http://www.yavdr.org/documentation/de/ch…tml#ir-keytable
Hattest du die /etc/rc_maps.cfg irgendwie angepasst?
yaVDR-Doku

Meine VDRs

VDR 1: Point of View Ion-330-1 (Intel Atom 330@1,6 GHz). 2GB, 2TB HDD, KNC One DVB-C, Sundtek MediaTV Pro (DVB-C), Atric IR-Einschalter Rev.5, yaVDR 0.5 testing
VDR 2: Acer Revo 3610, 4GB Ram, 1x HDD 320 GB, Pinnacle PCTV SAT 452e, Medion X10, YaVDR 0.5
VDR 3: Intel DH67BL, Celeron 540, 4 GB Ram, POV Geforce 210 512 MB, 500 GB, DD Duo-flex CT, Arch LInux, VDR 2.1.6, CIR-Empfänger
Client 1: Raspberry Pi Model B, Arch Linux ARM, VDR 2.1.6
Ceterum censeo enchiridia esse lectitanda.

Daniel26

Intermediate

  • "Daniel26" started this thread

Posts: 279

Location: Krumbach

Occupation: Administrator

  • Send private message

3

Sunday, November 13th 2011, 10:35pm

Ja, kenn ich. Scheint auch alles zu passen (bis auf die Mangelnde Ausgabe bei ir-keytable -t).
Trotzdem tut sich eben nichts.

Liegt also der Schluss nahe, das die Hardware im Eimer ist?

Gruß
Daniel
Gruß

Daniel
--------------------------------------------------------------------------
1. Client Sempron 140, M3N78-VM, 2GB DDR, 60GB SDD, Silverstone ML01-B-MXR, yaVDR 0.4 PRE1, Samsung LE42B530
2. Client Fujitsu Esprimo E5600, YaVDR 0.5 32" Phillips LCD
3. Eigenbau-PC, YaVDR 0.5 Headless-Server, CineS2 V6.5

4

Sunday, November 13th 2011, 11:51pm

Ich habe das gleiche Problem mit der selben Hardware. Nach einem apt-get update / apt-get upgrade ging keine Taste auf der Fernbedienung mehr...
Nachdem ich folgendes in /etc/rc_maps.cfg geändert hatte, hat es wieder funktioniert:


#* rc-imon-pad /lib/udev/rc_keymaps/imon_mce
* rc-imon-pad imon_mce

Ich habe leider noch nicht die Zeit dazu gehabt, das mal genau zu untersuchen, aber offensichtlich wird das falsche Protokoll genutzt:


Found /sys/class/rc/rc0/ (/dev/input/event3) with:
Driver imon, table rc-imon-pad
Supported protocols: RC-6 other
Enabled protocols: RC-6
Repeat delay = 500 ms, repeat period = 125 ms

Es funktioniert allerdings nur mit dem Protokoll: other.

@Daniel26: Funktionieren bei Dir alle Tasten (besonders "Blau" und "Skip Back")?
yaVDR 0.4, Asus AT5IONT-I (ION2), Cine S2 V5.5, FB: ( 15c2:0038 ) SoundGraph Inc. GD01 MX VFD Display/IR Receiver, Logitech Harmony One (emulating original FB)

5

Sunday, November 13th 2011, 11:54pm

Dann muss man entweder eine eigene Keymap benutzen (wie olafc) oder in der /lib/udev/rc_keymaps/imon_mce die erste Zeile ändern, dass type: other statt type: RC6 drin steht...
yaVDR-Doku

Meine VDRs

VDR 1: Point of View Ion-330-1 (Intel Atom 330@1,6 GHz). 2GB, 2TB HDD, KNC One DVB-C, Sundtek MediaTV Pro (DVB-C), Atric IR-Einschalter Rev.5, yaVDR 0.5 testing
VDR 2: Acer Revo 3610, 4GB Ram, 1x HDD 320 GB, Pinnacle PCTV SAT 452e, Medion X10, YaVDR 0.5
VDR 3: Intel DH67BL, Celeron 540, 4 GB Ram, POV Geforce 210 512 MB, 500 GB, DD Duo-flex CT, Arch LInux, VDR 2.1.6, CIR-Empfänger
Client 1: Raspberry Pi Model B, Arch Linux ARM, VDR 2.1.6
Ceterum censeo enchiridia esse lectitanda.

6

Sunday, November 13th 2011, 11:57pm

Gibt es denn einen Grund dafür, dass von "RC-6" auf "other" umgestellt wurde? Oder sollten wir den yavdr-remote Maintainer fragen, das wieder zurückzudrehen?
yaVDR 0.4, Asus AT5IONT-I (ION2), Cine S2 V5.5, FB: ( 15c2:0038 ) SoundGraph Inc. GD01 MX VFD Display/IR Receiver, Logitech Harmony One (emulating original FB)

7

Monday, November 14th 2011, 12:01am

Gibt es denn einen Grund dafür, dass von "RC-6" auf "other" umgestellt wurde?

Genau umgekehrt, vorher wurde other + RC6 geladen, jetzt nur noch RC6 - Jemand hat entdeckt, dass man es da einstellen kann...
Oder sollten wir den yavdr-remote Maintainer fragen, das wieder zurückzudrehen?

Wenn es bei dir klappt, wenn du es zurückstellst/abänderst dann wäre es einen Bugreport mit Lösungsansatz wert...
yaVDR-Doku

Meine VDRs

VDR 1: Point of View Ion-330-1 (Intel Atom 330@1,6 GHz). 2GB, 2TB HDD, KNC One DVB-C, Sundtek MediaTV Pro (DVB-C), Atric IR-Einschalter Rev.5, yaVDR 0.5 testing
VDR 2: Acer Revo 3610, 4GB Ram, 1x HDD 320 GB, Pinnacle PCTV SAT 452e, Medion X10, YaVDR 0.5
VDR 3: Intel DH67BL, Celeron 540, 4 GB Ram, POV Geforce 210 512 MB, 500 GB, DD Duo-flex CT, Arch LInux, VDR 2.1.6, CIR-Empfänger
Client 1: Raspberry Pi Model B, Arch Linux ARM, VDR 2.1.6
Ceterum censeo enchiridia esse lectitanda.

8

Monday, November 14th 2011, 12:07am

Oder sollten wir den yavdr-remote Maintainer fragen, das wieder zurückzudrehen?
Wenn es bei dir klappt, wenn du es zurückstellst/abänderst dann wäre es einen Bugreport mit Lösungsansatz wert...
Kannst Du mir einen kleinen Tip geben, wo ich das Changelog für den Fehler einsehen kann? Hier ist das File (/lib/udev/rc_keymaps/imon_mce) nicht vorhanden: https://github.com/yavdr/yavdr-remote

Ich würde dann einen Bugreport schreiben, ein diff-File anhängen und den entsprechenden Commit herausfinden, der das Problem hervorruft.

Danke schonmal für Deine Hilfe!
yaVDR 0.4, Asus AT5IONT-I (ION2), Cine S2 V5.5, FB: ( 15c2:0038 ) SoundGraph Inc. GD01 MX VFD Display/IR Receiver, Logitech Harmony One (emulating original FB)

9

Monday, November 14th 2011, 12:13am

hier das gleiche Problem: Infrarot Empfänger defekt?
yaVDR 0.4, Asus AT5IONT-I (ION2), Cine S2 V5.5, FB: ( 15c2:0038 ) SoundGraph Inc. GD01 MX VFD Display/IR Receiver, Logitech Harmony One (emulating original FB)

10

Monday, November 14th 2011, 10:24am

So, ich hatte das selbe Problem... auch mit dem "15c2:0038 SoundGraph Inc. GD01 MX VFD Display/IR Receiver"

Wie oben schon geschrieben, wird das Display + IR-Modul als "imon_mce" erkannt. Durch ein wenig suchen habe ich herausgefunden, dass es in "/lib/udev/rc_keymaps/" auch eine "imon_pad" gibt...

Testweise habe ich einfach mal den Namen der "imon_pad" nach "imon_mce" geändert und die Kiste neugestartet. - Und siehe da, fast alles funktioniert (bis auf "Blau" und "Skip-Back")

Sprich, ich tippe es wird einfach die falsche Hardware erkannt und dadurch eine falsche Keytable gemappt.

Ich hoffe ich konnte einigen helfen.

Gruß
DoubleXMinus

@edit:
Im Bug-Tracker: https://bugs.yavdr.com/issues/685 ist das Problem schon beschrieben, es schient sich wohl nicht auf das "15c2:0038 SoundGraph Inc. GD01 MX VFD Display/IR Receiver" zu beschränken.
Aber dort wird quasi die sauberere Lösung vorgeschlagen ;)
yaVDR 0.5 * Ausgabe: vdr-plugin-softhddevice * Zotac ION F-E Intel Atom 330 * 4GB DDR2-RAM * 2TB SATA HDD * DigitalDevices Cine C/T * 15c2:0038 SoundGraph Inc. GD01 MX VFD Display/IR Receiver * Logitech Harmony 650 (emulating orig.-FB)

This post has been edited 1 times, last edit by "DoubleXMinus" (Nov 14th 2011, 10:35am)


11

Monday, November 14th 2011, 11:19am

Vielen dank für die super Analyse! Hast Du auch schon einen Fix für das "Blau" und "Skip-Back" Problem?
yaVDR 0.4, Asus AT5IONT-I (ION2), Cine S2 V5.5, FB: ( 15c2:0038 ) SoundGraph Inc. GD01 MX VFD Display/IR Receiver, Logitech Harmony One (emulating original FB)

12

Monday, November 14th 2011, 11:40am

Nein, habe ich leider noch nicht. Habe auch im moment keinen Zugriff auf die FB... um zu testen.
Wenn ich heute abend noch ein wenig Zeit finde, dann versuche ich mich auch mal daran.

Ansonsten, falls zufällig jemand anderes das Problem lösen konnte, würde ich mich natürlich über eine Mitteilung freuen :)

Ich tippe aber mal, dass es dazu schon Lösungen hier im Forum gibt. Hab aber auch aktuell keine Zeit hier zu suchen.

LG
yaVDR 0.5 * Ausgabe: vdr-plugin-softhddevice * Zotac ION F-E Intel Atom 330 * 4GB DDR2-RAM * 2TB SATA HDD * DigitalDevices Cine C/T * 15c2:0038 SoundGraph Inc. GD01 MX VFD Display/IR Receiver * Logitech Harmony 650 (emulating orig.-FB)

13

Monday, November 14th 2011, 3:24pm

Und ich hab mich getstern abend schwarz geärgert das auf einaml die FB nicht geht... habe selbes Problem. IMON VFD+IR und nach upgrade und neustart geht nischts mehr... nachher werd ich mal den workaround probieren... hat jemand schon einen bug report gemacht?
Origenae M10, Zotac IONITX-P E, 4GB Ram, Intel SSD 320, Sundtek DVB-CT, TT CT-3650 CI, yaVDR 0.4

14

Monday, November 14th 2011, 4:10pm

yaVDR 0.4, Asus AT5IONT-I (ION2), Cine S2 V5.5, FB: ( 15c2:0038 ) SoundGraph Inc. GD01 MX VFD Display/IR Receiver, Logitech Harmony One (emulating original FB)

Daniel26

Intermediate

  • "Daniel26" started this thread

Posts: 279

Location: Krumbach

Occupation: Administrator

  • Send private message

15

Monday, November 14th 2011, 7:11pm

Also durch umkopieren von imon_mce auf /lib/udev/rc_keymaps/ tut sie auch bei mir wieder. Allerdings ziemlich unregelmäßig. Mal geht was, mal nicht.

Sehr seltsam das ganze.....
Gruß

Daniel
--------------------------------------------------------------------------
1. Client Sempron 140, M3N78-VM, 2GB DDR, 60GB SDD, Silverstone ML01-B-MXR, yaVDR 0.4 PRE1, Samsung LE42B530
2. Client Fujitsu Esprimo E5600, YaVDR 0.5 32" Phillips LCD
3. Eigenbau-PC, YaVDR 0.5 Headless-Server, CineS2 V6.5

Daniel26

Intermediate

  • "Daniel26" started this thread

Posts: 279

Location: Krumbach

Occupation: Administrator

  • Send private message

16

Monday, November 14th 2011, 7:52pm

Also, evtest spuckt aus für:

blue: 2ba115b7
Backspace: 200002a

Source code

1
2
3
4
5
6
7
8
9
10
Event: time 1321296591.008688, type 4 (Misc), code 4 (ScanCode), value 200002a
Event: time 1321296591.008700, type 1 (Key), code 14 (Backspace), value 1
Event: time 1321296591.008702, -------------- Report Sync ------------
Event: time 1321296591.255989, type 1 (Key), code 14 (Backspace), value 0
Event: time 1321296591.255994, -------------- Report Sync ------------
Event: time 1321296592.585699, type 4 (Misc), code 4 (ScanCode), value 2ba115b7
Event: time 1321296592.585708, type 1 (Key), code 442 (?), value 1
Event: time 1321296592.585709, -------------- Report Sync ------------
Event: time 1321296592.825987, type 1 (Key), code 442 (?), value 0
Event: time 1321296592.825992, -------------- Report Sync ------------


Vielleicht hilft das ja den Entwicklern auch etwas weiter....
Gruß

Daniel
--------------------------------------------------------------------------
1. Client Sempron 140, M3N78-VM, 2GB DDR, 60GB SDD, Silverstone ML01-B-MXR, yaVDR 0.4 PRE1, Samsung LE42B530
2. Client Fujitsu Esprimo E5600, YaVDR 0.5 32" Phillips LCD
3. Eigenbau-PC, YaVDR 0.5 Headless-Server, CineS2 V6.5

17

Monday, November 14th 2011, 10:06pm

Deine Scancodes kann ich reproduzieren. Zusätzlich funktioniert folgende Taste nicht mit der Keytable.
evtest-Ausgabe:

Skip Back: 2b9115b7

Quoted

Also durch umkopieren von imon_mce auf /lib/udev/rc_keymaps/ tut sie auch bei mir wieder.

Woher kopierst Du denn die imon_mce? Ich kann die nirgendwo finden. (/etc/rc_keymaps/ ist leer)

Irgendwie fehlt mir noch der Überblick über dieses ganze Thema...
yaVDR 0.4, Asus AT5IONT-I (ION2), Cine S2 V5.5, FB: ( 15c2:0038 ) SoundGraph Inc. GD01 MX VFD Display/IR Receiver, Logitech Harmony One (emulating original FB)

Daniel26

Intermediate

  • "Daniel26" started this thread

Posts: 279

Location: Krumbach

Occupation: Administrator

  • Send private message

18

Monday, November 14th 2011, 10:54pm

Hab ich mich falsch ausgedrückt....imon_pad nach imon_mce kopieren. Dann rennts wieder halbwegs.....
Gruß

Daniel
--------------------------------------------------------------------------
1. Client Sempron 140, M3N78-VM, 2GB DDR, 60GB SDD, Silverstone ML01-B-MXR, yaVDR 0.4 PRE1, Samsung LE42B530
2. Client Fujitsu Esprimo E5600, YaVDR 0.5 32" Phillips LCD
3. Eigenbau-PC, YaVDR 0.5 Headless-Server, CineS2 V6.5

19

Monday, November 14th 2011, 11:02pm

ui was für ein Durcheinander/Gewusel mit den verschiedenen Imons - sehr wahrscheinlich hats da irgendwo nen Fehler ... Lasst uns mal ein paar Tage Zeit das Geflecht um imon zu entwirren.
VDR User: 87 - LaScala LC14B - LG/Phillipps 6,4" VGA Display | Asrock H61/U3S3 | G630T | 1x 16GB Mobi Mtron 3035 1x WD 750GB 2,5" |1x L4m DVB-S2 Version 5.4

20

Monday, November 14th 2011, 11:07pm

Hi Steffen. Ich bin gerne bereit, Patches zu testen und Scancodes zu liefern.
yaVDR 0.4, Asus AT5IONT-I (ION2), Cine S2 V5.5, FB: ( 15c2:0038 ) SoundGraph Inc. GD01 MX VFD Display/IR Receiver, Logitech Harmony One (emulating original FB)