Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Nix

Profi

  • »Nix« ist der Autor dieses Themas

Beiträge: 586

Wohnort: südlich v. Hamburg, nördlich v. München

  • Nachricht senden

1

Mittwoch, 2. November 2011, 10:43

[yaVDR 0.4] bekomme imon-pad 15c2:ffdc nicht zum Laufen

Hallo zusammen,

habe gestern die finale Version von yaVDR 0.4 auf meinem System installiert. Leider bekomme ich meine Fernbedienung nicht ans Laufen. Sie wird erkannt und eingebunden:

Quellcode

1
2
3
[   20.521714] input: iMON Panel, Knob and Mouse(15c2:ffdc) as /devices/pci0000:00/0000:00:06.0/usb4/4-2/4-2:1.0/input/input4
[   20.603312] input: iMON Remote (15c2:ffdc) as /devices/pci0000:00/0000:00:06.0/usb4/4-2/4-2:1.0/rc/rc0/input5
[   27.281647] input: eventlircd as /devices/virtual/input/input6


Es handelt sich dabei um die VFD-Version der ffdc, nicht um die LCD-Version. Die FB reagiert auf keinerlei Tastendruck. Auch nicht mit evtest /dev/input/event5 (bei gestopptem VDR und eventlircd). Was mich etwas irritiert, ist dass sie mit der MCE-Keymap verknüpft wird:

Quellcode

1
2
3
4
5
dmesg | grep imon
[   20.540407] imon 4-2:1.0: 0xffdc iMON VFD, MCE IR (id 0x7e)
[   20.600322] Registered IR keymap rc-imon-mce
[   20.970103] imon 4-2:1.0: iMON device (15c2:ffdc, intf0) on usb<4:3> initialized
[   20.970176] usbcore: registered new interface driver imon


Ich habe aber eine PAD-Fernbedienung.

remote.conf habe ich in Ruhe gelassen (ist also serienmässig) und lirc habe ich auch nicht aktiviert. Unter yaVDR 0.3 läuft die FB am gleichen Rechner mit lirc und mit imon-pad-Konfiguration.
Was kann ich tun?

Gruß, Nix
  • Server: Gigabyte H67-Board, i3-2120, 8GB Ram, 12 TB Video-Part., ca. 5000 Aufnahmen, 5x DVB-S (2x Cine S2, 1x USB), easyVDR 2.0 headless
  • WoZi-Client: Zotac ZBox ID86, Hama-MCE mit Harmony, keine Tuner, reiner Streaming-Client, easyVDR 2.0

2

Mittwoch, 2. November 2011, 18:35

Hallo, falls du es noch nicht kennst - den Abschnitt zur Fernbedienung in der Doku lesen: http://www.yavdr.org/documentation/de/ch02s02.html
Ansonsten zeig bitte mal die Ausgabe von "sudo ir-keytable"
Und schau mal ob und welche Tastencodes bei gestopptem eventlircd von "sudo ir-keytable -t" geliefert werden.
yaVDR-Doku

Meine VDRs

VDR 1: Point of View Ion-330-1 (Intel Atom 330@1,6 GHz). 2GB, 4TB HDD, KNC One DVB-C, Sundtek MediaTV Pro (DVB-C), Atric IR-Einschalter Rev.5, yaVDR 0.6 testing
VDR 2: Acer Revo 3610, 4GB Ram, 1x HDD 320 GB, Pinnacle PCTV SAT 452e, Medion X10, YaVDR 0.5 testing
VDR 3: Intel DH67BL, Celeron 540, 4 GB Ram, POV Geforce 210 512 MB, 500 GB, DD Duo-flex CT, Arch LInux, VDR 2.2.0, CIR-Empfänger
Client 1: Raspberry Pi Model B, Arch Linux ARM, VDR 2.2.0
Client 2: Raspberry Pi 2, Arch Linux ARM, VDR 2.3.1
vdr-epg-daemon + MariaDB auf Cubietruck mit 32 GB SSD, Arch Linux ARM, optional Sundtek MediaTV Pro III + VDR 2.2.0
Ceterum censeo enchiridia esse lectitanda.

Nix

Profi

  • »Nix« ist der Autor dieses Themas

Beiträge: 586

Wohnort: südlich v. Hamburg, nördlich v. München

  • Nachricht senden

3

Mittwoch, 2. November 2011, 20:14

Hi,

der VDR läuft gerade mit yaVDR 0.3, und wenn ich jetzt ins andere System boote gibts 'nen Aufstand. ;)
Ich hatte das aber vorhin schon gemacht und das Terminalfenster auf meinem Mac ist noch offen:

Quellcode

1
2
3
4
5
6
sudo ir-keytable
Found /sys/class/rc/rc0/ (/dev/input/event5) with:
	Driver imon, table rc-imon-mce
	Supported protocols: RC-6 
	Enabled protocols: RC-6 
	Repeat delay = 500 ms, repeat period = 125 ms


Bei ir-keytable -t passiert leider überhaupt nichts. Die FB wird nach der Erkennung komplett vom System ignoriert, noch nicht mal der Powerschalter funktioniert (und der funktioniert im alten System auch ohne LIRC).

Gruß, Nix
  • Server: Gigabyte H67-Board, i3-2120, 8GB Ram, 12 TB Video-Part., ca. 5000 Aufnahmen, 5x DVB-S (2x Cine S2, 1x USB), easyVDR 2.0 headless
  • WoZi-Client: Zotac ZBox ID86, Hama-MCE mit Harmony, keine Tuner, reiner Streaming-Client, easyVDR 2.0

4

Mittwoch, 2. November 2011, 20:31

Bei ir-keytable -t passiert leider überhaupt nichts.

Vorher "sudo stop eventlircd" gemacht?
yaVDR-Doku

Meine VDRs

VDR 1: Point of View Ion-330-1 (Intel Atom 330@1,6 GHz). 2GB, 4TB HDD, KNC One DVB-C, Sundtek MediaTV Pro (DVB-C), Atric IR-Einschalter Rev.5, yaVDR 0.6 testing
VDR 2: Acer Revo 3610, 4GB Ram, 1x HDD 320 GB, Pinnacle PCTV SAT 452e, Medion X10, YaVDR 0.5 testing
VDR 3: Intel DH67BL, Celeron 540, 4 GB Ram, POV Geforce 210 512 MB, 500 GB, DD Duo-flex CT, Arch LInux, VDR 2.2.0, CIR-Empfänger
Client 1: Raspberry Pi Model B, Arch Linux ARM, VDR 2.2.0
Client 2: Raspberry Pi 2, Arch Linux ARM, VDR 2.3.1
vdr-epg-daemon + MariaDB auf Cubietruck mit 32 GB SSD, Arch Linux ARM, optional Sundtek MediaTV Pro III + VDR 2.2.0
Ceterum censeo enchiridia esse lectitanda.

Nix

Profi

  • »Nix« ist der Autor dieses Themas

Beiträge: 586

Wohnort: südlich v. Hamburg, nördlich v. München

  • Nachricht senden

5

Mittwoch, 2. November 2011, 20:40


Vorher "sudo stop eventlircd" gemacht?

Ja.

Gruß, Nix
  • Server: Gigabyte H67-Board, i3-2120, 8GB Ram, 12 TB Video-Part., ca. 5000 Aufnahmen, 5x DVB-S (2x Cine S2, 1x USB), easyVDR 2.0 headless
  • WoZi-Client: Zotac ZBox ID86, Hama-MCE mit Harmony, keine Tuner, reiner Streaming-Client, easyVDR 2.0

Nix

Profi

  • »Nix« ist der Autor dieses Themas

Beiträge: 586

Wohnort: südlich v. Hamburg, nördlich v. München

  • Nachricht senden

6

Donnerstag, 3. November 2011, 22:28

Hallo zusammen,

ich habe inzwischen im Netz herausgefunden, dass es (mindestens) drei verschiedene Varianten des Imon-Device gibt, die alle mitder Device-ID ffdc laufen. Diese drei Varianten unterscheiden sich im Config-Bit, und zwar gibt es 0x46, 0x7e und 0x9e. Zu sehen ist das in der Ausgabe von dmesg, bei mir steht da z.B.

Quellcode

1
imon 4-2:1.0: 0xffdc iMON VFD, MCE IR (id 0x7e)


Scheinbar wurde die Variante mit 0x7e erst seit Juli in die Erkennung durch den Kernel aufgenommen (siehe hier). Frage an die Experten, die sich besser mit Linux auskennen: Könnte das irgendwie mit dem absoluten Nicht-Funktionieren meiner FB mit dem Natty-Kernel in yaVDR 0.4 zu tun haben?

Gruß, Nix
  • Server: Gigabyte H67-Board, i3-2120, 8GB Ram, 12 TB Video-Part., ca. 5000 Aufnahmen, 5x DVB-S (2x Cine S2, 1x USB), easyVDR 2.0 headless
  • WoZi-Client: Zotac ZBox ID86, Hama-MCE mit Harmony, keine Tuner, reiner Streaming-Client, easyVDR 2.0

7

Donnerstag, 3. November 2011, 22:34

Nicht unmöglich, versuch mal v4l-dvb-dkms , das enthält neuere Treiber für imon.
VDR User: 87 - LaScala LC14B - LG/Phillipps 6,4" VGA Display | Asrock H61/U3S3 | G630T | 1x 16GB Mobi Mtron 3035 1x WD 750GB 2,5" |1x L4m DVB-S2 Version 5.4

Nix

Profi

  • »Nix« ist der Autor dieses Themas

Beiträge: 586

Wohnort: südlich v. Hamburg, nördlich v. München

  • Nachricht senden

8

Freitag, 4. November 2011, 08:04

Hi,
Nicht unmöglich, versuch mal v4l-dvb-dkms , das enthält neuere Treiber für imon.

Habe gestern einmal zu liplianin und dann zurück zu v4l gewechselt. Ohne Ergebnis. Über ein dist-upgrade auch die neue Kernel-Version eingespielt. Auch nix.

Ich vermute, dass das Kernel-Modul imon mit meiner FB einfach nicht funktioniert (bzw. andersrum, meine FB nicht mit dem Kernel-Modul). Das vermute ich deshalb, weil ich ja mit der FB den Rechner einschalten kann (FB selbst funktioniert also, und das läuft ja über den gleichen Empfänger), aber sobald das System läuft, geht mit der FB gar nix mehr.

Wenn ich die FB irgendwie zum Laufen bekommen will, wie muss ich da jetzt vorgehen? Meine Idee: Über /etc/modprobe.d das Kernel-Modul blacklisten und dann LIRC aktivieren? Könnte das so gehen? (Bin grad nicht zu Hause, sonst würde ich es gleich ausprobieren...)

Gruß, Nix
  • Server: Gigabyte H67-Board, i3-2120, 8GB Ram, 12 TB Video-Part., ca. 5000 Aufnahmen, 5x DVB-S (2x Cine S2, 1x USB), easyVDR 2.0 headless
  • WoZi-Client: Zotac ZBox ID86, Hama-MCE mit Harmony, keine Tuner, reiner Streaming-Client, easyVDR 2.0

9

Freitag, 18. November 2011, 15:59

Hallo,

hast du schon eine Lösung für deine iMon Fernbedienung gefunden?

hab auch eine mit (id 0x7e)

lg
michi

Nix

Profi

  • »Nix« ist der Autor dieses Themas

Beiträge: 586

Wohnort: südlich v. Hamburg, nördlich v. München

  • Nachricht senden

10

Freitag, 18. November 2011, 16:28

Hallo,

nein, leider nicht wirklich. Ich habe inzwischen das Kernel-Modul imon in /etc/modprobe.d geblacklistet, und danach wurde auch das richtige lirc_imon-Modul geladen, aber dennoch funktioniert das Ganze nicht. Nur wird die FB inzwischen wenigstens schon wahrgenommen, allerdings nur manchmal, und dann auch nur in dem Sinne, dass eventlircd pro Sekunde ein paar neue input-devices findet:

Quellcode

1
2
3
4
5
6
7
8
9
Nov 17 11:57:33 yavdr kernel: [   35.991358] input: eventlircd as /devices/virtual/input/input31
Nov 17 11:57:34 yavdr kernel: [   36.742412] input: lircd as /devices/virtual/input/input32
Nov 17 11:57:34 yavdr kernel: [   36.831560] input: eventlircd as /devices/virtual/input/input33
Nov 17 11:57:35 yavdr kernel: [   37.565791] input: lircd as /devices/virtual/input/input34
Nov 17 11:57:35 yavdr kernel: [   37.641791] input: eventlircd as /devices/virtual/input/input35
Nov 17 11:57:36 yavdr kernel: [   38.339423] input: lircd as /devices/virtual/input/input36
Nov 17 11:57:36 yavdr kernel: [   38.421664] input: eventlircd as /devices/virtual/input/input37
Nov 17 11:57:36 yavdr kernel: [   39.079278] input: lircd as /devices/virtual/input/input38
Nov 17 11:57:37 yavdr kernel: [   39.141684] input: eventlircd as /devices/virtual/input/input39


Das geht dann bis in die Tausende. Ist aber, wie gesagt, nicht immer so. Und egal, wie ich es im WIF umstelle, egal ob ich lirc-Nutzung einschalte oder wieder abschalte, nutzen kann ich die FB bzw. den Imon-Empfänger + Displaydefinitiv nicht.

Bei yaVDR 0.3.1 ist es übrigens auch schon so, dass ein Kernel-Modul die Imon-Devices findet, und dass sie dann nicht funktionieren. Aber nachdem ich da das imon-Modul geblacklistet habe, konnte ich lirc zum Laufen bringen. Ich musste allerdings lirc erst per apt-get remove entfernen, dabei sagte apt-get, dass lirc als "manuelle Installation" registriert sei und wollte beim Entfernen yavdr-essential mitnehmen. Habe ich so gemacht, danach beides wieder installiert, und sofort konnte ich meinen VDR wieder per FB bedienen und auch das Display funktionierte sofort wieder.

Bei der 0.4 habe ich dann genau das gleiche Verfahren versucht, auch da wurde lirc beim Entfernen als "manuelle Installation" angemeckert und yavdr-essential wurde mitgezogen. Aber leider hat es bei der 0.4 bis auf obiges Verhalten nichts genützt.

Gruß, Nix
  • Server: Gigabyte H67-Board, i3-2120, 8GB Ram, 12 TB Video-Part., ca. 5000 Aufnahmen, 5x DVB-S (2x Cine S2, 1x USB), easyVDR 2.0 headless
  • WoZi-Client: Zotac ZBox ID86, Hama-MCE mit Harmony, keine Tuner, reiner Streaming-Client, easyVDR 2.0

Immortal Romance Spielautomat