Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Samstag, 30. April 2011, 17:16

[gelöst][yavdr0.3a]buffer usage steigt stark an beim HD streaming

Hallo zusammen,

Ich habe das Proble, dass das Bild nur noch ruckelt, wenn ich über den Streamdev-Client und VNSI-Client HD Sender schauen will.

Die Log-Datei zeigt folgendes:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
Apr 30 17:08:56 vdr-srv vdr: [1929] streamdev-livestreaming thread started (pid=1737, tid=1929)
Apr 30 17:08:56 vdr-srv vdr: [1930] receiver on device 2 thread started (pid=1737, tid=1930)
Apr 30 17:08:56 vdr-srv vdr: [1931] TS buffer on device 2 thread started (pid=1737, tid=1931)
Apr 30 17:08:59 vdr-srv vdr: [1787] ERROR: 1 ring buffer overflow (188 bytes dropped)
Apr 30 17:08:59 vdr-srv vdr: [1930] buffer usage: 70% (tid=1929)
Apr 30 17:08:59 vdr-srv vdr: [1930] buffer usage: 80% (tid=1929)
Apr 30 17:08:59 vdr-srv vdr: [1930] buffer usage: 60% (tid=1929)
Apr 30 17:08:59 vdr-srv vdr: [1930] buffer usage: 70% (tid=1929)
Apr 30 17:09:00 vdr-srv vdr: [1930] buffer usage: 80% (tid=1929)
Apr 30 17:09:00 vdr-srv vdr: [1930] buffer usage: 90% (tid=1929)
Apr 30 17:09:00 vdr-srv vdr: [1930] ERROR: 1 ring buffer overflow (188 bytes dropped)
Apr 30 17:09:03 vdr-srv vdr: [1787] ERROR: 1 ring buffer overflow (188 bytes dropped)
Apr 30 17:09:05 vdr-srv vdr: [1787] ERROR: 28 ring buffer overflows (5264 bytes dropped)
Apr 30 17:09:06 vdr-srv vdr: [1930] ERROR: 39374 ring buffer overflows (7402312 bytes dropped)
Apr 30 17:09:09 vdr-srv vdr: [1787] ERROR: 36 ring buffer overflows (6768 bytes dropped)
Apr 30 17:09:11 vdr-srv vdr: [1787] ERROR: 15 ring buffer overflows (2820 bytes dropped)
Apr 30 17:09:12 vdr-srv vdr: [1930] ERROR: 49984 ring buffer overflows (9396992 bytes dropped)
Apr 30 17:09:15 vdr-srv vdr: [1787] ERROR: 60 ring buffer overflows (11280 bytes dropped)
Apr 30 17:09:17 vdr-srv vdr: [1787] ERROR: 7 ring buffer overflows (1316 bytes dropped)
Apr 30 17:09:18 vdr-srv vdr: [1930] ERROR: 55711 ring buffer overflows (10473668 bytes dropped)
Apr 30 17:09:21 vdr-srv vdr: [1787] ERROR: 60 ring buffer overflows (11280 bytes dropped)
Apr 30 17:09:23 vdr-srv vdr: [1787] ERROR: 122 ring buffer overflows (22936 bytes dropped)
Apr 30 17:09:24 vdr-srv vdr: [1930] ERROR: 66637 ring buffer overflows (12527756 bytes dropped)
Apr 30 17:09:27 vdr-srv vdr: [1787] ERROR: 28 ring buffer overflows (5264 bytes dropped)
Apr 30 17:09:30 vdr-srv vdr: [1930] ERROR: 65693 ring buffer overflows (12350284 bytes dropped)
Apr 30 17:09:32 vdr-srv vdr: [1787] ERROR: 22 ring buffer overflows (4136 bytes dropped)
Apr 30 17:09:33 vdr-srv vdr: [1787] ERROR: 53 ring buffer overflows (9964 bytes dropped)
Apr 30 17:09:36 vdr-srv vdr: [1930] ERROR: 65181 ring buffer overflows (12254028 bytes dropped)
Apr 30 17:09:39 vdr-srv vdr: [1787] ERROR: 52 ring buffer overflows (9776 bytes dropped)


Hatte von euch jemand ein ähnliches Problem? Ich kann irgendwie nur alte Einträge finden, die sich mit den "ring buffer overflows" beschäftigen.

Am Server direkt fernsehen funktioniert ohne Probleme.

EDIT: Da ich nun das Ganze noch mit VNSI getestet hab scheint es beim Streamen von HD Sendern allgemein zu liegen.
Ich muss außerdem noch sagen, dass ich das Problem schon mal vor ein paar Tagen hatte und neu installiert habe. Das Problem war bis heute behoben...

VDR-Client: Silverstone SST-GD05B, Asrock 90-MXGPY0-A0UAYZ, Celeron 2x 2,6GHz, 4GB RAM, ASUS GT210, SSD 16GB, Futaba MDM166A USB VFD Display, yavdr 0.6.0
VDR-Server: Supermicro, Xeon 3,3 GHz, 16GB RAM ,ESXi 5.5, 2 x L4M-Twin S2 ver 6.5, yavdr 0.5a(headless)

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »bendiss« (8. Mai 2011, 14:22)


2

Sonntag, 8. Mai 2011, 14:21

Nach diversen Test und Neu-Installationen habe ich herausgefunden, dass es am Netzwerk liegt. Ich verwende dlan-Adapter um vom Arbeitszimmer ins Wohnzimmer zu kommen und die schaffen die Übertragungsrate bei HD leider nicht...

VDR-Client: Silverstone SST-GD05B, Asrock 90-MXGPY0-A0UAYZ, Celeron 2x 2,6GHz, 4GB RAM, ASUS GT210, SSD 16GB, Futaba MDM166A USB VFD Display, yavdr 0.6.0
VDR-Server: Supermicro, Xeon 3,3 GHz, 16GB RAM ,ESXi 5.5, 2 x L4M-Twin S2 ver 6.5, yavdr 0.5a(headless)


3

Montag, 9. Mai 2011, 10:32

Wenigstens mal einer, der dazuschreibt, was er rausgefunden hat. (Und nicht nur ein 'Geht wieder.')
:tup

Danke,
Faudeer
Synchronisieren und Backup auch unter Linux! 250MB extra für euch und mich bei Dropbox-Anmeldung (zu den kostenlosen 2GB), wenn ihr meinen Referral nutzt.

4

Montag, 9. Mai 2011, 11:55

hallo,
Ich verwende dlan-Adapter um vom Arbeitszimmer ins Wohnzimmer zu kommen und die schaffen die Übertragungsrate bei HD leider nicht...
das wundert mich jetzt aber sehr! was hast du da für dinger? hier funktionieren "devolo" (200AV+) wunderbar, trotz platzierung in einer steckleiste und 30 jahre alte elektroverkabeleung ...

gruß, ciax
Lascala LC17 - tribute to viking ;o) + atric IR / AMD X2 BE-2400 / OctopusNet S4 / yavdr-(testing) vdr / output: graphTFT-fe via 6.4" TFT & DVB-S/S2 via FullHD / NVidia GT220 passiv

5

Montag, 9. Mai 2011, 13:36

Ich hab auch die devolo 200. Hast du die Verschlüsselung aktiviert?

Es hat auch eine Zeit lang ohne Probleme funktioniert...zum Test hab ich den VDR-Server ins Wohnzimmer geholt und ihn direkt an den Switch angeschlossen, wo auch der Client dranhängt und hatte seitdem keine Probleme mehr...
Ich wollte nochmal nen Test machen mit zwei einzelnen Steckdosen, wo nichts mehr weiter dranhängt. Evtl. erreiche ich da eine höhere Datenrate. Ich bin auf jeden Fall erstmal froh die Fehlerquelle Netzwerk gefunden zu haben ;)

Grüße,
bendiss

VDR-Client: Silverstone SST-GD05B, Asrock 90-MXGPY0-A0UAYZ, Celeron 2x 2,6GHz, 4GB RAM, ASUS GT210, SSD 16GB, Futaba MDM166A USB VFD Display, yavdr 0.6.0
VDR-Server: Supermicro, Xeon 3,3 GHz, 16GB RAM ,ESXi 5.5, 2 x L4M-Twin S2 ver 6.5, yavdr 0.5a(headless)


Ähnliche Themen

Immortal Romance Spielautomat