Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

knebb

Erleuchteter

  • »knebb« ist der Autor dieses Themas

Beiträge: 3 981

Wohnort: derzeit M-V

Beruf: Linux Geek ;)

  • Nachricht senden

1

Mittwoch, 23. April 2008, 21:13

Installation- CD Junkie?

Yohoo!

Ich bin ja kurz davor, von meinem betagten LinVDR auf easyVDR umzusteigen.

Nur werde ich die ersten Schritte bestimmt nicht auf meinem Live-System machen- das gibt Aerger mit der Familie.
Wollte das Ganze also in einer virtuellen Maschine testen.

Bootmenue erscheint, Auswahl "1" als Standard. Die Kiste bootet sauber hoch, bis die Meldung kommt "CD entnehmen, um automatisch zu installieren."

Wuerde ich ja gerne machen, aber zeigt mir mal, wie ihr das schafft, so schnell die Konfig der VM umzubauen, so dass die CD raus ist. Selbst wenn ich das (ueber zwei VI Clients) schaffe, bin ich nicht schnell genug, um sie danach wieder einzulegen. :computertod :schiel

Lasse ich sie drinnen, kommt ein Auswahlmenue "STOP", "AUTO" und "INTERAKTIV". Egal, was ich da waehle, das System faehrt runter und startet ohne irgendwas zu tun wieder neu. :tdw :angryfire

Unn nu?

Ich habe ja nun einiges an Erfahrung, aber offensichtlich bin ich hierfuer zu doof :versteck
Glotze: yaVDR (ASRock Q1900M, 4GB RAM, DD Cine S2 V6.5, ZOTAC GT630 (Rev. 2)
Server: HP ProLiant MicroServer G8, VMware ESXi 5.5 :P

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »knebb« (23. April 2008, 21:25)


2

Donnerstag, 24. April 2008, 06:02

RE: Installation- CD Junkie?

einfach deaktivieren per menue geht nicht?
rechtsklick auf das cd symbol ...

hatte allerdings schon lang keine vmware mehr.
2003 - 2011 - R.I.P.

knebb

Erleuchteter

  • »knebb« ist der Autor dieses Themas

Beiträge: 3 981

Wohnort: derzeit M-V

Beruf: Linux Geek ;)

  • Nachricht senden

3

Donnerstag, 24. April 2008, 08:42

RE: Installation- CD Junkie?

Zitat

Original von wilderigel
einfach deaktivieren per menue geht nicht?
Noe.
Dauert mit VirtualCenter zu lange fuer easyVDR.

Ist das wirklich ernst gemeint, dass man das Teil nicht installieren kann ohne das Laufwerk zu oeffnen?

Die Frage bleibt, warum er mir danach ein Menue anbietet, die Auswahloptionen aber total ignoriert....
Glotze: yaVDR (ASRock Q1900M, 4GB RAM, DD Cine S2 V6.5, ZOTAC GT630 (Rev. 2)
Server: HP ProLiant MicroServer G8, VMware ESXi 5.5 :P

nogood

Anfänger

Beiträge: 46

Wohnort: Münsterland

Beruf: Fachinformatiker

  • Nachricht senden

4

Donnerstag, 24. April 2008, 09:09

RE: Installation- CD Junkie?

Zitat

Original von knebb
Unn nu?


Ich binde das ISO immer als CD ein (in den VM-Settings).
Als Festplatte unbedingt IDE mit mind. 10GB (oder waren es 11GB?) auswählen, sonst geht es net!!

Dann die VM Starten und einfach durchlaufen lassen. Hat bei mir bisher immer geklappt.

lg
Thorsten

knebb

Erleuchteter

  • »knebb« ist der Autor dieses Themas

Beiträge: 3 981

Wohnort: derzeit M-V

Beruf: Linux Geek ;)

  • Nachricht senden

5

Donnerstag, 24. April 2008, 09:46

RE: Installation- CD Junkie?

Zitat

Original von nogood

Zitat

Original von knebb
Unn nu?


Ich binde das ISO immer als CD ein (in den VM-Settings).

Klar, mache ich ja auch so..genau das ist ja das Problem.

Zitat


Als Festplatte unbedingt IDE mit mind. 10GB (oder waren es 11GB?) auswählen, sonst geht es net!!

IDE? easyVDR unterstuetzt kein SCSI?
Dann muss ich das ja auf meiner VM Workstation installieren- anstatt auf dem ESX :-(

Naja, das koennte das Problem gewesen sein. Werd's testen.
Glotze: yaVDR (ASRock Q1900M, 4GB RAM, DD Cine S2 V6.5, ZOTAC GT630 (Rev. 2)
Server: HP ProLiant MicroServer G8, VMware ESXi 5.5 :P

6

Donnerstag, 24. April 2008, 19:36

Ich habe da vielleicht eine lösung!
Es soll aus den Betstadium raus.
Linvdr braucht dafür hwinfo oder du trägst es direkt ein.

Ich gebe es mal inoffiziell da ich weiß das du damit klar kommst.
Es sollte eigentlich funzen.
»Dauser« hat folgende Datei angehängt:
HauptVDR AMD Goede 1750 Easyvdr 0.06.4
FF_TT2.3 Skystar2.6c 1x160GB + 1x1TB lautloser Rechner weil er im Keller steht. :D

2x MediaMVP als Client+VOMPServer-Plugin

TestVDR AMD Goede 1750 mit TT1.5 Easyvdr 06.*
Bootet auf einer komischen Weise
PicoPSU als NT

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Dauser« (30. April 2008, 11:21)


knebb

Erleuchteter

  • »knebb« ist der Autor dieses Themas

Beiträge: 3 981

Wohnort: derzeit M-V

Beruf: Linux Geek ;)

  • Nachricht senden

7

Donnerstag, 24. April 2008, 20:49

Zitat

Original von Dauser
Ich gebe es mal inoffiziell da ich weiß das du damit klar kommst.

Dein Vertrauen ehrt- allerdings bin ich mir nicht sicher, ob mir das hilft. Soweit ich das gesehen habe, installiert das Skript easyVDR auf einem Device (per default USB-Stick, aber evtl. auch zweite Festplatte).

Hmmm....dann wuerde ich auf einem zweiten Linux System das Skript starten und auf die Platte des easyvdr-VM installieren lassen.....jo, kapiert :D

Bin mal kurz weg, was ausprobieren ;D
Glotze: yaVDR (ASRock Q1900M, 4GB RAM, DD Cine S2 V6.5, ZOTAC GT630 (Rev. 2)
Server: HP ProLiant MicroServer G8, VMware ESXi 5.5 :P

knebb

Erleuchteter

  • »knebb« ist der Autor dieses Themas

Beiträge: 3 981

Wohnort: derzeit M-V

Beruf: Linux Geek ;)

  • Nachricht senden

8

Donnerstag, 24. April 2008, 21:13

Zitat

Original von knebb
Hmmm....dann wuerde ich auf einem zweiten Linux System das Skript starten und auf die Platte des easyvdr-VM installieren lassen.....jo, kapiert :D

Scheinbar doch nicht.
Das Skript macht eigentlich genau garnix.
Habe als Device die zweite Platte (/dev/sdb) angegeben.
Er sagt auch, dass alle Parameter ok sind. stopvdr und startvdr findet er nicht (klar, ist ja kein VDR)- auskommentiert. Aber machen tut er nix. Auch die Aufrufparameter "-iso" o.ae. ignoriert das Skript voellig (ausser in der auskommentierten "-h" Schleife).

Nene, das ist eher Alpha als Beta.

Ich werde mir mein laufendes System via Knoppix sichern und dann live installieren.

Toll ist das aber trotzdem nicht. Ich meine, so besonders sind meine Anforderungen doch auch nicht, oder?
Glotze: yaVDR (ASRock Q1900M, 4GB RAM, DD Cine S2 V6.5, ZOTAC GT630 (Rev. 2)
Server: HP ProLiant MicroServer G8, VMware ESXi 5.5 :P

knebb

Erleuchteter

  • »knebb« ist der Autor dieses Themas

Beiträge: 3 981

Wohnort: derzeit M-V

Beruf: Linux Geek ;)

  • Nachricht senden

9

Donnerstag, 24. April 2008, 21:45

Prima Sache, das.

Habe jetzt das Ganze auf VMware Workstation mit einer IDE disk probiert. Nun habe ich es auch geschafft, die CD rauszunehmen und rechtzeitig wieder einzulegen.

Beim Paritionieren meckert er irgendwas von wegen "nicht ausserhalb der Disk anlegbar" oder so. Und danach meckert er, dass die Partitionierung ungueltig ist.

Habe festgestellt, dass ihm die 8GB lokale Festplatte zu klein war. Gebe ich ihm 80GB kommt er ueber die Partitionierung hinweg. So, und wo ist die Grenze? Wieviel lokalen Platz brauche ich denn? Mein LinVDR nutzt ca. 500MB- die Videodaten liegen sowieso im Netz.

Ihr meint wirklich, dass ich so eine Installationsroutine auf mein Live-System drauflasse?
Glotze: yaVDR (ASRock Q1900M, 4GB RAM, DD Cine S2 V6.5, ZOTAC GT630 (Rev. 2)
Server: HP ProLiant MicroServer G8, VMware ESXi 5.5 :P

10

Donnerstag, 24. April 2008, 22:11

HI,

knebb
Die grenze liegt bei 10 GB, wovon easyvdr natürlich nicht alles belegt, da aber ne Entwicklungsumgebung dabei ist, wird halt vorgesorgt.

Es werden übrigens vier Partitionen erstellt

Quellcode

1
2
3
4
hda1: primär swap           256 MB   type 82 
 hda2: primär /mnt/hda1     1000 MB   type 83 ext3
 hda3: primär /             8000 MB   type 83 ext3
 hda4: primär /video0       REST      type 83 ext3


Ansonsten kannst Du Dir ja mal das zur gemüte führen
http://wiki.easy-vdr.de/index.php/Installation

Zitat

Habe festgestellt, dass ihm die 8GB lokale Festplatte zu klein war

Hat Nogood ja auch erwähnt ;)

Zitat

Als Festplatte unbedingt IDE mit mind. 10GB (oder waren es 11GB?) auswählen, sonst geht es net!!


Zitat

Ihr meint wirklich, dass ich so eine Installationsroutine auf mein Live-System drauflasse?

Nur Mut ;)

MfG
Kris
Intel DN2800MT 4GB RAM; 32GB mSata, Ubuntu 15.04, TVHeadend 4.1, Digibit R1 SatIP

sparkie

Erleuchteter

Beiträge: 3 046

Wohnort: a child of the universe

Beruf: duct tape programmer

  • Nachricht senden

11

Donnerstag, 24. April 2008, 23:33

Zitat

Originally posted by knebb
IDE? easyVDR unterstuetzt kein SCSI?
Dann muss ich das ja auf meiner VM Workstation installieren- anstatt auf dem ESX :-(
[...]
Ihr meint wirklich, dass ich so eine Installationsroutine auf mein Live-System drauflasse?


easyvdr orientiert sich vermutlich eher am Normalfall (ein vdr ohne SCSI Platten) als am Worst-Case (vdr auf VMware + SCSI).

es koennte manchmal auch helfen, die Installationsbedingungen fuer eine Distribution zu erleichtern, statt zu erschweren :D

knebb

Erleuchteter

  • »knebb« ist der Autor dieses Themas

Beiträge: 3 981

Wohnort: derzeit M-V

Beruf: Linux Geek ;)

  • Nachricht senden

12

Freitag, 25. April 2008, 08:33

Zitat

Original von sparkie
es koennte manchmal auch helfen, die Installationsbedingungen fuer eine Distribution zu erleichtern, statt zu erschweren :D


Es koennte manchmal auch helfen, gute Ideen auch benutzerfreundlich umzusetzten :lol2

Nein, nicht so ernst gemeint. Sicherlich ist das nicht die Standardloesung. Ich meckere ja garnicht mehr rum, dass easyVDR kein SCSI unterstuetzt. Kann ich mit leben- ist bei LinVDR auch nicht anders. Ich kann auch mit der Idee "CD raus& rein" leben- da liegt die Schwierigkeit halt tatsaechlich an meinem System.

Was ich aber halt wirklich schlecht finde, sind die fehlenden Fehlermeldungen und Plausibilitaetspruefungen.
Warum kriege ich keine g'scheite Fehlermeldung zu sehen, wenn er keine Platte zum installieren findet?
Warum kriege ich keinerlei Fehlermeldung, wenn die Platte angeblich zu klein ist?


Ich weiss, dass viele Nutzer wunderbar mit easyVDR klarkommen- was auch der Grund dafuer ist, dass ich es weiter versuchen werde. Aber besonders vertrauenserweckend in die spaetere Zuverlaessigkeit ist das halt nicht.
Glotze: yaVDR (ASRock Q1900M, 4GB RAM, DD Cine S2 V6.5, ZOTAC GT630 (Rev. 2)
Server: HP ProLiant MicroServer G8, VMware ESXi 5.5 :P

lheik

Fortgeschrittener

Beiträge: 199

Wohnort: Aistmer aus Großostheim

  • Nachricht senden

13

Freitag, 25. April 2008, 09:28

Hallo Knebb,

somit wirst du von mir herzlichst eingeladen die installationsroutinen zu verbessern.

-- ist ernst gemeint --

Gruß Uwe
Distri: easyVDR 0.9.10-DEV (Karmic) www.easy-vdr.de
VDR-Version:1.7.0
Kernel:2.6.31.5
Hardware:
BE 2350 GF8200
root: 80 GB 2,5" Laptophdd
Video/Media: 400 GB Samsung SATA + 1TB WD SATA 1 x DVB Nexus 2.1 + 1 x budget
Alles in allem: Power und dank Powernow sogar äusserst sparsam!

nogood

Anfänger

Beiträge: 46

Wohnort: Münsterland

Beruf: Fachinformatiker

  • Nachricht senden

14

Freitag, 25. April 2008, 09:29

Zitat

Original von knebb
Aber besonders vertrauenserweckend in die spaetere Zuverlaessigkeit ist das halt nicht.


Nun, Du hast da sicher nicht ganz unrecht.

Die Probleme die Du jetzt hattest, haben wohl nur sehr wenige - was aber nicht heisst das man es nicht besser machen kann. Das geht immer!!

Ich bin schon vor langer Zeit von LinVDR auf easyVDR umgestiegen und habe es nicht bereut!!

Die Installationsroutine fand ich damals auch ungewöhnlich, aber nicht weiter Schlimm!

Schau doch mal auf http://www.easy-vdr.de vorbei.... Vorschläge, Kritik (vielleicht auch mehr) von so einem erfahrenen VDRler ist doch immer Willkommen.

lg
Thorsten

15

Freitag, 25. April 2008, 11:15

Ich kann knebb's Erfahrungen nur bestätigen. Ich habe versucht easyVDR in einer qemu-vm zu installieren und bin auch an der eject-Problematik gescheitert.
Mein VDR: LinVDR 0.7 + MT, ASROCK K7VM4, Duron 1000@500, 128 MB RAM, Samsung SP1604+SP2014, Medion 4688, TT 1.3 + Skystar 2.6D

16

Samstag, 26. April 2008, 09:52

ähm - zumindest bei mir kommt (seit RC1?) - wenn die CD-Lade nicht geöffnet wird, eine neues Script, das nachfragt, wie man nun weitermachen möchte:
vollautomatische Inst, selber partitionieren oder abbrechen...

ich nehme VMWare Workstation, dynamische Harddisk IDE mit 20 GB (nimmt sich dann auf der Platte eh nur den tatsächlich verbrauchten Platz) und gebe im CD-Rom einfach die Iso an. Dann booten und die CD-Geschichte abwarten :)

easyVDR ist im aktuellen Stand vielleicht nicht ganz so unzerstörbar wie LinVDR damals :-)) aber dafür kann es 200x mehr und ist gewitzt aufgebaut - und man hat die DEV-Umgebung gleich dabei und muß sich nicht verrenken von wegen Compiler-Version und libs...
Zotac ION-ITX F mit 2GB RAM, ASUS GT610, yaVDR 0.5.0a im Client-Betrieb
yaVDR 0.5.0a als headless Server auf Citrix XenServer 6.1

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »zebulon« (26. April 2008, 09:53)


17

Samstag, 26. April 2008, 21:18

Zitat

eject-Problematik gescheitert

halte ich fast für unmöglich schon seit 0.3

Aber was sein kann ist dass er mit dem Plattentreiber nicht klarkommt...

knebb

Erleuchteter

  • »knebb« ist der Autor dieses Themas

Beiträge: 3 981

Wohnort: derzeit M-V

Beruf: Linux Geek ;)

  • Nachricht senden

18

Montag, 28. April 2008, 00:29

Zitat

Original von ranseyer

Zitat

eject-Problematik gescheitert

halte ich fast für unmöglich schon seit 0.3

So?
Also mit VMware ESX geht das garnicht, weil man mehr als 10s braucht um die (virtuelle) CD zu "entnehmen".

Zitat

Aber was sein kann ist dass er mit dem Plattentreiber nicht klarkommt...

Das war dann mein naechster Fehler und wahrscheinlich der Grund fuer das Scheitern- dennoch keine brauchbare Fehlermeldung, einfach nur Reboot.

Weiter im Text
Nun gut, aufgrund der vielen positiven Stimmen zu easyVDR habe ich es jetzt mal tatsaechlich auf mein Live-System losgelassen.
Aber auch hier bin ich (fast) an der Eject-Thematik gescheitert. Mein Laufwerk ist ein Slot-in Laufwerk. Die CD wurde sauber ausgeworfen- aber wie soll er denn die (nicht vorhandene) Lade wieder schliessen? Nach mehreren Versuchen konnte ich ihn mit einer leeren CD-R ueberlisten:
CD ausgeworfen, Rohling rein. Rohling ausgeworfen, CD rein. Von da an hat der offensichtlich die Installation gestartet. Das laefut z.Zt. noch- mangels Monitor kann ich es nicht verfolgen.

Wir warten gespannt auf die Fortsetzung :)
Glotze: yaVDR (ASRock Q1900M, 4GB RAM, DD Cine S2 V6.5, ZOTAC GT630 (Rev. 2)
Server: HP ProLiant MicroServer G8, VMware ESXi 5.5 :P

19

Montag, 28. April 2008, 10:21

Der Installer will sicher sein dass die Installation auch gewollt ist...
Sonst würde gelegentlich auch mal ein Office-PC geplättet werden wenn die CD im Laufwerk ist.

Für die Bestätigung der User gibt es zwei Möglichkeiten:

A) Das "CD raus / rein"-Spielchen (Check 1: CD nicht mountbar, Check2 CD wieder mountbar)
B) [Cursor-nach-unten] und dann [ENTER] drücken.
Erster Punkt ist abbrechen. Zweiter ist die automatische Installation.
Bei Auto-Installation werden Mindestgrößen der Partitionen gecheckt, und falls die Mindestanforderungen nicht erfüllt werden abgebrochen (Platte zu klein), bzw. 10 Sekunden gewarnt und dann Partitioniert + Formatiert.
Formatiert wird immer alles außer xda4 wenn die Partitionen schon passten...

PS: Bei VM-Ware GSX deaktiviere ich einfach kurz das virtuelle CD-Laufwerk komplett beim ersten Check, und aktiviere es wieder vor dem zweiten Check ob die CD nun wieder drin ist. Das geht meist ganz wunderbar !

knebb

Erleuchteter

  • »knebb« ist der Autor dieses Themas

Beiträge: 3 981

Wohnort: derzeit M-V

Beruf: Linux Geek ;)

  • Nachricht senden

20

Montag, 28. April 2008, 10:34

Zitat

Original von ranseyer
Der Installer will sicher sein dass die Installation auch gewollt ist...

Das ist mir schon klar.

Zitat

A) Das "CD raus / rein"-Spielchen (Check 1: CD nicht mountbar, Check2 CD wieder mountbar)

Die Idee ist ja nicht schlecht- aber halt nur eingeschraenkt nutzbar. Sei es wegen der knappen 10s (das unter ESX nicht reicht!) oder der Problematik mit Slot-In Laufwerk. Die Frage ist, ueberprueft er beim erneuten Einzug, ob die CD mountbar ist, oder ob es die richtige easyVDR-CD ist? Zweiteres waere ja besser....

Zitat

B) [Cursor-nach-unten] und dann [ENTER] drücken.
Erster Punkt ist abbrechen. Zweiter ist die automatische Installation.
Keine Doku dazu gefunden. Ohne Monitor geht das so schlecht, die Ausgaben anzusehen. Und vor allem ohne Tastatur geht das so schlecht, Auswahlen zu bestaetigen. :D

Zitat

Bei Auto-Installation werden Mindestgrößen der Partitionen gecheckt, und falls die Mindestanforderungen nicht erfüllt werden abgebrochen (Platte zu klein),

Kann ich gerne nochmal durckfuehren- genau diesen Check hat er bei mir NICHT gemacht, sondern Partitionen lustig erstellt und dann erst festgestellt, dass fuer weitere Partitionen nicht genug Platz ist. Aber nichtmal irgendwelche Error von fdisk abgefragt, sondern stur weitergemacht, bis er halt die (nicht angelegten) Partitionen nicht mounten konnte.

Zitat

PS: Bei VM-Ware GSX deaktiviere ich einfach kurz das virtuelle CD-Laufwerk komplett beim ersten Check, und aktiviere es wieder vor dem zweiten Check ob die CD nun wieder drin ist. Das geht meist ganz wunderbar !

Ich glaube, das habe ich inzwischen deutlich gemacht, dass es mit dem ESX definitiv nicht klappt, weil die 10s zu knapp bemessen sind. Ich redete weder von GSX noch von VMware Server, noch von WS. Aber es klappt ja aufgrund des fehlenden SCSI Supports (ist das richtig?) sowieso nicht unter ESX.
Glotze: yaVDR (ASRock Q1900M, 4GB RAM, DD Cine S2 V6.5, ZOTAC GT630 (Rev. 2)
Server: HP ProLiant MicroServer G8, VMware ESXi 5.5 :P

Immortal Romance Spielautomat