You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

21

Saturday, October 22nd 2005, 5:48pm

das verstehe ich nicht! ich installiere ein neues linvdr07
dann das update von marctwain 2005-05-18?! dann deine neuen
lib's und dann den aktuellsten cody. dann "ldconfig"

dann mein xxv_nfk und alles löpt wie einst im mai?!
P3-1333 - 512 MB - Siemens DVB-C
Debian Etch - Kernel 2.6.23 - VDR 1.3.47 (selber kompiliert)

tarandor

Professional

Posts: 1,308

Location: Hessen

  • Send private message

22

Saturday, October 22nd 2005, 5:55pm

Das sind die links wohl beim mir kaputt gegangen.

Hab das Paket entpackt und dann die Dateien rausgeworfen die ich nicht brauche. (hab schon den mysql drauf).
Dann wieder das Paket geschnürt und mit -C / entpackt. (So brauch ich die net einzeln zu kopieren :) )
Wahrscheinlich ist's dabei passiert.

Gruß
Tarandor
VDR-User #1011
http://vdr.nella.de

23

Saturday, October 22nd 2005, 6:06pm

@tarandor
jetzt löpt es aber bei dir?


naja - jetzt mit der version 0.0.4 sollte eigentlich alles behoben sein - hope so -
jetzt könnte jemand der sich mit shell scipten auskennt den "installer" verbessern :D

ansonsten wünsche ich viel spaß mit eurem neuen XXV :]


thomas
P3-1333 - 512 MB - Siemens DVB-C
Debian Etch - Kernel 2.6.23 - VDR 1.3.47 (selber kompiliert)

VirtuaDZ

Intermediate

Posts: 206

Location: Berlin

Occupation: IT Consultant

  • Send private message

24

Saturday, October 22nd 2005, 6:09pm

Danke NoFutureKid! Läuft alles bestens! :]

Hatte vor ner Woche probiert XXV nach der Anleitung hier im LinVDR Forum zu installieren, aber leider ohne erfolg.
Dein Paket dagegen arbeitet ohne Probleme! :D

PS: ich hab Version 0.2 genommen

VDR standalone: easyVDR 2.0 Alpha| TT6400
VDR Server: Intel Atom D945GSEJT | Digital Devices DuoFlex S2 miniPCIe| headless
Server: ESXi 5.5 mit easyVDR 2 Alpha in virtueller Maschine
Intel DQ45CB | Q2Q9650 | NAS-Server | Streaming-Server | VompServer
VDR Clients:
easyVDR 1.0 mit TT FF
3x MediaMVP

[Registered VDR User #823]

This post has been edited 1 times, last edit by "VirtuaDZ" (Oct 22nd 2005, 6:11pm)


Posts: 2,950

Location: Isen

Occupation: System Manager

  • Send private message

25

Saturday, October 22nd 2005, 6:12pm

Quoted

Original von NoFutureKid
jetzt könnte jemand der sich mit shell scipten auskennt den "installer" verbessern :D

Ich guck ihn mir mal an... den Installer... Und latürnich auch das XXV Paket... ;)

Mar(mahlzeit)kus
:mahlzeit

Klick hier für "Aktuelle Verkaufsthreads"

Klick hier für "Meine Systeme"


  • yaVDR 0.5 headless Server in ProxMox VM, Digital Devices Cine S2 6.5 mit DuoFlex Erweiterung (Quad Tuner) per vt-d durchgereicht.
  • yaVDR 0.5 deviceless Client auf Zotac D2550 ITX Wifi Supreme am 42" LG
  • MLD RPI Edition mit vompclient


tarandor

Professional

Posts: 1,308

Location: Hessen

  • Send private message

26

Saturday, October 22nd 2005, 6:19pm

Quoted

Original von NoFutureKid
@tarandor
jetzt löpt es aber bei dir?


naja - jetzt mit der version 0.0.4 sollte eigentlich alles behoben sein - hope so -
jetzt könnte jemand der sich mit shell scipten auskennt den "installer" verbessern :D

ansonsten wünsche ich viel spaß mit eurem neuen XXV :]


thomas

Läuft auch bei mir.
Hatte noch ein backup von Anfang des Monats.
Hab daraus zumindest schonmal die X11-libs genommen.
bei den svn-libs beschwert er sich ja nur. ;)

Hat jemand ne Idee wie ich die Links am einfachsten wiederherstellen kann, ohne das alles manuell mit ln -sf .... zu machen?

Gruß
Tarandor
VDR-User #1011
http://vdr.nella.de

27

Saturday, October 22nd 2005, 6:20pm

danke für das lob - so macht "nachtarbeit" doch spaß. wenn ich mal wieder den drang verspüre dann suche ich mir wieder was zusammen und bastell
daraus was feines...

@mahlzeit:
wenn du da was gebacken bekommst - dann kann ich das ja wieder da online stellen - mußt dann halt nur laut geben :D
P3-1333 - 512 MB - Siemens DVB-C
Debian Etch - Kernel 2.6.23 - VDR 1.3.47 (selber kompiliert)

28

Saturday, October 22nd 2005, 6:22pm

zum bleistift mit dem "midnight commander" und dann mittels STRG+X+S dann kannst ganz leicht die fehlende zahl hinten dran hängen :-)
P3-1333 - 512 MB - Siemens DVB-C
Debian Etch - Kernel 2.6.23 - VDR 1.3.47 (selber kompiliert)

This post has been edited 1 times, last edit by "NoFutureKid" (Oct 22nd 2005, 6:22pm)


Posts: 2,950

Location: Isen

Occupation: System Manager

  • Send private message

29

Saturday, October 22nd 2005, 6:30pm

Quoted

Original von NoFutureKid
danke für das lob - so macht "nachtarbeit" doch spaß. wenn ich mal wieder den drang verspüre dann suche ich mir wieder was zusammen und bastell
daraus was feines...

@mahlzeit:
wenn du da was gebacken bekommst - dann kann ich das ja wieder da online stellen - mußt dann halt nur laut geben :D

Ich hab grad noch ein Bugfix für MyLinVDR in Arbeit, aber danach guck ich mir den Installer mal an.

Mar(mahlzeit)kus
:mahlzeit

Klick hier für "Aktuelle Verkaufsthreads"

Klick hier für "Meine Systeme"


  • yaVDR 0.5 headless Server in ProxMox VM, Digital Devices Cine S2 6.5 mit DuoFlex Erweiterung (Quad Tuner) per vt-d durchgereicht.
  • yaVDR 0.5 deviceless Client auf Zotac D2550 ITX Wifi Supreme am 42" LG
  • MLD RPI Edition mit vompclient


tarandor

Professional

Posts: 1,308

Location: Hessen

  • Send private message

30

Saturday, October 22nd 2005, 6:31pm

Prima, danke.
Hab mit mc noch nie viel gemacht. :)

Gruß
Tarandor
VDR-User #1011
http://vdr.nella.de

31

Saturday, October 22nd 2005, 8:46pm

Was sagt mir denn beim Aufruf von xxv das ??? :

LinVDR:~# Can't use an undefined value as an ARRAY reference at /opt/XXV/bin/../lib/XXV/MODULES/USER.pm line 170.

Es geht nix - ausser das mysql läuft, eine leere xxv-Datenbank da ist und das wars...

Hier nochmal mein xxv.log:

Quoted

1 (250) [20:55:58] :
----------------------------
---- XXVD System startet ---
----------------------------
2 (250) [20:55:58] : Verbose Level is set to 3
3 (250) [20:55:58] : Schnelle Template Unterstützung ist aktiv!
4 (250) [20:55:58] main: DBD::mysql::db do failed: Error writing file './xxv/VERSION.frm' (Errcode: 28) at ./bin/xxvd line 445.

=========== top of stack =========
/opt/XXV/bin/../lib/Tools.pm:89 (Tools::stackTrace)
/opt/XXV/bin/../lib/Tools.pm:114 (Tools::lg)
./bin/xxvd:666 (Tools::debug)
./bin/xxvd:445 (main::__ANON__)
./bin/xxvd:558 (main::getDBVersion)
./bin/xxvd:694 (main::checkDB)
./bin/xxvd:237 (main::init_db_connect)
=========== eval on ==============
./bin/xxvd:558 (main::getDBVersion)
=========== end of stack =========

5 (250) [20:55:58] main: DBD::mysql::db do failed: Table 'xxv.VERSION' doesn't exist at ./bin/xxvd line 446.

=========== top of stack =========
/opt/XXV/bin/../lib/Tools.pm:89 (Tools::stackTrace)
/opt/XXV/bin/../lib/Tools.pm:114 (Tools::lg)
./bin/xxvd:666 (Tools::debug)
./bin/xxvd:446 (main::__ANON__)
./bin/xxvd:558 (main::getDBVersion)
./bin/xxvd:694 (main::checkDB)
./bin/xxvd:237 (main::init_db_connect)
=========== eval on ==============
./bin/xxvd:558 (main::getDBVersion)
=========== end of stack =========

6 (250) [20:55:58] main: DBD::mysql::db selectrow_hashref failed: Table 'xxv.VERSION' doesn't exist at ./bin/xxvd line 448.

=========== top of stack =========
/opt/XXV/bin/../lib/Tools.pm:89 (Tools::stackTrace)
/opt/XXV/bin/../lib/Tools.pm:114 (Tools::lg)
./bin/xxvd:666 (Tools::debug)
./bin/xxvd:448 (main::__ANON__)
./bin/xxvd:558 (main::getDBVersion)
./bin/xxvd:694 (main::checkDB)
./bin/xxvd:237 (main::init_db_connect)
=========== eval on ==============
./bin/xxvd:558 (main::getDBVersion)
=========== end of stack =========

7 (250) [20:55:58] main: Use of uninitialized value in numeric eq (==) at ./bin/xxvd line 562.

=========== top of stack =========
/opt/XXV/bin/../lib/Tools.pm:89 (Tools::stackTrace)
/opt/XXV/bin/../lib/Tools.pm:114 (Tools::lg)
./bin/xxvd:666 (Tools::debug)
./bin/xxvd:562 (main::__ANON__)
./bin/xxvd:694 (main::checkDB)
./bin/xxvd:237 (main::init_db_connect)
=========== eval on ==============
./bin/xxvd:694 (main::checkDB)
=========== end of stack =========

8 (250) [20:55:58] main: Use of uninitialized value in sprintf at ./bin/xxvd line 562.

=========== top of stack =========
/opt/XXV/bin/../lib/Tools.pm:89 (Tools::stackTrace)
/opt/XXV/bin/../lib/Tools.pm:114 (Tools::lg)
./bin/xxvd:666 (Tools::debug)
./bin/xxvd:562 (main::__ANON__)
./bin/xxvd:694 (main::checkDB)
./bin/xxvd:237 (main::init_db_connect)
=========== eval on ==============
./bin/xxvd:694 (main::checkDB)
=========== end of stack =========

9 (501) [20:55:58] :
------- !PROBLEM! ----------
Upps, your Version from DB(0) doesn't match
with the wished version from xxv-software-packet(12).
Please go to contribdir 'cd /opt/XXV/contrib' and start
'./update-xxv' to upgrade your xxv database!
------- !PROBLEM! ----------
10 (250) [20:56:00] : Load Module XXV::MODULES::WAPD = 0.45
11 (250) [20:56:00] : Load Module XXV::MODULES::VTX = 0.45
12 (250) [20:56:00] USER: DBD::mysql::db do failed: Error writing file './xxv/USER.frm' (Errcode: 28) at /opt/XXV/bin/../lib/XXV/MODULES/USER.pm line 154.

=========== top of stack =========
/opt/XXV/bin/../lib/Tools.pm:89 (Tools::stackTrace)
/opt/XXV/bin/../lib/Tools.pm:114 (Tools::lg)
./bin/xxvd:666 (Tools::debug)
/opt/XXV/bin/../lib/XXV/MODULES/USER.pm:154 (main::__ANON__)
/opt/XXV/bin/../lib/XXV/MODULES/USER.pm:134 (XXV::MODULES::USER::init)
./bin/xxvd:264 (XXV::MODULES::USER::new)
./bin/xxvd:240 (main::init)
=========== eval on ==============
/opt/XXV/bin/../lib/XXV/MODULES/USER.pm:134 (XXV::MODULES::USER::init)
=========== end of stack =========

13 (250) [20:56:00] USER: DBD::mysql::db selectall_arrayref failed: Table 'xxv.USER' doesn't exist at /opt/XXV/bin/../lib/XXV/MODULES/USER.pm line 170.

=========== top of stack =========
/opt/XXV/bin/../lib/Tools.pm:89 (Tools::stackTrace)
/opt/XXV/bin/../lib/Tools.pm:114 (Tools::lg)
./bin/xxvd:666 (Tools::debug)
/opt/XXV/bin/../lib/XXV/MODULES/USER.pm:170 (main::__ANON__)
/opt/XXV/bin/../lib/XXV/MODULES/USER.pm:134 (XXV::MODULES::USER::init)
./bin/xxvd:264 (XXV::MODULES::USER::new)
./bin/xxvd:240 (main::init)
=========== eval on ==============
/opt/XXV/bin/../lib/XXV/MODULES/USER.pm:134 (XXV::MODULES::USER::init)
=========== end of stack =========

14 (550) [20:56:00] USER: Can't use an undefined value as an ARRAY reference at /opt/XXV/bin/../lib/XXV/MODULES/USER.pm line 170.

=========== top of stack =========
/opt/XXV/bin/../lib/Tools.pm:89 (Tools::stackTrace)
/opt/XXV/bin/../lib/Tools.pm:134 (Tools::lg)
./bin/xxvd:667 (Tools::panic)
/opt/XXV/bin/../lib/XXV/MODULES/USER.pm:170 (main::__ANON__)
/opt/XXV/bin/../lib/XXV/MODULES/USER.pm:134 (XXV::MODULES::USER::init)
./bin/xxvd:264 (XXV::MODULES::USER::new)
./bin/xxvd:240 (main::init)
=========== eval on ==============
/opt/XXV/bin/../lib/XXV/MODULES/USER.pm:134 (XXV::MODULES::USER::init)
=========== end of stack =========

yaVDR 0.5 testing / ASRock B75 Pro3-M / Celeron G540 / 4GB RAM / NVIDIA GT-610/ 64GB SSD / 2TB HD / DD Cine S2 r6.5 / in Silverstone ML03 / Harmony 600 FB / KeySonic ACK-540RF Keyboard / Panasonic TX-P 50 U30 e TV / 120-Kanal Seduatmo

This post has been edited 2 times, last edit by "Taipan" (Oct 22nd 2005, 9:00pm)


vdr_Thor

Trainee

Posts: 114

Location: Darmstadt

Occupation: SysAdmin

  • Send private message

32

Saturday, October 22nd 2005, 10:22pm

version 0.0.2

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
A  XXV-Skins/deltab/Makefile
A  XXV-Skins/deltab/now.tmpl
A  XXV-Skins/Makefile
Checked out revision 560.
Start bin/xxvd: Can't call method "selectall_arrayref" on unblessed reference at /opt/XXV/bin/../lib/Tools.pm line 204.
xxvd started with pid 4797.
Stop bin/xxvd: xxvd with pid 4797 killed

update-xxv
----------

Info: Checking Server
Error: Can not connect to mysql server on 'localhost' !

Hint: You might need to overwrite the defaults for the database
server, the database name or the user name and password.

See update-xxv -h for a list of available options.

ALLES ERLEDIGT!!! HP


/etc/init.d/mysql start
Starting MySQL database server: mysqld...failed.

kein eintrag im logread
3x ASRock ION 330 + TT S2-3600 + Pollin X10 + Freevdr 2.0e
2x HTPC GMC AVC-M1 + Asus M2A VM/HDMI + HVR 4000 + NVidia 8400GS + Pollin X10 + Freevdr 2.0e
1x Asus T3-m3n8200 + Nova HD S2 + NVidia 8400GS + Pollin X10 + Freevdr 2.1
Daten Server Gentoo_Amd64 - VDR1.4.6 - xineliboutput - streamdev-server - 4 TB Raid5 - LVM - DM-Crypt


vdr_Thor

Trainee

Posts: 114

Location: Darmstadt

Occupation: SysAdmin

  • Send private message

33

Saturday, October 22nd 2005, 11:42pm

0.0.4 geht jetzt
3x ASRock ION 330 + TT S2-3600 + Pollin X10 + Freevdr 2.0e
2x HTPC GMC AVC-M1 + Asus M2A VM/HDMI + HVR 4000 + NVidia 8400GS + Pollin X10 + Freevdr 2.0e
1x Asus T3-m3n8200 + Nova HD S2 + NVidia 8400GS + Pollin X10 + Freevdr 2.1
Daten Server Gentoo_Amd64 - VDR1.4.6 - xineliboutput - streamdev-server - 4 TB Raid5 - LVM - DM-Crypt


34

Sunday, October 23rd 2005, 12:25am

Yepp,

bei mir auch. :D Endlich - war die ganze Zeit dabei... Hat sich aber vollends gelohnt wie ich das sehe. Wenn das jetzt alles noch schön stabil läuft... ?(
yaVDR 0.5 testing / ASRock B75 Pro3-M / Celeron G540 / 4GB RAM / NVIDIA GT-610/ 64GB SSD / 2TB HD / DD Cine S2 r6.5 / in Silverstone ML03 / Harmony 600 FB / KeySonic ACK-540RF Keyboard / Panasonic TX-P 50 U30 e TV / 120-Kanal Seduatmo

banano

Intermediate

Posts: 184

Location: Heilbronn

  • Send private message

35

Sunday, October 23rd 2005, 1:12am

kan mich mit ip:8080 nicht einloggen ... das gewählte login wir nicht akzeptiert und nu ????
Netceiver DVB S2 - 2 x Netclient mit NC_CLIENTVDR-0.03

ho70

Trainee

Posts: 77

Location: Erzgebirge

  • Send private message

36

Sunday, October 23rd 2005, 2:53am

Hallo,
ich habe xxv auch probiert - funktioniert super, danke.
Es bleiben aber zwei Fragen:
1. Beim Einlesen der vorhandenen (alten) Aufnahmen erscheint nur die folgende Meldung:
Schreibe nur 21 Aufnahmen in die Datenbank. Konnte 21 Aufnahmen nicht zuordnen.
Kann man die Aufnahmen noch auf eine andere Art aktualisieren?
2. Kann man die VDRAdmin-Autotimer irgendwie einlesen?
easyVDR mit PVR250 und k-Data-Hardware-WakeUp-Platine

Posts: 2,950

Location: Isen

Occupation: System Manager

  • Send private message

37

Sunday, October 23rd 2005, 2:57am

Quoted

Original von ho70
Hallo,
ich habe xxv auch probiert - funktioniert super, danke.
Es bleiben aber zwei Fragen:
1. Beim Einlesen der vorhandenen (alten) Aufnahmen erscheint nur die folgende Meldung:
Schreibe nur 21 Aufnahmen in die Datenbank. Konnte 21 Aufnahmen nicht zuordnen.
Kann man die Aufnahmen noch auf eine andere Art aktualisieren?

Das würde mich auch interessieren... Und vor allem wie ich das EPG reinbekomme. da ist bis jetzt noch nix, Daten müssten für die kommende Woche da sein, werden von tvMovie geholt.

Quoted

2. Kann man die VDRAdmin-Autotimer irgendwie einlesen?

Ja, geh ins Autotimer Menu, da gibts oben einen Link [Import autotimer], dort einfach "/etc/vdradmin/vdradmind.at" eintippen und schon hat man die alten Autotimer vom VDRAdmin importiert...
:mahlzeit

Klick hier für "Aktuelle Verkaufsthreads"

Klick hier für "Meine Systeme"


  • yaVDR 0.5 headless Server in ProxMox VM, Digital Devices Cine S2 6.5 mit DuoFlex Erweiterung (Quad Tuner) per vt-d durchgereicht.
  • yaVDR 0.5 deviceless Client auf Zotac D2550 ITX Wifi Supreme am 42" LG
  • MLD RPI Edition mit vompclient


Posts: 2,950

Location: Isen

Occupation: System Manager

  • Send private message

38

Sunday, October 23rd 2005, 3:06am

Ich hab mal das Installskript überarbeitet und werde es an NoFutureKid schicken damit er es in das Archiv mit reinnehmen kann wenn er es für gut befindet ;)

Changes:
  • Statusausgaben
  • Fehlerbehandlung
  • Schreiben eines Logs (/pub/export/xxv_install.log) während der Installation
  • Mehrfachstart (z.B. nach Fehler) möglich, vor dem Schreiben in Konfigurationsdateien etc. wird (zwar rudimetär aber immerhin...) geprüft ob die Einträge schon mal gemacht worden sind.
  • Keine Bearbeitung des Skripts mehr notwendig, Benutzername und Passwort (sowie Proxyserver und -Port für Subversion falls benötigt) werden jetzt zur Laufzeit vom Skript erfragt.


cu
Mar(Mahl(gäähhhhhn)zeit)kus
:mahlzeit

Klick hier für "Aktuelle Verkaufsthreads"

Klick hier für "Meine Systeme"


  • yaVDR 0.5 headless Server in ProxMox VM, Digital Devices Cine S2 6.5 mit DuoFlex Erweiterung (Quad Tuner) per vt-d durchgereicht.
  • yaVDR 0.5 deviceless Client auf Zotac D2550 ITX Wifi Supreme am 42" LG
  • MLD RPI Edition mit vompclient


ho70

Trainee

Posts: 77

Location: Erzgebirge

  • Send private message

39

Sunday, October 23rd 2005, 3:25am

Danke, den Link [Import autotimer] habe ich übersehen, da er nur verfügbar ist,
wenn unter [Einstellungen] -> [HTTPD] unter HtmlRoot: "html" auswählt,
ich hatte "stone" ausgewählt, da fehlt der Link leider.
easyVDR mit PVR250 und k-Data-Hardware-WakeUp-Platine

40

Sunday, October 23rd 2005, 12:03pm

Moin,

ich habe nun ein wenig getestet und bin begeistert. Ein paar Kleinigkeiten sind mir noch aufgefallen. Vielleicht hat von Euch noch jemand Lösungstipps für mich parat:

1. Ich haber IMMER die Startseite "Programm". Änderung auf "was läuft jetzt" bringt nix

2. Logread zeigt mir immer "Konnte die Log-Datei /var/log/xxvd.log nicht einlesen!". Die Datei existiert aber definitiv. Dasselbe ist mit den andern Logs (Syslog zeigt bei mir auf /var/log/messages)

Weiterhelfende Fehlermeldungen finde ich keine.
yaVDR 0.5 testing / ASRock B75 Pro3-M / Celeron G540 / 4GB RAM / NVIDIA GT-610/ 64GB SSD / 2TB HD / DD Cine S2 r6.5 / in Silverstone ML03 / Harmony 600 FB / KeySonic ACK-540RF Keyboard / Panasonic TX-P 50 U30 e TV / 120-Kanal Seduatmo