You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

M@dMo

Trainee

Posts: 143

Location: Stadt am Rhein

Occupation: Student

  • Send private message

301

Saturday, October 22nd 2005, 2:26pm

Also, die Karte hat eine Bt865AKRF Chip


Is ne Creativ-Karte Modell: CT7230

Die Aufschrift em8300 oder adv717x finde ich aber garnicht.

Es sind noch zwei große Chuips mit der Aufschrift Creative CT7235-VAQ -und VBQ 9924


Die Siemens ist in diesem rechner nicht verbaut, is nur ein Testrechner mit Celeron 467 Mhz, is der zu schwach dafür?
„Vielen Dank für die Beachtung aller Sicherheitsmaßnahmen.“

easyVDR 0.6.06 Kernel: 2.6.22.15
Videokarte(n): Air2PC/AirStar 2 DVB-T, Fujitsu Siemens DVB-C, Terratec Cinergy DVB-C ,Hauppauge PVR-350

Dr. Seltsam

Im Forum Zuhause

  • "Dr. Seltsam" started this thread

Posts: 9,969

Location: 3. Planet des Sonnensystems

Occupation: Organisator

  • Send private message

302

Saturday, October 22nd 2005, 2:43pm

der Rechner reicht auf alle Fälle. Irgendwo in diesem Thread gab es glaube ich schon mal so ein ähnliches Problem. Auf alle Fälle brauchst Du einen Eintrag für bt865 -wie auch immer der aussehen mag. Poste doch mal ein komplettes log vom Startvorgang ab booten.
Mich irritiert, dass der Microcode offenbar schon beim Booten geladen wird. Das macht nach meiner Erinnerung erst das dxr3-Plugin.

Oct 22 12:32:37 linvdr user.notice kernel: em8300: Microcode version 0x29 loaded

Oct 22 11:15:45 linvdr user.err vdr[7986]: dxr3: fatal: microcode upload failed: Timer expired
Oct 22 11:15:45 linvdr user.err kernel: em8300: DICOM Update failed
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

joachim-h

Professional

Posts: 606

Location: Köln.de

  • Send private message

303

Saturday, October 22nd 2005, 2:44pm

Dann hattest Du hiermit

Source code

1
2
3
4
5
6
#loading em8300 modules for dxr3
modprobe i2c-core
modprobe i2c-algo-bit
modprobe bt865
modprobe em8300 dicom_fix=1 dicom_control=1 dicom_other_pal=1
use_bt865=1
wenigstens schon mal die richtigen Module geladen. Das wollte Dr. Seltsam wissen. Die Karte benutzt auf jeden Fall einen em8300 Chip und entweder einen BT865 oder einen adv717x. Da muss man unterschiedliche Module benutzen.

Dein Ergebniss sieht allerdings wirklich so aus, als ob Du keine (oder die falschen) Module lädst. Die gleiche Ausgabe bekam ich nämlich als ich vergessen hatte den Block (s.o.) in die rcStart einzufügen.



joachim
Registrieter VDR User Nr. 1237

Hardware: Celeron E1400 (2*2,0GHz),4 GB Ram. 1TB HDD, Geforce GT 520, DVB-C
Software: YaVDR 0.5 mit XBMC Frodo (Test)
Fernseher: Philips 42PFL7403/10
Anlage: Sony STR-DH520, Teufel Kompakt 30

M@dMo

Trainee

Posts: 143

Location: Stadt am Rhein

Occupation: Student

  • Send private message

304

Saturday, October 22nd 2005, 2:46pm

hmm, also ich installiere jetzt nocheinmal alles von grundauf. Mal sehen ob ich es dann hinbekomme.

Danke schon mal für die Antworten
„Vielen Dank für die Beachtung aller Sicherheitsmaßnahmen.“

easyVDR 0.6.06 Kernel: 2.6.22.15
Videokarte(n): Air2PC/AirStar 2 DVB-T, Fujitsu Siemens DVB-C, Terratec Cinergy DVB-C ,Hauppauge PVR-350

M@dMo

Trainee

Posts: 143

Location: Stadt am Rhein

Occupation: Student

  • Send private message

305

Saturday, October 22nd 2005, 3:13pm

Hab jetzt linvdr 0.7 mit mt patch linvdr-0.7-mt-1.3.24-20050518 und cody-patch linvdr-1.3.34-20051019 installiert

hmm, log sagt jetzt:

Oct 22 14:26:18 linvdr user.info vdr[1068]: switching to channel 1
Oct 22 14:26:18 linvdr user.info vdr[1068]: info: Kanal nicht verfügbar!
Oct 22 14:26:18 linvdr user.debug vdr[1068]: dxr3: cSPUEncoder::Flush: OSD data size: 4117
Oct 22 14:26:18 linvdr user.debug vdr[1068]: dxr3: cSPUEncoder::Flush: OSD data size: 4117
Oct 22 14:26:18 linvdr user.debug vdr[1068]: dxr3: cSPUEncoder::Flush: OSD data size: 4117
Oct 22 14:26:19 linvdr user.debug vdr[1068]: dxr3: cSPUEncoder::Flush: OSD data size: 4117

lsmod zeigt auch an das die module da sind:

i2c_algo_bit 9736 1 em8300
i2c_core 23296 21 skystar2,mt352,budget_av,tda10021,budget_ci,budget,l64781,budget_core,dvb_ttpci,tda8083,stv0297,sp8870,ttpci_eeprom,mt312,cx24110,tda1004x,ves1820,stv0299,ves1x93,bt865,i2c_algo_bit


es kann natürlich keine channels geben, ich hab ja auch kein dvb-device

hab auch mal den kernel 2.6.12.4 installiert, mit dem ergebniss das ich über fbtv nix mehr sehe, also keine konsole mit alt-F1 bekomme,




hmm, also ich kapier nix mehr:

Oct 22 15:11:29 linvdr user.notice kernel: bt865.o: Configuring for PAL
Oct 22 15:11:29 linvdr user.notice kernel: em8300_audio.o: Analog audio enabled
Oct 22 15:11:29 linvdr user.notice kernel: em8300: Microcode version 0x29 loaded
Oct 22 15:11:30 linvdr user.debug vdr[1237]: dxr3: configure: video mode: PAL
Oct 22 15:11:30 linvdr user.notice kernel: bt865.o: Configuring for PAL
Oct 22 15:11:30 linvdr user.debug vdr[1237]: dxr3: configure: audio mode: analog
Oct 22 15:11:30 linvdr user.debug vdr[1237]: dxr3: intf: brightness=500,contrast
=500,saturation=500 at init
Oct 22 15:11:30 linvdr user.notice kernel: em8300_audio.o: Analog audio enabled
Oct 22 15:11:30 linvdr user.info vdr[1237]: initializing plugin: mp3 (0.9.13-MKI
II-pre6): A versatile audio player[MKIII]
Oct 22 15:11:30 linvdr user.debug vdr[1256]: DXR3 audio output thread started (pid=1256, tid=2050)
Oct 22 15:11:30 linvdr user.debug vdr[1257]: DXR3 video output thread started (pid=1257, tid=3075)
Oct 22 15:11:30 linvdr user.info vdr[1237]: loading /etc/vdr/plugins/mp3sources.conf
Oct 22 15:11:30 linvdr user.err vdr[1237]: WARNING: source base /dev/cdrom expan ds to /dev/hdc
Oct 22 15:11:30 linvdr user.err vdr[1237]: WARNING: source base /dev/hdc is not a directory
Oct 22 15:11:30 linvdr user.info vdr[1237]: setting primary device to 1
Oct 22 15:11:30 linvdr user.info vdr[1237]: SVDRP listening on port 2001
Oct 22 15:11:30 linvdr user.info vdr[1237]: loading /etc/vdr/themes/classic-defa ult.theme
Oct 22 15:11:30 linvdr user.info vdr[1237]: starting plugin: dxr3
Oct 22 15:11:30 linvdr user.info vdr[1237]: starting plugin: mp3
Oct 22 15:11:30 linvdr user.info vdr[1237]: loading /etc/vdr/themes/classic-defa ult.theme
Oct 22 15:11:30 linvdr user.debug vdr[1237]: remote control LIRC - keys known
Oct 22 15:11:30 linvdr user.info vdr[1237]: switching to channel 1
Oct 22 15:11:30 linvdr user.info vdr[1237]: info: Kanal nicht verfügbar!
Oct 22 15:11:30 linvdr user.debug vdr[1258]: LIRC remote control thread started (pid=1258, tid=4100)
Oct 22 15:11:30 linvdr user.debug vdr[1237]: dxr3: cSPUEncoder::Flush: OSD data

bekomme aber kein bild
„Vielen Dank für die Beachtung aller Sicherheitsmaßnahmen.“

easyVDR 0.6.06 Kernel: 2.6.22.15
Videokarte(n): Air2PC/AirStar 2 DVB-T, Fujitsu Siemens DVB-C, Terratec Cinergy DVB-C ,Hauppauge PVR-350

This post has been edited 4 times, last edit by "M@dMo" (Oct 22nd 2005, 4:00pm)


Dr. Seltsam

Im Forum Zuhause

  • "Dr. Seltsam" started this thread

Posts: 9,969

Location: 3. Planet des Sonnensystems

Occupation: Organisator

  • Send private message

306

Saturday, October 22nd 2005, 4:01pm

ich kann Dir nur helfen, wenn Du mal ein vollständiges Log postest.

Quoted

es kann natürlich keine channels geben, ich hab ja auch kein dvb-device


ich dachte, Du hast die Airstar2 drin ? Ansonsten scheint das dxr3-Plugin nun doch zu funktionieren. Du musst natürlich einen TV an die dxr3 anschließen, um ein Bild zu sehen.

Quoted

hab auch mal den kernel 2.6.12.4 installiert, mit dem ergebniss das ich über fbtv nix mehr sehe, also keine konsole mit alt-F1 bekomme,

fbtv würde wenn überhaupt nur auf Konsole 10 kommen, es funktioniert jedoch nur mit einer FF-Karte. Schalte es im setup bitte ab. Dass man nicht auf Konsole 1 wechseln kann, wäre mir neu. So einen Effekt kenne ich nur, wenn man das pvr350-Plugin laufen hat.
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

Dr. Seltsam

Im Forum Zuhause

  • "Dr. Seltsam" started this thread

Posts: 9,969

Location: 3. Planet des Sonnensystems

Occupation: Organisator

  • Send private message

307

Saturday, October 22nd 2005, 4:05pm

Quoted

Original von M@dMo
Oct 22 15:11:30 linvdr user.info vdr[1237]: switching to channel 1
Oct 22 15:11:30 linvdr user.info vdr[1237]: info: Kanal nicht verfügbar!
Oct 22 15:11:30 linvdr user.debug vdr[1258]: LIRC remote control thread started (pid=1258, tid=4100)
Oct 22 15:11:30 linvdr user.debug vdr[1237]: dxr3: cSPUEncoder::Flush: OSD data

bekomme aber kein bild


lass mich raten: du hast die Airstar2 drin? Du hast eine passende channels.conf?

Ohne vollständiges Log ist das hier Rätselraten.

Idee: hast Du in der runvdr das Modul skystar2 durch b2c2-flexcop-pci ersetzt? Sonst hat die Airstar2 keinen Treiber.
siehe http://drseltsam.device.name/vdr/kernel26124.html

Quoted

für den Fall, dass Ihr eine Skystar2 oder Airstar2-Karte habt, müsst Ihr in /etc/init.d/runvdr im Abschnitt MODULES den Treiber skystar2 durch b2c2-flexcop-pci ersetzen
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

M@dMo

Trainee

Posts: 143

Location: Stadt am Rhein

Occupation: Student

  • Send private message

308

Saturday, October 22nd 2005, 4:06pm

Tv monitor ist drann, sollte auch eigentlich s-vhs signale können, werd das erstmal überprüfen mit nem anderen rechner
„Vielen Dank für die Beachtung aller Sicherheitsmaßnahmen.“

easyVDR 0.6.06 Kernel: 2.6.22.15
Videokarte(n): Air2PC/AirStar 2 DVB-T, Fujitsu Siemens DVB-C, Terratec Cinergy DVB-C ,Hauppauge PVR-350

Dr. Seltsam

Im Forum Zuhause

  • "Dr. Seltsam" started this thread

Posts: 9,969

Location: 3. Planet des Sonnensystems

Occupation: Organisator

  • Send private message

309

Saturday, October 22nd 2005, 4:08pm

nochwas: Wenn das Laden der Aistar2-Treiber hartnäckig fehlschlägt, hilft es evtl., den Rechner bzw. das Netzteil mal für ein paar Minuten vom Netz zu trennen und dann neu zu booten.
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

M@dMo

Trainee

Posts: 143

Location: Stadt am Rhein

Occupation: Student

  • Send private message

310

Saturday, October 22nd 2005, 4:22pm

also ich wollte den rechner eigentlich komplett ohne dvb Karte laufen lassen, nur als Streaming Rechner und die ausgabe über die DXR3, das mit der Airstar kann ich mal testen,

Das Problem ist wahrscheinlich das ich dachte ein OSD auf dem Monitor zu bekommen so wie ich das von dem anderen Rechner gewohnt war, leider weiß ich aber jetzt garnicht wie ich irgendwas ohne so ein OSD zum laufen bekomm, sei es ne Mp3 oder ein Mpeg, denn auf dem Tv seh ich auch nix, wahrscheinlich aber nur ne einstellungssache
„Vielen Dank für die Beachtung aller Sicherheitsmaßnahmen.“

easyVDR 0.6.06 Kernel: 2.6.22.15
Videokarte(n): Air2PC/AirStar 2 DVB-T, Fujitsu Siemens DVB-C, Terratec Cinergy DVB-C ,Hauppauge PVR-350

This post has been edited 1 times, last edit by "M@dMo" (Oct 22nd 2005, 4:36pm)


Dr. Seltsam

Im Forum Zuhause

  • "Dr. Seltsam" started this thread

Posts: 9,969

Location: 3. Planet des Sonnensystems

Occupation: Organisator

  • Send private message

311

Sunday, October 23rd 2005, 9:32pm

RE: [LinVDR-package]: dxr3 (CVS 0.2.4) für LinVDR 0.7 !

kleines unspektakuläres update:
das Plugin für 1.3.34 basiert jetzt auf vdr mit bigpatch-test2 (habe mich Codys Sourcen angeglichen). Zudem habe ich eine Änderung (erstmal nur beim Plugin für vdr-1.3.34) an dxr3ffmpeg.c vorgenommen, die laut mailing list Probleme in Verbindung mit dem image-plugin beseitigen soll.

@ Austrian Coder (falls du hier mal vorbeischneien solltest):
wie sind denn die Chancen, dass es dieses Jahr noch einen verbesserten demuxer gibt, damit das Umschalten auch mit neueren vdr-Versionen genauso sauber geht wie bis vdr 1.3.12?
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

This post has been edited 1 times, last edit by "Dr. Seltsam" (Oct 23rd 2005, 9:33pm)


312

Sunday, October 23rd 2005, 9:44pm

RE: [LinVDR-package]: dxr3 (CVS 0.2.4) für LinVDR 0.7 !

Quoted

@ Austrian Coder (falls du hier mal vorbeischneien solltest):
wie sind denn die Chancen, dass es dieses Jahr noch einen verbesserten demuxer gibt, damit das Umschalten auch mit neueren vdr-Versionen genauso sauber geht wie bis vdr 1.3.12?


Ich habe mittlerweile super kurze Umschaltzeiten und es läuft beim mir rockstable. Ich führe das darauf zurück, dass offensichtlich Vortschritte beim flexcop gemacht wurden. Wenn dem so ist, dann ist die Weiterentwicklung der DVB Module genauso wichtig wie die Entwicklung der dxr3-Module. Denn anders kann ich mir nicht erklären, dass mein System z.Z. so gut läuft.
Aber natürlich würde ich mich auch freuen, wenn AustrianCoder wieder am dxr-plugin weiter arbeiten würde. Insbesondere wenn dabei DD-Ton herausspringt.

Gruß
Wicky
Hardware: M2NPV-VM, AthlonXP-64 5700, Samsung 1TB HD, TT-1600, GF210
Software: Ubuntu 10.04 und yaVDR Pakete
dxr3-Links:
dxr3config, dxr3-Howto :], dxr3-Modul-Entwicklerseite, dxr3-Plugin-Entwicklerseite

313

Monday, October 24th 2005, 3:45pm

Hallo,

bin gerade am dxr3-Plugin testen. Mehr dazu später! Nur habe ich gerade ein Problem:

Mir fehlen die Plugins für VDR 1.3.30, 1.3.32, 1.3.33.

Hat sie noch jemand bei sich im Bestand?

Wer sie hat, bitte Nachricht per PN. Gebe dann email an.


Vielen Dank

Steffen

314

Monday, October 24th 2005, 7:41pm

@Dr Jones

Was spricht gegen 1.3.34 ? So weit ich weiß läuft doch 1.3.34 genauso gut (oder besser) wie 1.3.30-1.3.33 !!

Gruß
Wicky
Hardware: M2NPV-VM, AthlonXP-64 5700, Samsung 1TB HD, TT-1600, GF210
Software: Ubuntu 10.04 und yaVDR Pakete
dxr3-Links:
dxr3config, dxr3-Howto :], dxr3-Modul-Entwicklerseite, dxr3-Plugin-Entwicklerseite

315

Monday, October 24th 2005, 7:58pm

Ach Wicky,

hast Du meinen Thread zum Thema streamdev und dxr3 gelesen?
http://www.vdr-portal.de/board/thread.ph…lightuser=10328


Mein jetziger Status:

So geht zum Beispiel 1.3.28, 29 relativ gut.
Bei 1.3.30, 31, 34 gehen nur die Kanäle, die auf dem gleichen Transponder liegen, der beim Start des Clients gewählt wurde...

Ein ganz normales durchschalten der Känäle bekomme ich einfach nicht hin. Für Tips von Euch bin ich jederzeit dankbar.

Ach, Du hast schon recht, daß die neuen VDR Versionen viel besser sind, was das Umschalten angeht. es geht viel sauberer. Aber bei mir eben nur auf dem Transponder und nich weiter.

Grüße Steffen

316

Tuesday, October 25th 2005, 8:16am

@Dr.Seltsam: ich habe mal deinen kernel 2.6.13.4 ausprobiert. funktioniert bis auf eine Sache ganz gut. Wenn ich das Modul dvb-bt8xx (für meine Twinhan) lade bekomme ich etliche unresolved symbol Fehler. Hast Du da eine Lösung für?
VDR: freevdr 2.1 + 2.6.32-7 +Asus M4N78 Pro + AMD X2 II 240 + 2x1 GB (DDR2 1066) + SkyStar 2 + Nova HD S2 + SS-LC17

Dr. Seltsam

Im Forum Zuhause

  • "Dr. Seltsam" started this thread

Posts: 9,969

Location: 3. Planet des Sonnensystems

Occupation: Organisator

  • Send private message

317

Tuesday, October 25th 2005, 8:43am

ja :)

schau mal hier:
http://drseltsam.device.name/vdr/kernel26134.html

Quoted

Wichtiger Hinweis: Derzeit sind die Module tveeprom.ko des Kernels (v4l2) sowie die gleichnamigen aus den ivtv-Treibern inkompatibel. Wer mit einer bttv-basierten DVB-Karte Probleme hat (dies ist z.B. bei der Avermedia 771 der Fall), der muss folgendes machen:

cd /lib/modules/2.6.13.4/ivtv
mv tveeprom.ko tveeprom.ko.HIDE
cd /lib/modules/2.6.13.4/kernel/drivers/media/video
mv tveeprom.ko.HIDE tveeprom.ko
depmod -ae
reboot

Bei mir läuft die PVR250 auch mit dem tveeprom des Kernels einwandfrei, aber bei neueren PVR-Karten könnte das Probleme geben. Daher habe ich standardmäßig mit Rücksicht auf die "Analog-Freaks" das tveeprom von ivtv aktiv.
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

318

Tuesday, October 25th 2005, 9:04am

ups...wer lesen kann.....
VDR: freevdr 2.1 + 2.6.32-7 +Asus M4N78 Pro + AMD X2 II 240 + 2x1 GB (DDR2 1066) + SkyStar 2 + Nova HD S2 + SS-LC17

Eddy_

Trainee

Posts: 106

Location: Hessen

  • Send private message

319

Tuesday, October 25th 2005, 9:15pm

@Dr.S , die Installation von deinem Kernel ging schon mal problemlos ;)
Wäre es viel Aufwand unter /misc/input noch das PC Speaker Device als Modul zu aktivieren ?
Dann würde ich endlich diese Kuh vom Eis bekommen , thx
vdr1 : Duron 900, K7SOM+, 512Mb, TT 1.5, linvdr 0.7 + MT20050518
vdr2 : Intel D945GCLF2 + 2GB , Nexus-S , Ubuntu 8.04 , vga2scart

This post has been edited 1 times, last edit by "Eddy_" (Oct 25th 2005, 9:15pm)


Posts: 3,648

Location: Mülheim / Ruhr

Occupation: Admin

  • Send private message

320

Tuesday, October 25th 2005, 10:01pm

Tach!

Kernel ist ok, hatte aber längere umschaltzeiten und osdpip-plug ging nicht! Bin erstmal zurück auf 2.6.9! Der tuts für meine alte HW am besten!

Danke trotzdem für die viele Arbeit die du investierst! Das DXR3 Plug ist spitze!!!

Gruß

Toxic
Registrierter VDR-User #1275

HW neu: Asrock B75 Pro3 - Pentium G620T - SKYDVB S952
SW neu: YaVDR mit 3.16.3er Kernel ...