You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Dr. Seltsam

Im Forum Zuhause

  • "Dr. Seltsam" started this thread

Posts: 9,931

Location: 3. Planet des Sonnensystems

Occupation: Organisator

  • Send private message

1

Saturday, July 9th 2005, 4:15pm

[LinVDR-package]: dxr3 für LinVDR 0.7 -jetzt mit AC3!

----newsflash 22.04.06-----

Bitte schaut für die Installation hier nach:
[ANNOUNCE] linvdr-dxr.deb; dxr3-System in 15min

Wicky hat viel Mühe investiert, um die Installation und Konfiguration mit einem deb-Paket zu vereinfachen und zu automatisieren.
Das sollte daher die bevorzugte Installationsmethode sein! :]


---------------------------------------------------------------------------------------------------

Tach!

es ist neu angerichtet :) :

Mit diesem Paket (edit 14.12.07: Link entfernt, da Paket inzwischen obsolet ist. Nehmt das mahlzeit 3.2-iso, da ist alles drin!) ist es möglich, in wenigen Minuten aus einer originalen ("plain-vanilla") LinVDR 0.7-Installation ein funktionierendes System mit einer dxr3 als Ausgabedevice zu machen. Das Paket enthält nicht nur die Plugin-libs für die zur 0.7 gehörende vdr-Version 1.3.17, sondern auch für 1.3.24 (für installierten MarcTwain-Patch vom 18.05.) sowie 1.4.0 (für installierten Cody-Patch).

Stand 16.05.2006:

-dxr3-Plugin 0.2.4
(für vdr 1.3.24 gepatcht mit dem Patch von Lord Zodiac, der den Ton beim DVD-Plugin bei neueren vdr-Versionen wieder hervorzaubert., sowie mit dem neuen AC3-Patch). Kleiner Wermutstropfen: mit 1.3.17 geht AC3 leider nicht
-vdr 1.3.24 (MarcTwain-Patch vom 18.05.) wurde mit dem Patch von LordZodiac sowie dem AC3-Patch aus der dxr3-plugin-users-ML neu kompiliert und ist im Paket enthalten. Danke an vdr_Thor für den Testbericht (siehe Beitrag vom 17.12. in diesem Thread)

-dxr3-Plugin 0.2.6 für vdr-1.4.0.
Den aktuellen ac3-patch sowie eine Anpassung für das image-Plugin habe ich integriert !

-die em8300-Treiber für Kernel 2.6.9 haben CVS-Stand 20.11.05
-die em8300-Treiber für Kernel 2.6.15.1 haben Versionsstand 0.15.3

-im Paket enthalten ist ein mit dxr3-Unterstützung neu kompilierter mplayer. Es ist ebenfalls möglich, die (leider nur rudimentären) DVD-Funktionen des mplayers zu benutzen. Ich habe zusätzlich noch mplayer-multi von http://www.js-home.org/vdr/mplayer-multi/index.php eingebaut. Filme, die aus mehreren Dateien bestehen und bei denen die Reihenfolge im Dateinamen steht, werden nun automatisch nacheinander abgespielt. Im mplayer-Plugin- Menü muß man nur die erste Filmdatei auswählen. Das geht auch mit vob-Dateien im video_ts-Ordner einer DVD! Es gibt also drei Wege, eine DVD abzuspielen: Über das dvd-Plugin, über den Mplayer als DVD (über DVD-VCD > DVD) oder über den mplayer als vob-Datei(en). Kleiner Wehrmutstropfen: Verschlüsselte DVDs werden offenbar nicht abgespielt. Da wird auch die böse lib, die keiner anbieten darf ,nichts nützen, denn mplayer nutzt hierfür eigene Bibliotheken.
Wenn man die AC3-Wiedergabe beim mplayer aktivieren will, so geschieht dies durch eine Änderung in /usr/bin/mplayer.sh.conf:

Source code

1
2
USEAC3="true"
AC3OUT="-ac hwac3"
(Das habe ich allerdings nicht selbst getestet)
Noch ein Tip: Wenn man sich von http://www.mplayerhq.hu/homepage/design7/dload.html das "essential codecs package" runterlädt und den Inhalt in /usr/lib/codecs auspackt, spielt mplayer sogar Windows Media VIdeos (wmv).

-ebenfalls enthalten ist nun das Tool em8300setup. Irgendwer fragte danach. Es wird aber für den Betrieb nicht benötigt, da das dxr3-Plugin selbst automatisch den Microcode lädt.

-durch den Audiopatch für das DVD-Plugin bringen leider einige Plugins, die gegen Sourcen ohne diesen patch kompiliert wurden, unresolved symbols. Diese Plugins -soweit mir bekannt- habe ich daher für die Cody-User neu kompiliert und mit ins Paket genommen. Es sind per 27.11.05 streamdev, streamplayer und pvrinput. Für streamdev in Verbindung mit vdr 1.3.17 kann ich leider keine Lösung anbieten, da es immer unresolved symbols gibt (auch ohne dxr3-Plugin)

Die Installation ist denkbar einfach: (Hinweis: Wenn Ihr einen Cody-Patch verwendet, dann muss mein dxr3-Paket immer nach dem Cody-Patch installiert werden !)

Voraussetzung: Verwendung des zur 0.7 gehörenden Kernels 2.6.9 oder des Kernels von der update-CD (2.6.15.1)

oder (empfohlen: )

mein Kernel 2.6.15
http://drseltsam.device.name/vdr/kernel2615.html



Sicherheitshalber Stoppen des vdr:

Source code

1
/etc/init.d/runvdr stop


Entpacken des tarballs

Source code

1
tar xvfz linvdr07_dxr3.tgz -C /


sowie -nur nötig, falls Ihr Kernel 2.6.9 oder 2.6.15.1 verwendet- anschließend

Source code

1
depmod -ae


Zum Laden der Treiber ist eine händische Ergänzung der Datei /etc/init.d/rcStart nötig. Sucht die Stelle vor dem Aufruf der runvdr und gebt die fettgedruckte Ergänzung ein

---------------------------------------------------------------

#loading em8300 modules for dxr3
modprobe i2c-core
modprobe i2c-algo-bit
modprobe adv717x pixelport_16bit=0 pixelport_other_pal=0
modprobe em8300 dicom_fix=1 dicom_control=1 dicom_other_pal=0


#
progress 80 "starting vdr"
#execute kill $STPID
execute /etc/init.d/runvdr start &

--------------------------------------------------------------
Die genauen Modulparameter können je nach Karte und Chip bei Euch durchaus anders sein. Wenn das Bild grün ist, versucht stattdessen eine der folgenden Kombinationen:

modprobe adv717x pixelport_16bit=1 pixelport_other_pal=1
modprobe em8300 dicom_fix=1 dicom_control=1 dicom_other_pal=1

modprobe adv717x pixelport_16bit=0 pixelport_other_pal=1
modprobe em8300 dicom_fix=1 dicom_control=1 dicom_other_pal=1

modprobe adv717x pixelport_16bit=1 pixelport_other_pal=0
modprobe em8300 dicom_fix=0 dicom_control=0 dicom_other_pal=0

Wer eine Karte mit bt865-Chip hat, der sollte stattdessen mal folgendes versuchen:

Source code

1
2
3
4
5
6
#loading em8300 modules for dxr3
modprobe i2c-core
modprobe i2c-algo-bit
modprobe bt865
modprobe em8300 dicom_fix=1 dicom_control=1 dicom_other_pal=1
use_bt865=1
Bevor es jetzt weitergeht, machen wir uns kurz Gedanken, wie die dxr3 an den TV angeschlossen werden soll. Die Karte hat eine 7-polige Mini-DIN-Buchse, an die sich auch jeder normale 4-polige Hosiden (S-Video) -Stecker anschließen lässt. Wenn der TV S-Video ("S-VHS")-fähig ist, sollte dies die erste Wahl sein. Der TV selbst brauchst dazu nicht unbedingt eine Hosidenbuchse. Viele TV`s können S-Videosiganle über die Scartbuchse entgegennehmen, der Handel hat entsprechende Adapter. Meist muss man im Menü des TV die Art des an der Scartbuchse anliegenden Signals (FBAS/Composite, RGB oder S-Video) noch definieren.
Was aber, wenn der TV nur normale FBAS/Composite-Signale verarbeiten kann? Bisher ging an dieser Stelle die Bastei los. Einen passenden Adapter für die 7-polige Buchse der dxr3, so dass man per Cinch das FBAS-Signal abgreifen kann, haben die meisten Käufer einer gebrauchten dxr3 nicht mehr bekommen. Bei Pollin gibt (gab?) es mal eine passenden Artikel "TV-Out-Adapter" , Bestell-Nr. 720 617 . Eine andere Lösung wäre, aus dem S-Video-Signal mittels eines Adapters, der ein integriertes Filterglied enthält, ein FBAS-Signal zu gewinnen. Diese Methode hat den Nachteil, dass die Bildqualität meist sichtbar leidet. Viele haben daher zum Lötkolben gegriffen und sich selbst einen FBAS-Ausgang an die entsprechenden Kontakte der dxr3 angelötet.

All dieser Aufwand gehört nun der Vergangenheit an, wenn Ihr einen adv717x-Chip auf Eurer dxr3 habt! Alles was Ihr braucht, ist ein handelsüblicher Adapter S-Video auf Cinch, der einfach nur das Luminanzsignal abgreift und an die Cinchbuchse führt. Normalerweise würdet ihr mit diesem Adapter nun ein schwarz-weiss-Bild erhalten. Der Treiber bietet seit kurzem aber die Möglichkeit, das Ausgangssignal zu definieren. Dazu müsst Ihr die Zeile in der rcStart, wo adv717x geladen wird, wie folgt modifizieren:

Source code

1
modprobe adv717x output_mode=comp+psvideo pixelport_16bit=0 pixelport_other_pal=0
Nun gibt die dxr3 auf dem Luminanz-Pin ein FBAS-Signal aus, und es wird farbig :]
(Aber nochmal: dies ist nur erforderlich, wenn die Nutzung des qualitativ besseren S-Video-Signals nicht möglich ist)

So, weiter geht`s. Nun noch das dxr3-Plugin entweder per setup auswählen oder händisch in /etc/sysconfig (PLUGINLIST="dxr3") ergänzen. Nehmt am besten erstmal alle anderen Plugins raus. Ausnahme: Bei Verwendung einer Cody-Version braucht Ihr das setup-Plugin, um in das Einstellungs-Menü zu kommen.

Mit Sicherheit dürften auch nicht alle Plugins in Kombination mit der dxr3 laufen. (Besondere Vorsicht ist auch bei Skins geboten, die meist für die OSD-Fähigkeiten des Decoders einer FF-Karte programmiert wurden. Recht gut zu laufen scheint es hingegen mit skinelchi als Plugin. Aber besser nicht die Anzeige von Senderlogos aktivieren!)

Nach einem reboot sollte die dxr3 anschließend ein Bild liefern. Wahrscheinlich hört Ihr zunächst keinen Ton, dann müsst Ihr einfach die Lautstärke aufdrehen (war bei mir komischerweise zuerst immer auf Null gesetzt). Den Digitalton habe ich nicht getestet, man kann ihn im Menü aktivieren.

Ich habe den Eindruck, dass das Umschalten mit vdr 1.3.17 etwas sauberer funktioniert als mit den neueren vdr-Versionen. Dies könnte an einem etwas anderen Buffer-Verhalten liegen, das bei den neueren Versionen für Dolby-Digital-Ausgabe über die FF-Karte optimiert ist.

Und wie immer: alles ohne Garantie und auf eigene Gefahr. Auf einer nackten Festplatte mit frisch installierter 0.7 hat es jedoch nach oben beschriebener Vorgehensweise bei mir einwandfrei funktioniert.

Gruß
Dr. Seltsam
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

This post has been edited 36 times, last edit by "Dr. Seltsam" (Dec 14th 2007, 9:06am)


MR42HH

Intermediate

Posts: 438

Location: Schleswig-Holstein

Occupation: Ingenieur Verfahrenstechnik

  • Send private message

2

Saturday, July 9th 2005, 5:37pm

Danke!!!

Ich neige mein Haupt in Ehrfurcht vor dieser Leistung - kann es leider erst Mittwoch testen. Freu mich schon!
Und so eine nette Anleitung :] Prima, sieht alles aus, als ob sogar ich das Ding demit zum Laufen kriegen werde...

Schönes Wochenende noch!

Gruß,

Mirko

mein VDR:
Siemens Gigaset 740AV, Buffalo Linkstation NAS
in meiner Bastelkiste:
2x Activy 300, 1x MediaPortal mit GLCD, 1x Fujitsu-Siemens Jetson, 1xDVB-C Rev.2.1, Airstar2, neue Nova-T, Linksys NSLU2, defekte 2300C

Uatschitchun

Professional

Posts: 1,524

Location: Wülfrath (NRW)

  • Send private message

3

Saturday, July 9th 2005, 10:09pm

RE: [linVDR-package]: dxr3 für LinVDR 0.7 !

Cool, das klingt ja man simpel!

Das heißt mit MT-Patch vom 18.5. klappt das auch?
Welche Reihenfolge ist da einzuhalten?
1. LinVDR, 2. MT-Patch, 3. DXR3 - oder - 2. und 3. vertauschen?

Wie schauts mit der Stabilität?

Wollte nämlich nem Kumpel die Tage nen VDR fertig machen mit ner DXR3 ... habe schon einiges mit diesen netten Karten angestellt ... bisher aber immer unter Debian bzw. ctvdr ..

LG
Roman
Wohnzimmer (Client 1): C't Vdr (Sarge), 2.6.15-sl, 1.4.0-2, TT-1.5 FF, Hermes 651, 40 GB, 2Ghz Celeron, 512MB, PSOne TFT
Server: C't VDR (Sid), 2.6.15-1-k7, 1.4.1-1, TT-1.6 FF, XP-2000+, 500GB, 512MB
Schlafzimmer (Client 2): MediaMVP
MediaMVP, Bose S 100, 400er Oldischlepptopp für den Garten

Dr. Seltsam

Im Forum Zuhause

  • "Dr. Seltsam" started this thread

Posts: 9,931

Location: 3. Planet des Sonnensystems

Occupation: Organisator

  • Send private message

4

Saturday, July 9th 2005, 10:18pm

RE: [linVDR-package]: dxr3 für LinVDR 0.7 !

die Reihenfolge sollte völlig egal sein, da nichts überschrieben wird. Nur die Anpassung in der rcStart sollte als letztes gemacht werden, da MT glaube ich seine eigene rcStart mitbringt.

Wenn ein MT-Patch installiert wird, dann muss es der vom 18.5. sein. das ist die einzige Einschränkung. Für vdr 1.3.23 aus einem älteren MT-Patch habe ich kein Plugin kompiliert.

ich habe mich bemüht, es so einfach und komfortabel wie möglich für einen möglichst breiten Kreis an LinVDR-User zu machen. :)
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

Dr. Seltsam

Im Forum Zuhause

  • "Dr. Seltsam" started this thread

Posts: 9,931

Location: 3. Planet des Sonnensystems

Occupation: Organisator

  • Send private message

5

Saturday, July 9th 2005, 11:43pm

RE: [linVDR-package]: dxr3 für LinVDR 0.7 !

Quoted

Original von Uatschitchun

Wie schauts mit der Stabilität?


wenn das Signal sauber ist (guter Empfang) wird schnell und sauber umgeschaltet. Danach läuft es stundenlang stabil. Wer viel zappt und auch mal schlechten Empfang hat, wird vielleicht manchmal erleben, dass der Buffer vollläuft und das Bild zu ruckeln anfängt. Das sollte sich aber nach ein paar Sekunden wieder geben.

Ich bin noch am Experimentieren, ob man die buffereserve (defaultmäßig in transfer.c definiert) braucht, oder ob sie für den Betrieb mit einer dxr3 eher stört. Bei der 1.3.17 gab es sie glaube ich noch nicht -vielleicht läuft es daher damit besser als mit 1.3.24/1.3.27. Was nicht heißen soll, das es mit denen schlecht läuft.

Ich hoffe, dass möglichst viele dxr3-Bastler Feedback geben. Die Installation ist ja sehr einfach, das sollte einen Test wert sein. Es gab doch so viele Threads mit Leidensgeschichten in den letzten Wochen.
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

Posts: 4,478

Location: nahe Eschwege/Göttingen

Occupation: Linux-Redakteur

  • Send private message

6

Sunday, July 10th 2005, 1:55am

RE: [linVDR-package]: dxr3 für LinVDR 0.7 !

Jepp, es wäre sehr gut, ein paar Erfahrungsberichte zur Stabilität zu bekommen. Würde auch mich sehr interessieren.

@Dr. Seltsam:
Gibt's beim compilieren irgend was besonderes zu beachten? Irgend welche Stolperfallen?

Ansonsten könntest du ne DXR-3 mit BT865 von mir bekommen, falls du Testmaterial brauchst.

Viele Grüße, Mirko

Dr. Seltsam

Im Forum Zuhause

  • "Dr. Seltsam" started this thread

Posts: 9,931

Location: 3. Planet des Sonnensystems

Occupation: Organisator

  • Send private message

7

Sunday, July 10th 2005, 10:43am

RE: [linVDR-package]: dxr3 für LinVDR 0.7 !

Quoted

Original von cooper
@Dr. Seltsam:
Gibt's beim compilieren irgend was besonderes zu beachten? Irgend welche Stolperfallen?

Zu meinem großen Erstaunen flutsche alles einwandfrei durch den compiler ohne händische Anpassungen. Ich glaube ich habe nur die em8300.h einmal in /usr/include/linux kopiert, weil woody keinen Header mitbrachte. ist nicht ganz sauber, aber so erspare ich mir Anpassungen des Makefiles. Das gleiche habe ich glaube ich mit /usr/include/linux/dvb gemacht. Da liegen jetzt die Header aus dem linuxtv-Treiber drin.

Für die Erstellung der devices habe ich das devices.sh-Script aus dem modules-Ordner etwas anpassen müssen, da es devfs zu erkennen glaubte und nicht tätig werden wollte.

Quoted

Ansonsten könntest du ne DXR-3 mit BT865 von mir bekommen, falls du Testmaterial brauchst.

danke, aber ich fürchte mir fehlt da die Zeit... ich hab aber mal gegoogelt. Es gibt gar keine Moduloptionen für bt865. Wenn man eine bt865 hat, kommen nur zwei ergänzende Optionen für das Laden der em8300 in Frage:

Quoted

Options for the EM8300 module

dicom_other_pal 0 or 1
If this is set, then some internal register values are swapped for PAL and NTSC. Defaults to 1.

dicom_fix 0 or 1
If this is set then some internal register values are changed. Fixes green screen problems for some. Defaults to 1.

dicom_control 0 or 1
If this is set then some internal register values are changed. Fixes green screen problems for some. Defaults to 1.

activate_loopback 0 or 1
If you lose video after loading the modules or uploading the microcode set this to 1. See the VGA Overlay section below for more details. Defaults to 0.

bt865_ucode_timeout 0 or 1
Set this to 1 if you have a bt865 and get timeouts when uploading the microcode. Defaults to 0.

use_bt865 0 or 1
Set this to 1 if you have a bt865. It changes some internal register values. Defaults to 0.

Kannst es ja mal probieren... es müsste wohl eine der folgenden Kombinationen funktionieren, evtl. noch ergänzt um die timeout-Option:

Source code

1
2
3
4
5
6
7
8
9
10
11
modprobe bt865
modprobe em8300 dicom_fix=1 dicom_control=1 dicom_other_pal=0 use_bt865=1

modprobe bt865
modprobe em8300 dicom_fix=1 dicom_control=1 dicom_other_pal=1 use_bt865=1

modprobe bt865
modprobe em8300 dicom_fix=1 dicom_control=1 dicom_other_pal=1 use_bt865=1

modprobe bt865
modprobe em8300 dicom_fix=0 dicom_control=0 dicom_other_pal=0 use_bt865=1

Gruß
Dr. Seltsam
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

8

Sunday, July 10th 2005, 11:58am

hi,
da ich alles was mit einer DXR3 zu tun hat immer dabei bin,muste ich es sofort ausprobieren,aber es läuft nicht ;(
hier mal logread:
Jul 10 11:52:39 linvdr user.info vdr[2041]: loading plugin: /usr/lib/vdr/plugins /libvdr-streamdev-client.so.1.3.27
Jul 10 11:52:39 linvdr user.info vdr[2041]: loading /etc/vdr/setup.conf
Jul 10 11:52:39 linvdr user.info vdr[2041]: loading /etc/vdr/sources.conf
Jul 10 11:52:39 linvdr user.info vdr[2041]: loading /etc/vdr/diseqc.conf
Jul 10 11:52:39 linvdr user.info vdr[2041]: loading /etc/vdr/channels.conf
Jul 10 11:52:39 linvdr user.info vdr[2041]: loading /etc/vdr/commands.conf
Jul 10 11:52:39 linvdr user.info vdr[2041]: loading /etc/vdr/reccmds.conf
Jul 10 11:52:39 linvdr user.info vdr[2041]: loading /etc/vdr/svdrphosts.conf
Jul 10 11:52:39 linvdr user.info vdr[2041]: loading /etc/vdr/ca.conf
Jul 10 11:52:39 linvdr user.info vdr[2041]: loading /etc/vdr/remote.conf
Jul 10 11:52:39 linvdr user.info vdr[2041]: loading /etc/vdr/keymacros.conf
Jul 10 11:52:39 linvdr user.debug vdr[2041]: probing /dev/dvb/adapter0/frontend0
Jul 10 11:52:39 linvdr user.info vdr[2041]: no DVB device found
Jul 10 11:52:39 linvdr user.info vdr[2041]: initializing plugin: dxr3 (0.2.3-cvs ): Hardware MPEG decoder
Jul 10 11:52:39 linvdr user.err vdr[2041]: dxr3: unable to open /dev/em8300-0: N o such device
Jul 10 11:52:39 linvdr user.err vdr[2041]: dxr3: please verify that the em8300 m odules are loaded


Hat da einer eine Idee?
gruß
dejuh
Server-3000-AMD-64bit-1536mbRam- Suse-10.0-DHCP-TFTP-PHP-Apache-VDR-1.3.43-2x DVB-S-TT-1.3 und 2x NOVA-S-250GB-250GB für Video
Bose-Zenega-Xine

Client mit Epia-DXR3-Lüfterlos und Linvdr mit vdr-1.3.27
DVD-Wechsler ......zu sehen auf meiner HP
VDR-Touch-Control mit DXR3 und Linvdr-1.3.27
2x Mediamvp

Dr. Seltsam

Im Forum Zuhause

  • "Dr. Seltsam" started this thread

Posts: 9,931

Location: 3. Planet des Sonnensystems

Occupation: Organisator

  • Send private message

9

Sunday, July 10th 2005, 12:01pm

hast Du die rcStart angepasst, so dass die Treiber geladen werden? zeigt lsmod an, dass em8300 und adv717x geladen sind ?
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

10

Sunday, July 10th 2005, 12:04pm

Quoted

Original von Dr. Seltsam
hast Du die rcStart angepasst, so dass die Treiber geladen werden? zeigt lsmod an, dass em8300 und adv717x geladen sind ?

Ja habe ich angepast
lsmod:


budget_core 9604 3 budget_av,budget_ci,budget
dvb_ttpci 84000 0
tda8083 6276 2 budget,dvb_ttpci
stv0297 7936 1 dvb_ttpci
sp8870 7300 1 dvb_ttpci
firmware_class 9984 4 budget_av,budget_ci,dvb_ttpci,sp8870
ttpci_eeprom 3072 2 budget_core,dvb_ttpci
saa7146_vv 46336 2 budget_av,dvb_ttpci
saa7146 18588 6 budget_av,budget_ci,budget,budget_core,dvb_ttpci,saa7146_vv
mt312 7812 1 skystar2
cx24110 7556 0
tda1004x 12036 2 budget_av,budget_ci
ves1820 6148 2 budget,dvb_ttpci
stv0299 9604 5 skystar2,budget_av,budget_ci,budget,dvb_ttpci
ves1x93 6784 2 budget,dvb_ttpci
dvb_core 80296 6 skystar2,budget_av,budget_ci,budget,budget_core,dvb_ttpci
video_buf 21248 1 saa7146_vv
v4l2_common 6528 1 saa7146_vv
v4l1_compat 14080 1 saa7146_vv
videodev 10240 1 saa7146_vv
evdev 9600 0
lirc_dev 14208 2 lirc_serial
via_rhine 20612 0
mii 5248 1 via_rhine
em8300 65924 0
adv717x 6784 0
i2c_algo_bit 9736 1 em8300
i2c_core 23296 21 skystar2,mt352,budget_av,tda10021,budget_ci,budget,l64781,budget_core,dvb_ttpci,tda8083,stv0297,sp8870,ttpci_eeprom,mt312,cx24110,tda1004x,ves1820,stv0299,ves1x93,adv717x,i2c_algo_bit
snd_via82xx 26016 0
snd_ac97_codec 64480 1 snd_via82xx
snd_pcm 91776 1 snd_via82xx
snd_timer 24576 1 snd_pcm
snd_page_alloc 10376 2 snd_via82xx,snd_pcm
gameport 4992 1 snd_via82xx
snd_mpu401_uart 7680 1 snd_via82xx
snd_rawmidi 24096 1 snd_mpu401_uart
snd_seq_device 8324 1 snd_rawmidi
snd 54432 7 snd_via82xx,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore 10464 2 em8300,snd
ehci_hcd 28032 0
uhci_hcd 30600 0
ohci_hcd 20480 0
cdfs 30496 0
Server-3000-AMD-64bit-1536mbRam- Suse-10.0-DHCP-TFTP-PHP-Apache-VDR-1.3.43-2x DVB-S-TT-1.3 und 2x NOVA-S-250GB-250GB für Video
Bose-Zenega-Xine

Client mit Epia-DXR3-Lüfterlos und Linvdr mit vdr-1.3.27
DVD-Wechsler ......zu sehen auf meiner HP
VDR-Touch-Control mit DXR3 und Linvdr-1.3.27
2x Mediamvp

Dr. Seltsam

Im Forum Zuhause

  • "Dr. Seltsam" started this thread

Posts: 9,931

Location: 3. Planet des Sonnensystems

Occupation: Organisator

  • Send private message

11

Sunday, July 10th 2005, 12:13pm

schau bitte mal nach, ob /dev/em8300-0 existiert.

Welche 0.7 hast Du genau? nackt oder mit Patches? der Kernel ist 2.6.9 ?

gibt`s im Log noch mehr zu em8300? Noch bevor vdr + die plugins geladen werden ?
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

12

Sunday, July 10th 2005, 12:34pm

Quoted

Original von Dr. Seltsam
schau bitte mal nach, ob /dev/em8300-0 existiert.


Ja existiert

Quoted

Original von Dr. Seltsam
Welche 0.7 hast Du genau? nackt oder mit Patches? der Kernel ist 2.6.9 ?


Orginal nur da läuft streamdev-client nicht?
Update auf vdr-1.3.27

Quoted

Original von Dr. Seltsam
gibt`s im Log noch mehr zu em8300? Noch bevor vdr + die plugins geladen werden ?


Jul 10 12:30:44 linvdr user.warn kernel: saa7146: register extension 'dvb'.
Jul 10 12:30:44 linvdr user.warn kernel: saa7146: register extension 'budget dvb'.
Jul 10 12:30:44 linvdr user.warn kernel: saa7146: register extension 'budget_ci dvb'.
Jul 10 12:30:44 linvdr user.warn kernel: saa7146: register extension 'budget dvb /w video in'.
Jul 10 12:30:45 linvdr user.info kernel: lirc_serial: auto-detected active low receiver
Jul 10 12:30:45 linvdr user.warn kernel: lirc_dev: lirc_register_plugin:sample_rate: 0
Jul 10 12:30:45 linvdr daemon.notice lircd 0.7.0pre4[6333]: lircd(serial) ready
Jul 10 12:30:45 linvdr user.info vdr[6353]: VDR version 1.3.27 started
Jul 10 12:30:45 linvdr user.info vdr[6353]: Bigpatch 26.06.2005 is active!
Jul 10 12:30:45 linvdr user.info vdr[6353]: loading plugin: /usr/lib/vdr/plugins/libvdr-dxr3.so.1.3.27
Jul 10 12:30:45 linvdr user.info vdr[6353]: loading plugin: /usr/lib/vdr/plugins/libvdr-streamdev-client.so.1.3.27
Jul 10 12:30:45 linvdr user.info vdr[6353]: loading /etc/vdr/setup.conf
Jul 10 12:30:45 linvdr user.info vdr[6353]: loading /etc/vdr/sources.conf
Jul 10 12:30:45 linvdr user.info vdr[6353]: loading /etc/vdr/diseqc.conf
Jul 10 12:30:45 linvdr user.info vdr[6353]: loading /etc/vdr/channels.conf
Jul 10 12:30:45 linvdr user.info vdr[6353]: loading /etc/vdr/commands.conf
Jul 10 12:30:45 linvdr user.info vdr[6353]: loading /etc/vdr/reccmds.conf
Jul 10 12:30:45 linvdr user.info vdr[6353]: loading /etc/vdr/svdrphosts.conf
Jul 10 12:30:45 linvdr user.info vdr[6353]: loading /etc/vdr/ca.conf
Jul 10 12:30:45 linvdr user.info vdr[6353]: loading /etc/vdr/remote.conf
Jul 10 12:30:45 linvdr user.info vdr[6353]: loading /etc/vdr/keymacros.conf
Jul 10 12:30:45 linvdr user.debug vdr[6353]: probing /dev/dvb/adapter0/frontend0
Jul 10 12:30:45 linvdr user.info vdr[6353]: no DVB device found
Jul 10 12:30:45 linvdr user.info vdr[6353]: initializing plugin: dxr3 (0.2.3-cvs): Hardware MPEG decoder
Jul 10 12:30:45 linvdr user.err vdr[6353]: dxr3: unable to open /dev/em8300-0: No such device
Jul 10 12:30:45 linvdr user.err vdr[6353]: dxr3: please verify that the em8300 modules are loaded
Server-3000-AMD-64bit-1536mbRam- Suse-10.0-DHCP-TFTP-PHP-Apache-VDR-1.3.43-2x DVB-S-TT-1.3 und 2x NOVA-S-250GB-250GB für Video
Bose-Zenega-Xine

Client mit Epia-DXR3-Lüfterlos und Linvdr mit vdr-1.3.27
DVD-Wechsler ......zu sehen auf meiner HP
VDR-Touch-Control mit DXR3 und Linvdr-1.3.27
2x Mediamvp

13

Sunday, July 10th 2005, 12:35pm

Da ich auf diesem Rechner die Karte unter eis auch nicht ans laufen bekommen habe,dort aber immer Linvdr-0.5 lief,weiß ich nicht woran es liegt.
Wie sehe ich ob die DXR3 auch richtig erkannt wurde?
gruß
Dejuh
Server-3000-AMD-64bit-1536mbRam- Suse-10.0-DHCP-TFTP-PHP-Apache-VDR-1.3.43-2x DVB-S-TT-1.3 und 2x NOVA-S-250GB-250GB für Video
Bose-Zenega-Xine

Client mit Epia-DXR3-Lüfterlos und Linvdr mit vdr-1.3.27
DVD-Wechsler ......zu sehen auf meiner HP
VDR-Touch-Control mit DXR3 und Linvdr-1.3.27
2x Mediamvp

This post has been edited 1 times, last edit by "Dejuh" (Jul 10th 2005, 12:45pm)


Dr. Seltsam

Im Forum Zuhause

  • "Dr. Seltsam" started this thread

Posts: 9,931

Location: 3. Planet des Sonnensystems

Occupation: Organisator

  • Send private message

14

Sunday, July 10th 2005, 12:43pm

sehr merkwürdig. Treiber und Plugin werden geladen. Nur dass die Treiber von keinem Gerät genutzt werden, weil keine Karte erkannt wird. Die devices sind aber richtig angelegt, so das ich jetzt normalerweise als nächstes fragen würde, ob die Karte drin steckt bzw. richtig sitzt. Steck sie doch mal in einen anderen Slot.

:idee
Hat die Karte evtl. statt eines adv717x-Chips einen bt865? Dann musst du den noch laden, wie weiter oben beschrieben.
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

15

Sunday, July 10th 2005, 12:47pm

Quoted

Original von Dr. Seltsam
sehr merkwürdig. Treiber und Plugin werden geladen. Nur dass die Treiber von keinem Gerät genutzt werden, weil keine Karte erkannt wird. Die devices sind aber richtig angelegt, so das ich jetzt normalerweise als nächstes fragen würde, ob die Karte drin steckt bzw. richtig sitzt. Steck sie doch mal in einen anderen Slot.

:idee
Hat die Karte evtl. statt eines adv717x-Chips einen bt865? Dann musst du den noch laden, wie weiter oben beschrieben.


Hatte schon gepostet!!!
Hat adv717.....,habe ein Epia-Boerd mit nur einem PCI-Slot
Dejuh
Server-3000-AMD-64bit-1536mbRam- Suse-10.0-DHCP-TFTP-PHP-Apache-VDR-1.3.43-2x DVB-S-TT-1.3 und 2x NOVA-S-250GB-250GB für Video
Bose-Zenega-Xine

Client mit Epia-DXR3-Lüfterlos und Linvdr mit vdr-1.3.27
DVD-Wechsler ......zu sehen auf meiner HP
VDR-Touch-Control mit DXR3 und Linvdr-1.3.27
2x Mediamvp

Dr. Seltsam

Im Forum Zuhause

  • "Dr. Seltsam" started this thread

Posts: 9,931

Location: 3. Planet des Sonnensystems

Occupation: Organisator

  • Send private message

16

Sunday, July 10th 2005, 1:01pm

steckt die Karte in einer Riser-Card?
wann/wo lief die Karte zuletzt?

em8300 65924 0
adv717x 6784 0

Die Null zeigt an, dass das Modul von keinem Gerät oder einem anderen Modul benutzt wird.

Jul 10 12:30:45 linvdr user.err vdr[6353]: dxr3: unable to open /dev/em8300-0: No such device
Jul 10 12:30:45 linvdr user.err vdr[6353]: dxr3: please verify that the em8300 modules are loaded

zeigt ganz klar, dass entweder keine Karte vorhanden ist, oder die Treiber für diese Karte nicht geladen wurden (was aber der Fall ist). Oder dass das device /dev/em8300-0 nicht existiert, aber es ist im tarball ja drin und Du hast ja auch in /dev nachgesehen.

Sorry, da gehen mir die ideen aus :(
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

17

Sunday, July 10th 2005, 1:05pm

Quoted

Original von Dr. Seltsam
steckt die Karte in einer Riser-Card?
wann/wo lief die Karte zuletzt?
(


Hatte sie vor 4 Tagen noch mit Linvdr-0.5 laufen,habe aber auch das Gefühl das sie nicht da ist,PCI-Slot kaputt?
gruß
Dejuh
Server-3000-AMD-64bit-1536mbRam- Suse-10.0-DHCP-TFTP-PHP-Apache-VDR-1.3.43-2x DVB-S-TT-1.3 und 2x NOVA-S-250GB-250GB für Video
Bose-Zenega-Xine

Client mit Epia-DXR3-Lüfterlos und Linvdr mit vdr-1.3.27
DVD-Wechsler ......zu sehen auf meiner HP
VDR-Touch-Control mit DXR3 und Linvdr-1.3.27
2x Mediamvp

Dr. Seltsam

Im Forum Zuhause

  • "Dr. Seltsam" started this thread

Posts: 9,931

Location: 3. Planet des Sonnensystems

Occupation: Organisator

  • Send private message

18

Sunday, July 10th 2005, 1:08pm

was sagt

Source code

1
lspci
?
wird die Karte da aufgeführt?
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

19

Sunday, July 10th 2005, 1:27pm

Quoted

Original von Dr. Seltsam
was sagt

Source code

1
lspci
?
wird die Karte da aufgeführt?



linvdr:~# lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8601 [Apollo ProMedia] (rev 05)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8601 [Apollo ProMedia AGP]
00:11.0 ISA bridge: VIA Technologies, Inc. VT8231 [PCI-to-ISA Bridge] (rev 10)
00:11.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 06)
00:11.2 USB Controller: VIA Technologies, Inc. UHCI USB (rev 1e)
00:11.3 USB Controller: VIA Technologies, Inc. UHCI USB (rev 1e)
00:11.4 Bridge: VIA Technologies, Inc. VT8235 Power Management (rev 10)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. AC97 Audio Controller (rev 40)
00:12.0 Ethernet controller: VIA Technologies, Inc. Ethernet Controller (rev 51)
00:14.0 Multimedia controller: RasterOps Corp.: Unknown device 8300
01:00.0 VGA compatible controller: Trident Microsystems CyberBlade/i1 (rev 6a)

Ich glaube ich habe ein Problem
Server-3000-AMD-64bit-1536mbRam- Suse-10.0-DHCP-TFTP-PHP-Apache-VDR-1.3.43-2x DVB-S-TT-1.3 und 2x NOVA-S-250GB-250GB für Video
Bose-Zenega-Xine

Client mit Epia-DXR3-Lüfterlos und Linvdr mit vdr-1.3.27
DVD-Wechsler ......zu sehen auf meiner HP
VDR-Touch-Control mit DXR3 und Linvdr-1.3.27
2x Mediamvp

This post has been edited 1 times, last edit by "Dejuh" (Jul 10th 2005, 1:28pm)


Dr. Seltsam

Im Forum Zuhause

  • "Dr. Seltsam" started this thread

Posts: 9,931

Location: 3. Planet des Sonnensystems

Occupation: Organisator

  • Send private message

20

Sunday, July 10th 2005, 1:52pm

Quoted

Original von Dejuh
[
00:14.0 Multimedia controller: RasterOps Corp.: Unknown device 8300

Ich glaube ich habe ein Problem


fürchte ich leider auch. Bei mir steht da

00:0a.0 Multimedia controller: Sigma Designs, Inc. REALmagic Hollywood Plus DVD Decoder (rev 02)
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD