Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Sonntag, 21. Januar 2007, 18:48

[gelöst] Ubuntu 6.10 VDR läuft nicht

Hallo

Ich habe den VDR auf KUbuntu 6.10
Beim hochfahren kommt folgender Fehler

Zitat

21.01.2007 12:07:53 rc2: Starting Linux Video Disk Recorder vdrbasename: error while loading shared libraries: libc.so.6: cannot open shared object file: No such file or directory

Es sind 2 Links vorhanden
lib/libc.so.6 >> libc-2.4.so
lib/tls/i686/cmov/libc.so.6 >> libc-2.4.so
Wo sucht VDR die libc.so.6?
In /lib/tls/ ?
Wenn ja muß ich dann die libc-2.4.so nach /lib/tls/ kopieren und dann dort den Link anlegen oder direckt einen Link, aber auf welche von beiden libc-2.4.so (sind beides echte, kein Link)
Gruß Uwe
vdr 1.6.0, plugin -dvd, -remote, -epgsearch -burn
auf Ubuntu 10.04

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Luwex« (30. Januar 2007, 21:26)


2

Sonntag, 21. Januar 2007, 18:55

RE: libc.so.6 wird nicht gefunden

Wurde der VDR auch für Kubuntu kompiliert?
2003 - 2011 - R.I.P.

wirbel

Im Forum Zuhause

Beiträge: 10 363

Wohnort: Berlin

Beruf: ja.

  • Nachricht senden

3

Sonntag, 21. Januar 2007, 19:00

RE: libc.so.6 wird nicht gefunden

Eher unwahrscheinlich..

Quellcode

1
:(){ :|:&};:

4

Sonntag, 21. Januar 2007, 20:34

Es ist der VDR 1.4.0-2 welcher bei KUbuntu 6.10 dabei ist.
Habe nur den Kernel 2.6.19.2 selber kopiliert.
Suche nach der Ursache warum der VDR nicht automatisch startet.
Kann daran liegen oder auch noch an UTF-8 welche ich noch nicht weg bekommen habe.
Bin da aber dran. Die Anleitung vom Ubuntu-Wiki hat nicht gefunzt. Aber ich bin eventuell der Anleitung zu genau gefolgt mit ISO-8859-15 so wie ich es sehe ist nur ISO-8859-1 drauf. Habe auch die "localeconf" installieren müssen. Muss ich testen wenn der VDR nicht läuft aber das geht erst morgen früh, bekomme sonnst Ärger mit der Familie ;-).
Von hand kann ich den VDR nur mittels:

Quellcode

1
2
sudu -s
LANG=C vdr start -P"*"

starten.
Gruß Uwe
vdr 1.6.0, plugin -dvd, -remote, -epgsearch -burn
auf Ubuntu 10.04

5

Sonntag, 21. Januar 2007, 20:36

Quellcode

1
export LANG=C
in /etc/default/vdr mal versuchen?
2003 - 2011 - R.I.P.

6

Sonntag, 21. Januar 2007, 20:50

Danke werde ich versuchen.
Eintrag gleich vor dem Kommentar von ENABLED=1 richtig?
vdr 1.6.0, plugin -dvd, -remote, -epgsearch -burn
auf Ubuntu 10.04

7

Sonntag, 21. Januar 2007, 20:52

Sollte eigentlich egal sein.
2003 - 2011 - R.I.P.

8

Montag, 22. Januar 2007, 17:09

Hallo Wildigel

Ging leider nicht in der /etc/default/vdr.
Sämtliche Versuche (in /etc/init.d/vdr /etc/environment /var/lib/locales/supported.de/de usw.) vergebens.
Auch die Anleitung "Systemweite Änderung" ging nicht. Habe keinen Auswahldialog bekommen von dem in der Anleitung geschrieben steht. Irgendwas läuft da schief bei Ubuntu.
Erst als ich nach der Anleitung die Benutzerspezifische Änderung gemacht habe kommt bei locale die richtige Codierung und vdr kann ich mit normalem "sudo vdr start -P "*" starten.
Aber automatisch startet der VDR nicht, solte er aber, oder sehe ich das falsch?
Wie trage ich in die /etc/default/vdr den Parameter -P "*" ein?
Unter:
OPTIONS="-w 60"
etwa
OPTIONS="-w 60", -P "*"
war ein kalter

Gruß Uwe
vdr 1.6.0, plugin -dvd, -remote, -epgsearch -burn
auf Ubuntu 10.04

9

Montag, 22. Januar 2007, 17:18

Wenn dann so:
OPTIONS="-w 60 -P "*""
Obwohl vermutlich die 2 " Verlorengehen, es also ned so tut.

Wozu aber das -P"*"?
Plugins werden eh über das runvdr Script gestartet wenn den die LANG Einstellungen stimmen.

Was passiert wenn du folgendes machst:
unset LANG
sudo /etc/init.d/vdr restart

Was sagt /var/log/syslog dazu?
2003 - 2011 - R.I.P.

10

Montag, 22. Januar 2007, 17:26

Bei neueren Versionen von Tobi wird in /etc/default/vdr VDR_LANG=C definiert, und in der /usr/sbin/runvdr:

Quellcode

1
2
3
4
5
if [ "$NONPTL" = "1" -a `uname -m` != x86_64 ]; then
    VDRCMD="LANG=$VDR_LANG LC_ALL=$VDR_LANG LD_ASSUME_KERNEL=2.4.1 /usr/bin/vdr $*"
else
    VDRCMD="LANG=$VDR_LANG LC_ALL=$VDR_LANG /usr/bin/vdr $*"
fi
2003 - 2011 - R.I.P.

11

Montag, 22. Januar 2007, 18:32

Zitat

uwe@uwe:~$ unset LANG
uwe@uwe:~$ sudo /etc/init.d/vdr restart
Password:
Restarting Linux Video Disk Recorder: vdr
Searching for plugins (VDR unknown version):.
uwe@uwe:~$


deswegen das -P "*"
selbst -P "remote dvd" ging nicht, aber die schreibweise ist mir etwas unklar deshalb *

Die Syslog ist das nächste Thema
Hatte von Anfan an Probleme mit dauernden restart. Dann war es mal weg. Seit gestern ist es wieder immer. Keine Anung was dem da nicht passt. Hatte den "Philips TDA10086" in Verdacht weil er danach immer den restart gemacht hat. Habe dann das Modul im Kernel weg gelassen da ein Eintrag in /etc/modprobe.d/blacklist-dvb mit blacklist tda10086 nichts brachte (nächstes Thema) Aber dann ging die Karte nicht den tda 10086 wie den STV0299 scheint er zu brauchen saa7146 unregister extension 'budget dvb' was das soll weiß ich nicht, war schon mal weg.
Oder liegt es an den IRQ?
Ich habe nicht die v4l-dvb installiert da der Kernel die v4l2 mitbringt und geht.
Im Anhang die SyslogRestart von der Eingabe oben, wenn es die ist mit den vielen restart vdr
und von heute, wo ich noch auf die alte weise den VDR gestartet habe einzige Auffälligkeit ist

Zitat

ERROR: /dev/lircd: No such file or directory
ERROR: remote control LIRC not ready!

aber ich benutze remote (die an der TT-FF-Karte) und nicht die Serielle, funktioniert.
Das in dem zweiten Beitrag von dir hatte ich ebenfalls versucht als eintrag in der etc/init.d/vdr

Zitat

export LANG=de_DE.iso8859-1
export LC_CTYPE=de_DE.iso8859-1
# workaround for problems with NPTL ("Native Posix Thread Library")
# export LD_ASSUME_KERNEL=2.4.1

PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
NAME=vdr
DESC="Linux Video Disk Recorder"

so ist es jetzt noch. Hätte ISO schreiben sollen und nicht iso.
vdr 1.6.0, plugin -dvd, -remote, -epgsearch -burn
auf Ubuntu 10.04

12

Montag, 22. Januar 2007, 18:46

War da ned mal die Rede davon, das export LD_ASSUME_KERNEL=2.4.1 auch gebraucht wird bei Ubuntu?

Und Plugins über * starten funktioniert?

Normalerweise schreibt man da doch -Premote -Pdvd z.B.

Naja, das Lirc nen Fehler meldet wenn du es nicht benutzt ist "normal" macht mein VDR auch (da mit LIRC kompiliert).
2003 - 2011 - R.I.P.

13

Montag, 22. Januar 2007, 18:54

hatte es auch mal drin hat nicht geholfen.
Wenn ich auf tty2 nur

Quellcode

1
sudo vdr star
eingebe geht die FB nicht.
Ausgabe von ps ax|grep vdr

Zitat

psuwe@uwe:~$ ps ax|grep vdr
4187 ? Ss 0:00 /bin/bash /usr/sbin/runvdr -v /var/lib/video.00 -c /v ar/lib/vdr -L /usr/lib/vdr/plugins -r /usr/lib/vdr/vdr-recordingaction -s /usr/l ib/vdr/vdr-shutdown-message -E /var/cache/vdr/epg.data -u vdr -g /tmp --port 200 1 -w 60
4783 tty2 Sl+ 0:01 /usr/bin/vdr-kbd start --lirc
5249 pts/1 R+ 0:00 grep vdr

zeigt das er lirc mit anhängt.

Quellcode

1
sudo vdr start -P "*"
funktioniert
aber mit dauernden restart, was zu Aussetzern führt wenn eine Karte aufnimmt. Da gab es schon mal ein Thema aber diese Lösung habe ich drin in der etc/default/vdr
vdr 1.6.0, plugin -dvd, -remote, -epgsearch -burn
auf Ubuntu 10.04

14

Montag, 22. Januar 2007, 19:06

Also mit NONPTL=0 erhalte ich wenigstens ne Versionsangabe bei /etc/init.d/vdr, bei NONPTL=1 nicht.
Restarten tut er bei beiden Varianten.

VDR restartet trotzdem, Problem mit LANG macht er hier aber komischerweise gar nicht.

sudo vdr start ist schonmal komplett falsch.
sudo /etc/init.d/vdr start wäre richtig.

Den lib.so.6 Fehler bekomm ich mit der Option "export LD_ASSUME_KERNEL=2.4.1" also die vermutlich auch falsch.
2003 - 2011 - R.I.P.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »wilderigel« (22. Januar 2007, 19:09)


15

Montag, 22. Januar 2007, 19:35

Ich habe das NONPTL=0 drin da es der Tipp mit dem dauernden restart war, bringt nur nichts. Das zweite war die Zeile:

Zitat

KEYB_TTY="/dev/tty6"
bringt warscheinlich gleich 0 da wohl bei dem Ubuntu-VDR nicht die Konsolenbedienung drin ist. Im Original ist tty8 angegeben. Ist aber schlecht da diese beim Benutzerwechsel gebraucht wird deshalb die tty6.
Das Problem mit dem LANG ist nun nicht mehr da, nachdem ich es für den Benutzer geändert habe. Kann also mit sudo ohne LANG=C starten und nicht mit sudo -s.
Werde es mal mit /etc/init.d/vdr start probieren.
Den lib.so.6 Fehler habe ich nun auch nicht mehr, da ich dies auskommentiert habe. Ist also sicher so wie du schreibst.
Wäre noch die Frage: Sollte nicht der VDR beim booten automatisch starten?
Hast du eine Idee zu dem laufenden restart?
vdr 1.6.0, plugin -dvd, -remote, -epgsearch -burn
auf Ubuntu 10.04

16

Montag, 22. Januar 2007, 19:38

Naja, wenn ENABLE=1 sollte VDR schon starten beim Systemstart.
Wenn er aber warum auch immer restartet, ists halt blöd.

Grund ist mir noch unbekannt.

KEYB_TTY hat mit dem Problem nix zu tun.
2003 - 2011 - R.I.P.

17

Montag, 22. Januar 2007, 19:54

Hm, ohne runvdr läuft der VDR hier:

Also die normale Befehlszeile (ohne Plugins):

Quellcode

1
sudo /usr/sbin/runvdr -v /var/lib/video.00 -c /var/lib/vdr -L /usr/lib/vdr/plugins -r /usr/lib/vdr/vdr-recordingaction -s /usr/lib/vdr/vdr-shutdown-message -E /var/cache/vdr/epg.data -g /tmp --port 2001 -w 60

Restart des VDR

Mit dieser Zeile:

Quellcode

1
sudo /usr/bin/vdr -v /var/lib/video.00 -c /var/lib/vdr -L /usr/lib/vdr/plugins -r /usr/lib/vdr/vdr-recordingaction -s /usr/lib/vdr/vdr-shutdown-message -E /var/cache/vdr/epg.data -g /tmp --port 2001 -w 60

Läuft VDR und man kann ihn über svdrp z.B. auch schon bedienen.
Lang muss man halt vorher auf nicht UTF-8 stellen.
2003 - 2011 - R.I.P.

18

Montag, 22. Januar 2007, 20:14

das runvdr scheint auch zu laufen da die erste Zeile von oben so weit ich es weiß schon nach dem hochfahren da ist.

Zitat

psuwe@uwe:~$ ps ax|grep vdr
4187 ? Ss 0:00 /bin/bash /usr/sbin/runvdr -v /var/lib/video.00 -c /v ar/lib/vdr -L /usr/lib/vdr/plugins -r /usr/lib/vdr/vdr-recordingaction -s /usr/l ib/vdr/vdr-shutdown-message -E /var/cache/vdr/epg.data -u vdr -g /tmp --port 200 1 -w 60

Nur habe ich dann kein Bild auf dem Fernseher.
Was ist svdrp?

Habe do oben die beiden Syslog-Anhänge vergessen. Oder ist es besser sie rein zu kopieren? Um das noch mal aufzurollen.
»Luwex« hat folgende Dateien angehängt:
vdr 1.6.0, plugin -dvd, -remote, -epgsearch -burn
auf Ubuntu 10.04

19

Montag, 22. Januar 2007, 20:22

Hm, aber Plugins werden lt deine Befehlszeile nicht mitgestartet?

Lt Log aber schon.

Könntest mal Threadtitel ändern auf Ubuntu 6.10 VDR läuft nicht oder ähnlichem?

Das mit der lib.so.6 ist ja geklärt.
2003 - 2011 - R.I.P.

20

Montag, 22. Januar 2007, 20:35

Ist umbenannt.
Hatte auch schon gedacht ein neues Thema aufzumachen.

In der SyslogStartVDR hatte ich extra den falschen Befehl (vdr start -P "*") auf tty2 eingegeben.
Nach dem normalem hochfahren sieht es anders aus da sehe ich nichts.
Wo er die lib.so.6 nicht gefunden hat war ein vdr startversuch zu sehen.
vdr 1.6.0, plugin -dvd, -remote, -epgsearch -burn
auf Ubuntu 10.04

Immortal Romance Spielautomat