Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

  • »miraculix025« ist der Autor dieses Themas

Beiträge: 112

Wohnort: Wettringen

Beruf: Apotheker

  • Nachricht senden

1

Donnerstag, 8. Oktober 2009, 19:58

vdr-plugin-imonlcd

Hi,

danke an Tobi für das Bereitstellen des imonlcd plugins.

Trotz Studium des readme weiss ich nicht, wie ich es konfiguriere, muss ich die lirc Installation noch anpassen?

Weiss jemand wie es nach apt-get install vdr-plugin-imonlcd weitergeht?

Grüße aus dem Münsterland
Andreas

2

Samstag, 10. Oktober 2009, 09:47

vielleicht hilft das weiter:
http://www.vdrportal.de/board/thread.php…9983#post819983

(rechteproblem lcd0)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »hotzenplotz5« (10. Oktober 2009, 09:48)


ramon.serrano

Fortgeschrittener

Beiträge: 219

Wohnort: nicht aus Hannover

  • Nachricht senden

3

Montag, 12. Oktober 2009, 13:16

RE: vdr-plugin-imonlcd

Hallo Andreas,

zunächst mal per lsusb herausfinden, welches Imon-Display Du hast
z.B.

Quellcode

1
Bus 001 Device 003: ID 15c2:0038 SoundGraph Inc.
das ist das Imon mit der Kennung 0038.

Dann müßtest Du in /etc/vdr/plugins/plugin.imonlcd.conf
die Zeile

Quellcode

1
-d /dev/lcd0 -p 0038

stehen haben, wenn die oben von hotzenplotz angesprochenen Rechte stimmen.

Gruß, Bernd
Prod1: yaVDR 0.4; hush mini-itx-Gehäuse mit POV/ION330-1,technisat skystar usb 2
Prod2: yaVDR 0.3; Silverstone ML02B-MXR; ZOTAC ION-F;
Prod3: ZenDEB SMT7020

  • »miraculix025« ist der Autor dieses Themas

Beiträge: 112

Wohnort: Wettringen

Beruf: Apotheker

  • Nachricht senden

4

Sonntag, 25. Oktober 2009, 13:28

RE: vdr-plugin-imonlcd

entschuldigung, dass ich mich erst jetzt wieder melde, aber aufgrund eines Familienurlaubes konnte ich mich nicht mehr mit meinem VDR beschäftigen.
Aber jetzt geht es wieder los.

Danke für Eure Tips.
das passende Lcd habe ich gefunden und in der conf eingetragen. Das Plugin wird aber anscheinend gar nicht richtig geladen, im Syslog stehen folgende relevante Fehlermeldungen dazu

iMonLCD: error writing to dead file descriptor


vdr kernel: [ 5443.516782] vdr[2946]: segfault at 4 ip b7a8d23e sp bf9a1810 error 4 in libvdr-imonlcd.so.1.6.0[b7a85000+11000]

iMonLCD: ERROR opening /dev/lcd0 (Datei oder Verzeichnis nicht gefunden)

iMonLCD: Did you load the iMON kernel module?

Was sagen mir die Meldungen, was kann ich tun?


Grüße aus dem Münsterland
Andreas

5

Montag, 26. Oktober 2009, 22:00

Ich habe selbiges Display und hatte es gestern kurz am Laufen. Folgende Links haben mir geholfen

  1. http://www.vdrportal.de/board/thread.php?threadid=86921
  2. http://projects.vdr-developer.org/wiki/plg-imonlcd
    [/list=1]

    Bei mir hat es dann auch schon Sendernamen angezeigt. Ich hatte noch ein paar mehr Seiten gelesen, die habe ich mir aber nicht gebookmarked.

    Zudem hatte ich mich entschieden, mir die neueste CVS-Version zu ziehen und habe lirc neu kompiliert. Ausserdem habe ich folgenden Hinweis befolgt;

    Zitat

    Other software like LCDproc should not be used, it could locking the device access.


    Ich bin noch am kämpfen, die FB läuft auch noch nicht, aber zusätzlich habe ich mir Rechten um mich geworfen

    Quellcode

    1
    2
    3
    4
    
    chmod g+w /dev/lircd
    chgrp vdr /dev/lircd
    chmod g+w /dev/lirc
    chgrp vdr /dev/lirc


    Danach den vdr-Prozess neu starten und schon zeigte er was an. Den Reboot des Rechners hat das Display leider nicht überlebt, jetzt zeigt es aber nichts mehr an, bin aber noch nicht dazu gekommen, nachzuforschen warum es nicht mehr will.
WYS
Mag

6

Montag, 26. Oktober 2009, 22:29

Zitat

Original von mag
Den Reboot des Rechners hat das Display leider nicht überlebt


Schnorch! :wand Hatte die udev-Regel vergessen anzulegen, daher stimmten die Rechte nicht.
(Siehe erwähnten Link von hotzenplotz5)
WYS
Mag

Immortal Romance Spielautomat