You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Monday, March 14th 2005, 10:21pm

PVR350-only / VDRDevel-1.3.x / Analogtv - Wie ist euer Status? Wer hat´s am laufen?

Guten Abend,
ich bin auch nach zahlreichen Installationsvarianten und lesen von dutzenden Threats immer noch auf der Suche nach einer Konstellation die funktioniert!?

--ZIEL--
PVR 350 rev. 991 als einzige Karte mit folgenden Plugins unter VDRDevel zum laufen bekommen:

VDR 1.3.x (Tobis Testing oder Experimental, am liebsten 1.3.22!!!)
PVR350-Plugin
AnalogTV

Falls mir jemand antwortet, wäre es toll, wenn dabei die genauen Pakete, Treiber, Versionen angegeben werden könnten.
Vielleicht sogar die genaue Vorgehensweise?

--PROBLEM--
ist die Fehlermeldung buffer usage bei den aktuellen Testing oder Experimental Paketen:

Mar 14 21:55:29 vdr vdr[1084]: buffer usage: 70% (tid=16386)
Mar 14 21:55:29 vdr vdr[1084]: buffer usage: 80% (tid=16386)
Mar 14 21:55:29 vdr vdr[1084]: buffer usage: 90% (tid=16386)
Mar 14 21:55:29 vdr vdr[1068]: max. latency time 1 seconds
Mar 14 21:55:30 vdr vdr[1084]: buffer usage: 100% (tid=16386)

Wenn ich die VDRDevel von der C´t 3 nehme, habe ich zwar die Version 1.3.12 die in diesem Zusammenhang genannt wurde. Hier sind die Bufferwerte vom dazu passenden AnalogTV wohl noch nicht verändert worden. Allerdings ist dann das PVR350-Plugin bei der Installation noch nicht installiert. Wenn ich das über apt-get nachträglich installiere, scheinen die Abhängikeiten der verschiedenen Pakete nicht zu stimmen, sprich das PVR-Plugin das geladen wird ist zu neu? Denn es wird dann beim starten des VDRs schlußendlich nicht geladen.

Hier mal mein aktueller Status bei dem auch oben genannte Fehlermeldung kommt:

**************************************
* c't VDR Übersicht *
**************************************

c't VDR: 1.3.17-6
Kernel : 2.4.27-ctvdr-1

Patches:
--------------------------------------
dvd-subtitles
enAIO-1.6
jumpplay-0.6
AC3overDVB-0.2.6
subtitles-ttxtsubs_ac3
director
sharelnb
HDTV
setup-show-valid
CutterQueue-0.5

Plugins:
( N = Native Plugin )
( ! = Falscher Patchlevel )
--------------------------------------
vdrdevel-plugin-analogtv (0.9.37-7)
vdrdevel-plugin-pvr350 (0.0.3-2)

Addon Packages:
--------------------------------------
Kein Paket gefunden, dass auf vdrdevel-addon* passt.

Habe die Channels.conf mal nur auf drei Sender reduziert um mögliche Fehlerquellen auszumerzen:

:Analog
ARD:182250:B6C0D45:C:0:301:300:0:A0:28106:0:0:0
ZDF:196250:B6C0D45:C:0:301:300:0:A0:28006:0:0:0
NDR:175250:B6C0D45:C:0:301:300:0:A0:28224:0:0:0
~

Die setup.conf werde ich aus Platzgründen im nächsten Post angeben!

Hier kann ich über die option:

analogTV.usePVR350 = 1

zwar ultra schnell zappen, aber sobald ich eine Wiedergabe einer Aufnahme starte, stürzt der VDR ab und o.g. Fehlermeldung erscheint.
Ich glaube das diese Option sowieso nur die Ausgabe des Signals direkt ausgibt. Hier wurde auch von Problemen berichtet weswegen es in neueren Versionen im OSD herausgenommen wurde.

Ich habe auch schon gelesen das man einen Patch auf den IVTV Treiber anwenden soll:

http://www.gossamer-threads.com/lists/ivtv/devel/17555?

bzw. der Threat der mich dahin geführt hat:

http://www.vdr-portal.de/board/thread.ph…ilightuser=8652

Weiß allerdings nicht wie das vom Befehlssyntax her geht!

Derjenige verwendet allerdings Gentoo, sodaß ich nicht weiß ob es für Debian bzw. die C´t 3 auch funktionieren würde.
Ich habe im Zusammenhang mit Gentoo mal von sog. Ebuilds gelesen, wäre es damit event. einfacher einen VDRPVRonly System mit neusten Paketen aufzubauen?

Wäre echt super wenn mir da mal geholfen werden könnte...

LG Squaregarden
Silverstone LC11 / Asus P4P800-VM / Celeron 2,53 / 512 MB / 2x250 1x160 GB / PVR350 rev. 991 / Technotrend 2.1 PE DVB-C / IR-Modul / Medion MD41169 / c't VDR: 1.4.3-1ctvdr3
Das Nebensächliche macht riesige Fortschritte. Wir entfernen uns immer weiter vom Wesentlichen.

2

Monday, March 14th 2005, 10:22pm

RE: PVR350-only / VDRDevel-1.3.x / Analogtv - Wie ist euer Status? Wer hat´s am laufen?

Hier die Setup.conf:
Card1usesLNBnr = 1
Card2usesLNBnr = 2
ChannelInfoPos = 0
CurrentChannel = 1
CurrentVolume = 255
DefaultLifetime = 99
DefaultPriority = 50
DiSEqC = 0
EPGBugfixLevel = 2
EPGLanguages =
EPGLinger = 0
EPGScanTimeout = 5
InstantRecordTime = 180
JumpPlay = 0
LiveMultichannelAudio = 0
LnbFrequHi = 10600
LnbFrequLo = 9750
LnbSLOF = 11700
LoadMarksInterval = 0
MarginStart = 2
MarginStop = 10
MarkInstantRecord = 1
MaxVideoFileSize = 2000
MenuCmdPosition = 0
MenuScrollPage = 1
MinEventTimeout = 30
MinUserInactivity = 0
MultiSpeedMode = 0
NameInstantRecord = TITLE EPISODE
OSDHeight = 486
OSDLanguage = 1
OSDLeft = 54
OSDMessageTime = 1
OSDSkin = sttng
OSDTheme = default
OSDTop = 45
OSDWidth = 624
PauseLifetime = 1
PausePriority = 10
PlayJump = 0
PlayMultichannelAudio = 0
PrimaryDVB = 2
PrimaryLimit = 0
RecordDolbyDigital = 1
RecordingDirs = 1
ResumeID = 0
SetSystemTime = 0
ShowInfoOnChSwitch = 1
ShowProgressBar = 0
ShowRecDate = 1
ShowRecLength = 0
ShowRecTime = 1
ShowReplayMode = 0
SortTimers = 1
SplitEditedFiles = 0
SVDRPTimeout = 300
TimeSource = 0
TimeTransponder = 0
UpdateChannels = 4
UseSmallFont = 1
UseSubtitle = 1
UseVps = 0
VideoFormat = 0
VpsMargin = 120
ZapTimeout = 3
analogtv.AudioBitRate = 256
analogtv.AudioMode = 3
analogtv.AutoUpdate = 0
analogtv.avSyncHack = 0
analogtv.Bframes = 3
analogtv.AutoUpdate = 0
analogtv.avSyncHack = 0
analogtv.Bframes = 3
analogtv.Brightness = 17
analogtv.Clipping = 1
analogtv.Colour = 17
analogtv.Contrast = 18
analogtv.debug = 0
analogtv.Deinterlace = 0
analogtv.DNRmode = 0
analogtv.DNRspatial = 0
analogtv.DNRtemporal = 2
analogtv.DNRtype = 0
analogtv.Encoder = 8
analogtv.EncoderAlwaysUp = 1
analogtv.EPGfrom = 1
analogtv.EPGprovider = "FF
analogtv.External = "
analogtv.Filter = 7
analogtv.Finetune = "|
analogtv.FramesPerGOP = 12
analogtv.GOP = 1
analogtv.GOPclosure = 0
analogtv.HideMainMenu = 1
analogtv.Hue = 15
analogtv.ImageSize = 5
analogtv.Link = 0
analogtv.Logger = 2
analogtv.MemcpyMethod = 1
analogtv.MixerDevice = "/dev/mixer
analogtv.MixerInput = 14
analogtv.MixerVolume = 100
analogtv.MotionMax = 0
analogtv.MotionMin = 0
analogtv.MPEG = 0
analogtv.PCMdevice = "/dev/dsp
analogtv.ppHack = 0
analogtv.Profile = 0
analogtv.PsychoAnalysis = 0
analogtv.Report = 0
analogtv.StutteringHack = 1
analogtv.SyncHack = 1
analogtv.Test = 0
analogtv.ThemeLanguage = 2
analogtv.Videobitrate = 70
analogtv.WiningHack = 0
streamdev-server.AllowSuspend = 0
streamdev-server.HTTPServerPort = 3000
streamdev-server.HTTPStreamType = 1
streamdev-server.MaxClients = 5
streamdev-server.ServerPort = 2004
streamdev-server.StartHTTPServer = 1
streamdev-server.StartServer = 1
streamdev-server.SuspendMode = 0
Silverstone LC11 / Asus P4P800-VM / Celeron 2,53 / 512 MB / 2x250 1x160 GB / PVR350 rev. 991 / Technotrend 2.1 PE DVB-C / IR-Modul / Medion MD41169 / c't VDR: 1.4.3-1ctvdr3
Das Nebensächliche macht riesige Fortschritte. Wir entfernen uns immer weiter vom Wesentlichen.

3

Tuesday, March 15th 2005, 3:57pm

RE: PVR350-only / VDRDevel-1.3.x / Analogtv - Wie ist euer Status? Wer hat´s am laufen?

Hat das wirklich keiner am laufen? Dann scheint das ja wohl doch nicht möglich zu sein?

Ich hoffe ja noch das sich einer meldet!

LG Squaregarden
Silverstone LC11 / Asus P4P800-VM / Celeron 2,53 / 512 MB / 2x250 1x160 GB / PVR350 rev. 991 / Technotrend 2.1 PE DVB-C / IR-Modul / Medion MD41169 / c't VDR: 1.4.3-1ctvdr3
Das Nebensächliche macht riesige Fortschritte. Wir entfernen uns immer weiter vom Wesentlichen.

Dr. Seltsam

Im Forum Zuhause

Posts: 9,895

Location: 3. Planet des Sonnensystems

Occupation: Organisator

  • Send private message

4

Wednesday, March 16th 2005, 8:28am

RE: PVR350-only / VDRDevel-1.3.x / Analogtv - Wie ist euer Status? Wer hat´s am laufen?

tja, das ist wirklich eine biestige Angelegenheit. Bei mir lief es kurzzeitig mal halbwegs (stark verpixeltes Bild beim Umschalten), aber kurioserweise kann ich das jetzt nicht mehr rekonstruieren. Ich dachte ursprünglich, Dominics Patch für ivtv wäre die Lösung gewesen. Bei genauerem Hinsehen habe ich dann allerdings festgestellt, dass ich die ivtv-Treiber gar nicht aus dem gepatchten Verzeichnis installiert hatte, also lag das kurzzeitige "es geht" nicht daran.

Mein letzter Zustand war nun, dass man Aufnahmen starten konnte (die dann auch richtig liefen) und auch wiedergeben konnte. Aber nach dem Start der Aufnahme wurde das Bild dann dunkel und kam auch nach Beendigung der Aufnahme nicht wieder (>Restart nötig). Gleiches bei Wiedergabe einer vorhandenen Aufnahme. Mit etwas Glück klappte dieser Moduswechsel 1 bis 2 x, danach wie gesagt Bild dunkel.

Inzwischen laufen hier diverse PVR350-Threads, so dass ich selbst allmählich den Überblick verliere, wem ich schon was geraten habe. :rolleyes:

Auf alle Fälle nochmal ein Tip: Der Decoder benötigt für die Ausgabe das device /dev/video16 . Bei Suse 9.0 war das standardmäßig nicht vorhanden und musste manuell erstellt werden:
mknod /dev/video16 c 81 16
chmod 660 /dev/video16
chown video /dev/video16

Ich weiß vom Autor beider Plugins (analogtv/pvr350), dass sie ein PVR350-only-System am laufen haben und es als stabil bezeichnen. Es muss also irgendwie gehen!
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

5

Friday, March 18th 2005, 12:11am

RE: PVR350-only / VDRDevel-1.3.x / Analogtv - Wie ist euer Status? Wer hat´s am laufen?

Quoted

Original von Dr. Seltsam
Ich weiß vom Autor beider Plugins (analogtv/pvr350), dass sie ein PVR350-only-System am laufen haben und es als stabil bezeichnen. Es muss also irgendwie gehen!

Kann man die event. ganz freundlich um Hilfe bitten, oder meinst Du das die "wahrscheinlich" besseres zu tuen haben?

Also so langsam gebe ich es glaube ich auf! Habe den VDR jetzt bestimmt bald 100 mal neu installiert.

Ich glaube ich beiße in den sauren Apfel und werde mir noch eine Technotrend DVB-C 2.1 Premium dazu holen! Damit soll es ja angeblich funktionieren?

Ich wollte anfänglich mal den neusten Kernel mit dem VDR kombinieren um zugleich einen eigenständigen Firewall-Rechner zu haben. Sozusagen zwei Fliegen mit einer....aber das habe ich inzwischen auch verworfen. Jetzt weiß ich auch warum die Leute hier im Forum oftmals so viele Clients haben:

1. bei dem vielen Gebastel ist die Wahrscheinlichkeit das einer läuft größer..

2. es scheinen nicht alle Karten miteinander zu laufen. Verteilt man diese auf mehrere Systeme hat man weniger Probleme....

Nee mal im Ernst, hätte nie gedacht das es so ein Akt ist.

Wie ist jetzt Dein Status, d.h. welche Versionen benutzt Du?


Danke für die Hilfe LG

Squaregarden
Silverstone LC11 / Asus P4P800-VM / Celeron 2,53 / 512 MB / 2x250 1x160 GB / PVR350 rev. 991 / Technotrend 2.1 PE DVB-C / IR-Modul / Medion MD41169 / c't VDR: 1.4.3-1ctvdr3
Das Nebensächliche macht riesige Fortschritte. Wir entfernen uns immer weiter vom Wesentlichen.

6

Friday, March 18th 2005, 12:18am

RE: PVR350-only / VDRDevel-1.3.x / Analogtv - Wie ist euer Status? Wer hat´s am laufen?

Ähm hubs,

hatte bis eben noch gearbeitet, da habe ich wohl Deine Signatur übersehen. Ist die noch aktuell?

Ich bekomme selbst die 1.3.12 nicht zum laufen.

Wenn ich die Standartmäßig von der CD installiere, ist das pvr350 Plugin noch nicht dabei. Wenn ich es dann "apt-gette", ich hole es von Tobi und nehme die testing, geht es weder mit der Multi noch mit der Bigpatch Variante. D.h. Plugin ist zwar installiert wird aber nicht gestartet? Schätze das dort die vorhandenen Versionen nicht mit dem geholten PVR350Plugin zusammen passen?

Wenn ich ein vdrdevelapt-refresh mache, nimmt er ja die neusten Pakete, oder? Das wäre dann also falsch.

Any ideas?

und nochmals Danke!!!!!!!!!!!!!!!!!!!!!!!!!

Squaregarden :D
Silverstone LC11 / Asus P4P800-VM / Celeron 2,53 / 512 MB / 2x250 1x160 GB / PVR350 rev. 991 / Technotrend 2.1 PE DVB-C / IR-Modul / Medion MD41169 / c't VDR: 1.4.3-1ctvdr3
Das Nebensächliche macht riesige Fortschritte. Wir entfernen uns immer weiter vom Wesentlichen.

7

Friday, March 18th 2005, 2:00am

Also ich habe ein fast-PVR350only-System relativ schnell ans laufen bekommen (fast, weil auch noch zwei Skystar 2 Karten drinstecken).

Folgende Anleitung hatte ich als Ausgangsbasis genutzt:
http://www.vdr-portal.de/board/thread.ph…adid=30497&sid=

Beide aktuellen VDR-Versionen von Tobi laufen bei mir halbwegs zufriedenstellend, wichtig war halt vor allem eine aktuelle Version von ivtv.

Dr. Seltsam

Im Forum Zuhause

Posts: 9,895

Location: 3. Planet des Sonnensystems

Occupation: Organisator

  • Send private message

8

Friday, March 18th 2005, 8:00am

RE: PVR350-only / VDRDevel-1.3.x / Analogtv - Wie ist euer Status? Wer hat´s am laufen?

Moin,

zumindest Andreas Kool ist ziemlich ausgelastet und wird nach meiner Einschätzung nicht unbedingt jede Mail beantworten können. Ich habe aber auch ein paar Hinweise/Fragen gesammelt, die ich ihm zumailen werde - vielleicht ergibt sich danach ja etwas.

Ich habe sowohl eine PVR250 als auch seit kurzem eine 350. Die 250 werkelt zusammen mit einer dxr3 und dem dxr3-Plugin von Austrian Coder sehr stabil. Allerdings nur bis vdr-Version 1.3.12, danach gibt es Ruckler, vermutlich wegen veränderter Buffer.

Mit der 350 experimentiere ich ab und an (derzeit mit Kernel 2.6.11), und im Moment habe ich die beschriebenen Probleme. Am Wochenende werde ich mal weiter basteln...

Wenn Du digitales Kabelfernsehen hast, wäre eine DVB-C FF eine gute Wahl. Da kann es aber auch Probleme geben, weil der Decoder mit dem Stream der PVR manchmal Zicken macht (Flackern). Was nach meinen Erfahrungen bislang am besten läuft, ist die Kombination mit einer dxr3, wobei die Umschaltzeit allerdings 3-4 Sekunden dauert.

Ich glaube, bei der ganzen Bastlei (ständiges Probieren verschiedener, z.T. gepatchter Versionen) ist die c´t bzw. Debian nicht die einfachste Lösung.
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

maxx_flea

Beginner

Posts: 12

Location: Berlin

Occupation: ITSE / System-Administrator / Hoster

  • Send private message

9

Thursday, June 2nd 2005, 10:58am

Bei mir geht's

Hi,

ich hab keine großen Probleme gehabt bei der Installation von der PVR 350.

Basis war die C't VDR 3.06 und dann noch die Änderungen, damit das System läuft:

1. "/etc/modutils/ivtv.2.4....." anpassen
2. "update-modules"
3. "/etc/lilo.conf" anpassen
4. "lilo"
5. in "/var/lib/vd4/setup.conf" ein paar Schönheitskleinigkeiten
6. "/var/lib/channels.conf" anpassen

Bei der channels.conf sind, wegen der älteren Version von ivtv, als VPID und APID "...:160:80:..." einzutragen

und das war's. Es läuft zuverlässig. Die Umschaltzeiten sind auszuhalten, aber sonst läuft das System stabil.

Im Moment versuche ich mich an einer zusätzlichen PVR150....siehe Thread 33815

Ich hoffe, es hilft dir, dass ES GEHT.
Bei Fragen schreib mich einfach an....

Der Flo(h)

10

Wednesday, June 8th 2005, 1:05pm

Hi Squaregarden,

ich habe meine Installation beschrieben, das Ergebnis nach mehreren Fehlschlägen und Seitenblicken in Richtung MythTV, freevo und nmm findest Du hier:

http://www.vdrportal.de/board/thread.php…d=&hilight=ivtv

Gruß,
yamorik

11

Thursday, June 9th 2005, 2:34pm

Quoted

Original von yamorik
Hi Squaregarden,

ich habe meine Installation beschrieben, das Ergebnis nach mehreren Fehlschlägen und Seitenblicken in Richtung MythTV, freevo und nmm findest Du hier:

http://www.vdrportal.de/board/thread.php…d=&hilight=ivtv

Gruß,
yamorik


Danke für Deine Hilfestellung!

Vielleicht probiere ich das nochmal aus, aber eigentlich habe ich mich nun seit 4 Monaten mit der Ct Variante herumgeschlagen, d.h. eigentlich möchte ich diese verwenden, da ich hier unabhängiger bin und so manchen Dienst zusätztlich auf dem System unterbringen kann!

Außerdem scheint mir die Lösung unter Linvdr immer noch zu sehr eine Bastellösung zu sein.

Ich denke das hier eines Tages der Support einer PVR out of the Box implementiert sein wird. Dann könnte es event. für einen zusätzlichen Client taugen.

Ich habe zudem mittlerweile noch eine Technotrend DVB-C 2100 Prem dazubekommen, deswegen habe ich kein richtiges PVR-Only System mehr. Die Ausgabe mache ich jetzt über die DVB-C, und hey das Ergebnis ist viel besser!

Mein Problem war auch viel mehr das ich die Entwicklerversion von CtVDR nicht nutzen konnte, da hier ein Stuttering Patch fehlte. Dieser ist jetzt zwar Bestandteil der neusten Verison, funktioniert aber leider bei mir nicht. Deswegen halte ich z.Zt. an der normalen Version fest.

Ich kann mittlerweile alle Funktionen normal nutzen.
Das einzige was ich noch nicht in den Griff bekommen habe ist das programmieren über den Merkzettelimport von tvmovie2vdr über Internet.

Bei mir ist ebenfalls anfänglich das EPG weg! Das betrifft aber nur vdradmin direkt nach dem einschalten, nach so ca. 5 min ist dann alles da?

Mir fehlt jetzt eigentlich nur noch Wake Up über Internet.

Würde das gerne mit einer Art Button im meiner IPCOP-Firewall integrieren.

Achso und ein Skin der mir die Bilder des EPG anzeigt, das kann so schwer ja nicht sein...schauen wir mal...

Da bin ich noch am tüfteln!

Berichte gerne weiter über Deinen Status, dürfte so manchen interessieren.

LG und danke der

Squaregarden
Silverstone LC11 / Asus P4P800-VM / Celeron 2,53 / 512 MB / 2x250 1x160 GB / PVR350 rev. 991 / Technotrend 2.1 PE DVB-C / IR-Modul / Medion MD41169 / c't VDR: 1.4.3-1ctvdr3
Das Nebensächliche macht riesige Fortschritte. Wir entfernen uns immer weiter vom Wesentlichen.