Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Freitag, 3. Juni 2005, 14:44

Gelöst Rechner schaltet nach dem runterfahren nicht ab

Hallo Leute,

leider schaltet sich mein c´tvdr (v 3.06) nach dem runterfahren nicht ab ;(
Alles Andere funktioniert soweit klaglos, nur nach dem Abschaltkommando fährt das Teil halt runter und bleibt dann mit der letzten Aufschrift: Power down weiter "unter Strom". Es ist noch kein so altes Board von MSI: MS-6309, mit neuestem BIOS, P III / 450MHz, Samsung HD 160GB, usw.

Folgendes habe ich in /etc/lilo.conf bereits probiert:

1: append = "apm = "apm=power-off no apic"
2: append = "acpi=on"

anschließend natürlich lilo auf der console aufgerufen, dabei gibt es eine Warnung:

>Warning: COMPACT may conflict with LBA32 of some systems


weiss einer Abhilfe hierfür? vielen Dank - Tobias
PS. und noch immer kein Internet / DSL zu Hause !!!

VDR1: linvdr 0.7 / mahlzeit ISO 3.0 auf TUSL2-C + Celeron 1200 @800Mhz; 256MB; 160GB HDD; TT-1400;
VDR2: linvdr 0.7 / mahlzeit ISO 3.0 auf TUSL2-C + Celeron 1200Mhz; Test-vdr;


Pico-AVBoard 1.0 , new: Pico-AVBoard 1.01

2

Freitag, 3. Juni 2005, 14:45

RE: Rechner schaltet nach dem runterfahren nicht ab

ist das Modul "apm" geladen ?

Gruß
Mag1c

3

Freitag, 3. Juni 2005, 14:59

RE: Rechner schaltet nach dem runterfahren nicht ab

Wie bekomme ich das raus? oder ist es nicht schon standardmäßig bei der c´t-Installation mit dabei?
Gruß - Tobias
PS. und noch immer kein Internet / DSL zu Hause !!!

VDR1: linvdr 0.7 / mahlzeit ISO 3.0 auf TUSL2-C + Celeron 1200 @800Mhz; 256MB; 160GB HDD; TT-1400;
VDR2: linvdr 0.7 / mahlzeit ISO 3.0 auf TUSL2-C + Celeron 1200Mhz; Test-vdr;


Pico-AVBoard 1.0 , new: Pico-AVBoard 1.01

4

Freitag, 3. Juni 2005, 16:13

RE: Rechner schaltet nach dem runterfahren nicht ab

bei lsmod sollte auch das Modul apm dabeistehen.
Wenn nicht, dann einfach mal laden ("modprobe apm") und dann den Rechner runterfahren.
Wenn das klappt, kannst du das in die /etc/modules eintragen. Dann wird es beim Start automatisch geladen.

Gruß
Mag1c

5

Freitag, 3. Juni 2005, 16:40

RE: Rechner schaltet nach dem runterfahren nicht ab

hi Mag1c,
mit lsmod wird kein Modul apm angezeigt und folgendes bei Eingabe von:

>modprobe apm
modprobe: Can´t locate module apm


was muss ich nun machen? Tobias
PS. und noch immer kein Internet / DSL zu Hause !!!

VDR1: linvdr 0.7 / mahlzeit ISO 3.0 auf TUSL2-C + Celeron 1200 @800Mhz; 256MB; 160GB HDD; TT-1400;
VDR2: linvdr 0.7 / mahlzeit ISO 3.0 auf TUSL2-C + Celeron 1200Mhz; Test-vdr;


Pico-AVBoard 1.0 , new: Pico-AVBoard 1.01

PeterD

Meister

Beiträge: 1 769

Wohnort: Hessen

Beruf: Elektronikingenieur

  • Nachricht senden

6

Freitag, 3. Juni 2005, 17:22

RE: Rechner schaltet nach dem runterfahren nicht ab

Zitat

Original von seaman
Folgendes habe ich in /etc/lilo.conf bereits probiert:

1: append = "apm = "apm=power-off no apic"
2: append = "acpi=on"


Erstes ist nicht ganz korrekt:
1. immer append "...."; bei dir sind zu viele "
2. parameter sind falsch:
  • apm=[on|off|power-off]
  • acpi=[on|off|force]
  • noapic

Müsste also richtig heissen:

1: append = "apm=power-off noapic"


Bei alten boards sollte man ACPI aber besser erzwingen:

1: append = "apm=off acpi=force"

Das sorgt auch dafür das apm wirklich nicht verwendet wird
Hab damit ein altes P2 board am laufen wo bios noch nix von ACPI sagt.

Alternativ dann mit APM:

1: append = "apm=on acpi=off"



Zitat

mit lsmod wird kein Modul apm angezeigt und folgendes bei Eingabe von:

>modprobe apm
modprobe: Can´t locate module apm

APM ist im kernel

gruss Peter
Mein anderer VDR ist (auch) ein EPIA
1)VIA M10000-Nehemiah, 160+120G Samsung; NEC 1300A; YY A106; LCD20x4 ...
2) ctvdr+e-tobi ; C3M266+1,2GHz-Nehmiah; 160G Samsung + 4x500G Seagate SATA; NEC3500; TT-Case; DVB-S 1.3+4MB + Nova ; gLCD 240x128 ...

. . .TB rulez. . .

7

Samstag, 4. Juni 2005, 11:23

RE: Rechner schaltet nach dem runterfahren nicht ab

Hurra, es klappt :]

@PeterD
vielen Dank, Deine ausführlichen Hinweise waren sehr hilfreich. Letzlich hat folgendes geholfen: im BIOS APM aktivieren (muss ich anfänglich übersehen haben) und die vorgeschlagene Zeile:

append = "apm=on acpi=off"


Mit meinen (noch) geringen Linux-Kenntnissen ließ sich acpi nicht verwenden, mit apm klappt es nun.

Grüße vom glücklichen seaman 8)
PS. und noch immer kein Internet / DSL zu Hause !!!

VDR1: linvdr 0.7 / mahlzeit ISO 3.0 auf TUSL2-C + Celeron 1200 @800Mhz; 256MB; 160GB HDD; TT-1400;
VDR2: linvdr 0.7 / mahlzeit ISO 3.0 auf TUSL2-C + Celeron 1200Mhz; Test-vdr;


Pico-AVBoard 1.0 , new: Pico-AVBoard 1.01

8

Samstag, 4. Juni 2005, 11:36

RE: Rechner schaltet nach dem runterfahren nicht ab

Zitat

Original von seaman
Mit meinen (noch) geringen Linux-Kenntnissen ließ sich acpi nicht verwenden, mit apm klappt es nun.

Für acpi:
apt-get install acpid
VDR 1.7.15 - Debian Squeeze/Kernel 2.6.32
Rebach-Gehäuse, Intel Atom330, Extension HD, Technisat Cablestar2

9

Freitag, 13. April 2007, 03:37

Sorry, daß ich diesen Thread nochmal ausgrabe, aber ich komme einfach nicht weiter.

Nachdem ich in meinem vdr2 das Mainboard getauscht habe, will der
Rechner nach dem runterfahren nicht ausschalten.
Mainboard vorher:
Asus CUSL2-C - schaltet ab ohne apm/acpi-Parameter in der Kernel-Zeile.

Mainboard neu:
CUSL2 (ohne C) - will nicht ausschalten, stattdessen wird neu gebootet

Habe nun einige Parameter, wie hier im Thread erwähnt, versucht aber
leider keine Besserung.

apm=on acpi=off
Shutdown hdX ...
System halted.
-> Rechner geht nicht aus

apm=power-off noapic
-> Rechner startet neu

apm=off acpi=force
-> Rechner startet neu

apm=on acpi=off
Shutdown hdX ...
System halted.
-> Rechner geht nicht aus
USER: EX-Aman
seit kurzem produktiv: VDR SZ: Geh.: MS-Tech LC-02 / Asus M3N78-EM / DVB-S: 2xCTX929 / IR-Einschalter / nvidia-vdpau / USB-Boot... easyVDR 1.0
zZ noch produktiv VDR-WZ: Low-Budget -- Asus A7V133/1700+/Nova-S/GeForce 5500/4:3 Röhre - XBMC + easyVDR 0.8 ohne vdpau
zZ Testsystem: Digitainer-Gehäuse / Asus M3N78-EM / DVB-S: 2xNova-S / Medion X10 / nvidia-vdpau / USB-Boot... easyVDR 1.0
Bastelstatus: O2 Joggler - YaVDR
... Dockstar für Aufnahmen ...

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Aman« (13. April 2007, 03:47)


10

Freitag, 13. April 2007, 04:39

GELÖST:

Die BIOS-Option Wake-on-Lan war aktiv und das WOL-Kabel falsch
gepolt, d.h. Standby-Spannung und WOL-Signal waren vertauscht,
da hat das Board beim runterfahren 'gedacht', es liegt ein WOL-Signal an
und es muß nun aufwachen ...
USER: EX-Aman
seit kurzem produktiv: VDR SZ: Geh.: MS-Tech LC-02 / Asus M3N78-EM / DVB-S: 2xCTX929 / IR-Einschalter / nvidia-vdpau / USB-Boot... easyVDR 1.0
zZ noch produktiv VDR-WZ: Low-Budget -- Asus A7V133/1700+/Nova-S/GeForce 5500/4:3 Röhre - XBMC + easyVDR 0.8 ohne vdpau
zZ Testsystem: Digitainer-Gehäuse / Asus M3N78-EM / DVB-S: 2xNova-S / Medion X10 / nvidia-vdpau / USB-Boot... easyVDR 1.0
Bastelstatus: O2 Joggler - YaVDR
... Dockstar für Aufnahmen ...

rudibert

Fortgeschrittener

Beiträge: 247

Wohnort: gebürtig ganz im Norden, Wohnort in Spanien

Beruf: Informatiker

  • Nachricht senden

11

Sonntag, 1. Juli 2007, 15:36

RE: Rechner schaltet nach dem runterfahren nicht ab

...Geilheit die mich packte!!!

Hier die Bestätigung, daß es auch mit Grub klappt:

In die Menu.lst

Quellcode

1
apm=on acpi=off
eingetragen

in die Datei /etc/modules

Quellcode

1
 apm

angehängt und läuft wie geschmiert. Ich war echt frustiert, weil der Rechner beim ctvdr4.5 vorher (fast*) einwandfrei runterfuhr!!!

Dank an PeterD und Mag1c! Meine alte Möhre läuft jetzt wie die Wutz. :vdr1


*fast deshalb, weil er dummerweise nicht über den sleeptimer, sondern nur über den direkten Befehl

Quellcode

1
 /usr/bin/poweroffvdr

z.B. im crontab eingetragen runterfuhr!!

Mein VDR

Kubuntu-64bit (vdr2.0 seit 8/2014),MS-7358-Medion-PC mit kabellosen Tastaturen, 6GB RAM, TT 1.6 + SkyStar2.3 — USV-Betrieb (ausgeschaltet ~5W, startbereit über acpi-wakeup)
wenn doch bei
Rudibert........ nur alles so zuverlässig liefe, wie der VDR...

dwoe

Fortgeschrittener

Beiträge: 246

Wohnort: Neunkirchen-Seelscheid

  • Nachricht senden

12

Montag, 23. Juli 2007, 19:33

RE: Rechner schaltet nach dem runterfahren nicht ab

Wo genau hast Du die Zeile

Quellcode

1
apm=on acpi=off
in die menu.lst eingefügt?

Danke,

Dirk
VDR: ASUS E35M1-M (AMD E-350), 2 GB Ram, 1 TB HDD, Technotrend Premium S2-6400

rudibert

Fortgeschrittener

Beiträge: 247

Wohnort: gebürtig ganz im Norden, Wohnort in Spanien

Beruf: Informatiker

  • Nachricht senden

13

Montag, 30. Juli 2007, 17:42

RE: Rechner schaltet nach dem runterfahren nicht ab

Hola DWOE,

entschuldigung, für die lange Antwortphase....

Die Parameter gehören alle in die Zeile wo der Linuxkernel geladen wird. (glaube da steht ein "KERNEL" zu Beginn der Zeile

Quellcode

1
2
3
4
title 	VDR linux (2.6.18-10ctvdr_spezial_sonderkernel)
root 	(hda 0,0)
kernel 	/vmlinuz-2.6.18-10ctvdr_spezial_sonderkernel root = dev/hda5 apm=on acpi=off video=vesafb:1024x768-16@72 vga=791 ro
initrd 	/initrd--2.6.18-10ctvdr_spezial_sonderkernelimg hdd=ide-scsi

mit dem Teil:

Quellcode

1
 video=vesafb:1024x768-16@72 vga=791

habe ich es dann sogar noch geschaft, daß mein Rechner auch mit dem Kernel 2.6 die höhere Auflösung nutzt.


Begeisterung
:strike1

Mein VDR

Kubuntu-64bit (vdr2.0 seit 8/2014),MS-7358-Medion-PC mit kabellosen Tastaturen, 6GB RAM, TT 1.6 + SkyStar2.3 — USV-Betrieb (ausgeschaltet ~5W, startbereit über acpi-wakeup)
wenn doch bei
Rudibert........ nur alles so zuverlässig liefe, wie der VDR...

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »rudibert« (30. Juli 2007, 17:43)


Immortal Romance Spielautomat