You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Austrian Coder

Professional

Posts: 1,616

Location: Österreich

Occupation: Student

  • Send private message

61

Thursday, April 22nd 2004, 11:12pm

Den Patch für das DXR3-Plugin muss man noch von Hand einspielen, ist aber eine Arbeit von einigen Sekunden.

TomSoniq

Intermediate

Posts: 160

Location: Hannover

Occupation: Ingenieur Elektronikentwicklung

  • Send private message

62

Friday, April 23rd 2004, 12:16am

Ah, der ist für's DXR3 plugin, nicht für die Kernel-Module, verstehe :)

Also, wenn ich das richtig sehe:

  1. Quellcode des DXR3 Plugins herunterladen
  2. Patch einspielen -> erklärst Du mir bitte kurz, wie?
  3. Plugin compilieren
  4. Plugin installieren
    [/list=1]

    Stimmt's?

    Muß ich für's erfolgreiche compilieren auch die Quellen vom VDR selbst haben, noch dazu in der richtigen Patchvariante?

    .oO( Oh je, das klingt nach Arbeit )

    Danke schonmal!

    Tom
In Betrieb: Serener GD-L01 mit VIA EPIA-EN15000G (passiv / 30W Betrieb / 4W Standby), Hitachi 80GB 2.5", FF: TT-DVB-S 2.3, c't-VDR 5
Reserve: Asus Pundit mit P4 1.6 GHz (sehr leise / 60W Betrieb), IBM 60 GB 2.5", FF: TT-DVB-S 1.6, Budget: TT-DVB-T 1.3, c't-VDR 5

Austrian Coder

Professional

Posts: 1,616

Location: Österreich

Occupation: Student

  • Send private message

63

Friday, April 23rd 2004, 12:29am

Hier ist der Patch:

In das dxr3-0.2.2 Verzeichnis wechseln und
'wget http://www.visual-page.de/dxr3/fix.patch'
ausführen.

Danach: 'patch < fix.patch'

Dann noch ein 'make all', dann kannst du die *.so in das lib-Verzeichnis vom VDR kopieren und schon kann es losgehen :]

Fürs compilen vom Plugin brauchst du die Sources vom VDR nicht, nur die inlcude-Files, welche schon auf deinem System sein sollten.

TomSoniq

Intermediate

Posts: 160

Location: Hannover

Occupation: Ingenieur Elektronikentwicklung

  • Send private message

64

Friday, April 23rd 2004, 2:00pm

Hi!

Danke erstmal, hat aber leider nicht geklappt :(

Ich brauche zusätzlich lediglich noch vdr-dev mit dem richtigen Patchlevel, richtig?

Zuerst hatte ich kein libavcodec, hatte mir also das komplette ffdshow Paket direkt von sourceforge 'runtergeladen und libavcodec compiliert. (Vielleicht habe ich dabei ja auch schon was falsch gemacht)

Dann hat auch das make all funktioniert, aber nun startet der vdr nicht mehr. Hier die Logs:

dmesg:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
Linux video capture interface: v1.00
DVB: registering new adapter (TT-Budget/WinTV-NOVA-T  PCI).
TT-Budget/WinTV-NOVA-T  PCI adapter 0 has MAC addr = 00:d0:5c:22:2e:10
tda1004x: Detected Philips TDA10045H.
tda1004x: Detected Philips TDM1316L tuner.
DVB: registering frontend 0:0 (Philips TDA10045H)...
i2c-core.o: i2c core module
i2c-algo-bit.o: i2c bit algorithm module
i2c-core.o: driver ADV717X video encoder driver registered.
em8300: EM8300 8300 (rev 1) bus: 0, devfn: 112, irq: 10, memory: 0xdc800000.
em8300: mapped-memory at 0xcef39000
em8300: using MTRR
em8300_main.o: Chip revision: 2
adv717x.o: ADV7175A chip detected
i2c-core.o: client [ADV7175A chip] registered to adapter [EM8300 I2C bus 1](pos. 0).
adv717x.o: Configuring for PAL 60
i2c-core.o: adapter EM8300 I2C bus 1 registered as adapter 0.
i2c-core.o: adapter EM8300 I2C bus 2 registered as adapter 1.
adv717x.o: Configuring for PAL
em8300_audio.o: Analog audio enabled
em8300: Microcode version 0x29 loaded
DVB: registering new adapter (TT-Budget/WinTV-NOVA-T  PCI).
TT-Budget/WinTV-NOVA-T  PCI adapter 0 has MAC addr = 00:d0:5c:22:2e:10
DVB: registering new adapter (TT-Budget/WinTV-NOVA-T  PCI).
TT-Budget/WinTV-NOVA-T  PCI adapter 0 has MAC addr = 00:d0:5c:22:2e:10
tda1004x: Detected Philips TDA10045H.
tda1004x: Detected Philips TDM1316L tuner.
DVB: registering frontend 0:0 (Philips TDA10045H)...
DVB: registering new adapter (TT-Budget/WinTV-NOVA-T  PCI).
TT-Budget/WinTV-NOVA-T  PCI adapter 0 has MAC addr = 00:d0:5c:22:2e:10


messages:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
Apr 23 12:57:11 pundit vdr[545]: VDR version 1.2.6 (ElchiAIO4c) started
Apr 23 12:57:11 pundit vdr[545]: loading plugin: /usr/lib/vdr/plugins/libvdr-dxr3.so.1.2.6
Apr 23 12:57:11 pundit vdr[545]: loading plugin: /usr/lib/vdr/plugins/libvdr-femon.so.1.2.6
Apr 23 12:57:11 pundit vdr[545]: loading /etc/vdr/setup.conf
Apr 23 12:57:11 pundit vdr[545]: loading /etc/vdr/sources.conf
Apr 23 12:57:11 pundit vdr[545]: loading /etc/vdr/diseqc.conf
Apr 23 12:57:11 pundit vdr[545]: loading /etc/vdr/channels.conf
Apr 23 12:57:11 pundit vdr[545]: loading /etc/vdr/commands.conf
Apr 23 12:57:11 pundit vdr[545]: loading /etc/vdr/reccmds.conf
Apr 23 12:57:11 pundit vdr[545]: loading /etc/vdr/svdrphosts.conf
Apr 23 12:57:11 pundit vdr[545]: loading /etc/vdr/ca.conf
Apr 23 12:57:11 pundit vdr[545]: loading /etc/vdr/remote.conf
Apr 23 12:57:11 pundit vdr[545]: loading /etc/vdr/keymacros.conf
Apr 23 12:57:13 pundit vdr[545]: found 1 video device
Apr 23 12:57:13 pundit vdr[545]: initializing plugin: dxr3 (0.2.2): DXR3-MPEG decoder plugin
Apr 23 12:57:13 pundit runvdr: restarting VDR
Apr 23 12:57:18 pundit kernel: DVB: registering new adapter (TT-Budget/WinTV-NOVA-T  PCI).
Apr 23 12:57:19 pundit kernel: TT-Budget/WinTV-NOVA-T  PCI adapter 0 has MAC addr = 00:d0:5c:22:2e:10


Mir ist auch gerade aufgefallen, daß das compilat plötzlich 4MB lang ist. Ziemlich suspekt...

Bin wie immer für Hilfe dankbar :)
In Betrieb: Serener GD-L01 mit VIA EPIA-EN15000G (passiv / 30W Betrieb / 4W Standby), Hitachi 80GB 2.5", FF: TT-DVB-S 2.3, c't-VDR 5
Reserve: Asus Pundit mit P4 1.6 GHz (sehr leise / 60W Betrieb), IBM 60 GB 2.5", FF: TT-DVB-S 1.6, Budget: TT-DVB-T 1.3, c't-VDR 5

Crue

Intermediate

Posts: 485

Location: Berlin

Occupation: Informations- und Telekommunikations-System-Elektroniker

  • Send private message

65

Friday, April 23rd 2004, 3:38pm

hab nochmal komplett von vorn angefangen ;(

@kk234 bin jetzt schon bei dem 16. punkt, biss dahin alles ohne fehler...

--16. die neuen drei Dateien adv717x.o bt865.o em8300.o sollten in /lib/modules/2.4.24-ctvdr-2/em8300 zu finden sein.

ja, da sind sie auch...

---17. die gleichnamigen Dateien aus /lib/modules/2.4.24-ctvdr-2/kernel/drivers/video wo anders hinsichern (nicht löschen!)

oke, gesichert...

--- 18. mit lsmod nachschauen, ob noch die alten Module geladen sind, (adv717x, bt865, em8300) wenn nötig (vdr vorher runterfahren) mit rmmod entladen,

waren geladen, habe sie entlladen (vdr hatte ich gestoppt)

---und dann mit modprobe bt865 oder adv717x laden, dann mit modprobe den em8300 laden.

>>>>>>>>>>>>??? meine grosse frage : wie lade ich die neuen module bt865+em8300?<<<<<<<<<<<<<<<

wenn ich da einfach modprobe bt865 und modprobe em8300 mache,
sehe ich per lsmod, dass wieder die alten module geladen werden...
wenn ich aber die alten "entsorge" und die neuen an ihre stelle setzte,
bekomme ich fehlermeldung...

--------------------
vdr:/usr/src/em8300# modprobe bt865
/lib/modules/2.4.24-ctvdr-2/kernel/drivers/video/bt865.o: unresolved symbol i2c_check_functionality_Rsmp_e3c84bfd
/lib/modules/2.4.24-ctvdr-2/kernel/drivers/video/bt865.o: unresolved symbol i2c_attach_client_Rsmp_e230575f
/lib/modules/2.4.24-ctvdr-2/kernel/drivers/video/bt865.o: unresolved symbol i2c_smbus_read_byte_data_Rsmp_220cfd1a
/lib/modules/2.4.24-ctvdr-2/kernel/drivers/video/bt865.o: unresolved symbol printk_Rsmp_1b7d4074
/lib/modules/2.4.24-ctvdr-2/kernel/drivers/video/bt865.o: unresolved symbol kfree_Rsmp_037a0cba
/lib/modules/2.4.24-ctvdr-2/kernel/drivers/video/bt865.o: unresolved symbol i2c_detach_client_Rsmp_293e7552
/lib/modules/2.4.24-ctvdr-2/kernel/drivers/video/bt865.o: unresolved symbol kmalloc_Rsmp_93d4cfe6
/lib/modules/2.4.24-ctvdr-2/kernel/drivers/video/bt865.o: unresolved symbol i2c_add_driver_Rsmp_6ec4580a
/lib/modules/2.4.24-ctvdr-2/kernel/drivers/video/bt865.o: unresolved symbol i2c_del_driver_Rsmp_37c75d23
/lib/modules/2.4.24-ctvdr-2/kernel/drivers/video/bt865.o: unresolved symbol i2c_smbus_write_byte_data_Rsmp_59249dba
/lib/modules/2.4.24-ctvdr-2/kernel/drivers/video/bt865.o: insmod /lib/modules/2.4.24-ctvdr-2/kernel/drivers/video/bt865.o failed
/lib/modules/2.4.24-ctvdr-2/kernel/drivers/video/bt865.o: insmod bt865 failed
------------------

was mach ich bloss falsch??? ;(

cyberthom

Intermediate

Posts: 469

Location: Berlin

Occupation: Ingenieur

  • Send private message

66

Friday, April 23rd 2004, 4:27pm

Ich denke Du musst in dem Verzeichnis, wo die module sind (em8300.o) ein insmod em8300 usw. wachen. Dann sollten sich die neuen module laden lassen
Asus Pundit-S 2600 - Celeron 2,6 GHz - 512 MB - Samsung 160 GB - NEC DVD-+RW 1300 - WinTV Nova-T (alt) - DXR3 (Creative);
c't3 - tobi Distri experimental (Sarge)/ VDR 1.4.x + (DXR3 oder em84xx 4MB bin am testen) , Streamdev, LIRC

kk234

Trainee

Posts: 115

Location: Oberhessen

  • Send private message

67

Saturday, April 24th 2004, 7:43pm

@Crue:
Wenn Du die Module aus /kernel/driver/video rausgeschmissen hast, kann es doch die Fehlermeldung oben gar nicht geben, die neuen Module sind doch im em8300-Verzeichnis. Oder hast Du die neuen CVS-Module aus dem em8300-Dir ins video-Dir kopiert?

Gruß
KK

TomSoniq

Intermediate

Posts: 160

Location: Hannover

Occupation: Ingenieur Elektronikentwicklung

  • Send private message

68

Sunday, April 25th 2004, 6:37pm

Endlich habe ich es hinbekommen, ein funktionierendes compilat vom dxr3 Plugin zu erstellen.

Meine Vorgehensweise:

0. vdr-dev installiert

1. Die Quellcodes vom vdr-plugin-dxr3-0.2.2 heruntergeladen und nach /usr/src/vdr-plugin-dxr3-0.2.2 entpackt

2. Die Quellcodes von ffmpeg 0.4.6 heruntergeladen und nach /usr/src/ffmpeg-0.4.6 entpackt

3. ffmpeg mit make compiliert -> es kommt u.a. eine 3.5MB lange libavcodec.a in /usr/src/ffmpeg-0.4.6/libavcodec dabei 'raus

4. Zum compilieren des dxr Plugins mußte ich zu einigen Tricks greifen. Es erwartet nämlich ein paar Dateien in Pfaden, in denen sie im ffmpeg Verzeichnis nicht liegen X(

5. Im Stammverzeichnis temporär durch herauskopieren aus den ffmpeg-Quellverzeichnissen folgenden Dateibaum angelegt:
/ffmpeg/common.h
/ffmpeg/ffmpeg/avcodec.h
/ffmpeg/libavcodec/libavcodec.a

6. Im dxr3 Quellverzeichnis im Makefile "FFMDIR = /ffmpeg" gesetzt

7. "make all" im dxr3 Quellverzeichnis ausgeführt -> herausgekommen ist eine 2253808 bytes lange libvdr-dxr3.so, die ich nach /usr/lib/vdr/plugins/libvdr-dxr3.so.1.2.6 kopiert habe. (Vorher natürlich eine Sicherheitskopie vom alten Plugin gemacht!)

Und: Keine Abstürze mehr beim spulen! :)

Bloß: Warum ist mein compilat ca. 10x so groß wie das Original?

Tom
In Betrieb: Serener GD-L01 mit VIA EPIA-EN15000G (passiv / 30W Betrieb / 4W Standby), Hitachi 80GB 2.5", FF: TT-DVB-S 2.3, c't-VDR 5
Reserve: Asus Pundit mit P4 1.6 GHz (sehr leise / 60W Betrieb), IBM 60 GB 2.5", FF: TT-DVB-S 1.6, Budget: TT-DVB-T 1.3, c't-VDR 5

beeblomarv

Beginner

Posts: 11

Location: Ludwigshafen

  • Send private message

69

Monday, April 26th 2004, 11:45pm

Hallo,
ich habe jetzt schon alles mögliche probiert die em8300 Treiber selbst zu kompilieren aber es bisher nicht geschafft, ich bekomme immer die Fehlermeldung:
lib/modules/2.4.24-ctvdr-2/build/include/linux/version.h: Datei oder Verzeichnis nicht gefunden

Also habe ich die Treiber aus dem Forum hier installiert, was bisher ganz gut funktioniert, bis auf das Spulen in Videos, da stürzt der Treiber regelmäßig ab.
Vielleicht könnte ja mal jemand hier seine aktuellen Treiber posten wo der aktuelle Patch mit drin ist bei dem das spulen stabiler gehen soll.
Wäre echt dankbar darüber

beeblomarv

kk234

Trainee

Posts: 115

Location: Oberhessen

  • Send private message

70

Tuesday, April 27th 2004, 8:11am

@beeblomarv:
Blätter einfach ein paar Seiten zurück :-)

Gruß
KK

beeblomarv

Beginner

Posts: 11

Location: Ludwigshafen

  • Send private message

71

Tuesday, April 27th 2004, 11:43am

Das weiter oben sind die Treiber ohne den neuen Patch! Diese Treiber stürzen bei mir ja dauernd ab beim spulen und springen in Aufnahmen.

Ich wollte mal die Treiber mit dem Patch probieren ob die bei mir stabiler laufen.

beeblomarv

Austrian Coder

Professional

Posts: 1,616

Location: Österreich

Occupation: Student

  • Send private message

72

Tuesday, April 27th 2004, 11:54am

Der Patch ist nicht für den Treiber, sonder für das vdrplugin-dxr3-0.2.2 !!!

beeblomarv

Beginner

Posts: 11

Location: Ludwigshafen

  • Send private message

73

Thursday, April 29th 2004, 1:25pm

@TomSoniq
Ich habe mir jetzt das Plugin kompiliert, wenn ich es aber durch das alte Plugin ersetze läuft die dxr3 nicht, der VDR wird andauernd neu gestartet bei dem Versuch die dxr3 zu starten.
Muss ich vielleicht noch sonst irgendwo Einstellungen machen damit es läuft?

Gruß
beeblomarv

TomSoniq

Intermediate

Posts: 160

Location: Hannover

Occupation: Ingenieur Elektronikentwicklung

  • Send private message

74

Thursday, April 29th 2004, 6:15pm

Gib doch bitte mal die letzten relevanten Zeilen, die das dmesg Kommando auswirft und die letzten relevanten Zeilen aus /var/log/messages

Tom
In Betrieb: Serener GD-L01 mit VIA EPIA-EN15000G (passiv / 30W Betrieb / 4W Standby), Hitachi 80GB 2.5", FF: TT-DVB-S 2.3, c't-VDR 5
Reserve: Asus Pundit mit P4 1.6 GHz (sehr leise / 60W Betrieb), IBM 60 GB 2.5", FF: TT-DVB-S 1.6, Budget: TT-DVB-T 1.3, c't-VDR 5

beeblomarv

Beginner

Posts: 11

Location: Ludwigshafen

  • Send private message

75

Thursday, April 29th 2004, 8:08pm

Das sind die letzten Meldungen, widerholen sich dauernd:

Apr 29 20:06:34 vdr kernel: Linux video capture interface: v1.00
Apr 29 20:06:35 vdr kernel: saa7146: register extension 'dvb'.
Apr 29 20:06:36 vdr kernel: saa7146: register extension 'budget dvb'.
Apr 29 20:06:36 vdr kernel: saa7146: register extension 'budget_ci dvb'.
Apr 29 20:06:36 vdr kernel: Linux video capture interface: v1.00
Apr 29 20:06:37 vdr kernel: saa7146: register extension 'budget dvb /w video in'.
Apr 29 20:06:37 vdr kernel: PCI: Found IRQ 12 for device 00:09.0
Apr 29 20:06:37 vdr kernel: PCI: Sharing IRQ 12 with 00:04.2
Apr 29 20:06:37 vdr kernel: skystar2.c: FlexCopII(rev.130) chip found
Apr 29 20:06:37 vdr kernel: skystar2.c: the chip has 6 hardware filters
Apr 29 20:06:37 vdr kernel: DVB: registering new adapter (Technisat SkyStar2 driver).
Apr 29 20:06:37 vdr kernel: master_xfer: read error !
Apr 29 20:06:37 vdr kernel: message 0: flags=0x0, addr=0xe, buf=0x7e, len=1
Apr 29 20:06:37 vdr kernel: message 1: flags=0x1, addr=0xe, buf=0xc2, len=1
Apr 29 20:06:37 vdr kernel: probe_tuner: try to attach to Technisat SkyStar2 driver
Apr 29 20:06:37 vdr kernel: stv0299.c: setup for tuner Samsung TBMU24112IMB
Apr 29 20:06:37 vdr kernel: DVB: registering frontend 0:0 (STV0299/TSA5059/SL1935 based)...
Apr 29 20:06:37 vdr vdr[1244]: VDR version 1.2.6 (ElchiAIO4d) started
Apr 29 20:06:37 vdr vdr[1244]: loading plugin: /usr/lib/vdr/plugins/libvdr-streamdev-server.so.1.2.6
Apr 29 20:06:37 vdr vdr[1244]: loading plugin: /usr/lib/vdr/plugins/libvdr-dxr3.so.1.2.6
Apr 29 20:06:37 vdr vdr[1244]: loading plugin: /usr/lib/vdr/plugins/libvdr-games.so.1.2.6
Apr 29 20:06:37 vdr vdr[1244]: loading /etc/vdr/setup.conf
Apr 29 20:06:37 vdr vdr[1244]: loading /etc/vdr/sources.conf
Apr 29 20:06:37 vdr vdr[1244]: loading /etc/vdr/diseqc.conf
Apr 29 20:06:37 vdr vdr[1244]: loading /etc/vdr/channels.conf
Apr 29 20:06:37 vdr vdr[1244]: loading /etc/vdr/timers.conf
Apr 29 20:06:37 vdr vdr[1244]: loading /etc/vdr/commands.conf
Apr 29 20:06:37 vdr vdr[1244]: loading /etc/vdr/reccmds.conf
Apr 29 20:06:37 vdr vdr[1244]: loading /etc/vdr/svdrphosts.conf
Apr 29 20:06:37 vdr vdr[1244]: loading /etc/vdr/ca.conf
Apr 29 20:06:37 vdr vdr[1244]: loading /etc/vdr/remote.conf
Apr 29 20:06:37 vdr vdr[1244]: loading /etc/vdr/keymacros.conf
Apr 29 20:06:37 vdr vdr[1244]: found 1 video device
Apr 29 20:06:37 vdr vdr[1244]: initializing plugin: streamdev-server (0.3.1): VDR Streaming Server
Apr 29 20:06:37 vdr vdr[1244]: initializing plugin: dxr3 (0.2.2): DXR3-MPEG decoder plugin
Apr 29 20:06:37 vdr runvdr: restarting VDR
Apr 29 20:06:45 vdr kernel: Linux video capture interface: v1.00
Apr 29 20:06:45 vdr kernel: saa7146: register extension 'dvb'.
Apr 29 20:06:46 vdr kernel: saa7146: register extension 'budget dvb'.
Apr 29 20:06:46 vdr kernel: saa7146: register extension 'budget_ci dvb'.
Apr 29 20:06:46 vdr kernel: Linux video capture interface: v1.00
Apr 29 20:06:47 vdr kernel: saa7146: register extension 'budget dvb /w video in'.
Apr 29 20:06:47 vdr kernel: PCI: Found IRQ 12 for device 00:09.0
Apr 29 20:06:47 vdr kernel: PCI: Sharing IRQ 12 with 00:04.2
Apr 29 20:06:47 vdr kernel: skystar2.c: FlexCopII(rev.130) chip found
Apr 29 20:06:47 vdr kernel: skystar2.c: the chip has 6 hardware filters
Apr 29 20:06:47 vdr kernel: DVB: registering new adapter (Technisat SkyStar2 driver).
Apr 29 20:06:47 vdr kernel: master_xfer: read error !
Apr 29 20:06:47 vdr kernel: message 0: flags=0x0, addr=0xe, buf=0x7e, len=1
Apr 29 20:06:47 vdr kernel: message 1: flags=0x1, addr=0xe, buf=0xc2, len=1
Apr 29 20:06:47 vdr kernel: probe_tuner: try to attach to Technisat SkyStar2 driver
Apr 29 20:06:47 vdr kernel: stv0299.c: setup for tuner Samsung TBMU24112IMB
Apr 29 20:06:47 vdr kernel: DVB: registering frontend 0:0 (STV0299/TSA5059/SL1935 based)...
Apr 29 20:06:47 vdr vdr[1602]: VDR version 1.2.6 (ElchiAIO4d) started
Apr 29 20:06:47 vdr vdr[1602]: loading plugin: /usr/lib/vdr/plugins/libvdr-streamdev-server.so.1.2.6
Apr 29 20:06:47 vdr vdr[1602]: loading plugin: /usr/lib/vdr/plugins/libvdr-dxr3.so.1.2.6
Apr 29 20:06:47 vdr vdr[1602]: loading plugin: /usr/lib/vdr/plugins/libvdr-games.so.1.2.6
Apr 29 20:06:47 vdr vdr[1602]: loading /etc/vdr/setup.conf
Apr 29 20:06:47 vdr vdr[1602]: loading /etc/vdr/sources.conf
Apr 29 20:06:47 vdr vdr[1602]: loading /etc/vdr/diseqc.conf
Apr 29 20:06:47 vdr vdr[1602]: loading /etc/vdr/channels.conf
Apr 29 20:06:47 vdr vdr[1602]: loading /etc/vdr/timers.conf
Apr 29 20:06:47 vdr vdr[1602]: loading /etc/vdr/commands.conf
Apr 29 20:06:47 vdr vdr[1602]: loading /etc/vdr/reccmds.conf
Apr 29 20:06:47 vdr vdr[1602]: loading /etc/vdr/svdrphosts.conf
Apr 29 20:06:47 vdr vdr[1602]: loading /etc/vdr/ca.conf
Apr 29 20:06:47 vdr vdr[1602]: loading /etc/vdr/remote.conf
Apr 29 20:06:47 vdr vdr[1602]: loading /etc/vdr/keymacros.conf
Apr 29 20:06:47 vdr vdr[1602]: found 1 video device
Apr 29 20:06:47 vdr vdr[1602]: initializing plugin: streamdev-server (0.3.1): VDR Streaming Server
Apr 29 20:06:47 vdr vdr[1602]: initializing plugin: dxr3 (0.2.2): DXR3-MPEG decoder plugin
Apr 29 20:06:47 vdr runvdr: restarting VDR

TomSoniq

Intermediate

Posts: 160

Location: Hannover

Occupation: Ingenieur Elektronikentwicklung

  • Send private message

76

Friday, April 30th 2004, 8:22am

Hmm, ok, daraus geht hervor, daß er nach der Initialisierung vom dxr3-Plugin den vdr neustartet, aber nicht, warum.

Was sagt denn dmesg?

Da müßte sowas ähnliches kommen wie:

Linux video capture interface: v1.00
DVB: registering new adapter (TT-Budget/WinTV-NOVA-T PCI).
TT-Budget/WinTV-NOVA-T PCI adapter 0 has MAC addr = 00:d0:5c:22:2e:10
tda1004x: Detected Philips TDA10045H.
tda1004x: Detected Philips TDM1316L tuner.
DVB: registering frontend 0:0 (Philips TDA10045H)...
i2c-core.o: i2c core module
i2c-algo-bit.o: i2c bit algorithm module
i2c-core.o: driver ADV717X video encoder driver registered.
em8300: EM8300 8300 (rev 1) bus: 0, devfn: 112, irq: 10, memory: 0xdc800000.
em8300: mapped-memory at 0xcef37000
em8300: using MTRR
em8300_main.o: Chip revision: 2
adv717x.o: ADV7175A chip detected
i2c-core.o: client [ADV7175A chip] registered to adapter [EM8300 I2C bus 1](pos.
0).
adv717x.o: Configuring for PAL 60
i2c-core.o: adapter EM8300 I2C bus 1 registered as adapter 0.
i2c-core.o: adapter EM8300 I2C bus 2 registered as adapter 1.
adv717x.o: Configuring for PAL
em8300_audio.o: Analog audio enabled
em8300: Microcode version 0x29 loaded
adv717x.o: Configuring for PAL
em8300_audio.o: Analog audio enabled

Bei Dir sind's wahrscheinlich am Anfang leicht andere Meldungen wegen SkyStar statt WinTV.

Tom
In Betrieb: Serener GD-L01 mit VIA EPIA-EN15000G (passiv / 30W Betrieb / 4W Standby), Hitachi 80GB 2.5", FF: TT-DVB-S 2.3, c't-VDR 5
Reserve: Asus Pundit mit P4 1.6 GHz (sehr leise / 60W Betrieb), IBM 60 GB 2.5", FF: TT-DVB-S 1.6, Budget: TT-DVB-T 1.3, c't-VDR 5

Uatschitchun

Professional

Posts: 1,524

Location: Wülfrath (NRW)

  • Send private message

77

Friday, April 30th 2004, 12:39pm

Jupsdi!

Konnte die cvs Treiber problemlos installieren ... auch das dxr3-plugin mit patch läuft gut ... !!!

Die stabilität ist wesentlich besser ... nur ... meine riesen Hoffnungen auf ein stabiles Mp3-Plugin haben sich leider immer noch nicht erfüllt ;-(

Wie gehabt kommen die "Fifo Full" Meldungen bei aktiviertem OSD des Mp3-Plugs ... und damit auch aussetzer ... zwar wesentlich weniger und seltener und auch nicht mehr so dramatisch, aber dennoch ... ;-(

Könnt ihr das bestätigen ?
Na, jedenfalls kann man nun kurzfristig das volle OSD ohne Sorge aktivieren ... der Fortschrittsbalken alleine läuft dagegen problemloser ...

Habe z.Zt. das Elchi-Theme aktiv ... werde mal auf Plain gehen und nochmal testen ...

gebe dann erneut ne Info

Lg
Roman

P.S. Habe übrigens ein Prob beim Abspielen von Net-Streams ... nach etwa 1-2 Liedern fängt der Stream an zu stottern und zu rauschen ... (366er mit ca. 10% CPU-Last) auf nem anderen Rechner läuft der Stream dagegen sauber durch ... !?
Wohnzimmer (Client 1): C't Vdr (Sarge), 2.6.15-sl, 1.4.0-2, TT-1.5 FF, Hermes 651, 40 GB, 2Ghz Celeron, 512MB, PSOne TFT
Server: C't VDR (Sid), 2.6.15-1-k7, 1.4.1-1, TT-1.6 FF, XP-2000+, 500GB, 512MB
Schlafzimmer (Client 2): MediaMVP
MediaMVP, Bose S 100, 400er Oldischlepptopp für den Garten

78

Friday, April 30th 2004, 8:20pm

Hilfe, auch bei mir ist die gepatchte dxr3-Library nicht an den Start zu bekommen.

Das Kompilieren hat noch funktioniert, wie bei TomSoniq ist auch bei mir eine vergleichsweise riesengroße Library rausgekommen. Ich wage mal zu vermuten, dass das daran liegt, dass die libavcodec statisch gelinkt wird.

ldd-Aufruf für die Original-c't-vdr-Bibliothek

vdr:/# ldd /usr/lib/vdr/plugins/libvdr-dxr3.so.1.2.6
libavcodec.so.0.4.8 => /usr/lib/libavcodec.so.0.4.8 (0x40042000)
libstdc++-libc6.2-2.so.3 => /usr/lib/libstdc++-libc6.2-2.so.3 (0x40257000)
libm.so.6 => /lib/libm.so.6 (0x402a1000)
libc.so.6 => /lib/libc.so.6 (0x402c2000)
libz.so.1 => /usr/lib/libz.so.1 (0x403df000)
libdl.so.2 => /lib/libdl.so.2 (0x403ed000)
libfaad.so.0 => /usr/lib/libfaad.so.0 (0x403f0000)
libmp3lame.so.0 => /usr/lib/libmp3lame.so.0 (0x40405000)
libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0x404c8000)
libvorbisenc.so.0 => /usr/lib/libvorbisenc.so.0 (0x404e7000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)
libogg.so.0 => /usr/lib/libogg.so.0 (0x4055b000)

Dagegen einer für die selbstkompilierte

vdr:/usr/src/dxr3-0.2.2# ldd ./libvdr-dxr3.so
libstdc++-libc6.2-2.so.3 => /usr/lib/libstdc++-libc6.2-2.so.3 (0x40252000)
libm.so.6 => /lib/libm.so.6 (0x4029b000)
libc.so.6 => /lib/libc.so.6 (0x402bd000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)

Wie man sieht, ist die libavcodec im Original dynamisch gebunden. Viel beunruhigender finde ich die ganzen anderen Bibliotheken, die im Original gelinkt sind und im Eigenbau gar nicht auftauchen.

Wie dem auch sei: Auch bei mir ergibt sich dasselbe Problem wie bei beeblomarv, vdr bleibt jetzt in einer Endlosschleife hängen. Wahrscheinlich passt das neue Plugin vorne und hinten nicht zu bestehenden System, nur was kann man dagegen tun?


Grüße,
El Greñen

79

Sunday, May 2nd 2004, 5:51pm

selbes problem wie grenjen

Hallo,

auch bei mir tritt dasselbe Problem wie bei grenjen auf.
Ein dmesg bringt bei mir folgendes zu Tage:

skystar2.c: FlexCopII(rev.130) chip found
skystar2.c: the chip has 6 hardware filters
DVB: registering new adapter (Technisat SkyStar2 driver).
probe_tuner: try to attach to Technisat SkyStar2 driver
stv0299.c: setup for tuner Samsung TBMU24112IMB
DVB: registering frontend 0:0 (STV0299/TSA5059/SL1935 based)...
skystar2.c: FlexCopII(rev.130) chip found
skystar2.c: the chip has 6 hardware filters
DVB: registering new adapter (Technisat SkyStar2 driver).
probe_tuner: try to attach to Technisat SkyStar2 driver
stv0299.c: setup for tuner Samsung TBMU24112IMB
DVB: registering frontend 0:0 (STV0299/TSA5059/SL1935 based)...
skystar2.c: FlexCopII(rev.130) chip found
skystar2.c: the chip has 6 hardware filters
DVB: registering new adapter (Technisat SkyStar2 driver).
probe_tuner: try to attach to Technisat SkyStar2 driver
stv0299.c: setup for tuner Samsung TBMU24112IMB
DVB: registering frontend 0:0 (STV0299/TSA5059/SL1935 based)...
skystar2.c: FlexCopII(rev.130) chip found
skystar2.c: the chip has 6 hardware filters
DVB: registering new adapter (Technisat SkyStar2 driver).
probe_tuner: try to attach to Technisat SkyStar2 driver
stv0299.c: setup for tuner Samsung TBMU24112IMB
DVB: registering frontend 0:0 (STV0299/TSA5059/SL1935 based)...


- Die Meldungen der DXR3 Karte erscheinen gar nicht mehr beim Neustart des VDR. Die DXR3 wurde nur beim Hochbooten 1x geladen.
Vermutlich hängt sich die Karte auf.

- Allerdings gibt der TV-Out der DXR3 ein Signal aus (die Hintergrundbeleuchtung des an die DXR3 angeschlossenen PSOne LCD geht zumindest an und bleibt auch beim Restart des VDRs an.

Auch bei mir erhalte ich die identischen Meldungen beim Aufruf von ldd wie bei grenjen auf.

Hat jemand einen Tip?

Grüße

Michael
mein VDR
[list=2]
[*]Hardware: Via Epia M10000, 80 GB Samsung, Skystar2, Hollywood+
[*]Software: c't VDR 08/04, DXR, Femon, Nvram
[/list=2]

kear

Beginner

Posts: 15

Location: Berlin

  • Send private message

80

Tuesday, May 18th 2004, 1:57am

hey Michael, oder auch kk234 :)

war auch schon total gefrustet von den dxr3 abstuerzen,..
deine step by step anleitung hat mich doch echt innerhalb von ner viertelstunde weitergebracht!
soll heissen,.. ich spiel jetzt seit 20mins im osd rum,.. habe senderlogos drin und... immer wenn´s ausschaut, als ob die dxr3 abstuerzt - faengt sie sich wieder - hip hip hurrrra! :)

also schonmal 1000 dank fuer die anleitung! :)

achja,.. zum punkt 18 - da gehoert vor dem neuladen der module noch ein depmod -a hinein,.. sonst findet modprobe sie ja nicht :)
hermes 851, 256mb, 1.7ghz celeron, hauppauge nova-t, dxr3, ctvdr (vdr 1.2.6-elfie)