You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Sunday, January 25th 2004, 6:19pm

Ankündigung: umfangreiche Updates für die c't-VDR-Distribution

Hallo,

es ist geschafft:

- das Repository ist umgebaut, zahlreiche Updates sind drin

- ein neuer Kernel ist verfügbar

- die Web-Seiten sind überarbeitet

- neue Versionen/Fixes dürften jetzt deutlich schneller kommen

Die Details verrät ein Besuch auf:

http://www.heise.de/ct/ftp/projekte/vdr/version2.shtml

Peter Siering, c't

This post has been edited 1 times, last edit by "psct" (Jan 25th 2004, 6:26pm)


alex141077

Intermediate

Posts: 149

Location: Frankfurt/Main

Occupation: Student

  • Send private message

2

Sunday, January 25th 2004, 8:21pm

Hallo,

danke für die Arbeit, das Update verlief problemlos von Tobis version, außer daß ich die AutoPID-channels.conf durch eine normale ersetzen mußte und die timers.conf löschen mußte.

Endlich ist auch analogtv drin, läuft aber nicht richtig. ich habe einmal ein analoges Programm reingekriegt, mit dem encoder "test". Das Umschalten geht, wie auf heise beschrieben, nicht. Auch der Start über einen vordefinierten Eintrag in der Setup.conf ging nur einmal, der Ton blieb jedoch hängen. Manchmal konnte ich von einem digitalen Programm auf ein analoges umschalten, der Ton kam, nicht aber das Bild und vdr hing fest.
Die Treiber sind geladen, ich bekomme mit fbtv jeden analogen sender rein.

Gruß
Alex


Asus MN378-VM / AMD Phenom II X2 / 2GB RAM /Hauppauge Nova HD-S2 / Hauppauge Nexus-S / easyVDR 0.7.10 mit xineliboutput und VDPAU

3

Sunday, January 25th 2004, 8:56pm

Quoted

Endlich ist auch analogtv drin, läuft aber nicht richtig. ich habe einmal ein analoges Programm reingekriegt, mit dem encoder "test". Das Umschalten geht, wie auf heise beschrieben, nicht. Auch der Start über einen vordefinierten Eintrag in der Setup.conf ging nur einmal, der Ton blieb jedoch hängen. Manchmal konnte ich von einem digitalen Programm auf ein analoges umschalten, der Ton kam, nicht aber das Bild und vdr hing fest.


Ähnelt den Problemen, die zum Plugin dokumentiert sind:

http://www.heise.de/ct/ftp/projekte/vdr/…/analogtv.shtml

Wie sieht es mit dem Encoder mp1e aus (ist im Plugin-Paket derzeit enthalten)?

Was für eine TV-Karte?

Peter Siering, c't

alex141077

Intermediate

Posts: 149

Location: Frankfurt/Main

Occupation: Student

  • Send private message

4

Sunday, January 25th 2004, 9:04pm

Ich habe die Pinnacle PCTV Pro. mp1e ging nicht, aber es lief wie gasagt nur ein einziges Mal mit "test". Das Problem ist auch, daß ich die Änderungen für analogtv nur in der setup.conf einstellen kann, denn wenn ich sie über das Menü einstelle, werden sie vergessen. Deshalb konnte ich die Einstellung "medium (like akool)" nicht einstellen, weil ich den dazugehürigen Eintrag in der setup.conf nicht gefunden habe.

Gruß
Alex


Asus MN378-VM / AMD Phenom II X2 / 2GB RAM /Hauppauge Nova HD-S2 / Hauppauge Nexus-S / easyVDR 0.7.10 mit xineliboutput und VDPAU

alex141077

Intermediate

Posts: 149

Location: Frankfurt/Main

Occupation: Student

  • Send private message

5

Sunday, January 25th 2004, 9:14pm

hier nochmal mein Testfeld in der channels.conf:

:Analog
SAT.1:203250:B6C0D0:C:0:160:80:0:32001:46:0:0:0
RTL:210250:B6C0D0:C:0:160:80:0:32001:12003:0:0:0
Pro7:217250:B6C0D0:C:0:160:80:0:32001:898:0:0:0

es gibt keine Fehlermeldungen aus der /var/log/syslog:

...
Jan 25 21:11:52 alex-k vdr[29405]: switching to channel 57
Jan 25 21:11:52 alex-k vdr[29414]: transfer thread started (pid=29414)


Asus MN378-VM / AMD Phenom II X2 / 2GB RAM /Hauppauge Nova HD-S2 / Hauppauge Nexus-S / easyVDR 0.7.10 mit xineliboutput und VDPAU

6

Sunday, January 25th 2004, 9:27pm

Quoted

Das Problem ist auch, daß ich die Änderungen für analogtv nur in der setup.conf einstellen kann, denn wenn ich sie über das Menü einstelle, werden sie vergessen.


Über das VDR-"Haupt-"menü ist das Nichtspeichern dokumentiert, glaube ich. Wie ist es über Einstellungen, Plugins aus? Wird da auch nichts gesichert?

Ich hab mal alle analogtv-bezogenen Einträge aus der setup.conf eines Testsystems angehängt.

Peter
psct has attached the following file:

alex141077

Intermediate

Posts: 149

Location: Frankfurt/Main

Occupation: Student

  • Send private message

7

Sunday, January 25th 2004, 9:48pm

so, jetzt hat es wieder EINmal geklappt. Ich konnte sogar per FB auf einen analogen Kanal schalten (der dann allerdings nicht der richtige war). Nach einem Reboot wieder nix...
Doch, jetzt... Auf Sat1 umgeschaltet, RTL kam. Das zurückschalten ging jetzt ein paar mal auf Radiosender (ohne daß der analoge Ton verschwand); als ich auf einen TV-Sender schalten wollte, hängte er sich eben wieder auf. Die Einträge in der setup.conf verändern sich aber nicht von selbst.


Asus MN378-VM / AMD Phenom II X2 / 2GB RAM /Hauppauge Nova HD-S2 / Hauppauge Nexus-S / easyVDR 0.7.10 mit xineliboutput und VDPAU

8

Sunday, January 25th 2004, 9:49pm

RE: Ankündigung: umfangreiche Updates für die c't-VDR-Distribution

hi ho

Ich glaube da ist ein kleiner Fehler.
Das vdr-plugin-mplayer in elchiimposdac3, bringt den vdr immer nur zum restarten.

Aber sonst echt gut gemacht!!! Ein fettes Danke.

GRUSS
WWW-KR
AMD Athlon 64 X2 4600+, FSC D2461.A1 nForce4, 4GB Kingston,
OCZ Vertex Plus 30GB OS, Samsung SpinPoint F4 EcoGreen 2TB, LG GSA-H30N, Hauppauge NEXUS-s Rev.2.2
c't VDR 7 Upgrade auf
Squeeze und e-Tobi mit div. Plugin's und Server-Diensten & Hauppauge MediaMVP

alex141077

Intermediate

Posts: 149

Location: Frankfurt/Main

Occupation: Student

  • Send private message

9

Sunday, January 25th 2004, 9:53pm

Ah, da ist was im syslog:

root@alex-k:~$ !tail
tail -f /var/log/syslog
Jan 25 21:52:41 alex-k vdr[843]: analogTV: setPictureProperties(brightness=18 (52.9%), contrast=14 (41.2%), colour=16 (47.1%), hue=15 (44.1%))
Jan 25 21:52:41 alex-k vdr[843]: analogTV: tune(3252) [frequency=203250, freqOffset=16, ofs=0]
Jan 25 21:52:41 alex-k vdr[843]: analogTV: setNorm() does not support V4L - Sorry
Jan 25 21:52:41 alex-k vdr[843]: analogTV: setNorm(0:PAL (0xff))
Jan 25 21:52:41 alex-k vdr[843]: analogTV: Switching to channel 55 on device 4
Jan 25 21:52:41 alex-k vdr[843]: analogTV: cAnalogtvDevice::SetPid(Pid=160, handle=-1, used=1, Type=5, On=1)
Jan 25 21:52:41 alex-k vdr[843]: analogTV: SetPid(Type=5, On=1, Pid=160), havePCR=1
Jan 25 21:52:41 alex-k vdr[843]: analogTV: cAnalogtvDevice::SetPid(Pid=80, handle=-1, used=1, Type=6, On=1)
Jan 25 21:52:41 alex-k vdr[843]: analogTV: SetPid(Type=6, On=1, Pid=80), havePCR=1
Jan 25 21:52:41 alex-k vdr[1116]: transfer thread started (pid=1116)


Asus MN378-VM / AMD Phenom II X2 / 2GB RAM /Hauppauge Nova HD-S2 / Hauppauge Nexus-S / easyVDR 0.7.10 mit xineliboutput und VDPAU

10

Sunday, January 25th 2004, 9:53pm

Quoted

Doch, jetzt... Auf Sat1 umgeschaltet, RTL kam. Das zurückschalten ging jetzt ein paar mal auf Radiosender (ohne daß der analoge Ton verschwand); als ich auf einen TV-Sender schalten wollte, hängte er sich eben wieder auf.


Das entspricht dem Fehlerbild, das mir auch sattsam bekannt ist. Andreas Kool hat mir eine paar Tipps zum Debuggen gegeben, da mache ich mich jetzt mal dran. Sollte sich daraus ein Update ergeben, kündige ich es an. Danke soweit.

Quoted

Die Einträge in der setup.conf verändern sich aber nicht von selbst.


Verstehe ich jetzt nicht: Auch beim Ändern über Einstellungen, Plugins lassen sich keine Änderungen an der Konfiguration vornehmen? (Ggf. mal den Blauen-Knopf drücken, dann geht auch die Einstellungen auf "Lieferzustand" zurück.)

Peter

11

Sunday, January 25th 2004, 9:55pm

RE: Ankündigung: umfangreiche Updates für die c't-VDR-Distribution

Quoted

Das vdr-plugin-mplayer in elchiimposdac3, bringt den vdr immer nur zum restarten.


Ein Link auf das DVD-Laufwerk existiert? Was gibt ls -l /dev/dvd aus? In /var/log/messages müsste ein Hinweis stehen ...

Peter

alex141077

Intermediate

Posts: 149

Location: Frankfurt/Main

Occupation: Student

  • Send private message

12

Sunday, January 25th 2004, 9:59pm

nein, ich meinte damit, daß obwohl es mal klappt, mal nicht, die analogtv-einträge in der setup.conf nicht von der Software verändert werden. (Von mir auch nicht).

Gruß
Alex


Asus MN378-VM / AMD Phenom II X2 / 2GB RAM /Hauppauge Nova HD-S2 / Hauppauge Nexus-S / easyVDR 0.7.10 mit xineliboutput und VDPAU

13

Sunday, January 25th 2004, 10:13pm

RE: Ankündigung: umfangreiche Updates für die c't-VDR-Distribution

Quoted

Ein Link auf das DVD-Laufwerk existiert? Was gibt ls -l /dev/dvd aus? In /var/log/messages müsste ein Hinweis stehen ...


Ich habe kein DVD-Laufwerk eingebaut. Brauche ich es, es sollte doch auch ohne laufen?
/dev/dvd existiert gar nicht. Für das abspielen von mp3 und DivX brauche ich theoretisch nur ein CD-ROM und dafür dann mPlayer. Habe ich etwas falsch bisher verstanden mit mp3, DivX und mPlayer?

2. Frage: Der neue Kernel enthält nur die Standard-Gerätetreiber? Ich habe hier ein System mit i845GV Board und kleine Probleme mit Abspielen der Aufzeichnungen. Ich habe gehofft durch entsprechende Treiber das Problem zu beseitigen.

GRUSS
WWW-KR
AMD Athlon 64 X2 4600+, FSC D2461.A1 nForce4, 4GB Kingston,
OCZ Vertex Plus 30GB OS, Samsung SpinPoint F4 EcoGreen 2TB, LG GSA-H30N, Hauppauge NEXUS-s Rev.2.2
c't VDR 7 Upgrade auf
Squeeze und e-Tobi mit div. Plugin's und Server-Diensten & Hauppauge MediaMVP

14

Sunday, January 25th 2004, 10:26pm

Hi!

soweit lief bei mir alles klar, aber nach dem Kernelupdate (incl. modules) liefert die Hollywood-Karte nur noch Ton und kein Bild:

Quoted


Jan 25 22:19:31 vdr kernel: em8300_video: mpegvideo_command(0x11) failed
Jan 25 22:19:31 vdr kernel: i2c-core.o: client [ADV7170 chip] unregistered.
Jan 25 22:19:31 vdr kernel: i2c-core.o: driver unregistered: ADV717X video encoder driver
Jan 25 22:19:31 vdr insmod: /lib/modules/2.4.23-ctvdr-1/kernel/drivers/video/em8300.o: post-install em8300 failed
Jan 25 22:19:31 vdr insmod: /lib/modules/2.4.23-ctvdr-1/kernel/drivers/video/em8300.o: insmod char-major-121 failed
Jan 25 22:19:32 vdr kernel: em8300_audio.o: Analog audio enabled
Jan 25 22:19:32 vdr kernel: em8300: Microcode version 0x29 loaded
Jan 25 22:19:33 vdr kernel: em8300_audio.o: Analog audio enabled
Jan 25 22:19:33 vdr vdr[531]: cDxr3AbsDevice::Resuscitation Device failure detected


Was läuft da falsch? Zwischenzeitlich hatte ich mich klassisch aus dem VDR-Ausgesperrt, aber das ist eine andere Geschichte....

Gruß,
Björn
VDR: ct-Distri mit VDR 1.41 (Tobi), dxr-plugin 2.5.2, Asus A7V133-Board mit AMD Athlon 900 512 MB Ram, 320 Gig HD DVB-S Budget-Karte und Hollywood+ DXR3-Ausgabe

15

Sunday, January 25th 2004, 10:57pm

RE: Ankündigung: umfangreiche Updates für die c't-VDR-Distribution

Quoted

Ich habe kein DVD-Laufwerk eingebaut. Brauche ich es, es sollte doch auch ohne laufen?
/dev/dvd existiert gar nicht. Für das abspielen von mp3 und DivX brauche ich theoretisch nur ein CD-ROM und dafür dann mPlayer. Habe ich etwas falsch bisher verstanden mit mp3, DivX und mPlayer?


Das Plugin braucht aber eine "Adresse", an die es sich wenden kann. Einfach mal einen Link anlegen, etwa ln -s /dev/hdc /dev/dvd - wenn das CD-Laufwerk auf /dev/hdc hängt. Zum Ansehen von auf der Platte angelegten Image-Dateien eignet sich im Zusammenspiel mit dem DVD-Plugin das dvdselect-Plugin - es kann zwischen Image-Dateien (und Laufwerk) wechseln.

Quoted

2. Frage: Der neue Kernel enthält nur die Standard-Gerätetreiber? Ich habe hier ein System mit i845GV Board und kleine Probleme mit Abspielen der Aufzeichnungen. Ich habe gehofft durch entsprechende Treiber das Problem zu beseitigen.


Ja nur die Treiber, die dazu gehören. Ist Platten-DMA an (hdparm /dev/hda verrät das)?

Peter

16

Sunday, January 25th 2004, 10:59pm

Quoted

soweit lief bei mir alles klar, aber nach dem Kernelupdate (incl. modules) liefert die Hollywood-Karte nur noch Ton und kein Bild:


Das mitgeschickte log war leider sehr knapp. Kann es sein, dass die Karte spezielle Parameter in /etc/modutils/em8300 gebraucht hat, die durchs Updaten flöten gegangen sind? Sollte sie nicht, aber ...

Peter

17

Sunday, January 25th 2004, 11:03pm

Ich habe inzwischen mal das übliche "Zeilenausprobierspiel" in der /etc/modutils/em8300 wiederholt, die entsprechenden Einstellungen waren tatsächlich nicht da.

Aber das Bild ist quasi das gleiche - jede andere als die bisherige /etc/modutils/em8300- Einstellung liefert ein grünes Bild. nur mit dem Unterschied, dass die "richtige" Variante *kein* Bild liefert...


Hmpf.

Gruß,
Björn
VDR: ct-Distri mit VDR 1.41 (Tobi), dxr-plugin 2.5.2, Asus A7V133-Board mit AMD Athlon 900 512 MB Ram, 320 Gig HD DVB-S Budget-Karte und Hollywood+ DXR3-Ausgabe

18

Sunday, January 25th 2004, 11:16pm

Quoted

Aber das Bild ist quasi das gleiche - jede andere als die bisherige /etc/modutils/em8300- Einstellung liefert ein grünes Bild. nur mit dem Unterschied, dass die "richtige" Variante *kein* Bild liefert...


Mit dem alten Kernel gebootet geht es? Welche VDR-Variante?

Einfach mal vollständige Logs an unserer Bug-Adresse abladen - vielleicht fällt mir noch was anderes auf ...

Peter

19

Sunday, January 25th 2004, 11:17pm

Ah, jetzt gehts wieder, die auszukommentierenden Zeilen in der em8300 waren nicht *ganz* die selben.

Eine Kombination hatte ich vorhin übersehen, et voilá....


?(

Gruß,

Björn
VDR: ct-Distri mit VDR 1.41 (Tobi), dxr-plugin 2.5.2, Asus A7V133-Board mit AMD Athlon 900 512 MB Ram, 320 Gig HD DVB-S Budget-Karte und Hollywood+ DXR3-Ausgabe

20

Sunday, January 25th 2004, 11:31pm

RE: Ankündigung: umfangreiche Updates für die c't-VDR-Distribution

Quoted

Das Plugin braucht aber eine "Adresse", an die es sich wenden kann. Einfach mal einen Link anlegen, etwa ln -s /dev/hdc /dev/dvd - wenn das CD-Laufwerk auf /dev/hdc hängt. Zum Ansehen von auf der Platte angelegten Image-Dateien eignet sich im Zusammenspiel mit dem DVD-Plugin das dvdselect-Plugin - es kann zwischen Image-Dateien (und Laufwerk) wechseln.


Ich habe den Link richtig gesetzt, nun bekomme ich folgenden Meldng in der /var/log/messages

Jan 25 23:12:30 VDR vdr[17578]: initializing plugin: mplayer (0.8.2): A MPlayer calling plugin
Jan 25 23:12:30 VDR runvdr: stopping after fatal fail (No source(s) defined in mplayersources.conf)



Quoted

Ja nur die Treiber, die dazu gehören. Ist Platten-DMA an (hdparm /dev/hda verrät das)?


Ist gesetzt:
/dev/hda:
multcount = 16 (on)
I/O support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
nowerr = 0 (off)
readonly = 0 (off)
readahead = 8 (on)
geometry = 4870/255/63, sectors = 78242976, start = 0
busstate = 1 (on)

Ich beschreibe mal kurz das Problem. Wenn ich eine Aufnahme abspiele kommt irgendwann der Moment, wo das Bild für eine Bruchteil einer Sekunde in Klötze zerlegt wird und von da an ist Bild und Ton nicht mehr synchron. Ist ca. 1. bis 2. Sekunden Unterschied zwischen Bild und Ton. Jedoch ist die Aufnahme nicht beschädigt. Ich spule einfach bis kurz vor der besagten Stelle und spiele nochmal ab und der Fehler wiederholt sich nicht an der Stelle, sonder irgendwann später wieder. Wie gesagt Aufnahme ist nach Prüfung OK.

Ich hatte vorher eine i815 basiertes Testsystem und dort kam der Fehler nicht vor. Mir ist aber aufgefallen, dass bei lspci alles Intel unbekannt ist. Beim i815 war ihm mehr bekannt. Dort vermute ich den Fehler.

00:00.0 Host bridge: Intel Corp.: Unknown device 2560 (rev 01)
00:02.0 VGA compatible controller: Intel Corp.: Unknown device 2562 (rev 01)
00:1d.0 USB Controller: Intel Corp.: Unknown device 24c2 (rev 01)
00:1d.1 USB Controller: Intel Corp.: Unknown device 24c4 (rev 01)
00:1d.2 USB Controller: Intel Corp.: Unknown device 24c7 (rev 01)
00:1d.7 USB Controller: Intel Corp.: Unknown device 24cd (rev 01)
00:1e.0 PCI bridge: Intel Corp. 82820 820 (Camino 2) Chipset PCI (rev 81)
00:1f.0 ISA bridge: Intel Corp.: Unknown device 24c0 (rev 01)
00:1f.1 IDE interface: Intel Corp.: Unknown device 24cb (rev 01)
00:1f.3 SMBus: Intel Corp.: Unknown device 24c3 (rev 01)
00:1f.5 Multimedia audio controller: Intel Corp.: Unknown device 24c5 (rev 01)
02:01.0 Ethernet controller: Linksys Network Everywhere Fast Ethernet 10/100 model NC100 (rev 11)
02:05.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)

GRUSS
WWW-KR
AMD Athlon 64 X2 4600+, FSC D2461.A1 nForce4, 4GB Kingston,
OCZ Vertex Plus 30GB OS, Samsung SpinPoint F4 EcoGreen 2TB, LG GSA-H30N, Hauppauge NEXUS-s Rev.2.2
c't VDR 7 Upgrade auf
Squeeze und e-Tobi mit div. Plugin's und Server-Diensten & Hauppauge MediaMVP