Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Gerd Peter

Fortgeschrittener

  • »Gerd Peter« ist der Autor dieses Themas

Beiträge: 230

Wohnort: Nordhessen

Beruf: Admin

  • Nachricht senden

1

Samstag, 12. November 2011, 13:02

HDTV mit der TT-6400 und Debian wheezy

HI,

möchte kurz berichten wie das bei mir mit Debian wheezy gelaufen ist.
Gleich vorweg: NICHT GUT!
Ich möchte ein Debian VDR System mit TT-6400, Bidausgabe direkt über die FF Karte zum TV und dabei möchte ich möglichst WENIG selbst übersetzen müssen, also möglichst viel aus dem repository holen (zB: e-tobi).
Die wichtigsten Quellen für mich sind das Howto aus dem vdr-wiki und einige hier im Forum.
Die Leidensgeschichte ist hier im Forum beschrieben.

Aber der Hauptgrund für den Post ist mitzuteilen was wohl bei wheezy alles noch NICHT geht:
Die Installation der Treiber bzw. das übersetzen der Module (wie im oben benannten vdr-wiki) brach zuerst mit error ab, erst mit dem nochmaligen Beginn der Installation ab dem Abschnitt Aktualisieren der DVB Treiber lief das bei mir durch.

Die Installation des dvbhddevice ist wirklich furchtbar!
Hier im forum wird an verschiedenen stellen von "debianize-vdrplugin" geschrieben. Super Sache, wenn's gehen würde. Jetzt ist nämlich in wheezy das nötige Paket dh_make zu neu :wow und passt nicht mehr :wand

Ich habe das Paket dh_make wieder deinstalliert und die ältere Version von hier runter geladen und neu installiert (dpkg -i mäßig)
Hier stehen weitere fummel Lösungen

Das original aus den repositories installierte runvdr script passt nicht zur wheezy Umgebung und führt zu folgendem " Syntax error: "(" unexpected" Fehler:

Quellcode

1
2
3
4
5
6
root@vdr:/etc/modprobe.d# /usr/sbin/runvdr
/usr/sbin/runvdr: 31: /usr/sbin/runvdr: Syntax error: "(" unexpected
root@vdr:/etc/modprobe.d# vim /usr/sbin/runvdr
root@vdr:/etc/modprobe.d# /usr/sbin/runvdr
root@vdr:/etc/modprobe.d# /etc/init.d/vdr stop
Sto


hier muss man aus der Startzeile

Quellcode

1
#!/bin/sh  =>  #!/bin/bash

machen. Dann läuft runvdr durch.

Nicht vergessen die Startscripte unter /etc/default/vdr zu aktivieren:

Quellcode

1
2
# Change to 1 to enable vdr's init-script
ENABLED=0 ändern in ENABLED=1


E D I T 13.11.11:
Das folgende darf in mein Debian whezzy NICHT rein, sonst startet der Treiber nach einem Neustart nicht mehr!
Mit nicht vorhandener "saa716x..." blacklist ist er durchgestartet!
Ich werde diese Zeilen und folgende morgen raus löschen (macht doch mehr Sinn oder?)
Dann habe ich an vielen Stellen gelesen, mann solle:

Quellcode

1
2
echo "blacklist saa716x_ff" > /etc/modprobe.d/blacklist-saa716x_ff.conf
echo "blacklist ?dvbtstick?" > /etc/modprobe.d/blacklist-?dvbtstick?.conf


EDIT2 13.11.11:
Ich werde jetzt auch noch testen, was passiert, wenn ich folgendes in der runvdr einfach weglasse, sprich, die runvdr - bis auf die erste Zeile - so lasse wie sie original war.

und in die //usr/sbin/runvdr:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
function LoadDriver()
{
  sleep 5
  modprobe saa716x_ff int_type=1
  sleep 5
  modprobe ?dvbtstick?
  return 0
}
function UnloadDriver()
{
  sleep 5
  modprobe -r saa716x_ff
  sleep 5
  modprobe -r ?dvbtstick?
  sleep 5
  return 0
}

eintragen. Das habe ich gemacht und damit läuft Debian wheezy jetzt in der Grundinstallation auch, VDR-Live läßt mich auch schon "fernbedienen" Lirc kommt als nächstes ...
Finde ich zur Zeit so noch etwas abschreckend - oder :rolleyes:

Ach ja, das sage ich vor allem zu mir selbst: wenn man so viele Stunden investiert hat, um endlich wieder bewegte Bilder auf dem Schirm zu haben, dann ist als nächstes Clonezilla und eine externe Festplatte mein nächster Freund!

Grüße,
gerd
yaVDR 0.4 virtualisiert unter Proxmox mit TT S-2 6400

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Gerd Peter« (13. November 2011, 01:27) aus folgendem Grund: EDIT weil die blacklist Geschichte ersatzlos gestrichen werden muss


2

Samstag, 12. November 2011, 14:21

Wart's ab. Das war mit Sicherheit nur eine Kleinigkeit. Früher oder später hast du dich da reingefunden und es läuft.
VDR4Arch --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | Digital Devices Cine S2 V6 | ZOTAC GT630 (Rev. 2) Zone Edition

3

Samstag, 12. November 2011, 14:22

Debian testing (wheezy) zu benutzen, ist keine gute Idee. Es sei denn, man ist bugs auf der Spur und möchte helfen, debian zu verbessern.
Für stabile Systeme nimmst du besser unstable (sid), wenn du sehr aktuell sein willst. Oder konservativ, aber sehr stabil squeeze.

4

Samstag, 12. November 2011, 16:07


Das original aus den repositories installierte runvdr script passt nicht zur wheezy Umgebung und führt zu folgendem " Syntax error: "(" unexpected" Fehler:

Quellcode

1
2
3
4
5
root@vdr:/etc/modprobe.d# /usr/sbin/runvdr
/usr/sbin/runvdr: 31: /usr/sbin/runvdr: Syntax error: "(" unexpected
root@vdr:/etc/modprobe.d# vim /usr/sbin/runvdr
root@vdr:/etc/modprobe.d# /usr/sbin/runvdr
root@vdr:/etc/modprobe.d# /etc/init.d/vdr stop


hier muss man aus der Startzeile

Quellcode

1
#!/bin/sh  =>  #!/bin/bash

machen. Dann läuft runvdr durch.


Das Problem gibts aber auch schon bei Debian stable und es wundert mich das du darauf gestossen bist. Weil, entweder e-tobi hat dafür nen Patch im Paket (weil die Pakete für stable sind) oder diese Datei wird garnicht benutzt.

Edit, Nachgeschaut: Die orgniale VDR runvdr wird bei e-tobi garnicht benutzt. Wie kommst du da jetzt überhaupt ran? Mit dieser Datei hast du eigentlich überhaupt nix zu tun.


Aber evtl. sollte das wirklich mal jemand auf der VDR ML melden. Ist nen Fehler der sich schnell beheben lässt (entweder das Script Posix kompertibel machen oder bash vorraussetzen).

cu

Mein VDR

Mein VDR
Digitainer2xBouget DVB-SDebian Squeeze (Kernel 2.6.35.3 von kernel.org)Softdevice Ausgabepluginvdr 1.6.0-3 (Extensions Patch 72) und viele Plugins von SourceMedion X10 FernbedienungSDC-Megtron Display (240x128x1) mit GraphLCD-PluginFreevo 1.9.0
Vodcatcher Helper in ein freundliches DEB verpackt, Tester Willkommen: http://dl.dropbox.com/s/705bh6ydgisfrqu/index.htmlFingerprint: 8A104A00D5031773A9F72A19BAEE135EA7860149

Gerd Peter

Fortgeschrittener

  • »Gerd Peter« ist der Autor dieses Themas

Beiträge: 230

Wohnort: Nordhessen

Beruf: Admin

  • Nachricht senden

5

Sonntag, 13. November 2011, 00:38

Zitat

Das Problem gibts aber auch schon bei Debian stable und es wundert mich das du darauf gestossen bist. Weil, entweder e-tobi hat dafür nen Patch im Paket (weil die Pakete für stable sind) oder diese Datei wird garnicht benutzt.
Edit, Nachgeschaut: Die orgniale VDR runvdr wird bei e-tobi garnicht benutzt. Wie kommst du da jetzt überhaupt ran? Mit dieser Datei hast du eigentlich überhaupt nix zu tun.
Aber evtl. sollte das wirklich mal jemand auf der VDR ML melden. Ist nen Fehler der sich schnell beheben lässt (entweder das Script Posix kompertibel machen oder bash vorraussetzen).
cu

1:
Ja, und das Problem gibt es ebenfalls bei Ubuntu. Daher kannte ich das bereits, weil ich zuerst (fast) genau nach vdr-wiki vorgegangen war - hier gab's den gleichen Fehler.
Verstehe ich auch nicht, warum sich diese Inkompatibilität sh zu bash so durch die Systeme zieht ....???
2:
Wie kommst du darauf, dass ich nichts mit der runvdr zu tun habe müsste?
Die wird doch im startscript aufgerufen:

Quellcode

1
2
3
root@vdr:~# cat /etc/init.d/vdr | grep runvdr
DAEMON=/usr/sbin/runvdr
PIDFILE=/var/run/runvdr.pid

Und wenn ich "sh" lasse => kein VDR kein buntes Bild, wenn ich auf "bash" umstelle => VDR Start und bewegte Bilder am TV ;-)
Muss also irgendein Zusammenhang bestehen.
Oder kann es sein, dass wir gerade exakt aneinander vorbei posten ...? In meiner wheezy sources.list is' nix von e-tobi. Alles original von und für wheezy, die aber wiederum auch von e-tobi betreut werden.
Das hier sinddoch die Macher um c'tvdr und e-tobi oder? Andere wheezy <-> e-tobi superaktuell Pakete gibt es zZ nicht.


Zitat

Debian testing (wheezy) zu benutzen, ist keine gute Idee. Es sei denn, man ist bugs auf der Spur und möchte helfen, debian zu verbessern.
Für stabile Systeme nimmst du besser unstable (sid), wenn du sehr aktuell sein willst. Oder konservativ, aber sehr stabil squeeze.


So viele Linux Distries wie es auf dem Markt gibt, so vielseitig sind die Meinungen der user 8)
Will sagen: ich sehe das nicht ganz so. Klar für Produktive / Kritische Systeme Stable - keine Frage. Ansonsten habe ich auf meinen Desktop Maschinen immer gerne etwas früher so manche aktuelleren Pakete.
Als ich das damals vor gefühlten 20 Jahren ?( mit squeeze gemacht habe, war das einzige, was nicht von Anfang an genug stabil lief, die nagelneue KDE 4 Oberfläche. Die hat wirklich genervt. Da konnte aber squeeze nix dafür.
Ich selbst habe bisher die Erfahrung gemacht, dass Debian Testing locker mit neuen Ubuntus und Suses, die als stabil auf den Markt kommen (die ich alle grundsätzlich okay finde), mithalten kann.

Trotzdem denke ich inzwischen, dass squeeze vielleicht doch die bessere Wahl gewesen wäre, einfach weil es hier die super Unterstützung durch e-tobi gibt und insgesamt bezüglich VDR viel mehr Erfahrung vor liegt.
Ich bin aber guter Hoffnung, dass das alles mit wheezy auch bald kommt (e-tobi hau rein ;-) Mein Hauptgrund für wheezy war auch ein anderer: meine Logik war ganz einfach die, dass ich dachte, je neuer das System, desto
eher bekomme ich die TT-6400 Firmware module und dvdhddevice an den Start. Und ich habe bisher überhaupt keine einzige direkte im Internet beschriebene Lösung gefunden, die aus irgendwelchen repositories ein VDR
HD System aufbaut, mit der TT-6400 und direktem abgreifen des Streams (ohne vdpau oder vergleichbares ). Jetzt weiß ich aber, dass es wundersamerweise gerade mit yaVDR funktionieren soll. Habe ich da was übersehen oder warum kommt das so wenig aus dem c'tvdr Lager? Die machen wohl zZ alle Mutterschaftsurlaub :mua

Grüße,

Gerd
yaVDR 0.4 virtualisiert unter Proxmox mit TT S-2 6400

Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von »Gerd Peter« (13. November 2011, 01:46)


6

Sonntag, 13. November 2011, 09:28

Verstehe ich auch nicht, warum sich diese Inkompatibilität sh zu bash so durch die Systeme zieht ....???


Das ist ja keine inkompatibilität sondern ein Fehler in der runvdr.

"/bin/sh" zeigt auf die Systemshell (welche das auch immer gerade zufällig ist), nutzt man bash Befehle im Script sollte man direkt auf "/bin/bash" zeigen und sich nicht darauf verlassen das /bin/sh zufällig bash ist.
https://wiki.ubuntu.com/DashAsBinSh

Wie kommst du darauf, dass ich nichts mit der runvdr zu tun habe müsste?
Die wird doch im startscript aufgerufen:

Quellcode

1
2
3
root@vdr:~# cat /etc/init.d/vdr | grep runvdr
DAEMON=/usr/sbin/runvdr
PIDFILE=/var/run/runvdr.pid

Und wenn ich "sh" lasse => kein VDR kein buntes Bild, wenn ich auf "bash" umstelle => VDR Start und bewegte Bilder am TV ;-)
Muss also irgendein Zusammenhang bestehen.
Oder kann es sein, dass wir gerade exakt aneinander vorbei posten ...? In meiner wheezy sources.list is' nix von e-tobi. Alles original von und für wheezy, die aber wiederum auch von e-tobi betreut werden.


Ach so, ich dachte du nutzt e-Tobi und ich hatte nur dort im Paket nachgeschaut. e-Tobi nutzt ne eigene runvdr im VDR Paket.

Wobei ich jetzt auch nicht kapiere warum es e-Tobi UND Debian VDR Pakete gibt (die sich im Aufbau auch unterscheiden) wenn da eh die selben Betreuer hintestehen.

Habe ich da was übersehen oder warum kommt das so wenig aus dem c'tvdr Lager? Die machen wohl zZ alle Mutterschaftsurlaub :mua


Um mal etwas gehässig zu sein... Der Kram für die TT-6400 hat in stable ja noch nix verloren (den Threads nach zu urteilen die man hier so sieht) ;)

Das dvbhddevice Plugin (ist ja speziell für die TT-6400) gehört ja zum VDR selber, das müsste nur im VDR Paket aktiviert werden dann hätte man auch bei e-Tobi das dvbhddevice Pluginpaket, aber dann hätte man vermutlich ne Buildabhängigkeit vom TT-6400 Treiber.

Für den TT-6400 Treiber bräuchte man nur nen DKMS Paket (das wäre auch die Vorraussetzung um das dvbhddevice Pluginpaket anbieten zu können), keine grosse Sache, da hatte vermutlich einfach noch niemand Lust.

cu

Mein VDR

Mein VDR
Digitainer2xBouget DVB-SDebian Squeeze (Kernel 2.6.35.3 von kernel.org)Softdevice Ausgabepluginvdr 1.6.0-3 (Extensions Patch 72) und viele Plugins von SourceMedion X10 FernbedienungSDC-Megtron Display (240x128x1) mit GraphLCD-PluginFreevo 1.9.0
Vodcatcher Helper in ein freundliches DEB verpackt, Tester Willkommen: http://dl.dropbox.com/s/705bh6ydgisfrqu/index.htmlFingerprint: 8A104A00D5031773A9F72A19BAEE135EA7860149

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Keine_Ahnung« (13. November 2011, 09:51)


Gerd Peter

Fortgeschrittener

  • »Gerd Peter« ist der Autor dieses Themas

Beiträge: 230

Wohnort: Nordhessen

Beruf: Admin

  • Nachricht senden

7

Sonntag, 13. November 2011, 11:48

Hi Keine_Ahnung


Zitat

Um mal etwas gehässig zu sein... Der Kram für die TT-6400 hat in stable ja noch nix verloren (den Threads nach zu urteilen die man hier so sieht) ;)

Dass das so ist wie es ist, hat mich jetzt auch sehr überrascht, ich hatte extra mit dem Kauf noch mal 'nen 1/4 Jahr gewateter und dachte jetzt brauch' ich's nur noch zu installieren fertig.

Zitat

Für den TT-6400 Treiber bräuchte man nur nen DKMS Paket (das wäre auch die Vorraussetzung um das dvbhddevice Pluginpaket anbieten zu können), keine grosse Sache, da hatte vermutlich einfach noch niemand Lust.

Ist ja auch bald Weihnachten, da darf man sich was wünschen ...
Grüße
gp
yaVDR 0.4 virtualisiert unter Proxmox mit TT S-2 6400

8

Sonntag, 13. November 2011, 12:50

So viele Linux Distries wie es auf dem Markt gibt, so vielseitig sind die Meinungen der user 8)
Will sagen: ich sehe das nicht ganz so. Klar für Produktive / Kritische Systeme Stable - keine Frage. Ansonsten habe ich auf meinen Desktop Maschinen immer gerne etwas früher so manche aktuelleren Pakete.
Als ich das damals vor gefühlten 20 Jahren ?( mit squeeze gemacht habe, war das einzige, was nicht von Anfang an genug stabil lief, die nagelneue KDE 4 Oberfläche. Die hat wirklich genervt. Da konnte aber squeeze nix dafür.
Ich selbst habe bisher die Erfahrung gemacht, dass Debian Testing locker mit neuen Ubuntus und Suses, die als stabil auf den Markt kommen (die ich alle grundsätzlich okay finde), mithalten kann.


Ich wollte dir damit eigentlich nur sagen, dass der testing Zweig nicht soviel Spass macht, denn fehlerhafte Pakete, die es irgendwie in testing geschafft haben brauchen oft sehr lange, bis sie ersetzt werden.
Bei unstable geht es am schnellsten, da dort ständig neue Stände einfließen. Ubuntu zum Beispiel wird aus unstable gemacht. Auch finde ich nicht, dass testing sehr aktuell ist. Du kannst natürlich nehmen was
du möchtest aber ich denke, dass du bei deinem Vorhaben mit unstable besser bedient bist. Meines Wissens bedeutet unstable nicht unbedingt instabil, sondern vielmehr, auf die Debian Philosophie bezogen, das "nicht stable" release.
Wenn ich falsch liege, möge mich jemand korriegieren. Ich habe früher jahrelang unstable benutzt, es war für mich aber immer alles andere als instabil.

Gruß

9

Sonntag, 13. November 2011, 13:06

Danke für Dein Feedback. Ich plane selbst in nächster zeit einen HDTV - FF - VDR auf Debainbasis.
Frage mich noch, ob Stable oder Sid (aptosid) die bessere Wahl ist.

Wäre schön, wenn DU am Ende die wichtigsten Schritte und Hürden in einem kleinen Anleitungsweeg (how to) hier im Forum reinstellen könntest.
Danke!

Gerd Peter

Fortgeschrittener

  • »Gerd Peter« ist der Autor dieses Themas

Beiträge: 230

Wohnort: Nordhessen

Beruf: Admin

  • Nachricht senden

10

Sonntag, 13. November 2011, 13:17

Hi Lanzi,

Schau bitte mal hier

so wie zur Zeit die Unterstützung für wheezy ist, halte ich meinen Test mit wheezy eher für nicht empfehlenswert.
Entweder tut sich da was, dass die, die es wirklich verstehen was bauen oder ...man geht zu den Alternativen
Ich würde jetzt bei Debian eher squeeze ausprobieren ... Jetzt warte ich mal 'nen paar Tage ab und überlege ... Dann stecke ich mal ne ander Festplatte in den VDR und probiere obiges
EDITF: 13.12.2011

"mini-howto-s2-6400-mit-ubuntu-natty-11-04-und-yavdr-0-4-paketen" einfach mal aus.
so lange es kein ctvdr tt-S2-6400 Lösung gibt:
Die zur Zeit einfachste Lösung, die ich bisher gefunden habe, ist direkt das yaVDR 0.4 iso file zu nehmen. Eine FF-HD-Karte ist zwar am Grundkonzept von yaVDR vorbei, die S2-6400 wird aber unterstützt und es läuft mehr oder weniger out of the Box (OT: Falls man bei den yaVDR Gurus Fragen stellt, bitte voher 24h setzten lassen und 48h Suche verwenden, sonst gibt's dresche von denen :D OT Ende)
gerd

grüße,
gerd
yaVDR 0.4 virtualisiert unter Proxmox mit TT S-2 6400

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Gerd Peter« (13. Dezember 2011, 12:14)


lola

Erleuchteter

Beiträge: 7 150

Wohnort: ʃtʁaːlzʊnt

  • Nachricht senden

11

Sonntag, 13. November 2011, 16:07

Frage mich noch, ob Stable oder Sid (aptosid) die bessere Wahl ist.


mit aptosid kannst Du nichts verkehrt machen. Ich verwende schon seit Jahren ( erst sidux, jetzt aptosid) als Gundlage für meine vdr. Im April hatte ich das zu der Zeit aktuelle Iso mit kernel 2.6.38 gezogen und damit alles aufgebaut. Läuft alles super stabil - eben Premiumklasse

Gruß Fr@nk
Sent from my brain


"...ein Leben ohne VDR ist zwar vorstellbar aber sinnlos..."


derzeit altes Zeug.......

Immortal Romance Spielautomat