Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Freitag, 15. Februar 2008, 17:48

ffmpeg über yast ?

Hi,
bin sehr neu mit Suse. Ich möchte ffmpeg installieren. Die Forumssuche brachte mir nur Ergenisse aus 2006.

Ich habe die openSuse 10.3 installiert. Installiere ich über yast erhalte ich Fehlermeldungen, dass das Paket nicht verfügbar sei. Dann soll ich die InstallationsCD einlegen. Die ist drinn, aber er greift nicht darauf zu... Kann man das fixen oder kompiliert man sich ffmpeg manuell?

Muss ich irgendwas beachten, wenn ich es kompiliere. Brauchen tue ich es für graphTFT :)

danke.

coke

Fortgeschrittener

Beiträge: 520

Wohnort: 50° 47' n. Br. 7° 17' ö. L.

Beruf: Azubi als Elektroniker für Betriebstechnik

  • Nachricht senden

2

Freitag, 15. Februar 2008, 17:52

Hallo

du könntest es vom Packman Server installieren.
Dann hast du es bei einem Update auch immer recht aktuell.
Und es geht einfacher als es neu zu compilieren.

Siehe hier

coke
VDR:AMD Athlon X2 4850e, ASUS M3A-H/HDMI, 1 GB DDR2-RAM, 80 GB 3,5"HDD, Hauppauge DVB-C Rev. 2.1, Nova-T, Lorenzen DVB-T, Atric IR-Einschalter, easyvdr 0.6.2

Server: Allnet ALL6250, 1xGb-LAN, 2xUSB, 400GB mit OPENNAS 1.7

VDR-User #1475

3

Freitag, 15. Februar 2008, 18:35

danke. jetzt scheinbar nur noch imlib2. Da gibts aber keine pakete für und über yast hab ich wieder das problem, dass der CD Zugriff nicht klappt. Ist aber richtig eingestellt der Laufwerkspfad :(

coke

Fortgeschrittener

Beiträge: 520

Wohnort: 50° 47' n. Br. 7° 17' ö. L.

Beruf: Azubi als Elektroniker für Betriebstechnik

  • Nachricht senden

4

Freitag, 15. Februar 2008, 19:24

Du kannst Packman auch als zusätzuliche Packetquelle hinzufügen.
Sieh einfach mal auf der Hauptseite von Packman nach.
VDR:AMD Athlon X2 4850e, ASUS M3A-H/HDMI, 1 GB DDR2-RAM, 80 GB 3,5"HDD, Hauppauge DVB-C Rev. 2.1, Nova-T, Lorenzen DVB-T, Atric IR-Einschalter, easyvdr 0.6.2

Server: Allnet ALL6250, 1xGb-LAN, 2xUSB, 400GB mit OPENNAS 1.7

VDR-User #1475

5

Samstag, 16. Februar 2008, 10:01

ISt als Paketquelle sogar schon angegeben hab ich gerade festgestellt.

Der Zugriff auf das CDrom klappt mittlerweile und ich habe imlib2 installiert.

Trotzdem meckert er immer noch bei der installation von ffmpeg, egal ob über yast als auch auf konsole:
vdr:~ # rpm -i ffmpeg-0.4.9-9.pm.svn20080209.i586.rpm error: ffmpeg-0.4.9-9.pm.svn20080209.i586.rpm: Header V3 DSA signature: BAD, key ID 9a795806
error: ffmpeg-0.4.9-9.pm.svn20080209.i586.rpm cannot be installed

Bei dem System ist irgendwas im argen, doch ich weiss es nicht zuzuordnen :(

6

Samstag, 16. Februar 2008, 15:59

Könnte sein, daß du zuerst die Packman-Schlüssel impoertieren mußt. Eigentlich sollte yast das beim Hinzufügen der Quelle automatisch machen. Du kannst mal probieren, das packman-repo zu entfernen und neu hinzuzufügen. Adressen der repos findest du bei opensuse.

mfg
pidel
Mediaportal (AVT), 533er Celeron, 250GB HD, 128MB RAM, DVBs Rev. 1.3, easyVdr 0.5 04
Meine Projekte: vdr_remote
Registered vdr user #1306
Typisiert und Organspender

7

Samstag, 16. Februar 2008, 18:19

Danke pidel.
Hab ich gemacht. Den Fehler hatte ich vorher auch schonmal:

Zitat


There was an error in the repository initialization.
'packman': Valid metadata not found at specified URL(s)
History:
- Wrong checksum for primary.xml.gz


ffmpeg findet yast jetzt gar nicht mehr :(

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »ziz« (16. Februar 2008, 18:20)


8

Dienstag, 19. Februar 2008, 16:01

Möglichkeit 1) ein Fehler in yast, schau mal nach yast-Updates.
Möglichkeit 2) Problem im repo, dauert idR max ein paar Tage.

Für ffmpeg ist Packman dann deine einzige Quelle, wenn yast das Verzeichnis nicht akualisieren kann wird´s ausgeblendet.

Du kannst dir das rpm auch über http://packman.links2linux.org runterladen und dann als root auf der Kommandozeile mit

Quellcode

1
rpm -i Paketname
installieren.

mfg
pidel
Mediaportal (AVT), 533er Celeron, 250GB HD, 128MB RAM, DVBs Rev. 1.3, easyVdr 0.5 04
Meine Projekte: vdr_remote
Registered vdr user #1306
Typisiert und Organspender

9

Dienstag, 19. Februar 2008, 16:07

Danke,

aber das hab ich alles schon probiert :(

Werde/habe mich damit abgefunden und werde wenn Zeit ist wieder auf debian umschwenken....

10

Dienstag, 19. Februar 2008, 16:18

Ist das evtl. die 64-bit Version? Mit der hatte ich auch massive Probleme, bin dann zurück auf 10.2 x86_64, das läuft stabil.

Gab mal so ne Faustregel: Niemals ne ungerade Suse, das hat sich wohl bis zu opensuse gehalten.

mfg
pidel
Mediaportal (AVT), 533er Celeron, 250GB HD, 128MB RAM, DVBs Rev. 1.3, easyVdr 0.5 04
Meine Projekte: vdr_remote
Registered vdr user #1306
Typisiert und Organspender

Immortal Romance Spielautomat