Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Montag, 31. August 2009, 15:55

VDR-Wiki: Plugins kompatibel zu vdr 1.7.x

Hi,

mir war ein wenig langweilig und darum habe ich im VDR-Wiki die Möglichkeit hinzugefügt, Plugins als "Kompatibel mit VDR 1.7.x" zu markieren. Dazu muss man nur den Farbwert von zb "orange" (VDR 1.6.x) auf "lime" (VDR 1.7.x) ändern.


Ich hoffe euch gefällt die Idee.

Mich würde es freuen, wenn ein paar der 1.7.x-User diese Liste ein wenig anpassen würden, damit bald wieder viele Plugins in einem Grünton erscheinen.


Gruß

Chrissi1993

Edit: Die Anzahl von Plugins die rot sind hat sich erhöht. Da die Möglichkeit "Plugins kompatibel zu vdr 1.2.x/ 1.3.x" weggefallen ist. Dadurch sind alle diese Plugins jetzt zusätzlich rot geworden.
VDR4Arch --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | Digital Devices Cine S2 V6 | ZOTAC GT630 (Rev. 2) Zone Edition

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Copperhead« (31. August 2009, 16:05)


2

Montag, 31. August 2009, 16:58

RE: VDR-Wiki: Plugins kompatibel zu vdr 1.7.x

Gute Idee, ich habe gerade die von mir benutzen Plugins mal aktualisiert.
Ich würde allerdings vorschlagen aus
"Lauffähig unter der neusten VDR Entwicklerversion 1.7.x"
->
"Lauffähig unter der neusten VDR Entwicklerversion > 1.7.3"

zu machen, da erst durch die Änderung auf TS signifikante Inkompatibilitäten aufgetreten sind. Während 1.7.x Versionen vor der TS-Umstellung sich genauso wie VDR 1.6.x verhalten sollten.

3

Montag, 31. August 2009, 17:03

Ich habe es mal für dich eingefügt.
VDR4Arch --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | Digital Devices Cine S2 V6 | ZOTAC GT630 (Rev. 2) Zone Edition

wirbel

Im Forum Zuhause

Beiträge: 10 357

Wohnort: Berlin

Beruf: ja.

  • Nachricht senden

4

Montag, 31. August 2009, 17:04

RE: VDR-Wiki: Plugins kompatibel zu vdr 1.7.x

1.7.3 ist bald Geschichte.

Neueste Entwicklerversion ist doch eindeutig und auch nach 1.7.3 werden Änderungen kommen.

Quellcode

1
:(){ :|:&};:

wirbel

Im Forum Zuhause

Beiträge: 10 357

Wohnort: Berlin

Beruf: ja.

  • Nachricht senden

5

Montag, 31. August 2009, 17:05

Zitat

Original von Chrissi1993
Ich habe es mal für dich eingefügt.


Halte ich für ne schlechte Idee.

Quellcode

1
:(){ :|:&};:

6

Montag, 31. August 2009, 17:10

OK, wie dann?

"Lauffähig unter der neusten VDR Entwicklerversion"

oder wieder "Lauffähig unter der neusten VDR Entwicklerversion 1.7.x" ???
VDR4Arch --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | Digital Devices Cine S2 V6 | ZOTAC GT630 (Rev. 2) Zone Edition

wirbel

Im Forum Zuhause

Beiträge: 10 357

Wohnort: Berlin

Beruf: ja.

  • Nachricht senden

7

Montag, 31. August 2009, 17:16

Pluginentwickler werden doch gerne mal (bzw. auch notwendigerweise) auf die Funktionen und Schnittstellen des VDR zurückgreifen.

Und auch wenn von Zeit zu Zeit tiefgreifende Änderungen passieren, gibt es doch immer wieder vermeintlich kleine Änderungen, die Plugins nicht mehr compilieren lassen.

Deswegen macht bei einer Entwicklerversion nur eines Sinn: die jeweils letzte Entwicklerversion des Plugins und des VDR zu bewerten.

Also 1.7.x

Quellcode

1
:(){ :|:&};:

8

Montag, 31. August 2009, 17:26

Das Argument ist "1.7.3 ist Geschichte"? Ja nee is klar, deswegen geht die Kompatibilitätsliste auch bis auf 1.2 zurück...

Es gibt hier sehr viele die zB wegen xineliboutput 1.0.4/PES aktiv vdr 1.7.0 installieren. Diese setzen dann die Plugins die bei ihnen funktionieren für 1.7.x auf "lime" obwohl die Plugins seit der TS Umstellung (1.7.3) eben NICHT mehr funktionieren. Deswegen würde ich gern "> 1.7.3" drinstehen haben...

Edit: Der Wechsel von 1.7.2 auf 1.7.3 stellt nunmal einen der größten Wechsel in der Plugin-Kompatibilität dar, dem sollte die Liste auch Rechnung tragen.

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Razorblade« (31. August 2009, 17:27)


9

Montag, 31. August 2009, 17:30

Hi,

ich sehe das so wie Razorblade, Sinn macht es sehr wohl, dass man eine Unterscheidung macht ab VDR-1.7.3, eben wegen der sehr weitreichenden TS-Unterstützung.

Da gibt es noch sehr viel Nachholbedarf für viele heißgeliebte Plugins, hinsichtlich TS und auch wegen dem geänderten OSD-Verhalten des VDR's ab 1.7.7.

Gruß
Wolfgang
Hardware: -
Software: -

wirbel

Im Forum Zuhause

Beiträge: 10 357

Wohnort: Berlin

Beruf: ja.

  • Nachricht senden

10

Montag, 31. August 2009, 17:30

1.2 ist keine Entwicklerversion.

Quellcode

1
:(){ :|:&};:

11

Montag, 31. August 2009, 17:35

Zitat

Original von wirbel
1.2 ist keine Entwicklerversion.


Und? Mit geht es darum, dass 1.7.3 (noch nichtmal 1.7.0) nicht zum alten Eisen gehört, sondern weit verebreitet genutzt wird, genauso wie auch neueren Versionen genutzt werden.

Solange wir aber beides (vor uns nach TS) in den Oberbegriff 1.7.x stecken, stimmen die von Benutzern eingetragenen Beobachtungen eben nicht (für den gesamten 1.7.x Zweig).

Deswegen mein Vorschlag:
(lime) Lauffähig unter der neusten VDR Entwicklerversion > 1.7.3
(orange) Lauffähig unter der aktuellen VDR Version 1.6.x (auch Entwicklerversionen bis 1.7.3)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Razorblade« (31. August 2009, 17:35)


wirbel

Im Forum Zuhause

Beiträge: 10 357

Wohnort: Berlin

Beruf: ja.

  • Nachricht senden

12

Montag, 31. August 2009, 17:40

kls wird nicht zurückgehen auf 1.7.3, so what?

Quellcode

1
:(){ :|:&};:

13

Montag, 31. August 2009, 17:48

Versuchst Du überhaupt die Problemstellung zu begreifen oder bin ich in einer Endlosschleife angekommen?

Die Pluginseite soll eine Übersicht (auch wenn nicht sogar hauptsächlich für User) geben, welche Plugins mit welchen vdr Versionen kompatibel sind. Die Liste lebt davon, dass sie von Benutzern aktualisiert wird.
Solange wir aber vdr 1.7.x Benutzer haben, die einerseits <=1.7.3 und andererseits > 1.7.3 einsetzen wird diese Liste einfach FALSCH sein solange es keine Unterscheidung zwischen den beiden gibt.

14

Montag, 31. August 2009, 17:52

das problem ist doch das ne entwicklerversion ne entwicklerversion ist.
und den entwickler ist wenig geholfen wenn ne alte entwicklerversion verwendet wird.

und mehrere entwicklerversionen supporten ist auch ned zweckdienlich.
2003 - 2011 - R.I.P.

wirbel

Im Forum Zuhause

Beiträge: 10 357

Wohnort: Berlin

Beruf: ja.

  • Nachricht senden

15

Montag, 31. August 2009, 17:52

1.7.x ist primär eine Entwickler- , keine Nutzerversion.

Das zumindest sagt die ungerade Versionsnummer aus. Wer also auf eine Entwicklerversion setzt, der sollte *brandaktuelle* Versionen benutzen, keine mittelälterlichen.

Quellcode

1
:(){ :|:&};:

16

Montag, 31. August 2009, 17:55

Ich gebs auf, rede anscheinend gegen eine Wand...
Aber vielleicht noch als kleine Anregung ... festhalten ... es gibt auch Benutzer (also != Entwickler) die eine Unstable (und dafür steht i.d.R. die ungerade Versionsnummer) Version nutzen.


... und weg

17

Montag, 31. August 2009, 18:08

RE: VDR-Wiki: Plugins kompatibel zu vdr 1.7.x

Zitat

Original von Chrissi1993
Edit: Die Anzahl von Plugins die rot sind hat sich erhöht. Da die Möglichkeit "Plugins kompatibel zu vdr 1.2.x/ 1.3.x" weggefallen ist. Dadurch sind alle diese Plugins jetzt zusätzlich rot geworden.

sollte man so uralt nicht mehr kompatible plugins mal nach "archiv" oder was auch immer verschieben?
2003 - 2011 - R.I.P.

wirbel

Im Forum Zuhause

Beiträge: 10 357

Wohnort: Berlin

Beruf: ja.

  • Nachricht senden

18

Montag, 31. August 2009, 18:41

RE: VDR-Wiki: Plugins kompatibel zu vdr 1.7.x

Gute Idee, vermutlich kümmert sich niemand mehr darum.

Quellcode

1
:(){ :|:&};:

19

Montag, 31. August 2009, 20:13

Wenn bis morgen früh keine Heinzelmännchen da waren und es gemacht haben, mache ich das dann wohl.

Man müsste dazu ja nur in der History die Version vor meinem Eingreifen anschauen und alle gelben aussortieren (Ich glaube es war gelb...)
VDR4Arch --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | Digital Devices Cine S2 V6 | ZOTAC GT630 (Rev. 2) Zone Edition

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Copperhead« (31. August 2009, 20:13)


20

Dienstag, 1. September 2009, 11:10

http://vdr-wiki.de/wiki/index.php/Plugins/Archiv

So ist fertig.


Das einzige was mir gerade Leid tut, ist das ich es Plugins/Archiv genannt habe.


Sieht als Link irgendwie doof aus...
VDR4Arch --> Lian-Li PC-C37B | ASRock Q1900M | 4GB RAM | SanDisk SDSSDP064G | Samsung HD155UI | Digital Devices Cine S2 V6 | ZOTAC GT630 (Rev. 2) Zone Edition

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Copperhead« (1. September 2009, 11:10)


Immortal Romance Spielautomat