Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Donnerstag, 23. März 2006, 22:04

30 sec. warten, Video Modus

Hallo,
ich habe MiniVDR 1.3 drauf und muss immer 30 sec. warten, oder die Leertaste drücken, beim Booten.
Wie kann ich dem System beibringen, das es immer mit Video Modus 0 hoch fahren soll?

Willi

Dr. Seltsam

Im Forum Zuhause

Beiträge: 10 116

Wohnort: 3. Planet des Sonnensystems

Beruf: Organisator

  • Nachricht senden

2

Donnerstag, 23. März 2006, 23:32

RE: 30 sec. warten, Video Modus

ich versuch mal zu raten, wovon Du sprichst ;)

möglicherweise wird beim Booten eine Kerneloption verwandt, die der Grafikchip nicht kann.

Bei einem Board muss ich für LinVDR z.B. in der /boot/grub/menu.lst immer die Zeile

Quellcode

1
kernel		/boot/vmlinuz vga=0x314 root=/dev/hda1 quiet

ändern in

Quellcode

1
kernel		/boot/vmlinuz vga=normal root=/dev/hda1 quiet


minivdr nutzt glaube ich lilo, da wird das anders, aber ähnlich gehen
VDR 1: Silverstone LC20, Cougar A300/R, MSI C847MS-E33, passive Asus GT520, KNC One DVB-C, Cine CT V6, WD10EACS; Atric-IR-Einschalter. SW: yavdr 0.5 per SSD
VDR 2: im Aufbau: ACT-620 mit Coba-NT, Asrock B75 Pro3-M, Celeron G540, Sundtek MediaTV Digital Home (DVB-C/T), passive Asus GT610. SW: Ubuntu 13.04 minimal (ohne grafische Oberfläche) per SSD

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Dr. Seltsam« (23. März 2006, 23:33)


3

Freitag, 24. März 2006, 16:11

Hi,
bei MiniVDR gibt es leider den Ordner grub nicht.
Auch MC findet keine Datei menue.lst.
Damit das Rätselraten ein Ende hat, schreibe ich mal die Meldung auf, sie kommt direkt nach dem Bootloader.

You passed an undefined mode number.
Press <RETURN> to see video modes available, <SPACE> to continue or wait 30 secs.

Wo kann ich noch danach suchen um die Meldung weg zubekommen?

Willi

4

Freitag, 24. März 2006, 16:15

Hallo,
gibts unter MiniVdr eine bootpartition, falls ja, wurde die gemountet ?
mfg
/ gibt gar kein grub, zu spaet gesehen.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »holymoly« (24. März 2006, 16:17)


5

Freitag, 24. März 2006, 16:25

Wirf mal einen Blick in die lilo.conf. Da müßte was zu finden sein in Bezug auf den Videomodus.
VDR1: Dign HV5 mit Noritake GU 256x64C-3900 VFD,Asus P4B-E, P4 1,8 GHz, 160 GB Samsung SP1614N + 200 GB Samsung SP2014N, 2 FF DVB-S (1x4MB MOD), AV-Board 1.3, WLAN, Debian Sarge 2.6.15, VDR 1.5.2
VDR2: OrigenAE X15e, Asus P5Q, Intel E5200, MSI N9500 GT, 1 TB Samsung HD103SI, TT S2-3200 + Nova HD-S2, Ubuntu 8.10 + VDR 1.7.0

VDR3: Mediacenter-Gehäuse mit L4M-Display, DFI LANPARTY JR GF9400-T2RS, Intel E8400, 1 TB Samsung HD103UJ, Digital Devices Cine S2 Rev 5.5, yavdr 0.3.0a

6

Freitag, 24. März 2006, 16:43

Auch in der angesprochenen /etc/lilo.conf gibt es eine vga=xyz Zeile. Diese muss geändert werden auf vga=normal (s.o.) und dann muss noch einmal der bootloader geschrieben werden. Das passiert mit dem Befehl lilo. Ausgabe von lilo sollte sein added linux oder added wasweissich. Lilo meldet für jedes im Bootmanager eingetragene Betriebssystem jeweils einmal added blabla und beim standardbooteintrag steht ein sternchen davor. Danach sollte der Rechner normal booten.

7

Freitag, 24. März 2006, 17:06

Hi,
ich habe den Eintrag in der lilo.conf geändert, aber der Befehl heißt leider nicht lilo.
Weiß jemannd wie der Befehl genau heißt?
Es gibt z.B. den Befehl "lilo -A /dev/XXX [ mbr_file ] install master boot record.

Willi

8

Freitag, 24. März 2006, 17:15

Was passiert denn, wenn du nur lilo eintippst?

9

Freitag, 24. März 2006, 18:19

Oha, jede Menge:
Warning: Int 0x13 funnktion 8 and function 0x48 return different
head/sector geometries for Bios drive 0x80
fn 08:1024 cylinders, 255 heads, 63 sectors
fn 48:57473 cylinders, 16 heads, 63 sectors
Added MVDR-2.6.13.2 *
Added PowerOFF

AHHHHHHHHHHHH!!!
Die 30 sekunden Warterei ist nun vorbei. :)

Vielen Dank
Willi

10

Freitag, 24. März 2006, 18:30

Genau wie ich gesagt habe:

Added MVDR-2.6.13.2 *

Wenn du übrigens mal einen anderen VGA-Modus testen möchtest kannst du mit vga=ask wieder den von dir so gehassten prompt (30 sek.) einschalten und dann mal return drücken. Du bekommst dann eine Liste der mit deiner VGA-Karte möglichen codes geliefert. Gibst du einen dieser codes dann bei vga=xyz ein startet dein Rechner automatisch in diesem VGA-Modus (natürlich immer nach Ändern der lilo.conf das lilo nicht vergessen um die Änderung zu aktivieren)
Du kannst auch mal nach "vga vesa lilo modes" googeln. Da finden sich dann diverse Seiten mit den vga=xyz Zahlen für diverse VESA Modes. Die wirst du brauchen, um das Framebuffer Device zu nutzen. Vielleicht. Später. Wer weiß?

11

Freitag, 24. März 2006, 18:34

Zitat

Original von willi at home
Oha, jede Menge:
Warning: Int 0x13 funnktion 8 and function 0x48 return different
head/sector geometries for Bios drive 0x80
fn 08:1024 cylinders, 255 heads, 63 sectors
fn 48:57473 cylinders, 16 heads, 63 sectors
Added MVDR-2.6.13.2 *
Added PowerOFF

AHHHHHHHHHHHH!!!
Die 30 sekunden Warterei ist nun vorbei. :)

Vielen Dank
Willi


Ach ja: noch was zu den Warnings. Das bedeutet nur, dass deine Platte von den verschiedenen BIOS Funktionen zum Ermitteln der Plattengeometrie unterschiedlich erkannt wird. Deine Platte ist also einfach nur recht groß. Die Warnung wird dir nur gemeldet weil manche alten BIOSe mit so großen Platten Probleme haben könnten. Kann also bei halbwegs moderner Hardware (Jenseits Pentium II...) ignoriert werden.

12

Freitag, 24. März 2006, 18:52

@ xnalpf,
ich habe schon mal andere VGA-modi ausprobiert, aber wozu, ich habe keine TV Ausgabe auf den PC Monitor.
Meine Grafigkarte ist OnBoard, auf einem PCISA Slot PC und das ganze steckt in einem Technics CD-Player Gehäuse.
Da möchte ich wegen Platzmangel keine zusätzliche Grafikkarte reinsetzen.
Was kann man denn mit dem Framebuffer Device machen?


Willi

PS: ich habe mir deine Nachricht nochmal durchgelesen und habe das mit dem . verstanden.............. :P

13

Freitag, 24. März 2006, 18:56

GraphTFT braucht das glaube ich, GraphLCD kann auch anstelle auf einem LCD auf dem Framebuffer ausgeben. (Wenn auch nur S/W) Und und und... Wenn du mit dem Teil so zufrieden bist ist alles klar. Wenn du weiterbasteln willst weißt du jetzt wie du an ein Frambuffer kommst ;D

14

Freitag, 24. März 2006, 19:09

Hi,
jetzt vertehe ich.
Ein Arbeitskolege hat sich ein PSone Display besorgt und benutzt es zur Anzeige.
Dafür hat er aber mehrere Grafikkarten ausprobiert bis es ging.
Ich habe so etwas nicht vor. Dafür werde ich mir noch einen AT90S2343 einbauen, damit ich mit der FB An/Ausschalten kann.

Danke nochmal
Willi

Immortal Romance Spielautomat