You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

321

Monday, March 2nd 2009, 9:49am

Hi,

super, werde ich heute Abend gleich mal ausprobieren! Danke schonmal für die schnelle Hilfe!

Gruß, kandamir
Konfiguration:
ASUS P4P800-E Deluxe
Intel Pentium 4 Mobile 1,7GHz mit CPU-Adapter ASUS CT-379 (funktioniert einwandfrei)
2GB RAM
500GB S_ATAII Festplatte
TechnoTrend Premium DVB-C 2300 FF, Rev. 1.1
2x Hauppauge Nova-T DVB-T Budget, Rev. C2B0f
Gen2VDR Linux 2.6.23.11-gentoo
Zalman HD160XT PLUS Gehäuse

322

Tuesday, March 3rd 2009, 9:55am

Ich hab noch ein Problem mit meinem DH102 und der Logitech 785. Mit der lirc-0.8.5 aus dem Wiki funktioniert das Ausschalten per Fernbedienung nicht mehr richtig. Muss dann meistens über die HELP-Taste zwei bis drei Mal probieren, bevor der VDR ausgeht. Mit der lirc-0.8.3 Version ging das problemlos. Was könnte das sein? Woran kann das liegen?

EDIT: Ach gleich nochwas. Gibt es eine Möglichkeit den Infrarot-Empfänger zu tunen? Meist muss man die Fernbedienung ja direkt aufs Gehäuse richten.
- VDR: Thermaltake DH 102 mit 7" TouchTFT * Mystique SaTiX-S2 Dual * Debian Wheezy/vdr-2.1.5/graphtft/MainMenuHooks-Patch * Intel Petium G3220 * DH87RL * Zotac GT630 * 1 TB System HDD * 4 GB Corsair Vegance * Harmony 900 (39-44W)
- Server: Zotac H55-ITX WiFi, Core i3 540, 4GB RAM, 4x4TB 3.5" WD RED + 1x500GB 2.5", Cine S2, vdr-2.1.6
- vdr-theme-darkred: https://github.com/TheChief79/vdr-theme-darkred

This post has been edited 1 times, last edit by "TheChief" (Mar 3rd 2009, 10:09am)


ranzen

Trainee

Posts: 94

Location: Marklohe

  • Send private message

323

Tuesday, March 3rd 2009, 9:26pm

DH 101 Nachfolger

Moin,

ich war heute auf der CeBIT und habe auf dem Thermaltake - Stand ein neues Gehäuse gesehen: DH 202 (siehe auch: http://www.thermaltake.com/product_overv…_CID=C_00001364 ).

Das Teil macht einen super Eindruck. Scheint der Nachfolger des DH 102 zu sein.

Auf demselben Stand gab es auch einige Geräte der Thermaltake-Tochter Luxa zu sehen. Diese "Home Theater Media PC's" sind auch sehr schön anzuschauen, spielen aber (auch preislich) in einer anderen Liga.

Wer von Euch diese Woche auf der CEBIT ist, sollte dort mal vorbeischauen.

Gruß ranzen
Mein LinuxVDR Testsystem:
--------------------
yaVDR 0.2, Asus M4N78-EM, AMD Sempron 140, Nvidia 8200 Chipsatz, Tevii S470, 2x 1024MB, 1 TB Festplatte

324

Tuesday, March 3rd 2009, 10:19pm

Hi,

den neuen Treiber konnte ich jetzt erfolgreich compilen und installieren (make install). Danke an Rene!
Allerdings wird der Treiber nicht geladen:

Source code

1
2
3
4
5
6
7
8
9
cat /proc/bus/usb/devices
[...]
P:  Vendor=15c2 ProdID=0034 Rev= 0.15
C:* #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=100mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=00 Prot=02 Driver=usbhid
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=10ms
I:* If#= 1 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=00 Prot=00 Driver=usbhid
E:  Ad=82(I) Atr=03(Int.) MxPS=   8 Ivl=10ms
[...]

Entladen von usbhid funktioniert leider auch nicht:

Source code

1
2
rmmod usbhid && modprobe usbhid quirks=0x15c2:0x0034:0x0004
ERROR: Module usbhid does not exist in /proc/modules

Ist usbhid nicht als Modul geladen sondern mit im Kernel kompiliert?

Also wenn wer sachdienliche Hinweise hat... ;-)

Danke und Gruß, kandamir
Konfiguration:
ASUS P4P800-E Deluxe
Intel Pentium 4 Mobile 1,7GHz mit CPU-Adapter ASUS CT-379 (funktioniert einwandfrei)
2GB RAM
500GB S_ATAII Festplatte
TechnoTrend Premium DVB-C 2300 FF, Rev. 1.1
2x Hauppauge Nova-T DVB-T Budget, Rev. C2B0f
Gen2VDR Linux 2.6.23.11-gentoo
Zalman HD160XT PLUS Gehäuse

325

Tuesday, March 3rd 2009, 11:17pm

Ja Sorry, wenn der usbhid Treiber das Geraet belegt aber kein Modul geladen ist, sieht es sehr stark danach auch.
Da bleibt dir keine andere Wahl als einen anderen Kernel, bei dem der usbhid Treiber als Modul compiliert wurde, zu installieren.

Rene

326

Friday, March 13th 2009, 8:13pm

Hi Rene,

jetzt hat es eine Weile gedauert, aber ich bin weiter - aber noch nicht fertig.

Was inzwischen geschah:
Ich hab' meinen VDR neu installiert (war aus diversen Gründen angebracht) und auch den Kernel habe ich neu installiert, usbhid diesmal als Modul eingebunden. LIRC habe ich auch kompiliert und installiert bekommen, allerdings bekomme ich mit evtest keine Reaktion.

Hier mal ein paar Infos:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
vdr01 ~ # lsmod
Module                  Size  Used by
usb_storage            61600  0
mga                    60032  2
drm                    76948  3 mga
snd_pcm_oss            45856  0
snd_mixer_oss          16768  2 snd_pcm_oss
snd_seq_oss            31104  0
snd_seq_midi_event      7936  1 snd_seq_oss
snd_seq                50896  4 snd_seq_oss,snd_seq_midi_event
snd_seq_device          9100  2 snd_seq_oss,snd_seq
sg                     29980  0
joydev                 10688  0
tsdev                   9152  0
lirc_imontouch         13600  0
lirc_dev               15060  1 lirc_imontouch
skge                   39312  0
[...]

vdr01 ~ # cat /proc/bus/usb/devices
[...]
T:  Bus=04 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  2 Spd=1.5 MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=15c2 ProdID=0034 Rev= 0.15
C:* #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=100mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=00 Prot=02 Driver=lirc_imontouch
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=10ms
I:* If#= 1 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=00 Prot=00 Driver=lirc_imontouch
E:  Ad=82(I) Atr=03(Int.) MxPS=   8 Ivl=10ms

=> Modul lirc_imontouch wird also geladen.

Folgende Input-Devices gibt's:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
vdr01 ~ # ls -la /dev/input/*
crw------- 1 root root 13,  64 2009-03-13 19:52 /dev/input/event0
crw------- 1 root root 13,  65 2009-03-13 19:52 /dev/input/event1
crw------- 1 root root 13,  66 2009-03-13 19:52 /dev/input/event2
crw------- 1 root root 13,  67 2009-03-13 19:52 /dev/input/event3
crw------- 1 root root 13,  68 2009-03-13 19:52 /dev/input/event4
crw------- 1 root root 13,  69 2009-03-13 19:52 /dev/input/event5
crw------- 1 root root 13,  70 2009-03-13 19:52 /dev/input/event6
crw------- 1 root root 13,  71 2009-03-13 19:52 /dev/input/event7
crw-r--r-- 1 root root 13,  63 2009-03-13 19:52 /dev/input/mice
crw-r--r-- 1 root root 13,  32 2009-03-13 19:52 /dev/input/mouse0
crw-r--r-- 1 root root 13,  33 2009-03-13 19:52 /dev/input/mouse1
crw------- 1 root root 13, 128 2009-03-13 19:52 /dev/input/ts0
crw------- 1 root root 13, 129 2009-03-13 19:52 /dev/input/ts1

/dev/input/by-id:
total 0
drwxr-xr-x 2 root root  80 2009-03-13 19:52 .
drwxr-xr-x 4 root root 340 2009-03-13 19:52 ..
lrwxrwxrwx 1 root root   9 2009-03-13 19:52 usb-15c2_0034-event-ir -> ../event6
lrwxrwxrwx 1 root root   9 2009-03-13 19:52 usb-15c2_0034-ir -> ../mouse0

/dev/input/by-path:
total 0
drwxr-xr-x 2 root root 200 2009-03-13 19:52 .
drwxr-xr-x 4 root root 340 2009-03-13 19:52 ..
lrwxrwxrwx 1 root root   9 2009-03-13 19:52 pci-0000:00:1d.2-usb-0:1:1.0-event-ir -> ../event6
lrwxrwxrwx 1 root root   9 2009-03-13 19:52 pci-0000:00:1d.2-usb-0:1:1.0-ir -> ../mouse0
lrwxrwxrwx 1 root root   9 2009-03-13 19:52 pci-0000:00:1d.2-usb-0:1:1.1- -> ../mouse1
lrwxrwxrwx 1 root root   9 2009-03-13 19:52 pci-0000:00:1d.2-usb-0:1:1.1-event- -> ../event7
lrwxrwxrwx 1 root root   9 2009-03-13 19:52 pci-0000:02:0a.0--event-ir -> ../event3
lrwxrwxrwx 1 root root   9 2009-03-13 19:52 pci-0000:02:0c.0--event-ir -> ../event4
lrwxrwxrwx 1 root root   9 2009-03-13 19:52 pci-0000:02:0d.0--event-ir -> ../event5
lrwxrwxrwx 1 root root   9 2009-03-13 19:52 platform-i8042-serio-0-event-kbd -> ../event2

Beim Ausführen von 'evtest /dev/input/event6' würde ich eine entsprechende Reaktion erwarten, wenn ich Tasten der Fernbedienung drücke. Passiert aber nix.

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
vdr01 ~ # evtest /dev/input/event6
Input driver version is 1.0.0
Input device ID: bus 0x3 vendor 0x15c2 product 0x34 version 0x15
Input device name: "iMON PAD IR Mouse 15c2:0034"
Supported events:
  Event type 0 (Sync)
  Event type 1 (Key)
    Event code 272 (LeftBtn)
    Event code 273 (RightBtn)
    Event code 274 (MiddleBtn)
    Event code 275 (SideBtn)
    Event code 276 (ExtraBtn)
  Event type 2 (Relative)
    Event code 0 (X)
    Event code 1 (Y)
    Event code 8 (Wheel)
Testing ... (interrupt to exit)

Ebenso bei den anderen Input-Devices (mit Ausnahme meiner Hauppauge Fernbedienung auf den zugehörigen IR-Empfänger). Auch der Touchscreen läßt sich nicht "betouchen"... :-(

Hast Du noch ein paar Tips für mich? ;-)

Danke und Gruß, kandamir
Konfiguration:
ASUS P4P800-E Deluxe
Intel Pentium 4 Mobile 1,7GHz mit CPU-Adapter ASUS CT-379 (funktioniert einwandfrei)
2GB RAM
500GB S_ATAII Festplatte
TechnoTrend Premium DVB-C 2300 FF, Rev. 1.1
2x Hauppauge Nova-T DVB-T Budget, Rev. C2B0f
Gen2VDR Linux 2.6.23.11-gentoo
Zalman HD160XT PLUS Gehäuse

327

Monday, March 16th 2009, 4:57pm

Hi,

keine Tipps für mich parat? ;-)

Ich habe am WE selbst noch ein bisschen weiter gewerkelt und mittels mode2 zumindest herausgefunden, dass die Fernbedienung, die Tasten am Gehäuse inkl. Drehknopf und auch der Touchscreen Events erzeugen und diese bei LIRC anzukommen scheinen.

Ich habe auch die lircd.conf und die remotes.conf nach den Vorlagen hier im Thread angepasst (inkl. einiger kleinerer Änderungen der Tastencodes, da habe ich wohl eine neue Revision der Fernbedienung). Aber das Zusammenspiel mit VDR klappt leider immer noch nicht.

Im Zusammenhang mit den mode2 Tests war mir noch aufgefallen, dass bei mir das Device /dev/lirc0 beim Booten angelegt wird, mode2 besteht aber scheinbar auf /dev/lirc, was ich manuell und nach jedem Booten als Link angelegt habe (ln -s /deb/lirc0 /dev/lirc). Gibt's irgendwo eine Konfig, wo ich /dev/lirc0 eintragen kann/muss?

Und die große Frage: wie bekomme ich VDR dazu, das LIRC-Device zu verwenden? Im Moment ist es so, dass beim Start von VDR angemeckert wird, dass die Fernbedienung remote-event3 angelernt werden müßte, allerdings auf keinen Tastendruck auch nur irgendeiner Fernbedienung bzw. über keinen einzigen IR-Sensor reagiert (auch nicht Tastatur).
Im Moment kann ich den VDR leider noch nicht einmal über die Tastatur bedienen (außer natürlich die Konsole)...

Hat nicht noch jemand ein paar hilfreiche Hinweise? Ich hab mich früher schon durch diverse Threads zu Fernbedienungen gelesen, aber hier komme ich im Moment nicht weiter...

Merci und Gruß,

kandamir
Konfiguration:
ASUS P4P800-E Deluxe
Intel Pentium 4 Mobile 1,7GHz mit CPU-Adapter ASUS CT-379 (funktioniert einwandfrei)
2GB RAM
500GB S_ATAII Festplatte
TechnoTrend Premium DVB-C 2300 FF, Rev. 1.1
2x Hauppauge Nova-T DVB-T Budget, Rev. C2B0f
Gen2VDR Linux 2.6.23.11-gentoo
Zalman HD160XT PLUS Gehäuse

peda

Professional

Posts: 918

Location: Dat Hätz vun dr Welt

Occupation: System Engineer

  • Send private message

328

Wednesday, March 25th 2009, 2:16pm

VDR mit make REMOTE=LIRC compiled?

Was sagt irw, wenn du Tasten drueckst?
MAIN: La Scala SST-LC04 Gehäuse / Asus P5N7A-VM / Intel E7500 / YaVDR 0.1 / TT-DVB-S2 / IR-Einschalter Atric / Wakeup-On-Call

ICH: Bin Microsoft, Cisco, VMware und NetApp zertifiziert

329

Tuesday, March 31st 2009, 7:51pm

Hi, danke für die Rückmeldung, peda!

Quoted

VDR mit make REMOTE=LIRC compiled?

Da muß ich passen. Ich habe VDR nicht selbst kompiliert, ist out-of-the-box, wie es eben im Intallation-Image war. Wie kann ich das ggf. nachprüfen?

Quoted

Was sagt irw, wenn du Tasten drueckst?

Konnte ich noch nicht probieren, mache ich aber, wenn ich wieder zuhause bin.

Gruß, kandamir
Konfiguration:
ASUS P4P800-E Deluxe
Intel Pentium 4 Mobile 1,7GHz mit CPU-Adapter ASUS CT-379 (funktioniert einwandfrei)
2GB RAM
500GB S_ATAII Festplatte
TechnoTrend Premium DVB-C 2300 FF, Rev. 1.1
2x Hauppauge Nova-T DVB-T Budget, Rev. C2B0f
Gen2VDR Linux 2.6.23.11-gentoo
Zalman HD160XT PLUS Gehäuse

Paulaner

Professional

Posts: 937

Location: Märkisch-Oderland

  • Send private message

330

Wednesday, April 22nd 2009, 2:18am

@Besitzer des Thermaltake DH101
ich möchte mir demnächst auch dieses Gehäuse (allerdings ohne eingebautes Display) zulegen und dann ein bereits vorhandenes Display reinbauen.
Kann bitte mal einer der Besitzer dieses Gehäuses die "Länge x Höhe" des Displayausschnittes messen und hier posten!

Danke schon mal im Voraus,
Paulaner

meine aktuelle Hard- und Software

Hardware: . . . . . Asus P8Z77-V_LX, Intel i5-2500, 4GB DDR3, Grafik Zotac Zone Edition GT630, 1x Single-DVB-TBS8922, 1x Dual-DVB-TBS6981, 2x WD20EFRX, 6,4"-TFT-Display
Produktiv-VDR: . . yaVDR-0.5 - Kernel 3.2.0 - vdr-2.0.6 - nvidia-331 . . . . . . . . . . . .Fernbed.: Philips SBC RU760 . . . . . LCD-FullHD-TV: Philips 47PFL9732
Reserve-VDR: . . . . yaVDR-0.5 - Kernel 3.2.0 - vdr-2.0.x - nvidia-331 auf Extra-Partition vom Produktiv-VDR, falls der Produktiv-VDR wiedermal kaputt gespielt wurde! :-)

MerlinElMago

Intermediate

Posts: 470

Location: Canary Islands

Occupation: Flying in the sky.... lalalala...

  • Send private message

331

Saturday, June 13th 2009, 12:04pm

Hallo Leute,
ich hatte meinen DH102 so schön mit Mandriva laufen, aber leider Gottes ist mir meine Festplatte hops gegangen. Nun jetzt habe ich nur sehr wenig Zeit um zu experimentieren, gibt's vielleicht eine Pre-Compiled Distro die man einfach draufmachen kann und die dann läuft? Ich werde langfristig gesehen wieder Mandriva draufmachen (aber dann die neue Version) deswegen brauche ich jetzt was Stressfreies für den Übergang. Ich muss nämlich weg, arbeiten, aber meine Frau hat jetzt schon VDR "Entzugserscheinungen" ;)

Gruss
Merlin

mdatab

Intermediate

Posts: 247

Location: BaWü, Kreis RT

Occupation: Informatiker

  • Send private message

332

Wednesday, June 24th 2009, 1:49pm

Hallo zusammen,

ich spiele mit dem Gedanken, mir das DH101 zuzulegen, bin mir aber nicht sicher ob ein CPU-Kühler wie z.B. Thermaltake BigTyp 120 reinpasst. Wäre schön wenn mir das jemand beantworten könnte. Oder was habt ihr für (leise) CPU-Kühler eingebaut?

Danke und Gruß
Martin
Hardware: SilverStone LC20M, TechnoTrend S-2300, Tevii S470
Software: Ubuntu 9.10, VDR-1.6.0-2

333

Tuesday, July 21st 2009, 8:34pm

Schnäppchen gemacht u. Probleme

Hi @all,

habe das Gehäuse DH102 neu für 230 Euro erworben.

Nutze easyvdr 0.6.08, Kernel 2.6.22.15.

Habe easyvdr neu aufgesetzt auf ne alte Festplatte zum testen.
Wollte nun nach der Wiki-Anleitung den lirc installieren. Hatte bisher ein AVboard mit remote genutzt.

Klappte soweit auch alles.

Ich habe es jetzt mit einer anderen Anleitung geschafft:
Gehäusetasten gehen
Fernbedienung geht
Touch geht

Bastle ja immer weiter und habe jetzt alles soweit am laufen.

Habe nun von meiner Test-HDD ein Backup über das VDR-Menü gemacht.
Dieses Backup habe ich dann auf meine "Runningsystem"-HDD eingespielt.
Jetzt stürzt der VDR immer wieder ab und startet neu. Vorallem jedesmal, wenn ich auf Menu - Programm gehe. Da kommt (wenn überhaupt) "No EPG Data" und der VDR startet neu.
Ansonsten wird aber der EPG des im Moment aktuellen Programms auf dem TFT angezeigt.
Wo liegt das Problem? Was kann ich tun? Was für Infos braucht ihr (Logs usw.)?

thx Gecko
Reelbox AVGII mit Sandisk SSD und BM2LTS Route 66

This post has been edited 4 times, last edit by "Gecko2101" (Jul 24th 2009, 1:31pm)


brabax22

Intermediate

Posts: 232

Location: Leipzig

  • Send private message

334

Sunday, July 26th 2009, 6:37pm

Segfault unter Debian

Egal was ich auch versuche, der Treiber schmiert immer mit Segfault ab:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
root@video:/mnt/usr/local/src/test/lirc# insmod /usr/local/src/lirc_dev.ko
root@video:/mnt/usr/local/src/test/lirc# insmod /usr/local/src/lirc_imontouch.ko
 video kernel: [  209.049735] Oops: 0000 [#1] SMP
 video kernel: [  209.049897] last sysfs file: /sys/devices/platform/it87.3712/pwm2
 video kernel: [  209.052029] Process insmod (pid: 3254, ti=dc87c000 task=f5c1cb60 task.ti=dc87c000)
 video kernel: [  209.052029] Stack:
 video kernel: [  209.052029]  c020b91b dc87dcc8 f618f548 f6351000 dc87dce0 00000000 f635133c f639b000
 video kernel: [  209.052029]  f6720000 f639b000 00000000 f639b01c dc87dd14 c03bbba2 f639b094 dc87dd00
 video kernel: [  209.052029] Call Trace:
 video kernel: [  209.052029]  [<c020c0d6>] ? sysfs_addrm_finish+0x36/0xf0
 video kernel: [  209.052029]  [<c020b883>] ? sysfs_add_one+0x13/0x50
 video kernel: [  209.052029]  [<c020b91b>] ? sysfs_addrm_start+0x5b/0xa0
 video kernel: [  209.052029]  [<c03bbba2>] ? usb_probe_interface+0xa2/0x130
 video kernel: [  209.052029]  [<c020c732>] ? sysfs_create_link+0x12/0x20
 video kernel: [  209.052029]  [<c034f2a6>] ? really_probe+0xe6/0x180
 video kernel: [  209.052029]  [<c03bb001>] ? usb_match_id+0x41/0x60
 video kernel: [  209.052029]  [<c034f37e>] ? driver_probe_device+0x3e/0x50
 video kernel: [  209.052029]  [<c034f419>] ? __driver_attach+0x89/0x90
 video kernel: [  209.052029]  [<c034eb53>] ? bus_for_each_dev+0x53/0x80
 video kernel: [  209.052029]  [<c034f0d9>] ? driver_attach+0x19/0x20
 video kernel: [  209.052029]  [<c034f390>] ? __driver_attach+0x0/0x90
 video kernel: [  209.052029]  [<c034e527>] ? bus_add_driver+0x1c7/0x240
 video kernel: [  209.052029]  [<c034f5b9>] ? driver_register+0x69/0x140
 video kernel: [  209.052029]  [<c03bbe6c>] ? usb_register_driver+0x7c/0x100
 video kernel: [  209.052029]  [<f7d0e000>] ? imontouch_init+0x0/0x6f [lirc_imontouch]
 video kernel: [  209.052029]  [<f7d0e000>] ? imontouch_init+0x0/0x6f [lirc_imontouch]
 video kernel: [  209.052029]  [<f7d0e046>] ? imontouch_init+0x46/0x6f [lirc_imontouch]
 video kernel: [  209.052029]  [<c010111e>] ? _stext+0x2e/0x170
 video kernel: [  209.052029]  [<c020c0b5>] ? sysfs_addrm_finish+0x15/0xf0
 video kernel: [  209.052029]  [<c020b883>] ? sysfs_add_one+0x13/0x50
 video kernel: [  209.052029]  [<c020b8ff>] ? sysfs_addrm_start+0x3f/0xa0
 video kernel: [  209.052029]  [<c01a90ac>] ? __vunmap+0x9c/0xe0
 video kernel: [  209.052029]  [<c01a90ac>] ? __vunmap+0x9c/0xe0
 video kernel: [  209.052029]  [<c01a9141>] ? vfree+0x21/0x30
 video kernel: [  209.052029]  [<c0163f5a>] ? load_module+0x103a/0x1040
 video kernel: [  209.052029]  [<c0163fe8>] ? sys_init_module+0x88/0x1b0
 video kernel: [  209.052029]  [<c01bb5fa>] ? sys_close+0x7a/0xc0
 video kernel: [  209.052029]  [<c0103f6b>] ? sysenter_do_call+0x12/0x2f
Segmentation fault
Kernel ist Standard Ubuntu (2.6.28-13). Probiert habe ich lirc-0.8.5pre1 mit dem letzten Patch aus diesem Thread. Der aktuelle cvs-Zweig vom lirc läuft übrigens - dort bekomme ich aber das Pad der Fernbedienung nicht als <links> <rechts> <oben> <unten> zum Laufen... Auch der entsprechende Modulparameter hilft nicht weiter, ohne 'Pfeiltasten' auf der Fernbedienung ist nicht viel zu wollen...

????

335

Sunday, July 26th 2009, 7:09pm

RE: Segfault unter Debian

Hi brabax22,

mit der 2.6.28er Kernel Version gabs ein Problem welches erst mit der imontouch 0.2.5 version behoben wurde (hier findest du naehere Infos dazu ). LIRC mit 0.2.5 imontouch Patch findest du hier.

Ich wuerde aber empfehlen auf die LIRC CVS version zu wechseln, ich arbeite nicht mehr an dem Patch da jetzt alles im LIRC imon Treiber integriert wurde und ich mich jetzt darauf konzentriere wenn ich mal Zeit finde.

Ich schaue mal was mit den Pfeiltasten in der CVS los ist, die sollten aber eigentlich funktionieren.


Gruss
Rene

brabax22

Intermediate

Posts: 232

Location: Leipzig

  • Send private message

336

Sunday, July 26th 2009, 7:47pm

Vielen Dank, jetzt scheints zu funktionieren (der erste Reboot steht noch aus, geladen wurde aber schon mal ohne segfault...). DIESER Thread war mir irgendwie entgangen...

Die Benutzung des Pad als Pfeiltasten war auch der einzige Grund, es noch einmal mit dem 'alten' Treiber zu probieren. Den neuen habe ich natürlich hier, hab aber immer nur die PAD-Funktion zum Laufen bekommen. DAS hat beim 'alten' Treiber eindeutig besser funktioniert ;-).

Gruss...

...Hagen

337

Sunday, July 26th 2009, 8:57pm

Hattest du den nomouse Parameter bei der CVS Version ausprobiert?
Damit sollte die Mausemulation komplett deaktiviert werden und das PAD sich immer im Keyboard mode (also Pfeiltasten) befinden.


Rene

brabax22

Intermediate

Posts: 232

Location: Leipzig

  • Send private message

338

Sunday, July 26th 2009, 11:07pm

Ja, hatte ich (wie ich oben geschrieben hatte: "...auch der entsprechende Modulparameter hilft nicht weiter..."). Ich habe beide Varianten probiert. Meine existierende Konfig hat nichts gebracht, dann habe versucht neu anzulernen - auch kein Erfolg. Habe ich etwas übersehen ?

339

Monday, July 27th 2009, 5:17pm

Ups, das hatte ich ueberlesen.

Also ich habe gerade nochmal die aktuelle CVS version ausprobiert, die Pfeiltasten funktionieren bei mir einwandfrei.

Bekommst du eine Ausgabe mit mode2 --raw nachdem du den imon Treiber mit dem Modulparameter nomouse=1 geladen hast? (INFO: lircd darf nicht laufen)

Rene

MerlinElMago

Intermediate

Posts: 470

Location: Canary Islands

Occupation: Flying in the sky.... lalalala...

  • Send private message

340

Friday, August 14th 2009, 4:30pm

Meine Festplatte hat sich verabschiedet, und nun sitze ich dabei meinen VDR wieder aufzusetzen.
Vorher ging's immer mit einer Version der von Mandriva hergestellten RPM Pakete ein funktionierendes LIRC zu zaubern. Leider wird bei der 2009.1 zwar alles mögliche erkannt, aber man kann nur /dev/lirc/0 lesen und aus irgendeinem Grund funktioniert lirc/1 nicht. Deswegen habe ich mir gedacht "übersetzte das mal selber". Pustekuchen, denn beim Versuch versage ich kläglich. Ich habe mir - wie auf Venky's Seite vorgeschlagen den richtigen Kernel mit den richtigen Sources gezogen. Setup und configure funkionieren auch ganz gut, jedoch bekomme ich folgenden Fehler bei MAKEn:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
[root@vdr111 lirc]# make
make  all-recursive
make[1]: se ingresa al directorio `/usr/src/lirc'
Making all in drivers
make[2]: se ingresa al directorio `/usr/src/lirc/drivers'
Making all in lirc_dev
make[3]: se ingresa al directorio `/usr/src/lirc/drivers/lirc_dev'
cp ./../lirc_dev/Module*.symvers .
cp: no se puede efectuar `stat' sobre «./../lirc_dev/Module*.symvers»: No existe el fichero o el directorio
make[3]: [lirc_dev.o] Error 1 (no tiene efecto)
mv Makefile Makefile.automake
cp ./../Makefile.kernel Makefile
CPPFLAGS="" CFLAGS="" LDFLAGS="" \
	make -C /lib/modules/2.6.29.1-desktop-4mnb/build/ SUBDIRS=/usr/src/lirc/drivers/lirc_dev modules \
		KBUILD_VERBOSE=1
make[4]: se ingresa al directorio `/usr/src/linux-2.6.29.1-4mnb'
test -e include/linux/autoconf.h -a -e include/config/auto.conf || (		\
	echo;								\
	echo "  ERROR: Kernel configuration is invalid.";		\
	echo "         include/linux/autoconf.h or include/config/auto.conf are missing.";	\
	echo "         Run 'make oldconfig && make prepare' on kernel src to fix it.";	\
	echo;								\
	/bin/false)
mkdir -p /usr/src/lirc/drivers/lirc_dev/.tmp_versions ; rm -f /usr/src/lirc/drivers/lirc_dev/.tmp_versions/*

  WARNING: Symbol version dump /usr/src/linux-2.6.29.1-4mnb/Module.symvers
           is missing; modules will have no dependencies and modversions.

make -f scripts/Makefile.build obj=/usr/src/lirc/drivers/lirc_dev
  gcc -Wp,-MD,/usr/src/lirc/drivers/lirc_dev/.lirc_dev.o.d  -nostdinc -isystem /usr/lib/gcc/i586-manbo-linux-gnu/4.3.2/include -Iinclude  -I/usr/src/linux-2.6.29.1-4mnb/arch/x86/include -include include/linux/autoconf.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -O2 -m32 -msoft-float -mregparm=3 -freg-struct-return -mpreferred-stack-boundary=2 -march=i686 -mtune=generic -Wa,-mtune=generic32 -ffreestanding -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -Iarch/x86/include/asm/mach-generic -Iarch/x86/include/asm/mach-default -fno-stack-protector -fno-omit-frame-pointer -fno-optimize-sibling-calls -g -Wdeclaration-after-statement -Wno-pointer-sign -fwrapv -DIRCTL_DEV_MAJOR=61 -DEXPORT_SYMTAB -DHAVE_CONFIG_H -I. -I../.. -I/usr/src/lirc/drivers/lirc_dev/. -I/usr/src/lirc/drivers/lirc_dev/. -I/usr/src/lirc/drivers/lirc_dev/../.. -I/usr/src/lirc/drivers/lirc_dev/../.. -I/lib/modules/2.6.29.1-desktop-4mnb/build//include/ -I/lib/modules/2.6.29.1-desktop-4mnb/build//drivers/media/video/ -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(lirc_dev)"  -D"KBUILD_MODNAME=KBUILD_STR(lirc_dev)" -D"DEBUG_HASH=43" -D"DEBUG_HASH2=18" -c -o /usr/src/lirc/drivers/lirc_dev/.tmp_lirc_dev.o /usr/src/lirc/drivers/lirc_dev/lirc_dev.c
/bin/sh: scripts/genksyms/genksyms: No existe el fichero o el directorio
make[5]: *** [/usr/src/lirc/drivers/lirc_dev/lirc_dev.o] Error 1
make[4]: *** [_module_/usr/src/lirc/drivers/lirc_dev] Error 2
make[4]: se sale del directorio `/usr/src/linux-2.6.29.1-4mnb'
make[3]: *** [lirc_dev.o] Error 2
make[3]: se sale del directorio `/usr/src/lirc/drivers/lirc_dev'
make[2]: *** [all-recursive] Error 1
make[2]: se sale del directorio `/usr/src/lirc/drivers'
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio `/usr/src/lirc'
make: *** [all] Error 2


Vielleicht weiss ja jemand hilfe.

Gruss
Merlin