Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

81

Mittwoch, 20. August 2008, 23:29

Hallo,

ich habe inzwischen auch dieses Gehäuse und möchte es wie SoS und Data mit easyvdr 0.6. betreiben.
Leider gelingt auch mir nicht, lircd zum Laufen zu bringen. Ich habe mich an die Anleitung von TheChief ghehalten:

Zitat


So anbei erstmal der Patch für lirc-0.8.3pre1. Einfach entpacken, ins lirc Verzeichnis kopieren und dann patch -p1 <lirc-imon_0038-v2.patch.

./setup.sh

imon auswählen

make && make install

modprobe lirc_dev && modprobe lirc_imon (oder umgekehrt)

Dann mal mit irrecord /dev/lirc0 probieren, ob Du die Fernbedienung anlernen kannst


Danach gibt es /dev/lirc, /dev/lircd und /dev/lircm, jedoch keine lirc0 oder lirc1. Was muss ich den tun, damit diese erzeugt werden?

Für Hilfe wäre ich sehr dankbar!

Liebe Grüße

MikeLehmann

data

Fortgeschrittener

Beiträge: 360

Wohnort: Stadt Dorfen / Bayern

  • Nachricht senden

82

Donnerstag, 21. August 2008, 08:26

Hallo MikeLehmann,

ich habe es bisher auch nicht zum laufen bekommen.
SoS hat mir gestern noch ein paar Tipps gegeben, die aber auch nicht zum gewünschten Ergebnis führten. SoS hat leider weinig Zeit - aber ich hoffe, dass er noch ein paar Minuten für unser Problem opfern kann.
Wäre super wenn LIRC - vor allen wg. der Tasten am Gehäuse - mal irgendwann liefe.

Wenn Du zwischenzeitlich mit Deinen Versuchen Erfolg haben solltest, lass es mich bitte wissen.
Viel Glück.

Gruß
data
VDR: easyVDR 0.8.0 - VDR 1.7.0
CPU: Athlon 4850e; MB: Gigabyte GA-MA78GM-S2H; RAM: 2 GB DDR2; HDD: 2TB SATA; DVD-Brenner; DVB-C: Hauppauge WinTV DVB-C 4MB Mod; STB AVBoard 1.3; Case: Thermaltake DH 202

83

Donnerstag, 21. August 2008, 10:08

Hi,

ich habe das DH 101. Was ja bautechnisch bis auf die Front gleich ist.

Hattet ihr auch probleme das Mainboard einzubauen bzw. Problem beim Einstecken der PCI-Karten? ICh habe die reinbekommen, indem ich zuerst die PCI karten gesteckt hatte und danach das Board befestig, wobei ich auf zwei Schrauben verzichten musste. Läuft aber jetzt schon seit 3 Wochen 24/7 mit aktiviertem Frontlüfter. Sehr leise und cool.
<font color="#0000ff">Gigabyte P35-DS3, Pentium E2140, GT220, 2 x DVB-C im Thermaltake DH101<br>gen2vdr V3 &amp; yaVDR 0.3.0a <br></font>

84

Donnerstag, 21. August 2008, 10:42

Hallo MChrisZ,

ich habe ein MicroATX-Board, das lies sich ohne Probleme einbauen. Auch mit dem Einstecken der PCI-Karten hatte ich keine Probleme.

@Data:
kannst Du die Tipps mal reinschreiben, vielleicht hilft es ja...
hast Du inzwischen /dev/lirc0 und /dev/lirc1?

MfG

MikeLehmann

85

Donnerstag, 21. August 2008, 12:21

Versuch doch mal

lircd --driver=default --device=/dev/lirc1 --output=/dev/lircd --pidfile=/var/run/lirc1.pid --listen /etc/lirc1.conf
lircd --driver=default --device=/dev/lirc0 --pidfile=/var/run/lirc0.pid --connect=localhost:8765 /etc/lirc0.conf

und schau dann ob die devices da sind. Falls nicht, schau ich später oder heute abend mal auf meinem VDR nach.
- VDR: Thermaltake DH 102 mit 7" TouchTFT * Debian Jessie/vdr-2.1.8/graphtft/MainMenuHooks-Patch * Intel Pentium G3220 * DH87RL * Zotac GT630 * 1 TB System HDD * 4 GB Corsair Vegance * Harmony 900 (39-44W) * satip-Plugin
- Server: Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
- SAT>IP: Inverto iLNB
- vdr-theme-darkred: https://github.com/TheChief79/vdr-theme-darkred

data

Fortgeschrittener

Beiträge: 360

Wohnort: Stadt Dorfen / Bayern

  • Nachricht senden

86

Donnerstag, 21. August 2008, 12:49

Hi,

ich habe es mit versch. LIRC Versionen ausprobiert und zu guter letzt mal versucht diesen Thread möglichst genau abzuarbeiten. Das war auch die Empfehlung von SoS.
Mein lirc KnowHow ist - gelinde gesagt - nicht besonders ausgeprägt. Ein DAU Fehler daher durchaus wahrscheinlich. Also bitte nicht hauen.

Mein genaues Vorgehen - und das Problen - Step by Step für EasyVDR:

VDR anhalten
stopvdr
/etc/lircd.conf entfernt


LIRC0.8.3pre1 gezogen
nach /usr/src/lirc-0.8.3pre1 entpackt

Patch lirc-imon_0038-v2.gz eingespielt
patch -p1 <lirc-imon_0038-v2

Symbolic Link unter /usr/src angelegt
ln -s lirc-0.8.3pre1/ lirc

autogen.sh von easyVDR Version kopiert (dieser Schritt weicht von der Threadbeschreibung ab - liegt hier vielleicht das Problem?)
cd /usr/src/lirc
./autogen.sh
./setup.sh (Treiber USB-> Soundgraph iMON MultiMedia IR/VFD ausgewählt)
make && make install
modprobe lirc_dev && modprobe lirc_imon
irrecord /etc/lircd.conf

Quellcode

1
2
3
4
5
6
7
irrecord -  application for recording IR-codes for usage with lirc

Copyright (C) 1998,1999 Christoph Bartelmus(lirc@bartelmus.de)

irrecord: could not open /dev/lirc
irrecord: default_init(): No such device
irrecord: could not init hardware (lircd running ? --> close it, check permissions)


Es läuft kein lircd Prozess
Permissons sehen so aus. Eigentlich auch OK

Quellcode

1
crw-r--r--  1 root root    61,   0 2008-08-20 20:37 lirc

Test:
dmesg

Quellcode

1
2
3
4
5
[   33.711000] lirc_dev: IR Remote Control driver registered, major 61
[   33.723000] lirc_imon: no version for "lirc_unregister_plugin" found: kernel tainted.
[   33.724000] /usr/src/lirc/drivers/lirc_imon/lirc_imon.c: Driver for Soundgraph iMON MultiMedia IR/VFD, v0.3
[   33.724000] /usr/src/lirc/drivers/lirc_imon/lirc_imon.c: Venky Raju <dev@venky.ws>
[   33.724000] usbcore: registered new interface driver lirc_imon


lircd -v

Quellcode

1
lircd 0.8.3pre1


Hier habe ich nun aufgehört.
Die zwei lircd Instanzen habe ich noch nicht gestartet. Ich habe das so verstanden, dass die erst nach dem lirc anlernen, also der lircd.conf Erstellung - gestartet werden müssen.

Könnt ihr damit was anfangen?

Gruß
data
VDR: easyVDR 0.8.0 - VDR 1.7.0
CPU: Athlon 4850e; MB: Gigabyte GA-MA78GM-S2H; RAM: 2 GB DDR2; HDD: 2TB SATA; DVD-Brenner; DVB-C: Hauppauge WinTV DVB-C 4MB Mod; STB AVBoard 1.3; Case: Thermaltake DH 202

87

Donnerstag, 21. August 2008, 13:12

Was sagt denn lsusb bzw. lsusb -v?
- VDR: Thermaltake DH 102 mit 7" TouchTFT * Debian Jessie/vdr-2.1.8/graphtft/MainMenuHooks-Patch * Intel Pentium G3220 * DH87RL * Zotac GT630 * 1 TB System HDD * 4 GB Corsair Vegance * Harmony 900 (39-44W) * satip-Plugin
- Server: Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
- SAT>IP: Inverto iLNB
- vdr-theme-darkred: https://github.com/TheChief79/vdr-theme-darkred

data

Fortgeschrittener

Beiträge: 360

Wohnort: Stadt Dorfen / Bayern

  • Nachricht senden

88

Donnerstag, 21. August 2008, 13:20

Hi TheChief,

ich komme momentan nicht an meinen VDR. Daher kann ich leider erst heute Abend die gewünschten Infos liefern.
VDR: easyVDR 0.8.0 - VDR 1.7.0
CPU: Athlon 4850e; MB: Gigabyte GA-MA78GM-S2H; RAM: 2 GB DDR2; HDD: 2TB SATA; DVD-Brenner; DVB-C: Hauppauge WinTV DVB-C 4MB Mod; STB AVBoard 1.3; Case: Thermaltake DH 202

data

Fortgeschrittener

Beiträge: 360

Wohnort: Stadt Dorfen / Bayern

  • Nachricht senden

89

Donnerstag, 21. August 2008, 17:49

Hi TheChief,

reicht das oder benötigst Du alle lsusb -v Angaben?

lsusb

Quellcode

1
Bus 004 Device 003: ID 15c2:0034 SoundGraph Inc.


lsusb -v

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
Bus 004 Device 003: ID 15c2:0034 SoundGraph Inc.
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0
  bDeviceProtocol         0
  bMaxPacketSize0         8
  idVendor           0x15c2 SoundGraph Inc.
  idProduct          0x0034
  bcdDevice            0.14
  iManufacturer           0
  iProduct                0
  iSerial                 0
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           59
    bNumInterfaces          2
    bConfigurationValue     1
    iConfiguration          0
    bmAttributes         0x80
      (Bus Powered)
    MaxPower              100mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         3 Human Interface Devices
      bInterfaceSubClass      0 No Subclass
      bInterfaceProtocol      2 Mouse
      iInterface              0
        HID Device Descriptor:
          bLength                 9
          bDescriptorType        33
          bcdHID               1.01
          bCountryCode            0 Not supported
          bNumDescriptors         1
          bDescriptorType        34 Report
          wDescriptorLength     121
         Report Descriptors:
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0008  1x 8 bytes
        bInterval              10
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        1
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         3 Human Interface Devices
      bInterfaceSubClass      0 No Subclass
      bInterfaceProtocol      0 None
      iInterface              0
        HID Device Descriptor:
          bLength                 9
          bDescriptorType        33
          bcdHID               1.00
          bCountryCode            0 Not supported
          bNumDescriptors         1
          bDescriptorType        34 Report
          wDescriptorLength      50
         Report Descriptors:
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x82  EP 2 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0008  1x 8 bytes
        bInterval              10
Device Status:     0x0000
  (Bus Powered)


Gruß
data
VDR: easyVDR 0.8.0 - VDR 1.7.0
CPU: Athlon 4850e; MB: Gigabyte GA-MA78GM-S2H; RAM: 2 GB DDR2; HDD: 2TB SATA; DVD-Brenner; DVB-C: Hauppauge WinTV DVB-C 4MB Mod; STB AVBoard 1.3; Case: Thermaltake DH 202

90

Freitag, 22. August 2008, 13:47

Sieht eigentlich gut aus.

Was Du noch probieren kannst, ist:

mknod /dev/lirc0 c 61 0
mknod /dev/lirc1 c 61 1

Danach mal mit irrecord probieren, ob was ankommt.

irrecord -d /dev/lirc0 /etc/lircd0.conf
irrecord -d /dev/lirc1 /etc/lircd1.conf

Gruß
TheChief
- VDR: Thermaltake DH 102 mit 7" TouchTFT * Debian Jessie/vdr-2.1.8/graphtft/MainMenuHooks-Patch * Intel Pentium G3220 * DH87RL * Zotac GT630 * 1 TB System HDD * 4 GB Corsair Vegance * Harmony 900 (39-44W) * satip-Plugin
- Server: Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
- SAT>IP: Inverto iLNB
- vdr-theme-darkred: https://github.com/TheChief79/vdr-theme-darkred

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »TheChief« (22. August 2008, 13:49)


data

Fortgeschrittener

Beiträge: 360

Wohnort: Stadt Dorfen / Bayern

  • Nachricht senden

91

Freitag, 22. August 2008, 16:39

Hi,

leider das gleiche Ergebnis wie vorher ;(

Quellcode

1
2
crw-r--r--  1 root root    61,   0 2008-08-22 16:31 lirc0
crw-r--r--  1 root root    61,   1 2008-08-22 16:31 lirc1

Quellcode

1
2
3
irrecord: could not open /dev/lirc0
irrecord: default_init(): No such device
irrecord: could not init hardware (lircd running ? --> close it, check permissions)

Quellcode

1
2
3
irrecord: could not open /dev/lirc1
irrecord: default_init(): No such device
irrecord: could not init hardware (lircd running ? --> close it, check permissions)


Gruß
data
VDR: easyVDR 0.8.0 - VDR 1.7.0
CPU: Athlon 4850e; MB: Gigabyte GA-MA78GM-S2H; RAM: 2 GB DDR2; HDD: 2TB SATA; DVD-Brenner; DVB-C: Hauppauge WinTV DVB-C 4MB Mod; STB AVBoard 1.3; Case: Thermaltake DH 202

92

Freitag, 22. August 2008, 20:20

Hm komisch

mode2 -d /dev/lirc0
mode2 -d /dev/lirc1

vielleicht?
- VDR: Thermaltake DH 102 mit 7" TouchTFT * Debian Jessie/vdr-2.1.8/graphtft/MainMenuHooks-Patch * Intel Pentium G3220 * DH87RL * Zotac GT630 * 1 TB System HDD * 4 GB Corsair Vegance * Harmony 900 (39-44W) * satip-Plugin
- Server: Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
- SAT>IP: Inverto iLNB
- vdr-theme-darkred: https://github.com/TheChief79/vdr-theme-darkred

93

Freitag, 22. August 2008, 21:13

Hallo,

ich probiere es parallel zu Data ebenfalls mit easyvdr. Die Resultate sind bei mir immer die gleichen wie bei Data.

ein

mode2 -d /dev/lirc0

ergibt:

mode2: error opening /dev/lirc0
mode2: No such device

Ebenso für /dev/lirc1.

So sieht es in /dev im Moment aus:
easyVDR:~# ls -alg /dev/lirc*
lrwxrwxrwx 1 root 10 2008-08-22 23:07 /dev/lirc -> /dev/lirc0
crw-r--r-- 1 root 61, 0 2008-08-22 21:08 /dev/lirc0
crw-r--r-- 1 root 61, 1 2008-08-22 21:08 /dev/lirc1
srw-rw-rw- 1 root 0 2008-08-22 21:07 /dev/lircd


Mit freundlichen Grüßem

MikeLehmann

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »mikelehmann« (22. August 2008, 21:18)


data

Fortgeschrittener

Beiträge: 360

Wohnort: Stadt Dorfen / Bayern

  • Nachricht senden

94

Freitag, 22. August 2008, 22:27

Hi,

Danke für den parallelen Test.
ich habe - natürlich - das gleiche negative Ergebnis wie mikelehmann.

Gruß
data
VDR: easyVDR 0.8.0 - VDR 1.7.0
CPU: Athlon 4850e; MB: Gigabyte GA-MA78GM-S2H; RAM: 2 GB DDR2; HDD: 2TB SATA; DVD-Brenner; DVB-C: Hauppauge WinTV DVB-C 4MB Mod; STB AVBoard 1.3; Case: Thermaltake DH 202

data

Fortgeschrittener

Beiträge: 360

Wohnort: Stadt Dorfen / Bayern

  • Nachricht senden

95

Sonntag, 24. August 2008, 12:45

Hallo zusammen,

es gibt ein neues GraphTFT Theme für 800x600 Auflösung.

[ANNOUNCE] graphtTFT Theme - "Alien vs. Predator"

Gruß
data
VDR: easyVDR 0.8.0 - VDR 1.7.0
CPU: Athlon 4850e; MB: Gigabyte GA-MA78GM-S2H; RAM: 2 GB DDR2; HDD: 2TB SATA; DVD-Brenner; DVB-C: Hauppauge WinTV DVB-C 4MB Mod; STB AVBoard 1.3; Case: Thermaltake DH 202

SoS

Schüler

Beiträge: 79

Wohnort: Weyhe bei Bremen

  • Nachricht senden

96

Montag, 25. August 2008, 10:12

ACHTUNG,

was mir noch gerade einfällt. Ich bin der Meinung,
das nach Kompilieren und installieren des gepatchten
lirc-0.8.3, 2 mal lircd vorliegt.
Einmal unter /usr/bin und einmal unter /usr/local/bin.

Ihr müsst schauen, welches die neuere ist und die benutzen
oder rueberkopieren. Sonst nutzt Ihr trotz Installation immer
noch die alte lirc, welche nicht gepatcht ist.

... ich glaube, das war so ;o)

LG,
Sven.

Meine Vdr's

VDR1: Thermaltake DH 102 mit TouchTFT | AMD Athlon X2 BE-2350 | 2TB HDD + 80GB 2,5" für OS | 3GB RAM | 2x TT S2-1600 | yaVDR 0.3
VDR2: Zotac HD-ID11 | Atom 510 | Nvidia ION | 64GB SSD | 2 GB RAM | DVB-S TT S2-3600 | yavdr 0.3



97

Montag, 25. August 2008, 14:29

Ja, sowas könnte auch noch sein.
- VDR: Thermaltake DH 102 mit 7" TouchTFT * Debian Jessie/vdr-2.1.8/graphtft/MainMenuHooks-Patch * Intel Pentium G3220 * DH87RL * Zotac GT630 * 1 TB System HDD * 4 GB Corsair Vegance * Harmony 900 (39-44W) * satip-Plugin
- Server: Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
- SAT>IP: Inverto iLNB
- vdr-theme-darkred: https://github.com/TheChief79/vdr-theme-darkred

data

Fortgeschrittener

Beiträge: 360

Wohnort: Stadt Dorfen / Bayern

  • Nachricht senden

98

Montag, 25. August 2008, 14:31

Hi,

ich werde das heute Abend gleich prüfen.
Es sei denn, MikeLehmann ist schneller ;-)

Gruß
data
VDR: easyVDR 0.8.0 - VDR 1.7.0
CPU: Athlon 4850e; MB: Gigabyte GA-MA78GM-S2H; RAM: 2 GB DDR2; HDD: 2TB SATA; DVD-Brenner; DVB-C: Hauppauge WinTV DVB-C 4MB Mod; STB AVBoard 1.3; Case: Thermaltake DH 202

99

Montag, 25. August 2008, 14:32

Hallo,

ich werde das morgen noch mal ausprobieren, heute komme ich leider nicht mehr an meinen VDR.
Vielen Dank schon mal für die Hinweise!

Liebe Grüße

MikeLehmann

100

Montag, 25. August 2008, 14:32

Da waren wir zumindest beim Antworten (fast) gleichschnell :-))

Immortal Romance Spielautomat