You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Sunday, November 6th 2011, 6:10pm

Pearl Display gebrickt :(

Moin,

ich habe vorhin meinen Pearl Bilderrahmen gebrickt. Habe zwar wenig Hoffnung den zu recovern, aber vielleicht kriege ich wenigstens raus welcher Schritt oder welche Abweichung ursächlich waren:

Ich bin nach dieser Anleitung vorgegangen:
http://geekparadise.de/2011/04/digitaler…y-fur-dockstar/

Folgende libs sind hier installiert:

libtool *** 2.2.6b-2 0
automake *** 1:1.11.1-1 0
autoconf *** 2.67-2 0
zlib1g-dev *** 1:1.2.3.4.dfsg-3 0
libssl-dev *** 0.9.8o-4squeeze1 0 (habe ich leicht anders nachgebaut - ein zus. Feature wurde dazuconfigured)
libgd2-noxpm-dev keine!
libgd2-xpm-dev 2.0.36~rc1~dfsg-5

sdcc 2.9.0-5
sdcc.libraries 2.9.0-5

Wobei ich hinterher gesehen habe, dass eh gcc zum bauen genutzt wird...

Konkret gemacht wurde dann wie folgt:

Source code

1
2
3
4
5
6
7
wget http://tech.section5.ch/files/dpfhack-0.1alpha.tgz
tar -xvzf dpfhack-0.1alpha.tgz
cd dpf/src
make
cd ..
wget http://tech.section5.ch/files/dpf-lcd4linux.tgz
tar -xvzf dpf-lcd4linux.tgz


Jetzt kommts (evtl?):
Die Datei build-dpf-lcd4linux.sh wurde wie folgt angepasst:
Ändern der --configure Zeile in:

Source code

1
./configure --with-drivers='all' --with-plugins='all'

sowie leider? aus einem vorigen Versuch war noch

Source code

1
svn co -r1159 https://ssl.bulix.org/svn/lcd4linux/trunk lcd4linux

drin, anstatt der r1142 wie ich später gesehen habe :/ Der patch dagegen ging zwar ohne rejects, aber evtl liegt hier der casus knacksus...

Aufruf dann mit

Source code

1
./build-dpf-lcd4linux.sh /usr/src/dpf/dpf/src/dpflib


da mit ../ als eigtl korrektem lib Pfad die dpf.h nicht gefunden wurde.

Schließlich musste ich für hackit.py noch das Datum 27. März in profiles.py ändern

Source code

1
        [ ('20090504', 'Mar 26 2010\xff\xff\xff\xff\xff', 'ProcTbl5' ),


was aber imho nicht das Problem sein sollte...


Jemand soweit einen Vorschlag was besonderer Mist ist/war?


Ich habe den Bildschirm dann abgezogen wie es ja nach dem hackit.py geschrieben steht. Beim Wiederanstecken habe ich beim ersten Mal allerdings den Menü Knopf erst nach dem Anstecken gedrückt, weil das aus der blöden Beschreibung nicht hervorgeht, dass es gleichzeitig sein muss

Noch das Syslog excerpt:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
Rahmen noch intakt:

Nov  6 12:00:51 squeezevdr kernel: [42088.939119] usb 2-5: new full speed USB device number 5 using ohci_hcd
Nov  6 12:00:51 squeezevdr kernel: [42089.190092] usb 2-5: New USB device found, idVendor=1908, idProduct=0102
Nov  6 12:00:51 squeezevdr kernel: [42089.190103] usb 2-5: New USB device strings: Mfr=2, Product=3, SerialNumber=0
Nov  6 12:00:51 squeezevdr kernel: [42089.190110] usb 2-5: Product: Digital Photo Frame
Nov  6 12:00:51 squeezevdr kernel: [42089.190115] usb 2-5: Manufacturer: BUILDWIN
Nov  6 12:00:51 squeezevdr kernel: [42089.202361] scsi5 : usb-storage 2-5:1.0

hackit.py

Nov  6 12:01:23 squeezevdr kernel: [42120.646817] usb 2-5: reset full speed USB device number 5 using ohci_hcd
Nov  6 12:35:30 squeezevdr kernel: [44167.680319] usb 2-5: USB disconnect, device number 5
Nov  6 12:35:47 squeezevdr kernel: [44185.438152] usb 2-5: new full speed USB device number 6 using ohci_hcd
Nov  6 12:35:48 squeezevdr kernel: [44185.618106] usb 2-5: device descriptor read/64, error -62
Nov  6 12:35:48 squeezevdr kernel: [44185.897934] usb 2-5: device descriptor read/64, error -62
Nov  6 12:35:48 squeezevdr kernel: [44186.177955] usb 2-5: new full speed USB device number 7 using ohci_hcd
Nov  6 12:35:48 squeezevdr kernel: [44186.350018] usb 2-5: device descriptor read/64, error -62
Nov  6 12:35:49 squeezevdr kernel: [44186.638031] usb 2-5: device descriptor read/64, error -62
Nov  6 12:35:49 squeezevdr kernel: [44186.917908] usb 2-5: new full speed USB device number 8 using ohci_hcd
Nov  6 12:35:49 squeezevdr kernel: [44187.325905] usb 2-5: device not accepting address 8, error -62
Nov  6 12:35:49 squeezevdr kernel: [44187.505898] usb 2-5: new full speed USB device number 9 using ohci_hcd
Nov  6 12:35:50 squeezevdr kernel: [44187.918382] usb 2-5: device not accepting address 9, error -62
Nov  6 12:35:50 squeezevdr kernel: [44187.918421] hub 2-0:1.0: unable to enumerate USB device on port 5

Nochmal angesteckt:

Nov  6 12:40:31 squeezevdr kernel: [44469.147331] usb 2-5: new full speed USB device number 10 using ohci_hcd
Nov  6 12:40:46 squeezevdr kernel: [44484.327138] usb 2-5: device descriptor read/64, error -110
Nov  6 12:41:02 squeezevdr kernel: [44499.626974] usb 2-5: device descriptor read/64, error -110
Nov  6 12:41:02 squeezevdr kernel: [44499.907060] usb 2-5: new full speed USB device number 11 using ohci_hcd
Nov  6 12:41:17 squeezevdr kernel: [44515.070797] usb 2-5: device descriptor read/64, error -110
Nov  6 12:41:32 squeezevdr kernel: [44530.342692] usb 2-5: device descriptor read/64, error -110
Nov  6 12:41:33 squeezevdr kernel: [44530.610711] usb 2-5: new full speed USB device number 12 using ohci_hcd
Nov  6 12:41:43 squeezevdr kernel: [44541.018554] usb 2-5: device not accepting address 12, error -110
Nov  6 12:41:43 squeezevdr kernel: [44541.186799] usb 2-8: reset full speed USB device number 4 using ohci_hcd
Nov  6 12:41:44 squeezevdr kernel: [44541.546601] usb 2-5: new full speed USB device number 13 using ohci_hcd
Nov  6 12:41:54 squeezevdr kernel: [44551.962248] usb 2-5: device not accepting address 13, error -110
Nov  6 12:41:54 squeezevdr kernel: [44551.962290] hub 2-0:1.0: unable to enumerate USB device on port 5


Steht also nur noch Mist im Chip ?

Der Rahmen lässt sich mit M nicht mehr einschalten, wenn kein USB-Kabel dran ist (auch als der Akku noch dran war). Wenn doch kommt die normale Diashow. Bei Verbinden zum PC bekomme ich einen weißen Bildschirm auf dem LCD (hängt wahrscheinlich) und Fehlermeldungen wie oben im syslog. Bei Start im Factory Mode ebenso. Reset bringt nichts.

Selten wird der Rahmen mal (im 'falschen' Modus) als USB-Hid device erkannt. Vielleicht kann man den zum recovern
nutzen?

Source code

1
Nov  6 13:17:33 squeezevdr kernel: [46691.042234] generic-usb 0003:1908:3318.0002: hiddev0,hidraw1: USB HID v2.01 Device [BUILDWIN BL206v1.0.0] on usb-0000:00:02.0-7/input0



Für Freunde des gehobenen Lötens habe ich mal Bilder angehängt, wobei die Panelseite eher uninteressant sein dürfte.

Hilfe ;(


tx und mfg

Midas
Midas has attached the following images:
  • Panelseite.jpg
  • Rückseite.jpg
plugin-block: Download, Thread im Portal, Wiki
plugin-sleeptimer: Download, Thread im Portal, Wiki
VDR-Chat: Web-Chat, IRC
ASUS M2N-E, Athlon X2 4450B, 2GB DDR2, Technisat Skystar HD (TT-3200), Technisat Skystar HD2, Hauppauge WinTV Nova-T USB, GigaByte GT-630 - 4TB RAID5 + 6GB externes Journal @50 GB Crucial Adrenaline SSD DP-CT050M4SSC2 - BeQuiet SystemPower7 300W - wheezy/vdr2.0.1 - xbmc 13

2

Tuesday, November 8th 2011, 2:16pm

Hallo,

der Patch den du verwendet hast ist nicht mehr aktuell und das ganze lcd4linux-Gedöns brauchst du nicht wenn du das Display am VDR betreiben willst.
Wie es besser geht steht hier.

Aber unabhängig davon sollte das Display auch mit der von dir verwendeten Version patchbar sein.
Ist hackit.py ohne Fehlermeldung durchgelaufen?
Welches USB-Kabel hat du verwendet? Das mitgelieferte ist Schrott! Mal ein anderes Kabel probiert? Anderen USB Port probiert? Mal den Reset-Knopf vom Display gedrückt?
Was tut das Display wenn du es mit USB verbindest - ohne Menü zu drücken? Dann sollte die Diashow ablaufen und im Syslog nix erscheinen.

Gruß
superelchi
#1: yaVDR 0.5 - Asus A5IONT-I, 4 GB Ram - 750 GB 2,5" HD - DD Cine S2 V6 - Silverstone Sugo SG06 - Pearl DPF - Hama MCE Remote
#2: yaVDR 0.5 - Intel DH67BL, 4 GB Ram - Asus GT610 - 40 GB SSD - 500 GB 2,5" HD - DD Cine S2 V5.5 - Silverstone Milo ML03 - Pearl DPF - Hama MCE Remote

carlos01

Intermediate

Posts: 194

Location: BW

  • Send private message

3

Tuesday, November 8th 2011, 4:11pm

Du kannst ganz einfach zum vorherigen Zustand zurück indem du folgendes machst:

Source code

1
To put the device back into (almost) original state workingas USB storage, press the RESET button.


So stehts auch auf http://geekparadise.de/2011/04/digitaler…y-fur-dockstar/

Danach einfach nochmal hacken. Das geht beliebeig oft.
Allerdings geht kein weiterer hack, wenn du schon einmal gehackt hast.

Gruß

Carlos
VDR1: AMD Athlon 64 3200+ - Hauppauge Nexus-S, Debian Lenny - Kernel 2.6.28.2 VDR 1.7.21(Tobi)
VDR2: POV ION 330 -2GB RAM - Tevii S470 MS-Tech 1200 Gehäuse, Debian YaVDR 0.4
VDR4: Seagate Goflex net - Debian Wheezy - Linux 3.9.5-dockstar-goflex-shyd VDR 2.0.3
VDR5: SMT-7020S zen2vdr auf Festplatte
VDR5: SMT-7020S zen2mms 1.3b auf CF-Karte
TV: Samsung LE46ES8090

4

Tuesday, November 8th 2011, 4:36pm

Quoted

Ist hackit.py ohne Fehlermeldung durchgelaufen?


Jap.

Quoted

Welches USB-Kabel hat du verwendet? Das mitgelieferte ist Schrott! Mal ein anderes Kabel probiert? Anderen USB Port probiert? Mal den Reset-Knopf vom Display gedrückt?


Verschiedene. Zum flashen weiß ich nicht mehr, wahrscheinlich ein anderes als das originale. USB-Ports durchprobiert. Reset bringt nichts.

Quoted

Was tut das Display wenn du es mit USB verbindest - ohne Menü zu drücken? Dann sollte die Diashow ablaufen und im Syslog nix erscheinen.


Sofort geht die Hintergrundbeleuchtung an. Im Gegensatz zu Post #1 geht dann mittlerweile gar nichts mehr. Das Display verbleibt in diesem Zustand, egal was gemacht wird. Ich fürchte, da hilft wenn überhaupt nur noch irgendwas auf der Platine selbst zu prutschen. Deep Reset oder so.

@Carlos01

Nö. das half schon direkt nach dem Flash so überhaupt nicht mehr.

mfg

Midas
plugin-block: Download, Thread im Portal, Wiki
plugin-sleeptimer: Download, Thread im Portal, Wiki
VDR-Chat: Web-Chat, IRC
ASUS M2N-E, Athlon X2 4450B, 2GB DDR2, Technisat Skystar HD (TT-3200), Technisat Skystar HD2, Hauppauge WinTV Nova-T USB, GigaByte GT-630 - 4TB RAID5 + 6GB externes Journal @50 GB Crucial Adrenaline SSD DP-CT050M4SSC2 - BeQuiet SystemPower7 300W - wheezy/vdr2.0.1 - xbmc 13

ako400

Intermediate

Posts: 223

Location: Frankfurt

  • Send private message

5

Tuesday, November 8th 2011, 5:16pm

Nö. das half schon direkt nach dem Flash so überhaupt nicht mehr.

Sicher? Ich dachte auch schon das ich meines gebrickt hätte, aber der Reset hatte dann bei mir doch funktioniert.
ASUS M3n78-EM, Sempron 140, 2 GB RAM, WD20EARX, DD DuoFlex CT , Atric IR Rev. 4, Pearl Display, Picopsu-150-XT mit Dell DA-1, yaVDR 0.50a am Samsung UE32D5000

6

Tuesday, November 8th 2011, 5:20pm

Das Display macht nichts mehr außer sofort weiß leuchten, wenn es an USB kommt. Da kann man Tasten drücken bis man lustig wird.

Es eignet sich momentan eher nicht für eine Notbeleuchtung, ich plane momentan aber Flutlicht für einen Flohzirkus...:)

mfg
plugin-block: Download, Thread im Portal, Wiki
plugin-sleeptimer: Download, Thread im Portal, Wiki
VDR-Chat: Web-Chat, IRC
ASUS M2N-E, Athlon X2 4450B, 2GB DDR2, Technisat Skystar HD (TT-3200), Technisat Skystar HD2, Hauppauge WinTV Nova-T USB, GigaByte GT-630 - 4TB RAID5 + 6GB externes Journal @50 GB Crucial Adrenaline SSD DP-CT050M4SSC2 - BeQuiet SystemPower7 300W - wheezy/vdr2.0.1 - xbmc 13

7

Tuesday, November 8th 2011, 5:52pm

Oha. Das sieht wirklich nach einem Brick aus. Gottseidank sind die DInger ja nicht so richtig teuer.
Ich würde es nochmal mit einem neuen Display nach der Anleitung hier im Forum machen. Aber das Gebrickte nicht wegschmeißen - nachdem das SDK für das Display inzwischen public ist besteht Aussicht das Ding irgendwann wieder zu reanimieren...

Edit: Wenn du mutig bist, kannst du ja damit mal spielen: AX206 Hardware Bootloader.


Gruß
superelchi
#1: yaVDR 0.5 - Asus A5IONT-I, 4 GB Ram - 750 GB 2,5" HD - DD Cine S2 V6 - Silverstone Sugo SG06 - Pearl DPF - Hama MCE Remote
#2: yaVDR 0.5 - Intel DH67BL, 4 GB Ram - Asus GT610 - 40 GB SSD - 500 GB 2,5" HD - DD Cine S2 V5.5 - Silverstone Milo ML03 - Pearl DPF - Hama MCE Remote

This post has been edited 1 times, last edit by "superelchi" (Nov 8th 2011, 5:58pm)


8

Tuesday, November 8th 2011, 10:42pm

@superelchi

super. hab gerade deinen edit gesehen.

Jetzt brauche ich noch zwei Sachen:

1. wie krieg ich den Rahmen in HID-Mode? Hab mal so einige Pins kurzgeschlossen, aber ohne Erfolg. Momentan wird das Gerät nämlich gar nimmer erkannt an USB. Ich weiß aber, dass es geht, weil war schonmal da.

2. Ich brauche ein ROM-Inhalt zum Flashen.

Sobald ich weiß wie man das ROM ausliest poste ich wieder.

mfg


EDIT:

Blindes Huhn findet Punkt auf Platine das gegen Masse das Device zumindest wieder mit der Diashow gestartet hat :rofl

Jetzt trau ich mich nicht irgendwas damit zu machen gerade XD
plugin-block: Download, Thread im Portal, Wiki
plugin-sleeptimer: Download, Thread im Portal, Wiki
VDR-Chat: Web-Chat, IRC
ASUS M2N-E, Athlon X2 4450B, 2GB DDR2, Technisat Skystar HD (TT-3200), Technisat Skystar HD2, Hauppauge WinTV Nova-T USB, GigaByte GT-630 - 4TB RAID5 + 6GB externes Journal @50 GB Crucial Adrenaline SSD DP-CT050M4SSC2 - BeQuiet SystemPower7 300W - wheezy/vdr2.0.1 - xbmc 13

This post has been edited 1 times, last edit by "Midas" (Nov 8th 2011, 10:53pm)


9

Wednesday, November 9th 2011, 9:00am

Trau dich!
Kommt beim Anschließen an USB wieder was im Syslog?
Oder nach 2 Sekunden Menü drücken vielleicht sogar der BSOH ("Blue Screen of Hack")?

Edit: Kannst du mal ein Bild von dem Punkt den du kurzgeschlossen hast posten? Vielleicht hilfts in Zukunft ja jemandem...
Edit2: Hab hier eine Anleitung zum De-bricken geschrieben.

Gruß
superelchi
#1: yaVDR 0.5 - Asus A5IONT-I, 4 GB Ram - 750 GB 2,5" HD - DD Cine S2 V6 - Silverstone Sugo SG06 - Pearl DPF - Hama MCE Remote
#2: yaVDR 0.5 - Intel DH67BL, 4 GB Ram - Asus GT610 - 40 GB SSD - 500 GB 2,5" HD - DD Cine S2 V5.5 - Silverstone Milo ML03 - Pearl DPF - Hama MCE Remote

This post has been edited 1 times, last edit by "superelchi" (Nov 9th 2011, 4:08pm)


10

Thursday, November 10th 2011, 8:46am

@superelchi

Klasse Arbeit das Howto!

Natürlich habe ich bereits vorgestern weitergemacht...

Im Übereifer habe ich mir jedoch noch mehr Steine in den Weg gelegt, genauer gesagt die USB-Buchse sagen wir mal 'entfernt'... Jaja nicht weiter kommentieren 8)

Leider war die SMD gelötet und ich krieg da nix mehr dran. Was mir noch einfällt wär den Strom an den Akku Anschluss zu löten, nur habe ich noch nicht rausgefunden wo ich insofern Data+ und - alternativ anlöten kann. Falls da jemandem was einfällt probiere ich gerne superelchis debricking aus ;)

Jaja, wenn bricken dann richtig!

mfg
plugin-block: Download, Thread im Portal, Wiki
plugin-sleeptimer: Download, Thread im Portal, Wiki
VDR-Chat: Web-Chat, IRC
ASUS M2N-E, Athlon X2 4450B, 2GB DDR2, Technisat Skystar HD (TT-3200), Technisat Skystar HD2, Hauppauge WinTV Nova-T USB, GigaByte GT-630 - 4TB RAID5 + 6GB externes Journal @50 GB Crucial Adrenaline SSD DP-CT050M4SSC2 - BeQuiet SystemPower7 300W - wheezy/vdr2.0.1 - xbmc 13

11

Thursday, November 10th 2011, 9:04am

Das ist kein Bricken - das ist Vandalismus. :D
Ich würde dir raten ein neues Display zu kaufen. Bei dem Preis lohnt es sich meiner Meinung nach nicht da noch mehr Arbeit reinzustecken. Eine neue USB-Buchse kostet ja fast soviel wie das ganze Display (USB SMB-Buche ca. 0.40 € + Versand + Arbeit + Risiko obs geht, ganzes Display 2,90 € + Versand). :]

Gruß
superelchi
#1: yaVDR 0.5 - Asus A5IONT-I, 4 GB Ram - 750 GB 2,5" HD - DD Cine S2 V6 - Silverstone Sugo SG06 - Pearl DPF - Hama MCE Remote
#2: yaVDR 0.5 - Intel DH67BL, 4 GB Ram - Asus GT610 - 40 GB SSD - 500 GB 2,5" HD - DD Cine S2 V5.5 - Silverstone Milo ML03 - Pearl DPF - Hama MCE Remote

12

Thursday, November 10th 2011, 9:07am

Jo, wird bald geordert.

...aber...ist leider noch nicht da :D
plugin-block: Download, Thread im Portal, Wiki
plugin-sleeptimer: Download, Thread im Portal, Wiki
VDR-Chat: Web-Chat, IRC
ASUS M2N-E, Athlon X2 4450B, 2GB DDR2, Technisat Skystar HD (TT-3200), Technisat Skystar HD2, Hauppauge WinTV Nova-T USB, GigaByte GT-630 - 4TB RAID5 + 6GB externes Journal @50 GB Crucial Adrenaline SSD DP-CT050M4SSC2 - BeQuiet SystemPower7 300W - wheezy/vdr2.0.1 - xbmc 13

13

Thursday, November 10th 2011, 9:11am

Vorfreude ist die schönste Freude. :D

Gruß
superelchi
#1: yaVDR 0.5 - Asus A5IONT-I, 4 GB Ram - 750 GB 2,5" HD - DD Cine S2 V6 - Silverstone Sugo SG06 - Pearl DPF - Hama MCE Remote
#2: yaVDR 0.5 - Intel DH67BL, 4 GB Ram - Asus GT610 - 40 GB SSD - 500 GB 2,5" HD - DD Cine S2 V5.5 - Silverstone Milo ML03 - Pearl DPF - Hama MCE Remote

urknall

Intermediate

Posts: 475

Location: /dev/null

Occupation: IT

  • Send private message

14

Thursday, November 10th 2011, 9:40am

Gibt es da eigentlich Unterschiede zwischen der "Billig-Variante" und dem Normalpreis Display bei Pearl?

Grüße
VDR 1: yaVDR 0.X+1 | Intel DH67BLB3 | Intel Celeron G530 | L4M Dual DVB-S2 V5.5 | Asus GeForce GT 610 LP Passiv | YAUSBIRV3 |
VDR 2: yaVDR 0.X+1 | Zotac IONITX-F-E | DD DuoFlex S2 + DuoFlex CT - PCIe Bridge LE | WD Scorpio Blue WD10TPVT | LiteOn Blu-ray IHOS104 | DD USB Display 128x64 | selbst gebauter IR Empfänger mit IOWarrior24 incl. Bedientasten u. Drehencoder in Braun Atelier Gehäuse | Harmony 655 | Atmolight Quattro | Toshiba 32WL66Z |

gda

Im Forum Zuhause

Posts: 12,767

Location: HH

  • Send private message

15

Thursday, November 10th 2011, 10:41am

Gibt es da eigentlich Unterschiede zwischen der "Billig-Variante" und dem Normalpreis Display bei Pearl?

Ist schon öfter gesagt worden. Es ist das selbe Display, aber du kannst von der Billig-Variante nur eines bestellen und von der Teuren so viel du magst.

Gerald

OrigenAE S16T, ASRock K10N78D, Athlon II X2 4400e (unlocked Sempron 140), 2GB RAM, OCZ Vertex 30GB, 2xWD10EADS, 3xKNC One TV-Station DVB-C, G210 MSI N210-MD512H, yaVDR.
Seagate Dockstar, Debian Squeeze, VDR 1.7.16, 500 GB 2,5" HD, 2xSundtek MediaTV Home DVB-C/T.

16

Friday, November 11th 2011, 8:23am

Man kann übrigens von hier http://www.gutscheinsammler.de/gutscheine/pearl nochwas kostenloses in den Warenkorb legen. Dann tut das Porto nicht ganz so weh, wenn man nur das DPF bestellen will.
VDR 2.1.5 (Server/Client) auf Asus M5A78L-M/USB3, Sempron 145@2Cores, 4GB ECC RAM, 2x Cinergy T Dual PCIe, PicoPSU, IRMPasp/irmplircd, Debian Wheezy 64Bit, Linux Kernel 3.9.
VDR 2.0.5 auf RaspberryPI

Similar threads